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-Select File -> New Project 
-Type countupd in the project name field. 
-Enter to location and a countupd subdirectory is created automatically. 
-Verify that HDL is selected from top-level source type list. 
-Click Next to move to the device properties page. 
- Fill in the properties in the table as shown below: 

• Product Category: All 
• Family: Spartan3 
• Device: XC3S200 
• Package: FT256 
• Speed Grade: -4 
• Top-Level Source Type: HDL 
• Synthesis Tool: XST (VHDLNerilog) 
• Simulator: ISE Simulator (VHDL/Verilog) 
• Preferred Language: Verilog (or VHDL) 
• Verify that Enable Enhanced Design Summary is selected. 

-Click Next to proceed to the Create New Source window in the New Project Wizard. At 
the end of the next section, your new project will be complete. 

1) Create a Countupd Project: 

2) Create the HDL Source of the Countupd: 

-Click the new source button in the new project wizard. 
-Select VHDL module as the source type. 
-Type in the file name countupd. 
-Verify that the add to project checkbox is selected. 
-Declare the ports for the countupd design by filling in the port information as shown 
below: 

Port Direction Bus MSB LSB 
Name 
clock in 
reset m 
clocken m 
load en m 
direction m 
inp m 3 0 
count out 3 0 

3) HDL Language Template: 

-Edit-> Language Templates 
-VHDL -> Synthesis Constructs-> Coding Examples-> Binary-> 

Up/Down Counters -> /w Load, CE and Async Active High Reset 



process (<clock>, <reset>) 
begin 

if <reset>=' l' then 
<count> <= ( others => 'O'); 

elsif <clock>=' l' and <clock>'event then 
if <clock enable>=' l' then 

if <load enable>=' l' then 
<count> <= <input>; 

else 
if <count direction>='!' then 
<count> <= <count> + 1; 

else 
<count> <= <count> - 1; 
end if; 

end if; 
· end if; 

end if; 
end process; 

-With -> /w Load, CE and Async Active High Reset selected, select Edit > Use in File, 
or select the Use Template in File toolbar button. This step copies the template into the 
countupd source file. 

4) Edit the HDL Code: 

library IEEE; 
use IEEE.STD_ LOGIC _1164.ALL; 
use IEEE. STD_ LOGIC_ ARITH.ALL; 
use IEEE.STD_LOGIC_UNSIGNED.ALL; 

---- Uncomment the following library declaration if instantiating 
---- any Xilinx primitives in this code. 
--library UNISIM; 
--use UNISIM.VComponents.all; 

Iii 
Ill 

entity countupd is 
Port ( clock : in STD LOGIC; 

reset : in STD _LOGIC; 
clocken : in STD _LOGIC; 
loaden : in STD_ LOGIC; 
direction: in STD _LOGIC; 
inp : in STD _LOGIC_ VECTOR (3 downto O); 
count : out STD_ LOGIC_ VECTOR (3 downto O)); 

end countupd; 

architecture Behavioral of countupd is 
signal input_int : std _logic_ vector(3 downto 0) := "0000"; 
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signal count_int : std _logic_ vector(3 downto 0) := "0000"; 
begin 

-- Usage of Asynchronous resets may negatively impact FPGA resources 
-- and timing. In general faster and smaller FPGA designs will 
-- result from not using Asynchronous Resets. Please refer to 
-- the Synthesis and Simulation Design Guide for more information. 
process (clock, reset) 
begin 
i freset=' l' then 

count_int <= ( others => 'O'); 
elsif clock=' l' and clock'event then 
ifclocken='l' then 
if loaden=' l' then 
count_int <= input_int; 

else 
if direction=' l' then 
count_int <= count int+ 1; 

else 
count_int <= count_int - 1; 

end if; 
end if; 

end if; 
end if; 

end process; 
count <= count int; 

end Behavioral; 

5) Syntax Check: 

-Verify that Synthesis/Implementation is selected from the drop-drown list in the sources 
window. 
-Click the '+' next to the Synthesize-XST process to expand the process group. 
-Double-click the Check Syntax process. 

6) create test banch 

II 
Iii 
I 

Project "7 add new source "7 test banch 
Edit "7 language temples "7 VHDL "7 Clock simulations 
And arrange like below. 
LIBRARY ieee; 
USE ieee.std _logic _1164.ALL; 
USE ieee.std _logic_ unsigned.all; 
USE ieee.numeric_std.ALL; 

ENTITY countupd _ tb _ vhd IS 
END countupd_tb_ vhd; 
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• ARCHITECTURE behavior OF countupd_tb_vhd IS • -- Component Declaration for the Unit Under Test (UUT) 
COMPONENT countupd 
PORT( 

clock : IN std _logic; 
reset : IN std_logic; 
clocken : IN std _logic; 
loaden: IN std_logic; 
direction : IN std , logic; 
inp : IN std _logic_ vector(3 downto O); 
count : OUT std _logic_ vector(3 downto 0) 
); 

END COMPONENT; • 
--Inputs . 
SIGNAL clock: std_logic := 'O'; 
SIGNAL reset: std_logic := 'l'; 
SIGNAL clocken: std Iogic := 'O'; 
SIGNAL loaden: std_logic := 'O'; 
SIGNAL direction: std_logic := 'O'; 
SIGNAL inp: std_Iogic_vector(3 downto 0) := (others=>'O'); 

--Outputs 
SIGNAL count : std _logic_ vector(3 downto O); 

BEGIN 

• 
-- Instantiate the Unit Under Test (UUT) 
uut: countupd PORT MAP( 

clock=> clock, 
reset => reset, 
clocken => clocken, 
loaden => loaden, 
direction => direction, 
inp => inp, 
count => count 

); 

-- Please ensure that the constant PERIOD is defined prior to the 
-- begin statement in the architecture. Refer to the PERIOD Constant Template 
-- for more info. 
process 
begin 
clock<= 'O'; 
wait for 5 ns; 
clock<= '1 '; 
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• 
~ 

wait for 5 ns; 
end process; 

tb: PROCESS 
BEGIN 

-- Wait 100 ns for global reset to finish 
wait for 100 ns; 

-- Place stimulus here 

• inp<="OlOl "; 
reset<='O'; 
clocken<=' I'; 
loaden<=' l '; 
wait for I 00 ns; 
loaden<='O'; 
direction<='!'; 
wait for I 00 ns; 
loaden<='O'; 
direction<='O'; 

wait; -- will wait forever 
END PROCESS; 

END; 
6) Creating a Verilog Source 

Create the top-level Verilog source file for the project as follows: 
- Click New Source in the New Project dialog box. 
- Select Verilog Module as the source type in the New Source dialog box. 
- Type in the file name countupd. 
- Verify that the Add to Project checkbox is selected. 
- Click Next. 
- Declare the ports for the countupd design by filling in the port information as shown 
below: 

• 
Ill 
Ill 
II 

• 

Port Direction Bus MSB LSB 
Name 
clock Ill 

reset Ill 

clocken Ill 

loaden Ill 

direction Ill 

inp Ill 3 0 
count out 3 0 

-Click Next, then Finish in the New Source Information dialog box to complete the new 
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• • 
source file template. 

7) Using Language Templates (Verilog) 

- Place the cursor on the line below the output [3 :O] COUNT_ OUT; statement. 
- Open the Language Templates by selecting Edit D Language Templates ... 
- Using the"+" symbol, browse to the following code example: 

Verilog -> Synthesis Constructs -> Coding Examples -> Binary -> 
Up/Down Counters -> /w Load, CE and Async Active High Reset 

• reg [<upper>:O] <reg_name>; 

• • • • II 

always @(posedge <clock> or posedge <reset>) 
if (<reset>) 
<reg_name> <= O; 

else if (<clock_enable>) 
if (<load_enable>) 
<reg_name> <= <load_signal_or_value>; 

else if (<up_down>) 
<reg_name> <= <reg_name> + 1; 

else 
<reg_name> <= <reg_name> - 1; 

-With /w Load, CE and Async Active High Reset, select Edit > Use in File, or select the 
Use Template in File toolbar button. This step copies the template into the countupd 
source file . 

8) Final Editing of the Verilog Source 

- To declare and initialize the register that stores the countupd value, modify the 
declaration statement in the first line of the template as follows: 
replace: reg [ <upper>:O] <reg_ name>; 
with: reg [3:0] count_int = O; 

I 
II 

-Add the following line just above the endmodule statement to assign the register value 
to the output port: 
assign COUNT_ OUT = count_int; 
- Save the file by selecting File > Save. 
When you are finished, the code for the countupd will look like the following: 

Ill 
I 

• 

module countupd(clock, reset, clocken, loaden, direction, inp, count); 
input clock; 
input reset; 
input clocken; 
input loaden; 
input direction; 
input [3:0] inp; 
output [3 :O] count; 
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• • II and timing. In general faster and smaller FPGA designs will 
II result from not using asynchronous resets. Please refer to 
II the Synthesis and Simulation Design Guide for more information. 

reg [3:0] count_int = O; 

• 
always @(posedge clock or posedge reset) 
if (reset) 
count_int <= O; 

else if ( clock en) 
if (loaden) 
count_int <= O; 

else if (direction) 
count_int <= count_int + 1; 

else 
count_int <= count_int - 1; 

assign COUNT_OUT = count_int; 
endmodule 

• • 
-Double-click the Check Syntax process . 

9) Create the Test Bench of the Countupd HDL Source: 

-Select the countupd HDL file in the sources window. 
-Create a new test bench source by selecting project -> new source 
-In the new source wizard,select test bench waveform as the source type and type 

countupd_tb in the file name field . 

• • 
10) Gave Inputs to the Test Bench: 

I 

• 
II 

-Clock high time : 20 ns 
-Clock low time : 20 ns 
-Input setup time: 10 ns 
-Offset : 0 ns 
-Global signals : GSR(FPGA) 
-Initial length of test bench: 1500 ns 
-Direction high : 300 ns 
-Direction low : 900 ns 

11) Control the Inputs: 

• • 
-Verify that behavioral simulation and countupd _tb are selected in the sources window. 
-In the process tab, click the"+" to expand the xilinx ISE simulator process and 

double-click the simulate behavioral model process . 

12) Entering Timing Constraint: 
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• • • -Select synthesis/implementation from the drop-down list in the sources window . 
-Select the countupd HDL source file. 
-Click the "+" sign next to the user constraints processes group and double-click the 

create timing constraint process. 
-Select clock in the clock net name field, then select the period toolbar button or 

double-click the empty period field to display the clock period dialog box. 
-Enter 40 ns in the time field. 
-Select the pad to setup toolbar button or double-click the empty pad to setup field to 

display the pad to setup dialog box. 
-Enter l O ns in the offset field to set the input offset constraint. 
-Select the clock to pad toolbar button or double-click the empty clock to pad field to 

display the clock to pad dialog box. 
-Enter 10 ns in the offset field to set the output delay constraint. 

I 

• 13) Implemantation: 

• • 
-Select the countupd source file in the sources window. 
-Open the design summary by double-clicking the view design summary process in the 

processes tab . 
-Double-click the implement design process in the processes tab. 

14) Pin Location Constraint: 

• • • 

-Verify that countupd is selected in the sources window. 
-Double-click the assign package pins process found in the user constraints process 

group. 
-Select the package view tab. 
-In the design object list window,enter a pin location for each pin in the Joe column 

using the following information: 
*clock input port connects to pin t9 
*cont_out<O> output port connects to pin k12 
*cont_out<l> output port connects to pin p14 
*cont_ out<2> output port connects to pin 112 
*cont_out<3> output port connects to pin n14 
*direction input port connects to pin k13 

15) Download Design to the Spartan™-3 Demo Board I 
II 
II 

- Select countupd in the Sources window. 
- In the Processes window, click the "+" sign to expand the Generate Programming 
File processes. 
- Double-dick the Configure Device (iMP ACT) process. 
- The Xilinx WebTalk Dialog box may open during this process. Click Decline. 
- Select Disable the collection of device usage statistics for this project only and 
click OK. 
- In the Welcome dialog box, select Configure devices using Boundary-Scan (JTAG). 
- Verify that Automatically connect to a cable and identify Boundary-Scan chain is 
selected. 

I 
I 
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Click Finish. 
- In the Welcome dialog box, select Configure devices using Boundary-Scan (JTAG). 
- Verify that Automatically connect to a cable and identify Boundary-Scan chain is 
selected. 
- Click Finish. 
-Right-click on the xc3s200 device image, and select Program ... The Programming 
Properties dialog box opens. 
- Click OK to program the device . 

• • • 
I 
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1) Create a Counter Project: 

-Select File -> New Project 
-Type counter in the project name field. 
-Enter to location and a counter subdirectory is created automatically. 
-Verify that HDL is selected from top-level source type list. 

2) Create the HDL Source of the Counter: 

-Click the new source button in the new project wizard. 
-Select VHDL module as the source type. 
-Type in the file name counter. 
-Verify that the add to project checkbox is selected. 

3) HDL Language Template: 

-Edit -> Language Templates 
-VHDL -> Synthesis Constructs -> Coding Examples ->Binary-> 

Up/Down Counters -> Simple Code 

*process (<clock>) 
begin 

if <clock>='l' and <clock>'event then 
if <count direction>=' 1' then 

<count> <= <count> + 1; 
else 

<count> <= <count> - 1; 
end if; 

end if; 
end process; 

4) Edit the HDL Code: 

-library IEEE; 
use IEEE.STD_LOGIC_1164.ALL; 
use IEEE.STD _LOGIC_ ARITH.ALL; 
use IEEE.STD _LOGIC_UNSIGNED.ALL; 
entity counter is 

Port (Clock: in STD _LOGIC; 
Direction: in STD _LOGIC; 
Count_Out: out STD_LOGIC_ VECTOR (3 down to O)); 

end counter; 
architecture Behavioral of counter is 
signal Count_Int :STD_LOGIC_ VECTOR (3 downto 0) := "0000"; 
begin 

process (Clock) 
begin 



if Clock= '1' and Clock'event then 
if Direction= 'l' then 

Count_Int <= Count_Int + l; 
else 

Count_Jnt <= Count_Int - 1; 
end if; 

end if; 
end process; 
Count_ Out<= Count_Int; 
end Behavioral; 

5) Syntax Check: 

-Verify that Synthesis/Implementation is selected from the drop-drown list in the sources 
window. 
-Click the '+' next to the Synthesize-XST process to expand the process group. 
-Double-click the Check Syntax process. 

6) Create the Test Bench of the Counter HDL Source: 

-Select the counter HDL file in the sources window. 
-Create a new test bench source by selecting project -> new source 
-In the new source wizard,select test bench waveform as the source type and type 

counter tb in the file name field. 

7) Gave Inputs to the Test Bench: 

-Clock high time : 20 ns 
-Clock low time : 20 ns 
-Input setup time : 10 ns 
-Offset : 0 ns 
-Global signals : GSR(FPGA) 
-Initial length of test bench : 1500 ns 
-Direction high : 300 ns 
-Direction low : 900 ns 

8) Control the Inputs: 

-Verify that behavioral simulation and counter_tb are selected in the sources window. 
-In the process tab, click the"+" to expand the xilinx ISE simulator process and 
double-click the simulate behavioral model process. 

9) Entering Timing Constraint: 

-Select synthesis/implementation from the drop-down list in the sources window. 
-Select the counter HDL source file. 
-Click the "+" sign next to the user constraints processes group and double-click the 
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-Select clock in the clock net name field, then select the period toolbar button or ~ ~ 
double-click the empty period field to display the clock period dialog box. 

-Enter 40 ns in the time field. 
-Select the pad to setup toolbar button or double-click the empty pad to setup field to 

display the pad to setup dialog box. 
-Enter 10 ns in the offset field to set the input offset constraint. 
-Select the clock to pad toolbar button or double-click the empty clock to pad field to 

display the clock to pad dialog box. 
-Enter 10 ns in the offset field to set the output delay constraint. 

10) Implemantation: 

-Select the counter source file in the sources window. 
-Open the design summary by double-clicking the view design summary process in the 

processes tab. 
-Double-click the implement design process in the processes tab. 

11) Pin Location Constraint: 

-Verify that counter is selected in the sources window. 
-Double-click the assign package pins process found in the user constraints process 

group. 
-Select the package view tab. 
-In the design object list window,enter a pin location for each pin in the loc column 

using the following information: 
*clock input port connects to pin t9 
*cont_ out<O> output port connects to pin kl2 
*cont_out<l> output port connects to pin pl4 
*cont_ out<2> output port connects to pin 112 
*cont_out<3> output port connects to pin n14 
*direction input port connects to pin k13 

• • 
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FULLADDER 

DESING STEPS 

DESING DESCRIPTION 

TOOLS USED 

CREATE THE NEW PROJECT FULLADDER 

CREATE AN HDL HALFADD 

CREATE TEST BENCH HALFADD 

CREATE AN HDL ORGATE 

CREATE TEST BENCH ORGATE 

CREA TE AN HDL FULLADD 

CREA TE TEST BENCH FULLADD 

SIMILATION 



DESING DESCRIPTION 

This project name FULLADDER. 

Entity FULLADD is 

Port ( A : in STD_LOGIC; 

B : in STD_LOGIC; 

cin : in STD_LOGIC; 

sum : out STD_LOGIC; 

carry : out STD_LOGIC); 

Entity halfadd is 

Port{ A: in STD_LOGIC 

B: in STD_LOGIC 

Sum: out STD_LOGIC 

carry: out STD_LOGIC 

Entity orgate is 

Port{ a: in STD_LOGIC 

b: in STD_LOGIC 

z: out STD_LOGIC 



The project family name Spartan3 

Dvice XC35200 

Package FT256 

Top-lwvwl source type HDL 



TOOLS USED 

HARDWARE 

Family name Spartan3 

Dvice XC3S200 

Package FT256 

Speed -4 

SOFTWARE 

XILINX-ISE 9.1 i 

Top Level source type VHDL 

Synthesis tool XST (VHDL/verilog) 

Similator ISE Similator (VHDL/verilog) 

Language VHDL 



1 . Design Steps Of FULLADDER 

Help 

Open Example,, , 
Close Project 
Save Project As, , , 

Q Nev,,, Ctrl+N 

~ Open ... Ctrl+O 

Close 

Save Cttl+S 

Save As .. , 

Save All 

Print Preview.i. 

Print, , , Ctrl+P 

Recent Files 

Recent Projects 

Exit 
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Before create a fulladder in VHDL file we create firsr two halfadder and orgate.First 

we create the halfadder for that we declare the inputs . 

Decleration of the Halfadder 

Add Copy of Source,, . 

Cleanup Project Files 
Toggle Paths 

Archive ... 
Take Snapshot ... 

Make Snapshot Current 

Apply Project Properties ... 

Processes for xc3s200-4ft256 

i---· t::l ti.dd bisting S ource 

:- t::l Create l··Jew Source 
f±J» Design Utilities 



IP (Coregen & Architecture Wizard) 
MEM File 
Schematic 
Implementation Constraints File 

File name: 

~ \/erilo .. 9 Test Fixture 
'.S] VHDUModule 

. \/HDL Library 
_:kl \/HD L Package 
~ \/HDL Test Bench 

Entity halfadd is 

Port{ A: in STD_LOGIC 

B: in STD_LOGIC 

Sum: out STD_LOGIC 



carry: out STD_LOGIC 

end halfadd; 

architectdre behaviroal of halfadd is 

sume A xor B 

ccrrv-> A and B 

end behaviroal; 

In the entity part of the halfadd we declera the inputs of the halfadd.In entity part as 
we see A,B are the inputs and sum, carry are the output for the first halfadder.AII the 
inputs and the outputs types are STD_LOGIC.They can take as a value just 1 or 0. 

By the architecture part of the halfadder as we see from the code.The ouput value 
comes from' A xor B' to the sum also the output value comes' A and B' to the 
carry.After cretating halfadder file by double clicking check syntax we compile the 
page to able to create the test bench file. 

Decleration of the Halfadder Test Bench File 

tion 

Add Copy of Source ... 

Open 

Set as Top Module 
Use SmartGuide 

(LJ 
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r·.Jew F·artiUcn 

Delete P,9rtiticn 

Partition Properties ... 
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View Desigr 
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~ BMM File 
q IP (Coregen & Architecture \1/izardl 

i MEH File 
Schematic 
Implementation Constraints File 

::~. State Diagram 
"':., Test Bench W aveF orm 
§i. User Document 
v .• Verilog Module 
Ni Verilog Test Fixture 
'·'H0 VH D L Module 

VHDL Library 
~ VHDL Package 
.~ VHDL Test Bench 

File name: 

0 bPACK_ S FD_ 91 i\xilinx\myproje 

Ne Cancel 

BEGIN 

uut: halfadd PORT MAP( 

A=> A, 

B => B, 

sum=> sum, 

carry => carry 

); tb :·PROCESS 

BEGIN 

-- Wait 100 ns for global reset to finish 

wait for 100 ns; 

A<= 'O'; 

B <= 'O'; 

-- Place stimulus here 

wait for 100 ns; 



A<= 'O'; 

B <= '1'; 

wait for 100 ns; 

A<= '1'; 

B <= 'O'; 

wait for 100 ns; 

A<= '1'; 

B <= '1'; 

wait; -- will wait forever 

END PROCESS; 

END; 

At the port map part we just declera again the inputs and the outputs.Where the alues 
will come from. For the inputs A,B we assign the values to able to see the results in the 
simulation part .Then by double clicking simulate behaviroal model we can see the 
results.As shown below: 

Decleration of Orgate 



"fi; .~-.,.,, .. ,,,,,,___________,"""'" ... 
~ BMM File 
t~ IP (Coregen & Architecture Wizard) 

~ 

MEM File 
Schematic 
Implementation Constraints File 

~' State Diagram I File name 
.n, Test Bench \.II aveF orrn 
~' User Document 
\/_,, \/erilog Module 

\/ erilog Test Fi,:ture 
'-'~a VHDL Module I l.~.:.1:~-!.~~~~-~:-SF~.~91 i\xilinx\myprojects\f 

\/HDL Library 
!:.J VHDL Package 
J~~ \/HDL Test Bench 

· L*''''NCancel 

Entity orgate is 

Port{ a: in STD_LOGIC 

b: in STD_LOGIC 

z: out STD_LOGIC 



end orgate; 

architecture behaviroal of orgate is 

z<= a orb; 

end behaviroal; 

In the entity part of orgate we declared the inputs and outputs for the fulladder.In 

here again A,B are the inputs and the output is z. 

In the architecture part of orgate we can see that we get the value of z by 'a orb'. 
After cretating orgate file by double clicking check syntax we compile the page to able 

to create the test bench file. 

Decleration of the Orgate Test Bench File 

IP [Coregen & Architecture Wizard) 
MEt,,1 File 
Schematic 
I rnplernentation Constr aints File 

, State D iagr arn 
Test Bench V/aveForm 
LI ser D ocurnent 

v, \/erilog Module 
, \/erilog Test Fixture 

''H0 VHDL Module 
VHDL Library 

File name: 

D 

IL r:i~;~t·> ·. ] < Back 



BEGIN 

-- Instantiate the Unit Under Test (UUT) 

uut: orgate PORT MAP( 

a=> a, 

b => b, 

z => z); 

tb : PROCESS 

BEGIN 

-- Wait 100 ns for global reset to finish 

wait for 100 ns; 

a<= 'Q'; 

b <= 'O'; 

-- Place stimulus here 

wait for 100 ns: 



·a<= 'O'; 

b <= '1'; 

wait for 100 ns; 

a<= '1'; 

b <= 'O'; 

wait for 100 ns; 

a<= '1'; 

b <= '1'; 

wait; -- will wait forever 

END PROCESS; 

It is the same with halfadder test bench file again in port map part we defined the 
inputs and outputs.Then able to see in the simulation we give values for a and b , the 
output values assigned to the z by a or b. 

Decleration of Fulladder 
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entity fulladder is 

Port ( A : in STD_LOGIC; 

B: in STD_LOGIC; 

cin : in STD_LOGIC; 

sum : out STD_LOGIC; 

carry : out STD_LOGIC); 

end fulladder; 

architecture Behavioral of fulladder is 

signal I1,I2,I3:STD_LOGIC; 

COMPONENT halfadd 

PORT( 

A : IN std_logic; 

B : IN std_logic; 

sum : OUT std_logic; 



carry : OUT std_logic 

); 

END COMPONENT; 

COMPONENT orgate 

PORT( a : IN std_logic; 

b : IN std_logic; 

z : OUT std_logic 

); 

END COMPONENT; 

begin 

ul: halfadd port map (a,b,Il,I2); 

u2: halfadd port map (Il,cin,sum,I3); 

u3: orgate port map (I3,I2,carry); 

end Behavioral; 

In fulladder differently we declare signals they are 1,I2,I3,I4.Those signals type also 
STD_LOGIC they can get as value just lor O.By this part of code 

begin 

ul: halfadd port map (a,b,I1,I2); 

u2: halfadd port map (Il,cin,sum,I3); 

u3: orgate port map (I3,I2,carry); 

end Behavioral; 

We assign the outputs of first halfadder Il,I2 , assign for second halfadder first input 
Il,second output I3,assign the inputs of orgate I3,I4.After finishing those assigments 
wesave the file and double clicking check syntax we compile the file and then we can 
create the test bench file. 

Decleration of Fulladder Test Bench File 



IP [Coreqen 2, .6.rchitecture Wizard) 
tv1Etv1 File 
Schematic 
lrnplernentetion Constraints File 

File neme: 

~ 

User D ocurnent 
Verilog Module 

. Verilog Test Fixture 
VHDL Module 
VHDL Library 

~ VHDL Package 
'.iH~ VH DL Test Bench . 

Location: 

D 

[ , C ~!~S,~L .. J 

ARCHITECTURE behavior OF fulladder _tb_vhd IS 

BEGIN 

-- Wait 100 ns for global reset to finish 

wait for 100 ns; 



A<= 'O'; 

B <= 'O'; 

cin<= 'O'; 

-- Place stimulus here 

wait for 100 ns; 

A<= 'O'; 

B <= 'O' 

cin <= '1'; 

wait for 100 ns; 

A<= 'O'; 

B <= '1'; 

cin <= 'O'; 

wait for 100 ns; 

A<= 'O'; 

B <= '1'; 

cin <= '1'; 

wait for 100 ns; 

A<= '1'; 

B <= 'O'; 

cin <= 'O'; 

wait for 100 ns; 

A<= '1 '; 

B <= 'O'; 

cin <= '1'; 

wait for 100 ns; 



A<= '1'; 

B <= '1'; 

cin <= 'O'; 

wait for 100 ns; 

A<= '1'; 

B <= '1'; 

cin <= '1'; 

wait; -- will wait forever 

END PROCESS; 

END; 

In the test bench file we assign values for the inputs A,B,Cin for the simulation design 
as we can see from the pictures in the different values of inputs it gives different 
outputs.In the first picture all the values are O and outputs are zero .In the second 
picture a=O,b=l so cin_=O,sum=l,carry=O.As we see from the project 1+0=0 with co carry. 



.·, 

·1 

I 

1 
! 

/i . . . 
·: 
'i 

,·;,~;-;;;;; 





DESING STEPS 

DESING DESCRIPTION 

TOOLS USED 

CREATE THE NEW PROJECT COUNTER 

CREATE AN HDL SOURCE 

DE SING SIMILA TION 

SIMILA TION DE SING FUNCTIONALITY 

CREATE VHDL TEST BENCH 



DESING DESCRIPTION 

This project name STAT_ TWO. 
The project have tree ports. 
A : in STD_LOGIC. 
CLOCK : in STD_LOGIC. 
RESET : in STD_LOGIC. 
X : out STD_LOGIC. 

The project family name Spartan3 
Dvice XC3S200 
Package FT256 
Top-lwvwl source type HDL 



TOOLS USED 

HARDWARE 
Family name Spartan3 
Dvice XC3S200 
Package FT256 
Speed -4 

SOFTWARE 
XILINX-ISE 9.1 i 
Top Level source type 
Synthesis tool 
Similator 
Language 

HDL 
XST (VHDL/verilog) 
ISE Similator (VHDL/verilog) 
VHTL 



STAT_TWO 

Create a New Project Counter 

Enter a Name and Location for the 

Proiect r~ame: Proiect Location 

,tat_two.,.,@~•· 1 IS;~i1~nx91i\stat_tvf~w, ,c,, ,, "' ww,, ~ I [J 

Select the Type of Top-Level Source for the 

Top-Level Source T ype: 

HDL 

t•,1~re Info WWI > ''' Cancel .. ~I 

Create a new ISE project which will target the FPGA device on the Spartan-3 Startup 
Kit 
demo board. 
To create a new project: 
1. Select File DDNew Project ... The New Project Wizard appears. 
2. Type stat_two in the Project Name field. 
3. Enter or browse to a location (directory path) for the new project. A tutorial 
subdirectory is created automatically. 
4. Verify that HDL is selected from the Top-Level Source Type list. 
5. Click Next to move to the device properties page. 
6. Fill in the properties in the table as shown below: 
DDProduct Category: All 
DDFamily: Spartan3 
DDDevice: XC3S200 



DDPackage: FT256 
DDSpeed Grade: -4 
DDTop-Level Source Type: HDL 
DDSynthesis Tool: XST (VHDL/Verilog) 
DDSimulator: ISE Simulator (VHDL/Verilog) 
DDPreferred Language: Verilog (or VHDL) 
DDVerify that Enable Enhanced Design Summary is selected. 
Leave the default values in the remaining fields. 
When the table is complete, your project properties will look like the following: 
Figure 2: Project Device Properties 

II New Project Wizard - Device Properties IIIIIJ 13] 

Create an HDL Source 
Create a VHDL source file for the project as follows: 
1. Click the New Source button in the New Project Wizard. 
2. Select VHDL Module as the source type. 
3. Type in the file name stat_two. 
4. Verify that the Add to project checkbox is selected. 
5. Click Next. 
6. Declare the ports for the counter design by filling in the port information as shown· 
below: 



New Source Wizard - Select Source Type IIIIJEI 

,~",_._ 1 mplementation Constraints File ''i State Diagram 
.i:-, Test Bench \//aveForm 

J - VHDL Library 
~ VHDL Package 
~ \/HDL Test Bench 

More Info Next> Cancel I 

New Source Wizard - Define Module IIIIJEI 

Architecture r~ sme 

Entity r~ erne L--=··~~·-·-~--------·~·----·,------·~---,,,,,----~,,,-,,-------~~--·--·d 

LSB Port r·.J sme 
a 

clock 
reset 

More Info j ~B~~k 111 Next> ) Cancel I 



II New Source Wizard - Summarv 1!!1111 El 

7. Click Next, then Finish in the New Source Wizard - Summary dialog box to complete 
the new source file template. 
8. Click Next, then Next, then Finish. 
Stat_two displays in the Source tab, as shown below: 



i"'LJ 
i"'LJ 
,L ,,.ii, 
cl-• 

Add Existing Source 
Create New Source 
Xilinx ISE Simulator 

44 
45 if (reset=' 1') then 
46 
47 
48 
49 

current state<= sO; 
elsif (clock'event and clock=' 
current state<= next state; 

Simulate Behavioral Model 

Parsing "stat two stx.prj": 0.06 

50 end if; 
end process; 51 

52 
53 
54 
55 
56 
57 
58 
59 
60 
61 
62 
63 
64 
65 
66 
67 
68 

current process#2: comot natt cna. 
corrb_logic:process(current state, 
begin 

-- use case statement to show the 
--state trsnsistion 

case current state is 

when so=> x <= '0'; 
if a='O' then 
next state<= sO; 
els if a= ' 1 ' t. hen 
next state<= sl; 
end if; 

Process "Check Syntax" completed successfully 

-----------------------------------------------------------------------------·---- 
-- Company: 
-- Engineer: 

-- Create Date: 13:39:12 08/14/2008 
-- Design Name: 
-- Module Name: stat_two - Behavioral 
-- Project Name: 
-- Target Devices: 
-- Tool versions: 
-- Description: 

-- Dependencies: 



-- Revision: 
-- Revision 0.01 - File Created 
-- Additional Comments: 

---------------------------------------------------------------------------------- 
library IEEE; 
use IEEE.STD_LOGIC_1164.ALL; 
use IEEE.STD_LOGIC_ARITH.ALL; 
use IEEE.STD_LOGIC_UNSIGNED.ALL; 

---- Uncomment the following library declaration if instantiating 
---- any Xilinx primitives in this code. 
--library UNISIM; 
--use UNISIM.VComponents.all; 

entity stat_two is 
Port ( a : in STD_LOGIC; 

clock: in STD_LOGIC; 
reset : in STD_LOGIC; 
x : out STD_LOGIC); 

end stat_two; 

architecture Behavioral of stat_two is 

type state_type is (sO,sl); 
signal next_state, current_state: state_type; 
begin 

state_reg: process ( clock, reset) 
begin 

if (reset>'J') then 
current_state <= sO; 
elsif (clock' event and clock=' 1') then 
current_state <= next_state; 

end if; 
end process; 

-- current process#2:combinational logic 
comb_logic:process(current_state, a) 
begin 

-- use case statement to show the 
--state trsnsistion 



case current_state is 

when sO => x <= 'Q'; 
if ceO' then 
next_state <= sO; 
els if a=' 1' then 
next_state <= s1; 
end if; 

when s1=> x <= '1'; 
if ceO' then 
next_state <= s1; 
els if a=' 1' then 
next_state <= sO; 
end if; 
when others=> 
X <= 'Q'; 
next_state <= sO; 
end case; 
end process; 

end Behavioral; Synthesis Report: 

Design Simulation 



•... t:] Add Existing Source 
[- ·· t:] Create r~ ew Source 
El » Xilinx ISE Simulator 

I ·· ,~9Check Syntex 
B Simulate Behavioral Model 

mt Processes 

51 
52 
53 
54 
55 
56 
57 
58 
59 
60 
61 
62 
63 
64 
65 
66 
67 
68 
69 
70 
71 
72 
73 
74 
75 
76 

encl proe:ess; 

current process#2 : comb inat ional lo,;;1 
comb_logic:process(current state, a) 
begin 

-- use case statement to show the 
--state trsnsistion 

case current state is 

when so=> x <= '0'; 
if a='O' then 
next state<= sO; 
elsif a=' 1' then 
next state<= sl; 
end if; 

when sl=> x <= '1'; 
if a='O' then 
next state<= sl; 
elsif a='l' then 
next state<= sO; 
end if; 
when others=> 
X <= IQ I ; 

n Summery 



CREA TE THE TEST BENCH 



58 
59 
60 

--state trsnsistion 

case current state is 

when sO => x <= '0'; 
if a='O' then 
next state<= sO; 
elsif a='1' then 
next state<= s1; 
end if; 

Add Copy of Source ... 

.q 
5 

y6 
7 Open 

Processes for: stat t•; 
I ~ Add E .- ... ' u~;e Sm,;1Jl6:t.1i.de 
:· ·· L..J ,-., x1st111 o 
L ... i:j Create r~el He.\!# l?aJtition 1 

c.:::J. '»1 Xii inx Is E I 01%t@le P;att~tQn 2 
/ .... t~(9Chedl l?atHltQlft 

4 Simul 

when s1=> x <= '1'; 
if a='O' then 
next state<= s1; 
elsif a='1' then 
next state<= sO; 
end if; 
when others=> 
X <= IQ I ; 

next state<= sO; 
end case; 
end process; 

~ stat_two.vhd 

Toggle Paths 

~ Properties ... end Behavioral; 

B New Source \!lizard - Select Source Type l!!lllJEI 
~BMM File 
<11 P [Core gen & Architecture Wizard) 

! MEM File 
Schematic 
Implementation Constraints File 

~ State Diagram 
-";1 Test Bench \.VaveForm 
§, User Document 
v, Verilog Module 
Ah \/ erilog Test Fixture 
''Ha \/HDL Module 

VHDL Library 

,P l'~:~.S L Package 

File name: 

stat_two_ttj 

. 
I 

- --- ----------- 
!? I.Xilinx91 i\stat t~-----·-·w·=~-,,---####U#, 

-- Company: 



-- Engineer: 

-- Create Date: 01:17:18 08/10/2008 
-- Design Name: stat_two 
-- Module Name: C:/Xilinx91i/stat_two/stat_two tb.vhd 
-- Project Name: stat_two 
-- Target Device: 
-- Tool versions: 
-- Description: 

-- VHDL Test Bench Created by ISE for module: stat_two 

-- Dependencies: 

-- Revision: 
-- Revision 0.01 - File Created 
-- Additional Comments: 

-- Notes: 
-- This testbench has been automatically generated using types std_logic and 
-- std_logic_vector for the ports of the unit under test. Xilinx recommends 
-- that these types always be used for the top-level I/0 of a design in order 
-- to guarantee that the testbench will bind correctly to the post-implementation 
-- simulation model. 
-------------------------------------------------------------------------------- 
LIBRARY ieee; 
USE ieee.std_logic_1164.ALL; 
USE ieee.std_logic_unsigned.all; 
USE ieee.numeric_std.ALL; 

ENTITY stat_two_tb_vhd IS 
END stat_two_tb_vhd; 

ARCHITECTURE behavior OF stat_two_tb_vhd IS 

-- Component Declaration for the Unit Under Test (UUT) 
COMPONENT stat_two 
PORT( 

a : IN std_logic; 
clock : IN std_logic; 
reset : IN std_logic; 
x : OUT std_logic 
); 

END COMPONENT; 



--Inputs 
SIGNAL a: std_logic := 'O'; 
SIGNAL clock: std_logic := 'O'; 
SIGNAL reset: std_logic := 'O'; 

--Outputs 
SIGNAL x : std_logic; 

BEGIN 

-- Instantiate the Unit Under Test (UUT) 
uut: stat_two PORT MAP( 

a=> a, 
clock => clock, 
reset => reset, 
X => X 

); 
clkp: process 
begin 

clcck « 'O'; 
wait for 10 ns; 
clock <= '1'; 
wait for 10 ns; 
end process; 

tb: PROCESS 
BEGIN 

-- Wait 100 ns for global reset to finish 
wait for 100 ns; 
reset « ' O'; 
a<='O'; 
wait for 100 ns; 
a<=' 1'; 
wait for 100 ns; 
a<='O'; 

-- Place stimulus here 

wait; -- will wait forever 
END PROCESS; 

END; 



,6,dd Existing Source 
Create rfow Source 
Xilinx ISE Simulator 

Di! • .... II Simulate Behavioral Model 

Parsing ttstat_two stx.prjtt: 0.06 

37 ARCHITECTURE behavior OF stat two tb vr; 
38 
39 -- Component Declaration for the Uni 
40 COMPONENT stat two 
41 PORT ( 
42 a : IN =«. lc11;ric; 
43 clock : IN std_ logic; 
44 reset : IN std_lo•Jic; 
45 x : OUT std_logic 
46 ) ; 
47 END COMPONENT; 
48 
49 --Input.s 

SIGNAL a stc!_lo,;ric := '0'; 
SIGNAL clock std_lc11Jic : = 'o'; 
SIGNAL reset std_lo,Jic : = 'o'; 

50 
51 
52 
53 
54 
55 
56 
57 BEGIN 

--Outputs 
SIGNAL x : s td logic; 

58 
59 -- Instantiate the Unit Under Test 
60 uut: stat_two PORT MAP( 
61 a=> a, 

Process ttCheck Syntaxtt completed successfully 



[-·· t::l Add Existing Source 
: .... t::l Create New Source 
i~J··'» Xilinx ISE Simulator 

•.... r~0Check Syntax 
• Simulate Behavioral Model 

~ ( 

58 
-- use case statement to snow tne 
--state trsnsistion 

59 
60 
61 
62 
63 
64 
65 
66 
67 
68 
69 
70 
71 
72 
73 
74 
75 

case current state is 

when so=> x <= '0'; 
if a='O' then 
next state<= sO; 
elsif a=' 1' then 
next state<= sl; 
end if; 

when sl=> x <= '1'; 
if a='O' then 
next state<= sl; 
elsif a=' 1' then 
next state<= sO; 
end if; 
when others=> 
X <= IQ I ; 

next state<= sO; 
end case; 
end process; 

76 
77 
78 
79 
80 
81 
82 

end Behavioral; 

~ Processes 
Design Summary 

I 
I 
I 
I 

I 



• '· 

• 
Now: 
1000 ns 
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