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Lecture 9: Regression Analysis by SPSS

Model

Dataset 6 indicates the determinants of Impulse Buying based on a cross-

sectional survey. In particular, it attempts to establish an understanding of

how impulse buying behaviour may affect the wealth of investors on the stock

market and this can be modelled in the following form:

Impulse = 0 + 1 Gender + 2 Age Band+ 3 Portfolio+ Vi

Where ’s and ’s are the estimated parameters, U and V the error terms.

Data Description
The data collected is cross sectional in nature. Questionnaires were used to

provide a spread of information from different ages and classes. The data

itself was collected manually over a period of a few weeks. The majority of the

subjects were approached in the street, in their place of work and in public

establishments such as bars and restaurants in Leicester city.

Tasks

1. How well can we predict the willingness in purchasing share (ib) if we

know something about the decision of portfolio (P)? (i.e., Simple

Regression).

2. Regress p, g, and ab on ib (i.e. Multiple Regression).

3. Use the log version of the existing variables and repeat Task 1.

4. Use the log term of the relevant variables and repeat Task 2.

5. Decompose the gender variable using recode procedure into two groups

such as male and female and regress the following steps to estimate the

effects of the two variables separately:

           a) regress p, m, and ab on ib

           b) regress p, f, and ab on ib
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Tips For Task 1

To conduct the analysis (i.e. simple regression), from the Analyze pull-down

menu, select Regression, then choose Linear. When the dialog box appears,

select “ib’ as the dependent variable and “p” as the independent variable (see

Fig 1). Choose statistics button and click on the boxes of estimates, model

fit, and descriptives (see Fig 2) and then click on continue to return to the

main regression dialog box. Finally, click on the OK button to run the analysis

(see Fig 3).

FIG 1

FIG 2

Descriptive Statistics

4.4231 2.1993 52
1.9038 .7985 52

impulse buying
portfolio

Mean Std. Deviation N
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Correlations

1.000 .303
.303 1.000

. .015
.015 .

52 52
52 52

impulse buying
portfolio
impulse buying
portfolio
impulse buying
portfolio

Pearson Correlation

Sig. (1-tailed)

N

impulse
buying portfolio

Variables Entered/Removedb

portfolioa . Enter
Model
1

Variables
Entered

Variables
Removed Method

All requested variables entered.a.

Dependent Variable: impulse buyingb.

Model Summary

.303a .092 .073 2.1170
Model
1

R R Square
Adjusted
R Square

Std. Error of
the Estimate

Predictors: (Constant), portfolioa.

ANOVAb

22.610 1 22.610 5.045 .029a

224.083 50 4.482
246.692 51

Regression
Residual
Total

Model
1

Sum of
Squares df Mean Square F Sig.

Predictors: (Constant), portfolioa.

Dependent Variable: impulse buyingb.

Coefficientsa

2.836 .765 3.705 .001
.834 .371 .303 2.246 .029

(Constant)
portfolio

Model
1

B Std. Error

Unstandardized
Coefficients

Beta

Standardi
zed

Coefficien
ts

t Sig.

Dependent Variable: impulse buyinga.

FIG 3



Lecture 9: Regression Analysis by SPSS

4

Tips For Task 2

This is a multiple regression analysis. To conduct this analysis, from the

Analyze pull-down menu, select Regression, then choose Linear. When the

dialog box appears, select “ib’ as the dependent variable and the rests as

independent variables (see Fig 4). Now, select statistics button and click on

the boxes of estimates, model fit, and descriptives (see Fig 5) and then

click on continue to return to the main regression dialog box. Finally, click on

the OK button to run the analysis (see Fig 6).

FIG 4

FIG 5
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Descriptive Statistics

4.4231 2.1993 52
1.4808 .5045 52
3.8462 1.4738 52
1.9038 .7985 52

impulse buying
gender
age band
portfolio

Mean Std. Deviation N

Correlations

1.000 .149 -.131 .303
.149 1.000 .101 .020
-.131 .101 1.000 .037
.303 .020 .037 1.000

. .146 .178 .015
.146 . .237 .445
.178 .237 . .397
.015 .445 .397 .

52 52 52 52
52 52 52 52
52 52 52 52
52 52 52 52

impulse buying
gender
age band
portfolio
impulse buying
gender
age band
portfolio
impulse buying
gender
age band
portfolio

Pearson Correlation

Sig. (1-tailed)

N

impulse
buying gender age band portfolio

Variables Entered/Removedb

portfolio,
gender,
age band

a . Enter

Model
1

Variables
Entered

Variables
Removed Method

All requested variables entered.a.

Dependent Variable: impulse buyingb.

Model Summary

.370a .137 .083 2.1062
Model
1

R R Square
Adjusted
R Square

Std. Error of
the Estimate

Predictors: (Constant), portfolio, gender, age banda.

ANOVAb

33.754 3 11.251 2.536 .068a

212.938 48 4.436
246.692 51

Regression
Residual
Total

Model
1

Sum of
Squares df Mean Square F Sig.

Predictors: (Constant), portfolio, gender, age banda.

Dependent Variable: impulse buyingb.
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Coefficientsa

2.704 1.320 2.048 .046
.693 .588 .159 1.179 .244
-.236 .201 -.158 -1.173 .247
.841 .370 .305 2.276 .027

(Constant)
gender
age band
portfolio

Model
1

B Std. Error

Unstandardized
Coefficients

Beta

Standardi
zed

Coefficien
ts

t Sig.

Dependent Variable: impulse buyinga.

FIG 6

How to take natural logarithm of a variable?

To create the natural log of the existing variables, go to the transform drop-

down menu and choose compute option and type lg in the target variable
box (see fig 6a) then click type & label button to open the dialog box as

appears in fig 6b. In this dialog box, type log of gender to make it recorded in

the variable view section and press continue button to get back to compute

variable dialog box. (see fig 6b and the variable view section). Having

completed these processes, select the relevant function (LG10) from the

function box and click function button to get it into the upper screen, then

choose the relevant variable (i.e. gender) with clicking the nearest button (see

fig 6c). To get the final product, look at the data view section. Apply the same

process for the other variables (see fig 6d)

 FIG 6a
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 FIG 6b

 FIG
6c

 FIG
6d

Tips For Task 3

Use the log version of the relevant variables to conduct the relationship

between, “lib” and “lp”. From the Analyze pull-down menu, select

Regression, then choose Linear. When the dialog box appears, select “lib”
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as the dependent variable and “lp” as the independent variable (see Fig 7).

Choose statistics button and click on the boxes of estimates, model fit, and

descriptives (see Fig 8) and then click on continue to return to the main

regression dialog box. Finally, click on the OK button to run the analysis (see

Fig 9).

 FIG 7

 FIG 8

Descriptive Statistics

.5771 .2703 52

.2384 .1956 52
log of impulse buying
log of portfolio

Mean Std. Deviation N
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Correlations

1.000 .252
.252 1.000

. .036
.036 .

52 52
52 52

log of impulse buying
log of portfolio
log of impulse buying
log of portfolio
log of impulse buying
log of portfolio

Pearson Correlation

Sig. (1-tailed)

N

log of impulse
buying log of portfolio

Variables Entered/Removedb

log of
portfolio

a . Enter

Model
1

Variables
Entered

Variables
Removed Method

All requested variables entered.a.

Dependent Variable: log of impulse buyingb.

Model Summary

.252a .063 .045 .2642
Model
1

R R Square
Adjusted
R Square

Std. Error of
the Estimate

Predictors: (Constant), log of portfolioa.

ANOVAb

.236 1 .236 3.387 .072a

3.489 50 6.978E-02
3.725 51

Regression
Residual
Total

Model
1

Sum of
Squares df Mean Square F Sig.

Predictors: (Constant), log of portfolioa.

Dependent Variable: log of impulse buyingb.

Coefficientsa

.494 .058 8.507 .000

.348 .189 .252 1.841 .072
(Constant)
log of portfolio

Model
1

B Std. Error

Unstandardized
Coefficients

Beta

Standardi
zed

Coefficien
ts

t Sig.

Dependent Variable: log of impulse buyinga.

FIG 9
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Tips For Task 4

From the Analyze pull-down menu, select Regression, then choose Linear.

When the dialog box appears, select “lib” as the dependent variable and the

rest as independent variables (see Fig 10). Now, select statistics button and

click on the boxes of estimates, model fit, and descriptives (see Fig 11) and

then click on continue to return to the main regression dialog box. Finally, click

on the OK button to run the analysis (see Fig 12).

 FIG 10

 FIG 11
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Descriptive Statistics

.5771 .2703 52

.2384 .1956 52

.1447 .1519 52

.5486 .1883 52

log of impulse buying
log of portfolio
log of gender
log of age band

Mean Std. Deviation N

Correlations

1.000 .252 .118 -.126
.252 1.000 .017 .080
.118 .017 1.000 .063
-.126 .080 .063 1.000

. .036 .203 .186
.036 . .451 .286
.203 .451 . .329
.186 .286 .329 .

52 52 52 52
52 52 52 52
52 52 52 52
52 52 52 52

log of impulse buying
log of portfolio
log of gender
log of age band
log of impulse buying
log of portfolio
log of gender
log of age band
log of impulse buying
log of portfolio
log of gender
log of age band

Pearson Correlation

Sig. (1-tailed)

N

log of impulse
buying log of portfolio log of gender

log of age
band

Variables Entered/Removedb

log of age
band, log
of gender,
log of
portfolio

a

. Enter

Model
1

Variables
Entered

Variables
Removed Method

All requested variables entered.a.

Dependent Variable: log of impulse buyingb.

Model Summary

.316a .100 .044 .2643
Model
1

R R Square
Adjusted
R Square

Std. Error of
the Estimate

Predictors: (Constant), log of age band, log of gender,
log of portfolio

a.
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ANOVAb

.373 3 .124 1.780 .164a

3.353 48 6.985E-02
3.725 51

Regression
Residual
Total

Model
1

Sum of
Squares df Mean Square F Sig.

Predictors: (Constant), log of age band, log of gender, log of portfolioa.

Dependent Variable: log of impulse buyingb.

Coefficientsa

.581 .123 4.731 .000

.362 .190 .262 1.909 .062

.219 .244 .123 .896 .375
-.222 .198 -.155 -1.126 .266

(Constant)
log of portfolio
log of gender
log of age band

Model
1

B Std. Error

Unstandardized
Coefficients

Beta

Standardi
zed

Coefficien
ts

t Sig.

Dependent Variable: log of impulse buyinga.

FIG 12

In the interpretation of the t-statistics, we will be looking at its p-value. The

situations that you will need to interpret the p-value. If the p-value is less than

0.05 (0.01), the null hypothesis is rejected and the result is significant beyond

the 5 percent (1 percent level).

Tips For Task 5

Before we estimate the relevant regressions, we recommend you to create

two new variables as m (male) and f (female) by using Data > Insert Variable

(see Fig 13). These variables can be generated conducting by copy and paste

from the original gender variable. Then, decompose the gender variable using

Recode procedure into two groups such as male and female. Now, click on

Transform> Recode and select Into Same Variables (see Fig 14).
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 FIG 13

FIG 14

The resulting dialog box, shown in Fig 15, contains a list of your variables on

the left. Put the relevant one (i.e. male) into the right box and then click on old

and new values.

FIG 15

In the left column under Old Value and next to the word ‘Value’ type 2 and

then click in the box to the right, under New value, type 0. Finally, click on

Add and use Continue button when they are done. This procedure is for

male variable (see Fig 16). Then use 1 and 0 for Old value and New value to



Lecture 9: Regression Analysis by SPSS

14

create female variable respectively as in Fig 17. At the main recode dialog

box, click on OK to execute the changes as in Fig 18 and 19.

FIG 16

FIG 17

FIG 18

FIG 19
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Now, from the Analyze pull-down menu, select Regression, then choose

Linear. The dialog box will appear. Select “ib’ as the dependent variable and

“ab”, “p” and “f” or “m” as the independent variables (see Fig 20). Choose

statistics button and click on the boxes of estimates, model fit, and

descriptives and then click on continue to return to the main regression

dialog box. Finally, click on the OK button to run the analysis to get the

estimated results for both male and female separately (see Figs 21 and 22).

FIG20

Coefficients a

4.089 1.135 3.602 .001
-.236 .201 -.158 -1.173 .247
.841 .370 .305 2.276 .027
-.693 .588 -.159 -1.179 .244

(Constant)
age band
portfolio
male

Model
1

B Std. Error

Unstandardized
Coefficients

Beta

Standardi
zed

Coefficien
ts

t Sig.

Dependent Variable: impulse buyinga.

FIG 21
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Coefficientsa

3.396 1.082 3.139 .003
-.236 .201 -.158 -1.173 .247
.841 .370 .305 2.276 .027
.346 .294 .159 1.179 .244

(Constant)
age band
portfolio
female

Model
1

B Std. Error

Unstandardized
Coefficients

Beta

Standardi
zed

Coefficien
ts

t Sig.

Dependent Variable: impulse buyinga.

FIG 22

Table 1: Codebook for Impulse Buying questionnaire

Variable Label Impulse buying
Variable name IB

Values
0-3   not/less interested in purchasing share
4-7 more interested in purchasing share

8-10 most interested in purchasing share

Variable Label Portfolio
Variable name P

Values and its label 1   Infrequent
2  Occasional
3     Frequent

Variable Label Age Band
Variable name AB

Values and its label 1   16-20
2   21-30
3   31-40
4   41-50
5   51-60
6   61-70
7   71-80

Variable Label Gender
Variable name G

Values and its label 1   Male
    2  Female


