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CONCLUSION 

This project that I produced creates a HTLM program and a WEB 
page. I practised all formulas of HTLM. While I was creating this WEB page I 
used two different Browser. These are; WEB page in OFFICE 97 and Visual 
Page Browser. Both of them were very useful. Specialities and usage of 
Browser will be engaged following pages. 

Because of Turkey is Tourist paradise I preferred to engage with 
touristic hotels that they are beneficial for tourism. 

I like to write about my pages briefly: 
First one is Turkey page. Later again a new Turkey page. Meanwhile 

brief and essential assistant information. From this page it is very easy to enter 
to www.turk.org. and www.turk.org./ata5.html pages. And because I wrote 
about hotels province by province first I gave information about provinces. 
After that brief information from that pages and from hotel pages it is possible 
to enter hotels' page. 

What did I use while I was producing HTLM design and Web pages: 
Links that can be found in every Web page, these are Active Links, 

Hyperlink, I preferred to use them. By using Frame I create page. I used tables 
and Background pictures. To colour writings and creating Turkish flag I used 
Animation gif. Also by assistance of Java program via choosing any region of 
map I used link to another page. 
This is not my whole program that now I present you; this is a very small 
sample and my whole program will take place in Internet with its over 150 
pages context. Then h will be possible to see it by June 1998 in Internet. 
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CHAPTER A 

INTERNET 

Historical Background 
The first computer network became operational in the late 1960's, with USA 

taking a lead with the Department of Defence network ARP ANET, which linked 
research computer from the East to the West Coast, with a link to London to allow 
UK researchers to grew rapidly, and was later split up into three interconnected 
networks, with connections to many other network across the world. This vast 
interconnected network is often referred to as the INTERNET . 

. The Internet is a world - wide system that is currently used mainly by academics 
and scientists, but it is rapidly becoming commercialised due to its incredible success. 
In the early 1980's ways to connect ARPANET to other WAN' s (Wide area 
Networks) e.g. in Europe, were developed. An Internet system can therefore be 
viewed as a set of networks interconnected by Gateways. A GATEWAY is a 
computer that has connections to at least two different networks. The purpose of a 
gateway is to translate the methods used to transfer data an one network into the 
methods used by another network so that data can flow smoothly between different 
types of networks. An Internet system is show is below in Figure 1. 

Network 

G 

Network 
Network 

H 

H= Host Computer G= Gateways 
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Fig.1. An Internet System 

From this early work has grown the system known as the Internet which now 
interconnects sites world wide (literally millions of computers interconnected) There 
are about 100 million people currently using the Internet. By the year 2005. "the 
number of computers attached to the Internet will exceed the world's human 
population" (Computer Journal) of course, growth will slow down, but nevertheless 
the growth is an impressive fact. It is radically changing access to information , news 
distribution, collaboration between people in remote places. The growth of the 
Internet has equalled that of a child by almost doubling insize every year. 

The data available to casual users on the Internet has grown as fast as the 
Internet itself and terabytes. Products have been developed to manage the information 
about data and provide a way of finding the document, program or in general the 
bytes that are wanted. 

Early information was shared with email and ftp. Email is moderately easy to 
use. Information can be passed from one person to another, or groups of people could 
form a mailing list. Originally email was just a text message; it didn't have the 
capability to include programs and data files. 
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Technical Definitions: 

The Internet is very difficult to define. Principally because things change on the 
Internet with great rapidity; definitions that are appropriate at one time have little 
meaning later. However, here are some definitions. 

The Internet is: 
=> A World Wide network of networks as Kevin Hughes defined in "A Guide to 

Cyberspace" 
=> A co-operative interconnection as emphasised by VUNETS "Internet Q&A" 
=> A way to communicate and share resources as described in the "What is the 

Internet?" by the Internet Society. 
=> computers connected using the TCP/IP protocol suite, as specified in the NCSA 

Guide to the Internet. 
Therefore, we can define it as a co-operative global network of computer 

networks that communicate and share resources using the TCP/IP protocol. 
In simple terms, it is the means by which computers in one part of the world 

can communicate with other in parts other of the world as easily as with computers in 
the next room. 

The mechanism for doing this is known as the Internet Protocol(IP) and the 
Transmission Control Protocol(TCP). Together these are commonly known as TCP/IP 
connections. The Internet protocol was first developed when the US Government 
wanted to allow researchers to share computing resources by making them available 
across a network. The military establishment were also involved in this process and 
developed the network on the assumption that there would be break ages in the 
network. Thus the protocol does not rely on the existence of any particular computers. 

When two computers communicate using TCP/IP the message is broken into a 
series of small packets which are sent over the network. The Internet Protocol deals 
with sending the individual packets and the Transmission Control Protocol managers 
the process of putting the packets together again at the other end.(Usually a packet is 
512 bytes) 

TCP/IP is a relatively simple networking protocol and was soon made available 
on most computers, allowing different makes of computers to communicate easily. 
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Computers on the Internet are all given a unique Internet Address. This address 
is used to tell the network where to send its individual packets of data. The Internet 
address is normally written as four digits(between O and 255) separated by dots. 

For example: 158.143.103.60 

this, however is not particularly easily to understand and therefore most 
computers provide a human readable name. This name is again made-up of a series of 
parts. 

For example: VAX.RES.AC.UK 

The process of naming computers is organised in a distributed manner, as there 
is no'central organising committee' for the Internet. Reading from right to left, we see 
that the computer is in the UK and, in particular, in the academic community. There is 
a local organiser for the academic community which distributes names for UK 
academic communities. Similarly , in Turkiye 

Various Protocols 

TCP/IP is simply a method for sending packets of data from one computer to 
another. Internet applications are built up by adding extra protocol layers on top of 
these. These are simply rules that describe the kind of messages that can be sent over 
Internet using TCP /IP. 
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CUSEEME 

This is a relatively new protocol that supports on-line video conferencing over 
the Internet. It does this by allowing a computer, if it has the necessary hardware, to 
use a video camera and sends this picture to other computers on that conference. 
Other computers receive this data and display it locally. The limited amount of 
capacity on many parts of the Internet means that often the picture that is received is 
quite Jerky. 

Network News 

Another protocol is the NNTP protocol. This allows you to read news on a 
variety of topics. Essentially, there is a hierarchy of news groups that discuss various 
subjects. For example: talk.rumors focuses on true and false rumours. Individuals 
read this news and can respond by adding their own messages to the group. 
Soc.culture.turkish is a news list where people can discuss things about Turkiye and 
issues related to the Turkish culture. 

Telnet 

One of the original and still mostwidely used protocols is TELNET. This 
essentially allows you to log on to a computer across the Internet. Anything that you 
type in is sent using the TELNET protocol and the response from the remotecomputer 
is sent back. TELNET normally requires that you have an account on the remote 
computer, but it is also used to provide access to library catalogues. 

FTP 

FTP is related to TELNET and allows you to upload and download files from a 
remote computer. FTP is often done anonymously which allows you to download 
files from computers where you don't have an account. FTP is the most widely used 
protocol for downloading files, but is slowly being replaced by more useably front 
ends. 
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Gopher 

One of the fastest and relatively easy to use protocol is Gopher. When you log 
on to a computer using to Gopher protocol it sends you a list of all the information it 
has. This information is normally in the form of individual files or directories. These 
items are displayed on your own computer and you can then choose the one you want. 
If you choose a directory, the system presents you with all the information in that 
directory. 

The beauty of the Gopher protocol is that the files and directories that are listed 
do not have to be on the same computer. You can select a particular item and will be 
automatically a different part of the Internet to obtain sent that information. 

The World Wide Web 

The Gopher protocol is fast and effective and automatically moves you from 
one part of the Internet to another. It is limited, however to the concept of files and 
directories. Whilst this is easily understood by computer specialist, it is not so intivite 
to non-computer specialists. The world wide web protocol overcomes this by 
presenting the information as normal text document. It also possible to include 
graphics within web documents. Within these documents are hot-links to other parts 
of the document or other parts of the Internet. As with Gopher, these jumps are 
handled automatically and invisibly. 

World wide web documents are often viewed using packages like the Microsoft 
Internet Explorer and Netscape Navigator. 

UNIFORM RESOURCE LOCATORS (URLs) 

URL s are designed to help with all these different protocols Essentially, they 
provide a standard format for specifying the Internet Information you want to use. The 
format is normally: 
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Internet Service: II Internet address /Access information. 
For example: 

http:l/www.wired.com/index.html 
http://www.isoctr.org/ 
http:l/www.hurriyet.com.tr 

In this example, http specifies the protocol (hypertext transaction protocol), 
www.wired.com is the name of the computer and index. html is the file to be loaded 
and displayed . 

Searching the Internet 

The Internet is huge and grawing everyday. It also has no central controller so it 
can be very difficult to find information on the net. In order to solve this problem, a 
number of search engines have been developed. Some well-known search engines are: 

1. Altavista (http:l/www.altavista.digital.com) 
2. Yahoo! (http:l/www.yahoo.com) 
3. Lycos (http:l/www.lycos.com) 
4. Webcrawler (http:l/www.webcrawler.com) 
5. lnfoseek (http:l/www.infoseek.com) 
6. Excite (http:l/www.excite.com) 

These normally work by creating a monthly list of everything they know about 
(for example, all the FTP files in all the FTP sites that are known), indexing these lists 
and allowing people to search these indexes. the results are then displayed in the 
appropriate format. 

ARCHIE 

Archie is the search engine for FTP sites. Archie normally only works on the 
basis of file names and related descriptions and so is best used if you know the name 
of the file you are looking for. 
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VERONiCA and JUGHEAD 

These are two search engines for GOPHER sites. They normally index all the 
worlds in the Gopher descriptions and you can perform Logical searches on them,for 
example, all the Gopher elements that contain both information and security. 

CUI and L YCOS 

Indexing world wide web files in much more difficult but these two facilities 
aim to provide results of web files searches. 

www.neu.edu.nc.tr/engf/index.html 

Image File Extensions on the Internet 

.gif 

.Jpg 

Introduction to HTML Language 

A simple Example 

<HTML> 
<HEAD> 
<META HTTP-EQUIV="Content-Type" CONTENT="text/html; charset=iso- 

8859-1 "> 
<META NAME="Author" CONTENT="metin taskm"> 
<META NAME="GENERATOR" CONTENT="Mozilla/4.02 [en] (Win95; I) 

[Netscape]"> 
<TITLE>index</TITLE> 

</HEAD> 
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<BODY> 
<CENTER><FONT COLOR="#330000"><FONT 
SIZE=+ 2></FONT></FONT></CENTER> 
<CENTER><FONT F ACE="Baskerville Win95BT Tur"><FONT 
COLOR="#330000"><FONT SIZE=+2>AMERICAN 
BIRDS</FONT></FONT></FONT></CENTER> 
<CENTER><FONT F ACE="Baskerville Win95BT Tur"><FONT 
COLOR="#330000"><FONT 
SIZE=+ 2></FONT></FONT></FONT></CENTER> 
<CENTER><FONT F ACE="Baskerville Win95BT Tur"><FONT 
COLOR="#000099"><FONT SIZE=+ l>BIRD 
CLASSIFICATION </FONT></FONT></FONT></CENTER> 
<CENTER><FONT F ACE="Baskerville Win95BT Tur"><FONT 
COLOR ="#000000"></FONT></FONT>&nbsp;</CENTER> 

<OL> 
<LI> 
<FONT F ACE="Baskerville 
COLOR="#OOOOOO">HERONS &amp; 
BITTERNS</FONT></FONT></LI> 

Win95BT Tur"><FONT 

<LI> 
<FONT F ACE="Baskerville 
COLOR="#OOOOOO">DUCK, GEESE 
&amp; SW ANS</FONT></FONT></LI> 

Win95BT Tur"><FONT 

<LI> 
<FONT F ACE="Baskerville Win95BT 
COLOR ="#000000"></FONT></FONT></LI> 

Tur"><FONT 

</OL> 
<CENTER><FONT F ACE="Baskerville 
COLOR ="#000099"><FONT 

Win95BT Tur"><FONT 

SIZE=+ 1 ></FONT></FONT></FONT>&nbsp; </CENTER> 
<CENTER><FONT COLOR="#330000"><FONT 
SIZE=+ 2></FONT></FONT>&nbsp;</CENTER> 
</BODY> 
</HTML> 
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What Software to Use For Writing HTML Programs 

1. Nodepad (under Accessories Directory in win95, also available or win3.1) 
2. Write (available or both win95& win 3.1) 
3. World (any version) (available or both win95& win 3.1) 
4. Netscape Communication 
5. Any other text editor. 

File Extension 

All HTML programs should have either. .htm or html extension. We shall later 
in the course that some files use .shtml extension. 

All image files that you use in your programs should either be in GIF format or 
JPG (also written as JPEG) 

TAG REFERENCE 

Document Formatting 

Tag Description 

<html> HTML document indicator 
<head> Document head 
<body> Document body 
<address> Owner/ Contact 
<title> Title 
<! ... > Comment 
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Paragraph Formatting 

Tag Description 

<blockquate> Blockquate 
<p> Paragraph 
<hr> Line break 
<hr> - Horizontal rule 
<pre> Preformatted text 

Character Formatting 

Tag Description 

<em> Emphasised 
<var> Variable 
<cile> Litation 
<i> Italic 
<strong> Strong 
<b> Bold 
<code> Code 
<samp> Sample 
<kbd> Keyboard 
<tt> Teletype 
<key> Keyword 
<dfn> Dfn 
<strike> Strike through 
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List Formattipg 

Tag Description 

<Ii> List item 
<ul> Unnumbered list 
<ol> ordered list 
<menu> Menu list 
<dir> Directory list 
<di> Description list 
<dt> Data term 
<dd> Data deser 

Anchor Formatting 
Tag Attribute Description 

Anchor hyper link 
href Points to destination of link 

<a> name Defines a named anchor so that a 
link can point to a place in a 
document not just to the document 
itself 
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Tag Attribute Descri~tion and Notes 
<img> 

src 
align 

alt 

ismap 

Incorporates images in a document 
The href for the image 
Aligns text, starting at the top, middle, 
or bottom the side of an image 
A name that can be displayed an 
browser that "' don't have image 
capabilities 
Activates the image so that the browser 
returns a set of x,y cordinates at which 
the image was clicked. 
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Table Formatting 

Tag Attribute Descri_etior, and Notes 
<table > I I Defines the table 

border Adds borders to separate rows and 
colums in tables 

<tr> I I Marks the end/start a table row 
Modifies 

<td> I I Encloses a cell of table data 
colspan Modifies the number of columns a cell 

will span 
rowspan I Modifies the number of rows a cell will 

span 
align I Defines the horizontal text alignment 

within a cell 
nowrap I Declares that the cell text cannot be 

broken up to wrap from one line to the 
text 

<th> I I Encloses a cell of table heading 
colspan Modifies the number of columns a cell 

will span 
rowspan I Modifies the number of rows a cell will 

span 
align I Defines the horizontal text alignment 

within a cell 
nowrap I Declares that the cell text cannot be 

broken up to wrap from one line to the 
text 

<caption> I I Creates a title for the table, outside 

GIF - The graphics interchanges format developed in 1987 by people from 
computer serve. This bitmapped format come into being because people wanted to 
exchanged images between different platforms. 

This format is now used on almost every platform that support graphical 
application. GIF format is not only a standart image type for WWW browser, it is 
also the only image type that can be used for inline images on all platforms. The one 
drawback of GIF format is that it is limited to 256 colours. 
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An extended standard called GIF89A was developed to add functionality for 
specific applications. The most no table use of this extended standard in web pages is 
the use of transparent backgrounds. Images can appear to float by making the 
background colour the same as the background of the browser. However browser 
don't always came with the plain grey background, and the user can override the 
choice of background colour as transparent compensates for the users specific 
configuration. 

JPEG - A bitmap format with compression that was designed and named after 
the Joint Photographic Expert Group: JPEG isn't used as often as the other formats 
but it is the basis for the most common moving image format, MPEG. In addition, the 
newest browser on the block, Netscape communicator row offers support for inline 
JPEG images. 

TIFF - The Tagged Image File Format designed by Microsoft and Aldus for 
use with scanners and desktop publishing programs. Most external viewers support 
this format. 

VIDEO STANDARTS 

MPEG - An animated video standard, format based on the JPEG methods. 
Like JPEG, the format received its name from the group that defined the standard 
Motion picture Experts Group. This is the most common movie format for WWW, 
primarily because viewers exist for all platforms. 

AVI - The movie format for Microsoft Windows. Use of this format isn't 
recommended until browsers for other platforms become common. 
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TCP/IP & INTERNET STRUCTURE 

Introduction: 
Data communication between places is the principle of computing. In the early 

days, this was quite hard. In the late 1970 s, networks have been developed and these 
evolved into host networks that were attached to a single packet-switched network. In 
the middle 1980s, various economic and technological factors have energised that 
made it possible to interconnect many physical networks. This new technology is 
called internetworking, and it hides the underlying details of actual networks, in order 
to provide a uniform service across networks. 

The Internet is an example of open systems interconnection(OSI). In on Internet 
structure, several networks are connected together through the use of gateways and 
Internet working protocol(as discussed earlier). The main advantage of an Internet 
structure is that it provides universal interconnection while allowing individual groups 
to use whatever network hardware is best suited to their needs. 

Network 

G-Gateways 

Network 

Network 
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In addition, the term Internet is used when making a generic reference to a 
network built using internetworking technology and the term Internet is used when 
specifically referring to this network. 

The transmission Control Protocol(TCP) 

The transmission Control Protocol, TCP, defines a key service provided by the 
Internet, namely, reliable, stream delivery and it provides a full duplex connection 
between two machines, allowing them to exchange large volume of data efficiently. 

The internet Protocol(IP), defines the IP datagram as the unit of information 
passed across the internet and provides the basis for connectionless, best-effort packet 
delivery stream. 

Message 

Packet Packet 

The TCP is part of the TCP/IP Internet protocol suite, it is an independent, 
general purpose protocol that can be adapted for use with other delivery systems. It is 
possible to use it over a single network like an Ethernet, which is popular Local Area 
Network(LAN ) technology invented at the Xerox corporation Polo Alto Research 
Centre , as well as over a complex Internet, because TCP makes very few assumptions 
about the underlying network. TCP is one of the International Standards 
Organisation(ISO) open system protocols. 

The most important services that TCP provides for its users include: connection 
orientation, sequencing, security against lost connection orientation, sequencing, 
security against loss connection monitoring, multiplexing, flow control, transparent 
data transport and secure connection establishment, release, IP has the ability to: 
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~ transmit messages over an internetwork. 
~ address each partner uniquely 
~ decompose and recombine packets according to the current network 

convertions. 
~ transmit certain information about the packet sequence and security features 

TCP Service Interfaces 
With its host-to-host communication, TCP/IP support the part/socket concept. A 

host, represented by its various application packages, may be viewed as providing a 
set of sockets, into which the desired connections, which are linked to I/0 ports of 
relevant applications by the main of many be plugged. Some sockets and ports are 
reserved for certain standardised application as shown below. 

PROTOCOL DESCRIPTION WELL-KNOWN PORT 
ARP Address Resolution Protocol - 
AUTH Authentication Service 113 
BO OTP Boot Strap Protocol 67,68 
ECHO ECHO Protocol 7 
FTP File Transfer Protocol 20-21 

GRAPHIC Graphics Exchange Protocol - 
MPM Exchange Multimedia Protocol 46 
LDP Load Debugger Protocol - 
LPR line Printer Protocol 514 
NNTP Network News Transfer Protocol 119 
NFS Network File System 2049 
RJE Remote Job Entry - 
RLP Resource Location Protocol 39 
SMTP Simple Mail Transfer Protocol 25 

TELNET Remote Terminal Protocol 23 
TFTP Trivial File transfer Protocol 69 
UDP User Datagram Protocol - 
X X- window System 6000 

STATSRV Sending Gateway Statics 95 
The most important TCP services are: 

OPEN- Open a virtual connection to a partner or wait until the connection is 
opened by an arbitrary or a specific partner. A time-out condition may be given. 

SEND- Deliver a data buffer to TCP for transmission to the other partner. A 
push flag may be used to force the full data transfer, otherwise the nature of the 
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execution is at the discretion of TCP. An URGENT flag may be used for express 
packets which must receive priority handling. 

RECEIVE- Receipt of data from the partner, with entry of size of the 
available buffer. TCP informs the clients process whether the PUSH or URGENT 
flags were set by the partner. 

CLOSE- Release of a virtual connection. 
STATUS- This service is only of a local nature and its fictions depend on the 

form of the current TCP implementation (in other words, which connection-related 
status/statistical data is made available). 

Connection Establishment 

Connection establishment between two TCP partners is based on the so-called 
"three way hardshake " principle. This mechanism reduces the possibility of the 
establishment of false connections. 

The following error situations may arise. 

=> Simultaneous establishment of a connection by each of the two partners 
involved. 

=> Multiple establishment of a connection by the initiator. Because of a time out 
for the first connection-establishment request. 

=> Unwanted establishment of a connection before the previous connection is 
released. 
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Data Transfer 

Once a connection is established between two partners data packets may be 
exchanged. Since these could be lost or rendered worthless as a result of errors or 
overloading of then network, TCP initiates a transmission repeat after the time-out 
condition expires. 

This way lead to duplicated data packets, which TCP detects using a special 
sequence numbering. 

Sequence Numbering 

Each data octet (8 bits=byte) transmitted by TCP is assigned a sequence 
number. This means that, in principle, the receipt of each octet can be confirmed. This 
is implemented in such a way that the confirmation of octet number n implicitly 
confirms the receipt of cell previous octets. Thus, duplicated segments are detected by 
the receiver and do not require special treatment. Sequence numbers run from O to 
232 -1. 

WINDOWS MECHANISM 

While in other protocols, such as HDLC(High Level Data Link Control) or X25 
level 3, the transmission window relates to the number of packets still to be 
transported from the sender to the recipient, because of the sequential numbering of 
octets, TCP uses a different mechanism. Here, a recent tells the sender the sequence 
number of the last octet which it has sufficient buffer space to receive. Unlike the 
above protocols, this provides for very dynamic management of this window. As soon 
as a recipient has a higher load and, thus possibly less buffer space, it can make this 
known to its partner. 
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Transmission Watchdog 

Each data packet transmitted is monitored so that a transmission repeat takes 
place if no acknowledgement is forth coming within a given interval (retransmission 
time). This interval depends heavily on the network type, the dimensioning of the 
network and the wrens network load. To frequent transmission repeats load the 
network unnecessarily too long a waiting period decreases the throughput possibly 
considerably. Thus, for each data packet, TCP continuously determines the time until 
the expiring of the acknowledgement period and thus is able to reset the 
retransmission timer adaptively. 

TCP Internet Protocol(IP) 

The Internet protocol, IP, defines the unreliable, connectionless delivery 
mechanism. IP provides three important definitions. First, the IP as a protocol defines 
the Internet datagram( or IP datagram). Second, IP software performs the routing 
function. Third, IP includes a set of rules that embody the idea of unreliable packet 
delivery. These rules characterise how hosts and gateway(router) should process 
packets how and when error messages should be generated , and the conditions under 
which packets may be discarded. 

A route is the path that network traffic takes from its source to its destination. IP 
datagram contains a source and destination IP, address, fragmentation controls, 
precedence and checksum used to catch transmission error along with data. In a 
TCP/IP datagram Internet each IP datagram, which is basis unit of information passed 
across a TCP/IP Internet, is may include may gateways and many physical network. 
Both hosts and gateways participate in IP routing. When an application program on a 
hosts attempts to communicate, the TCP/IP protocols eventually generate one or more 
IP datagrams. The host must make a routing decision when it chooses where to send 
the datagrams. 
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Datagram Delivery Over A Single Network 

Transmission of an IP datagram between two machines on a single network 
does not involve gateways. The sender encapsulates the datagram in a physical frame, 
binds the destination IP address to a physical hardware address, and Internetwork 
sends the resulting frame directly to the destination. 

Because the Internet addresses of all machines on a single network include a 
common network id, and because extracting that id can be done in a few instructions, 
testing whether a machine can be reached directly is extremely efficient. 

Internet Address 

Universal Identifiers: 

If a communication system allows any host to communicate with any other host, 
it is said to supply universal communication service. To make our communication 
system universal, we need to establish a globally accepted method of identifying 
computers that are attached to it. A name identifies what an object is an address where 
it is, and a route tells us how get there. Ingeneral pronounceable name to identify 
machines are preferred by the people. 

Three Primary Classes of IP Addresses 

For address, the designers of TCP/IP choose a scheme analogous to physical 
network addressing in which a host on the Internet is a assigned an address called an 
IP address. 

The clever part of Internet address is that Integers are carefully chosen to make 
rating efficient. 

An IP address encodes the identification of the network to which a host attaches 
as well as the identification of a unique host on that network. 

Each host on a TCP/IP Internet is assigned a unique 32-bit address that is used 
in all communication with that host. 

- 22 - 



NEAR EAST tlNIVERSTY 
COMPUTER lNQ/NEER/NQ 

1988 

Each address is a pair. One of the pair netid, identifies a network, and the other 
one, hostid, identifies a host on the network. 

Each IP address must have one of the first three forms shown below. 

0123 8 16 24 31 

Class A lo netid I hostid I Class A> 216 
14 

Class B I, 10 netid I hostid I 256<Class B<216 
28 

Cl ass C I 100 neti d I hostid I Class C < 256 

Class D I 1110 Multi Cost Address 

Class E 111110 Reserved For Future usJ 

An IP address can be determined from the three high order bits in a 
given IP address . Class A addresses are used for networks that have more then 
216(i.e.65.336) hosts. Class A bits devote 7 bits to netid and 24 bits to hostid. Class B 
addresses are used for intermediate size networks that have between 2\i.e.256) and 
216 hosts, and allocate 14 bits to the netid an 16 bits to the hostid. Class C networks 
have less then 28 hosts, and allocated 21 bits to the netid and only 8 bits to the hostid. 

The 32 bit Internet number or IP address is commonly represented as for 
numbers joined by period i.e.145.32.217.130 

The fourth part of this address identifies the host machine, the remainder 
identify the sub-network on which the machine resides. Class C network are typically 
LANs. 

Since users do not usually want to have to remember addresses in the form of 
numbers, a name-to- number service is available, called the Domain Name 
Service(DNS). DNS servers exchange information to allow a user to communicate 
with any other machine on the Internet simply by giving its name. One disadvantage 
of this addressing scheme is that if a host moves to another network, its Internet 
address must change. 

Example: Arpanet->- Class C 
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Difference Between Frames & Tables 

Use frames if you want to preserve the same layout an all your options. No need 
to reload the same section every time you choose an option. User can enlarge or 
arrange individual pages(frames)as required. 

Disadvantage of Frames 

Some browser can not view frames and generate an error messages. To cater for 
this when you create frames some HTML editors enable you to prepare text based 
version of pages using frames. 

Still, tables are more popular than frames. With tables you can produce, 
interesting effect and can use them for obtaining a nice layout. If you cheese border 
thickness=O then people cannot easily understand that you are using tables but this 
allows you to obtain nice layouts. 
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USING WORD PAGE 
WORKING WITH ONLINE AND INTERNET DOCUMENTS 

NAVIGATING 
Go to a page, bookmark, footnote, table, comment, graphic, or other location 
1 On the Edit menu, click Go To. 

Show me 

2 In the Go to what box, click the type of item. 
3 To go to a specific item, type the name or number of the item in the Enter 
box, and then click Go To. 

To go to the next or previous item of the same type, leave the Enter box empty, and 
then click Next or Previous. 

Tip For a quick way to go to the next or previous item, click Select Browse Object 
on the vertical scroll bar, and then click the item you want. You can click Next or 
Previous to go to the next or previous item of the same type. 
Navigate by using hyperlinks 
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When a Word publication or Web page contains hyperlinks to other locations% for 
example, to locations in the same file, or to files on the network or the Internet 
% you can move to these locations by clicking the hyperlink display text or image. 
When you point to the display text of a hyperlink, the pointer becomes a hand . 

In a file or Web page that contains hyperlinks, click the display text or image 
of a hyperlink. 

When a hyperlink is followed % that is, when you click the display text and jump to 
another location% the Web toolbar appears. 

Click Back to return to the original location in your Word publication. 
Click Forward to return to the file whose hyperlink you followed. 

Navigate by using the Document Map 

The Document Map is a separate pane that shows an outline of a document's 
headings. You can use the Document Map to quickly navigate around the document 
and keep track of your location in it. For example, click a heading in the Document 
Map to instantly jump to the related part of the document. 
Word automatically displays the Document Map in online layout view, but you can 
display it in any view. 
) 

1 
2 

Click Document Map 
In the Document Map, click the heading you want to go to. 

Word displays the heading at the top of the page. In the Document Map, the heading 
is highlighted to show your location in the document. 
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WORKING WITH DOCUMENTS ON INTRANENTS AND THE INTERNET 

Documents on the Internet 

If you have access to the Internet (for example, if you have a modem and an Internet 
account through an Internet service provider, or if you are in a corporation and have 
access through the network), you can open documents on the World Wide Web or 
anywhere on the Internet from the Open dialog box in your Office programs. You can 
also add FTP sites to the list of available Internet sites. And if your company has an 
intranet, you can open documents there. In addition, if you have the access rights and 
the FTP site supports saving files, you can save documents to the Internet from the 
Save As dialog box in your Office programs. 

Use Microsoft Excel, Word, PowerPoint, and Microsoft Access to browse Office 
documents that contain hyperlinks, whether the document is on your computer, on a 
network drive, or on the Internet. You don't have to be on the Internet to use 
hyperlinks in Office documents. 
The Web toolbar is available in your Office programs to make it easy to browse 
documents that contain hyperlinks. Use the Web toolbar to open a start page or a 
search page in your Web browser. Also from the Web toolbar, add interesting 
documents you find on the Web to the Favourites folder to gain access to them 
quickly. The Web toolbar keeps a list of the last 10 documents you jumped to by 
using either the Web toolbar or a hyperlink so you can easily return to these 
documents again. 

Add an FTP site to the list of Internet sites 

You can add an FTP site to the list of Internet sites to make it easier to open a 
document at an FTP site. To do this procedure, your company must have an intranet, 
or you must have access to the Internet (for example, you may have access by using a 
modem and an Internet account through an Internet service provider, or through the 
network if you are in a corporation). For information about how to set up Internet 
access, see the Microsoft Office 97 Resource Kit. For information about how to 
obtain the Office Resource Kit, click 

1 Click Open . 
2 In the Look in box, click Add/Modify FTP Locations. 
3 In the Name of FTP site box, type the FTP site name; for example, type 
ftp://ftp.microsoft.com/ 
4 If you want to log on to an FTP site that allows anonymous log on, click 
Anonymous. 
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If you want to log on to an FTP site that you have user privileges for, click User, and 
then type your password. 

5 Click Add. 

Remove an FTP site from the list of Internet sites 

1 Click Open . 
2 In the Look in box, click Internet Locations (FTP). 
3 Right-click the FTP site you want to remove, and then click Remove on the 
shortcut menu. 

Change the logon name or password for an FTP site 

You can change the way you log on to an FTP site. To do this procedure, your 
company must have an intranet, or you must have access to the Internet (for 
example, you may have access by using a modem and an Internet account through an 
Internet service provider, or through the network if you are in a corporation). For 
information about how to set up Internet access, see the Microsoft Office 97 Resource 
Kit. For information about how to obtain the Office Resource Kit, click 

1 Click Open . 
2 In the Look in box, click Internet Locations (FTP). 
3 Right-click the FTP site you want to change, and then click Modify on the 

shortcut menu. 
4 Change the options you want. 
Learn about installing and using Web page authoring tools 

Microsoft Word and some other Microsoft Office programs provide Web page 
authoring tools to help you easily create Web pages for intranets and the World 
Wide Web. If you haven't already installed these tools, you can rerun Set-up to install 
them and to install more Help topics about using them. 
When authoring Web pages in Word, you can use many familiars Word features, such 
as spelling and grammar checking, AutoText, and tables. Some features, such as 
graphical bullets and lines, are customised to make Web authoring easier. Features 
that aren't supported by HTML are not available when authoring Web pages. 

To install the Web page authoring features, select the Web Page Authoring (HTML) 
check box in Set-up. For more information about installing components of Office, 
click . 
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Open the Web start page 

When you start a World Wide Web browser, the start page is the first page that 
appears in the browser. You can set this location to any Web site you want or to a 
document on your computer hard disk. You can open the start page from the Web 
toolbar. A start page may contain hyperlinks to other documents on your computer, 
on the network, or on the Web. 
To do this procedure, you must have the Web toolbar displayed. On the View menu, 
point to Toolbars, and then click Web. 

On the Web toolbar, click Start Page 

Change the Web start page 

To do this procedure, the Web toolbar must be visible. On the View menu, point to 
Toolbars, and then click Web. 

1 Open the document you want to use as the start page. 
2 On the Web toolbar, click Go, and then click Set Start Page. 
3 Click Yes. 

Open the Web search page 

A search page provides an organised way to find and go to other Internet sites or to 
documents on an intranet. Many search pages provide the capability to search by 
topic or by keyword. Others simply provide an well-organised list of hyperlinks to 
selected Internet sites or to documents on an intranet. You can open the search page 
from the Web toolbar. 
To do this procedure, you must have the Web toolbar displayed. On the View menu, 
point to Toolbars, and then click Web. 

On the Web toolbar, click Search the Web 

Change the Web search page 

To do this procedure, the Web toolbar must be visible. On the View menu, point to 
Toolbars, and then click Web. 

1 Open the document you want to use as the search page. 
2 On the Web toolbar, click Go, and then click Set Search Page. 
3 Click Yes. 
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Open recently browsed files 

To do this procedure, you must have the Web toolbar displayed. On the View 
menu, point to Toolbars, and then click Web. To open the previous document in the 
history list, click Back on the Web toolbar. 

To open the next document in the history list, click Forward on the Web toolbar. 

Cancel a jump that takes too long 

To do this procedure, you must have the Web toolbar displayed. On the View menu, 
point to Toolbars, and then click Web. 

On the Web toolbar, click Stop Current Jump 

Refresh the display of the current file or Web page 

When you work in a document on the World Wide Web that contains hyperlinks, 
the author may modify the document while you have it open. When you update a 
document, the document is refreshed from the original file that is located on the 
network server, the Internet, or your computer hard disk. 
To do this procedure, you must have the Web toolbar displayed. On the View menu, 
point to Toolbars, and then click Web. 

On the Web toolbar, click Refresh Current Page 

Add the active document to Favourites 

When you open a document on the Internet, World Wide Web, intranet, or even on 
your computer hard disk, add the document to the Favourites folder so you can open it 
again without having to remember the path you typed to get the document the first 
time. 
To do this procedure, you must have the Web toolbar displayed. On the View menu, 
point to Toolbars, and then click Web. 

On the Web toolbar, click Favourites, and then click Add to Favourites. 

Hide all toolbars except the Web toolbar 

To do this procedure, you must have the Web toolbar displayed. On the View menu, 
point to Toolbars, and then click Web. 

On the Web toolbar, click Show Only Web Toolbar 
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Tip To show the toolbars that are hidden, click Show Only Web Toolbar on the 
Web toolbar. 

I can't open a document on the Internet. 

You must have access to the Internet (for example, you may have access by using a 
modem and an Internet account through an Internet service provider, or through the 
network if you are in a corporation) to open files at an FTP site or on the World 
Wide Web. For information about how to set up Internet access, see the Microsoft 
Office 97 Resource Kit. For information about how to obtain the Office Resource Kit, 
click. 

If you have these things, the site may be too busy. Try to open the document 
later. 

The Web Find Fast search page 

Microsoft Office ships with a search page you can use to find files on the intranet. 
The Web Find Fast search page makes it quick and easy to find a file you know exists 
even when you don't know where it's located. The Web Find Fast search page also 
makes it easy to find all of the information available on any subject. You can also 
quickly locate information outside of your workgroup, such as the quarterly report for 
your company, or all files that refer to company policies. 

To obtain the Web Find Fast search page, see your administrator. 

WORKING WITH HYPERLINKS 

Create hyperlinks 

You can enrich Web pages and Word publications that others read online by 
inserting hyperlinks to other items. The hyperlink can jump to a location in the 
current document or Web page, to a different Word document or Web page, or to a 
file that was created in a different program. You can even use hyperlinks to jump to 
multimedia files, such as sounds and videos. 
The destination the hyperlink jumps to can be on your hard disk, on your company's 
intranet, or on the Internet, such as a page on the World Wide Web. For example, 
you can create a hyperlink that jumps from a Word file to a chart in Microsoft Excel 
that provides more detail. A hyperlink is represented by a "hot" image or display 
text% that is often blue and underlined% that the reader clicks to jump to a different 
location. 
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Use the automatic formatting features for Word documents and Web pages when you 
know the addresses to jump to or when you have a document that contains file names 
or addresses that you want to format as hyperlinks. Use Insert Hyperlink to insert a 
hyperlink into Word files and Web pages when you aren't using the automatic 
formatting features or when you want to browse for the destination address. Use a 
drag-and-drop operation in Word files when you want to use the mouse to quickly 
create a hyperlink for text located within another Office file. 

Change the display text or image of a hyperlink 

You can change the display text or image of a hyperlink % the "hot" text or image that 
a user clicks to follow the hyperlink % as you would edit any text or image in your 
document or Web page. To avoid following the hyperlink, or opening the file you're 
inserting the hyperlink to, it's usually best to use the keyboard to select the image or 
text you want to change. 

1 Click outside of the text or image. 
2 Press the arrow keys until your insertion point is located just to the left or the right 
the image or text you want to change. 
3 Hold downs SHIFT and press an arrow key until the text or image is selected. 

Hold down CONTROL+SHIFT to select whole words. 

4 Edit the image or text. 

Remove a hyperlink 

1 Right-click the hyperlink you want to remove, point to Hyperlink on the 
shortcut menu, and then click Edit Hyperlink. 
2 Click Remove Link. 

Tip To remove a hyperlink and the display text or image that represents the hyperlink 
in the document, select the hyperlink, and then press DELETE. 

Change the appearance of all hyperlinks in Word documents 

This procedure doesn't affect hyperlinks on Web pages. For more information about 
changing text colours in Web pages, click . 

1 Open the document that contains the hyperlinks you want to change. 
2 On the Format menu, click Style. 
3 To change the appearance of a hyperlink, click Hyperlink in the Styles box, 
and then click Modify. 
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To change the appearance of a followed hyperlink, click FollowedHyperlink in the 
Styles box, and then click Modify. 

4 Click Format, and then click Font. 
5 Select the options you want. 

Tips 

To use animated text, click the Animation tab in the Font box, and then click 
the option you want in the Animations box. For instance, you could use Las Vegas 
Lights or Sparkle Text to point out the hyperlinks in your document. 

To use the modified Hyperlink or FollowedHyperlink style in new documents 
based on the same template, select the Add to template check box in the Modify 
Style dialog box. Word adds the modified style to the template attached to the active 
document. 

Change the hyperlink destination 

1 Right-click the hyperlink you want to change, point to Hyperlink on the 
shortcut menu, and then click Edit Hyperlink. 
2 Select the options you want. 

Set a hyperlink base for a document 

When you create a hyperlink in a document, you can make the path to the 
destination of the hyperlink a fixed file location (absolute link), which identifies the 
destination by its full address, such as c:\My Documents\Sales.doc, or you can make 
the path a relative link. Use a relative link if you want to move or copy the file that 
contains the hyperlink or the destination file to a new location. To change the path of 
the relative link, set a hyperlink base for the document. 

1 Open the document you want to set a hyperlink base for. 
2 On the File menu, click Properties, and then click the Summary tab. 
3 In the Hyperlink base box, type the path of the relative link you want to use 

for all the hyperlinks you create in this document. 
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CREATING AND WORKING WITH WEB PAGES 

CREATING WEB PAGES 
Create a Web page 

Word offers two easy ways for you to create Web pages. You can start a new page by 
using a wizard or template, or you can convert an existing Word document to HTML, 
the format used for Web pages. When you create a Web page with either of these 
methods, Word customises some toolbars, menu commands, and options to provide 
the Web page authoring features. 

Using the Web page authoring features to create your Web page will usually produce 
the best results. You can use the Web Page Wizard to start with sample content% 
such as a personal home page and registration form % and graphical themes % such as 
festive and community% to help you quickly creates a Web page. If you prefer, you 
can start with a blank Web page. For information about many of the features you can 
use in Web pages, click . 

Use the HTML conversion method when you have existing Word content that you 
want to quickly convert to a Web page. The formatting and features that are supported 
by HTML will be converted. For more information, click 

What do you want to do? 

Create a Web page from a wizard or template 
Save a Word document in HTML format 

Items you can add to Web pages 

You can make Web pages look more interesting by adding bullets and numbering, 
horizontal lines, background colours and textures, tables, pictures, videos, scrolling 
text, and forms. You add most of these items in much the same way as you do in a 
Word document. However, to make Web page authoring easier, Word offers some 
new and some customised commands for this purpose. 
Obtain more Web page graphics and templates from the Microsoft Web site 

Additional bullets, textured backgrounds, horizontal lines, and templates are available 
on the Microsoft Web site. If you have access to the World Wide Web, you can 
obtain these items to use on your Web pages. 
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Tips for creating Web pages 

There are many opinions about the best way to structure and design Web pages. You 
can find many tips, examples, and style guides on the World Wide Web. Here are 
some tips that apply to most Web pages: 

Content should be well organised. Well-structured pages help you deliver 
ideas effectively and help the reader navigate through your site. For more information, 
click . 

Text on Web pages should be easy to read. If you add a background to your 
Web page, it should contrast with the text colour. For more information, click . 

Web pages may not look the same in different Web browsers. It's a good idea 
to plan your Web pages so they are viewable in most browsers. For more information, 
click . 

Large images increase download time, especially for readers who gain access 
to Web pages by modem. Although graphics can make Web pages more interesting, 
you should use graphics strategically. For more information, click . 

Some users tum off the display of images, and some Web browsers don't 
support all video formats. When images and videos contain information that you don't 
want readers to overlook, you can use alternative text for graphics and alternative text 
and images for videos. For more information, click . 

You can use tables as a layout tool. For example, HTML, the format for Web 
pages, doesn't support newspaper columns, but you can create a two-column effect by 
using tables. For more information, click . 

Add a background sound to a Web page 

You can have a background sound play automatically when someone opens your Web 
page. 

1 On the Insert menu, points to Background Sound, and click Properties. 
2 In the Sound box, enter the address, or URL, of the sound file you want, or 
click Browse to locate the file. 
3 In the Loop box, click the number of times you want the sound to repeat. If 
you want it to loop continually while the Web page is open, click Infinite. 
4 To copy the sound to the same folder as your Web page, select the Copy to 
document folder check box. To use a relative path, a path that's relative to your 
current page, select the Use relative path check box. 

For more information about managing files for Web pages, click 

Notes 
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To review the sound while you are authoring the Web page, point to 
Background Sound on the Insert menu, and then click Play. To stop the sound, click 
Stop. 

For others to hear background sounds, they must have a sound system 
installed, and their Web browser must support the sound format of the file you 
inserted. You can insert sound files in WAY, MID, AU, AIF, RMI, SND, and MP2 
(MPEG audio) formats. 

The background sound plays automatically every time your page is opened or 
returned to. For frequently opened pages, such as home pages, this repetition could 
become annoying. You could add the background sound instead to a page that the 
user is likely to jump too less frequently. Or you could insert a hyperlink that the user 
can click to download a sound file. For more information about inserting hyperlinks, 
click . You may want to use caution when selecting Infinite for a looping option, 
because the sound will play continually when the user opens the page. 

Add a horizontal line to a Web page 

Horizontal lines are used often on Web pages to separate logical sections of text. 

1 Click where you want to insert the line. 
2 On the Insert menu, click Horizontal Line. 
3 In the Style box, click the line that you want, or click More to select a 
different line. 

Notes 

A Web browser will draw the first line in the Style box when someone opens 
the page. The other line styles are graphical images. When you save this Web page, 
the line will be saved as an image, such as image.gif, image 1.gif, in the same location 
as the Web page. If you move the Web page % for instance, when publishing the 
page % you should also move the image of the line. For more information, click . 

To quickly insert another line with the same style, click Horizontal Line 

Add a video to a Web page 

You can add an inline video to your Web page, which means the video is downloaded 
when the user opens the page. You can determine whether the video will play when 
the page is opened or when the user points to the video with the mouse. Because not 
all Web browsers support inline video, you may want to provide alternative text and 
images or avoid presenting essential information in videos. 
It's recommended that you save your document before inserting videos. For more 
information about managing files and links, click . 
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1 On the Insert menu, clicks Video. 
2 In the Video box under Source, type the address or URL of the video file you 
want. Or click Browse to search for the file. 
3 In the Alternate image box, type the address or URL of the graphics file that 
you want to designate as a substitute when the user's browser doesn't support videos 
or when the user turns off the display of videos. 
4 In the Alternate text box, type the text that you want to appear in place of the 

video or alternative image when the user's browser doesn't support videos, 
when the server where the video or image is located is temporarily 
unavailable, or when the user turns off the display of images and videos. 

5 In the Start list, click an option to specify how the video will play on a Web 
page. Open causes the video to play when the user downloads the Web page; Mouse­ 
over causes the video to play when the pointer moves over the video; Both causes the 
video to play in both scenarios. 
6 In the Loop box, enter the number of times you want the video to repeat. 
7 If you want to display video controls, such as "Start" and "Stop," while you're 
authoring Web pages, select the Display video controls check box. 

8 To copy the video to the same folder as your Web page, select the Copy to 
document folder check box. To use a relative path, a path that's relative to your 
current page, select the Use relative path check box. 

Notes 

The video will play after you insert it. If you've selected the Mouse-over 
option for video playback, the video will also play in your Web page document when 
your mouse moves over it. 

Video files can be very large and take a long time to download. For tips on 
reducing the size of images, click . 

You can also insert a hyperlink to a video, which means the user can click the 
hyperlink to download the video and play it. For more information about inserting 
hyperlinks, click . 

Add scrolling text to a Web page 

You can enhance your Web page with scrolling text, which is also known as a 
marquee. 

1 On the Insert menu, clicks Scrolling Text. 
2 Type the text that you want to scroll in the Type the scrolling text here box. 
3 Select any other options you want. 
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Notes 

Scrolling text, or the marquee, is supported in all versions of Microsoft 
Internet Explorer except version 1.0. Some other Web browsers don't support 
scrolling text. In those browsers, the text will appear but it won't scroll. 

To delete scrolling text, select the text, and then click Cut on the Edit menu. 
Set the language for a Web page 

When you are authoring a Web page, you can specify the language of the font, or the 
encoding, that a Web browser will use to display the page. For instance, if you want 
the page to appear with Greek characters, set the language to Greek. You can also set 
a default language encoding for new pages that you create. 

1 On the File menu, clicks Properties. 
2 Under HTML encoding, select the items you want. 

To specify the language code that Word will use to display the page if the 
page is not already displayed with the correct language encoding, click the language 
you want in the For displaying this page list. This setting is also used when loading 
subsequent pages, if the language encoding cannot be determined. 

To specify the language code for saving the page, click the language you want 
in the For saving this page list. 

To specify a default encoding for new Web pages that you create, click the 
language you want in the For creating new Web pages (default encoding) list. 

Notes 

To have Word always save your pages using a default language encoding, 
select the Always save Web pages with default encoding check box. This setting 
affects the current page and future pages that you save. This setting is useful if you 
reuse pages from other sources and want to store every page in one encoding. 

Some languages have more than one encoding scheme. To view the available 
encoding, see the lists under HTML encoding. 

Assign a title to a Web page 

The title appears in the title bar of the Web browser, and if someone stores a link to 
your Web page, the title appears in that person's history list and favourites list. 

1 On the File menu, clicks Properties. 
2 In the Title box, type the title you want. 
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Note If you don't specify a title, Word suggests a title based on the first few 
characters that appear on your Web page. 

Insert HTML mark-up 

Word provides features that help you create a Web page without writing HTML 
source. However, you can also insert your own HTML source code onto a page. 

1 Enter the HTML sources that you want. 
2 Select the source. 
3 In the Style box , NORMAL click HTML Mark-up. 

Notes 

You can also enter the HTML source directly when you are viewing the 
source of a Web page. View the source, and then type the HTML codes that you want. 
For more information about viewing the HTML source, click . 

Applying the HTML mark-up style will format text as hidden. If you need to 
view this text and hidden text is not showing, click Show/Hide 

Create a custom HTML template 

You can create a custom template that you base Web pages on. When you create the 
template, start with the Blank Web Page template, and then modify the template as 
you would any Word template. 

1 On the File menu, clicks New. 
2 Double-click Blank Web Page. 
3 Add any boilerplate text or graphics that you want. 
4 On the File menu, click Save As. 
5 In the Save as type box, click Document Template (*.dot). 
6 Word proposes the Templates folder in the Save in box. To save the template 
so that it will appear on a tab other than General, switch to the corresponding 
subfolder within the Templates folder. 

7 In the File name box, type a name for the new template, and then click Save. 

It is recommended that you give the file a .dot extension. 
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CHANGING THE APPEARANCE OF WEB PAGES 

Learn about formatting Web pages 

When creating Web pages in Word, you can use many of the same formatting tools 
you use for Word documents. For instance, you can click Bold to apply bold 
formatting to text, or you can click Heading 1 in the Style box NORMAL to apply 
a heading style. 
The HTML source that Word creates for the Web page doesn't contain formatting, 
but it contains codes that instruct the Web browser to format text. Word takes care of 
the HTML codes behind the scenes, though, so all you need to do is apply the 
formatting you want. 

Paragraphs will automatically contain space before and after them. To create 
paragraphs with no white space between them, press CTRL+ENTER. 
Formatting that isn't supported by HTML or some Web browsers aren't available in 
the Web authoring environment in Word. This includes the Emboss, Shadow, and 
Engrave character formatting effects, line spacing, margins, character spacing, 
kerning, text flow settings, and spacing before and after paragraphs. Tabs are not 
available because they are displayed as spaces by many Web browsers % to shift the 
first line of text to the right, you can use an indent. 

You can apply bold, italic, underline, strikethrough, superscript, and subscript formats 
to selected text. You can change the size of selected text to font sizes supported by 
HTML. You can click Increase Font Size or Decrease Font Size to quickly switch 
to the next available font size. You can also change the type of font, but keep in mind 
that others viewing your Web pages may not have the same fonts on their systems. 
Also, some Web browsers display text in a default font only. 

You can set the colours for text, hyperlinks, and followed hyperlinks for the entire 
page with the Text Colours dialog box (Format menu). You can change the colour 
of selected text % for instance, a word or a sentence % by clicking Font Colour. 
Setting the default text colours for the page doesn't change text whose colour you've 
changed with the Font Colour button. 

You can indent text in .25-inch increments by clicking Increase Indent and Decrease 
Indent , and you can change the alignment of text by clicking Align Left , Centre , 
or Align Right . However, you can't justify text on Web pages. 
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CONCLUSION 

This project that I produced creates a HTLM program and a WEB 
page. I practised all formulas of HTLM. While I was creating this WEB page I 
used two different Browser. These are; WEB page in OFFICE 97 and Visual 
Page Browser. Both of them were very useful. Specialities and usage of 
Browser will be engaged following pages. 

Because of Turkey is Tourist paradise I preferred to engage with 
touristic hotels that they are beneficial for tourism. 

I like to write about my pages briefly: 
First one is Turkey page. Later again a new Turkey page. Meanwhile 

brief and essential assistant information. From this page it is very easy to enter 
to www.turk.org. and www.turk.org./ata5.html pages. And because I wrote 
about hotels province by province first I gave information about provinces. 
After that brief information from that pages and from hotel pages it is possible 
to enter hotels' page. 

What did I use while I was producing HTLM design and Web pages: 
Links that can be found in every Web page, these are Active Links, 

Hyperlink, I preferred to use them. By using Frame I create page. I used tables 
and Background pictures. To colour writings and creating Turkish flag I used 
Animation gif. Also by assistance of Java program via choosing any region of 
map I used link to another page. 
This is not my whole program that now I present you; this is a very small 
sample and my whole program will take place in Internet with its over 150 
pages context. Then h will be possible to see it by June 1998 in Internet. 
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CHAPTER A 

INTERNET 

Historical Background 
The first computer network became operational in the late 1960's, with USA 

taking a lead with the Department of Defence network ARP ANET, which linked 
research computer from the East to the West Coast, with a link to London to allow 
UK researchers to grew rapidly, and was later split up into three interconnected 
networks, with connections to many other network across the world. This vast 
interconnected network is often referred to as the INTERNET . 

. The Internet is a world - wide system that is currently used mainly by academics 
and scientists, but it is rapidly becoming commercialised due to its incredible success. 
In the early 1980's ways to connect ARPANET to other WAN' s (Wide area 
Networks) e.g. in Europe, were developed. An Internet system can therefore be 
viewed as a set of networks interconnected by Gateways. A GATEWAY is a 
computer that has connections to at least two different networks. The purpose of a 
gateway is to translate the methods used to transfer data an one network into the 
methods used by another network so that data can flow smoothly between different 
types of networks. An Internet system is show is below in Figure 1. 

Network 

G 

Network 
Network 

H 

H= Host Computer G= Gateways 
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Fig.1. An Internet System 

From this early work has grown the system known as the Internet which now 
interconnects sites world wide (literally millions of computers interconnected) There 
are about 100 million people currently using the Internet. By the year 2005. "the 
number of computers attached to the Internet will exceed the world's human 
population" (Computer Journal) of course, growth will slow down, but nevertheless 
the growth is an impressive fact. It is radically changing access to information , news 
distribution, collaboration between people in remote places. The growth of the 
Internet has equalled that of a child by almost doubling insize every year. 

The data available to casual users on the Internet has grown as fast as the 
Internet itself and terabytes. Products have been developed to manage the information 
about data and provide a way of finding the document, program or in general the 
bytes that are wanted. 

Early information was shared with email and ftp. Email is moderately easy to 
use. Information can be passed from one person to another, or groups of people could 
form a mailing list. Originally email was just a text message; it didn't have the 
capability to include programs and data files. 
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Technical Definitions: 

The Internet is very difficult to define. Principally because things change on the 
Internet with great rapidity; definitions that are appropriate at one time have little 
meaning later. However, here are some definitions. 

The Internet is: 
=> A World Wide network of networks as Kevin Hughes defined in "A Guide to 

Cyberspace" 
=> A co-operative interconnection as emphasised by VUNETS "Internet Q&A" 
=> A way to communicate and share resources as described in the "What is the 

Internet?" by the Internet Society. 
=> computers connected using the TCP/IP protocol suite, as specified in the NCSA 

Guide to the Internet. 
Therefore, we can define it as a co-operative global network of computer 

networks that communicate and share resources using the TCP/IP protocol. 
In simple terms, it is the means by which computers in one part of the world 

can communicate with other in parts other of the world as easily as with computers in 
the next room. 

The mechanism for doing this is known as the Internet Protocol(IP) and the 
Transmission Control Protocol(TCP). Together these are commonly known as TCP/IP 
connections. The Internet protocol was first developed when the US Government 
wanted to allow researchers to share computing resources by making them available 
across a network. The military establishment were also involved in this process and 
developed the network on the assumption that there would be break ages in the 
network. Thus the protocol does not rely on the existence of any particular computers. 

When two computers communicate using TCP/IP the message is broken into a 
series of small packets which are sent over the network. The Internet Protocol deals 
with sending the individual packets and the Transmission Control Protocol managers 
the process of putting the packets together again at the other end.(Usually a packet is 
512 bytes) 

TCP/IP is a relatively simple networking protocol and was soon made available 
on most computers, allowing different makes of computers to communicate easily. 
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Computers on the Internet are all given a unique Internet Address. This address 
is used to tell the network where to send its individual packets of data. The Internet 
address is normally written as four digits(between O and 255) separated by dots. 

For example: 158.143.103.60 

this, however is not particularly easily to understand and therefore most 
computers provide a human readable name. This name is again made-up of a series of 
parts. 

For example: VAX.RES.AC.UK 

The process of naming computers is organised in a distributed manner, as there 
is no'central organising committee' for the Internet. Reading from right to left, we see 
that the computer is in the UK and, in particular, in the academic community. There is 
a local organiser for the academic community which distributes names for UK 
academic communities. Similarly , in Turkiye 

Various Protocols 

TCP/IP is simply a method for sending packets of data from one computer to 
another. Internet applications are built up by adding extra protocol layers on top of 
these. These are simply rules that describe the kind of messages that can be sent over 
Internet using TCP /IP. 
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CUSEEME 

This is a relatively new protocol that supports on-line video conferencing over 
the Internet. It does this by allowing a computer, if it has the necessary hardware, to 
use a video camera and sends this picture to other computers on that conference. 
Other computers receive this data and display it locally. The limited amount of 
capacity on many parts of the Internet means that often the picture that is received is 
quite Jerky. 

Network News 

Another protocol is the NNTP protocol. This allows you to read news on a 
variety of topics. Essentially, there is a hierarchy of news groups that discuss various 
subjects. For example: talk.rumors focuses on true and false rumours. Individuals 
read this news and can respond by adding their own messages to the group. 
Soc.culture.turkish is a news list where people can discuss things about Turkiye and 
issues related to the Turkish culture. 

Telnet 

One of the original and still mostwidely used protocols is TELNET. This 
essentially allows you to log on to a computer across the Internet. Anything that you 
type in is sent using the TELNET protocol and the response from the remotecomputer 
is sent back. TELNET normally requires that you have an account on the remote 
computer, but it is also used to provide access to library catalogues. 

FTP 

FTP is related to TELNET and allows you to upload and download files from a 
remote computer. FTP is often done anonymously which allows you to download 
files from computers where you don't have an account. FTP is the most widely used 
protocol for downloading files, but is slowly being replaced by more useably front 
ends. 
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Gopher 

One of the fastest and relatively easy to use protocol is Gopher. When you log 
on to a computer using to Gopher protocol it sends you a list of all the information it 
has. This information is normally in the form of individual files or directories. These 
items are displayed on your own computer and you can then choose the one you want. 
If you choose a directory, the system presents you with all the information in that 
directory. 

The beauty of the Gopher protocol is that the files and directories that are listed 
do not have to be on the same computer. You can select a particular item and will be 
automatically a different part of the Internet to obtain sent that information. 

The World Wide Web 

The Gopher protocol is fast and effective and automatically moves you from 
one part of the Internet to another. It is limited, however to the concept of files and 
directories. Whilst this is easily understood by computer specialist, it is not so intivite 
to non-computer specialists. The world wide web protocol overcomes this by 
presenting the information as normal text document. It also possible to include 
graphics within web documents. Within these documents are hot-links to other parts 
of the document or other parts of the Internet. As with Gopher, these jumps are 
handled automatically and invisibly. 

World wide web documents are often viewed using packages like the Microsoft 
Internet Explorer and Netscape Navigator. 

UNIFORM RESOURCE LOCATORS (URLs) 

URL s are designed to help with all these different protocols Essentially, they 
provide a standard format for specifying the Internet Information you want to use. The 
format is normally: 

- 6 - 



NEAR EAST UNIYER9TY 
COMPUTER ENQINEER/NQ 

1988 

Internet Service: II Internet address /Access information. 
For example: 

http:l/www.wired.com/index.html 
http://www.isoctr.org/ 
http:l/www.hurriyet.com.tr 

In this example, http specifies the protocol (hypertext transaction protocol), 
www.wired.com is the name of the computer and index. html is the file to be loaded 
and displayed . 

Searching the Internet 

The Internet is huge and grawing everyday. It also has no central controller so it 
can be very difficult to find information on the net. In order to solve this problem, a 
number of search engines have been developed. Some well-known search engines are: 

1. Altavista (http:l/www.altavista.digital.com) 
2. Yahoo! (http:l/www.yahoo.com) 
3. Lycos (http:l/www.lycos.com) 
4. Webcrawler (http:l/www.webcrawler.com) 
5. lnfoseek (http:l/www.infoseek.com) 
6. Excite (http:l/www.excite.com) 

These normally work by creating a monthly list of everything they know about 
(for example, all the FTP files in all the FTP sites that are known), indexing these lists 
and allowing people to search these indexes. the results are then displayed in the 
appropriate format. 

ARCHIE 

Archie is the search engine for FTP sites. Archie normally only works on the 
basis of file names and related descriptions and so is best used if you know the name 
of the file you are looking for. 

- 7 - 



NEAR EAST tlNIVERSTY 
COMPUTER INC/NEER/NC 

1988 

VERONiCA and JUGHEAD 

These are two search engines for GOPHER sites. They normally index all the 
worlds in the Gopher descriptions and you can perform Logical searches on them,for 
example, all the Gopher elements that contain both information and security. 

CUI and L YCOS 

Indexing world wide web files in much more difficult but these two facilities 
aim to provide results of web files searches. 

www.neu.edu.nc.tr/engf/index.html 

Image File Extensions on the Internet 

.gif 

.Jpg 

Introduction to HTML Language 

A simple Example 

<HTML> 
<HEAD> 
<META HTTP-EQUIV="Content-Type" CONTENT="text/html; charset=iso- 

8859-1 "> 
<META NAME="Author" CONTENT="metin taskm"> 
<META NAME="GENERATOR" CONTENT="Mozilla/4.02 [en] (Win95; I) 

[Netscape]"> 
<TITLE>index</TITLE> 

</HEAD> 
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<BODY> 
<CENTER><FONT COLOR="#330000"><FONT 
SIZE=+ 2></FONT></FONT></CENTER> 
<CENTER><FONT F ACE="Baskerville Win95BT Tur"><FONT 
COLOR="#330000"><FONT SIZE=+2>AMERICAN 
BIRDS</FONT></FONT></FONT></CENTER> 
<CENTER><FONT F ACE="Baskerville Win95BT Tur"><FONT 
COLOR="#330000"><FONT 
SIZE=+ 2></FONT></FONT></FONT></CENTER> 
<CENTER><FONT F ACE="Baskerville Win95BT Tur"><FONT 
COLOR="#000099"><FONT SIZE=+ l>BIRD 
CLASSIFICATION </FONT></FONT></FONT></CENTER> 
<CENTER><FONT F ACE="Baskerville Win95BT Tur"><FONT 
COLOR ="#000000"></FONT></FONT>&nbsp;</CENTER> 

<OL> 
<LI> 
<FONT F ACE="Baskerville 
COLOR="#OOOOOO">HERONS &amp; 
BITTERNS</FONT></FONT></LI> 

Win95BT Tur"><FONT 

<LI> 
<FONT F ACE="Baskerville 
COLOR="#OOOOOO">DUCK, GEESE 
&amp; SW ANS</FONT></FONT></LI> 

Win95BT Tur"><FONT 

<LI> 
<FONT F ACE="Baskerville Win95BT 
COLOR ="#000000"></FONT></FONT></LI> 

Tur"><FONT 

</OL> 
<CENTER><FONT F ACE="Baskerville 
COLOR ="#000099"><FONT 

Win95BT Tur"><FONT 

SIZE=+ 1 ></FONT></FONT></FONT>&nbsp; </CENTER> 
<CENTER><FONT COLOR="#330000"><FONT 
SIZE=+ 2></FONT></FONT>&nbsp;</CENTER> 
</BODY> 
</HTML> 
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What Software to Use For Writing HTML Programs 

1. Nodepad (under Accessories Directory in win95, also available or win3.1) 
2. Write (available or both win95& win 3.1) 
3. World (any version) (available or both win95& win 3.1) 
4. Netscape Communication 
5. Any other text editor. 

File Extension 

All HTML programs should have either. .htm or html extension. We shall later 
in the course that some files use .shtml extension. 

All image files that you use in your programs should either be in GIF format or 
JPG (also written as JPEG) 

TAG REFERENCE 

Document Formatting 

Tag Description 

<html> HTML document indicator 
<head> Document head 
<body> Document body 
<address> Owner/ Contact 
<title> Title 
<! ... > Comment 
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Paragraph Formatting 

Tag Description 

<blockquate> Blockquate 
<p> Paragraph 
<hr> Line break 
<hr> - Horizontal rule 
<pre> Preformatted text 

Character Formatting 

Tag Description 

<em> Emphasised 
<var> Variable 
<cile> Litation 
<i> Italic 
<strong> Strong 
<b> Bold 
<code> Code 
<samp> Sample 
<kbd> Keyboard 
<tt> Teletype 
<key> Keyword 
<dfn> Dfn 
<strike> Strike through 
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List Formattipg 

Tag Description 

<Ii> List item 
<ul> Unnumbered list 
<ol> ordered list 
<menu> Menu list 
<dir> Directory list 
<di> Description list 
<dt> Data term 
<dd> Data deser 

Anchor Formatting 
Tag Attribute Description 

Anchor hyper link 
href Points to destination of link 

<a> name Defines a named anchor so that a 
link can point to a place in a 
document not just to the document 
itself 
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Image Formatting 

Tag Attribute Descri~tion and Notes 
<img> 

src 
align 

alt 

ismap 

Incorporates images in a document 
The href for the image 
Aligns text, starting at the top, middle, 
or bottom the side of an image 
A name that can be displayed an 
browser that "' don't have image 
capabilities 
Activates the image so that the browser 
returns a set of x,y cordinates at which 
the image was clicked. 
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Table Formatting 

Tag Attribute Descri_etior, and Notes 
<table > I I Defines the table 

border Adds borders to separate rows and 
colums in tables 

<tr> I I Marks the end/start a table row 
Modifies 

<td> I I Encloses a cell of table data 
colspan Modifies the number of columns a cell 

will span 
rowspan I Modifies the number of rows a cell will 

span 
align I Defines the horizontal text alignment 

within a cell 
nowrap I Declares that the cell text cannot be 

broken up to wrap from one line to the 
text 

<th> I I Encloses a cell of table heading 
colspan Modifies the number of columns a cell 

will span 
rowspan I Modifies the number of rows a cell will 

span 
align I Defines the horizontal text alignment 

within a cell 
nowrap I Declares that the cell text cannot be 

broken up to wrap from one line to the 
text 

<caption> I I Creates a title for the table, outside 

GIF - The graphics interchanges format developed in 1987 by people from 
computer serve. This bitmapped format come into being because people wanted to 
exchanged images between different platforms. 

This format is now used on almost every platform that support graphical 
application. GIF format is not only a standart image type for WWW browser, it is 
also the only image type that can be used for inline images on all platforms. The one 
drawback of GIF format is that it is limited to 256 colours. 
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An extended standard called GIF89A was developed to add functionality for 
specific applications. The most no table use of this extended standard in web pages is 
the use of transparent backgrounds. Images can appear to float by making the 
background colour the same as the background of the browser. However browser 
don't always came with the plain grey background, and the user can override the 
choice of background colour as transparent compensates for the users specific 
configuration. 

JPEG - A bitmap format with compression that was designed and named after 
the Joint Photographic Expert Group: JPEG isn't used as often as the other formats 
but it is the basis for the most common moving image format, MPEG. In addition, the 
newest browser on the block, Netscape communicator row offers support for inline 
JPEG images. 

TIFF - The Tagged Image File Format designed by Microsoft and Aldus for 
use with scanners and desktop publishing programs. Most external viewers support 
this format. 

VIDEO STANDARTS 

MPEG - An animated video standard, format based on the JPEG methods. 
Like JPEG, the format received its name from the group that defined the standard 
Motion picture Experts Group. This is the most common movie format for WWW, 
primarily because viewers exist for all platforms. 

AVI - The movie format for Microsoft Windows. Use of this format isn't 
recommended until browsers for other platforms become common. 
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TCP/IP & INTERNET STRUCTURE 

Introduction: 
Data communication between places is the principle of computing. In the early 

days, this was quite hard. In the late 1970 s, networks have been developed and these 
evolved into host networks that were attached to a single packet-switched network. In 
the middle 1980s, various economic and technological factors have energised that 
made it possible to interconnect many physical networks. This new technology is 
called internetworking, and it hides the underlying details of actual networks, in order 
to provide a uniform service across networks. 

The Internet is an example of open systems interconnection(OSI). In on Internet 
structure, several networks are connected together through the use of gateways and 
Internet working protocol(as discussed earlier). The main advantage of an Internet 
structure is that it provides universal interconnection while allowing individual groups 
to use whatever network hardware is best suited to their needs. 

Network 

G-Gateways 

Network 

Network 
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In addition, the term Internet is used when making a generic reference to a 
network built using internetworking technology and the term Internet is used when 
specifically referring to this network. 

The transmission Control Protocol(TCP) 

The transmission Control Protocol, TCP, defines a key service provided by the 
Internet, namely, reliable, stream delivery and it provides a full duplex connection 
between two machines, allowing them to exchange large volume of data efficiently. 

The internet Protocol(IP), defines the IP datagram as the unit of information 
passed across the internet and provides the basis for connectionless, best-effort packet 
delivery stream. 

Message 

Packet Packet 

The TCP is part of the TCP/IP Internet protocol suite, it is an independent, 
general purpose protocol that can be adapted for use with other delivery systems. It is 
possible to use it over a single network like an Ethernet, which is popular Local Area 
Network(LAN ) technology invented at the Xerox corporation Polo Alto Research 
Centre , as well as over a complex Internet, because TCP makes very few assumptions 
about the underlying network. TCP is one of the International Standards 
Organisation(ISO) open system protocols. 

The most important services that TCP provides for its users include: connection 
orientation, sequencing, security against lost connection orientation, sequencing, 
security against loss connection monitoring, multiplexing, flow control, transparent 
data transport and secure connection establishment, release, IP has the ability to: 
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~ transmit messages over an internetwork. 
~ address each partner uniquely 
~ decompose and recombine packets according to the current network 

convertions. 
~ transmit certain information about the packet sequence and security features 

TCP Service Interfaces 
With its host-to-host communication, TCP/IP support the part/socket concept. A 

host, represented by its various application packages, may be viewed as providing a 
set of sockets, into which the desired connections, which are linked to I/0 ports of 
relevant applications by the main of many be plugged. Some sockets and ports are 
reserved for certain standardised application as shown below. 

PROTOCOL DESCRIPTION WELL-KNOWN PORT 
ARP Address Resolution Protocol - 
AUTH Authentication Service 113 
BO OTP Boot Strap Protocol 67,68 
ECHO ECHO Protocol 7 
FTP File Transfer Protocol 20-21 

GRAPHIC Graphics Exchange Protocol - 
MPM Exchange Multimedia Protocol 46 
LDP Load Debugger Protocol - 
LPR line Printer Protocol 514 
NNTP Network News Transfer Protocol 119 
NFS Network File System 2049 
RJE Remote Job Entry - 
RLP Resource Location Protocol 39 
SMTP Simple Mail Transfer Protocol 25 

TELNET Remote Terminal Protocol 23 
TFTP Trivial File transfer Protocol 69 
UDP User Datagram Protocol - 
X X- window System 6000 

STATSRV Sending Gateway Statics 95 
The most important TCP services are: 

OPEN- Open a virtual connection to a partner or wait until the connection is 
opened by an arbitrary or a specific partner. A time-out condition may be given. 

SEND- Deliver a data buffer to TCP for transmission to the other partner. A 
push flag may be used to force the full data transfer, otherwise the nature of the 
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execution is at the discretion of TCP. An URGENT flag may be used for express 
packets which must receive priority handling. 

RECEIVE- Receipt of data from the partner, with entry of size of the 
available buffer. TCP informs the clients process whether the PUSH or URGENT 
flags were set by the partner. 

CLOSE- Release of a virtual connection. 
STATUS- This service is only of a local nature and its fictions depend on the 

form of the current TCP implementation (in other words, which connection-related 
status/statistical data is made available). 

Connection Establishment 

Connection establishment between two TCP partners is based on the so-called 
"three way hardshake " principle. This mechanism reduces the possibility of the 
establishment of false connections. 

The following error situations may arise. 

=> Simultaneous establishment of a connection by each of the two partners 
involved. 

=> Multiple establishment of a connection by the initiator. Because of a time out 
for the first connection-establishment request. 

=> Unwanted establishment of a connection before the previous connection is 
released. 
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Data Transfer 

Once a connection is established between two partners data packets may be 
exchanged. Since these could be lost or rendered worthless as a result of errors or 
overloading of then network, TCP initiates a transmission repeat after the time-out 
condition expires. 

This way lead to duplicated data packets, which TCP detects using a special 
sequence numbering. 

Sequence Numbering 

Each data octet (8 bits=byte) transmitted by TCP is assigned a sequence 
number. This means that, in principle, the receipt of each octet can be confirmed. This 
is implemented in such a way that the confirmation of octet number n implicitly 
confirms the receipt of cell previous octets. Thus, duplicated segments are detected by 
the receiver and do not require special treatment. Sequence numbers run from O to 
232 -1. 

WINDOWS MECHANISM 

While in other protocols, such as HDLC(High Level Data Link Control) or X25 
level 3, the transmission window relates to the number of packets still to be 
transported from the sender to the recipient, because of the sequential numbering of 
octets, TCP uses a different mechanism. Here, a recent tells the sender the sequence 
number of the last octet which it has sufficient buffer space to receive. Unlike the 
above protocols, this provides for very dynamic management of this window. As soon 
as a recipient has a higher load and, thus possibly less buffer space, it can make this 
known to its partner. 
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Transmission Watchdog 

Each data packet transmitted is monitored so that a transmission repeat takes 
place if no acknowledgement is forth coming within a given interval (retransmission 
time). This interval depends heavily on the network type, the dimensioning of the 
network and the wrens network load. To frequent transmission repeats load the 
network unnecessarily too long a waiting period decreases the throughput possibly 
considerably. Thus, for each data packet, TCP continuously determines the time until 
the expiring of the acknowledgement period and thus is able to reset the 
retransmission timer adaptively. 

TCP Internet Protocol(IP) 

The Internet protocol, IP, defines the unreliable, connectionless delivery 
mechanism. IP provides three important definitions. First, the IP as a protocol defines 
the Internet datagram( or IP datagram). Second, IP software performs the routing 
function. Third, IP includes a set of rules that embody the idea of unreliable packet 
delivery. These rules characterise how hosts and gateway(router) should process 
packets how and when error messages should be generated , and the conditions under 
which packets may be discarded. 

A route is the path that network traffic takes from its source to its destination. IP 
datagram contains a source and destination IP, address, fragmentation controls, 
precedence and checksum used to catch transmission error along with data. In a 
TCP/IP datagram Internet each IP datagram, which is basis unit of information passed 
across a TCP/IP Internet, is may include may gateways and many physical network. 
Both hosts and gateways participate in IP routing. When an application program on a 
hosts attempts to communicate, the TCP/IP protocols eventually generate one or more 
IP datagrams. The host must make a routing decision when it chooses where to send 
the datagrams. 
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Datagram Delivery Over A Single Network 

Transmission of an IP datagram between two machines on a single network 
does not involve gateways. The sender encapsulates the datagram in a physical frame, 
binds the destination IP address to a physical hardware address, and Internetwork 
sends the resulting frame directly to the destination. 

Because the Internet addresses of all machines on a single network include a 
common network id, and because extracting that id can be done in a few instructions, 
testing whether a machine can be reached directly is extremely efficient. 

Internet Address 

Universal Identifiers: 

If a communication system allows any host to communicate with any other host, 
it is said to supply universal communication service. To make our communication 
system universal, we need to establish a globally accepted method of identifying 
computers that are attached to it. A name identifies what an object is an address where 
it is, and a route tells us how get there. Ingeneral pronounceable name to identify 
machines are preferred by the people. 

Three Primary Classes of IP Addresses 

For address, the designers of TCP/IP choose a scheme analogous to physical 
network addressing in which a host on the Internet is a assigned an address called an 
IP address. 

The clever part of Internet address is that Integers are carefully chosen to make 
rating efficient. 

An IP address encodes the identification of the network to which a host attaches 
as well as the identification of a unique host on that network. 

Each host on a TCP/IP Internet is assigned a unique 32-bit address that is used 
in all communication with that host. 
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Each address is a pair. One of the pair netid, identifies a network, and the other 
one, hostid, identifies a host on the network. 

Each IP address must have one of the first three forms shown below. 

0123 8 16 24 31 

Class A lo netid I hostid I Class A> 216 
14 

Class B I, 10 netid I hostid I 256<Class B<216 
28 

Cl ass C I 100 neti d I hostid I Class C < 256 

Class D I 1110 Multi Cost Address 

Class E 111110 Reserved For Future usJ 

An IP address can be determined from the three high order bits in a 
given IP address . Class A addresses are used for networks that have more then 
216(i.e.65.336) hosts. Class A bits devote 7 bits to netid and 24 bits to hostid. Class B 
addresses are used for intermediate size networks that have between 2\i.e.256) and 
216 hosts, and allocate 14 bits to the netid an 16 bits to the hostid. Class C networks 
have less then 28 hosts, and allocated 21 bits to the netid and only 8 bits to the hostid. 

The 32 bit Internet number or IP address is commonly represented as for 
numbers joined by period i.e.145.32.217.130 

The fourth part of this address identifies the host machine, the remainder 
identify the sub-network on which the machine resides. Class C network are typically 
LANs. 

Since users do not usually want to have to remember addresses in the form of 
numbers, a name-to- number service is available, called the Domain Name 
Service(DNS). DNS servers exchange information to allow a user to communicate 
with any other machine on the Internet simply by giving its name. One disadvantage 
of this addressing scheme is that if a host moves to another network, its Internet 
address must change. 

Example: Arpanet->- Class C 
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Difference Between Frames & Tables 

Use frames if you want to preserve the same layout an all your options. No need 
to reload the same section every time you choose an option. User can enlarge or 
arrange individual pages(frames)as required. 

Disadvantage of Frames 

Some browser can not view frames and generate an error messages. To cater for 
this when you create frames some HTML editors enable you to prepare text based 
version of pages using frames. 

Still, tables are more popular than frames. With tables you can produce, 
interesting effect and can use them for obtaining a nice layout. If you cheese border 
thickness=O then people cannot easily understand that you are using tables but this 
allows you to obtain nice layouts. 
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USING WORD PAGE 
WORKING WITH ONLINE AND INTERNET DOCUMENTS 

NAVIGATING 
Go to a page, bookmark, footnote, table, comment, graphic, or other location 
1 On the Edit menu, click Go To. 

Show me 

2 In the Go to what box, click the type of item. 
3 To go to a specific item, type the name or number of the item in the Enter 
box, and then click Go To. 

To go to the next or previous item of the same type, leave the Enter box empty, and 
then click Next or Previous. 

Tip For a quick way to go to the next or previous item, click Select Browse Object 
on the vertical scroll bar, and then click the item you want. You can click Next or 
Previous to go to the next or previous item of the same type. 
Navigate by using hyperlinks 
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When a Word publication or Web page contains hyperlinks to other locations% for 
example, to locations in the same file, or to files on the network or the Internet 
% you can move to these locations by clicking the hyperlink display text or image. 
When you point to the display text of a hyperlink, the pointer becomes a hand . 

In a file or Web page that contains hyperlinks, click the display text or image 
of a hyperlink. 

When a hyperlink is followed % that is, when you click the display text and jump to 
another location% the Web toolbar appears. 

Click Back to return to the original location in your Word publication. 
Click Forward to return to the file whose hyperlink you followed. 

Navigate by using the Document Map 

The Document Map is a separate pane that shows an outline of a document's 
headings. You can use the Document Map to quickly navigate around the document 
and keep track of your location in it. For example, click a heading in the Document 
Map to instantly jump to the related part of the document. 
Word automatically displays the Document Map in online layout view, but you can 
display it in any view. 
) 

1 
2 

Click Document Map 
In the Document Map, click the heading you want to go to. 

Word displays the heading at the top of the page. In the Document Map, the heading 
is highlighted to show your location in the document. 
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WORKING WITH DOCUMENTS ON INTRANENTS AND THE INTERNET 

Documents on the Internet 

If you have access to the Internet (for example, if you have a modem and an Internet 
account through an Internet service provider, or if you are in a corporation and have 
access through the network), you can open documents on the World Wide Web or 
anywhere on the Internet from the Open dialog box in your Office programs. You can 
also add FTP sites to the list of available Internet sites. And if your company has an 
intranet, you can open documents there. In addition, if you have the access rights and 
the FTP site supports saving files, you can save documents to the Internet from the 
Save As dialog box in your Office programs. 

Use Microsoft Excel, Word, PowerPoint, and Microsoft Access to browse Office 
documents that contain hyperlinks, whether the document is on your computer, on a 
network drive, or on the Internet. You don't have to be on the Internet to use 
hyperlinks in Office documents. 
The Web toolbar is available in your Office programs to make it easy to browse 
documents that contain hyperlinks. Use the Web toolbar to open a start page or a 
search page in your Web browser. Also from the Web toolbar, add interesting 
documents you find on the Web to the Favourites folder to gain access to them 
quickly. The Web toolbar keeps a list of the last 10 documents you jumped to by 
using either the Web toolbar or a hyperlink so you can easily return to these 
documents again. 

Add an FTP site to the list of Internet sites 

You can add an FTP site to the list of Internet sites to make it easier to open a 
document at an FTP site. To do this procedure, your company must have an intranet, 
or you must have access to the Internet (for example, you may have access by using a 
modem and an Internet account through an Internet service provider, or through the 
network if you are in a corporation). For information about how to set up Internet 
access, see the Microsoft Office 97 Resource Kit. For information about how to 
obtain the Office Resource Kit, click 

1 Click Open . 
2 In the Look in box, click Add/Modify FTP Locations. 
3 In the Name of FTP site box, type the FTP site name; for example, type 
ftp://ftp.microsoft.com/ 
4 If you want to log on to an FTP site that allows anonymous log on, click 
Anonymous. 
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If you want to log on to an FTP site that you have user privileges for, click User, and 
then type your password. 

5 Click Add. 

Remove an FTP site from the list of Internet sites 

1 Click Open . 
2 In the Look in box, click Internet Locations (FTP). 
3 Right-click the FTP site you want to remove, and then click Remove on the 
shortcut menu. 

Change the logon name or password for an FTP site 

You can change the way you log on to an FTP site. To do this procedure, your 
company must have an intranet, or you must have access to the Internet (for 
example, you may have access by using a modem and an Internet account through an 
Internet service provider, or through the network if you are in a corporation). For 
information about how to set up Internet access, see the Microsoft Office 97 Resource 
Kit. For information about how to obtain the Office Resource Kit, click 

1 Click Open . 
2 In the Look in box, click Internet Locations (FTP). 
3 Right-click the FTP site you want to change, and then click Modify on the 

shortcut menu. 
4 Change the options you want. 
Learn about installing and using Web page authoring tools 

Microsoft Word and some other Microsoft Office programs provide Web page 
authoring tools to help you easily create Web pages for intranets and the World 
Wide Web. If you haven't already installed these tools, you can rerun Set-up to install 
them and to install more Help topics about using them. 
When authoring Web pages in Word, you can use many familiars Word features, such 
as spelling and grammar checking, AutoText, and tables. Some features, such as 
graphical bullets and lines, are customised to make Web authoring easier. Features 
that aren't supported by HTML are not available when authoring Web pages. 

To install the Web page authoring features, select the Web Page Authoring (HTML) 
check box in Set-up. For more information about installing components of Office, 
click . 
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Open the Web start page 

When you start a World Wide Web browser, the start page is the first page that 
appears in the browser. You can set this location to any Web site you want or to a 
document on your computer hard disk. You can open the start page from the Web 
toolbar. A start page may contain hyperlinks to other documents on your computer, 
on the network, or on the Web. 
To do this procedure, you must have the Web toolbar displayed. On the View menu, 
point to Toolbars, and then click Web. 

On the Web toolbar, click Start Page 

Change the Web start page 

To do this procedure, the Web toolbar must be visible. On the View menu, point to 
Toolbars, and then click Web. 

1 Open the document you want to use as the start page. 
2 On the Web toolbar, click Go, and then click Set Start Page. 
3 Click Yes. 

Open the Web search page 

A search page provides an organised way to find and go to other Internet sites or to 
documents on an intranet. Many search pages provide the capability to search by 
topic or by keyword. Others simply provide an well-organised list of hyperlinks to 
selected Internet sites or to documents on an intranet. You can open the search page 
from the Web toolbar. 
To do this procedure, you must have the Web toolbar displayed. On the View menu, 
point to Toolbars, and then click Web. 

On the Web toolbar, click Search the Web 

Change the Web search page 

To do this procedure, the Web toolbar must be visible. On the View menu, point to 
Toolbars, and then click Web. 

1 Open the document you want to use as the search page. 
2 On the Web toolbar, click Go, and then click Set Search Page. 
3 Click Yes. 
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Open recently browsed files 

To do this procedure, you must have the Web toolbar displayed. On the View 
menu, point to Toolbars, and then click Web. To open the previous document in the 
history list, click Back on the Web toolbar. 

To open the next document in the history list, click Forward on the Web toolbar. 

Cancel a jump that takes too long 

To do this procedure, you must have the Web toolbar displayed. On the View menu, 
point to Toolbars, and then click Web. 

On the Web toolbar, click Stop Current Jump 

Refresh the display of the current file or Web page 

When you work in a document on the World Wide Web that contains hyperlinks, 
the author may modify the document while you have it open. When you update a 
document, the document is refreshed from the original file that is located on the 
network server, the Internet, or your computer hard disk. 
To do this procedure, you must have the Web toolbar displayed. On the View menu, 
point to Toolbars, and then click Web. 

On the Web toolbar, click Refresh Current Page 

Add the active document to Favourites 

When you open a document on the Internet, World Wide Web, intranet, or even on 
your computer hard disk, add the document to the Favourites folder so you can open it 
again without having to remember the path you typed to get the document the first 
time. 
To do this procedure, you must have the Web toolbar displayed. On the View menu, 
point to Toolbars, and then click Web. 

On the Web toolbar, click Favourites, and then click Add to Favourites. 

Hide all toolbars except the Web toolbar 

To do this procedure, you must have the Web toolbar displayed. On the View menu, 
point to Toolbars, and then click Web. 

On the Web toolbar, click Show Only Web Toolbar 
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Tip To show the toolbars that are hidden, click Show Only Web Toolbar on the 
Web toolbar. 

I can't open a document on the Internet. 

You must have access to the Internet (for example, you may have access by using a 
modem and an Internet account through an Internet service provider, or through the 
network if you are in a corporation) to open files at an FTP site or on the World 
Wide Web. For information about how to set up Internet access, see the Microsoft 
Office 97 Resource Kit. For information about how to obtain the Office Resource Kit, 
click. 

If you have these things, the site may be too busy. Try to open the document 
later. 

The Web Find Fast search page 

Microsoft Office ships with a search page you can use to find files on the intranet. 
The Web Find Fast search page makes it quick and easy to find a file you know exists 
even when you don't know where it's located. The Web Find Fast search page also 
makes it easy to find all of the information available on any subject. You can also 
quickly locate information outside of your workgroup, such as the quarterly report for 
your company, or all files that refer to company policies. 

To obtain the Web Find Fast search page, see your administrator. 

WORKING WITH HYPERLINKS 

Create hyperlinks 

You can enrich Web pages and Word publications that others read online by 
inserting hyperlinks to other items. The hyperlink can jump to a location in the 
current document or Web page, to a different Word document or Web page, or to a 
file that was created in a different program. You can even use hyperlinks to jump to 
multimedia files, such as sounds and videos. 
The destination the hyperlink jumps to can be on your hard disk, on your company's 
intranet, or on the Internet, such as a page on the World Wide Web. For example, 
you can create a hyperlink that jumps from a Word file to a chart in Microsoft Excel 
that provides more detail. A hyperlink is represented by a "hot" image or display 
text% that is often blue and underlined% that the reader clicks to jump to a different 
location. 
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Use the automatic formatting features for Word documents and Web pages when you 
know the addresses to jump to or when you have a document that contains file names 
or addresses that you want to format as hyperlinks. Use Insert Hyperlink to insert a 
hyperlink into Word files and Web pages when you aren't using the automatic 
formatting features or when you want to browse for the destination address. Use a 
drag-and-drop operation in Word files when you want to use the mouse to quickly 
create a hyperlink for text located within another Office file. 

Change the display text or image of a hyperlink 

You can change the display text or image of a hyperlink % the "hot" text or image that 
a user clicks to follow the hyperlink % as you would edit any text or image in your 
document or Web page. To avoid following the hyperlink, or opening the file you're 
inserting the hyperlink to, it's usually best to use the keyboard to select the image or 
text you want to change. 

1 Click outside of the text or image. 
2 Press the arrow keys until your insertion point is located just to the left or the right 
the image or text you want to change. 
3 Hold downs SHIFT and press an arrow key until the text or image is selected. 

Hold down CONTROL+SHIFT to select whole words. 

4 Edit the image or text. 

Remove a hyperlink 

1 Right-click the hyperlink you want to remove, point to Hyperlink on the 
shortcut menu, and then click Edit Hyperlink. 
2 Click Remove Link. 

Tip To remove a hyperlink and the display text or image that represents the hyperlink 
in the document, select the hyperlink, and then press DELETE. 

Change the appearance of all hyperlinks in Word documents 

This procedure doesn't affect hyperlinks on Web pages. For more information about 
changing text colours in Web pages, click . 

1 Open the document that contains the hyperlinks you want to change. 
2 On the Format menu, click Style. 
3 To change the appearance of a hyperlink, click Hyperlink in the Styles box, 
and then click Modify. 
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To change the appearance of a followed hyperlink, click FollowedHyperlink in the 
Styles box, and then click Modify. 

4 Click Format, and then click Font. 
5 Select the options you want. 

Tips 

To use animated text, click the Animation tab in the Font box, and then click 
the option you want in the Animations box. For instance, you could use Las Vegas 
Lights or Sparkle Text to point out the hyperlinks in your document. 

To use the modified Hyperlink or FollowedHyperlink style in new documents 
based on the same template, select the Add to template check box in the Modify 
Style dialog box. Word adds the modified style to the template attached to the active 
document. 

Change the hyperlink destination 

1 Right-click the hyperlink you want to change, point to Hyperlink on the 
shortcut menu, and then click Edit Hyperlink. 
2 Select the options you want. 

Set a hyperlink base for a document 

When you create a hyperlink in a document, you can make the path to the 
destination of the hyperlink a fixed file location (absolute link), which identifies the 
destination by its full address, such as c:\My Documents\Sales.doc, or you can make 
the path a relative link. Use a relative link if you want to move or copy the file that 
contains the hyperlink or the destination file to a new location. To change the path of 
the relative link, set a hyperlink base for the document. 

1 Open the document you want to set a hyperlink base for. 
2 On the File menu, click Properties, and then click the Summary tab. 
3 In the Hyperlink base box, type the path of the relative link you want to use 

for all the hyperlinks you create in this document. 
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CREATING AND WORKING WITH WEB PAGES 

CREATING WEB PAGES 
Create a Web page 

Word offers two easy ways for you to create Web pages. You can start a new page by 
using a wizard or template, or you can convert an existing Word document to HTML, 
the format used for Web pages. When you create a Web page with either of these 
methods, Word customises some toolbars, menu commands, and options to provide 
the Web page authoring features. 

Using the Web page authoring features to create your Web page will usually produce 
the best results. You can use the Web Page Wizard to start with sample content% 
such as a personal home page and registration form % and graphical themes % such as 
festive and community% to help you quickly creates a Web page. If you prefer, you 
can start with a blank Web page. For information about many of the features you can 
use in Web pages, click . 

Use the HTML conversion method when you have existing Word content that you 
want to quickly convert to a Web page. The formatting and features that are supported 
by HTML will be converted. For more information, click 

What do you want to do? 

Create a Web page from a wizard or template 
Save a Word document in HTML format 

Items you can add to Web pages 

You can make Web pages look more interesting by adding bullets and numbering, 
horizontal lines, background colours and textures, tables, pictures, videos, scrolling 
text, and forms. You add most of these items in much the same way as you do in a 
Word document. However, to make Web page authoring easier, Word offers some 
new and some customised commands for this purpose. 
Obtain more Web page graphics and templates from the Microsoft Web site 

Additional bullets, textured backgrounds, horizontal lines, and templates are available 
on the Microsoft Web site. If you have access to the World Wide Web, you can 
obtain these items to use on your Web pages. 
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Tips for creating Web pages 

There are many opinions about the best way to structure and design Web pages. You 
can find many tips, examples, and style guides on the World Wide Web. Here are 
some tips that apply to most Web pages: 

Content should be well organised. Well-structured pages help you deliver 
ideas effectively and help the reader navigate through your site. For more information, 
click . 

Text on Web pages should be easy to read. If you add a background to your 
Web page, it should contrast with the text colour. For more information, click . 

Web pages may not look the same in different Web browsers. It's a good idea 
to plan your Web pages so they are viewable in most browsers. For more information, 
click . 

Large images increase download time, especially for readers who gain access 
to Web pages by modem. Although graphics can make Web pages more interesting, 
you should use graphics strategically. For more information, click . 

Some users tum off the display of images, and some Web browsers don't 
support all video formats. When images and videos contain information that you don't 
want readers to overlook, you can use alternative text for graphics and alternative text 
and images for videos. For more information, click . 

You can use tables as a layout tool. For example, HTML, the format for Web 
pages, doesn't support newspaper columns, but you can create a two-column effect by 
using tables. For more information, click . 

Add a background sound to a Web page 

You can have a background sound play automatically when someone opens your Web 
page. 

1 On the Insert menu, points to Background Sound, and click Properties. 
2 In the Sound box, enter the address, or URL, of the sound file you want, or 
click Browse to locate the file. 
3 In the Loop box, click the number of times you want the sound to repeat. If 
you want it to loop continually while the Web page is open, click Infinite. 
4 To copy the sound to the same folder as your Web page, select the Copy to 
document folder check box. To use a relative path, a path that's relative to your 
current page, select the Use relative path check box. 

For more information about managing files for Web pages, click 

Notes 
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To review the sound while you are authoring the Web page, point to 
Background Sound on the Insert menu, and then click Play. To stop the sound, click 
Stop. 

For others to hear background sounds, they must have a sound system 
installed, and their Web browser must support the sound format of the file you 
inserted. You can insert sound files in WAY, MID, AU, AIF, RMI, SND, and MP2 
(MPEG audio) formats. 

The background sound plays automatically every time your page is opened or 
returned to. For frequently opened pages, such as home pages, this repetition could 
become annoying. You could add the background sound instead to a page that the 
user is likely to jump too less frequently. Or you could insert a hyperlink that the user 
can click to download a sound file. For more information about inserting hyperlinks, 
click . You may want to use caution when selecting Infinite for a looping option, 
because the sound will play continually when the user opens the page. 

Add a horizontal line to a Web page 

Horizontal lines are used often on Web pages to separate logical sections of text. 

1 Click where you want to insert the line. 
2 On the Insert menu, click Horizontal Line. 
3 In the Style box, click the line that you want, or click More to select a 
different line. 

Notes 

A Web browser will draw the first line in the Style box when someone opens 
the page. The other line styles are graphical images. When you save this Web page, 
the line will be saved as an image, such as image.gif, image 1.gif, in the same location 
as the Web page. If you move the Web page % for instance, when publishing the 
page % you should also move the image of the line. For more information, click . 

To quickly insert another line with the same style, click Horizontal Line 

Add a video to a Web page 

You can add an inline video to your Web page, which means the video is downloaded 
when the user opens the page. You can determine whether the video will play when 
the page is opened or when the user points to the video with the mouse. Because not 
all Web browsers support inline video, you may want to provide alternative text and 
images or avoid presenting essential information in videos. 
It's recommended that you save your document before inserting videos. For more 
information about managing files and links, click . 
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1 On the Insert menu, clicks Video. 
2 In the Video box under Source, type the address or URL of the video file you 
want. Or click Browse to search for the file. 
3 In the Alternate image box, type the address or URL of the graphics file that 
you want to designate as a substitute when the user's browser doesn't support videos 
or when the user turns off the display of videos. 
4 In the Alternate text box, type the text that you want to appear in place of the 

video or alternative image when the user's browser doesn't support videos, 
when the server where the video or image is located is temporarily 
unavailable, or when the user turns off the display of images and videos. 

5 In the Start list, click an option to specify how the video will play on a Web 
page. Open causes the video to play when the user downloads the Web page; Mouse­ 
over causes the video to play when the pointer moves over the video; Both causes the 
video to play in both scenarios. 
6 In the Loop box, enter the number of times you want the video to repeat. 
7 If you want to display video controls, such as "Start" and "Stop," while you're 
authoring Web pages, select the Display video controls check box. 

8 To copy the video to the same folder as your Web page, select the Copy to 
document folder check box. To use a relative path, a path that's relative to your 
current page, select the Use relative path check box. 

Notes 

The video will play after you insert it. If you've selected the Mouse-over 
option for video playback, the video will also play in your Web page document when 
your mouse moves over it. 

Video files can be very large and take a long time to download. For tips on 
reducing the size of images, click . 

You can also insert a hyperlink to a video, which means the user can click the 
hyperlink to download the video and play it. For more information about inserting 
hyperlinks, click . 

Add scrolling text to a Web page 

You can enhance your Web page with scrolling text, which is also known as a 
marquee. 

1 On the Insert menu, clicks Scrolling Text. 
2 Type the text that you want to scroll in the Type the scrolling text here box. 
3 Select any other options you want. 
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Notes 

Scrolling text, or the marquee, is supported in all versions of Microsoft 
Internet Explorer except version 1.0. Some other Web browsers don't support 
scrolling text. In those browsers, the text will appear but it won't scroll. 

To delete scrolling text, select the text, and then click Cut on the Edit menu. 
Set the language for a Web page 

When you are authoring a Web page, you can specify the language of the font, or the 
encoding, that a Web browser will use to display the page. For instance, if you want 
the page to appear with Greek characters, set the language to Greek. You can also set 
a default language encoding for new pages that you create. 

1 On the File menu, clicks Properties. 
2 Under HTML encoding, select the items you want. 

To specify the language code that Word will use to display the page if the 
page is not already displayed with the correct language encoding, click the language 
you want in the For displaying this page list. This setting is also used when loading 
subsequent pages, if the language encoding cannot be determined. 

To specify the language code for saving the page, click the language you want 
in the For saving this page list. 

To specify a default encoding for new Web pages that you create, click the 
language you want in the For creating new Web pages (default encoding) list. 

Notes 

To have Word always save your pages using a default language encoding, 
select the Always save Web pages with default encoding check box. This setting 
affects the current page and future pages that you save. This setting is useful if you 
reuse pages from other sources and want to store every page in one encoding. 

Some languages have more than one encoding scheme. To view the available 
encoding, see the lists under HTML encoding. 

Assign a title to a Web page 

The title appears in the title bar of the Web browser, and if someone stores a link to 
your Web page, the title appears in that person's history list and favourites list. 

1 On the File menu, clicks Properties. 
2 In the Title box, type the title you want. 
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Note If you don't specify a title, Word suggests a title based on the first few 
characters that appear on your Web page. 

Insert HTML mark-up 

Word provides features that help you create a Web page without writing HTML 
source. However, you can also insert your own HTML source code onto a page. 

1 Enter the HTML sources that you want. 
2 Select the source. 
3 In the Style box , NORMAL click HTML Mark-up. 

Notes 

You can also enter the HTML source directly when you are viewing the 
source of a Web page. View the source, and then type the HTML codes that you want. 
For more information about viewing the HTML source, click . 

Applying the HTML mark-up style will format text as hidden. If you need to 
view this text and hidden text is not showing, click Show/Hide 

Create a custom HTML template 

You can create a custom template that you base Web pages on. When you create the 
template, start with the Blank Web Page template, and then modify the template as 
you would any Word template. 

1 On the File menu, clicks New. 
2 Double-click Blank Web Page. 
3 Add any boilerplate text or graphics that you want. 
4 On the File menu, click Save As. 
5 In the Save as type box, click Document Template (*.dot). 
6 Word proposes the Templates folder in the Save in box. To save the template 
so that it will appear on a tab other than General, switch to the corresponding 
subfolder within the Templates folder. 

7 In the File name box, type a name for the new template, and then click Save. 

It is recommended that you give the file a .dot extension. 
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CHANGING THE APPEARANCE OF WEB PAGES 

Learn about formatting Web pages 

When creating Web pages in Word, you can use many of the same formatting tools 
you use for Word documents. For instance, you can click Bold to apply bold 
formatting to text, or you can click Heading 1 in the Style box NORMAL to apply 
a heading style. 
The HTML source that Word creates for the Web page doesn't contain formatting, 
but it contains codes that instruct the Web browser to format text. Word takes care of 
the HTML codes behind the scenes, though, so all you need to do is apply the 
formatting you want. 

Paragraphs will automatically contain space before and after them. To create 
paragraphs with no white space between them, press CTRL+ENTER. 
Formatting that isn't supported by HTML or some Web browsers aren't available in 
the Web authoring environment in Word. This includes the Emboss, Shadow, and 
Engrave character formatting effects, line spacing, margins, character spacing, 
kerning, text flow settings, and spacing before and after paragraphs. Tabs are not 
available because they are displayed as spaces by many Web browsers % to shift the 
first line of text to the right, you can use an indent. 

You can apply bold, italic, underline, strikethrough, superscript, and subscript formats 
to selected text. You can change the size of selected text to font sizes supported by 
HTML. You can click Increase Font Size or Decrease Font Size to quickly switch 
to the next available font size. You can also change the type of font, but keep in mind 
that others viewing your Web pages may not have the same fonts on their systems. 
Also, some Web browsers display text in a default font only. 

You can set the colours for text, hyperlinks, and followed hyperlinks for the entire 
page with the Text Colours dialog box (Format menu). You can change the colour 
of selected text % for instance, a word or a sentence % by clicking Font Colour. 
Setting the default text colours for the page doesn't change text whose colour you've 
changed with the Font Colour button. 

You can indent text in .25-inch increments by clicking Increase Indent and Decrease 
Indent , and you can change the alignment of text by clicking Align Left , Centre , 
or Align Right . However, you can't justify text on Web pages. 
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Learn about tables on Web pages 

Working with tables on Web pages is similar to working with tables in Word 
documents. You can use Draw Table to create and modify the structure for your 
table. You can insert a table grid by using Insert Table. There are some differences in 
how borders are applied and cells are formatted. 
Because tables are often used as a behind-the-scenes layout tool on Web pages% for 
instance, to arrange text and graphics % they do not have borders when you insert 
them. You can add borders to tables on Web pages by using the Border command 
(Table menu). Borders that you apply to tables on Web pages have a 3-D appearance 
in Web browsers. 

You can change the background colour, or shading, of tables by using the Table 
Properties command (Table menu); change the background colour of selected cells 
by using the Cell Properties command (Table menu). 
You can change the height of selected rows and the width of selected columns by 
using the Cell Properties command (Table menu). You can change the way that text 
wraps around the table, the distance between the table and surrounding text, and the 
spacing between columns by using the Table Properties command (Table menu). 

Using tables as a layout tool 

You can use tables with or without borders to add graphical effects and manage the 
layout of your Web page. You can organise columns of graphics and text so that they 
will be aligned together in Web browsers. Without tables, it's difficult to keep 
graphics and text aligned in HTML, the format for Web pages. 
You can use the table drawing tool in Word to help arrange text and graphics. If you 
don't want the border to appear on the finished Web page, remove the border. Even if 
the border is removed, gridlines may appear in your Word document to show the 
table boundaries. To control the display of gridlines, click Hide Gridlines or Display 
Gridlines on the Table menu. These will not appear on the finished Web page. 

Most Web browsers now support tables, but some earlier versions do not. If you 
intend for a broad audience to view the content in the table, you may want to also 
structure your information in text-only format and then provide a hyperlink to the 
text-only version. 
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Set text colours on Web pages 

When creating a Web page, you can determine the default colour scheme for text and 
hyperlinks for the Web page. This setting doesn't change the colour of text whose 
colour was set by applying direct font formatting, for example with Font Colour 

1 On the Format menu, clicks Text Colours. 
2 Select the colours you want in the Body text colour, Hyperlink, and 
Followed hyperlink lists. 

Notes 

Colours you set by using the Text Colours command become the default 
colours for all the text, hyperlinks, and followed hyperlinks. You can apply direct 
colour formatting to selected text by clicking Font Colour . 

Those who view your Web page can set their own default colours in their 
Web browsers. To have the colours of text and hyperlinks appear in the browser 
default colours when viewed in a browser, select Auto in each list. 

Working with styles on Web pages 

You can apply built-in styles that correspond to formatting that's supported by HTML 
on Web pages. You apply styles to text on Web pages the same way you apply styles 
to Word documents, but there are some differences in how styles work. 
When you are creating a Web page, Word adds the HTML styles to the Style box 
NORMAL on the Formatting toolbar and to the Styles list in the Style dialog box ( 
Format menu). One character style, HTML Mark-up, should be used for HTML 
source codes that you want to enter manually. 

The HTML-specific styles, such as Address and H2, correspond directly to an HTML 
tag; any modifications you make to these styles will not be retained. If you modify a 
Word built-in style, such as Heading 1, the formatting associated with the style will be 
exported to a corresponding HTML tag, provided the formatting is supported in 
HTML. 
You can define and modify your own styles. When you save the page as HTML, only 
the HTML-supported formatting is converted % any other formatting is lost when you 
view the page in a Web browser. For more information about formatting on Web 
pages, click . 
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Learn about bullets and numbering on Web pages 

You can create bulleted lists when authoring Web pages, similar to the way you create 
bulleted lists when creating Word documents. One main difference is that you can use 
graphical images in addition to bullet symbols. 
Bullet images are available in the Bullets and Numbering dialog box (Format 
menu) when you create Web pages. Text bullets that are supported by HTML, the 
format for Web pages, are also available. In addition to using the graphical bullets in 
the dialog box, you can click More to use other images as bullets. After choosing the 
image you want, click OK to return to the document. 

When you use images as bullets, the images are saved as GIF (.gif) images (unless 
you insert a JPEG [.jpg] image, in which case the JPEG format is retained) in the 
same location as or in a location relative to your Web page. For more information 
about managing files and links, click . 
When you use images as bullets, you can change the image by using the Bullets and 
Numbering command. Before changing a bullet image, however, you must delete the 
existing bullet images. If you inadvertently apply new bullet images without deleting 
the first images, just delete the first bullet images by selecting them and pressing 
DELETE. 

Some settings for bullets and numbering that are supported by HTML aren't available 
when you author Web pages. For instance, it's not possible to change the distance 
between bullets or numbers and text in the Web authoring environment. 
Numbering on Web pages is similar to numbering in Word documents, except that 
automatic outline and heading numbering isn't available in the Web authoring 
environment. By applying different numbering styles and indents, however, you can 
create a list that appears to have multiple levels. For more information, click . 
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WORKING WITH GRAPHICS ON WEB PAGES 

Learn about working with graphics on Web pages 

The first time you save your Web page in HTML format, all graphics are converted 
to GIF or JPEG format, two image types that are supported on the World Wide 
Web. 
You can insert a graphic on a Web page by pointing to Picture on the Insert menu 
and then clicking From File or Clip Art. If the graphic is in JPG format when you 
insert it, Word saves it in JPG format. If the graphic is in any other type of format, 
such as TIF, Word converts it to GIF format. If you have Internet access, you can 
obtain more graphics from the Microsoft Web Art Page. 

When you insert a graphic from a file, Word copies the graphic to the same folder as 
your Web page when you save the Web page, unless you select the Link to file check 
box. If you select the Link to file check box, you can link to a graphic at a fixed 
location, such as another Web server. 
When you insert a graphic on a Web page, it is aligned with the left margin by 
default. You can control the way text flows around the graphic by selecting it and then 
using the commands on the Format menu and the Picture toolbar. To provide 
additional control over the layout of text and graphics, use a table. 

You can use drawing objects% such as Autoshapes, text boxes, and WordArt 
effects% as Microsoft Word Picture objects. Once you close your document, you 
won't be able to update these items again. They will become static GIF images. For 
more information, click . 
The Picture toolbar in Word is customised to provide alignment commands that help 
you arrange your graphics. The customised Picture toolbar commands are compatible 
with HTML, the format for Web pages. When you select a graphic, the Picture 
toolbar appears. To hide the toolbar, right-click the graphic, and then click Hide 
Picture Toolbar on the shortcut menu. 

Align images on Web pages 

When you insert a graphic, such as a picture, on a Web page, by default the graphic is 
aligned with the left margin, and text does not wrap around it. This procedure changes 
the alignment and the way text wraps. 

1 Select the graphic. 
2 On the Format menu, click Picture, and then click the Position tab. 
3 Under Text wrapping, click None, Left, or Right. 
4 Under Distance from text, enter the amount of distance you want between the 
picture and the surrounding text. 
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Notes 

To quickly change the way that text wraps, you can also use the buttons on the 
Picture toolbar. 

Left and right alignment isn't available for graphics in table cells. 
Multiple images cannot appear in the same paragraph with the same 

alignment. 

Learn about creating graphics with transparent areas for Web pages 

You can use Microsoft Photo Editor, which comes with Microsoft Office, to create 
GIF (.gif) images with transparent areas for Web pages. When an image contains a 
transparent area, the background colour or texture of the page "shows through" the 
image. 
If Microsoft Photo Editor is not installed on your system, run Set-up again, and select 
Photo Editor in the Office Tools group. For more information about installing 
components of Microsoft Office, click . 

From Word, you can insert a Photo Editor object, and then apply transparency to the 
background colour. On the Insert menu, click Object, and then click the Create New 
tab. Under Object Type, double-click Microsoft Photo Editor 3.0 Photo. Open the 
graphic or photo you want to apply a transparent area to, and then use the Set 
Transparent Colour tool to apply transparency to the image. 
You can also create a graphic with transparent areas in Photo Editor and then insert it 
into Word. For more information about using Photo Editor, search on the keyword 
transparent areas in the Online Help Index in Photo Editor. 

WORKING WITH FORMS ON WEB PAGES 

Create a form for a Web page 

Forms are frequently used on Web pages to collect and provide dynamic data. Some 
examples are forms that provide data from a database on request, registration forms 
for memberships or events, and forms that help users provide feedback about your 
site. 
Word helps you design the form and set the properties for the form elements. Because 
forms require additional support files and, therefore, additional server support, it is 
recommended that you consult your network or Web administrator when planning the 
form. 
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Sample forms, such as feedback and survey forms, are available from the Web Page 
Wizard. You can use the wizard to create a basic form and then modify it to fit your 
needs. Or if the wizard doesn't contain a form that suits your needs, you can create a 
form by inserting the controls you want. 
1 If the Web Page Wizard contains a form you want to use or modify, run the 

wizard, and choose the form you want. 
How? 
If you are creating a form without using the wizard, use the Blank Web Page 
template. 

2 Click where you want to insert additional controls. 
3 On the Insert menu, point to Forms, and then click the form control you want 

to use. 
4 Double-click the control to display properties for the form. 
5 Enter the properties for the form control using either the Alphabetic or 

Categorised tabs. 
6 Repeat steps 2 through 5 until you've added all the form controls you want. 

So that users can submit the form after filling it in, each form should contain a 
Submit or an Image Submit control. 

7 Add or modify any content that you want. 
8 When you are finished inserting form elements, click Exit Design Mode in 

the Control Toolbox. 

VIEWING WEB PAGES AND HTML SOURCE 

View the HTML source of a Web page 

When you save your Web page, Word works behind the scenes to create HTML tags, 
which Web browsers interpret to display your text, graphics, sounds, and videos. For 
example, when you press ENTER to create a new line, Word converts the paragraph 
mark to a <P>, or paragraph tag, in the HTML source. 
It's usually not necessary to view the HTML source as you author Web pages, but you 
can view it if you like. To view the HTML source, you should first save unsaved 
changes to the file. 

1 Click Save. 
2 On the View menu, click HTML Source. 

Note To return to the Web page, click Exit HTML Source 
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Preview a Web page while authoring it 

In order to preview the Web page you're authoring, you must have a Web browser 
installed on your computer. 

Click Web Page Preview 

Note To switch back to Word, click the Word icon in the task bar, or close the 
browser. 

WORKING WITH WEB PAGES AND WEB AUTHORING TOOLS 

Get the latest version of Web authoring tools 

Microsoft will periodically provide updated versions of the Web page authoring tools 
to keep up with changing technology. If you have access to the World Wide Web, 
Word will periodically check to see if a newer version of the Web authoring tools is 
available on the Microsoft Web site. If a newer version is found, a dialog box appears 
to notify you that a newer version is available. You can choose to download and 
install the latest version. You can also use the AutoUpdate command on the Tools 
menu to manually check for the latest version, if you have a dial-up connection to the 
World Wide Web. 

1 Open a Web page document. 
2 On the Tools menu, click AutoUpdate. 
3 If Word prompts you to download the latest version, click Yes. 

Learn about managing files and links on Web pages 

When authoring Web pages, you should manage the related files and plan the links 
and hyperlinks so the images will appear and the links will "work" once the pages are 
placed on the final HTTP server. In many cases, the location where you create your 
Web pages will be different from the location on which they will be published. For 
more information about publishing Web pages, click . 
When all the files % such as bullets, navigational buttons, background textures, and 
Web pages you create hyperlinks to% will be published on the same Web server, you 
should probably use relative links. Using relative links makes it easier to move 
materials to another location. If you move the files or send them to someone, you 
should maintain the same file structure, including subfolders. 
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For example, your Web page, called Pagel.html, includes bullets stored in the Bullets 
folder, so the relative paths for the bullet files are \Bullets\Bulletl.gif and 
\Bullets\Bullet2.gif. If you move Page I .html, you need to create a folder called 
Bullets in your new location where you can move the Bulletl .gif and Bullet2.gif files. 
When you insert items on your Web page% such as pictures, graphical buttons and 
lines, and hyperlinks to other pages % Word prompts you to save your current file. 
Saving is necessary so that Word can properly create links that are relative to your 
current file. 

Hyperlinks to other Web sites, such as a list of your favourite Web sites, should 
typically use a fixed file location that includes the full path, or URL. To indicate an 
absolute, or fixed, location, clear the Use relative path for hyperlink check boxes in 
the Insert Hyperlink dialog box (Insert menu). 
Images, sounds, and videos can't be embedded in Web pages as they can in Word 
documents. These items are stored in separate files. Word will export embedded 
images and OLE objects in Word documents as GIF images when you save your Web 
page. 

When you apply graphical bullets through the Bullets and Numbering command 
(Format menu), insert graphical lines with the Horizontal Line command (Insert 
menu), or add a textured background with the Background command (Format 
menu), Word saves these items as separate files in the same location as your Web 
page. You'll need to move these files along with your Web pages so your links will 
work, which is necessary for your images to appear. For example, bullets are saved as 
Bullet.gif, Bulletl.gif, Bullet2.gif, and so on; lines are saved as Line.gif and so on; 
and textured backgrounds are saved as Image.gif and so on. 
GIF and JPEG formats are common graphical formats used on the Web. When you 
insert an image that is not in either of these formats with the From File subcommand 
(Picture command, Insert menu), and the Link to file check box is cleared, the 
image will be saved in the GIF format. Word saves the images as Image.gif, 
Imagel.gif, and Image2.gif and so on in the same folder as your Word document. If 
you insert JPEG images, the JPEG format and file name extension (.jpg) is retained. 

Learn about charts, equations, and other objects on Web pages 

You can add charts, equations, and other objects to a Web page, although once you 
close the Web page, you can't update the objects as you can OLE objects. The chart, 
equation, or other object becomes a GIF graphic that you can no longer update. 
Insert a chart, equation, or other object by using the Object command on the Insert 
menu. Just keep in mind that you can't make changes to the object once you close the 
document. If you plan to work with a complex equation or chart that you want to 
continue to update, you can instead store it in a Word document and then paste it onto 
your Web page when you're finished working on it. 
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Make your Web page available to other people 

The steps that you take to make your pages available to other people depend on how 
you want to share them. 
To make pages available to other people on your network, save your Web pages and 
related files, such as pictures, to a network location. If your company uses an intranet 
based on Internet protocols, you may need to copy your pages to a Web server. 
Contact your network or Web administrator for more information. 
To make your Web pages available on the World Wide Web, either you need to locate 
an Internet service provider that allocates space for Web pages, or you need to install 
Web server software on your computer. Some factors to consider in setting up your 
computer as a Web server are your computer's speed and availability. If you don't 
want to leave your computer on most or all hours of the day, then you may not want 
to set up your computer as a Web server. 

If you are working with an Internet service provider or a Web administrator, you 
should ask how the Web pages, graphics files, and other files should be structured on 
the server. For instance, find out whether you need to create separate folders for 
bullets and pictures, or whether you need to store all the files in one location. If you 
plan to use forms or image maps, you should ask about any limitations on using these 
items, because they require additional server support. 

Setting up a Web server requires special software. You can use Personal Web Server, 
which is available on the Office 97 ValuPack on CD-ROM, to set up a Web server. 
You can also use Microsoft Internet Information Server to set up an advanced Web 
server. If you have access to the Web, you can learn more about Microsoft Internet 
Information Server. 

The differences between Word and Microsoft FrontPage for Web authoring 

Web page authoring tools are provided with Microsoft Word and with other Microsoft 
Office programs to enable you to easily create various types of Web pages. Another 
Microsoft program, called FrontPage, also helps you create various types of Web 
pages by using an interface that's similar to other Office programs. FrontPage also 
helps you to manage a Web site. 
To create Web pages, you can use the Web page authoring tools in Microsoft Word, 
Microsoft FrontPage, or both. Both programs provide wizards to automate your work, 
and both enable you to view your Web page content % such as bullets and images % 
as you work. There are some purposes, however, for which one program is better 
suited. 
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Use Web page authoring tools in Microsoft Word when: 

You want to use the robust word-processing features in Word, such as 
automatic spelling checking, AutoText, and AutoCorrect. 

Other Web page authors whom you work with frequently use Word. 
You have customised Word features% such as AutoText, custom dictionaries, 

and AutoCorrect entries% that you want to use when creating Web pages. 

Use FrontPage when: 

You want to use WebBot to insert scripts and form elements, such as server 
includes and timestamps. 

You are working with a large team or managing a Web server. 
You need user authentication for Web page authors. 

Note In the Microsoft FrontPage Explorer, you can specify Word as your default 
editor for HTML files. See FrontPage documentation for more information. 

I can't find Web page authoring tools. 

To use the Web authoring features in Word, you must use a Web page template or 
wizard, or convert an existing document to HTML, the format used for Web pages. 
When the Web authoring features are active, you'll notice that the toolbars and menus 
have been customised for working on Web pages. 
The Web templates are on the Web Pages tab in the New dialog box (File menu). To 
convert a document to HTML, click Save as HTML on the File menu. 

If you don't see the Web Pages tab, the Web features may not be installed. You may 
need to run Set-up again and select Web page authoring components. For more 
information, click . 

I can't find Web page files to open them. 

Once you have used the Web page authoring tools, your Web page files% those with 
.html, .html, .asp, or .htx extensions % appear by default in the Open dialog box (File 
menu). Before you use the tools, you can get Web page files to appear in the list by 
clicking All Files in the Files of type box. 
For more troubleshooting information about opening files, click . 
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USING VISUAL PAGE 
USING BASIC FEATURES 

Creating a new Web page 
There are essentially two kinds of Web pages you may create: a Web page with 
frames or a Web page without frames. A Web page with frames can display the 
contents of a different Web page in each of its frames. Like a picture holder that has 
multiple frames for displaying multiple pictures simultaneously, a framed Web page 
can display multiple Web pages simultaneously. A Web page without frames simply 
displays one Web page file. To continue the previous comparison, a Web page 
without frames is like a single picture frame that displays one photograph. 

To create a new Web page: 

1 From the File menu, selects New (or press Control-N). 
A new, untitled Web page opens in Edit mode. 

2 Add graphics, text, plugging, links, and Java applets directly to your new Web 
page. 
3 Save your Web page in a folder dedicated to your collection of Web pages. 

To create a Web page that includes frames: 

1 From the File menu, chooses New Frame Set. 
Visual Page displays a Web page, which is divided into two frames of equal 

size. 
2 You may directly add the text, HTML tags, graphics, and plug-ins to each 
frame, or you may open an existing Web page file in a frame. For more information, 
see Setting the frame source . 
3 Save your Web page in a folder dedicated to your collection of Web pages. 
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Setting the frame source 

A Web page with frames, also known as a frame set, can display multiple Web pages 
by having a different Web page assigned to each frame. You can set a frame to 
display a particular Web page by using the Set Frame Source menu item to assign a 
particular Web page HTML file to the selected frame. 

To set the source file for a frame: 

1 Make sure a frame is selected in an open Web page. 
2 Select Frame > Set Frame Source. 

A standard Open file dialog box displays. 
3 Navigate to and select the HTML files you want the selected frame to display. 
4 Click open. 

A Visual Page Frame Save dialog box displays. 
5 Save the changes to the frame. · 

If you have not given the frame a name, a Save As dialog box displays. 
6 Enter a name for the frame and save it. 

Visual Page displays the Web page in the selected frame. 

Starting from an existing Web page 
The standard Visual Page installation places several professionally designed templates 
in your Visual Page directory. You can use these pre-existing Web pages as the basis 
for your own Web pages. Opening a Visual Page template is the same procedure you 
will use to open a Web page on which you have previously worked. 

To open an existing Web page: 

1 Select Open from the File menu (or press Control-0). 
2 Navigate to the directory where the file you want to work on is located. 
3 Select the file, and click Open. 

The Web page opens in Edit mode. 

Saving a Web page 

When you save a Web page file and name it, make sure that you preserve the HTML 
filename extension. All Web page files must end with a .html or .html filename 
extension. Visual Page's default filename extension is .html. You can change the 
default filename extension in the Preferences dialog box. 
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To save a Web page without frames: 

1 From the File menu, chooses Save or if you want to save a copy of a file with 
a different name, choose Save As. 
2 Navigate to the destination folder for the saved file. 
3 Enter the file name. 

Visual Page includes the default file extension. 
4 Click Save. 

The file is saved to the destination folder. 

Overview of preferences 

Visual Page provides a variety of preferences settings that you can use to customise 
your Web page building environment. If you choose Preferences from the Edit menu 
the Preferences dialog box displays. It includes tabs for: 

1 Setting General Preferences 
2 Setting Output Preferences 
3 Setting Images Preferences 
4 Setting Folder Mappings Preferences 
5 Setting FTP Preferences 
6 Setting Syntax Colour Preferences 

Setting Page Default Preferences 

Use the Page Defaults tab of the Preferences dialog box to set defaults preferences for 
every new page you create with Visual Page. If you want to restore these preferences 
to the default settings, click Use Defaults. If you want to change back to the settings 
that were in place before you opened this dialog box, click Revert. 

To set Page Default preferences: 

1. From the Edit menu, choose Preferences. 
The Preferences dialog box appears. 

2. Click the Page Defaults tab. 
3. Use the dialog box to select the page default preferences you want. 

The preferences are listed below. 
4. When you're finished setting preferences, click OK. 
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* Background sets the default background colour. 
Normal Text sets the default colour for normal text/ 
Normal Links sets the default colour for normal links/ 
Active Links sets the default colour for active links. 
Visited Links sets the default colour for visited links. 
Background Image You can have each new page use a default image as a 
background. 

* 
* 
* 
* 
* 

1 Click the checkbox or click the ellipses. 
The Open dialog box appears. 
Locate the image you want to set as a default background. 
Click Open. 
The selected image appears in the Image Preview window. 
Click OK to make the image the default background image. 

2 
3 

4 

Previewing your work 

To see how your Web page will look in a browser, use the Preview Mode. You'll 
know you're in Preview Mode when the Edit Page toolbar button is active and the 
Preview Page toolbar button is inactive. 

To go to Preview Mode: 

1 From the Edit menu, choose Preview Page. If instead you see Edit Page, you 
are already in Preview Mode. 

2 You can also click the Preview Page tool bar button. 

Printing Web pages 

Using Visual Page, you can print your Web pages as they will appear in a browser. If 
you want to print out the HTML source, make sure that the Source Window is active. 

To print a Web page: 

1 From the File menu, selects Print (or press Control-P). 
2 Select the desired print options. 

Visual Page prints your document. 
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ADDING TEXT 

Adding text 

Adding text to your Visual Page documents is very similar to inserting text using any 
standard word-processing application. The following procedures explain how to insert 
and format text. 

You can insert text by: 

Typing text 
Dragging and dropping text 
Copying and pasting text 
Importing a plain text file 

You can format text by: 

Generating paragraphs and line breaks 
Aligning and indenting paragraphs 
Formatting paragraphs 
Formatting characters 
Creating bulleted lists 
Creating ordered lists 
Creating term and definition lists 

Typing text 

If you have ever used a word processor to create a text document, you probably know 
how to type text into a Web page in the Visual Page environment. Visual Page 
supports all the standard text operations. 

To insert text by typing: 

1 Make sure that you're in Edit mode. 
For information on switching to Edit mode, see Previewing your work. 

2 Within the main Edit window, moves the text cursor to where you want to 
insert text. 

3 Single-click at the insertion point. 
4 Type in your text. 

The text displays on the Web page. 
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Dragging and dropping text 

Visual Page supports drag-and-drop functionality in many ways. It is an extremely 
handy way to move text from one location to another. Visual Page also allows you to 
insert other objects, such as images, from the Windows Explorer into Visual Page. 

To insert text by drag-and-drop: 

1 Make sure that you're in Edit mode. 
For information on switching to Edit mode, see Previewing your work. 

2 Make sure that the files that you want to drag to and from are open. 
3 Select the text you wish to move. 
4 Click on the selection, and, without releasing the mouse button, move the 

selection to the new location. 
5 Release the mouse button. 

The text is now in the new location. 

To insert other objects into Visual Page: 

1 Make sure that you're in Edit mode. 
For information on switching to Edit mode, see Previewing your work. 

2 Locate the object ( e.g. image) you want to insert with the Windows Explorer. 
3 Press and hold the Control key while dragging the object from Explorer into 

Visual Page. 
When you release the mouse and control key, the Save As dialog box appears. 

4 At this point, you can rename the object, or click OK to use the default name. 
The object is added to your page. 

Importing a plain text file 

This feature allows you to instantly fill your Web page with the text from a text file. 

To insert text by importing a plain text file: 

1 Make sure that you're in Edit mode. 
For information on switching to Edit mode, see Previewing your work. 

2 Position the cursor where you want the text to display. 
3 Using the Local Site window, select the plain text file. 

For more information see, Opening a Local Site window. 
4 Drag the plain text file from your Local Site window and drop it on your Web 

page. 
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The contents of the text file displays on your Web page. 

Using the Spelling Checker 

You can check the spelling in your page at any time by clicking the Spelling Checker 
icon. The Spelling Checker checks the spelling in the entire page, but does not check 
spelling of words that you highlight. The functions available are: 

1 Ignore skips the current word and continues spell checking. 
2 Ignore All skips all instances of this word. 
3 Add places the current word into the dictionary. 
4 Change replaces the current word with the word in the Change To window, or 

to the word that is highlighted in the Suggestions window. 
5 Change All replaces all instances of this word with the word in the Change To 

window or to the word that is highlighted in the Suggestions window. 
6 Suggestions automatically provides a list of alternatives to the current word. 
7 Edit Dictionary opens the Personal Dictionary. In the personal dictionary, you 

can add, modify, or delete entries. 
8 Cancel exits the Spelling Checker, but does not cancel any previous spelling 

changes made with the Spelling Checker. 

FORMATING CHARACTERS 

Formatting characters 

You can format individual characters to make words display differently, rather than 
affecting a whole paragraph. You can format individual characters by changing 
character styles or character size. 

To apply a character style: 

1 Select the character: 
2 From the Style menu, choose a style, colour, or size. You can also select a 

style, colour, or size by clicking one of the tool bar buttons. 

Physical character styles include the following standard HTML styles: 

The Bold, Italic, and Fixed Width Font styles can be quickly accessed by these toolbar 
buttons: 

Visual Page also supports these Netscape extensions to standard HTML character 
styles: 
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How these styles will appear depends on each browser's default settings. 

Changing character size 

The size of text in a Web page is relative to the default size setting for each browser. 
This is why the font .sizcs in the Size menu item (on the Style menu) are relative 
numbers 1 through 7, instead of the point sizes you see in a word processor, such as 
12 or 14. 
Visual Page uses the middle font size (number 4) as the "normal" font size. This is the 
browser's default display font. The other numbers signify either a smaller or larger 
font than the browser default, with 1 being the smallest font size and 7 the largest font 
size. 

To change the size of a character: 

1 Click Decrease Font Size or Increase Font Size on the toolbar. You can also 
choose Size from the Style menu, and then choose a number. 

A checkrnark displays next to the selected size. 

Working with fonts 

Visual Page allows you to use the fonts that are installed on your system to enhance 
the look of your Web pages. However, not all fonts are cross-platform compatible, 
and may not display correctly on other platforms. 
You can work with fonts in three ways in Visual Page by: 

Changing fonts 

You can change the font of selected text in your Web page to any other available font. 

To change a font: 

1. Highlight the text in your page that you want to change. 
2. Click on the Font pull-down menu. 

The list of available fonts appears. 
3. Select the new font that you want to apply. 

The font of the highlighted text changes. 
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Creating font groups 

Font groups are groups of fonts that usually have some common characteristic to 
preserve the original design of the Web page. Font groups allow the Web browser to 
substitute fonts from a group of assigned fonts when one or more fonts are not 
available on the client machine. When no font in a group is available on the client 
machine, the Web browser uses default fonts available on the client machine. 

With Visual Page you can create and assign font groups that make your pages look 
their best across different platforms and browsers. 

To create a font group: 

1. From the Font pull-down menu, select Font Groups. 
The Font Groups window opens with the names of default font groups. 

2. Click a blank cell in the Group Name column and enter a name for the new 
font group. 

3. Click the Font Names cell and enter font names separated by a comma. 
4. Click the OK button when you are finished entering font names. 

The font group is added to the Font pull-down menu. 
You can also assign a font group on the fly. 

Assigning font groups 

You can assign font groups in your Web page to allow the Web browser on the client 
machine to substitute fonts when the original font is not available. 

To assign a font group: 

1 Highlight the text to which you want to apply a font group. 
2 From the Font pull-down menu, select a font group. 

The selected font group name appears in the pull-down menu and is applied to the 
highlighted text. 
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WORKING WITH PARAGRAPHS 

Generating paragraphs and line breaks 

Paragraphs and line breaks generate different effects in the display of your Web page. 

Use a line break instead of a standard new paragraph if you want to create a space 
between lines without applying the previous paragraph's formatting. You can also use 
multiple line breaks to display multiple lines without text, However, a paragraph 
marker cannot generate multiple empty lines in a Web browser because HTML 
specifications allow only one empty paragraph line. 

To generate a new paragraph: 

1 Place the insertion point where you want the new paragraph to start. 
2 Press the Return key. 

Your cursor goes to a new line and Visual Page generates a paragraph tag in 
the HTML source. 

To create a line break: 

1 Click where you want the new paragraph to start. 
2 Press Shift-Return. 

Visual Page generates a line break (<BR>) tag in the HTML source. 

Aligning and indenting paragraphs 

You can make paragraphs line up against the left margin, the right margin, or the 
centre of the Web page by setting paragraph alignment. You can also format by 
indenting paragraphs. 

To align a paragraph: 

1 Click anywhere within the paragraph. 
2 Click on one of these three alignment tool bar buttons: . The choices are left 

aligned, centre-aligned, and right aligned, respectively. You can also choose, 
from the Format menu, Align Left, Align Right or Align Centre. 
The paragraph aligns according to the alignment option you choose. 
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To indent a paragraph: 

1 Click anywhere within the paragraph. 
2 Click on one of these two indent paragraph tool bar buttons: . The choices are 

Decrease Indent and Increase Indent , respectively. You may also choose 
Format > Increase Indent or Format > Decrease Indent. 
The paragraph indent changes. 

Formatting paragraphs 

Apply paragraph formats to make sections of text display differently, such as 
~eadings, quotes, and mono-spaced (preformatted) text. Visual Page supports these 
paragraph formats: 

Normal 
Headings 
Pre formatted 
Address 

To apply a format to a paragraph: 

1 Click anywhere in a paragraph. 
2 Choose a format from the pop-up menu on the toolbar, or from the Format 
menu. 

Visual Page formats the paragraph accordingly. 

Normal paragraph style 

Normal text is the default style, which is applied when you begin a new paragraph on 
a blank page. (The paragraph you are reading now is formatted with the Normal tag.) 
The text appears flush left in the page window and is displayed in the Visual Page 
default font. 
Use the Normal style for most text in a Web page. 

Heading paragraph style 

Heading tags are used to make headlines or titles distinct from the rest of the text in a 
page. In general, headings are larger than the Normal style, and are in a bold typeface. 
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Heading 1 
Heading 2 
Heading 3 
Heading 4 

Heading 5 

Heading6 

You may also manually specify the font size of a text block instead of using the 
Heading style. 
The heading types supported by Visual Page are: 

Preformatted paragraph style 

uses multiple spaces and tabs, such as the formatting found in code segments. 

Preformatted paragraphs are displayed in moonscape fonts, such as Courier. You can 
see an example of a preformatted paragraph in the following HTML code sample: 

Address paragraph style 

Web page authors typically apply the address style to a paragraph containing a 
signature address. An example of how it is used is shown below: 
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Send comments to the author: 

webmaster@symantec.itools.com 

Choosing to include an address is a matter of style. When you include an address, 
remember to make it an email link. 

CREATING LISTS 

Creating bulleted lists 

Bulleted lists are useful when you want to make some information easy to see. Visual 
Page supports bulleted lists and indented bulleted lists. 

To create a bulleted list: 

1 Select the text you want to change to bulleted list style. 
2 From the Format Paragraph drop-down list on the toolbar, select Bullet List. 

You can also select Format> List> Bullet. 
Visual Page indents the text and places a bullet character to the left of the text 

in the paragraph. 
3 You can apply indentation to the bulleted list by using the Increase Indent 
toolbar button to a bulleted paragraph. 

When you apply added indentation to a bulleted paragraph, the look of the 
bullet changes with the indentation. 

Creating ordered lists 

When you apply any of the ordered list formats to a paragraph, Visual Page indents 
the text and places a number or letter to the left of the paragraph. 

To create an ordered list: 

1 Select the desired text. 
2 Select Format> List and choose the desired type of ordered list. 

To create a numbered list: 

1 Select the desired text. 
2 Click the paragraph tag drop-down list on the toolbar, and select the 
Numbered List tag. 
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Creating term and description lists 

The term and description formats are designed to be used together in lists of 
definitions. The format is similar to what you would find in a Glossary. 
Applying the Term format to a paragraph places the paragraph text flush left at the 
left margin. When you press the return key after applying a Term format to a 
paragraph, Visual Page automatically applies the Description format, then indents the 
text of the paragraph. 

To create a term and description list: 

1 Select the text which you want in the term format. 
2 From the paragraph tag drop-down toolbar button select Term. 

The selected paragraph displays in the Term format. 
3 Select the text, which is to be in the definition format. 
4 From the paragraph tag drop-down toolbar button select Definition. 
5 Repeat steps 1-4 for the remaining terms and definitions. 

USING GRAPHICS AND IMAGE MAPS 

Adding graphics 

You can add graphics to your Web pages by either using drag-and-drop, the Insert 
Image toolbar button, or copy and paste. Graphics must be in BMP, DIB, GIF, or 
JPEG graphic format before you can insert them into a Web page. Visual Page 
automatically converts .bmp and .dib files into interlaced GIF files when you place 
them in your Web page. There is a setting in the Image Preferences for storing the 
new GIF files from these conversions. 
To add a graphic by using drag-and-drop: 

1 Open the Local Site Window, and navigate to the desired graphic's location. 
2 Select desired graphic file, and drag it over to your Web page. 

The image appears full size in your Web page. 

You can also drag and drop graphics from another open Web page, as long as the 
browser supports drag and drop. 
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To add a graphic by using Insert Image: 

1 Place your cursor at the desired location. 
2 Click on the Insert Image button ,or choose Image from the Insert menu. 

A standard Open file dialog box opens. 
3 Navigate to the graphic file you want, and click Open. 

The image displays in your Web page. 

To add a graphic by using copies and paste: 

1 Copy a selected graphic to your clipboard. 
2 Paste it into your Web page. 

The image displays in your Web page. 

Aligning graphics and text 

You can align graphics in a variety of ways. Using graphic alignment settings you can 
also flow text around graphics. You can see a good example of how to format images 
with text in the Visual Page Getting Started tour. 
To align graphics: 

1 Use the Graphic Alignment button on the Visual Page toolbar. You can also 
choose Graphic Alignment from the Settings menu. 

2 Select the graphic alignment you want. 
In general, use the first three options, Top, Bottom, Middle, for small graphics 
that appear in a line of text, like the image in step one. You use the Left and 
Right alignment options when you want to flow a paragraph of text around a 
larger graphic. 

To flow paragraphs of text around graphics: 

1 Select the graphic. 
2 Select Left from either the Graphic Alignment toolbar button, or choose 

Object Alignment from the Format menu. 
3 Insert your cursor to the right of the graphic and enter a paragraph or two of 

text. When the line wraps it returns to the right edge of the graphic, until it 
reaches the bottom of the graphic. 
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Creating transparent graphics 

This feature is useful if your Web page has a coloured background, which is obscured 
in part by an opaque graphic image. In this case, you could use Visual Page to make 
the image transparent so the background colour would show through. Only GIF files 
can be made transparent. 

To make your image transparent: 

Open the graphic file. For more information, see Opening a graphic image file. 
The graphic displays in the Visual Page's graphic editor. 

2 Click the transparency toolbar button on the Image Tools Toolbar. 
3 Click any colour in the image and that colour is rendered transparent. 

When you put the altered graphic in a Web page, you see the Web page's 
background through the image. 

2 To revert a transparent graphic and thus remove the transparent quality, click 
the Remove Transparency toolbar button on the Image Tools Toolbar. 

Setting graphic image properties 

Visual Page supports a range of attributes that are contained within any supported 
graphic. These attributes control the height, width, function, alternate text, and 
spacing around a graphic. 

To set a graphic image's properties: 

1 Make sure that you're in Edit mode. 
For information about how to switch to Edit mode, see Previewing your work. 

2 Select a graphic in a Web page. 
3 From the Edit menu, select Properties, then choose Image Properties. 
4 Use the options in the Image Properties dialog box to set the graphic' s 

attributes. These attributes are described in the table below. 
5 Click OK. Your graphic's settings are adjusted accordingly. 
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Attribute 
Image 
Width 

Height 
Original width 
Original Height 
Horizontal 

Vertical 

Border 

Image 

Has server map 

Submit form button 

Alternative text 

Button name 

Creating image maps 

Description 
The location and filename of the image file. 
The display width of the image, in pixels. Visual Page supports 
image scaling (changing an image's height and width). The 
width and height indicated in the Image Setting dialog box are 
the dimensions of the image as scaled in the HTML file. The 
actual dimensions of the image are indicated in the Original 
Width and Original Height fields, as described below. 
The display height of the image, in pixels. 
The width of the source images, in pixels. 
The height of the source image, in pixels. 
The blank space to the left and right of the image, in pixels. 
The default setting is zero. 
The blank space to the top and bottom of the image, in pixels. 
The default setting is zero. 
The width of the border around an image, in pixels. An image 
border is black and is similar to a frame around a painting. The 
default setting is zero, which indicates no border. 
Select this option if the graphic file functions only as an image. 
This is the default function for graphic files. 
Check this box if the graphic file acts as a server-side image 
map. 
Select this option if the graphic file acts as submit button for a 
form. 
If you type in text here, it displays in a user's browser if the 
image doesn't load properly, or if it can't be displayed by a 
user's browser. Note: The alternative text option is not for 
graphic files that function as a form submit button. 
(For buttons only) The name of the button. This is NOT the 
same as the name of the button's source file. A CGI script uses 
this name as an ID. 

Client-side image maps store the co-ordinates that define the linked areas of an image. 
These image maps are inserted directly into the HTML file. As such, the image map is 
downloaded to and referenced entirely from the user's machine (hence the name 
client-side). Visual Page creates these Image maps for you as you use drawing tools to 
outline and link areas of an image. 
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To create a client-side image map: 

1 Make sure that you're in Edit mode. For information about how to switch to 
Edit mode, see Previewing your work. 

2 Insert a graphic by clicking the Insert Graphics tool bar button. For information 
on inserting graphics, see Adding graphics. 

3 Right-click on the graphic and select Local Map Tools or select View > 
Toolbars > Image Tools from the menus. 

4 The Image Tools toolbar displays. 
5 Create the clickable areas of the image by doing the following: 

Click the rectangle, circle, or polygon Hotspot buttons on the toolbar. 
Click and drag on the graphic file to create a hotspot area. 
To end creating a polygon hotspot, double-click. To end creating a circle or 
rectangle hotspot, release the mouse button. 

6 Create the URL for each of the clickable areas. 

You can do this by either dragging a file or anchor icon from the Local Site window 
onto the selected link area, typing the link address into the Link field at the bottom of 
the main edit window, or right-clicking on the desired link location to open the Link 
To dialog box. You may also double-click on the hotspot to open the Link To dialog 
box. 

To move overlapping hotspots: 

1 Select a hotspot you want to move forwards or backwards. 
2 Click the Front-to-back Order button on the Image Tools toolbar. 
3 Choose Move to Front, Move Forward, Move to Back, or Move Backwards. 

The hotspot will change position. 

To delete hotspot areas: 

Select the hotspot area, and press Delete. 
To save your client-side image map: 
Select File> Save or press Ctrl+ S. 
To make the shapes easier to see, specify the colour of these areas by choosing the 
desired colour from the colour menu button. 
You may also use the Zoom buttons to adjust the graphic to the optimal size for 
outlining links. 
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Setting Images preferences 

Use the Images tab of the Preferences dialog box to set the Visual Page preferences 
described below: If you want to restore these preferences to the default settings, click 
Use Defaults. If you want to change back to the settings that were in place before you 
opened this dialog box, click Revert. 

To set images preferences: 

1 From the Edit menu, chooses Preferences. 
The Preferences dialog box appears. 

2 Click the Images tab. 
3 Use the dialog box to select the Images preference options you want. The 

preferences are listed below. 
4 When you're finished setting preferences, click OK. 

Converted Images Visual Page automatically converts .bmp and .dib files into 
interlaced GIF files. The following options tell Visual Page 
where to place the new GIF files.n Always store the new GIF 
file in same folder as the source documentn Use this image 
folder 

Default Image Map Server Format Visual Page supports server-side image 
maps if you need to use them. The two Server-Side image map 
formats are either CERN or NSCA. 

Setting Image properties 

By using the Image properties dialog box you can: 

1 Resize your image -this is handy if you have an image you want to use more 
than once in your Web site and want to optimize its size for the different 
locations 

2 Adjust the space around an image - this adds a fixed number of pixels of space 
horizontally or vertically around the image. Or, you could opt to create a 
border of space around the whole image. You might want to add space around 
an object when it is embedded in some text or has text flowing around it 

3 Change the function of your image- besides functioning as inert object, images 
can be set to work with an image map, so links can be embedded in the image, 
or as a Submit button which you would provide on a Web page form to 
transmit data in response to a user's click 

3 Alternative text - it's a god idea to provide a short caption which browsers that 
don't display graphics will display instead of the graphic 
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Creating a background 

You can create a coloured or tiled background for your Web page. 
To create a coloured background: 

1 In an open Web page document, click on the Page Properties toolbar button. 
2 Choose a colour from the Background colour well. If you want the 
background set according to each browser's default settings, select Default. 

Using a graphic file to tile your Web page background: 

1 In an open Web page document, click on the Page Properties toolbar button. 
2 Click the Background Image checkbox. 

An Open File dialog box appears. 
3 Navigate to the graphic file you're going to use, then click Open. 

A representation of the tiled graphic appears. 
4 Check the appearance of the tile on your Web page by clicking on the Apply 

button. A graphic may look interesting by itself, but may not be appropriate 
for use as a tiled background. 

To remove a background image: 
Uncheck the Background Image checkbox. 

Adding horizontal lines 

Horizontal lines can be useful layout tools, which can be used to break up a long Web 
page. However, they should be used sparingly or your Web page will appear to be 
choppy. Horizontal lines are easy to add in Visual Page and you may even play with 
their appearance by setting their properties. 

To add a horizontal lines: 

1 Place your cursor where you want the line to be inserted. 
2 Click the Insert Horizontal Line toolbar button. 

To change the properties of a horizontal line: 

1 Select a horizontal line by clicking directly on it.. 
2 Choose Edit > Properties > Line Properties ( or press F 4 ). 

The Line Properties dialog box displays. 
3 Set the shading, size, and alignment using the dialog box. 
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CREATING LINKS AND ANCHORS 

Creating links and anchors 

Hypertext links, also known as links, are one of the most important parts of a Web 
page. Links allow you to connect Web pages together. 

The following topics tell you more about creating and using links in your Web pages: 
Creating links with the Create Link dialog box 
Creating links with the Link Toolbar 
Creating links with the Site Window 
Copying an existing link 
Creating email links 
Creating and linking anchors 
Tes ting links 
Creating image maps . 

Creating links with the Create Link dialog box 

You can create a link to a selected object by using the Create Link dialog box. Using 
this dialog box, you can either enter the URL yourself or browse to locate the file 
you're linking to so Visual Page will generate the URL. 

To create a link with the Create Link dialog box: 

1 Select the object to be linked. 
2 Click the Hyperlink button in the Insert toolbar. The Link dialog box displays. 
3 Determine the file to be linked by either typing in the filename or URL of the 

file, or by clicking Browse and navigating to the file you want. 
Your link is created. 

Creating links with the Link Toolbar 

The Link Toolbar displays at the bottom of the Visual Page window. It consists of a 
label and a text field. 

- 71 - 



NEAR EA91 tlNIYER9TY 
COMPUTER ENQ/NEER/NQ 

1988 

To create a link using the Link Toolbar: 

1 Select the object to be linked. 
2 At the bottom of the Edit window, select the Link to field in the Link toolbar. 

If you do not see the Link to field at the bottom of the Edit window, select 
Toolbars > Link to make the link field display. 

3 Type in the filename or URL in the Link to edit box. 
4 Pressing Return and your link is created. 

Creating links with the Local Site Window 

You can use the Local Site window to drag-and-drop files on selected objects in your 
Web page to create a link. 

To create a link using the Local Site window: 

1 Open a Local Site window for your current project. 
For more information see Opening a Local Site window. 

2 Select the text or graphic image on your Web page that you want to link. 
3 Drag the file or anchor you want to link to from the Local Site window and 

drop it on the selected object. 

Copying an existing link 

If you want multiple links to the same place, such as to a home page, you can create 
the link once and copy and paste the rest of the links. 

To copy an existing link: 

1 Select the link you wish to copy. 
2 From the Edit menu, choose Copy (or press Control-C). 
3 Click where you want the link to be copied to. 
4 From the Edit menu, choose Paste (or press Control-V). 

Creating email links 

When an email link is clicked on, the browser opens up a pre-addressed email 
message window. 
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To create an email link: 

1 Create the link text that will display on a Web page. For example: 
user@company.com 

2 Highlight the link text. 
3 Click on the Link to: field and enter the text in the following format: 

mailto:user@company .com 
4 Replace user with the email address of the person being emailed, and 

company .com with there Internet address. 

Creating and linking anchors 

Anchors are used to mark specific locations within a document. Once an anchor is 
placed in a location, you can create a link to that spot. 

To add an anchor to a Web page: 

1 Click in your Web page where you want to put the anchor. 
2 Select on the Insert Anchor button in the Insert toolbar or select Insert > 

Anchor. 
The Anchor Properties dialog box displays. 

3 Name the anchor, and click OK. 
An anchor icon appears in your text. 

4 Select the object to be linked to the anchor. 
5 Click Create Link button in the Insert toolbar or right Click and select Link to. 

The Link to dialog box appears. 
6 Select the anchor from the drop down list box and click OK. 

The link to the anchor is displayed next to the object. 

Testing links 

You should test your links periodically to make sure they work. It's easy to break links 
when you're constructing Web pages. Since links are really URLs which record the 
location of a file or anchor, you can break a link by inadvertently changing the name 
of a file or of the folders in which the file resides. 
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To test links in your Web pages, use one of the following methods: 

1 In Edit Mode, hold down the Control key while clicking over the link. This 
opens the linked file. 

2 From the Edit menu, choose Preview in Browser. Your Visual Page document 
opens in the Web page browser which resides on your hard disk. You can then 
browse your document as you would any Web page. 

3 From the Edit menu, choose Go To Preview Mode. You can browse and click 
while still within Visual Page. 

USING FRAMES 

Creating frames 

Frames divide the parts of a Web page into two or more independent parts (frames), 
each displaying a separate HTML file. 
To create a Web page that includes frames: 

1 Choose File> New Frame Set or press Ctrl +Shift+ N. 
Visual Page displays a frame file with two frames of equal size. 

2 You may directly add the text, HTML tags, graphics, and plug-ins to each 
frame, or you may open an existing Web page file in a frame. For more 
information, see Setting the frame source. 

3 Save your Web page in a folder dedicated to your collection of Web pages. 
For more information, see Saving a Web page with frames. 

Additional Frame Set functions include: 

Opening a frame in a new window 
Setting a frame's attributes 
Setting the frame target 
Resizing a frame 
Removing a frame 
Splitting frames 
Editing the No Frames settings 

Editing the No Frames setting 

The No Frames window lets you specify what content will display when a user's 
browser doesn't support frames. 
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To use the No Frames window: 

1 Open the main frame file. 
2 Choose Frame > No Frames Page. 

The No Frames page displays. 
3 Enter or edit the content of the page. 
4 Close the No Frames page. 

Opening a frame in a new window 

If you have many Web pages which are accessed through the same Web page with 
frames you may want to navigate your Web site in Preview mode. When you see a 
displayed file that needs editing, opening a frame into a separate window makes it 
easier to edit the Web page. 

To open a frame file in a new window: 

1 Open the main frame file. 
2 Select the frame to be opened in a new window. 
3 Choose Frame> Open in New Window. 
The frame file opens in a new window. 

Removing a frame 

If you add too many frames to your Web page you can use the following procedure to 
remove the selected frame. 

To remove a frame: 

1 Open the main frame file. 
2 Select the frame file to be removed. 
3 Choose Frame > Remove Frame. 

Resizing a frame 

Resizing a frame can be done visually on the Web page by dragging frame borders or 
via the Frame Properties dialog box. 
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To resize a frame: 

1 Use the resize bar to resize the frame manually. You can also choose Edit> 
Properties > Show Frame Properties, and enter the desired width in the Width 
field. 

Setting the frame source 

A Web page with frames, also known as a frame set, can display multiple Web pages 
by having a different Web page assigned to each frame. You can set a frame to 
display a particular Web page by using the Set Frame Source menu item to assign a 
particular Web page HTML file to the selected frame. 

To set the source file for a frame: 

1 Make sure a frame is selected in an open Web page. 
2 Select Frame > Set Frame Source. 

A standard Open file dialog box displays. 
3 Navigate to and select the HTML files you want the selected frame to display. 
4 Click open. 

A Visual Page Frame Save dialog box displays. 
5 Save the changes to the frame. 

If you have not given the frame a name, a Save As dialog box displays. 
6 Enter a name for the frame and save it. 

Visual Page displays the Web page in the selected frame. 

Saving a Web page with frames 

A frame set, or Web page with frames, has more than one HTML Web page file 
associated with it. The frame set file contains information about the Web page that 
contains the frames. And, each frame displays its own separate HTML file. So, when 
you save a frame set you probably will be prompted to name more than one Web page 
file. Visual Page's default filename extension is .html. You can change the default 
filename extension in the Preferences dialog box. 

To save a Web page frame set: 

1 From the File menu, chooses Save Frame Set. 
Or, if you want to save a copy of a frame set file with a different name, choose 
Save Frame Set As. 

2 In the Save or Save As dialog box, navigate to the destination folder for the 
frame set and select it. 

3 Enter a filename with a .html or .html extension. 
4 Click the Save button. 
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If you made changes to any of the frames in your frame set, the Save Frame or 
Save Frame As dialog box displays. 

5 If asked, enter a name for the frame file, and click Save. 
If you made changes to other frames, another Save Frame or Save Frame As 
dialog box displays. 

6 Enter names and click Save until all the changed frame files are saved. 

Setting a frame's attributes 
<See Also> 

Frames have a set of properties you can set. Most of these can be changed as you 
visually edit the page. The frame properties are described below. 

To edit a frame's properties: 

1 Choose Edit> Properties > Show Frame Properties. 
2 The Frame Properties dialog displays. 
3 Use the options in the Frame Properties dialog box to set the frame's 

attributes. 
These attributes are described in the table below. 

4 Close the Frame Properties dialog. 

Attribute 
Source 
Frame titles 

Frame width 

Frameset height 

Margin width 
Margin height 
Show scrollbar 

Resizable frame 

Definition 
The HTML source file for a frame. 
The frame's name. This is NOT the same as the name of the 
source file. The frameset file (the file that contains the frames 
within a frame set) uses this name as an ID. 
The width of the selected frames, either as a percentage of the 
total frame set, or in pixels. 
The height of the frame set, either as a percentage of the total 
frame set, or in pixels. 
The width of the selected frame's margin, in pixels. 

The height of the selected frame's margin, in pixels. 
The settings for the frames scroll bars. Possible choices are 
Yes, No, and Auto. The default is Auto, which makes the scroll 
bars appear only when the frame extends beyond the length of 
the active window. 
Indicates whether or not the selected frame resizes along with 
the user's browser. The default is checked, which indicates that 
the selected frame will resize 

- 77 - 



NEAR EAST tlNIVERSTY 
COMPUTER ENQINEER/NQ 

1988 

Setting Frame properties 

Use the Frame properties to set the properties which pertain to a selected frame of a 
frame set. Use the Frame properties dialog box to check, assign, or change these 
values. 

To set frame properties: 

1 Select the frame whose properties you are setting by clicking once anywhere 
in the frame. 
A heavy black border outlines the frame. 

2 Choose Edit> Properties > Show Frame Properties. 
The Frame Properties dialog box displays. 

3 Set the properties as they are described below. 

The frame property settings: include the following: 

Source Name of the HTML file which you want to display in this 
frame, for instance, HomeTOC.html is an appropriate value. 
Title for the frame, otherwise Visual Page uses the random 
number shown as the default in this field. 
Width of the margin. 
Height of the margin. 
This only applies if there are frames below other frames in the 
frame set. 
Specifies the thickness of the frameset border. Set to O for 
borderless frames. Leave it empty to use the default border 
thickness. 
Defaults to automatically showing scrollbars when they're 
needed. 
Checked by default, if you don't want people to change the size 
of a frame, uncheck it. 

Frame title 

Margin width 
Margin height 
Frameset height 

Frameset Border 

Show scrollbars 

Resizable frame 

Setting the base target for a frame 

Visual Page allows you to select a base target for all the links in a frame. An example 
of using a base target is to direct all the hypertext links in a left-hand frame to appear 
in the neighbouring right-hand frame. 
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To set a base target for the links in a frame: 

1 Open a frame set, and make sure the frames are already named and saved. 
2 Make sure that you're in Edit mode. 

For information about how to switch to Edit mode, see Previewing your work. 
3 Click on the frame you are setting as a base target. 
4 Choose Edit > Properties > Page. 
5 Click the Select Base Target button. The Base Target dialog displays. 
6 Click a frame in the reproduction of your frame set. Set a base target for that 

frame by selecting one of the Base Target options. 
The Base Target options are described below. 

7 Click OK to set the base target for the selected frame. 

Tip: To set the base target for additional frames in your frame set, repeat steps 6 and 
7 for each frame. 

Base Target option 
Default 

New window 
Same frame 

Same window 

Parent window 

Splitting frames 

Description 
Makes the linked file display in the same frame as the current 
frame file. This is the default setting. How the default setting 
performs depends on each browser's configuration. 
Makes the linked file display in a new, untitled window. 
Makes the linked file display in the same frame as the current 
frame file. 
Makes the linked file display in the same window as the current 
frame file. 
Makes the linked file display in the parent window of the 
current frame file. The parent window is the window that was 
active, then a link opened which caused the current frame file 
to display. 

Visual Page lets you add frames by splitting existing frames into two equal parts, 
either horizontally or vertically. 

To split a frame: 

1 Open the main frame file. 
2 Select the frame to be split. 
3 Choose Frame > Split Frame Vertically or Frame > Split Frame Horizontally. 

The frame is split. 
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CREATING TABLES 

Creating tables 

Tables can hold all kinds of Web page elements and are useful in formatting and page 
layout tasks. You can easily create tables in Visual Page. 
To create a table in a Web page: 

1 Place the cursor where you want the table to display. 
2 Click the Insert Table toolbar button on the Insert Toolbar or choose Insert> 

Table > Table. 
The Table Settings dialog box displays. 

3 Set the number of rows and columns for your table. 
4 Click OK. 

The new table displays. 

You can also perform the following tasks: 
Inserting rows 
Inserting columns 
Deleting rows 
Deleting columns 
Changing multiple cells 
Resizing rows, columns and tables 
Spanning rows and columns 
Adding colour to tables 

For information on setting the attributes of a table, see Table settings. 

Inserting rows 

You can have Visual Page insert a new row either before or after the one in which you 
placed the insertion point. 

To insert a row after the current row: 

1 Place the cursor where you want the row to be inserted. 
2 Choose Insert > Table > Row. 

The row is inserted. 
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To insert a row before the current row: 

* Choose Insert > Table > Row Before. The row is inserted below the current 
row. 

Inserting columns 

Visual Page allows you to insert a column to the right or left of the column in which 
you placed the insertion point. 

To insert a column to the right of the current column: 

1 Place the cursor where you want the column to be inserted. 
2 Choose Insert> Table> Column. 

The column is inserted. 

To insert a column to the left of the current column: 

* Click Insert > Table > Column Before. A column is inserted to the left of the 
current column. 

Deleting rows 

In Visual Page you can designate a row to be deleted. 

To delete a row or rows: 

1 Select a row or set of rows to be deleted. 
2 Choose Insert> Table> Delete Row 

The row(s) are deleted. 

Deleting columns 

Visual Page allows you to delete multiple columns. 

To delete more than one column: 

1 Select a column or set of columns to be deleted. 
2 Choose Insert> Table > Delete Column 

The column(s) are deleted. 
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Changing multiple cells 

Visual Page allows selection of multiple adjacent cells. Any selected set of cells may 
be formatted by applying the following: 

Paragraph formatting 
Paragraph alignment 
Character formatting 

Resizing rows, columns, and tables 

You can customise tables by changing the size of rows, columns, or the table. 
To resize a row or column: 

1 Place the pointer over the border of the row or column you want to resize. 
The pointer changes to a resizing cursor. 

2 Click on the row or column's border and drag the mouse until the row or 
column is the size you want. 

3 Release the mouse button. 
The row or column displays at the new size. 

To resize a table: 

1 Select the table to be resized. 
2 Click on the resizing handle (a square box) at the bottom right comer of the 

table and drag the mouse until the table is the size you want. 
3 Release the mouse button. 

The table displays at the new size. 

Spanning rows and columns 

Sometimes you want a cell in a table to span across multiple rows or columns. 
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To set a cell to span across multiple rows and/or columns: 

1 Click on the cell that you want to enlarge. 
2 Choose Properties> Table Properties or press F4. 

The Table Properties dialog displays. 
3 Click on the Cells tab. 
4 Enter the number of columns that you want the cell to span in the Span across 

columns field. 
5 Enter the number of rows that you want the cell to span in the Span down rows 

field. 
6 The cell now spans across the specified number of rows and columns. An 

example of a table with a spanned cell is shown below: 

Adding colour to tables 

You can use Visual Page to set the background colour of a cell or an entire table. 

To change a cell's background colour: 

1 Select one or more cells. 
2 Choose Properties> Table Properties or press F4. 

The Table Properties dialog displays. 
3 Click the Cells tab. 
4 Select the colour you want from the Cell background colour palette. 

If you want to create a custom colour, click Custom. 

To change a table's background colour: 

1 Select a table. 
2 Choose Properties> Table Properties or press F4. 

The Table Properties dialog displays. 
3 Click the Table tab. 
4 Select the colour you want from the Background colour palette. 

If you want to create a custom colour, click Custom. 
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Table Settings dialog box 

This dialog box displays when you insert a table. 

Entire table 
number of rows 
number of columns 
space around text 
space between cells 
table width 
table height 
border width 
caption placement 
background colour 
For more information about table properties, see Setting Table properties and Setting 
Cell properties. 
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Harvester of Sorrow 

(Hetfield/Ulrich) 

My Life Suffocates 
Planting Seeds of Hate 
I've Loved, Turned to Hate 
Trapped Far Beyond My Fate 
I Give 
You Take 
This Life That I Forsake 
Been Cheated of My Youth 
You Turned this Lie to Truth 

Anger 
Misery 
You'll Suffer unto Me 

Harvester of Sorrow 
Language of the Mad 
Harvester of Sorrow 

Pure Black Looking Clear 
My Work Is Done Soon Here 
Try Getting Back to Me 
Get Back Which Used to Be 
Drink up 
Shoot in 
Let the Beatings Begin 
Distributor of Pain 
Your Loss Becomes My Gain 

Anger 
Misery 
You'll Suffer unto Me 

Harvester of Sorrow 
Language of the Mad 
Harvester of Sorrow 

All Have Said Their Prayers 
Invade Their Nightmares 
See into My Eyes 
You'll Find Where Murder Lies 
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Harvester of Sorrow 
Language of the Mad 
Harvester of Sorrow 
Language of the Mad 
Harvester of Sorrow 
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UNTIL IT SLEEP 
(Hetfield , Ulrich) 

Where do I take this pain of mine 
I run, but it stays right my side 

So tear me open, pour me out 
There's things inside that scream and shout 
And the pain still hates me 
So hold me, until it sleeps 

Just like the curse, just like the stray 
You feed it once, and now it stays 

So tear me open, but beware 
There's things inside without a care 
And the dirt still stains me 
So wash me, until I'm clean 

*It grips you, so hold me 
It stains you, so hold me 
It hates you, so hold me 
It holds you, so hold me 

Until it sleeps** 

So tell me why you've choosen me 
Don't want your grip, don't want your greed 

I'll tear me open, make you gone 
No more can you hurt anyone 
And the fear still shakes me 
So hold me, until it sleeps 

*--** Repeat 

I don't want it 

So tear me open, but beware 
The things inside without a care 
And the dirt still stains me 
So wash me, 'till I'm clean ... 

I'll tear me open, make you gone 
No longer will you hurt anyone 

Tuesday, June 02, 1998 0:34 PM 
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And the fear still shapes me 
So hold me, until it sleeps ... 

Until it sleeps ... 
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MAMA SAID 
(Hetfield, Ulrich) 

Mama she has taught me well 
Told me when I was young 
Son, your life's an open book 
Don't close it fore it's done 
The brigtest flame burns quickest 
Is what I heard they say 
A son's heart's owned to mother 
But I must find my way 

*Let my heart go 
Let your son grow 
Mama let your heart go 
Or let this heart be still 

Rebel my new last name 
Wild blood in my veins 
Apron strings around my neck 
The mark that still remains 
Left home at an early age 
Of what I heard was wrong 
I never asked forgiveness 
But what I said is done 

* Repeat 

**Never I ask you 
But never I gave 
But you gave me your emptiness 
I now take to my grave 
Never I ask of you 
But never I gave 
But you gave me your emptiness 
I now take to my grave 
So let this heart be still 

Mama now I'm coming home 
I'm not all you wished of me 
But a mother's love for her son 
Unspoken, Help me be 
I took your love for granted 
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And all the things you said to me 
I need your arms to welcome me 
But a cold stone's all I see 

* Repeat 

Let my heart go 
Mama let me heart go 
You never let me heart go 
So let this heart be still 

** Repeat 

'LinkExchange 
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CHAPTER C 

LEARNING JAVASCRIPT 

How to take full advantage of JavaScript by moving 
beyond its built-in commands 

Summary 

The power of any programming language depends on the extent to which you can 
modify it for your own needs. The more you are limited to using just the built-in 
commands and processes, the more you are limited in what you can do with that 
language. And the harder it is to write sophisticated programs. Thankfully, JavaScript 
supports user-defined functions, properties, and methods, and uses a simplified object 
model to create them. (3,400 words) 

JavaScript endorses full extensibility by letting you define your own functions. 
This allows you to create routines you can use over and over again. You save time in 
re-using common "components," and by designing your own functions you can extend 
JavaScript's base language to suit your needs. Think of it as "personalized JavaScript." 

Since JavaScript is based on objects, a JavaScript function can easily be turned 
into an object, and a method for that object. So, not only can you create user-defined 
objects to do your bidding, you can create your own objects that behave in exactly the 
way you want. And you can create methods that act upon those objects. While this 
sounds powerful -- and it is -- the process of creating functions, objects, and methods 
is very easy in JavaScript. 

Introducing functions 
Use the function statement to create your own JavaScript function. The bare-bones 

syntax is: 

function name (params) { 
... function stuff .. 

} 

name is the unique name of the function. All function names in a script 
must be unique. 

params is one or more parameter variables you pass to the function. 
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function stuff is the instructions carried out by the function. You can put 
most anything here. 

Notice the { and } brace characters; these define the function block, and 
are absolutely necessary. The braces tell JavaScript where a function begins 
and ends. The parentheses around the parameters also are required. Include 
the parentheses even if the function doesn't use parameters (and many don't). 

Names for your user-defined functions are up to you, just as long as you 
use only alphanumeric characters (the underscore character _ also is 
permitted). Function names must start with a letter character, but can include 
numbers elsewhere in the name. 

I've stuck with the JavaScript style of function name capitalization -- that is, 
initial lower case, then upper-case characters if the function name is 
composed of composite words. For example, myFuncName, yourFuncName, 
or theirFuncName. Function names are case-sensitive; be sure to use the 
same capitalization when you refer to the function elsewhere in the script. 
JavaScript considers myFunc different from Myfunc. 

To differentiate between functions and variables, I prefer to give my 
variables initial upper case characters, such as MyStuff. This immediately 
differentiates it from a function, which would use a the capitalization myStuff. 
Of course, you are free to adopt any capitalization scheme you Wish. 

Defining and using a function 
The best way to describe the how and why of a function is to show a simple one in 

action. Here's a basic function that displays "Hello, JavaScripters!" and is an obvious 
takeoff on the "Hello World!" example you see for new programming languages. 

function basicFunction () { 
alert ("Hello JavaScripters!"); 

} 

This merely defines the function. JavaScript will do nothing with it unless the 
function is referenced someplace else in the script. You have to call the function in 
order to use it. Calling a user-defined function is the same as calling a built-in 
JavaScript function -- you merely provide the name of the function in your script. 
This serves as the function call. When JavaScript encounters the function call, it 
dashes off to complete whatever instructions are in that function. When the function is 
over, JavaScript returns to the point immediately after the function call, and processes 
the remainder of the script. 

To call the function above, just include the text basicFunction() -- note the empty 
parentheses, as they are required. Here's a working example of the Hello JavaScripters 
program. 
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<HTML> 
<HEAD> 
<TITLE>Basic Function Example<fTITLE> 
<SCRIPT LANGUAGE="JavaScript"> 
function basicFunction () { 

alert ("Hello JavaScripters!"); 
} 
basicFunction(); 
</SCRIPT> 
</HEAD> 
<BODY> 
Page has loaded. 
</BODY> 
</HTML> 
The browser processes the contents of the <SCRIPT> tag as the document loads. 

When it encounters the basicFunction() function call, it pauses momentarily to 
process the function, and an alert box appears. Click OK and the remainder of the 
page finishes loading. 

Calling a function with an event handler 
A common way of calling a function is to include a reference to it in a form button 

or hypertext link. Processing a user-defined function when the user clicks a form 
button is perhaps the easiest of all. You use the onClick event handler to tell 
JavaScript that when the user clicks on the button, the function specified should be 
processed. Here's a revised version of the previous example, showing how 
basicFunction is called when the form button is clicked. 

<HTML> 
<HEAD> 
<TITLE>Basic Function Example<fTITLE> 
<SCRIPT LANGUAGE="JavaScript"> 
function basicFunction () { 

alert ("Hello JavaScripters!"); 
} 
</SCRIPT> 
</HEAD> 
<BODY> 
Click to call function. 
<FORM> 
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<INPUT TYPE="button" VALUE="Click" onClick="basicFunction()"> 
</FORM> 
</BODY> 
</HTML> 

Notice the onClick syntax in the <INPUT> tag. The event you want to process on 
a click is a call to basicFunction. This event is surrounded by double quotes. 

Passing a value to a function 
JavaScript functions support passing values -- or parameters -- to them. These 

values can be used for processing within the function. For instance, rather than having 
the alert box say "Hello JavaScripters!" whenever you call it, you can have it say 
anything you like. The text to display can be passed as a parameter to the function. 

To pass a parameter to a function, provide a variable name as the parameter in the 
function definition. You then use that variable name elsewhere in the function. For 
example: 

function basicExample (Text) { 
alert (Text); 

} 

The variable name is Text, and is defined as the parameter for the function. That 
variable is then used as the text to display in the alert box. When calling the function, 
provide the text you want to show as a parameter of the function call: 

basicExample ("This says anything I want"); 

Passing multiple values to a function 
You can pass multiple parameters to a function. As with built-in JavaScript 

functions and methods, separate the parameters with commas: 

multipleParams ("one", "two"); 

function multipleParams (Param1, Param2) { 

When you define a function with multiple parameters, be sure the parameters are 
listed in the same order in the function call. Otherwise, your JavaScript code may 
apply the parameters to the wrong variables, and your function won't work right. 
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Here's a working example sof a function with multiple parameters. It takes two 
parameters: an input string and a number value. The number value indicates how 
many characters on the left of the string you want to display in the alert box. When 
you run the following script, the alert box displays "This is" -- the first seven 
characters of the input string. 

<HTML> 
<HEAD> 
<TITLE>Global Variable Example<fTITLE> 
<SCRIPT LANGUAGE="JavaScript"> 
lefty ("This is a test", 7); 
function lefty (lnString, Num) { 

var OutString=lnString.substring (lnString, Num); 
alert (OutString); 

} 
</SCRIPT> 
</HEAD> 
<BODY> 
</BODY> 
</HTML> 

Returning a value from a function 
The functions described so far don't return a value; that is, they do whatever magic 

you want them to do, then end. No "output" value is provided by the function. In some 
other languages, such return-less functions are called subroutines. However, in 
JavaScript (like in C and C++), "functions are functions" whether or not they return a 
value. 

It's easy to return a value from a function: use the return statement, along with the 
value you wish to return. This is handy when you want your function to chum through 
some data and return the processed result. Take the "lefty" function from above. 
Instead of displaying the chopped-off string, you can return it to the calling function, 
and use the return value any way you want. 

<HTML> 
<HEAD> 
<TITLE>Global Variable Example<fTITLE> 
<SCRIPT LANGUAGE="JavaScript"> 
var Ret = lefty ("This is a test", 7); 
alert (Ret); 
function lefty (lnString, Num) { 
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var OutString=lnString.substring (lnString, Num); 
return (OutString); 

} 
</SCRIPT> 
</HEAD> 
<BODY> 
</BODY> 
</HTML> 

This script does essentially the same one as the previous example, but 
instead of always displaying the chopped-off text, the function merely returns 
the processed value. The return value is captured in a variable, and you are 
free to use that variable in any way you wish. The above shows the Ret 
variable used with an alert box, but you can use it in other ways, too. For 
example, you can write the contents of the Ret variable using the 
document.write method: 

document.write (Ret); 

Defining local variables within functions 
By default all JavaScript variables are declared global for the document that 

created them. That means when you define a variable in a function, it is also "visible" 
to any other portion of the script on that document. For example, in the following 
global variable test, the variable test is visible to the showVar function, even though 
the variable is defined in the loadVar function. 

<HTML> 
<HEAD> 
<TITLE>Global Variable Example</TITLE> 
<SCRIPT LANGUAGE="JavaScript"> 
function showVar () { 

alert (test) 
} 
function loadVar () { 

test= "6" 
} 
loadVar(); 
</SCRIPT> 
</HEAD> 
<BODY> 
Click to call function. 
<FORM> 
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<INPUT TYPE="button" Value="Click" onClick="showVar()"> 
</FORM> 
</BODY> 
</HTML> 

Global variables aren't always what you want. Instead, you want variables that are 
local to the function. These variables exist only as long as JavaScript is processing the 
function. When it exits the function, the variables are lost. In addition, a local variable 
of a given name is treated as a separate entity from a global variable of the same 
name. In this way, you don't have to worry about reuse of variable names. The local 
variable in the function won't have any effect on the global variable used elsewhere in 
the script. 

To declare a local variable, add the var keyword to the beginning of the variable 
name in the function. This tells JavaScript you want to make the variable local to that 
function. As a test, change the loadVar function above to the following, and re-load 
the script. When you click the button, JavaScript tells you the variable doesn't exist. 
This is because test is only local to the loadVar function, and does not exist outside 
the function. 

function loadVar () { 
var test = "6" 

} 

Calling one function from another function 
Code inside a function behaves just like code anywhere else. This means you can 

call one function from inside another function. This allows you to "nest" functions so 
that you can create separate functions, which each perform a specific task, and then 
run them together as a complete process, one right after the other. For example, here's 
a function that calls three other mythical functions, each one returning a string of text 
that has been altered in some way. 

function run () { 
var Ret = changeText ("Change me"); 
alert (Ret); 
document.write (Ret); 

} 
function changeText (Text) { 

Text= makeBold (Text); 
Text= makeltalics (Text); 
Text= makeBig (Text); 
return (Text); 

} 
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function makeBold (lnString) { 
return (lnString.bold()); 

} 
function makeltalics (lnString) { 

return (lnString.italics()); 
} 
function makeBig (lnString) { 

return (lnString.big()); 
} 

Creating objects with user-defined functions 

JavaScript is based on objects: the window is an object, links are objects, forms 
are objects, even Netscape itself (or other browser) is an object. Using objects can 
help make programming easier and more streamlined. You can extend the use of 
objects in JavaScript by making your own. The process uses functions in a slightly 
modified way. In fact, you'll be surprised how easy it is to make your own JavaScript 
objects. 

Making a new object entails two steps: 
Define the object in a user-defined function. 
Use the new keyword to create (or instantiate) the object with a call to the object 

function. 
Here's an example of the world's simplest user-defined JavaScript object: 
II this part creates a new object 
ret = new makeSimpleObject(); 
II this part defines the object 
function makeSimpleObject() {} 
I've called the new object ret; use any valid variable name for the new object (I 

use lower-case letters for variables that contain objects, so it's easier to tell that the 
variable contains an object). 

You can use the same object function to create any number of new objects. For 
instance, these lines create four new and separate objects: eenie, meenie, minie, and 
moe: 

eenie = new makeSimpleObject(); 
meenie = new makeSimpleObject(); 
minie = new makeSimpleObject(); 
moe = new makeSimpleObject(); 

Actually, there is even a shortcut to the above "world's simplest JavaScript 
object." You don't need to define an object function to make a bare-bones object. 
JavaScript supports a generic Object() object, which you can use to make new objects. 
The following does the same as the above, without an explicit object function: 
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eenie = new Object(); 

Defining new properties to already-made objects 

After an object has been created you can assign a value to it. But instead of just 
assigning a value to the object itself, you should define a new property for the object, 
and assign a value to the property. To create a new property and assign a value to it, 
simply write a variable expression like this: 

myobject.property = value; 
myobject is the name of the user-defined object. 
property is the name of the property you want to create. 
value is the value you want to assign. 
Suppose you create an object called "customer" and you want to define three 

properties to it: name, address, and phone. Here's one way to do it: 

customer= new makeSimpleObject(); 
customer.name= "Fred"; 
customer.address= "123 Main Street"; 
customer.phone= "555-1212"; 
function makeSimpleObject() { 

return (this); 
} 
You can verify that you've indeed created a new object and assigned properties to 

the object my adding an alert method to display one of the properties. For example, 
you could put this after the customer.phone line. When you run the script the alert box 
will say "Fred." 

alert (customer.name); 

Defining properties when you create the object 

Another method of defining properties for objects is to include the property names 
in the object function. You can use this technique to simultaneously create a new 
object and define the property values. All it takes is a few more lines of code in the 
object function. 

customer= new makeCustomer("Fred", "123 Main Street", "555-1212"); 
alert (customer.name); 
function makeCustomer(Name, Address, Phone) { 

this.name= Name; 
this.address= Address; 
this.phone= Phone; 

} 
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Note the series of this statements. Each this statement assigns a property to the 
current object, which is the one being created in the makeCustomer object function. 
Three parameters are passed to the object statement: the customer's name, address, 
and phone number. These parameters are used to define the contents of the three 
properties, which are name, address, and phone. 

JavaScript imposes no limitations on the number of properties you can assign to 
an object. To include as customer object, just do this: 

customer= new makeCustomer("Fred" "123 Main Street" "555-1212")· ' ' ' customer.salutation= "Mr."; 
Note that other objects you create with the makeCustomer object function will 

have just the three base properties, but this object for Fred will have an additional 
property for the salutation. Properties added later do not affect other objects created 
with the same object function. 

Creating user-defined methods 
A user-defined method is yet another way of using functions in JavaScript. 

Methods act upon objects -- either objects built into JavaScript, or objects that you've 
created. A method changes or manipulates an object in some way. For instance, 
suppose you want to insert the various contents of the customer object: name, address, 
and phone number. Write the code to insert the object contents, then stuff the code in 
a function. Call the function, using the customer object as a parameter, like so: 

customer= new makeCustomer("Fred", "123 Main Street", "555-1212"); 
displayCustomer ( customer); 
function displayCustomer (cust_obj) { 

Temp= "Name:"+ cust_obj.name + "<BR>"; 
Temp+= "Address: "+ cust_obj.address + "<BR>"; 
Temp+= "Phone: "+ cust_obj.phone + "<BR>"; 
document.write (Temp+ "<BR>"); 

} 

Here's a fully functioning user-defined property example if you'd like to try this 
out. Load the script; JavaScript will display three lines of customer data. (Reload the 
document if you want to run it again.) 

<HTML> 
<HEAD> 
<TITLE>Object Method Example</TITLE> 
<SCRIPT LANGUAGE="JavaScript"> 
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function run () { 
customer= new makeCustomer("Fred", "123 Main Street", "555-1212"); 
displayCustomer (customer); 
} 
function displayCustomer (cust_obj) { 

Temp= "Name: "+ cust_obj.name + "<BR>"; 
Temp+= "Address: "+ cust_obj.address + "<BR>"; 
Temp+= "Phone:"+ cust_obj.phone + "<BR>"; 
document.write (Temp+ "<P>"); 

} 
function makeCustomer(Name, Address, Phone) { 

this.name= Name; 
this.address= Address; 
this.phone= Phone; 

} 
run() 
</SCRIPT> 
</HEAD> 
<BODY> 
</BODY> 
</HTML> 

The other method is to create a method for the customer object. With this 
approach, you call the method as part of the object. This helps in defining special 
method functions that are designed for -- and only for -- certain kinds of objects. This 
process forms one of the foundations of object-oriented programming, where objects 
contain their own unique methods of operation. Here's the same script as above, 
modified so that the customer object contains the displayCustomer method. 

<HTML> 
<HEAD> 
<TITLE>Object Method Example</TITLE> 
<SCRIPT LANGUAGE="JavaScript"> 
function run () { 

customer= new makeCustomer("Fred", "123 Main Street", "555- 
1212"); 

customer.displayCustomer(); 
} 
function displayCustomer () { 

Temp= "Name: "+this.name+ "<BR>"; 
Temp+= "Address: "+this.address+ "<BR>"; 
Temp+= "Phone: "+this.phone+ "<BR>"; 
document.write (Temp + "<P>"); 

} 
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function makeCustomer(Name, Address, Phone) { 
this.name= Name; 
this.address= Address; 
this.phone= Phone; 
this.displayCustomer = displayCustomer; 

} 

run() 

</SCRIPT> 
</HEAD> 
<BODY> 
</BODY> 
</HTML> 

As you can see, to display the customer data, you call the displayCustomer 
method, like so: 

customer.displayCustomer(); 
Notice a few other changes in this version: 
The call to the displayCustomer function no longer uses a parameter. 
The displayCustomer() function no longer uses a parameter. 
The displayCustomer() function uses the "this" keyword to refers to the current 

object. 
When you write your own methods for objects, you'll follow the pattern used in 

the displayCustomer() function. There's no need to pass parameters to the function 
unless you need to. Refer to properties using the "this" keyword." And, add the name 
of the method function in the function that creates the object -- in this case, it's the 
makeCustomer object function. 

Conclusion 

Much of JavaScript's power comes from user-defined functions -- functions you 
make yourself. With your own functions, you create what is in essence your own 
JavaScript commands. And, you use functions to build JavaScript objects and 
methods. Master functions, and you'll go far in mastering JavaScript. 
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Take Advantage of User-Defined Variables 
JavaScript 
Learn how to master variables, the special information­ 
holding areas that are crucial to a programming language 

Summary 

in 

As with all programming languages, JavaScript relies heavily on user-defined 
variables. But unlike many languages -- including Java -- JavaScript's system of 
variables is simplified, so that even users with minimal programming experience 
can immediately use them. JavaScript doesn't impose strict data formats or types 
for its variables, which can greatly simplify programming. However, just because 
JavaScript's variables are easy to use doesn't mean they lack power. 

These special information-holding areas can store numbers, text strings, 
objects, and other data types. Once stored, this information can be used later in 
your program. With a variable, a person's name could be stored and used at some 
point in the script. 

Variables are temporary holders of information. They can hold: 
• Numeric values ("numbers") -- numbers that can be added together. Example: 

2+ 2 results in 4 
• Character strings -- a collection of text, such as "JavaScript" or "My name is 

Mudd" 
• True/false values -- the Boolean true and false 
• Objects -- JavaScript or user-defined objects (JavaScript variables can hold a 

few other kinds of data, but these are by far the most common types) 
(Note: As with most modem programming languages, JavaScript supports array 

variables in addition to the basic scalar variables used to hold the above data types. 
We'll concentrate on single-value variables for this column and devote a separate 
column to arrays.) 

JavaScript variables "belong" to the script document that created them; the 
variables are lost when the document is unloaded. In addition, the contents of a 
variable are erased when you assign a new value to them. Though a variable created 
in one document script is not usually seen by another document script, JavaScript 
does provide ways to share variables between scripts. You do this by referencing the 
name of the document along with the name of the variable. 

Several JavaScript instructions create and store variables, but the basic way to 
accomplish this manually is with the equals(=) assignment operator. The basic syntax 
1s: 

VariableName = value 
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The first argument is the name of the variable. Variable names can be very long, 
but you are restricted in the characters you may use. For more information on valid 
variable names, see the section on Variable name limits. 

The second argument is the contents of the variable. You can put all sorts of stuff 
into a variable, including a number, a string, a math expression (such as 2+2), and 
various other things that we'll get to in a bit. 

Pascal users may be tempted to construct the variable assignment using :=. Be 
aware that this syntax is not supported in JavaScript. 

Following is a more specific rundown of the four most common contents you can 
place in JavaScript variables, including examples. 

Contents placed in JavaScript variables 
Numbers in variables 

A number is one or more digits stored in the computer in such a way that 
JavaScript can perform math calculations with them. JavaScript supports both integers 
and floating-point values. To place a number in a variable, just provide the variable 
name, the equals sign (the variable assignment operator), and the value you want to 
use. For example, the following is what you do to place the number 10 in a variable 
named MyVar: 

MyVar = 10; 
Strings in variables 

A string is one or more text characters arranged in memory in single file. Strings 
can contain numbers (digits), letters, punctuation, or a combination of these elements. 
Math calculations cannot be performed on strings. Strings are assigned to JavaScript 
variables by being enclosed in a set of single or double quotes: 

"I am a string;' 
or 
'I am a string' 

Note that double or single quotes are acceptable; unlike some languages, such as 
Perl, JavaScript makes no distinction between the two forms of quote marks. This 
working example shows how to place a string into a variable: 

MyVar = "This is JavaScript"; 
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Boolean values in variables 

There are two Boolean values: true and false. Some programming languages don't 
have a separate set of Boolean values, and instead use O for false, and 1 or -1 ( or any 
other non-zero value) for true. JavaScript can use these numbers to represent true and 
false but, in addition, reserves the words "true" and "false" to mean Boolean true and 
false. You can think of the Boolean true and false values as being equivalent to on/off 
or yes/no. To assign a Boolean value to a variable, provide just the word true or false, 
without quotes. Here's an example: 

MyVar = true; 

Objects in variables 
Variables can contain objects, including JavaScript objects. There are basically 

two kinds of object variables: 
• Variables that contain built-in browser-related objects -- window, document, 

navigator, and so on -- actually are references to the original object. They are like 
copies, but the copies change if the original changes. In some cases, making a change 
to the object in the variable affects the original JavaScript object. 

• Variables that contain user-defined objects represent the actual object. Make a 
change to the object in the variable, and you change only that object. 

To assign a JavaScript object to a variable, provide the name of the object, as in: 

MyVar = navigator; 
To assign a new copy of a user-defined object to a variable, use the new 

statement, and provide the name of the object function: 

MyVar = new myObject(); 

SUBHEAD Variable name limits 
When it comes to the names you can give variables, JavaScript offers a great deal 

of latitude. JavaScript variables can be almost unlimited in length, although for 
practical reasons you'll probably keep your variable names under 10 or 15 characters. 
Shorter variable names help JavaScript execute the program faster. Keep the 
following in mind when naming your variables: 

• Variable names should consist of letters only -- without spaces. You can use 
numbers as long as the name doesn't start with a digit. For example, MyVarl is 
acceptable, but lMyVar is not. 
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• Don't use punctuation characters in variable names. Exception: the underscore 
character ( _ ). That is, the variable My_ Var is acceptable, but My*Var is not. 
Variables can begin with the underscore character. 

• Variable names are case-sensitive. The variable MyVar is a distinctly different 
variable from my Var, myvar, and other variations. 

Understanding JavaScript's "loose" variable data types 

Unlike some other programming languages, in JavaScript there is no need to 
explicitly define the type of variable you want to create. This JavaScript behavior is 
called "loose data typing," and it differs from C and Java, both of which use strict data 
typing. 

In JavaScript there is no need to differentiate variable types by appending special 
characters to the end of the variable name, such as My Var$ for a string variable (or, 
for that matter, $MyVar for a scalar variable, a la Perl). JavaScript internally decodes 
the variable type based on its content. 

Using the var statement to assign a variable 

JavaScript supports a var statement that can be used to explicitly define a variable. 
The syntax is merely the statement var, a space, and the same variable assignment 
expression detailed above. For instance: 

var MyVar = "This is a variable"; 
You can also use the var statement with the variable name to declare the variable 

but not define a value for it: 

var MyVar; 

In this case, you've defined MyVar in memory but have yet to assign a value to it. 
This technique is often used when setting up global variables -- variables that can be 
freely shared anywhere in your script. For more information about global variables, 
see the section "Understanding the scope of variables", below. 

String length limitations 
JavaScript imposes a limit of 254 characters for each string variable assignment in 

your program. If you go over the 254-character limit, JavaScript responds with a 
"Unterminated string literal" error message. (Note: This is fundamentally a limit of 
JavaScript in Netscape 2.0x; it's a good idea to observe it since not all users have 
adopted Netscape 3.0.) 
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You can create longer strings by "piecing" them together -- as long as each piece 
is 254 characters or less. After assigning a string to each variable, you combine them 
using the + character. This is called "concatenation." The following example shows 
how concatenation works: 

MyVar = "This is the start " + of how you " + " can build strings"; 

Each individual string segment -- defined by text within the quotes -- can be up to 
254 characters. To make a string longer than 254 characters, merely add more 
segments. Another approach is to build strings using the += assignment operator, like 
this: 

MyVar = "This is the start " 
MyVar += "of how you " 
MyVar + = can build strings " 
You can continue to concatenate strings this way as long as your computer has the 

memory for it. But, while JavaScript can hold strings larger than that possible in many 
other programming languages (like Basie's typical 64K), doing so can severely 
degrade the performance of the system. Obviously, you won't create a lot of huge 
string variables. It's just nice to know that, if needed, a JavaScript variable can 
accommodate so much text. 

Understanding the "scope" of variables 

The "scope of a variable" has nothing to do with optics or mouthwash, but rather 
the extent to which a variable is visible to other parts of a JavaScript program. Unless 
you provide explicit instructions to tell JavaScript otherwise, the scope of its variables 
is managed as follows: 

• Variables defined outside a function are available to any function within the 
script, as long as all the variables are definined in the script of the same HTML 
document. These are referred to as global variables. 

• Variables defined inside a function are also global, assuming the var statement 
is not used when first declaring that variable. That is, MyVar = "hello." 

• Variables defined inside a function with the var statement are "local" to that 
function only. These are referred to as local variables. 

• Global variables remain in memory even after a script has stopped execution. 
The variable remains in memory until the document is unloaded. 

Local variables are treated as if they don't exist outside the function where they 
are defined. That way, you can use the same variable name inside a function, and that 
variable won't interfere with the same-named variable elsewhere in the script. 
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CONCLUSION 

This project that I produced creates a HTLM program and a WEB 
page. I practised all formulas of HTLM. While I was creating this WEB page I 
used two different Browser. These are; WEB page in OFFICE 97 and Visual 
Page Browser. Both of them were very useful. Specialities and usage of 
Browser will be engaged following pages. 

Because of Turkey is Tourist paradise I preferred to engage with 
touristic hotels that they are beneficial for tourism. 

I like to write about my pages briefly: 
First one is Turkey page. Later again a new Turkey page. Meanwhile 

brief and essential assistant information. From this page it is very easy to enter 
to www.turk.org. and www.turk.org./ata5.html pages. And because I wrote 
about hotels province by province first I gave information about provinces. 
After that brief information from that pages and from hotel pages it is possible 
to enter hotels' page. 

What did I use while I was producing HTLM design and Web pages: 
Links that can be found in every Web page, these are Active Links, 

Hyperlink, I preferred to use them. By using Frame I create page. I used tables 
and Background pictures. To colour writings and creating Turkish flag I used 
Animation gif. Also by assistance of Java program via choosing any region of 
map I used link to another page. 
This is not my whole program that now I present you; this is a very small 
sample and my whole program will take place in Internet with its over 150 
pages context. Then h will be possible to see it by June 1998 in Internet. 
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CHAPTER A 

INTERNET 

Historical Background 
The first computer network became operational in the late 1960's, with USA 

taking a lead with the Department of Defence network ARP ANET, which linked 
research computer from the East to the West Coast, with a link to London to allow 
UK researchers to grew rapidly, and was later split up into three interconnected 
networks, with connections to many other network across the world. This vast 
interconnected network is often referred to as the INTERNET . 

. The Internet is a world - wide system that is currently used mainly by academics 
and scientists, but it is rapidly becoming commercialised due to its incredible success. 
In the early 1980's ways to connect ARPANET to other WAN' s (Wide area 
Networks) e.g. in Europe, were developed. An Internet system can therefore be 
viewed as a set of networks interconnected by Gateways. A GATEWAY is a 
computer that has connections to at least two different networks. The purpose of a 
gateway is to translate the methods used to transfer data an one network into the 
methods used by another network so that data can flow smoothly between different 
types of networks. An Internet system is show is below in Figure 1. 

Network 

G 

Network 
Network 

H 

H= Host Computer G= Gateways 
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Fig.1. An Internet System 

From this early work has grown the system known as the Internet which now 
interconnects sites world wide (literally millions of computers interconnected) There 
are about 100 million people currently using the Internet. By the year 2005. "the 
number of computers attached to the Internet will exceed the world's human 
population" (Computer Journal) of course, growth will slow down, but nevertheless 
the growth is an impressive fact. It is radically changing access to information , news 
distribution, collaboration between people in remote places. The growth of the 
Internet has equalled that of a child by almost doubling insize every year. 

The data available to casual users on the Internet has grown as fast as the 
Internet itself and terabytes. Products have been developed to manage the information 
about data and provide a way of finding the document, program or in general the 
bytes that are wanted. 

Early information was shared with email and ftp. Email is moderately easy to 
use. Information can be passed from one person to another, or groups of people could 
form a mailing list. Originally email was just a text message; it didn't have the 
capability to include programs and data files. 
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Technical Definitions: 

The Internet is very difficult to define. Principally because things change on the 
Internet with great rapidity; definitions that are appropriate at one time have little 
meaning later. However, here are some definitions. 

The Internet is: 
=> A World Wide network of networks as Kevin Hughes defined in "A Guide to 

Cyberspace" 
=> A co-operative interconnection as emphasised by VUNETS "Internet Q&A" 
=> A way to communicate and share resources as described in the "What is the 

Internet?" by the Internet Society. 
=> computers connected using the TCP/IP protocol suite, as specified in the NCSA 

Guide to the Internet. 
Therefore, we can define it as a co-operative global network of computer 

networks that communicate and share resources using the TCP/IP protocol. 
In simple terms, it is the means by which computers in one part of the world 

can communicate with other in parts other of the world as easily as with computers in 
the next room. 

The mechanism for doing this is known as the Internet Protocol(IP) and the 
Transmission Control Protocol(TCP). Together these are commonly known as TCP/IP 
connections. The Internet protocol was first developed when the US Government 
wanted to allow researchers to share computing resources by making them available 
across a network. The military establishment were also involved in this process and 
developed the network on the assumption that there would be break ages in the 
network. Thus the protocol does not rely on the existence of any particular computers. 

When two computers communicate using TCP/IP the message is broken into a 
series of small packets which are sent over the network. The Internet Protocol deals 
with sending the individual packets and the Transmission Control Protocol managers 
the process of putting the packets together again at the other end.(Usually a packet is 
512 bytes) 

TCP/IP is a relatively simple networking protocol and was soon made available 
on most computers, allowing different makes of computers to communicate easily. 
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Computers on the Internet are all given a unique Internet Address. This address 
is used to tell the network where to send its individual packets of data. The Internet 
address is normally written as four digits(between O and 255) separated by dots. 

For example: 158.143.103.60 

this, however is not particularly easily to understand and therefore most 
computers provide a human readable name. This name is again made-up of a series of 
parts. 

For example: VAX.RES.AC.UK 

The process of naming computers is organised in a distributed manner, as there 
is no'central organising committee' for the Internet. Reading from right to left, we see 
that the computer is in the UK and, in particular, in the academic community. There is 
a local organiser for the academic community which distributes names for UK 
academic communities. Similarly , in Turkiye 

Various Protocols 

TCP/IP is simply a method for sending packets of data from one computer to 
another. Internet applications are built up by adding extra protocol layers on top of 
these. These are simply rules that describe the kind of messages that can be sent over 
Internet using TCP /IP. 
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CUSEEME 

This is a relatively new protocol that supports on-line video conferencing over 
the Internet. It does this by allowing a computer, if it has the necessary hardware, to 
use a video camera and sends this picture to other computers on that conference. 
Other computers receive this data and display it locally. The limited amount of 
capacity on many parts of the Internet means that often the picture that is received is 
quite Jerky. 

Network News 

Another protocol is the NNTP protocol. This allows you to read news on a 
variety of topics. Essentially, there is a hierarchy of news groups that discuss various 
subjects. For example: talk.rumors focuses on true and false rumours. Individuals 
read this news and can respond by adding their own messages to the group. 
Soc.culture.turkish is a news list where people can discuss things about Turkiye and 
issues related to the Turkish culture. 

Telnet 

One of the original and still mostwidely used protocols is TELNET. This 
essentially allows you to log on to a computer across the Internet. Anything that you 
type in is sent using the TELNET protocol and the response from the remotecomputer 
is sent back. TELNET normally requires that you have an account on the remote 
computer, but it is also used to provide access to library catalogues. 

FTP 

FTP is related to TELNET and allows you to upload and download files from a 
remote computer. FTP is often done anonymously which allows you to download 
files from computers where you don't have an account. FTP is the most widely used 
protocol for downloading files, but is slowly being replaced by more useably front 
ends. 
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Gopher 

One of the fastest and relatively easy to use protocol is Gopher. When you log 
on to a computer using to Gopher protocol it sends you a list of all the information it 
has. This information is normally in the form of individual files or directories. These 
items are displayed on your own computer and you can then choose the one you want. 
If you choose a directory, the system presents you with all the information in that 
directory. 

The beauty of the Gopher protocol is that the files and directories that are listed 
do not have to be on the same computer. You can select a particular item and will be 
automatically a different part of the Internet to obtain sent that information. 

The World Wide Web 

The Gopher protocol is fast and effective and automatically moves you from 
one part of the Internet to another. It is limited, however to the concept of files and 
directories. Whilst this is easily understood by computer specialist, it is not so intivite 
to non-computer specialists. The world wide web protocol overcomes this by 
presenting the information as normal text document. It also possible to include 
graphics within web documents. Within these documents are hot-links to other parts 
of the document or other parts of the Internet. As with Gopher, these jumps are 
handled automatically and invisibly. 

World wide web documents are often viewed using packages like the Microsoft 
Internet Explorer and Netscape Navigator. 

UNIFORM RESOURCE LOCATORS (URLs) 

URL s are designed to help with all these different protocols Essentially, they 
provide a standard format for specifying the Internet Information you want to use. The 
format is normally: 
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Internet Service: II Internet address /Access information. 
For example: 

http:l/www.wired.com/index.html 
http://www.isoctr.org/ 
http:l/www.hurriyet.com.tr 

In this example, http specifies the protocol (hypertext transaction protocol), 
www.wired.com is the name of the computer and index. html is the file to be loaded 
and displayed . 

Searching the Internet 

The Internet is huge and grawing everyday. It also has no central controller so it 
can be very difficult to find information on the net. In order to solve this problem, a 
number of search engines have been developed. Some well-known search engines are: 

1. Altavista (http:l/www.altavista.digital.com) 
2. Yahoo! (http:l/www.yahoo.com) 
3. Lycos (http:l/www.lycos.com) 
4. Webcrawler (http:l/www.webcrawler.com) 
5. lnfoseek (http:l/www.infoseek.com) 
6. Excite (http:l/www.excite.com) 

These normally work by creating a monthly list of everything they know about 
(for example, all the FTP files in all the FTP sites that are known), indexing these lists 
and allowing people to search these indexes. the results are then displayed in the 
appropriate format. 

ARCHIE 

Archie is the search engine for FTP sites. Archie normally only works on the 
basis of file names and related descriptions and so is best used if you know the name 
of the file you are looking for. 
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VERONiCA and JUGHEAD 

These are two search engines for GOPHER sites. They normally index all the 
worlds in the Gopher descriptions and you can perform Logical searches on them,for 
example, all the Gopher elements that contain both information and security. 

CUI and L YCOS 

Indexing world wide web files in much more difficult but these two facilities 
aim to provide results of web files searches. 

www.neu.edu.nc.tr/engf/index.html 

Image File Extensions on the Internet 

.gif 

.Jpg 

Introduction to HTML Language 

A simple Example 

<HTML> 
<HEAD> 
<META HTTP-EQUIV="Content-Type" CONTENT="text/html; charset=iso- 

8859-1 "> 
<META NAME="Author" CONTENT="metin taskm"> 
<META NAME="GENERATOR" CONTENT="Mozilla/4.02 [en] (Win95; I) 

[Netscape]"> 
<TITLE>index</TITLE> 

</HEAD> 
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<BODY> 
<CENTER><FONT COLOR="#330000"><FONT 
SIZE=+ 2></FONT></FONT></CENTER> 
<CENTER><FONT F ACE="Baskerville Win95BT Tur"><FONT 
COLOR="#330000"><FONT SIZE=+2>AMERICAN 
BIRDS</FONT></FONT></FONT></CENTER> 
<CENTER><FONT F ACE="Baskerville Win95BT Tur"><FONT 
COLOR="#330000"><FONT 
SIZE=+ 2></FONT></FONT></FONT></CENTER> 
<CENTER><FONT F ACE="Baskerville Win95BT Tur"><FONT 
COLOR="#000099"><FONT SIZE=+ l>BIRD 
CLASSIFICATION </FONT></FONT></FONT></CENTER> 
<CENTER><FONT F ACE="Baskerville Win95BT Tur"><FONT 
COLOR ="#000000"></FONT></FONT>&nbsp;</CENTER> 

<OL> 
<LI> 
<FONT F ACE="Baskerville 
COLOR="#OOOOOO">HERONS &amp; 
BITTERNS</FONT></FONT></LI> 

Win95BT Tur"><FONT 

<LI> 
<FONT F ACE="Baskerville 
COLOR="#OOOOOO">DUCK, GEESE 
&amp; SW ANS</FONT></FONT></LI> 

Win95BT Tur"><FONT 

<LI> 
<FONT F ACE="Baskerville Win95BT 
COLOR ="#000000"></FONT></FONT></LI> 

Tur"><FONT 

</OL> 
<CENTER><FONT F ACE="Baskerville 
COLOR ="#000099"><FONT 

Win95BT Tur"><FONT 

SIZE=+ 1 ></FONT></FONT></FONT>&nbsp; </CENTER> 
<CENTER><FONT COLOR="#330000"><FONT 
SIZE=+ 2></FONT></FONT>&nbsp;</CENTER> 
</BODY> 
</HTML> 
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What Software to Use For Writing HTML Programs 

1. Nodepad (under Accessories Directory in win95, also available or win3.1) 
2. Write (available or both win95& win 3.1) 
3. World (any version) (available or both win95& win 3.1) 
4. Netscape Communication 
5. Any other text editor. 

File Extension 

All HTML programs should have either. .htm or html extension. We shall later 
in the course that some files use .shtml extension. 

All image files that you use in your programs should either be in GIF format or 
JPG (also written as JPEG) 

TAG REFERENCE 

Document Formatting 

Tag Description 

<html> HTML document indicator 
<head> Document head 
<body> Document body 
<address> Owner/ Contact 
<title> Title 
<! ... > Comment 
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Paragraph Formatting 

Tag Description 

<blockquate> Blockquate 
<p> Paragraph 
<hr> Line break 
<hr> - Horizontal rule 
<pre> Preformatted text 

Character Formatting 

Tag Description 

<em> Emphasised 
<var> Variable 
<cile> Litation 
<i> Italic 
<strong> Strong 
<b> Bold 
<code> Code 
<samp> Sample 
<kbd> Keyboard 
<tt> Teletype 
<key> Keyword 
<dfn> Dfn 
<strike> Strike through 
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List Formattipg 

Tag Description 

<Ii> List item 
<ul> Unnumbered list 
<ol> ordered list 
<menu> Menu list 
<dir> Directory list 
<di> Description list 
<dt> Data term 
<dd> Data deser 

Anchor Formatting 
Tag Attribute Description 

Anchor hyper link 
href Points to destination of link 

<a> name Defines a named anchor so that a 
link can point to a place in a 
document not just to the document 
itself 
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Tag Attribute Descri~tion and Notes 
<img> 

src 
align 

alt 

ismap 

Incorporates images in a document 
The href for the image 
Aligns text, starting at the top, middle, 
or bottom the side of an image 
A name that can be displayed an 
browser that "' don't have image 
capabilities 
Activates the image so that the browser 
returns a set of x,y cordinates at which 
the image was clicked. 
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Table Formatting 

Tag Attribute Descri_etior, and Notes 
<table > I I Defines the table 

border Adds borders to separate rows and 
colums in tables 

<tr> I I Marks the end/start a table row 
Modifies 

<td> I I Encloses a cell of table data 
colspan Modifies the number of columns a cell 

will span 
rowspan I Modifies the number of rows a cell will 

span 
align I Defines the horizontal text alignment 

within a cell 
nowrap I Declares that the cell text cannot be 

broken up to wrap from one line to the 
text 

<th> I I Encloses a cell of table heading 
colspan Modifies the number of columns a cell 

will span 
rowspan I Modifies the number of rows a cell will 

span 
align I Defines the horizontal text alignment 

within a cell 
nowrap I Declares that the cell text cannot be 

broken up to wrap from one line to the 
text 

<caption> I I Creates a title for the table, outside 

GIF - The graphics interchanges format developed in 1987 by people from 
computer serve. This bitmapped format come into being because people wanted to 
exchanged images between different platforms. 

This format is now used on almost every platform that support graphical 
application. GIF format is not only a standart image type for WWW browser, it is 
also the only image type that can be used for inline images on all platforms. The one 
drawback of GIF format is that it is limited to 256 colours. 
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An extended standard called GIF89A was developed to add functionality for 
specific applications. The most no table use of this extended standard in web pages is 
the use of transparent backgrounds. Images can appear to float by making the 
background colour the same as the background of the browser. However browser 
don't always came with the plain grey background, and the user can override the 
choice of background colour as transparent compensates for the users specific 
configuration. 

JPEG - A bitmap format with compression that was designed and named after 
the Joint Photographic Expert Group: JPEG isn't used as often as the other formats 
but it is the basis for the most common moving image format, MPEG. In addition, the 
newest browser on the block, Netscape communicator row offers support for inline 
JPEG images. 

TIFF - The Tagged Image File Format designed by Microsoft and Aldus for 
use with scanners and desktop publishing programs. Most external viewers support 
this format. 

VIDEO STANDARTS 

MPEG - An animated video standard, format based on the JPEG methods. 
Like JPEG, the format received its name from the group that defined the standard 
Motion picture Experts Group. This is the most common movie format for WWW, 
primarily because viewers exist for all platforms. 

AVI - The movie format for Microsoft Windows. Use of this format isn't 
recommended until browsers for other platforms become common. 
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TCP/IP & INTERNET STRUCTURE 

Introduction: 
Data communication between places is the principle of computing. In the early 

days, this was quite hard. In the late 1970 s, networks have been developed and these 
evolved into host networks that were attached to a single packet-switched network. In 
the middle 1980s, various economic and technological factors have energised that 
made it possible to interconnect many physical networks. This new technology is 
called internetworking, and it hides the underlying details of actual networks, in order 
to provide a uniform service across networks. 

The Internet is an example of open systems interconnection(OSI). In on Internet 
structure, several networks are connected together through the use of gateways and 
Internet working protocol(as discussed earlier). The main advantage of an Internet 
structure is that it provides universal interconnection while allowing individual groups 
to use whatever network hardware is best suited to their needs. 

Network 

G-Gateways 

Network 

Network 
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In addition, the term Internet is used when making a generic reference to a 
network built using internetworking technology and the term Internet is used when 
specifically referring to this network. 

The transmission Control Protocol(TCP) 

The transmission Control Protocol, TCP, defines a key service provided by the 
Internet, namely, reliable, stream delivery and it provides a full duplex connection 
between two machines, allowing them to exchange large volume of data efficiently. 

The internet Protocol(IP), defines the IP datagram as the unit of information 
passed across the internet and provides the basis for connectionless, best-effort packet 
delivery stream. 

Message 

Packet Packet 

The TCP is part of the TCP/IP Internet protocol suite, it is an independent, 
general purpose protocol that can be adapted for use with other delivery systems. It is 
possible to use it over a single network like an Ethernet, which is popular Local Area 
Network(LAN ) technology invented at the Xerox corporation Polo Alto Research 
Centre , as well as over a complex Internet, because TCP makes very few assumptions 
about the underlying network. TCP is one of the International Standards 
Organisation(ISO) open system protocols. 

The most important services that TCP provides for its users include: connection 
orientation, sequencing, security against lost connection orientation, sequencing, 
security against loss connection monitoring, multiplexing, flow control, transparent 
data transport and secure connection establishment, release, IP has the ability to: 
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~ transmit messages over an internetwork. 
~ address each partner uniquely 
~ decompose and recombine packets according to the current network 

convertions. 
~ transmit certain information about the packet sequence and security features 

TCP Service Interfaces 
With its host-to-host communication, TCP/IP support the part/socket concept. A 

host, represented by its various application packages, may be viewed as providing a 
set of sockets, into which the desired connections, which are linked to I/0 ports of 
relevant applications by the main of many be plugged. Some sockets and ports are 
reserved for certain standardised application as shown below. 

PROTOCOL DESCRIPTION WELL-KNOWN PORT 
ARP Address Resolution Protocol - 
AUTH Authentication Service 113 
BO OTP Boot Strap Protocol 67,68 
ECHO ECHO Protocol 7 
FTP File Transfer Protocol 20-21 

GRAPHIC Graphics Exchange Protocol - 
MPM Exchange Multimedia Protocol 46 
LDP Load Debugger Protocol - 
LPR line Printer Protocol 514 
NNTP Network News Transfer Protocol 119 
NFS Network File System 2049 
RJE Remote Job Entry - 
RLP Resource Location Protocol 39 
SMTP Simple Mail Transfer Protocol 25 

TELNET Remote Terminal Protocol 23 
TFTP Trivial File transfer Protocol 69 
UDP User Datagram Protocol - 
X X- window System 6000 

STATSRV Sending Gateway Statics 95 
The most important TCP services are: 

OPEN- Open a virtual connection to a partner or wait until the connection is 
opened by an arbitrary or a specific partner. A time-out condition may be given. 

SEND- Deliver a data buffer to TCP for transmission to the other partner. A 
push flag may be used to force the full data transfer, otherwise the nature of the 
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execution is at the discretion of TCP. An URGENT flag may be used for express 
packets which must receive priority handling. 

RECEIVE- Receipt of data from the partner, with entry of size of the 
available buffer. TCP informs the clients process whether the PUSH or URGENT 
flags were set by the partner. 

CLOSE- Release of a virtual connection. 
STATUS- This service is only of a local nature and its fictions depend on the 

form of the current TCP implementation (in other words, which connection-related 
status/statistical data is made available). 

Connection Establishment 

Connection establishment between two TCP partners is based on the so-called 
"three way hardshake " principle. This mechanism reduces the possibility of the 
establishment of false connections. 

The following error situations may arise. 

=> Simultaneous establishment of a connection by each of the two partners 
involved. 

=> Multiple establishment of a connection by the initiator. Because of a time out 
for the first connection-establishment request. 

=> Unwanted establishment of a connection before the previous connection is 
released. 
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Data Transfer 

Once a connection is established between two partners data packets may be 
exchanged. Since these could be lost or rendered worthless as a result of errors or 
overloading of then network, TCP initiates a transmission repeat after the time-out 
condition expires. 

This way lead to duplicated data packets, which TCP detects using a special 
sequence numbering. 

Sequence Numbering 

Each data octet (8 bits=byte) transmitted by TCP is assigned a sequence 
number. This means that, in principle, the receipt of each octet can be confirmed. This 
is implemented in such a way that the confirmation of octet number n implicitly 
confirms the receipt of cell previous octets. Thus, duplicated segments are detected by 
the receiver and do not require special treatment. Sequence numbers run from O to 
232 -1. 

WINDOWS MECHANISM 

While in other protocols, such as HDLC(High Level Data Link Control) or X25 
level 3, the transmission window relates to the number of packets still to be 
transported from the sender to the recipient, because of the sequential numbering of 
octets, TCP uses a different mechanism. Here, a recent tells the sender the sequence 
number of the last octet which it has sufficient buffer space to receive. Unlike the 
above protocols, this provides for very dynamic management of this window. As soon 
as a recipient has a higher load and, thus possibly less buffer space, it can make this 
known to its partner. 
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Transmission Watchdog 

Each data packet transmitted is monitored so that a transmission repeat takes 
place if no acknowledgement is forth coming within a given interval (retransmission 
time). This interval depends heavily on the network type, the dimensioning of the 
network and the wrens network load. To frequent transmission repeats load the 
network unnecessarily too long a waiting period decreases the throughput possibly 
considerably. Thus, for each data packet, TCP continuously determines the time until 
the expiring of the acknowledgement period and thus is able to reset the 
retransmission timer adaptively. 

TCP Internet Protocol(IP) 

The Internet protocol, IP, defines the unreliable, connectionless delivery 
mechanism. IP provides three important definitions. First, the IP as a protocol defines 
the Internet datagram( or IP datagram). Second, IP software performs the routing 
function. Third, IP includes a set of rules that embody the idea of unreliable packet 
delivery. These rules characterise how hosts and gateway(router) should process 
packets how and when error messages should be generated , and the conditions under 
which packets may be discarded. 

A route is the path that network traffic takes from its source to its destination. IP 
datagram contains a source and destination IP, address, fragmentation controls, 
precedence and checksum used to catch transmission error along with data. In a 
TCP/IP datagram Internet each IP datagram, which is basis unit of information passed 
across a TCP/IP Internet, is may include may gateways and many physical network. 
Both hosts and gateways participate in IP routing. When an application program on a 
hosts attempts to communicate, the TCP/IP protocols eventually generate one or more 
IP datagrams. The host must make a routing decision when it chooses where to send 
the datagrams. 
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Datagram Delivery Over A Single Network 

Transmission of an IP datagram between two machines on a single network 
does not involve gateways. The sender encapsulates the datagram in a physical frame, 
binds the destination IP address to a physical hardware address, and Internetwork 
sends the resulting frame directly to the destination. 

Because the Internet addresses of all machines on a single network include a 
common network id, and because extracting that id can be done in a few instructions, 
testing whether a machine can be reached directly is extremely efficient. 

Internet Address 

Universal Identifiers: 

If a communication system allows any host to communicate with any other host, 
it is said to supply universal communication service. To make our communication 
system universal, we need to establish a globally accepted method of identifying 
computers that are attached to it. A name identifies what an object is an address where 
it is, and a route tells us how get there. Ingeneral pronounceable name to identify 
machines are preferred by the people. 

Three Primary Classes of IP Addresses 

For address, the designers of TCP/IP choose a scheme analogous to physical 
network addressing in which a host on the Internet is a assigned an address called an 
IP address. 

The clever part of Internet address is that Integers are carefully chosen to make 
rating efficient. 

An IP address encodes the identification of the network to which a host attaches 
as well as the identification of a unique host on that network. 

Each host on a TCP/IP Internet is assigned a unique 32-bit address that is used 
in all communication with that host. 
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Each address is a pair. One of the pair netid, identifies a network, and the other 
one, hostid, identifies a host on the network. 

Each IP address must have one of the first three forms shown below. 

0123 8 16 24 31 

Class A lo netid I hostid I Class A> 216 
14 

Class B I, 10 netid I hostid I 256<Class B<216 
28 

Cl ass C I 100 neti d I hostid I Class C < 256 

Class D I 1110 Multi Cost Address 

Class E 111110 Reserved For Future usJ 

An IP address can be determined from the three high order bits in a 
given IP address . Class A addresses are used for networks that have more then 
216(i.e.65.336) hosts. Class A bits devote 7 bits to netid and 24 bits to hostid. Class B 
addresses are used for intermediate size networks that have between 2\i.e.256) and 
216 hosts, and allocate 14 bits to the netid an 16 bits to the hostid. Class C networks 
have less then 28 hosts, and allocated 21 bits to the netid and only 8 bits to the hostid. 

The 32 bit Internet number or IP address is commonly represented as for 
numbers joined by period i.e.145.32.217.130 

The fourth part of this address identifies the host machine, the remainder 
identify the sub-network on which the machine resides. Class C network are typically 
LANs. 

Since users do not usually want to have to remember addresses in the form of 
numbers, a name-to- number service is available, called the Domain Name 
Service(DNS). DNS servers exchange information to allow a user to communicate 
with any other machine on the Internet simply by giving its name. One disadvantage 
of this addressing scheme is that if a host moves to another network, its Internet 
address must change. 

Example: Arpanet->- Class C 
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Difference Between Frames & Tables 

Use frames if you want to preserve the same layout an all your options. No need 
to reload the same section every time you choose an option. User can enlarge or 
arrange individual pages(frames)as required. 

Disadvantage of Frames 

Some browser can not view frames and generate an error messages. To cater for 
this when you create frames some HTML editors enable you to prepare text based 
version of pages using frames. 

Still, tables are more popular than frames. With tables you can produce, 
interesting effect and can use them for obtaining a nice layout. If you cheese border 
thickness=O then people cannot easily understand that you are using tables but this 
allows you to obtain nice layouts. 
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USING WORD PAGE 
WORKING WITH ONLINE AND INTERNET DOCUMENTS 

NAVIGATING 
Go to a page, bookmark, footnote, table, comment, graphic, or other location 
1 On the Edit menu, click Go To. 

Show me 

2 In the Go to what box, click the type of item. 
3 To go to a specific item, type the name or number of the item in the Enter 
box, and then click Go To. 

To go to the next or previous item of the same type, leave the Enter box empty, and 
then click Next or Previous. 

Tip For a quick way to go to the next or previous item, click Select Browse Object 
on the vertical scroll bar, and then click the item you want. You can click Next or 
Previous to go to the next or previous item of the same type. 
Navigate by using hyperlinks 
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When a Word publication or Web page contains hyperlinks to other locations% for 
example, to locations in the same file, or to files on the network or the Internet 
% you can move to these locations by clicking the hyperlink display text or image. 
When you point to the display text of a hyperlink, the pointer becomes a hand . 

In a file or Web page that contains hyperlinks, click the display text or image 
of a hyperlink. 

When a hyperlink is followed % that is, when you click the display text and jump to 
another location% the Web toolbar appears. 

Click Back to return to the original location in your Word publication. 
Click Forward to return to the file whose hyperlink you followed. 

Navigate by using the Document Map 

The Document Map is a separate pane that shows an outline of a document's 
headings. You can use the Document Map to quickly navigate around the document 
and keep track of your location in it. For example, click a heading in the Document 
Map to instantly jump to the related part of the document. 
Word automatically displays the Document Map in online layout view, but you can 
display it in any view. 
) 

1 
2 

Click Document Map 
In the Document Map, click the heading you want to go to. 

Word displays the heading at the top of the page. In the Document Map, the heading 
is highlighted to show your location in the document. 
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WORKING WITH DOCUMENTS ON INTRANENTS AND THE INTERNET 

Documents on the Internet 

If you have access to the Internet (for example, if you have a modem and an Internet 
account through an Internet service provider, or if you are in a corporation and have 
access through the network), you can open documents on the World Wide Web or 
anywhere on the Internet from the Open dialog box in your Office programs. You can 
also add FTP sites to the list of available Internet sites. And if your company has an 
intranet, you can open documents there. In addition, if you have the access rights and 
the FTP site supports saving files, you can save documents to the Internet from the 
Save As dialog box in your Office programs. 

Use Microsoft Excel, Word, PowerPoint, and Microsoft Access to browse Office 
documents that contain hyperlinks, whether the document is on your computer, on a 
network drive, or on the Internet. You don't have to be on the Internet to use 
hyperlinks in Office documents. 
The Web toolbar is available in your Office programs to make it easy to browse 
documents that contain hyperlinks. Use the Web toolbar to open a start page or a 
search page in your Web browser. Also from the Web toolbar, add interesting 
documents you find on the Web to the Favourites folder to gain access to them 
quickly. The Web toolbar keeps a list of the last 10 documents you jumped to by 
using either the Web toolbar or a hyperlink so you can easily return to these 
documents again. 

Add an FTP site to the list of Internet sites 

You can add an FTP site to the list of Internet sites to make it easier to open a 
document at an FTP site. To do this procedure, your company must have an intranet, 
or you must have access to the Internet (for example, you may have access by using a 
modem and an Internet account through an Internet service provider, or through the 
network if you are in a corporation). For information about how to set up Internet 
access, see the Microsoft Office 97 Resource Kit. For information about how to 
obtain the Office Resource Kit, click 

1 Click Open . 
2 In the Look in box, click Add/Modify FTP Locations. 
3 In the Name of FTP site box, type the FTP site name; for example, type 
ftp://ftp.microsoft.com/ 
4 If you want to log on to an FTP site that allows anonymous log on, click 
Anonymous. 
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If you want to log on to an FTP site that you have user privileges for, click User, and 
then type your password. 

5 Click Add. 

Remove an FTP site from the list of Internet sites 

1 Click Open . 
2 In the Look in box, click Internet Locations (FTP). 
3 Right-click the FTP site you want to remove, and then click Remove on the 
shortcut menu. 

Change the logon name or password for an FTP site 

You can change the way you log on to an FTP site. To do this procedure, your 
company must have an intranet, or you must have access to the Internet (for 
example, you may have access by using a modem and an Internet account through an 
Internet service provider, or through the network if you are in a corporation). For 
information about how to set up Internet access, see the Microsoft Office 97 Resource 
Kit. For information about how to obtain the Office Resource Kit, click 

1 Click Open . 
2 In the Look in box, click Internet Locations (FTP). 
3 Right-click the FTP site you want to change, and then click Modify on the 

shortcut menu. 
4 Change the options you want. 
Learn about installing and using Web page authoring tools 

Microsoft Word and some other Microsoft Office programs provide Web page 
authoring tools to help you easily create Web pages for intranets and the World 
Wide Web. If you haven't already installed these tools, you can rerun Set-up to install 
them and to install more Help topics about using them. 
When authoring Web pages in Word, you can use many familiars Word features, such 
as spelling and grammar checking, AutoText, and tables. Some features, such as 
graphical bullets and lines, are customised to make Web authoring easier. Features 
that aren't supported by HTML are not available when authoring Web pages. 

To install the Web page authoring features, select the Web Page Authoring (HTML) 
check box in Set-up. For more information about installing components of Office, 
click . 
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Open the Web start page 

When you start a World Wide Web browser, the start page is the first page that 
appears in the browser. You can set this location to any Web site you want or to a 
document on your computer hard disk. You can open the start page from the Web 
toolbar. A start page may contain hyperlinks to other documents on your computer, 
on the network, or on the Web. 
To do this procedure, you must have the Web toolbar displayed. On the View menu, 
point to Toolbars, and then click Web. 

On the Web toolbar, click Start Page 

Change the Web start page 

To do this procedure, the Web toolbar must be visible. On the View menu, point to 
Toolbars, and then click Web. 

1 Open the document you want to use as the start page. 
2 On the Web toolbar, click Go, and then click Set Start Page. 
3 Click Yes. 

Open the Web search page 

A search page provides an organised way to find and go to other Internet sites or to 
documents on an intranet. Many search pages provide the capability to search by 
topic or by keyword. Others simply provide an well-organised list of hyperlinks to 
selected Internet sites or to documents on an intranet. You can open the search page 
from the Web toolbar. 
To do this procedure, you must have the Web toolbar displayed. On the View menu, 
point to Toolbars, and then click Web. 

On the Web toolbar, click Search the Web 

Change the Web search page 

To do this procedure, the Web toolbar must be visible. On the View menu, point to 
Toolbars, and then click Web. 

1 Open the document you want to use as the search page. 
2 On the Web toolbar, click Go, and then click Set Search Page. 
3 Click Yes. 
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Open recently browsed files 

To do this procedure, you must have the Web toolbar displayed. On the View 
menu, point to Toolbars, and then click Web. To open the previous document in the 
history list, click Back on the Web toolbar. 

To open the next document in the history list, click Forward on the Web toolbar. 

Cancel a jump that takes too long 

To do this procedure, you must have the Web toolbar displayed. On the View menu, 
point to Toolbars, and then click Web. 

On the Web toolbar, click Stop Current Jump 

Refresh the display of the current file or Web page 

When you work in a document on the World Wide Web that contains hyperlinks, 
the author may modify the document while you have it open. When you update a 
document, the document is refreshed from the original file that is located on the 
network server, the Internet, or your computer hard disk. 
To do this procedure, you must have the Web toolbar displayed. On the View menu, 
point to Toolbars, and then click Web. 

On the Web toolbar, click Refresh Current Page 

Add the active document to Favourites 

When you open a document on the Internet, World Wide Web, intranet, or even on 
your computer hard disk, add the document to the Favourites folder so you can open it 
again without having to remember the path you typed to get the document the first 
time. 
To do this procedure, you must have the Web toolbar displayed. On the View menu, 
point to Toolbars, and then click Web. 

On the Web toolbar, click Favourites, and then click Add to Favourites. 

Hide all toolbars except the Web toolbar 

To do this procedure, you must have the Web toolbar displayed. On the View menu, 
point to Toolbars, and then click Web. 

On the Web toolbar, click Show Only Web Toolbar 
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Tip To show the toolbars that are hidden, click Show Only Web Toolbar on the 
Web toolbar. 

I can't open a document on the Internet. 

You must have access to the Internet (for example, you may have access by using a 
modem and an Internet account through an Internet service provider, or through the 
network if you are in a corporation) to open files at an FTP site or on the World 
Wide Web. For information about how to set up Internet access, see the Microsoft 
Office 97 Resource Kit. For information about how to obtain the Office Resource Kit, 
click. 

If you have these things, the site may be too busy. Try to open the document 
later. 

The Web Find Fast search page 

Microsoft Office ships with a search page you can use to find files on the intranet. 
The Web Find Fast search page makes it quick and easy to find a file you know exists 
even when you don't know where it's located. The Web Find Fast search page also 
makes it easy to find all of the information available on any subject. You can also 
quickly locate information outside of your workgroup, such as the quarterly report for 
your company, or all files that refer to company policies. 

To obtain the Web Find Fast search page, see your administrator. 

WORKING WITH HYPERLINKS 

Create hyperlinks 

You can enrich Web pages and Word publications that others read online by 
inserting hyperlinks to other items. The hyperlink can jump to a location in the 
current document or Web page, to a different Word document or Web page, or to a 
file that was created in a different program. You can even use hyperlinks to jump to 
multimedia files, such as sounds and videos. 
The destination the hyperlink jumps to can be on your hard disk, on your company's 
intranet, or on the Internet, such as a page on the World Wide Web. For example, 
you can create a hyperlink that jumps from a Word file to a chart in Microsoft Excel 
that provides more detail. A hyperlink is represented by a "hot" image or display 
text% that is often blue and underlined% that the reader clicks to jump to a different 
location. 
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Use the automatic formatting features for Word documents and Web pages when you 
know the addresses to jump to or when you have a document that contains file names 
or addresses that you want to format as hyperlinks. Use Insert Hyperlink to insert a 
hyperlink into Word files and Web pages when you aren't using the automatic 
formatting features or when you want to browse for the destination address. Use a 
drag-and-drop operation in Word files when you want to use the mouse to quickly 
create a hyperlink for text located within another Office file. 

Change the display text or image of a hyperlink 

You can change the display text or image of a hyperlink % the "hot" text or image that 
a user clicks to follow the hyperlink % as you would edit any text or image in your 
document or Web page. To avoid following the hyperlink, or opening the file you're 
inserting the hyperlink to, it's usually best to use the keyboard to select the image or 
text you want to change. 

1 Click outside of the text or image. 
2 Press the arrow keys until your insertion point is located just to the left or the right 
the image or text you want to change. 
3 Hold downs SHIFT and press an arrow key until the text or image is selected. 

Hold down CONTROL+SHIFT to select whole words. 

4 Edit the image or text. 

Remove a hyperlink 

1 Right-click the hyperlink you want to remove, point to Hyperlink on the 
shortcut menu, and then click Edit Hyperlink. 
2 Click Remove Link. 

Tip To remove a hyperlink and the display text or image that represents the hyperlink 
in the document, select the hyperlink, and then press DELETE. 

Change the appearance of all hyperlinks in Word documents 

This procedure doesn't affect hyperlinks on Web pages. For more information about 
changing text colours in Web pages, click . 

1 Open the document that contains the hyperlinks you want to change. 
2 On the Format menu, click Style. 
3 To change the appearance of a hyperlink, click Hyperlink in the Styles box, 
and then click Modify. 
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To change the appearance of a followed hyperlink, click FollowedHyperlink in the 
Styles box, and then click Modify. 

4 Click Format, and then click Font. 
5 Select the options you want. 

Tips 

To use animated text, click the Animation tab in the Font box, and then click 
the option you want in the Animations box. For instance, you could use Las Vegas 
Lights or Sparkle Text to point out the hyperlinks in your document. 

To use the modified Hyperlink or FollowedHyperlink style in new documents 
based on the same template, select the Add to template check box in the Modify 
Style dialog box. Word adds the modified style to the template attached to the active 
document. 

Change the hyperlink destination 

1 Right-click the hyperlink you want to change, point to Hyperlink on the 
shortcut menu, and then click Edit Hyperlink. 
2 Select the options you want. 

Set a hyperlink base for a document 

When you create a hyperlink in a document, you can make the path to the 
destination of the hyperlink a fixed file location (absolute link), which identifies the 
destination by its full address, such as c:\My Documents\Sales.doc, or you can make 
the path a relative link. Use a relative link if you want to move or copy the file that 
contains the hyperlink or the destination file to a new location. To change the path of 
the relative link, set a hyperlink base for the document. 

1 Open the document you want to set a hyperlink base for. 
2 On the File menu, click Properties, and then click the Summary tab. 
3 In the Hyperlink base box, type the path of the relative link you want to use 

for all the hyperlinks you create in this document. 
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CREATING AND WORKING WITH WEB PAGES 

CREATING WEB PAGES 
Create a Web page 

Word offers two easy ways for you to create Web pages. You can start a new page by 
using a wizard or template, or you can convert an existing Word document to HTML, 
the format used for Web pages. When you create a Web page with either of these 
methods, Word customises some toolbars, menu commands, and options to provide 
the Web page authoring features. 

Using the Web page authoring features to create your Web page will usually produce 
the best results. You can use the Web Page Wizard to start with sample content% 
such as a personal home page and registration form % and graphical themes % such as 
festive and community% to help you quickly creates a Web page. If you prefer, you 
can start with a blank Web page. For information about many of the features you can 
use in Web pages, click . 

Use the HTML conversion method when you have existing Word content that you 
want to quickly convert to a Web page. The formatting and features that are supported 
by HTML will be converted. For more information, click 

What do you want to do? 

Create a Web page from a wizard or template 
Save a Word document in HTML format 

Items you can add to Web pages 

You can make Web pages look more interesting by adding bullets and numbering, 
horizontal lines, background colours and textures, tables, pictures, videos, scrolling 
text, and forms. You add most of these items in much the same way as you do in a 
Word document. However, to make Web page authoring easier, Word offers some 
new and some customised commands for this purpose. 
Obtain more Web page graphics and templates from the Microsoft Web site 

Additional bullets, textured backgrounds, horizontal lines, and templates are available 
on the Microsoft Web site. If you have access to the World Wide Web, you can 
obtain these items to use on your Web pages. 
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Tips for creating Web pages 

There are many opinions about the best way to structure and design Web pages. You 
can find many tips, examples, and style guides on the World Wide Web. Here are 
some tips that apply to most Web pages: 

Content should be well organised. Well-structured pages help you deliver 
ideas effectively and help the reader navigate through your site. For more information, 
click . 

Text on Web pages should be easy to read. If you add a background to your 
Web page, it should contrast with the text colour. For more information, click . 

Web pages may not look the same in different Web browsers. It's a good idea 
to plan your Web pages so they are viewable in most browsers. For more information, 
click . 

Large images increase download time, especially for readers who gain access 
to Web pages by modem. Although graphics can make Web pages more interesting, 
you should use graphics strategically. For more information, click . 

Some users tum off the display of images, and some Web browsers don't 
support all video formats. When images and videos contain information that you don't 
want readers to overlook, you can use alternative text for graphics and alternative text 
and images for videos. For more information, click . 

You can use tables as a layout tool. For example, HTML, the format for Web 
pages, doesn't support newspaper columns, but you can create a two-column effect by 
using tables. For more information, click . 

Add a background sound to a Web page 

You can have a background sound play automatically when someone opens your Web 
page. 

1 On the Insert menu, points to Background Sound, and click Properties. 
2 In the Sound box, enter the address, or URL, of the sound file you want, or 
click Browse to locate the file. 
3 In the Loop box, click the number of times you want the sound to repeat. If 
you want it to loop continually while the Web page is open, click Infinite. 
4 To copy the sound to the same folder as your Web page, select the Copy to 
document folder check box. To use a relative path, a path that's relative to your 
current page, select the Use relative path check box. 

For more information about managing files for Web pages, click 

Notes 
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To review the sound while you are authoring the Web page, point to 
Background Sound on the Insert menu, and then click Play. To stop the sound, click 
Stop. 

For others to hear background sounds, they must have a sound system 
installed, and their Web browser must support the sound format of the file you 
inserted. You can insert sound files in WAY, MID, AU, AIF, RMI, SND, and MP2 
(MPEG audio) formats. 

The background sound plays automatically every time your page is opened or 
returned to. For frequently opened pages, such as home pages, this repetition could 
become annoying. You could add the background sound instead to a page that the 
user is likely to jump too less frequently. Or you could insert a hyperlink that the user 
can click to download a sound file. For more information about inserting hyperlinks, 
click . You may want to use caution when selecting Infinite for a looping option, 
because the sound will play continually when the user opens the page. 

Add a horizontal line to a Web page 

Horizontal lines are used often on Web pages to separate logical sections of text. 

1 Click where you want to insert the line. 
2 On the Insert menu, click Horizontal Line. 
3 In the Style box, click the line that you want, or click More to select a 
different line. 

Notes 

A Web browser will draw the first line in the Style box when someone opens 
the page. The other line styles are graphical images. When you save this Web page, 
the line will be saved as an image, such as image.gif, image 1.gif, in the same location 
as the Web page. If you move the Web page % for instance, when publishing the 
page % you should also move the image of the line. For more information, click . 

To quickly insert another line with the same style, click Horizontal Line 

Add a video to a Web page 

You can add an inline video to your Web page, which means the video is downloaded 
when the user opens the page. You can determine whether the video will play when 
the page is opened or when the user points to the video with the mouse. Because not 
all Web browsers support inline video, you may want to provide alternative text and 
images or avoid presenting essential information in videos. 
It's recommended that you save your document before inserting videos. For more 
information about managing files and links, click . 
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1 On the Insert menu, clicks Video. 
2 In the Video box under Source, type the address or URL of the video file you 
want. Or click Browse to search for the file. 
3 In the Alternate image box, type the address or URL of the graphics file that 
you want to designate as a substitute when the user's browser doesn't support videos 
or when the user turns off the display of videos. 
4 In the Alternate text box, type the text that you want to appear in place of the 

video or alternative image when the user's browser doesn't support videos, 
when the server where the video or image is located is temporarily 
unavailable, or when the user turns off the display of images and videos. 

5 In the Start list, click an option to specify how the video will play on a Web 
page. Open causes the video to play when the user downloads the Web page; Mouse­ 
over causes the video to play when the pointer moves over the video; Both causes the 
video to play in both scenarios. 
6 In the Loop box, enter the number of times you want the video to repeat. 
7 If you want to display video controls, such as "Start" and "Stop," while you're 
authoring Web pages, select the Display video controls check box. 

8 To copy the video to the same folder as your Web page, select the Copy to 
document folder check box. To use a relative path, a path that's relative to your 
current page, select the Use relative path check box. 

Notes 

The video will play after you insert it. If you've selected the Mouse-over 
option for video playback, the video will also play in your Web page document when 
your mouse moves over it. 

Video files can be very large and take a long time to download. For tips on 
reducing the size of images, click . 

You can also insert a hyperlink to a video, which means the user can click the 
hyperlink to download the video and play it. For more information about inserting 
hyperlinks, click . 

Add scrolling text to a Web page 

You can enhance your Web page with scrolling text, which is also known as a 
marquee. 

1 On the Insert menu, clicks Scrolling Text. 
2 Type the text that you want to scroll in the Type the scrolling text here box. 
3 Select any other options you want. 
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Notes 

Scrolling text, or the marquee, is supported in all versions of Microsoft 
Internet Explorer except version 1.0. Some other Web browsers don't support 
scrolling text. In those browsers, the text will appear but it won't scroll. 

To delete scrolling text, select the text, and then click Cut on the Edit menu. 
Set the language for a Web page 

When you are authoring a Web page, you can specify the language of the font, or the 
encoding, that a Web browser will use to display the page. For instance, if you want 
the page to appear with Greek characters, set the language to Greek. You can also set 
a default language encoding for new pages that you create. 

1 On the File menu, clicks Properties. 
2 Under HTML encoding, select the items you want. 

To specify the language code that Word will use to display the page if the 
page is not already displayed with the correct language encoding, click the language 
you want in the For displaying this page list. This setting is also used when loading 
subsequent pages, if the language encoding cannot be determined. 

To specify the language code for saving the page, click the language you want 
in the For saving this page list. 

To specify a default encoding for new Web pages that you create, click the 
language you want in the For creating new Web pages (default encoding) list. 

Notes 

To have Word always save your pages using a default language encoding, 
select the Always save Web pages with default encoding check box. This setting 
affects the current page and future pages that you save. This setting is useful if you 
reuse pages from other sources and want to store every page in one encoding. 

Some languages have more than one encoding scheme. To view the available 
encoding, see the lists under HTML encoding. 

Assign a title to a Web page 

The title appears in the title bar of the Web browser, and if someone stores a link to 
your Web page, the title appears in that person's history list and favourites list. 

1 On the File menu, clicks Properties. 
2 In the Title box, type the title you want. 
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Note If you don't specify a title, Word suggests a title based on the first few 
characters that appear on your Web page. 

Insert HTML mark-up 

Word provides features that help you create a Web page without writing HTML 
source. However, you can also insert your own HTML source code onto a page. 

1 Enter the HTML sources that you want. 
2 Select the source. 
3 In the Style box , NORMAL click HTML Mark-up. 

Notes 

You can also enter the HTML source directly when you are viewing the 
source of a Web page. View the source, and then type the HTML codes that you want. 
For more information about viewing the HTML source, click . 

Applying the HTML mark-up style will format text as hidden. If you need to 
view this text and hidden text is not showing, click Show/Hide 

Create a custom HTML template 

You can create a custom template that you base Web pages on. When you create the 
template, start with the Blank Web Page template, and then modify the template as 
you would any Word template. 

1 On the File menu, clicks New. 
2 Double-click Blank Web Page. 
3 Add any boilerplate text or graphics that you want. 
4 On the File menu, click Save As. 
5 In the Save as type box, click Document Template (*.dot). 
6 Word proposes the Templates folder in the Save in box. To save the template 
so that it will appear on a tab other than General, switch to the corresponding 
subfolder within the Templates folder. 

7 In the File name box, type a name for the new template, and then click Save. 

It is recommended that you give the file a .dot extension. 
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CHANGING THE APPEARANCE OF WEB PAGES 

Learn about formatting Web pages 

When creating Web pages in Word, you can use many of the same formatting tools 
you use for Word documents. For instance, you can click Bold to apply bold 
formatting to text, or you can click Heading 1 in the Style box NORMAL to apply 
a heading style. 
The HTML source that Word creates for the Web page doesn't contain formatting, 
but it contains codes that instruct the Web browser to format text. Word takes care of 
the HTML codes behind the scenes, though, so all you need to do is apply the 
formatting you want. 

Paragraphs will automatically contain space before and after them. To create 
paragraphs with no white space between them, press CTRL+ENTER. 
Formatting that isn't supported by HTML or some Web browsers aren't available in 
the Web authoring environment in Word. This includes the Emboss, Shadow, and 
Engrave character formatting effects, line spacing, margins, character spacing, 
kerning, text flow settings, and spacing before and after paragraphs. Tabs are not 
available because they are displayed as spaces by many Web browsers % to shift the 
first line of text to the right, you can use an indent. 

You can apply bold, italic, underline, strikethrough, superscript, and subscript formats 
to selected text. You can change the size of selected text to font sizes supported by 
HTML. You can click Increase Font Size or Decrease Font Size to quickly switch 
to the next available font size. You can also change the type of font, but keep in mind 
that others viewing your Web pages may not have the same fonts on their systems. 
Also, some Web browsers display text in a default font only. 

You can set the colours for text, hyperlinks, and followed hyperlinks for the entire 
page with the Text Colours dialog box (Format menu). You can change the colour 
of selected text % for instance, a word or a sentence % by clicking Font Colour. 
Setting the default text colours for the page doesn't change text whose colour you've 
changed with the Font Colour button. 

You can indent text in .25-inch increments by clicking Increase Indent and Decrease 
Indent , and you can change the alignment of text by clicking Align Left , Centre , 
or Align Right . However, you can't justify text on Web pages. 
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Learn about tables on Web pages 

Working with tables on Web pages is similar to working with tables in Word 
documents. You can use Draw Table to create and modify the structure for your 
table. You can insert a table grid by using Insert Table. There are some differences in 
how borders are applied and cells are formatted. 
Because tables are often used as a behind-the-scenes layout tool on Web pages% for 
instance, to arrange text and graphics % they do not have borders when you insert 
them. You can add borders to tables on Web pages by using the Border command 
(Table menu). Borders that you apply to tables on Web pages have a 3-D appearance 
in Web browsers. 

You can change the background colour, or shading, of tables by using the Table 
Properties command (Table menu); change the background colour of selected cells 
by using the Cell Properties command (Table menu). 
You can change the height of selected rows and the width of selected columns by 
using the Cell Properties command (Table menu). You can change the way that text 
wraps around the table, the distance between the table and surrounding text, and the 
spacing between columns by using the Table Properties command (Table menu). 

Using tables as a layout tool 

You can use tables with or without borders to add graphical effects and manage the 
layout of your Web page. You can organise columns of graphics and text so that they 
will be aligned together in Web browsers. Without tables, it's difficult to keep 
graphics and text aligned in HTML, the format for Web pages. 
You can use the table drawing tool in Word to help arrange text and graphics. If you 
don't want the border to appear on the finished Web page, remove the border. Even if 
the border is removed, gridlines may appear in your Word document to show the 
table boundaries. To control the display of gridlines, click Hide Gridlines or Display 
Gridlines on the Table menu. These will not appear on the finished Web page. 

Most Web browsers now support tables, but some earlier versions do not. If you 
intend for a broad audience to view the content in the table, you may want to also 
structure your information in text-only format and then provide a hyperlink to the 
text-only version. 
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Set text colours on Web pages 

When creating a Web page, you can determine the default colour scheme for text and 
hyperlinks for the Web page. This setting doesn't change the colour of text whose 
colour was set by applying direct font formatting, for example with Font Colour 

1 On the Format menu, clicks Text Colours. 
2 Select the colours you want in the Body text colour, Hyperlink, and 
Followed hyperlink lists. 

Notes 

Colours you set by using the Text Colours command become the default 
colours for all the text, hyperlinks, and followed hyperlinks. You can apply direct 
colour formatting to selected text by clicking Font Colour . 

Those who view your Web page can set their own default colours in their 
Web browsers. To have the colours of text and hyperlinks appear in the browser 
default colours when viewed in a browser, select Auto in each list. 

Working with styles on Web pages 

You can apply built-in styles that correspond to formatting that's supported by HTML 
on Web pages. You apply styles to text on Web pages the same way you apply styles 
to Word documents, but there are some differences in how styles work. 
When you are creating a Web page, Word adds the HTML styles to the Style box 
NORMAL on the Formatting toolbar and to the Styles list in the Style dialog box ( 
Format menu). One character style, HTML Mark-up, should be used for HTML 
source codes that you want to enter manually. 

The HTML-specific styles, such as Address and H2, correspond directly to an HTML 
tag; any modifications you make to these styles will not be retained. If you modify a 
Word built-in style, such as Heading 1, the formatting associated with the style will be 
exported to a corresponding HTML tag, provided the formatting is supported in 
HTML. 
You can define and modify your own styles. When you save the page as HTML, only 
the HTML-supported formatting is converted % any other formatting is lost when you 
view the page in a Web browser. For more information about formatting on Web 
pages, click . 
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Learn about bullets and numbering on Web pages 

You can create bulleted lists when authoring Web pages, similar to the way you create 
bulleted lists when creating Word documents. One main difference is that you can use 
graphical images in addition to bullet symbols. 
Bullet images are available in the Bullets and Numbering dialog box (Format 
menu) when you create Web pages. Text bullets that are supported by HTML, the 
format for Web pages, are also available. In addition to using the graphical bullets in 
the dialog box, you can click More to use other images as bullets. After choosing the 
image you want, click OK to return to the document. 

When you use images as bullets, the images are saved as GIF (.gif) images (unless 
you insert a JPEG [.jpg] image, in which case the JPEG format is retained) in the 
same location as or in a location relative to your Web page. For more information 
about managing files and links, click . 
When you use images as bullets, you can change the image by using the Bullets and 
Numbering command. Before changing a bullet image, however, you must delete the 
existing bullet images. If you inadvertently apply new bullet images without deleting 
the first images, just delete the first bullet images by selecting them and pressing 
DELETE. 

Some settings for bullets and numbering that are supported by HTML aren't available 
when you author Web pages. For instance, it's not possible to change the distance 
between bullets or numbers and text in the Web authoring environment. 
Numbering on Web pages is similar to numbering in Word documents, except that 
automatic outline and heading numbering isn't available in the Web authoring 
environment. By applying different numbering styles and indents, however, you can 
create a list that appears to have multiple levels. For more information, click . 
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WORKING WITH GRAPHICS ON WEB PAGES 

Learn about working with graphics on Web pages 

The first time you save your Web page in HTML format, all graphics are converted 
to GIF or JPEG format, two image types that are supported on the World Wide 
Web. 
You can insert a graphic on a Web page by pointing to Picture on the Insert menu 
and then clicking From File or Clip Art. If the graphic is in JPG format when you 
insert it, Word saves it in JPG format. If the graphic is in any other type of format, 
such as TIF, Word converts it to GIF format. If you have Internet access, you can 
obtain more graphics from the Microsoft Web Art Page. 

When you insert a graphic from a file, Word copies the graphic to the same folder as 
your Web page when you save the Web page, unless you select the Link to file check 
box. If you select the Link to file check box, you can link to a graphic at a fixed 
location, such as another Web server. 
When you insert a graphic on a Web page, it is aligned with the left margin by 
default. You can control the way text flows around the graphic by selecting it and then 
using the commands on the Format menu and the Picture toolbar. To provide 
additional control over the layout of text and graphics, use a table. 

You can use drawing objects% such as Autoshapes, text boxes, and WordArt 
effects% as Microsoft Word Picture objects. Once you close your document, you 
won't be able to update these items again. They will become static GIF images. For 
more information, click . 
The Picture toolbar in Word is customised to provide alignment commands that help 
you arrange your graphics. The customised Picture toolbar commands are compatible 
with HTML, the format for Web pages. When you select a graphic, the Picture 
toolbar appears. To hide the toolbar, right-click the graphic, and then click Hide 
Picture Toolbar on the shortcut menu. 

Align images on Web pages 

When you insert a graphic, such as a picture, on a Web page, by default the graphic is 
aligned with the left margin, and text does not wrap around it. This procedure changes 
the alignment and the way text wraps. 

1 Select the graphic. 
2 On the Format menu, click Picture, and then click the Position tab. 
3 Under Text wrapping, click None, Left, or Right. 
4 Under Distance from text, enter the amount of distance you want between the 
picture and the surrounding text. 
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Notes 

To quickly change the way that text wraps, you can also use the buttons on the 
Picture toolbar. 

Left and right alignment isn't available for graphics in table cells. 
Multiple images cannot appear in the same paragraph with the same 

alignment. 

Learn about creating graphics with transparent areas for Web pages 

You can use Microsoft Photo Editor, which comes with Microsoft Office, to create 
GIF (.gif) images with transparent areas for Web pages. When an image contains a 
transparent area, the background colour or texture of the page "shows through" the 
image. 
If Microsoft Photo Editor is not installed on your system, run Set-up again, and select 
Photo Editor in the Office Tools group. For more information about installing 
components of Microsoft Office, click . 

From Word, you can insert a Photo Editor object, and then apply transparency to the 
background colour. On the Insert menu, click Object, and then click the Create New 
tab. Under Object Type, double-click Microsoft Photo Editor 3.0 Photo. Open the 
graphic or photo you want to apply a transparent area to, and then use the Set 
Transparent Colour tool to apply transparency to the image. 
You can also create a graphic with transparent areas in Photo Editor and then insert it 
into Word. For more information about using Photo Editor, search on the keyword 
transparent areas in the Online Help Index in Photo Editor. 

WORKING WITH FORMS ON WEB PAGES 

Create a form for a Web page 

Forms are frequently used on Web pages to collect and provide dynamic data. Some 
examples are forms that provide data from a database on request, registration forms 
for memberships or events, and forms that help users provide feedback about your 
site. 
Word helps you design the form and set the properties for the form elements. Because 
forms require additional support files and, therefore, additional server support, it is 
recommended that you consult your network or Web administrator when planning the 
form. 
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Sample forms, such as feedback and survey forms, are available from the Web Page 
Wizard. You can use the wizard to create a basic form and then modify it to fit your 
needs. Or if the wizard doesn't contain a form that suits your needs, you can create a 
form by inserting the controls you want. 
1 If the Web Page Wizard contains a form you want to use or modify, run the 

wizard, and choose the form you want. 
How? 
If you are creating a form without using the wizard, use the Blank Web Page 
template. 

2 Click where you want to insert additional controls. 
3 On the Insert menu, point to Forms, and then click the form control you want 

to use. 
4 Double-click the control to display properties for the form. 
5 Enter the properties for the form control using either the Alphabetic or 

Categorised tabs. 
6 Repeat steps 2 through 5 until you've added all the form controls you want. 

So that users can submit the form after filling it in, each form should contain a 
Submit or an Image Submit control. 

7 Add or modify any content that you want. 
8 When you are finished inserting form elements, click Exit Design Mode in 

the Control Toolbox. 

VIEWING WEB PAGES AND HTML SOURCE 

View the HTML source of a Web page 

When you save your Web page, Word works behind the scenes to create HTML tags, 
which Web browsers interpret to display your text, graphics, sounds, and videos. For 
example, when you press ENTER to create a new line, Word converts the paragraph 
mark to a <P>, or paragraph tag, in the HTML source. 
It's usually not necessary to view the HTML source as you author Web pages, but you 
can view it if you like. To view the HTML source, you should first save unsaved 
changes to the file. 

1 Click Save. 
2 On the View menu, click HTML Source. 

Note To return to the Web page, click Exit HTML Source 
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Preview a Web page while authoring it 

In order to preview the Web page you're authoring, you must have a Web browser 
installed on your computer. 

Click Web Page Preview 

Note To switch back to Word, click the Word icon in the task bar, or close the 
browser. 

WORKING WITH WEB PAGES AND WEB AUTHORING TOOLS 

Get the latest version of Web authoring tools 

Microsoft will periodically provide updated versions of the Web page authoring tools 
to keep up with changing technology. If you have access to the World Wide Web, 
Word will periodically check to see if a newer version of the Web authoring tools is 
available on the Microsoft Web site. If a newer version is found, a dialog box appears 
to notify you that a newer version is available. You can choose to download and 
install the latest version. You can also use the AutoUpdate command on the Tools 
menu to manually check for the latest version, if you have a dial-up connection to the 
World Wide Web. 

1 Open a Web page document. 
2 On the Tools menu, click AutoUpdate. 
3 If Word prompts you to download the latest version, click Yes. 

Learn about managing files and links on Web pages 

When authoring Web pages, you should manage the related files and plan the links 
and hyperlinks so the images will appear and the links will "work" once the pages are 
placed on the final HTTP server. In many cases, the location where you create your 
Web pages will be different from the location on which they will be published. For 
more information about publishing Web pages, click . 
When all the files % such as bullets, navigational buttons, background textures, and 
Web pages you create hyperlinks to% will be published on the same Web server, you 
should probably use relative links. Using relative links makes it easier to move 
materials to another location. If you move the files or send them to someone, you 
should maintain the same file structure, including subfolders. 
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For example, your Web page, called Pagel.html, includes bullets stored in the Bullets 
folder, so the relative paths for the bullet files are \Bullets\Bulletl.gif and 
\Bullets\Bullet2.gif. If you move Page I .html, you need to create a folder called 
Bullets in your new location where you can move the Bulletl .gif and Bullet2.gif files. 
When you insert items on your Web page% such as pictures, graphical buttons and 
lines, and hyperlinks to other pages % Word prompts you to save your current file. 
Saving is necessary so that Word can properly create links that are relative to your 
current file. 

Hyperlinks to other Web sites, such as a list of your favourite Web sites, should 
typically use a fixed file location that includes the full path, or URL. To indicate an 
absolute, or fixed, location, clear the Use relative path for hyperlink check boxes in 
the Insert Hyperlink dialog box (Insert menu). 
Images, sounds, and videos can't be embedded in Web pages as they can in Word 
documents. These items are stored in separate files. Word will export embedded 
images and OLE objects in Word documents as GIF images when you save your Web 
page. 

When you apply graphical bullets through the Bullets and Numbering command 
(Format menu), insert graphical lines with the Horizontal Line command (Insert 
menu), or add a textured background with the Background command (Format 
menu), Word saves these items as separate files in the same location as your Web 
page. You'll need to move these files along with your Web pages so your links will 
work, which is necessary for your images to appear. For example, bullets are saved as 
Bullet.gif, Bulletl.gif, Bullet2.gif, and so on; lines are saved as Line.gif and so on; 
and textured backgrounds are saved as Image.gif and so on. 
GIF and JPEG formats are common graphical formats used on the Web. When you 
insert an image that is not in either of these formats with the From File subcommand 
(Picture command, Insert menu), and the Link to file check box is cleared, the 
image will be saved in the GIF format. Word saves the images as Image.gif, 
Imagel.gif, and Image2.gif and so on in the same folder as your Word document. If 
you insert JPEG images, the JPEG format and file name extension (.jpg) is retained. 

Learn about charts, equations, and other objects on Web pages 

You can add charts, equations, and other objects to a Web page, although once you 
close the Web page, you can't update the objects as you can OLE objects. The chart, 
equation, or other object becomes a GIF graphic that you can no longer update. 
Insert a chart, equation, or other object by using the Object command on the Insert 
menu. Just keep in mind that you can't make changes to the object once you close the 
document. If you plan to work with a complex equation or chart that you want to 
continue to update, you can instead store it in a Word document and then paste it onto 
your Web page when you're finished working on it. 
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Make your Web page available to other people 

The steps that you take to make your pages available to other people depend on how 
you want to share them. 
To make pages available to other people on your network, save your Web pages and 
related files, such as pictures, to a network location. If your company uses an intranet 
based on Internet protocols, you may need to copy your pages to a Web server. 
Contact your network or Web administrator for more information. 
To make your Web pages available on the World Wide Web, either you need to locate 
an Internet service provider that allocates space for Web pages, or you need to install 
Web server software on your computer. Some factors to consider in setting up your 
computer as a Web server are your computer's speed and availability. If you don't 
want to leave your computer on most or all hours of the day, then you may not want 
to set up your computer as a Web server. 

If you are working with an Internet service provider or a Web administrator, you 
should ask how the Web pages, graphics files, and other files should be structured on 
the server. For instance, find out whether you need to create separate folders for 
bullets and pictures, or whether you need to store all the files in one location. If you 
plan to use forms or image maps, you should ask about any limitations on using these 
items, because they require additional server support. 

Setting up a Web server requires special software. You can use Personal Web Server, 
which is available on the Office 97 ValuPack on CD-ROM, to set up a Web server. 
You can also use Microsoft Internet Information Server to set up an advanced Web 
server. If you have access to the Web, you can learn more about Microsoft Internet 
Information Server. 

The differences between Word and Microsoft FrontPage for Web authoring 

Web page authoring tools are provided with Microsoft Word and with other Microsoft 
Office programs to enable you to easily create various types of Web pages. Another 
Microsoft program, called FrontPage, also helps you create various types of Web 
pages by using an interface that's similar to other Office programs. FrontPage also 
helps you to manage a Web site. 
To create Web pages, you can use the Web page authoring tools in Microsoft Word, 
Microsoft FrontPage, or both. Both programs provide wizards to automate your work, 
and both enable you to view your Web page content % such as bullets and images % 
as you work. There are some purposes, however, for which one program is better 
suited. 
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Use Web page authoring tools in Microsoft Word when: 

You want to use the robust word-processing features in Word, such as 
automatic spelling checking, AutoText, and AutoCorrect. 

Other Web page authors whom you work with frequently use Word. 
You have customised Word features% such as AutoText, custom dictionaries, 

and AutoCorrect entries% that you want to use when creating Web pages. 

Use FrontPage when: 

You want to use WebBot to insert scripts and form elements, such as server 
includes and timestamps. 

You are working with a large team or managing a Web server. 
You need user authentication for Web page authors. 

Note In the Microsoft FrontPage Explorer, you can specify Word as your default 
editor for HTML files. See FrontPage documentation for more information. 

I can't find Web page authoring tools. 

To use the Web authoring features in Word, you must use a Web page template or 
wizard, or convert an existing document to HTML, the format used for Web pages. 
When the Web authoring features are active, you'll notice that the toolbars and menus 
have been customised for working on Web pages. 
The Web templates are on the Web Pages tab in the New dialog box (File menu). To 
convert a document to HTML, click Save as HTML on the File menu. 

If you don't see the Web Pages tab, the Web features may not be installed. You may 
need to run Set-up again and select Web page authoring components. For more 
information, click . 

I can't find Web page files to open them. 

Once you have used the Web page authoring tools, your Web page files% those with 
.html, .html, .asp, or .htx extensions % appear by default in the Open dialog box (File 
menu). Before you use the tools, you can get Web page files to appear in the list by 
clicking All Files in the Files of type box. 
For more troubleshooting information about opening files, click . 
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USING VISUAL PAGE 
USING BASIC FEATURES 

Creating a new Web page 
There are essentially two kinds of Web pages you may create: a Web page with 
frames or a Web page without frames. A Web page with frames can display the 
contents of a different Web page in each of its frames. Like a picture holder that has 
multiple frames for displaying multiple pictures simultaneously, a framed Web page 
can display multiple Web pages simultaneously. A Web page without frames simply 
displays one Web page file. To continue the previous comparison, a Web page 
without frames is like a single picture frame that displays one photograph. 

To create a new Web page: 

1 From the File menu, selects New (or press Control-N). 
A new, untitled Web page opens in Edit mode. 

2 Add graphics, text, plugging, links, and Java applets directly to your new Web 
page. 
3 Save your Web page in a folder dedicated to your collection of Web pages. 

To create a Web page that includes frames: 

1 From the File menu, chooses New Frame Set. 
Visual Page displays a Web page, which is divided into two frames of equal 

size. 
2 You may directly add the text, HTML tags, graphics, and plug-ins to each 
frame, or you may open an existing Web page file in a frame. For more information, 
see Setting the frame source . 
3 Save your Web page in a folder dedicated to your collection of Web pages. 
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Setting the frame source 

A Web page with frames, also known as a frame set, can display multiple Web pages 
by having a different Web page assigned to each frame. You can set a frame to 
display a particular Web page by using the Set Frame Source menu item to assign a 
particular Web page HTML file to the selected frame. 

To set the source file for a frame: 

1 Make sure a frame is selected in an open Web page. 
2 Select Frame > Set Frame Source. 

A standard Open file dialog box displays. 
3 Navigate to and select the HTML files you want the selected frame to display. 
4 Click open. 

A Visual Page Frame Save dialog box displays. 
5 Save the changes to the frame. · 

If you have not given the frame a name, a Save As dialog box displays. 
6 Enter a name for the frame and save it. 

Visual Page displays the Web page in the selected frame. 

Starting from an existing Web page 
The standard Visual Page installation places several professionally designed templates 
in your Visual Page directory. You can use these pre-existing Web pages as the basis 
for your own Web pages. Opening a Visual Page template is the same procedure you 
will use to open a Web page on which you have previously worked. 

To open an existing Web page: 

1 Select Open from the File menu (or press Control-0). 
2 Navigate to the directory where the file you want to work on is located. 
3 Select the file, and click Open. 

The Web page opens in Edit mode. 

Saving a Web page 

When you save a Web page file and name it, make sure that you preserve the HTML 
filename extension. All Web page files must end with a .html or .html filename 
extension. Visual Page's default filename extension is .html. You can change the 
default filename extension in the Preferences dialog box. 
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To save a Web page without frames: 

1 From the File menu, chooses Save or if you want to save a copy of a file with 
a different name, choose Save As. 
2 Navigate to the destination folder for the saved file. 
3 Enter the file name. 

Visual Page includes the default file extension. 
4 Click Save. 

The file is saved to the destination folder. 

Overview of preferences 

Visual Page provides a variety of preferences settings that you can use to customise 
your Web page building environment. If you choose Preferences from the Edit menu 
the Preferences dialog box displays. It includes tabs for: 

1 Setting General Preferences 
2 Setting Output Preferences 
3 Setting Images Preferences 
4 Setting Folder Mappings Preferences 
5 Setting FTP Preferences 
6 Setting Syntax Colour Preferences 

Setting Page Default Preferences 

Use the Page Defaults tab of the Preferences dialog box to set defaults preferences for 
every new page you create with Visual Page. If you want to restore these preferences 
to the default settings, click Use Defaults. If you want to change back to the settings 
that were in place before you opened this dialog box, click Revert. 

To set Page Default preferences: 

1. From the Edit menu, choose Preferences. 
The Preferences dialog box appears. 

2. Click the Page Defaults tab. 
3. Use the dialog box to select the page default preferences you want. 

The preferences are listed below. 
4. When you're finished setting preferences, click OK. 
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* Background sets the default background colour. 
Normal Text sets the default colour for normal text/ 
Normal Links sets the default colour for normal links/ 
Active Links sets the default colour for active links. 
Visited Links sets the default colour for visited links. 
Background Image You can have each new page use a default image as a 
background. 

* 
* 
* 
* 
* 

1 Click the checkbox or click the ellipses. 
The Open dialog box appears. 
Locate the image you want to set as a default background. 
Click Open. 
The selected image appears in the Image Preview window. 
Click OK to make the image the default background image. 

2 
3 

4 

Previewing your work 

To see how your Web page will look in a browser, use the Preview Mode. You'll 
know you're in Preview Mode when the Edit Page toolbar button is active and the 
Preview Page toolbar button is inactive. 

To go to Preview Mode: 

1 From the Edit menu, choose Preview Page. If instead you see Edit Page, you 
are already in Preview Mode. 

2 You can also click the Preview Page tool bar button. 

Printing Web pages 

Using Visual Page, you can print your Web pages as they will appear in a browser. If 
you want to print out the HTML source, make sure that the Source Window is active. 

To print a Web page: 

1 From the File menu, selects Print (or press Control-P). 
2 Select the desired print options. 

Visual Page prints your document. 

- 54 - 



NEAR EAST UNIVERSTY 
COMPUTER ENQ/NEER/NQ 

1988 

ADDING TEXT 

Adding text 

Adding text to your Visual Page documents is very similar to inserting text using any 
standard word-processing application. The following procedures explain how to insert 
and format text. 

You can insert text by: 

Typing text 
Dragging and dropping text 
Copying and pasting text 
Importing a plain text file 

You can format text by: 

Generating paragraphs and line breaks 
Aligning and indenting paragraphs 
Formatting paragraphs 
Formatting characters 
Creating bulleted lists 
Creating ordered lists 
Creating term and definition lists 

Typing text 

If you have ever used a word processor to create a text document, you probably know 
how to type text into a Web page in the Visual Page environment. Visual Page 
supports all the standard text operations. 

To insert text by typing: 

1 Make sure that you're in Edit mode. 
For information on switching to Edit mode, see Previewing your work. 

2 Within the main Edit window, moves the text cursor to where you want to 
insert text. 

3 Single-click at the insertion point. 
4 Type in your text. 

The text displays on the Web page. 
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Dragging and dropping text 

Visual Page supports drag-and-drop functionality in many ways. It is an extremely 
handy way to move text from one location to another. Visual Page also allows you to 
insert other objects, such as images, from the Windows Explorer into Visual Page. 

To insert text by drag-and-drop: 

1 Make sure that you're in Edit mode. 
For information on switching to Edit mode, see Previewing your work. 

2 Make sure that the files that you want to drag to and from are open. 
3 Select the text you wish to move. 
4 Click on the selection, and, without releasing the mouse button, move the 

selection to the new location. 
5 Release the mouse button. 

The text is now in the new location. 

To insert other objects into Visual Page: 

1 Make sure that you're in Edit mode. 
For information on switching to Edit mode, see Previewing your work. 

2 Locate the object ( e.g. image) you want to insert with the Windows Explorer. 
3 Press and hold the Control key while dragging the object from Explorer into 

Visual Page. 
When you release the mouse and control key, the Save As dialog box appears. 

4 At this point, you can rename the object, or click OK to use the default name. 
The object is added to your page. 

Importing a plain text file 

This feature allows you to instantly fill your Web page with the text from a text file. 

To insert text by importing a plain text file: 

1 Make sure that you're in Edit mode. 
For information on switching to Edit mode, see Previewing your work. 

2 Position the cursor where you want the text to display. 
3 Using the Local Site window, select the plain text file. 

For more information see, Opening a Local Site window. 
4 Drag the plain text file from your Local Site window and drop it on your Web 

page. 
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The contents of the text file displays on your Web page. 

Using the Spelling Checker 

You can check the spelling in your page at any time by clicking the Spelling Checker 
icon. The Spelling Checker checks the spelling in the entire page, but does not check 
spelling of words that you highlight. The functions available are: 

1 Ignore skips the current word and continues spell checking. 
2 Ignore All skips all instances of this word. 
3 Add places the current word into the dictionary. 
4 Change replaces the current word with the word in the Change To window, or 

to the word that is highlighted in the Suggestions window. 
5 Change All replaces all instances of this word with the word in the Change To 

window or to the word that is highlighted in the Suggestions window. 
6 Suggestions automatically provides a list of alternatives to the current word. 
7 Edit Dictionary opens the Personal Dictionary. In the personal dictionary, you 

can add, modify, or delete entries. 
8 Cancel exits the Spelling Checker, but does not cancel any previous spelling 

changes made with the Spelling Checker. 

FORMATING CHARACTERS 

Formatting characters 

You can format individual characters to make words display differently, rather than 
affecting a whole paragraph. You can format individual characters by changing 
character styles or character size. 

To apply a character style: 

1 Select the character: 
2 From the Style menu, choose a style, colour, or size. You can also select a 

style, colour, or size by clicking one of the tool bar buttons. 

Physical character styles include the following standard HTML styles: 

The Bold, Italic, and Fixed Width Font styles can be quickly accessed by these toolbar 
buttons: 

Visual Page also supports these Netscape extensions to standard HTML character 
styles: 
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How these styles will appear depends on each browser's default settings. 

Changing character size 

The size of text in a Web page is relative to the default size setting for each browser. 
This is why the font .sizcs in the Size menu item (on the Style menu) are relative 
numbers 1 through 7, instead of the point sizes you see in a word processor, such as 
12 or 14. 
Visual Page uses the middle font size (number 4) as the "normal" font size. This is the 
browser's default display font. The other numbers signify either a smaller or larger 
font than the browser default, with 1 being the smallest font size and 7 the largest font 
size. 

To change the size of a character: 

1 Click Decrease Font Size or Increase Font Size on the toolbar. You can also 
choose Size from the Style menu, and then choose a number. 

A checkrnark displays next to the selected size. 

Working with fonts 

Visual Page allows you to use the fonts that are installed on your system to enhance 
the look of your Web pages. However, not all fonts are cross-platform compatible, 
and may not display correctly on other platforms. 
You can work with fonts in three ways in Visual Page by: 

Changing fonts 

You can change the font of selected text in your Web page to any other available font. 

To change a font: 

1. Highlight the text in your page that you want to change. 
2. Click on the Font pull-down menu. 

The list of available fonts appears. 
3. Select the new font that you want to apply. 

The font of the highlighted text changes. 
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Creating font groups 

Font groups are groups of fonts that usually have some common characteristic to 
preserve the original design of the Web page. Font groups allow the Web browser to 
substitute fonts from a group of assigned fonts when one or more fonts are not 
available on the client machine. When no font in a group is available on the client 
machine, the Web browser uses default fonts available on the client machine. 

With Visual Page you can create and assign font groups that make your pages look 
their best across different platforms and browsers. 

To create a font group: 

1. From the Font pull-down menu, select Font Groups. 
The Font Groups window opens with the names of default font groups. 

2. Click a blank cell in the Group Name column and enter a name for the new 
font group. 

3. Click the Font Names cell and enter font names separated by a comma. 
4. Click the OK button when you are finished entering font names. 

The font group is added to the Font pull-down menu. 
You can also assign a font group on the fly. 

Assigning font groups 

You can assign font groups in your Web page to allow the Web browser on the client 
machine to substitute fonts when the original font is not available. 

To assign a font group: 

1 Highlight the text to which you want to apply a font group. 
2 From the Font pull-down menu, select a font group. 

The selected font group name appears in the pull-down menu and is applied to the 
highlighted text. 
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WORKING WITH PARAGRAPHS 

Generating paragraphs and line breaks 

Paragraphs and line breaks generate different effects in the display of your Web page. 

Use a line break instead of a standard new paragraph if you want to create a space 
between lines without applying the previous paragraph's formatting. You can also use 
multiple line breaks to display multiple lines without text, However, a paragraph 
marker cannot generate multiple empty lines in a Web browser because HTML 
specifications allow only one empty paragraph line. 

To generate a new paragraph: 

1 Place the insertion point where you want the new paragraph to start. 
2 Press the Return key. 

Your cursor goes to a new line and Visual Page generates a paragraph tag in 
the HTML source. 

To create a line break: 

1 Click where you want the new paragraph to start. 
2 Press Shift-Return. 

Visual Page generates a line break (<BR>) tag in the HTML source. 

Aligning and indenting paragraphs 

You can make paragraphs line up against the left margin, the right margin, or the 
centre of the Web page by setting paragraph alignment. You can also format by 
indenting paragraphs. 

To align a paragraph: 

1 Click anywhere within the paragraph. 
2 Click on one of these three alignment tool bar buttons: . The choices are left 

aligned, centre-aligned, and right aligned, respectively. You can also choose, 
from the Format menu, Align Left, Align Right or Align Centre. 
The paragraph aligns according to the alignment option you choose. 
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To indent a paragraph: 

1 Click anywhere within the paragraph. 
2 Click on one of these two indent paragraph tool bar buttons: . The choices are 

Decrease Indent and Increase Indent , respectively. You may also choose 
Format > Increase Indent or Format > Decrease Indent. 
The paragraph indent changes. 

Formatting paragraphs 

Apply paragraph formats to make sections of text display differently, such as 
~eadings, quotes, and mono-spaced (preformatted) text. Visual Page supports these 
paragraph formats: 

Normal 
Headings 
Pre formatted 
Address 

To apply a format to a paragraph: 

1 Click anywhere in a paragraph. 
2 Choose a format from the pop-up menu on the toolbar, or from the Format 
menu. 

Visual Page formats the paragraph accordingly. 

Normal paragraph style 

Normal text is the default style, which is applied when you begin a new paragraph on 
a blank page. (The paragraph you are reading now is formatted with the Normal tag.) 
The text appears flush left in the page window and is displayed in the Visual Page 
default font. 
Use the Normal style for most text in a Web page. 

Heading paragraph style 

Heading tags are used to make headlines or titles distinct from the rest of the text in a 
page. In general, headings are larger than the Normal style, and are in a bold typeface. 
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Heading 1 
Heading 2 
Heading 3 
Heading 4 

Heading 5 

Heading6 

You may also manually specify the font size of a text block instead of using the 
Heading style. 
The heading types supported by Visual Page are: 

Preformatted paragraph style 

uses multiple spaces and tabs, such as the formatting found in code segments. 

Preformatted paragraphs are displayed in moonscape fonts, such as Courier. You can 
see an example of a preformatted paragraph in the following HTML code sample: 

Address paragraph style 

Web page authors typically apply the address style to a paragraph containing a 
signature address. An example of how it is used is shown below: 
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Send comments to the author: 

webmaster@symantec.itools.com 

Choosing to include an address is a matter of style. When you include an address, 
remember to make it an email link. 

CREATING LISTS 

Creating bulleted lists 

Bulleted lists are useful when you want to make some information easy to see. Visual 
Page supports bulleted lists and indented bulleted lists. 

To create a bulleted list: 

1 Select the text you want to change to bulleted list style. 
2 From the Format Paragraph drop-down list on the toolbar, select Bullet List. 

You can also select Format> List> Bullet. 
Visual Page indents the text and places a bullet character to the left of the text 

in the paragraph. 
3 You can apply indentation to the bulleted list by using the Increase Indent 
toolbar button to a bulleted paragraph. 

When you apply added indentation to a bulleted paragraph, the look of the 
bullet changes with the indentation. 

Creating ordered lists 

When you apply any of the ordered list formats to a paragraph, Visual Page indents 
the text and places a number or letter to the left of the paragraph. 

To create an ordered list: 

1 Select the desired text. 
2 Select Format> List and choose the desired type of ordered list. 

To create a numbered list: 

1 Select the desired text. 
2 Click the paragraph tag drop-down list on the toolbar, and select the 
Numbered List tag. 
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Creating term and description lists 

The term and description formats are designed to be used together in lists of 
definitions. The format is similar to what you would find in a Glossary. 
Applying the Term format to a paragraph places the paragraph text flush left at the 
left margin. When you press the return key after applying a Term format to a 
paragraph, Visual Page automatically applies the Description format, then indents the 
text of the paragraph. 

To create a term and description list: 

1 Select the text which you want in the term format. 
2 From the paragraph tag drop-down toolbar button select Term. 

The selected paragraph displays in the Term format. 
3 Select the text, which is to be in the definition format. 
4 From the paragraph tag drop-down toolbar button select Definition. 
5 Repeat steps 1-4 for the remaining terms and definitions. 

USING GRAPHICS AND IMAGE MAPS 

Adding graphics 

You can add graphics to your Web pages by either using drag-and-drop, the Insert 
Image toolbar button, or copy and paste. Graphics must be in BMP, DIB, GIF, or 
JPEG graphic format before you can insert them into a Web page. Visual Page 
automatically converts .bmp and .dib files into interlaced GIF files when you place 
them in your Web page. There is a setting in the Image Preferences for storing the 
new GIF files from these conversions. 
To add a graphic by using drag-and-drop: 

1 Open the Local Site Window, and navigate to the desired graphic's location. 
2 Select desired graphic file, and drag it over to your Web page. 

The image appears full size in your Web page. 

You can also drag and drop graphics from another open Web page, as long as the 
browser supports drag and drop. 
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To add a graphic by using Insert Image: 

1 Place your cursor at the desired location. 
2 Click on the Insert Image button ,or choose Image from the Insert menu. 

A standard Open file dialog box opens. 
3 Navigate to the graphic file you want, and click Open. 

The image displays in your Web page. 

To add a graphic by using copies and paste: 

1 Copy a selected graphic to your clipboard. 
2 Paste it into your Web page. 

The image displays in your Web page. 

Aligning graphics and text 

You can align graphics in a variety of ways. Using graphic alignment settings you can 
also flow text around graphics. You can see a good example of how to format images 
with text in the Visual Page Getting Started tour. 
To align graphics: 

1 Use the Graphic Alignment button on the Visual Page toolbar. You can also 
choose Graphic Alignment from the Settings menu. 

2 Select the graphic alignment you want. 
In general, use the first three options, Top, Bottom, Middle, for small graphics 
that appear in a line of text, like the image in step one. You use the Left and 
Right alignment options when you want to flow a paragraph of text around a 
larger graphic. 

To flow paragraphs of text around graphics: 

1 Select the graphic. 
2 Select Left from either the Graphic Alignment toolbar button, or choose 

Object Alignment from the Format menu. 
3 Insert your cursor to the right of the graphic and enter a paragraph or two of 

text. When the line wraps it returns to the right edge of the graphic, until it 
reaches the bottom of the graphic. 
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Creating transparent graphics 

This feature is useful if your Web page has a coloured background, which is obscured 
in part by an opaque graphic image. In this case, you could use Visual Page to make 
the image transparent so the background colour would show through. Only GIF files 
can be made transparent. 

To make your image transparent: 

Open the graphic file. For more information, see Opening a graphic image file. 
The graphic displays in the Visual Page's graphic editor. 

2 Click the transparency toolbar button on the Image Tools Toolbar. 
3 Click any colour in the image and that colour is rendered transparent. 

When you put the altered graphic in a Web page, you see the Web page's 
background through the image. 

2 To revert a transparent graphic and thus remove the transparent quality, click 
the Remove Transparency toolbar button on the Image Tools Toolbar. 

Setting graphic image properties 

Visual Page supports a range of attributes that are contained within any supported 
graphic. These attributes control the height, width, function, alternate text, and 
spacing around a graphic. 

To set a graphic image's properties: 

1 Make sure that you're in Edit mode. 
For information about how to switch to Edit mode, see Previewing your work. 

2 Select a graphic in a Web page. 
3 From the Edit menu, select Properties, then choose Image Properties. 
4 Use the options in the Image Properties dialog box to set the graphic' s 

attributes. These attributes are described in the table below. 
5 Click OK. Your graphic's settings are adjusted accordingly. 
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Attribute 
Image 
Width 

Height 
Original width 
Original Height 
Horizontal 

Vertical 

Border 

Image 

Has server map 

Submit form button 

Alternative text 

Button name 

Creating image maps 

Description 
The location and filename of the image file. 
The display width of the image, in pixels. Visual Page supports 
image scaling (changing an image's height and width). The 
width and height indicated in the Image Setting dialog box are 
the dimensions of the image as scaled in the HTML file. The 
actual dimensions of the image are indicated in the Original 
Width and Original Height fields, as described below. 
The display height of the image, in pixels. 
The width of the source images, in pixels. 
The height of the source image, in pixels. 
The blank space to the left and right of the image, in pixels. 
The default setting is zero. 
The blank space to the top and bottom of the image, in pixels. 
The default setting is zero. 
The width of the border around an image, in pixels. An image 
border is black and is similar to a frame around a painting. The 
default setting is zero, which indicates no border. 
Select this option if the graphic file functions only as an image. 
This is the default function for graphic files. 
Check this box if the graphic file acts as a server-side image 
map. 
Select this option if the graphic file acts as submit button for a 
form. 
If you type in text here, it displays in a user's browser if the 
image doesn't load properly, or if it can't be displayed by a 
user's browser. Note: The alternative text option is not for 
graphic files that function as a form submit button. 
(For buttons only) The name of the button. This is NOT the 
same as the name of the button's source file. A CGI script uses 
this name as an ID. 

Client-side image maps store the co-ordinates that define the linked areas of an image. 
These image maps are inserted directly into the HTML file. As such, the image map is 
downloaded to and referenced entirely from the user's machine (hence the name 
client-side). Visual Page creates these Image maps for you as you use drawing tools to 
outline and link areas of an image. 
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To create a client-side image map: 

1 Make sure that you're in Edit mode. For information about how to switch to 
Edit mode, see Previewing your work. 

2 Insert a graphic by clicking the Insert Graphics tool bar button. For information 
on inserting graphics, see Adding graphics. 

3 Right-click on the graphic and select Local Map Tools or select View > 
Toolbars > Image Tools from the menus. 

4 The Image Tools toolbar displays. 
5 Create the clickable areas of the image by doing the following: 

Click the rectangle, circle, or polygon Hotspot buttons on the toolbar. 
Click and drag on the graphic file to create a hotspot area. 
To end creating a polygon hotspot, double-click. To end creating a circle or 
rectangle hotspot, release the mouse button. 

6 Create the URL for each of the clickable areas. 

You can do this by either dragging a file or anchor icon from the Local Site window 
onto the selected link area, typing the link address into the Link field at the bottom of 
the main edit window, or right-clicking on the desired link location to open the Link 
To dialog box. You may also double-click on the hotspot to open the Link To dialog 
box. 

To move overlapping hotspots: 

1 Select a hotspot you want to move forwards or backwards. 
2 Click the Front-to-back Order button on the Image Tools toolbar. 
3 Choose Move to Front, Move Forward, Move to Back, or Move Backwards. 

The hotspot will change position. 

To delete hotspot areas: 

Select the hotspot area, and press Delete. 
To save your client-side image map: 
Select File> Save or press Ctrl+ S. 
To make the shapes easier to see, specify the colour of these areas by choosing the 
desired colour from the colour menu button. 
You may also use the Zoom buttons to adjust the graphic to the optimal size for 
outlining links. 
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Setting Images preferences 

Use the Images tab of the Preferences dialog box to set the Visual Page preferences 
described below: If you want to restore these preferences to the default settings, click 
Use Defaults. If you want to change back to the settings that were in place before you 
opened this dialog box, click Revert. 

To set images preferences: 

1 From the Edit menu, chooses Preferences. 
The Preferences dialog box appears. 

2 Click the Images tab. 
3 Use the dialog box to select the Images preference options you want. The 

preferences are listed below. 
4 When you're finished setting preferences, click OK. 

Converted Images Visual Page automatically converts .bmp and .dib files into 
interlaced GIF files. The following options tell Visual Page 
where to place the new GIF files.n Always store the new GIF 
file in same folder as the source documentn Use this image 
folder 

Default Image Map Server Format Visual Page supports server-side image 
maps if you need to use them. The two Server-Side image map 
formats are either CERN or NSCA. 

Setting Image properties 

By using the Image properties dialog box you can: 

1 Resize your image -this is handy if you have an image you want to use more 
than once in your Web site and want to optimize its size for the different 
locations 

2 Adjust the space around an image - this adds a fixed number of pixels of space 
horizontally or vertically around the image. Or, you could opt to create a 
border of space around the whole image. You might want to add space around 
an object when it is embedded in some text or has text flowing around it 

3 Change the function of your image- besides functioning as inert object, images 
can be set to work with an image map, so links can be embedded in the image, 
or as a Submit button which you would provide on a Web page form to 
transmit data in response to a user's click 

3 Alternative text - it's a god idea to provide a short caption which browsers that 
don't display graphics will display instead of the graphic 

- 69 - 



KEAR EAST UKIVERSTY 
COMPUTER ENQINEER/NQ 

1988 

Creating a background 

You can create a coloured or tiled background for your Web page. 
To create a coloured background: 

1 In an open Web page document, click on the Page Properties toolbar button. 
2 Choose a colour from the Background colour well. If you want the 
background set according to each browser's default settings, select Default. 

Using a graphic file to tile your Web page background: 

1 In an open Web page document, click on the Page Properties toolbar button. 
2 Click the Background Image checkbox. 

An Open File dialog box appears. 
3 Navigate to the graphic file you're going to use, then click Open. 

A representation of the tiled graphic appears. 
4 Check the appearance of the tile on your Web page by clicking on the Apply 

button. A graphic may look interesting by itself, but may not be appropriate 
for use as a tiled background. 

To remove a background image: 
Uncheck the Background Image checkbox. 

Adding horizontal lines 

Horizontal lines can be useful layout tools, which can be used to break up a long Web 
page. However, they should be used sparingly or your Web page will appear to be 
choppy. Horizontal lines are easy to add in Visual Page and you may even play with 
their appearance by setting their properties. 

To add a horizontal lines: 

1 Place your cursor where you want the line to be inserted. 
2 Click the Insert Horizontal Line toolbar button. 

To change the properties of a horizontal line: 

1 Select a horizontal line by clicking directly on it.. 
2 Choose Edit > Properties > Line Properties ( or press F 4 ). 

The Line Properties dialog box displays. 
3 Set the shading, size, and alignment using the dialog box. 
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CREATING LINKS AND ANCHORS 

Creating links and anchors 

Hypertext links, also known as links, are one of the most important parts of a Web 
page. Links allow you to connect Web pages together. 

The following topics tell you more about creating and using links in your Web pages: 
Creating links with the Create Link dialog box 
Creating links with the Link Toolbar 
Creating links with the Site Window 
Copying an existing link 
Creating email links 
Creating and linking anchors 
Tes ting links 
Creating image maps . 

Creating links with the Create Link dialog box 

You can create a link to a selected object by using the Create Link dialog box. Using 
this dialog box, you can either enter the URL yourself or browse to locate the file 
you're linking to so Visual Page will generate the URL. 

To create a link with the Create Link dialog box: 

1 Select the object to be linked. 
2 Click the Hyperlink button in the Insert toolbar. The Link dialog box displays. 
3 Determine the file to be linked by either typing in the filename or URL of the 

file, or by clicking Browse and navigating to the file you want. 
Your link is created. 

Creating links with the Link Toolbar 

The Link Toolbar displays at the bottom of the Visual Page window. It consists of a 
label and a text field. 
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To create a link using the Link Toolbar: 

1 Select the object to be linked. 
2 At the bottom of the Edit window, select the Link to field in the Link toolbar. 

If you do not see the Link to field at the bottom of the Edit window, select 
Toolbars > Link to make the link field display. 

3 Type in the filename or URL in the Link to edit box. 
4 Pressing Return and your link is created. 

Creating links with the Local Site Window 

You can use the Local Site window to drag-and-drop files on selected objects in your 
Web page to create a link. 

To create a link using the Local Site window: 

1 Open a Local Site window for your current project. 
For more information see Opening a Local Site window. 

2 Select the text or graphic image on your Web page that you want to link. 
3 Drag the file or anchor you want to link to from the Local Site window and 

drop it on the selected object. 

Copying an existing link 

If you want multiple links to the same place, such as to a home page, you can create 
the link once and copy and paste the rest of the links. 

To copy an existing link: 

1 Select the link you wish to copy. 
2 From the Edit menu, choose Copy (or press Control-C). 
3 Click where you want the link to be copied to. 
4 From the Edit menu, choose Paste (or press Control-V). 

Creating email links 

When an email link is clicked on, the browser opens up a pre-addressed email 
message window. 
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To create an email link: 

1 Create the link text that will display on a Web page. For example: 
user@company.com 

2 Highlight the link text. 
3 Click on the Link to: field and enter the text in the following format: 

mailto:user@company .com 
4 Replace user with the email address of the person being emailed, and 

company .com with there Internet address. 

Creating and linking anchors 

Anchors are used to mark specific locations within a document. Once an anchor is 
placed in a location, you can create a link to that spot. 

To add an anchor to a Web page: 

1 Click in your Web page where you want to put the anchor. 
2 Select on the Insert Anchor button in the Insert toolbar or select Insert > 

Anchor. 
The Anchor Properties dialog box displays. 

3 Name the anchor, and click OK. 
An anchor icon appears in your text. 

4 Select the object to be linked to the anchor. 
5 Click Create Link button in the Insert toolbar or right Click and select Link to. 

The Link to dialog box appears. 
6 Select the anchor from the drop down list box and click OK. 

The link to the anchor is displayed next to the object. 

Testing links 

You should test your links periodically to make sure they work. It's easy to break links 
when you're constructing Web pages. Since links are really URLs which record the 
location of a file or anchor, you can break a link by inadvertently changing the name 
of a file or of the folders in which the file resides. 
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To test links in your Web pages, use one of the following methods: 

1 In Edit Mode, hold down the Control key while clicking over the link. This 
opens the linked file. 

2 From the Edit menu, choose Preview in Browser. Your Visual Page document 
opens in the Web page browser which resides on your hard disk. You can then 
browse your document as you would any Web page. 

3 From the Edit menu, choose Go To Preview Mode. You can browse and click 
while still within Visual Page. 

USING FRAMES 

Creating frames 

Frames divide the parts of a Web page into two or more independent parts (frames), 
each displaying a separate HTML file. 
To create a Web page that includes frames: 

1 Choose File> New Frame Set or press Ctrl +Shift+ N. 
Visual Page displays a frame file with two frames of equal size. 

2 You may directly add the text, HTML tags, graphics, and plug-ins to each 
frame, or you may open an existing Web page file in a frame. For more 
information, see Setting the frame source. 

3 Save your Web page in a folder dedicated to your collection of Web pages. 
For more information, see Saving a Web page with frames. 

Additional Frame Set functions include: 

Opening a frame in a new window 
Setting a frame's attributes 
Setting the frame target 
Resizing a frame 
Removing a frame 
Splitting frames 
Editing the No Frames settings 

Editing the No Frames setting 

The No Frames window lets you specify what content will display when a user's 
browser doesn't support frames. 
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To use the No Frames window: 

1 Open the main frame file. 
2 Choose Frame > No Frames Page. 

The No Frames page displays. 
3 Enter or edit the content of the page. 
4 Close the No Frames page. 

Opening a frame in a new window 

If you have many Web pages which are accessed through the same Web page with 
frames you may want to navigate your Web site in Preview mode. When you see a 
displayed file that needs editing, opening a frame into a separate window makes it 
easier to edit the Web page. 

To open a frame file in a new window: 

1 Open the main frame file. 
2 Select the frame to be opened in a new window. 
3 Choose Frame> Open in New Window. 
The frame file opens in a new window. 

Removing a frame 

If you add too many frames to your Web page you can use the following procedure to 
remove the selected frame. 

To remove a frame: 

1 Open the main frame file. 
2 Select the frame file to be removed. 
3 Choose Frame > Remove Frame. 

Resizing a frame 

Resizing a frame can be done visually on the Web page by dragging frame borders or 
via the Frame Properties dialog box. 
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To resize a frame: 

1 Use the resize bar to resize the frame manually. You can also choose Edit> 
Properties > Show Frame Properties, and enter the desired width in the Width 
field. 

Setting the frame source 

A Web page with frames, also known as a frame set, can display multiple Web pages 
by having a different Web page assigned to each frame. You can set a frame to 
display a particular Web page by using the Set Frame Source menu item to assign a 
particular Web page HTML file to the selected frame. 

To set the source file for a frame: 

1 Make sure a frame is selected in an open Web page. 
2 Select Frame > Set Frame Source. 

A standard Open file dialog box displays. 
3 Navigate to and select the HTML files you want the selected frame to display. 
4 Click open. 

A Visual Page Frame Save dialog box displays. 
5 Save the changes to the frame. 

If you have not given the frame a name, a Save As dialog box displays. 
6 Enter a name for the frame and save it. 

Visual Page displays the Web page in the selected frame. 

Saving a Web page with frames 

A frame set, or Web page with frames, has more than one HTML Web page file 
associated with it. The frame set file contains information about the Web page that 
contains the frames. And, each frame displays its own separate HTML file. So, when 
you save a frame set you probably will be prompted to name more than one Web page 
file. Visual Page's default filename extension is .html. You can change the default 
filename extension in the Preferences dialog box. 

To save a Web page frame set: 

1 From the File menu, chooses Save Frame Set. 
Or, if you want to save a copy of a frame set file with a different name, choose 
Save Frame Set As. 

2 In the Save or Save As dialog box, navigate to the destination folder for the 
frame set and select it. 

3 Enter a filename with a .html or .html extension. 
4 Click the Save button. 

- 76 - 



1988 

NEAR EAST tlNIVERSTY 
COMPUTER lNQINEER/NQ 

If you made changes to any of the frames in your frame set, the Save Frame or 
Save Frame As dialog box displays. 

5 If asked, enter a name for the frame file, and click Save. 
If you made changes to other frames, another Save Frame or Save Frame As 
dialog box displays. 

6 Enter names and click Save until all the changed frame files are saved. 

Setting a frame's attributes 
<See Also> 

Frames have a set of properties you can set. Most of these can be changed as you 
visually edit the page. The frame properties are described below. 

To edit a frame's properties: 

1 Choose Edit> Properties > Show Frame Properties. 
2 The Frame Properties dialog displays. 
3 Use the options in the Frame Properties dialog box to set the frame's 

attributes. 
These attributes are described in the table below. 

4 Close the Frame Properties dialog. 

Attribute 
Source 
Frame titles 

Frame width 

Frameset height 

Margin width 
Margin height 
Show scrollbar 

Resizable frame 

Definition 
The HTML source file for a frame. 
The frame's name. This is NOT the same as the name of the 
source file. The frameset file (the file that contains the frames 
within a frame set) uses this name as an ID. 
The width of the selected frames, either as a percentage of the 
total frame set, or in pixels. 
The height of the frame set, either as a percentage of the total 
frame set, or in pixels. 
The width of the selected frame's margin, in pixels. 

The height of the selected frame's margin, in pixels. 
The settings for the frames scroll bars. Possible choices are 
Yes, No, and Auto. The default is Auto, which makes the scroll 
bars appear only when the frame extends beyond the length of 
the active window. 
Indicates whether or not the selected frame resizes along with 
the user's browser. The default is checked, which indicates that 
the selected frame will resize 
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Setting Frame properties 

Use the Frame properties to set the properties which pertain to a selected frame of a 
frame set. Use the Frame properties dialog box to check, assign, or change these 
values. 

To set frame properties: 

1 Select the frame whose properties you are setting by clicking once anywhere 
in the frame. 
A heavy black border outlines the frame. 

2 Choose Edit> Properties > Show Frame Properties. 
The Frame Properties dialog box displays. 

3 Set the properties as they are described below. 

The frame property settings: include the following: 

Source Name of the HTML file which you want to display in this 
frame, for instance, HomeTOC.html is an appropriate value. 
Title for the frame, otherwise Visual Page uses the random 
number shown as the default in this field. 
Width of the margin. 
Height of the margin. 
This only applies if there are frames below other frames in the 
frame set. 
Specifies the thickness of the frameset border. Set to O for 
borderless frames. Leave it empty to use the default border 
thickness. 
Defaults to automatically showing scrollbars when they're 
needed. 
Checked by default, if you don't want people to change the size 
of a frame, uncheck it. 

Frame title 

Margin width 
Margin height 
Frameset height 

Frameset Border 

Show scrollbars 

Resizable frame 

Setting the base target for a frame 

Visual Page allows you to select a base target for all the links in a frame. An example 
of using a base target is to direct all the hypertext links in a left-hand frame to appear 
in the neighbouring right-hand frame. 
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To set a base target for the links in a frame: 

1 Open a frame set, and make sure the frames are already named and saved. 
2 Make sure that you're in Edit mode. 

For information about how to switch to Edit mode, see Previewing your work. 
3 Click on the frame you are setting as a base target. 
4 Choose Edit > Properties > Page. 
5 Click the Select Base Target button. The Base Target dialog displays. 
6 Click a frame in the reproduction of your frame set. Set a base target for that 

frame by selecting one of the Base Target options. 
The Base Target options are described below. 

7 Click OK to set the base target for the selected frame. 

Tip: To set the base target for additional frames in your frame set, repeat steps 6 and 
7 for each frame. 

Base Target option 
Default 

New window 
Same frame 

Same window 

Parent window 

Splitting frames 

Description 
Makes the linked file display in the same frame as the current 
frame file. This is the default setting. How the default setting 
performs depends on each browser's configuration. 
Makes the linked file display in a new, untitled window. 
Makes the linked file display in the same frame as the current 
frame file. 
Makes the linked file display in the same window as the current 
frame file. 
Makes the linked file display in the parent window of the 
current frame file. The parent window is the window that was 
active, then a link opened which caused the current frame file 
to display. 

Visual Page lets you add frames by splitting existing frames into two equal parts, 
either horizontally or vertically. 

To split a frame: 

1 Open the main frame file. 
2 Select the frame to be split. 
3 Choose Frame > Split Frame Vertically or Frame > Split Frame Horizontally. 

The frame is split. 
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CREATING TABLES 

Creating tables 

Tables can hold all kinds of Web page elements and are useful in formatting and page 
layout tasks. You can easily create tables in Visual Page. 
To create a table in a Web page: 

1 Place the cursor where you want the table to display. 
2 Click the Insert Table toolbar button on the Insert Toolbar or choose Insert> 

Table > Table. 
The Table Settings dialog box displays. 

3 Set the number of rows and columns for your table. 
4 Click OK. 

The new table displays. 

You can also perform the following tasks: 
Inserting rows 
Inserting columns 
Deleting rows 
Deleting columns 
Changing multiple cells 
Resizing rows, columns and tables 
Spanning rows and columns 
Adding colour to tables 

For information on setting the attributes of a table, see Table settings. 

Inserting rows 

You can have Visual Page insert a new row either before or after the one in which you 
placed the insertion point. 

To insert a row after the current row: 

1 Place the cursor where you want the row to be inserted. 
2 Choose Insert > Table > Row. 

The row is inserted. 
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To insert a row before the current row: 

* Choose Insert > Table > Row Before. The row is inserted below the current 
row. 

Inserting columns 

Visual Page allows you to insert a column to the right or left of the column in which 
you placed the insertion point. 

To insert a column to the right of the current column: 

1 Place the cursor where you want the column to be inserted. 
2 Choose Insert> Table> Column. 

The column is inserted. 

To insert a column to the left of the current column: 

* Click Insert > Table > Column Before. A column is inserted to the left of the 
current column. 

Deleting rows 

In Visual Page you can designate a row to be deleted. 

To delete a row or rows: 

1 Select a row or set of rows to be deleted. 
2 Choose Insert> Table> Delete Row 

The row(s) are deleted. 

Deleting columns 

Visual Page allows you to delete multiple columns. 

To delete more than one column: 

1 Select a column or set of columns to be deleted. 
2 Choose Insert> Table > Delete Column 

The column(s) are deleted. 
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Changing multiple cells 

Visual Page allows selection of multiple adjacent cells. Any selected set of cells may 
be formatted by applying the following: 

Paragraph formatting 
Paragraph alignment 
Character formatting 

Resizing rows, columns, and tables 

You can customise tables by changing the size of rows, columns, or the table. 
To resize a row or column: 

1 Place the pointer over the border of the row or column you want to resize. 
The pointer changes to a resizing cursor. 

2 Click on the row or column's border and drag the mouse until the row or 
column is the size you want. 

3 Release the mouse button. 
The row or column displays at the new size. 

To resize a table: 

1 Select the table to be resized. 
2 Click on the resizing handle (a square box) at the bottom right comer of the 

table and drag the mouse until the table is the size you want. 
3 Release the mouse button. 

The table displays at the new size. 

Spanning rows and columns 

Sometimes you want a cell in a table to span across multiple rows or columns. 
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To set a cell to span across multiple rows and/or columns: 

1 Click on the cell that you want to enlarge. 
2 Choose Properties> Table Properties or press F4. 

The Table Properties dialog displays. 
3 Click on the Cells tab. 
4 Enter the number of columns that you want the cell to span in the Span across 

columns field. 
5 Enter the number of rows that you want the cell to span in the Span down rows 

field. 
6 The cell now spans across the specified number of rows and columns. An 

example of a table with a spanned cell is shown below: 

Adding colour to tables 

You can use Visual Page to set the background colour of a cell or an entire table. 

To change a cell's background colour: 

1 Select one or more cells. 
2 Choose Properties> Table Properties or press F4. 

The Table Properties dialog displays. 
3 Click the Cells tab. 
4 Select the colour you want from the Cell background colour palette. 

If you want to create a custom colour, click Custom. 

To change a table's background colour: 

1 Select a table. 
2 Choose Properties> Table Properties or press F4. 

The Table Properties dialog displays. 
3 Click the Table tab. 
4 Select the colour you want from the Background colour palette. 

If you want to create a custom colour, click Custom. 
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Table Settings dialog box 

This dialog box displays when you insert a table. 

Entire table 
number of rows 
number of columns 
space around text 
space between cells 
table width 
table height 
border width 
caption placement 
background colour 
For more information about table properties, see Setting Table properties and Setting 
Cell properties. 
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Harvester of Sorrow 

(Hetfield/Ulrich) 

My Life Suffocates 
Planting Seeds of Hate 
I've Loved, Turned to Hate 
Trapped Far Beyond My Fate 
I Give 
You Take 
This Life That I Forsake 
Been Cheated of My Youth 
You Turned this Lie to Truth 

Anger 
Misery 
You'll Suffer unto Me 

Harvester of Sorrow 
Language of the Mad 
Harvester of Sorrow 

Pure Black Looking Clear 
My Work Is Done Soon Here 
Try Getting Back to Me 
Get Back Which Used to Be 
Drink up 
Shoot in 
Let the Beatings Begin 
Distributor of Pain 
Your Loss Becomes My Gain 

Anger 
Misery 
You'll Suffer unto Me 

Harvester of Sorrow 
Language of the Mad 
Harvester of Sorrow 

All Have Said Their Prayers 
Invade Their Nightmares 
See into My Eyes 
You'll Find Where Murder Lies 
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Harvester of Sorrow 
Language of the Mad 
Harvester of Sorrow 
Language of the Mad 
Harvester of Sorrow 
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UNTIL IT SLEEP 
(Hetfield , Ulrich) 

Where do I take this pain of mine 
I run, but it stays right my side 

So tear me open, pour me out 
There's things inside that scream and shout 
And the pain still hates me 
So hold me, until it sleeps 

Just like the curse, just like the stray 
You feed it once, and now it stays 

So tear me open, but beware 
There's things inside without a care 
And the dirt still stains me 
So wash me, until I'm clean 

*It grips you, so hold me 
It stains you, so hold me 
It hates you, so hold me 
It holds you, so hold me 

Until it sleeps** 

So tell me why you've choosen me 
Don't want your grip, don't want your greed 

I'll tear me open, make you gone 
No more can you hurt anyone 
And the fear still shakes me 
So hold me, until it sleeps 

*--** Repeat 

I don't want it 

So tear me open, but beware 
The things inside without a care 
And the dirt still stains me 
So wash me, 'till I'm clean ... 

I'll tear me open, make you gone 
No longer will you hurt anyone 

Tuesday, June 02, 1998 0:34 PM 
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And the fear still shapes me 
So hold me, until it sleeps ... 

Until it sleeps ... 
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MAMA SAID 
(Hetfield, Ulrich) 

Mama she has taught me well 
Told me when I was young 
Son, your life's an open book 
Don't close it fore it's done 
The brigtest flame burns quickest 
Is what I heard they say 
A son's heart's owned to mother 
But I must find my way 

*Let my heart go 
Let your son grow 
Mama let your heart go 
Or let this heart be still 

Rebel my new last name 
Wild blood in my veins 
Apron strings around my neck 
The mark that still remains 
Left home at an early age 
Of what I heard was wrong 
I never asked forgiveness 
But what I said is done 

* Repeat 

**Never I ask you 
But never I gave 
But you gave me your emptiness 
I now take to my grave 
Never I ask of you 
But never I gave 
But you gave me your emptiness 
I now take to my grave 
So let this heart be still 

Mama now I'm coming home 
I'm not all you wished of me 
But a mother's love for her son 
Unspoken, Help me be 
I took your love for granted 

Tuesday, June 02, 1998 0:34 PM 
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And all the things you said to me 
I need your arms to welcome me 
But a cold stone's all I see 

* Repeat 

Let my heart go 
Mama let me heart go 
You never let me heart go 
So let this heart be still 

** Repeat 
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CHAPTER C 

LEARNING JAVASCRIPT 

How to take full advantage of JavaScript by moving 
beyond its built-in commands 

Summary 

The power of any programming language depends on the extent to which you can 
modify it for your own needs. The more you are limited to using just the built-in 
commands and processes, the more you are limited in what you can do with that 
language. And the harder it is to write sophisticated programs. Thankfully, JavaScript 
supports user-defined functions, properties, and methods, and uses a simplified object 
model to create them. (3,400 words) 

JavaScript endorses full extensibility by letting you define your own functions. 
This allows you to create routines you can use over and over again. You save time in 
re-using common "components," and by designing your own functions you can extend 
JavaScript's base language to suit your needs. Think of it as "personalized JavaScript." 

Since JavaScript is based on objects, a JavaScript function can easily be turned 
into an object, and a method for that object. So, not only can you create user-defined 
objects to do your bidding, you can create your own objects that behave in exactly the 
way you want. And you can create methods that act upon those objects. While this 
sounds powerful -- and it is -- the process of creating functions, objects, and methods 
is very easy in JavaScript. 

Introducing functions 
Use the function statement to create your own JavaScript function. The bare-bones 

syntax is: 

function name (params) { 
... function stuff .. 

} 

name is the unique name of the function. All function names in a script 
must be unique. 

params is one or more parameter variables you pass to the function. 
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function stuff is the instructions carried out by the function. You can put 
most anything here. 

Notice the { and } brace characters; these define the function block, and 
are absolutely necessary. The braces tell JavaScript where a function begins 
and ends. The parentheses around the parameters also are required. Include 
the parentheses even if the function doesn't use parameters (and many don't). 

Names for your user-defined functions are up to you, just as long as you 
use only alphanumeric characters (the underscore character _ also is 
permitted). Function names must start with a letter character, but can include 
numbers elsewhere in the name. 

I've stuck with the JavaScript style of function name capitalization -- that is, 
initial lower case, then upper-case characters if the function name is 
composed of composite words. For example, myFuncName, yourFuncName, 
or theirFuncName. Function names are case-sensitive; be sure to use the 
same capitalization when you refer to the function elsewhere in the script. 
JavaScript considers myFunc different from Myfunc. 

To differentiate between functions and variables, I prefer to give my 
variables initial upper case characters, such as MyStuff. This immediately 
differentiates it from a function, which would use a the capitalization myStuff. 
Of course, you are free to adopt any capitalization scheme you Wish. 

Defining and using a function 
The best way to describe the how and why of a function is to show a simple one in 

action. Here's a basic function that displays "Hello, JavaScripters!" and is an obvious 
takeoff on the "Hello World!" example you see for new programming languages. 

function basicFunction () { 
alert ("Hello JavaScripters!"); 

} 

This merely defines the function. JavaScript will do nothing with it unless the 
function is referenced someplace else in the script. You have to call the function in 
order to use it. Calling a user-defined function is the same as calling a built-in 
JavaScript function -- you merely provide the name of the function in your script. 
This serves as the function call. When JavaScript encounters the function call, it 
dashes off to complete whatever instructions are in that function. When the function is 
over, JavaScript returns to the point immediately after the function call, and processes 
the remainder of the script. 

To call the function above, just include the text basicFunction() -- note the empty 
parentheses, as they are required. Here's a working example of the Hello JavaScripters 
program. 
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<HTML> 
<HEAD> 
<TITLE>Basic Function Example<fTITLE> 
<SCRIPT LANGUAGE="JavaScript"> 
function basicFunction () { 

alert ("Hello JavaScripters!"); 
} 
basicFunction(); 
</SCRIPT> 
</HEAD> 
<BODY> 
Page has loaded. 
</BODY> 
</HTML> 
The browser processes the contents of the <SCRIPT> tag as the document loads. 

When it encounters the basicFunction() function call, it pauses momentarily to 
process the function, and an alert box appears. Click OK and the remainder of the 
page finishes loading. 

Calling a function with an event handler 
A common way of calling a function is to include a reference to it in a form button 

or hypertext link. Processing a user-defined function when the user clicks a form 
button is perhaps the easiest of all. You use the onClick event handler to tell 
JavaScript that when the user clicks on the button, the function specified should be 
processed. Here's a revised version of the previous example, showing how 
basicFunction is called when the form button is clicked. 

<HTML> 
<HEAD> 
<TITLE>Basic Function Example<fTITLE> 
<SCRIPT LANGUAGE="JavaScript"> 
function basicFunction () { 

alert ("Hello JavaScripters!"); 
} 
</SCRIPT> 
</HEAD> 
<BODY> 
Click to call function. 
<FORM> 
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<INPUT TYPE="button" VALUE="Click" onClick="basicFunction()"> 
</FORM> 
</BODY> 
</HTML> 

Notice the onClick syntax in the <INPUT> tag. The event you want to process on 
a click is a call to basicFunction. This event is surrounded by double quotes. 

Passing a value to a function 
JavaScript functions support passing values -- or parameters -- to them. These 

values can be used for processing within the function. For instance, rather than having 
the alert box say "Hello JavaScripters!" whenever you call it, you can have it say 
anything you like. The text to display can be passed as a parameter to the function. 

To pass a parameter to a function, provide a variable name as the parameter in the 
function definition. You then use that variable name elsewhere in the function. For 
example: 

function basicExample (Text) { 
alert (Text); 

} 

The variable name is Text, and is defined as the parameter for the function. That 
variable is then used as the text to display in the alert box. When calling the function, 
provide the text you want to show as a parameter of the function call: 

basicExample ("This says anything I want"); 

Passing multiple values to a function 
You can pass multiple parameters to a function. As with built-in JavaScript 

functions and methods, separate the parameters with commas: 

multipleParams ("one", "two"); 

function multipleParams (Param1, Param2) { 

When you define a function with multiple parameters, be sure the parameters are 
listed in the same order in the function call. Otherwise, your JavaScript code may 
apply the parameters to the wrong variables, and your function won't work right. 
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Here's a working example sof a function with multiple parameters. It takes two 
parameters: an input string and a number value. The number value indicates how 
many characters on the left of the string you want to display in the alert box. When 
you run the following script, the alert box displays "This is" -- the first seven 
characters of the input string. 

<HTML> 
<HEAD> 
<TITLE>Global Variable Example<fTITLE> 
<SCRIPT LANGUAGE="JavaScript"> 
lefty ("This is a test", 7); 
function lefty (lnString, Num) { 

var OutString=lnString.substring (lnString, Num); 
alert (OutString); 

} 
</SCRIPT> 
</HEAD> 
<BODY> 
</BODY> 
</HTML> 

Returning a value from a function 
The functions described so far don't return a value; that is, they do whatever magic 

you want them to do, then end. No "output" value is provided by the function. In some 
other languages, such return-less functions are called subroutines. However, in 
JavaScript (like in C and C++), "functions are functions" whether or not they return a 
value. 

It's easy to return a value from a function: use the return statement, along with the 
value you wish to return. This is handy when you want your function to chum through 
some data and return the processed result. Take the "lefty" function from above. 
Instead of displaying the chopped-off string, you can return it to the calling function, 
and use the return value any way you want. 

<HTML> 
<HEAD> 
<TITLE>Global Variable Example<fTITLE> 
<SCRIPT LANGUAGE="JavaScript"> 
var Ret = lefty ("This is a test", 7); 
alert (Ret); 
function lefty (lnString, Num) { 
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var OutString=lnString.substring (lnString, Num); 
return (OutString); 

} 
</SCRIPT> 
</HEAD> 
<BODY> 
</BODY> 
</HTML> 

This script does essentially the same one as the previous example, but 
instead of always displaying the chopped-off text, the function merely returns 
the processed value. The return value is captured in a variable, and you are 
free to use that variable in any way you wish. The above shows the Ret 
variable used with an alert box, but you can use it in other ways, too. For 
example, you can write the contents of the Ret variable using the 
document.write method: 

document.write (Ret); 

Defining local variables within functions 
By default all JavaScript variables are declared global for the document that 

created them. That means when you define a variable in a function, it is also "visible" 
to any other portion of the script on that document. For example, in the following 
global variable test, the variable test is visible to the showVar function, even though 
the variable is defined in the loadVar function. 

<HTML> 
<HEAD> 
<TITLE>Global Variable Example</TITLE> 
<SCRIPT LANGUAGE="JavaScript"> 
function showVar () { 

alert (test) 
} 
function loadVar () { 

test= "6" 
} 
loadVar(); 
</SCRIPT> 
</HEAD> 
<BODY> 
Click to call function. 
<FORM> 
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<INPUT TYPE="button" Value="Click" onClick="showVar()"> 
</FORM> 
</BODY> 
</HTML> 

Global variables aren't always what you want. Instead, you want variables that are 
local to the function. These variables exist only as long as JavaScript is processing the 
function. When it exits the function, the variables are lost. In addition, a local variable 
of a given name is treated as a separate entity from a global variable of the same 
name. In this way, you don't have to worry about reuse of variable names. The local 
variable in the function won't have any effect on the global variable used elsewhere in 
the script. 

To declare a local variable, add the var keyword to the beginning of the variable 
name in the function. This tells JavaScript you want to make the variable local to that 
function. As a test, change the loadVar function above to the following, and re-load 
the script. When you click the button, JavaScript tells you the variable doesn't exist. 
This is because test is only local to the loadVar function, and does not exist outside 
the function. 

function loadVar () { 
var test = "6" 

} 

Calling one function from another function 
Code inside a function behaves just like code anywhere else. This means you can 

call one function from inside another function. This allows you to "nest" functions so 
that you can create separate functions, which each perform a specific task, and then 
run them together as a complete process, one right after the other. For example, here's 
a function that calls three other mythical functions, each one returning a string of text 
that has been altered in some way. 

function run () { 
var Ret = changeText ("Change me"); 
alert (Ret); 
document.write (Ret); 

} 
function changeText (Text) { 

Text= makeBold (Text); 
Text= makeltalics (Text); 
Text= makeBig (Text); 
return (Text); 

} 
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function makeBold (lnString) { 
return (lnString.bold()); 

} 
function makeltalics (lnString) { 

return (lnString.italics()); 
} 
function makeBig (lnString) { 

return (lnString.big()); 
} 

Creating objects with user-defined functions 

JavaScript is based on objects: the window is an object, links are objects, forms 
are objects, even Netscape itself (or other browser) is an object. Using objects can 
help make programming easier and more streamlined. You can extend the use of 
objects in JavaScript by making your own. The process uses functions in a slightly 
modified way. In fact, you'll be surprised how easy it is to make your own JavaScript 
objects. 

Making a new object entails two steps: 
Define the object in a user-defined function. 
Use the new keyword to create (or instantiate) the object with a call to the object 

function. 
Here's an example of the world's simplest user-defined JavaScript object: 
II this part creates a new object 
ret = new makeSimpleObject(); 
II this part defines the object 
function makeSimpleObject() {} 
I've called the new object ret; use any valid variable name for the new object (I 

use lower-case letters for variables that contain objects, so it's easier to tell that the 
variable contains an object). 

You can use the same object function to create any number of new objects. For 
instance, these lines create four new and separate objects: eenie, meenie, minie, and 
moe: 

eenie = new makeSimpleObject(); 
meenie = new makeSimpleObject(); 
minie = new makeSimpleObject(); 
moe = new makeSimpleObject(); 

Actually, there is even a shortcut to the above "world's simplest JavaScript 
object." You don't need to define an object function to make a bare-bones object. 
JavaScript supports a generic Object() object, which you can use to make new objects. 
The following does the same as the above, without an explicit object function: 
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eenie = new Object(); 

Defining new properties to already-made objects 

After an object has been created you can assign a value to it. But instead of just 
assigning a value to the object itself, you should define a new property for the object, 
and assign a value to the property. To create a new property and assign a value to it, 
simply write a variable expression like this: 

myobject.property = value; 
myobject is the name of the user-defined object. 
property is the name of the property you want to create. 
value is the value you want to assign. 
Suppose you create an object called "customer" and you want to define three 

properties to it: name, address, and phone. Here's one way to do it: 

customer= new makeSimpleObject(); 
customer.name= "Fred"; 
customer.address= "123 Main Street"; 
customer.phone= "555-1212"; 
function makeSimpleObject() { 

return (this); 
} 
You can verify that you've indeed created a new object and assigned properties to 

the object my adding an alert method to display one of the properties. For example, 
you could put this after the customer.phone line. When you run the script the alert box 
will say "Fred." 

alert (customer.name); 

Defining properties when you create the object 

Another method of defining properties for objects is to include the property names 
in the object function. You can use this technique to simultaneously create a new 
object and define the property values. All it takes is a few more lines of code in the 
object function. 

customer= new makeCustomer("Fred", "123 Main Street", "555-1212"); 
alert (customer.name); 
function makeCustomer(Name, Address, Phone) { 

this.name= Name; 
this.address= Address; 
this.phone= Phone; 

} 
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Note the series of this statements. Each this statement assigns a property to the 
current object, which is the one being created in the makeCustomer object function. 
Three parameters are passed to the object statement: the customer's name, address, 
and phone number. These parameters are used to define the contents of the three 
properties, which are name, address, and phone. 

JavaScript imposes no limitations on the number of properties you can assign to 
an object. To include as customer object, just do this: 

customer= new makeCustomer("Fred" "123 Main Street" "555-1212")· ' ' ' customer.salutation= "Mr."; 
Note that other objects you create with the makeCustomer object function will 

have just the three base properties, but this object for Fred will have an additional 
property for the salutation. Properties added later do not affect other objects created 
with the same object function. 

Creating user-defined methods 
A user-defined method is yet another way of using functions in JavaScript. 

Methods act upon objects -- either objects built into JavaScript, or objects that you've 
created. A method changes or manipulates an object in some way. For instance, 
suppose you want to insert the various contents of the customer object: name, address, 
and phone number. Write the code to insert the object contents, then stuff the code in 
a function. Call the function, using the customer object as a parameter, like so: 

customer= new makeCustomer("Fred", "123 Main Street", "555-1212"); 
displayCustomer ( customer); 
function displayCustomer (cust_obj) { 

Temp= "Name:"+ cust_obj.name + "<BR>"; 
Temp+= "Address: "+ cust_obj.address + "<BR>"; 
Temp+= "Phone: "+ cust_obj.phone + "<BR>"; 
document.write (Temp+ "<BR>"); 

} 

Here's a fully functioning user-defined property example if you'd like to try this 
out. Load the script; JavaScript will display three lines of customer data. (Reload the 
document if you want to run it again.) 

<HTML> 
<HEAD> 
<TITLE>Object Method Example</TITLE> 
<SCRIPT LANGUAGE="JavaScript"> 
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function run () { 
customer= new makeCustomer("Fred", "123 Main Street", "555-1212"); 
displayCustomer (customer); 
} 
function displayCustomer (cust_obj) { 

Temp= "Name: "+ cust_obj.name + "<BR>"; 
Temp+= "Address: "+ cust_obj.address + "<BR>"; 
Temp+= "Phone:"+ cust_obj.phone + "<BR>"; 
document.write (Temp+ "<P>"); 

} 
function makeCustomer(Name, Address, Phone) { 

this.name= Name; 
this.address= Address; 
this.phone= Phone; 

} 
run() 
</SCRIPT> 
</HEAD> 
<BODY> 
</BODY> 
</HTML> 

The other method is to create a method for the customer object. With this 
approach, you call the method as part of the object. This helps in defining special 
method functions that are designed for -- and only for -- certain kinds of objects. This 
process forms one of the foundations of object-oriented programming, where objects 
contain their own unique methods of operation. Here's the same script as above, 
modified so that the customer object contains the displayCustomer method. 

<HTML> 
<HEAD> 
<TITLE>Object Method Example</TITLE> 
<SCRIPT LANGUAGE="JavaScript"> 
function run () { 

customer= new makeCustomer("Fred", "123 Main Street", "555- 
1212"); 

customer.displayCustomer(); 
} 
function displayCustomer () { 

Temp= "Name: "+this.name+ "<BR>"; 
Temp+= "Address: "+this.address+ "<BR>"; 
Temp+= "Phone: "+this.phone+ "<BR>"; 
document.write (Temp + "<P>"); 

} 
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function makeCustomer(Name, Address, Phone) { 
this.name= Name; 
this.address= Address; 
this.phone= Phone; 
this.displayCustomer = displayCustomer; 

} 

run() 

</SCRIPT> 
</HEAD> 
<BODY> 
</BODY> 
</HTML> 

As you can see, to display the customer data, you call the displayCustomer 
method, like so: 

customer.displayCustomer(); 
Notice a few other changes in this version: 
The call to the displayCustomer function no longer uses a parameter. 
The displayCustomer() function no longer uses a parameter. 
The displayCustomer() function uses the "this" keyword to refers to the current 

object. 
When you write your own methods for objects, you'll follow the pattern used in 

the displayCustomer() function. There's no need to pass parameters to the function 
unless you need to. Refer to properties using the "this" keyword." And, add the name 
of the method function in the function that creates the object -- in this case, it's the 
makeCustomer object function. 

Conclusion 

Much of JavaScript's power comes from user-defined functions -- functions you 
make yourself. With your own functions, you create what is in essence your own 
JavaScript commands. And, you use functions to build JavaScript objects and 
methods. Master functions, and you'll go far in mastering JavaScript. 
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Take Advantage of User-Defined Variables 
JavaScript 
Learn how to master variables, the special information­ 
holding areas that are crucial to a programming language 

Summary 

in 

As with all programming languages, JavaScript relies heavily on user-defined 
variables. But unlike many languages -- including Java -- JavaScript's system of 
variables is simplified, so that even users with minimal programming experience 
can immediately use them. JavaScript doesn't impose strict data formats or types 
for its variables, which can greatly simplify programming. However, just because 
JavaScript's variables are easy to use doesn't mean they lack power. 

These special information-holding areas can store numbers, text strings, 
objects, and other data types. Once stored, this information can be used later in 
your program. With a variable, a person's name could be stored and used at some 
point in the script. 

Variables are temporary holders of information. They can hold: 
• Numeric values ("numbers") -- numbers that can be added together. Example: 

2+ 2 results in 4 
• Character strings -- a collection of text, such as "JavaScript" or "My name is 

Mudd" 
• True/false values -- the Boolean true and false 
• Objects -- JavaScript or user-defined objects (JavaScript variables can hold a 

few other kinds of data, but these are by far the most common types) 
(Note: As with most modem programming languages, JavaScript supports array 

variables in addition to the basic scalar variables used to hold the above data types. 
We'll concentrate on single-value variables for this column and devote a separate 
column to arrays.) 

JavaScript variables "belong" to the script document that created them; the 
variables are lost when the document is unloaded. In addition, the contents of a 
variable are erased when you assign a new value to them. Though a variable created 
in one document script is not usually seen by another document script, JavaScript 
does provide ways to share variables between scripts. You do this by referencing the 
name of the document along with the name of the variable. 

Several JavaScript instructions create and store variables, but the basic way to 
accomplish this manually is with the equals(=) assignment operator. The basic syntax 
1s: 

VariableName = value 
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The first argument is the name of the variable. Variable names can be very long, 
but you are restricted in the characters you may use. For more information on valid 
variable names, see the section on Variable name limits. 

The second argument is the contents of the variable. You can put all sorts of stuff 
into a variable, including a number, a string, a math expression (such as 2+2), and 
various other things that we'll get to in a bit. 

Pascal users may be tempted to construct the variable assignment using :=. Be 
aware that this syntax is not supported in JavaScript. 

Following is a more specific rundown of the four most common contents you can 
place in JavaScript variables, including examples. 

Contents placed in JavaScript variables 
Numbers in variables 

A number is one or more digits stored in the computer in such a way that 
JavaScript can perform math calculations with them. JavaScript supports both integers 
and floating-point values. To place a number in a variable, just provide the variable 
name, the equals sign (the variable assignment operator), and the value you want to 
use. For example, the following is what you do to place the number 10 in a variable 
named MyVar: 

MyVar = 10; 
Strings in variables 

A string is one or more text characters arranged in memory in single file. Strings 
can contain numbers (digits), letters, punctuation, or a combination of these elements. 
Math calculations cannot be performed on strings. Strings are assigned to JavaScript 
variables by being enclosed in a set of single or double quotes: 

"I am a string;' 
or 
'I am a string' 

Note that double or single quotes are acceptable; unlike some languages, such as 
Perl, JavaScript makes no distinction between the two forms of quote marks. This 
working example shows how to place a string into a variable: 

MyVar = "This is JavaScript"; 
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Boolean values in variables 

There are two Boolean values: true and false. Some programming languages don't 
have a separate set of Boolean values, and instead use O for false, and 1 or -1 ( or any 
other non-zero value) for true. JavaScript can use these numbers to represent true and 
false but, in addition, reserves the words "true" and "false" to mean Boolean true and 
false. You can think of the Boolean true and false values as being equivalent to on/off 
or yes/no. To assign a Boolean value to a variable, provide just the word true or false, 
without quotes. Here's an example: 

MyVar = true; 

Objects in variables 
Variables can contain objects, including JavaScript objects. There are basically 

two kinds of object variables: 
• Variables that contain built-in browser-related objects -- window, document, 

navigator, and so on -- actually are references to the original object. They are like 
copies, but the copies change if the original changes. In some cases, making a change 
to the object in the variable affects the original JavaScript object. 

• Variables that contain user-defined objects represent the actual object. Make a 
change to the object in the variable, and you change only that object. 

To assign a JavaScript object to a variable, provide the name of the object, as in: 

MyVar = navigator; 
To assign a new copy of a user-defined object to a variable, use the new 

statement, and provide the name of the object function: 

MyVar = new myObject(); 

SUBHEAD Variable name limits 
When it comes to the names you can give variables, JavaScript offers a great deal 

of latitude. JavaScript variables can be almost unlimited in length, although for 
practical reasons you'll probably keep your variable names under 10 or 15 characters. 
Shorter variable names help JavaScript execute the program faster. Keep the 
following in mind when naming your variables: 

• Variable names should consist of letters only -- without spaces. You can use 
numbers as long as the name doesn't start with a digit. For example, MyVarl is 
acceptable, but lMyVar is not. 
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• Don't use punctuation characters in variable names. Exception: the underscore 
character ( _ ). That is, the variable My_ Var is acceptable, but My*Var is not. 
Variables can begin with the underscore character. 

• Variable names are case-sensitive. The variable MyVar is a distinctly different 
variable from my Var, myvar, and other variations. 

Understanding JavaScript's "loose" variable data types 

Unlike some other programming languages, in JavaScript there is no need to 
explicitly define the type of variable you want to create. This JavaScript behavior is 
called "loose data typing," and it differs from C and Java, both of which use strict data 
typing. 

In JavaScript there is no need to differentiate variable types by appending special 
characters to the end of the variable name, such as My Var$ for a string variable (or, 
for that matter, $MyVar for a scalar variable, a la Perl). JavaScript internally decodes 
the variable type based on its content. 

Using the var statement to assign a variable 

JavaScript supports a var statement that can be used to explicitly define a variable. 
The syntax is merely the statement var, a space, and the same variable assignment 
expression detailed above. For instance: 

var MyVar = "This is a variable"; 
You can also use the var statement with the variable name to declare the variable 

but not define a value for it: 

var MyVar; 

In this case, you've defined MyVar in memory but have yet to assign a value to it. 
This technique is often used when setting up global variables -- variables that can be 
freely shared anywhere in your script. For more information about global variables, 
see the section "Understanding the scope of variables", below. 

String length limitations 
JavaScript imposes a limit of 254 characters for each string variable assignment in 

your program. If you go over the 254-character limit, JavaScript responds with a 
"Unterminated string literal" error message. (Note: This is fundamentally a limit of 
JavaScript in Netscape 2.0x; it's a good idea to observe it since not all users have 
adopted Netscape 3.0.) 
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You can create longer strings by "piecing" them together -- as long as each piece 
is 254 characters or less. After assigning a string to each variable, you combine them 
using the + character. This is called "concatenation." The following example shows 
how concatenation works: 

MyVar = "This is the start " + of how you " + " can build strings"; 

Each individual string segment -- defined by text within the quotes -- can be up to 
254 characters. To make a string longer than 254 characters, merely add more 
segments. Another approach is to build strings using the += assignment operator, like 
this: 

MyVar = "This is the start " 
MyVar += "of how you " 
MyVar + = can build strings " 
You can continue to concatenate strings this way as long as your computer has the 

memory for it. But, while JavaScript can hold strings larger than that possible in many 
other programming languages (like Basie's typical 64K), doing so can severely 
degrade the performance of the system. Obviously, you won't create a lot of huge 
string variables. It's just nice to know that, if needed, a JavaScript variable can 
accommodate so much text. 

Understanding the "scope" of variables 

The "scope of a variable" has nothing to do with optics or mouthwash, but rather 
the extent to which a variable is visible to other parts of a JavaScript program. Unless 
you provide explicit instructions to tell JavaScript otherwise, the scope of its variables 
is managed as follows: 

• Variables defined outside a function are available to any function within the 
script, as long as all the variables are definined in the script of the same HTML 
document. These are referred to as global variables. 

• Variables defined inside a function are also global, assuming the var statement 
is not used when first declaring that variable. That is, MyVar = "hello." 

• Variables defined inside a function with the var statement are "local" to that 
function only. These are referred to as local variables. 

• Global variables remain in memory even after a script has stopped execution. 
The variable remains in memory until the document is unloaded. 

Local variables are treated as if they don't exist outside the function where they 
are defined. That way, you can use the same variable name inside a function, and that 
variable won't interfere with the same-named variable elsewhere in the script. 
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Following is an example that demonstrates this. When you click the button, the 
script displays three alert boxes. The following details what happens when you click 
the button: 

• JavaScript calls firstFunction, which assigns a value of 1 to a local variable 
named My Var. The contents of My Var is displayed. 

• JavaScript calls secondFunction, which assigns a value of 2 to a local variable, 
also called My Var. The contents of My Var are displayed. 

• JavaScript returns to firstFunction, where the contents of My Var are again 
displayed. The result is 1, which is the value of My Var local to firstFunction. 

function firstFunction () { var My Var = 1; alert ("firstFunction: " + My Var); 
secondFunction(); alert ("firstFunction: "+ MyVar); } 

function secondFunction () { var MyVar = 2; alert ("secondFunction: "+ MyVar); 
} 

Referencing variables in other loaded documents 

When using frames, it is often necessary to share variables across documents. One 
or more frames may need a variable contained in another frame. By their nature, 
variables (even global ones) are not visible outside the document that created them. 
So, when you want to reference a variable in another document -- and assuming that 
document is loaded into the browser -:0 you need to explicitly reference that variable 
by adding the window name in front of the variable name. Here is syntax: 

winname.varname 

where w i nname is the name of the document, and v a rname is the name of the 
variable. More about document names in a bit. 

You can assign and reference variables using the following technique. For 
example, this sets the MyVar variable in the mydoc window to 1: 

mydoc.MyVar = 1; 
The code below assigns the value of a local MyVar variable in the mydoc 

window. 

VarlnThisDoc = mydoc.MyVar; 

Where do the names for the windows come from? It all depends on how the 
windows are used. 

To use a variable in the main browser window from a window that you created, 
first provide a "link" to the parent window object, using this method: 
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newwindow = window.open ("","NewWindow"); //repeat this for Mac/X 
Netscape 2.0 

newwindow.creator = self; 
Then, in this new window you can refer to any variable in the main window using 

the syntax: 

creator.MyVar; 

To use a variable in a window you've created, refer to it using the object name 
you've provided when you created the window. For instance, you'd use newwindow 
for a window created with the following: 

newwindow = window.open ("","NewWindow"); 

Now refer to that variable using the syntax: 

newwindow.MyVar; 

To use a variable defined in the frameset -- that is, the document containing tag -­ 
refer to it as parent. Here's an example: 

pa rent. My Var; 

To use a variable in another frame document, refer to it using the frame name 
you've provided in the tag. For instance, you'd use 

parent.frame1 .MyVar; 

for a frame created with the following: 

Understanding when variables are lost 
JavaScript variables don't hang around forever. A variable is lost when one of the 

following happens: 
• The document where the variable was assigned is unloaded (you load another 

document to take its place, for example). 
• You reload the document or frameset. 
• You resize the browser window (this causes the document to be reloaded). 
• You use the document.write method to write to a window or frame where 

the variable was assigned. 
Losing variables when a document is reloaded or resized is one of the most 

aggravating JavaScript behaviors. Each time a document is reloaded or resized you 
effectively start over. The same is true of frames. If the user resizes a frame (by 
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dragging the frame border), it causes the browser to reload the page, and thus loses all 
the previous variable contents. 

Most of the time, however, it won't matter if the page is reloaded or resized, as 
your JavaScript code will behave as if the page was just accessed. But it can be a 
problem if you need to set and keep variables as users work themselves through some 
process you've provided on your page. You will need to consider workarounds if 
losing the variable will corrupt your script. There are several methods to accomplish 
this. 

One method, if your page uses frames, is to include a text-box field in one of the 
frames. You can make that frame invisible by enlarging the others to take up all 
available space, or you can push the text box out of the way and make the frame 
unscrollable and non-resizable. That way the user never sees the text box. You then 
use JavaScript to write a value to the text box. The value remains even if the 
document is reloaded or resized. 

Another method is to use a Netscape cookie, which is a semipermanent data 
storage file provided by Netscape. Cookies allow a safe and secure method to store 
data that you want to use later. With a cookie you can store items for the current 
session of Netscape -- or even between sessions. The current session is sufficient for 
the task of remembering a variable so it will last after a resize or a reload. 

Variable shortcuts, tips, and tricks 
When defining and using variables JavaScript supports a number of useful 

shortcuts. Several of the more useful shortcuts are itemized below. 

Declaring multiple variables at once 

You can declare several variables at the same time, all on one line, using commas 
to separate them. Instead of doing this: 

var MyVar, 
var YourVar; 
var TheirVar; 

you can do this: 

var MyVar, YourVar, TheirVar; 
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Assigning multiple variables at once 

If you want to assign the same value to more than one variable at a time, a 
shortcut method is to use the multiple assignment trick. The following assigns 1 to all 
of the variables. 

var MyVar = YourVar = TheirVar = 1; 

Deleting a variable from memory 

JavaScript normally will delete any variables when the page that created them is 
unloaded. However, you can force "early retirement" of variables with this simple 
technique: 

varname = null; 
This is intended to clear the memory the variable was using, though the variable 

will still exist. You might use this technique, for example, if you've created a large 
variable and now want to clear it from memory to avoid any possible out-of-memory 
problems. 

Converting between number and string variables 
To convert a number to a string, add a set of empty quotes in front of it, like this: 

myVar = ""+= MyVar; 

To convert a string to a number, use the parselnt or parseFloat functions, 
depending on the number type (parselnt is used for integers; parseFloat is used for 
numbers with decimal values): 

MyVar = parselnt(Mylnt); 
or 

MyVar = parseFloat(Mylnt); 
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Conclusion 
JavaScript variables are both easy to use and powerful. As with the entire 

language, JavaScript's variables were designed to be exploited by Web designers of 
all levels, including those with little or no programming experience. This design 
makes JavaScript variables easy to approach but does not undermine their power and 
flexibility. As you work with JavaScript and its variables, keep this power and 
flexibility in mind; you can use it to build JavaScript applications as complex and 
sophisticated as you wish. 
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CHAPTER D 

PROGRAMMING WITH HTML 
INDEX.HTM 

<HTML> 

<HEAD> 
<META HTTP-EQUIV="Content-Type" CONTENT="text/html; 
charset=windows-1252 "> 
<META NAME="Generator" CONTENT="Microsoft Word 97"> 
<META NAME="AUTHOR" Content="METIN TASKIN"> 
<META NAME="DESCRIPTION" Content="This about TURKIYE"> 
<META NAME="KEYWORDS" 
Content="turkiye,hotel,akdeniz,antalya,izmir, 
mersin,giresun,ataturk, trabzon, ofo hotel,hilton,prencess, 
kit tur,ormancilar,sheraton"> 
<TITLE> Turkiye</TITLE> 

</HEAD> 

<FRAMESET COLS= "156,638" > 
<FRAME SRC="finl.htm" NAME="Frame274284" RESIZE> 
<FRAME SRC="finr.htm" NAME="Frame274311" RESIZE> 
</FRAMES ET> 

<NO FRAMES> 
<BODY> 
<P> 
</BODY> 

</NO FRAMES> 

</HTML> 

- 107 - 



NEAR EAST UN/f/ERSTY 
COMPUTER lNCINEERINC 

1988 

FINL.HTM 

<HTML> 
<HEAD> 

<META HTTP-EQUIV="Content-Type" CONTENT="text/html; 
charset=iso-8859-1 "> 
<META NAME="GENERATOR" CONTENT="Mozilla/4.02 [en] 
(Win95; I) [Netscape]"> 
<META NAME="AUTHOR" Content="METIN TASKIN"> 
<META NAME="DESCRIPTION" Content="This about 
TURKIYE"> 
<META NAME="KEYWORDS" Content=" turkiye, hotel, akdeniz, 
antalya, izmir, mersin, giresun, ataturk, trabzon, ofo hotel, hilton, 
prencess, kit tur, ormancilar, sheraton"> 

<TITLE> Turkiye</TITLE> 
</HEAD> 

<BODY TEXT="#CCOOOO" BGCOLOR="#CCOOOO" LINK="#CCOOOO" 
VLINK ="#CCOOOO" ALINK ="#CCOOOO" 
BACKGROUND="CDTSBK.jpg"> 
<CENTER><IMG SRC="globe7.gif'' ALT="dunya" BORDER=O 
HEIGHT=88 WIDTH=88 ALIGN=BOTTOM></CENTER> 
<CENTER><IMG SRC="Flagtk.gif'' ALT="Turk Bayragi" BORDER=O 
HEIGHT=71 WIDTH=121></CENTER> 
<CENTER><B><FONT FACE="Arial, Helvetica"><A HREF="turkO.htm" 
target="_top">WELCOME</A></FONT></B></CENTER> 
<CENTER><B><FONT F ACE="Arial, Helvetica"><A HREF="turkO.htm" 
target="_ top"> TO</ A></FONT></B></CENTER> 
<CENTER><B><FONT F ACE="Arial, Helvetica"><A HREF="turkO.htm" 
target="_ top"> TURKEY</ A></FONT></B></CENTER> 
<CENTER>&nbsp;</CENTER> 
<CENTER>&nbsp;</CENTER> 
<CENTER>&nbsp;</CENTER> 
<CENTER>&nbsp;</CENTER> 
<CENTER>&nbsp;</CENTER> 
<CENTER> 
<H2> 
<A HREF="turkO.htm" target="_top"><IMG SRC="docsrigh.gif'' 
ALT="ileri" BORDER=O HEIGHT=30 WIDTH=30></A></H2></CENTER> 

</BODY> 
</HTML> 
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FINR.HTM 

<HTML> 
<HEAD> 

<META HTTP-EQUIV="Content-Type" CONTENT="text/html; 
charset=windows-1252 "> 
<META NAME="Generator" CONTENT="Microsoft Word 
97"><META NAME="AUTHOR" Content="METIN TASKIN"> 
<META NAME="DESCRIPTION" Content="This about 
TURKIYE"> 
<META NAME="KEYWORDS" Content=" turkiye, hotel, akdeniz, 
antalya, izmir, mersin,giresun,ataturk,trabzon, ofo Hotel, hilton, 
prencess, kit tur, ormancilar, sheraton"> 

<TITLE> Turkiye</TITLE> 
</HEAD> 

<BODY TEXT="#FFOOOO" BGCOLOR="#FFOOOO" 
LINK ="#FFOOOO" VLINK ="#FFOOOO" ALINK ="#FFOOOO" 
BACKGROUND="CDTSBK.jpg"> 
<CENTER><B><FONT FACE=" Arial, Helvetica"><FONT 
SIZE=+4><AHREF="http://www.turkey.org/" 
target="_ top"> TURKEY</ A></FONT></FONT></B></CENTER> 
<CENTER><A HREF="turkO.htm" target="_top"><IMG 
SRC="MAPi.jpg" ALT="turkiye haritasy" BORDER=O HEIGHT=235 
WIDTH=436></ A></CENTER> 
<CENTER><B><BLINK><FONT F ACE="Arial,Helvetica"><FONT 
SIZE=+ 3> WELCOME TO 
TURKEY </FONT></FONT></BLINK></B></CENTER> 

</BODY> 
</HTML> 
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·ruRKO.HTM 

<HTML> 
<HEAD> 

<META HTTP-EQUIV="Content-Type" CONTENT="text/html; 
charset=windows-1252 "> 
<META NAME="Generator" CONTENT="Microsoft Word 97"> 
<MET A NAME=" AUTHOR" Content="METIN T ASKIN"> 
<META NAME="DESCRIPTION" Content="This about 
TURKIYE"> 
<META NAME="KEYWORDS" Content=" turkiye, hotel, akdeniz, 
antalya, izmir, mersin, giresun, ataturk, trabzon, ofo hotel, hilton, 
prencess,kit tur, ormancilar, sheraton"> 

<TITLE> Turkiye</TITLE> 
</HEAD> 

<FRAMESET COLS= "151,643" > 
<FRAME SRC="ftl.htm" NAME="Frame5915145" RESIZE> 
<FRAME SRC="ftr.htm" NAME="Frame5915159" RESIZE> 
</FRAMES ET> 
<NO FRAMES> 

<BODY> 
<P> 
</BODY> 

</NO FRAMES> 

</HTML> 

FTL.HTM 

<HTML> 
<HEAD> 
<META HTTP-EQUIV="Content-Type" CONTENT="text/html; 
charset=windows-1252 "> 
<META NAME="Generator" CONTENT="Microsoft Word 97"> 
<META NAME="AUTHOR" Content="METIN TASKIN"> 
<META NAME="DESCRIPTION" Content="This about TURKIYE"> 
<MET A NAME="KEYWORDS" Content=" turkiye, hotel, akdeniz, antalya, 
izmir, mersin, giresun, ataturk, trabzon, ofo hotel, hilton, prencess, kit tur, 
ormancilar, sheraton"> 
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<TITLE> Turkiye</TITLE> 
</HEAD> 
<BODY BACKGROUND="CDTSBK.jpg" TEXT="#CCOOOO" BGCOLOR= 
"#CCOOOO" LINK ="#CCOOOO" VLINK ="#660000" ALINK ="#CCOOOO"> 
<P ALIGN="CENTER"><IMG SRC="globe7.gif' WIDTH="88" HEIGHT= 
"88" ALIGN="BOTTOM" BORDER="O"> 
<CENTER> 

<IMG SRC="Flagtk.gif' WIDTH="121" HEIGHT="71" 
ALIGN="BOTTOM" BORDER="O"></CENTER> 
<B><BLINK></B><A HREF="index.htm" target="_top"><FONT 
F ACE="Arial, 
Helvetica"><B> WELCOME</ A></B></FONT><B></BLINK></B><A 
HREF="index.htm" target="_top"><BR> 
</ A><B><BLINK></B><A HREF="index.htm" target="_ top"><FONT 
F ACE="Arial, 
Helvetica"><B> TURKEY</ A></B></FONT><B></BLINK></B></P> 
<P ALIGN="CENTER"><BR> 
<BR> 
<BR> 
<BR> 
<BR> 
<BR> 
<A HREF="index.htm" target="_top"><IMG SRC="docsleft.gif' 
WIDTH="30" HEIGHT="30" ALIGN="BOTTOM" BORDER="O"><IMG 
SRC=" docsupar.gif" WIDTH="30" HEIGHT="30" ALIGN="BOTTOM" 
BORDER ="O"></ A><A HREF="turkl .htm" target="_ top"><IMG 
SRC="docsrigh.gif' WIDTH="30" HEIGHT="30" ALIGN="BOTTOM" 
BORDER="O"></A> 

</BODY> 
</HTML> 

FTR.HTM 

<HTML> 
<HEAD> 

<META HTTP-EQUIV="Content-Type" CONTENT="text/html; 
charset=windows-1252 "> 
<META NAME="Generator" CONTENT="Microsoft Word 97"> 
<META NAME="AUTHOR" Content="METIN TASKIN"> 
<META NAME="DESCRIPTION" Content="This about TURKIYE"> 
<META NAME="KEYWORDS" Content=" turkiye, hotel, akdeniz, 
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antalya, izmir, mersin, giresun, ataturk, trabzon, ofo hotel, hilton, prencess, 
kit tur, ormancilar, sheraton"> 
<TITLE> Turkiye</TITLE> 

</HEAD> 
<BODY BACKGROUND="CDTSBK.jpg" TEXT="#CCOOOO" 
BGCOLOR="#CCOOOO" LINK="#CCOOOO" VLINK="#660000" 
ALINK ="#CCOOOO"> 
<P ALIGN="CENTER"><IMG SRC="globe7.gif' WIDTH="88" 
HEIGHT="88" ALIGN="BOTTOM" BORDER="O"> 
<CENTER> 
<IMG SRC="Flagtk.gif' WIDTH="121" HEIGHT="71" 
ALIGN="BOTTOM" BORDER="O"></CENTER> 
<B><BLINK></B><A HREF="index.htm" target="_top"><FONT 
F ACE="Arial, 
Helvetica"><B>WELCOME</A></B></FONT><B></BLINK></B> 
<A HREF="index.htm" target ="_top"><BR> <IA> <B> <BLINK> 
</B> <A HREF="index.htm" target="_top"><FONT F ACE="Arial, 
Helvetica"><B> TURKEY</ A></B></FONT><B></BLINK></B></P 
><P ALIGN="CENTER"><BR> 
<BR> 
<BR> 
<BR> 
<BR> 
<BR> 
<A HREF="index.htm" target="_top"><IMG SRC="docsleft.gif' 
WIDTH="30" HEIGHT="30" ALIGN="BOTTOM" BORDER= "O" > 
<IMG SRC= "docsupar.gif" WIDTH="30" HEIGHT="30" ALIGN= 
"BOTTOM" BORDER="O"></A><A HREF="turkl.htm" target=" 
_top "><IMG SRC= "docsrigh.gif" WIDTH="30" HEIGHT="30" 
ALIGN="BOTTOM" BORDER="O"></A> 
</BODY> 

</HTML> 
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<BODY BACKGROUND="CDTSBK.jpg" TEXT="#CCOOOO" LINK=" #CCOOOO" 
VLINK= "#660000" ALINK="#CCOOOO"> 
<P ALIGN="CENTER"><FONT SIZE="5" COLOR="#CCOOOO" FACE="Arial, 
Helvetica"><B> WELCOME TO TURKEY </B></FONT><FONT 
SIZE=" 5 ">&nbsp;</FONT> 

<CENTER> 
<TABLE BORDER="O" CELLPADDING="O" CELLSPACING="O" 
WIDTH="524" HEIGHT="461 "> 
<TR><TD WIDTH="216" HEIGHT="23" VALIGN= "BOTTOM"> 
&nbsp;</TD> 
<TD WIDTH="153" VALIGN="BOTTOM" ROWSPAN="2"><A HREF= 
"http://www.turkey.org" target="_top"><IMG SRC="Atal.gif'' WIDTH= 
"153" HEIGHT="206" ALIGN="BOTTOM" BORDER="O"></A></TD> 
<TD HEIGHT="23" VALIGN="TOP">&nbsp;</TD> 
</TR> 
<TR> 
<TD WIDTH="216" HEIGHT=" 179" V ALIGN="BOTTOM"><IMG SRC= 
"Flagtk.gif'' WIDTH="216" HEIGHT="l 16" ALIGN="BOTTOM" 
BORDER="O"></TD><TD HEIGHT=" 179" V ALIGN="BOTTOM"> 
<P ALIGN="CENTER"><IMG SRC="globe7.gif'' WIDTH="126" HEIGHT= 
"111" ALIGN="BOTTOM" BORDER="O"> 
</TD> 
</TR> 
<TR> 
<TD HEIGHT="251" V ALIGN="TOP" COLSPAN="3 "> 
<P> <IMG SRC="MAPi.jpg" WIDTH="524" HEIGHT="185" ALIGN= 
"BOTTOM" BORDER= "O"></P> 
<P ALIGN="CENTER"><A HREF="turkl .htm" target="_top"><FONT 
F ACE="Arial, Helvetica"><B> WHEN TO TRAVEL 
TURKEY </B></FONT></ A><IP><P ALI GN="CENTER"><A 
HREF="turk2.htm" target="_top"><FONT F ACE="Arial, 
Helvetica"><B>HOW TO TRAVEL TO TURKEY</B></FONT></A></P> 
<P ALIGN="CENTER"><A HREF="turk3.htm" target="_top"><FONT 
FACE= "Arial, Helvetica"><B>USEFUL PHRASES IN TURKEY </B> 
</FONT></ A><IP> 
<P ALIGN="CENTER"><A HREF="tou.htm" target="_top"><FONT 
FACE= "Arial, Helvetica"><B>TOURISTIC PLACES IN TURKEY </B> 
</FONT></ A> 
</TD> 
</TR> 
</TABLE> 
</CENTER> 
&nbsp; 
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</BODY> 
</HTML> 
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TURK1.HTM 

<HTML> 
<HEAD> 

<MET A HTTP-EQUIV=" Content-Type" CONTENT="text/html; 
charset=windows-1252 "> 
<META NAME="Generator" CONTENT="Microsoft Word 97"> 
<META NAME=" AUTHOR" Content="METIN T ASKIN"> 
<META NAME="DESCRIPTION" Content="This about TURKIYE"> 
<META NAME="KEYWORDS" Content= "turkiye, hotel, akdeniz, 
antalya, izmir, mersin,giresun,ataturk,trabzon, ofo hotel,hilton,prencess, kit 
tur, ormancilar, sheraton"> 

<TITLE> Turkiye</TITLE> 
</HEAD> 

<FRAMESET COLS = "151,643 " > 
<FRAME SRC="fthll .htm" NAME="Frame890491" RESIZE> 
<FRAME SRC="fthrl .htm" NAME="Frame890504" RESIZE> 
</FRAMES ET> 
<NO FRAMES> 

<BODY> 
<P> 

</BODY> 
</NO FRAMES> 

</HTML> 

FTHL1.HTM 

<HTML> 

<HEAD> 
<META HTTP-EQUIV="Content-Type" CONTENT="text/html; 
charset=windows-1252 "> 
<META NAME="Generator" CONTENT="Microsoft Word 97"> 
<META NAME="AUTHOR" Content="METIN TASKIN"> 
<META NAME="DESCRIPTION" Content="This about TURKIYE"> 
<META NAME="KEYWORDS" Content= "turkiye, hotel, akdeniz, antalya, 
izmir, mersin, giresun, ataturk, trabzon, ofo hotel, hilton, prencess, kit tur, 
ormancilar, sheraton"> 
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<TITLE> Turkiye</TITLE> 
</HEAD> 

<BODY BACKGROUND="CDTSBK.jpg" TEXT="#CCOOOO" LINK 
= "#CCOOOO" VLINK="#660000" ALINK="#CCOOOO"> 
<P ALIGN="CENTER"><IMG SRC="globe7.gif'' WIDTH="88" 
HEIGHT ="88" ALIGN="BOTTOM" ALT="dunya" BORDER="O"> 
<CENTER> 
<B><BLINK></B><A HREF= "index.htm" target="_top"><FONT 
FACE= "Arial, Helvetica"><B>WELCOME</A></B></FONT> <B> 
</BLINK></B><A HREF="index.htm" target="_top"><BR> <IA> 
<B><BLINK></B><A HREF="index.htm" target="_top"><FONT 
FACE= "Arial, Helvetica"><B>TURKEY </ A></B></FONT><B> 
</BLINK></B><BR><IMG SRC="Flagtk.gif'' WIDTH= "121" 
HEIGHT= "71" ALIGN="BOTTOM" BORDER="O"></CENTER> 
<BR> 
<BR> 
<BR> 
<BR> 
<BR> 
<BR> 

<P ALIGN="CENTER"><A HREF="turkO.htm" target="_top"><IMG 
SRC="docsleft.gif'' WIDTH="30"HEIGHT="30"ALIGN="BOTTOM" 
BORDER="O"></A><A HREF="index.htm" target="_top"><IMG 
SRC="docsupar.gif''WIDTH="30"HEIGHT="30"ALIGN="BOTTOM 
BORDER="O"></A><A HREF="turk2.htm" target="_top"><IMG 
SRC="docsrigh.gif''WIDTH="30"HEIGHT="30"ALIGN="BOTTOM" 
BORDER="O"></A> 
</BODY> 

</HTML> 

FTHR1.HTM 

<HTML> 
<HEAD> 

<META HTTP-EQUIV="Content-Type" CONTENT="text/html; 
charset=windows-1252 "> 
<META NAME="Generator" CONTENT="Microsoft Word 97"><META 
NAME="AUTHOR" Content="METIN TASKIN"> 
<META NAME="DESCRIPTION" Content="This about TURKIYE"> 
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<MET A NAME="KEYWORDS" Content= 
"turkiye,hotel,akdeniz,antalya, izmir,mersin, giresun,ataturk,trabzon, 
ofo hotel ,hilton, prencess, kit tur,ormancilar,sheraton"> 

<TITLE> Turkiye</TITLE> 
</HEAD> 

<BODY BACKGROUND="CDTSBK.jpg" TEXT="#660099" LINK= 
"#CCOOOO" VLINK="#660000" ALINK="#CCOOOO"><H2 ALIGN= 
"CENTER"><FONT COLOR="#330066">When to Travel to Turkey 
</FONT></H2> 
<P><FONT COLOR="#330066"><B>Marmara, Aegean and 
Mediterranean Coasts:</B></FONT><BR> 

These coasts have a typical Mediterranean climate with hot summers and mild 
winters. The swimming season becomes shorter as one travels north:<BR> 
<STRONG>Marmara and North Aegean:</STRONG> June to September 
<BR> 
<STRONG>South Aegean and Mediterranean: </STRONG>April to October 
<BR> 
<B>Black Sea Coast:</B><BR> 
Temperate climate with warm summers, mild winters and relatively high 
rainfall. </P> 
<P><FONT COLOR="#330066"><B>Central Anatolia:</B></FONT><BR> 
These areas have a steppe climate with hot, dry summers and cold winters. 
<IP> 
<P><FONT CO LOR ="#3 3 0066 "><B> Eastern Anatolia:</B></FONT><BR> 
Long snowy, cold winters with mild summers. <IP> 
<P><FONT COLOR="#330066"><B>Southeast Anatolia:</B></FONT> 
<BR>These areas have a hot summer with mild, rainy winters.</P> 
<P> 
<H3><FONT COLOR="#330066">Average Air temperatures for Major 
Regions</FONT></H3> 
<P>(IN CELSIUS) 

<TABLE BORDER="l"> 
<td> 
<TR> 
<TD>&nbsp;</TD> 
<TD><FONT COLOR="#330066">Jan</FONT></TD> 
<TD><FONT COLOR="#330066">Feb</FONT></TD> 
<TD><FONT COLOR="#330066">Mar</FONT></TD> 
<TD><FONT COLOR="#330066">Apr</FONT></TD> 
<TD><FONT COLOR="#330066">May</FONT></TD> 
<TD><FONT COLOR="#330066"> Jun</FONT></TD> 
<TD><FONT COLOR="#330066">Jul</FONT></TD> 
<TD><FONT COLOR="#330066">Aug</FONT></TD> 
<TD><FONT COLOR="#330066">Sep</FONT></TD> 
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<TD><FONT COLOR="#330066">0ct</FONT></TD> 
<TD><FONT COLOR="#330066">Nov</FONT></TD> 
<TD><FONT COLOR="#330066">Dec</FONT></TD> 
</TR> 
<TR> 
<TD><FONT COLOR="#330066">ANTAL YA</FONT></TD> 
<TD> 1 O</TD> 
<TD> 11 </TD> 
<TD> 13 </TD> 
<TD> 16</TD> 
<TD>20</TD> 
<TD>25</TD> 
<TD>28</TD> 
<TD>28</TD> 
<TD>25</TD> 
<TD>20</TD> 
<TD> 15</TD> 
<TD> 12</TD> 
</TR> 
<TR> 
<TD><FONT COLOR="#330066">IZMIR</FONT></TD> 
<TD>9</TD> 
<TD> 1 O</TD> 
<TD> 11 </TD> 
<TD> 16</TD> 
<TD>20</TD> 
<TD>25</TD> 
<TD>28</TD> 
<TD>27</TD> 
<TD> 23 </TD> 
<TD> 18</TD> 
<TD> 15</TD> 
<TD> 1 O</TD> 
</TR> 
<TR> 
<TD><FONT COLOR="#330066">ISTANBUL</FONT></TD> 
<TD>S</TD> 
<TD>6</TD> 
<TD>7</TD> 
<TD> 12</TD> 
<TD> 16</TD> 
<TD> 21 </TD> 
<TD> 23 </TD> 
<TD> 23 </TD> 
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<TD>20</TD> 
<TD> 16</TD> 
<TD> 12</TD> 
<TD>8</TD> 
</TR> 
<TR> 
<TD><FONT COLOR="#330066">TRABZON</FONT></TD> 
<TD>6</TD> 
<TD>6</TD> 
<TD>7</TD> 
<TD> 11 </TD> 
<TD> 15 </TD> 
<TD>20</TD> 
<TD>22</TD> 
<TD>22</TD> 
<TD> 19</TD> 
<TD> 15</TD> 
<TD> 12</TD> 
<TD>9</TD> 
</TR> 
<TR> 
<TD><FONT COLOR="#330066">ANKARA</FONT></TD> 
<TD>O</TD> 
<TD>l</TD> 
<TD>5</TD> 
<TD> 11 </TD> 
<TD> 16</TD> 
<TD> 20</TD> 
<TD> 23 </TD> 
<TD>23</TD> 
<TD> 18</TD> 
<TD> 13</TD> 
<TD>8</TD> 
<TD>2</TD> 
</TR> 
<TR> 
<TD><FONT COLOR="#330066">ERZURUM</FONT></TD> 
<TD>-9</TD> 
<TD>- 7 </TD> 
<TD>-3</TD> 
<TD>5</TD> 
<TD> 11 </TD> 
<TD> 15</TD> 
<TD> 19</TD> 
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<TD>20</TD> 
<TD> 15</TD> 
<TD>9</TD> 
<TD>2</TD> 
<TD>-5</TD> 
</TR> 
<TR> 
<TD><FONT COLOR="#330066">DIYARBAKIR</FONT></TD> 
<TD>2</TD> 
<TD>2</TD> 
<TD>8</TD> 
<TD> 14</TD> 
<TD> 19</TD> 
<TD> 26</TD> 
<TD> 31 </TD> 
<TD> 31 </TD> 
<TD>25</TD> 
<TD> 17 </TD> 
<TD> 1 O</TD> 
<TD>4</TD> 
</TR> 
<TR> 
<TD></TD> 
<TD></TD> 
<TD></TD> 
<TD></TD> 
<TD></TD> 
<TD></TD> 
<TD></TD> 
<TD></TD> 
<TD></TD> 
<TD></TD> 
<TD></TD> 
<TD></TD> 
<TD></TD> 
</TR> 
</TABLE> 

</BODY> 
</HTML> 
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TURK2.HTM 

<HTML> 
<HEAD> 

<META HTTP-EQUIV="Content-Type" CONTENT="text/html; 
charset=windows-1252 "> 
<META NAME="Generator" CONTENT="Microsoft Word 97"> 
<META NAME="AUTHOR" Content="METIN TASKIN"> 
<META NAME="DESCRIPTION" Content="This about 
TURKIYE"> 
<META NAME="KEYWORDS" Content="turkiye,hotel, akdeniz, 
antalya,izmir,mersin,giresun,ataturk,trabzon, ofo hotel,hilton,prencess, 
kit tur,ormancilar,sheraton"> 

<TITLE> Turkiye</TITLE> 
</HEAD> 

<FRAMESET COLS= "151,643" > 
<FRAME SRC="fthl2.htm" NAME="Frame1677928" RESIZE> 
<FRAME SRC="fthr2.htm" NAME="Frame1677938" RESIZE> 
</FRAMES ET> 
<NO FRAMES> 

<BODY> 
<P> 
</BODY> 

</NO FRAMES> 
</HTML> 

FTHL2.HTM 

<HTML> 
<HEAD> 

<META HTTP-EQUIV="Content-Type" CONTENT="text/html; 
charset=windows-1252 "> 
<META NAME="Generator" CONTENT="Microsoft Word 97"> 
<META NAME="AUTHOR" Content="METIN TASKIN"> 
<META NAME="DESCRIPTION" Content="This about 
TURKIYE"> 
<MET A NAME="KEYWORDS" Content="turkiye,hotel,akdeniz, 
antalya,izmir,mersin,giresun,ataturk,trabzon, ofo hotel, hilton,prencess, 
kit tur,ormancilar,sheraton"> 
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<TITLE> Turkiye</TITLE> 
</HEAD> 

<BODY BACKGROUND="CDTSBK.jpg" TEXT="#CCOOOO" 
LINK ="#CCOOOO" VLINK ="#660000" ALINK ="#CCOOOO"> 
<P ALIGN="CENTER"><IMG SRC="globe7.gif' WIDTH="88" 
HEIGHT="88" ALIGN="BOTTOM" ALT="dunya" BORDER="O"> 
<CENTER> 
<A HREF="index.htm" target="_top"><FONT FACE="Arial, 
Helvetica"><B> WELCOME</B></FONT></ A></CENTER> 
<CENTER> 
<A HREF="index.htm" target="_top"><FONT FACE="Arial, 
Helvetica"><B> TURKEY </B></FONT></ A></CENTER> 
<CENTER> 
<IMG SRC="Flagtk.gif' WIDTH="121" HEIGHT="71" 
ALIGN="BOTTOM" BORDER="O"></CENTER> 
&nbsp; <BR> 
&nbsp; <BR> 
&nbsp; <BR> 
&nbsp; <BR> 
&nbsp; <BR> 
&nbsp; 
<CENTER> 
<A HREF="turkl .htm" target="_top"><IMG SRC="docsleft.gif' 
WIDTH="30" HEIGHT="30" ALIGN="BOTTOM" BORDER= 
"O"><IA><A HREF="turkO.htm" target="_top"> <IMG SRC= 
"docsupar.gif" WIDTH="30" HEIGHT="30" ALIGN="BOTTOM" 
BORDER="O"></A><A HREF="turk3.htm" target= "_top"> <IMG 
SRC="docsrigh.gif' WIDTH="30" HEIGHT="30" ALIGN= 
"BOTTOM" BORDER="O"></A></CENTER> 

</BODY> 
</HTML> 

FTHR2.HTM 

<HTML> 
<HEAD> 

<META HTTP-EQUIV="Content-Type" CONTENT="text/html; 
charset=windows-1252 "> 
<META NAME="Generator" CONTENT="Microsoft Word 97"> 
<META NAME="AUTHOR" Content="METIN TASKIN"> 
<META NAME="DESCRIPTION" Content="This about 
TURKIYE"> 
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<META NAME="KEYWORDS" Content="turkiye,hotel,akdeniz, 
antalya,izmir, mersin,giresun,ataturk,trabzon, ofo hotel,hilton,prencess, 
kit tur,ormancilar,sheraton"> 

<TITLE> Turkiye</TITLE> 
</HEAD> 

<BODY BACKGROUND="CDTSBK.jpg" TEXT="#660099"> 
<P ALIGN="CENTER"><FONT SIZE="5" COLOR= "#330066"> 
<B>How to Travel to Turkey</B></FONT><FONT SIZE="6"><B> 
</B></FONT></P> 

<UL> 
<LI><FONT COLOR="#330066"><B>Airlines</B></FONT><BR> 
Turkish Airlines has regular flights to Ankara, Istanbul, Izmir, Antalya, 
Adana, Trabzon and Dalaman, from the principal capitals and major cities of 
the world. 
<UL> 
<LI> Turkish Airlines 
<LI> International Airlines 
<LI>Charter Airlines 
</UL> 
<P> 
<LI><FONT COLOR="#330066"><B>Travel Agencies</B> </FONT> 
<BR> 
A listing of travel agents in major Turkish cities. 
<P> 
<LI><FONT COLOR="#330066"><B>Other Means of Transportation</B> 
</FONT><BR> A listing of other means of transportation, including state 
railways, maritime lines, sea buses and major city bus companies. 
</UL> 
<H2><FONT COLOR="#330066">Airlines</FONT></H2> 
<UL> 
<LI> Turkish Airlines 
<LI>Other Domestic Airlines 
<LI> International Airlines 
<LI>Charter Aircraft 
</UL> 

<H3>0ffice of Turkish Airlines</H3> 
<P>R: Reservations phone number<BR> 
S: Sales office phone number</P> 
<P><FONT SIZE="4"><B>Istanbul</B></FONT></P> 
<P> Turkish Airlines Head Office<BR> Ataturk Airport Y esilkoy, 
Istanbul<BR> 
Tel: (212) 663 63 OO<BR>Fax: (212) 663 47 44 -63 49 04<BR> 
R: (212) 663 63 63<BR>(25 lines)</P> 
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<P>Cargo Reservation Department<BR> Ataturk Airport Y esilkoy, 
Istanbul<BR>Tel: R: (212) 663 46 OO<BR>(4 lines)<BR>Fax: (212) 
573 35 26 <BR>Istanbul Sales<BR>Cumhuriyet Caddesi 199-201 Kat 
3<BR>Harbiye, Istanbul<BR>Tel: S (212) 248 26 31 -<BR> 
246 40 17 - 247 13 38<BR>R (212) 663 63 63<BR>(25 lines)<BR> 
Fax: (212) 240 29 84 <BR>Sales Offices:<BR>Taksim: (212) 252 11 
06 (6 lines)<BR>Harbiye: (212) 225 05 56<BR>(6 lines)<BR> 
Aksaray: (212) 514 00 22 - 23<BR> 
Sirkeci: (212) 522 88 88 -528 42 61 <IP> 
<P><FONT SIZE=" 4 "><B> Ankara</B></FONT><BR> 
Turkish Airlines<BR>Ataturk Bulvan 25 Bakanliklar, Ankara<BR> 
Tel: S (312) 419 28 25/<BR>418 68 45/ 518 92 60<BR> 
R (312) 418 26 24/<BR>419 28 OO<BR>Fax: (312) 418 94 53</P> 
<P><FONT SIZE=" 4 "><B> Izmir</B></FONT><BR> Turkish 
Airlines <BR>Gaziosmanpasa Bulvan<BR>I/F Buyuk Efes Oteli Alti 
Izmir<BR>Tel: S (232) 484 12 20<BR>(5 lines)<BR>R (232) 425 82 
80<BR>Fax: (232) 483 62 81 </P><P><FONT SIZE="4"><B>Adana 
</B></FONT><BR>Turkish Airlines<BR>Stadyum Caddesi 32 
01120 Adana<BR>Tel: S (322) 453 08 67<BR>R (322) 454 23 
93/<BR>454 35 38/ 453 72 47<BR>Fax: (322) 454 30 88</P> 
<P><FONT SIZE=" 4 "><B> Antalya</B></FONT><BR> Turkish 
Airlines<BR>Ozel Idare Ishani Alti Cumhuriyet Caddesi Antalya 
<BR>Tel: S (242) 243 43 81-82<BR>R (242) 243 43 84<BR> 
(4 linesO<BR>Fax: (242) 248 47 61 </P><P><H3>0ther Domestic 
Airlines</H3><P><B>Green Air</B><BR>Konakli Sokak 1 O<BR> 
Florya, Istanbul<BR>Tel: (212) 663 50 08-09<BR>Fax: (212) 663 56 
90</P> 
<P><B>Istanbul Airlines</B><BR>Cumhuriyet Caddesi 289<BR> 
Harbiye, Istanbul<BR>Tel: (212) 231 75 26<BR>Fax: (212) 246 49 
67</P> 
<P><B>Mas Air (Flights to Bodrum)</B><BR>City Office<BR> 
Cumhurieyet Caddesi<BR>l67 Elmadag, Ist.<BR>Tel: (212) 231 10 
72-73<BR>Fax: (212) 234 43 31 <BR>Airport Office<BR>Ataturk 
Hava Limani Kat 3<BR>Yesilkoy<BR>Istanbul<BR>Tel: (212) 663 
40 94 PBX<BR>Fax: (212) 574 05 53</P> 
<P><H3> International Airlines</H3><P><FONT SIZE=" 4 "><B> 
Istanbul</B></FONT></P><P><B>Adria (Slavonian) Airways</B> 
<BR>Ordu Caddesi 206/1 Lalei<BR>Tel: (212) 512 42 3l<BR>Fax: 
(212) 512 42 34-512 54 36</P> 
<P><B>Aeroflot</B><BR>Mete Caddesi 30 Taksim<BR>Tel: (212) 
243 47 25<BR>Fax: (212) 252 39 98</P> 
<P><B>Air China</B> <BR>Cumhuriyet Caddesi 235/1 
Harbiye<BR>Tel: (212) 232 71 11 <BR>Fax: (212) 232 44 87</P> 
<P><B>Air France</B><BR>Cumhuriyet Caddesi I Taksim<BR> 
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Tel: (212) 256 43 56<BR>Fax: (212) 254 43 34</P><P><B>Alia 
(Jordanian Airlines)</B><BR>Cumhuriyet Caddesi 163 Kat 2 
lmadag<BR>Tel: (212) 230 40 74<BR>Fax: 234 54 10</P><P> 
<B>Alitalia</B><BR>Cumhuriyet Caddesi Seyhan Apt. 12/4<BR> 
Elmadag,<BR>Tel: (212) 231 33 91-92<BR>Fax: (212) 230 63 4</P> 
<P><B> American Airlines</B><BR>Cumhuriyet Caddesi 4 7 /2 
Taksim<BR>Tel: (212) 237 20 03<BR>Fax: (212) 237 20 05</P> 
<P> <B>Austrian Airlines</B><BR>Sheraton Hotel Taksim<BR>Tel: 
(212) 232 22 OO<BR>Fax: (212) 234 37 28</P> 
<P><B>Azerbaijan Airlines</B><BR>Cumhuriyet Caddesi 39/I 
Taksim<BR>Tel: (212) 237 42 01-02<BR>Fax: (212) 237 42 00</P> 
<P><B>Balkan Bulgarian Airlines</B><BR>Cumhuriyet 
Caddesi<BR>Gezi Dukkanlan Taksim<BR>Tel: (212) 245 24 56</P> 
<P><B>British Airways</B><BR>Cumhuriyet Caddesi 10 
lmadag<BR>Tel: (212) 234 13 OO<BR>Fax: (212) 234 13 08</P> 
<P><B>Cathay Pacific Airlines</B><BR>Cumhuriyet Caddesi 309 
Kat I Harbiye<BR>Tel: (212) 241 71 17 - 2416833<BR>Fax: (212) 
234 49 99</P> 
<P><B>Continental Airlines</B><BR>Cumhuriyet Caddesi 163 Kat I 
Elmadag,<BR>Tel: (212) 230 48 32<BR>Fax: (212) 230 83 26</P> 
<P><B>Delta Airlines</B><BR>Istanbul Hilton Girisi Harbiye<BR> 
Tel: (212) 231 23 39<BR>Fax: (212) 2312346</P> 
<P><B>Egypt Air</B><BR>Cumhuriyet Caddesi 337-339 Kat 1 
Harbiye<BR>Tel: (212) 231 11 26<BR>Fax: (212) 234 07 54</P> 
<P><B>El-Al (Israeli Airlines)</B><BR>Rumeli Caddesi Nisantasi Is 
Mrk.<BR>Kat 4 No. 1 Nisantas<BR>Tel: (212) 246 53 03<BR>Fax: 
(212) 230 37 05</P> 
<P><B>Emirates Airlines</B><BR>Halaskargazi Caddesi 69/71 
Harbiye<BR>Tel: (212) 232 32 16<BR>Fax: (212) 240 20 85</P> 
<P><B>Finnair</B><BR>Cumhuriyet Caddesi 26, Elmadag, lst<BR> 
Tel: (1) 234 51 30<BR>Fax: (212) 234 47 44</P> 
<P><B>Georgia Airlines</B><BR> Y olcuzade Iskender Cad. <BR>66- 
68 Kat 2<BR>Sishane<BR>Tel: (212) 253 11 11-253 01 16<BR>Fax: 
(212) 253 21 58</P> 
<P><B>Gulf Air</B><BR>Cumhuriyet Cad. Hilton Oteli Girisi<BR> 
Elmadag<BR>Tel: (212) 231 34 50<BR>Fax: (212) 234 47 44</P> 
<P><B>Iberia</B><BR>Topcu Caddesi Uygun Apt. 2/2 Taksim<BR> 
Tel: (212) 255 19 68<BR>Fax: (212) 250 54 78 -<BR>256 12 13</P> 
<P><B>Iranair</B><BR>Curnhuriyet Caddesi 71 Elmadag<BR>Tel: 
(212) 225 02 55<BR>Fax: (212) 225 22 00</P> 
<P><B>JAL (Japanse Airlines)</B><BR>Cumhuriyet Caddesi 141/6 
K.2 Elmadag,<BR>Tel: (212) 241 73 66<BR>Fax: (212) 234 22 
9</P> 

- 125 - 



NEAR EAST UNIVERSTY 
COMPUTER ENC/NEER/NC 

1988 

<P><B>KLM (Royal Dutch Airlines)</B><BR>Abdi Ipekci Caddesi 
<BR>Unsal Apt 8 Nisantasi<BR>Tel: (212) 230 03 11 <BR>Fax: 
(212) 232 87 49</P> 
<P><B>KTHY (Turkisyh Airlines of Northern Cyprus)</B><BR> 
Buyukdere Cad 56/B Mecidiyekoy<BR>Tel: (212) 272 32 79-<BR> 
267 09 73 (3 lines)<BR>Fax: (212) 274 69 34</P> 
<P><B>Kuwait Airlines</B><BR>Cumhuriyet Caddesi 30<BR> 
Elmadag, Istanbul<BR>Tel: (212) 240 40 81<BR>Fax: (212) 231 45 
37</P> 
<P><B>Lot (Polish Airlines)</B><BR>Cumhuriyet Caddesi 91 Kat 2 
Elmadag,<BR>Tel: (212) 241 57 49<BR>Fax: (212) 246 76 26</P> 
<P><B>Lufthansa</B><BR>Maya Akar Center Buyukdere 
Caddesi<BR>l00-102 Esentepe<BR>Tel: (212) 288 10 50<BR>Fax: 
275 69 61 </P> 
<P><B>Malev (Hungarian Airlines)</B><BR>Cumhuriyet Caddesi 
71 K.2. Elmadag,<BR>Tel: (212) 230 71 30<BR>Fax: (212) 230 20 
34</P> 
<P><B>MAS (Malaysian Airlines)</B><BR>Cumhuriyet Caddesi 71 
K.2 Elmadag,<BR>Tel: (212) 230 71 30<BR>Fax: (212) 230 03 
7</P> 
<P><B>Middle East Airlines (MEA)</B><BR>Cumhuriyet Caddesi 
30 Harbiye<BR>Tel: (212) 248 22 41-42<BR>Fax: (212) 248 37 
3</P> 
<P><B>Olympic Airways</B><BR>Cumhuriyet Caddesi 171/A 
ElmadagTel: (212) 246 50 81<BR>Fax: (212) 232 21 73</P> 
<P><B>Pakistan Airlines (PIA)</B><BR>Cumhuriyet CaddesiTarhan 
203<BR>Elmadag<BR>Tel: (212) 233 05 71 <BR>Fax: (212) 234 10 
60</P> 
<P><B>Royal Air Maroc</B><BR>Valikonagi Caddesi Kose Atp. 
01/4<BR>Nisantasi<BR>Tel: (212) 231 80 21-231 71-21 <BR>Fax: 
(212) 230 65 23</P> 
<P><B>Sabena</B><BR>Topcu Caddesi Uygun Apt. 2/1 
Taksim<BR>Tel: (212) 254 72 54<BR>Fax: (212) 255 13 74</P> 
<P><B>SAS Scandinavian Airlines</B><BR>Cumhuriyet Caddesi 
26/A<BR>Elmadag<BR>Tel: (212) 246 60 75<BR>Fax: 233 88 
03</P> 
<P><B>Saudi Arabian Airlines</B><BR>Cumhuriyet Caddesi Inkilap 
Apt. 33, Elmadag<BR>Tel: (212) 256 48 OO<BR>Fax: (212) 256 46 
47</P> 
<P><B>Singapore Airlines</B><BR>Halaskargazi Caddesi 113 
Harbiye<BR>Tel: (212) 232 37 06<BR>Fax: (212) 248 86 20</P> 
<P><B>Syrian Arab Airlines</B><BR>Istanbul Sheraton Hotel<BR> 
Taksim, Istanbul<BR>Tel: (212) 246 17 81<BR>Fax: (212) 231 21 
80</P> 
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<P><B>Swissair</B><BR>Cumhuriyet Caddesi Pak Apt. 6, 
Elmadag<BR>Tel: (212) 2312844<BR>Fax: (212) 240 15 13</P> 
<P><B>Qantas Australian Airlines</B><BR>Cumhuriyet Caddesi 
155/1, Elmadag<BR>Tel: (212) 240 50 32 -<BR>246 34 66<BR> 
Fax: (212) 241 55 52</P> 
<P><B> T AROM Romanian Airlines</B><BR>Cumhuriyet Caddesi 
125 Kat 4, Elmadag<BR>Tel: (212) 230 73 09<BR>Fax: (212) 241 01 
30</P> 
<P><B>Tunisair</B><BR>Valikonagi Caddesi Bizim Apt. 8 
isantasi<BR>Tel: (212) 233 93 06-<BR>248 29 04<BR>Fax: (212) 
246 22 08</P> 
<P><B>TWA</B><BR>Cumhuriyet Caddesi 193, Elmadag,<BR> 
Tel: (212) 234 53 27<BR>Fax: (212) 230 63 44</P> 
<P><B>United Airlines</B><BR>Cumhuriyet Caddesi 209/2, 
Elmadag<BR>Tel: (212) 224 91 80<BR>(6 lines)<BR>Fax: (212) 232 
40 74</P> 
<P><B> Varig (Brazilian Airlines )</B><BR> 19 Mayis Caddesi 
4/505<BR>Nova Baran Carsis Sisli<BR>Tel: (212) 240 45 56<BR> 
Fax: (212) 240 51 06</P> 
<P><FONT SIZE="4"><B>Ankara</B></FONT></P> 
<P><B> Aeroflot</B><BR>Cinnah Caddesi 114/2 Cankaya<BR> Tel: 
(312) 440 98 74-75<BR>Fax: (312) 440 92 20</P> 
<P><B>Air France</B><BR>Ataturk Bulvan, 231/7 
Kavaklidere<BR>Tel: (312) 467 44 OO<BR>Fax: (312) 468 25 95</P> 
<P><B>Alitalia</B><BR>Iran Caddesi 21 Kat 3 No. 369<BR> 
Kavaklidere<BR>Tel: (312) 418 88 13-425 38 13<BR>Fax: (312) 417 
97 96</P> 
<P><B>Austrian Airlines</B><BR>Cinnah Caddesi 43/8 
Cankaya<BR>Tel: (312) 417 56 16-17<BR>Fax: (312) 440 61 08</P> 
<P><B>British Airways</B><BR>Ataturk Bulvan, 237/29 
Kavaklidere<BR>Tel: (312) 467 55 57<BR>Fax: (312) 427 33 13</P> 
<P><B>KTHY (Turkish Airlines of Northern Cyprus)</B><BR> 
Selanik Caddesi 17/1 Kizilay<BR>Tel: (312) 418 04 25<BR>Fax: 
(312) 418 78 17</P> 
<P><B>Delta Airlines</B><BR>Tunus Caddesi 85/8 
Kavaklidere<BR>Tel: (312) 468 28 08<BR>Fax: (312) 467 19 75</P> 
<P><B>KLM Royal Dutch Airlines</B><BR>Cinnah Caddesi 43/8 
Cankaya<BR>Tel: (312) 417 56 16-17<BR>Fax: (312) 440 61 08</P> 
<P><B>Lufthansa</B><BR>Iran Caddesi 2 Kavaklidere<BR>Tel: 
(312) 467 55 lO<BR>Fax: (312) 427 84 71</P> 
<P><B>SAS Scandinavian Airlines</B><BR>Ataturk Bulvan, 127 
Sercan Han Kat 4<BR>Bakanliklar<BR>Tel: (312) 425 51 90-425 76 
13<BR> Fax: (312) 417 24 28</P> 
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<P><B>Sabena</B><BR> Tunali Hilmi Caddesi, 112/1 
Kavaklidere<BR>Tel: (312) 467 25 35-36<BR>Fax: (312) 467 25 
43</P> 
<P><FONT SIZE="4"><B>Izmir</B></FONT></P><P><B>Air 
France</B><BR> 1353. Sokak Taner Ishani 1 <BR>Kat 2 205- 
206<BR>Tel: (232) 425 90 04(3)<BR>Fax: (232) k484 66 31 <IP> 
<P><B>Alitalia</B><BR>Ataturk Caddesi 328/A I.l Kordon<BR> 
Tel: (232) 42 71 97<BR>Fax: (232) 463 31 62</P> 
<P><B> Austrian Airlines</B><BR>Sair Esref Bulvan 5/105<BR> 
1371. Sokak Alkan Han Cankaya<BR>Tel: (232) 425 97 22- 425 80 
20<BR>Fax: (232) 425 03 09</P> 
<P><B> British Airways</B><BR>Sair Esref Bulvan 18<BR> 
Altay Is Mrk. Kat 3 No.1304 Cankaya,<BR>Tel: (232) 441 38 
29<BR>Fax: (232) 441 62 94</P> 
<P><B>Delta Airlines</B><BR>Cumhuriyet Bulvan 143/H 
Alsancak<BR>Tel: (232) 421 42 62-63 <BR>KLM (Royal Dutch 
Airlines)<BR>Adnan Menderes Airport<BR>Tel: (232) 274 20 
82</P> 
<P><B> L ufthansa</B><BR> 13 79 Sokak 23 Alsancak<BR> 
Tel: (232) 422 36 22<BR>Fax: (232) 422 64 12</P> 
<P><B>SAS (Scandinavian Airlines)</B><BR>Cumhuriyet Meydani 
Neyzan Apt. 11/2, Alsancak<BR>Tel: (232) 421 47 57-463 49 
60<BR>Fax: (232) 463 64 58</P> 
<P><B>Swissair</B><BR>Cumhuriyet Meydani Meydan Apt. 11/2, 
Pasaport<BR>Tel: (232) 463 49 60 - 463 49 90<BR>Fax: (232) 463 
64 58</P> 
<P><FONT SIZE="4"><B>Antalya</B></FONT></P> <P><B> 
SunExpress</B><BR>Fener Mahallesi, Sinangoglu Caddesi<BR> 
Oktay Apt. P.O. Bo 28 07100<BR>Tel: (242) 323 40 47-48<BR> 
Fax: (242) 323 40 57</P> 
<P> 
<H3>Charter Aircraft</H3> 
<P><FONT SIZE=" 4 "><B> Istanbul </B></FONT></P> 
<P><B>Birgen Air</B><BR>Cumhuriyet Caddesi 301/9 Harbiye, 
<BR>Istanbul<BR>Tel: (212) 240 11 50-246 17 61 <BR>Fax: (212) 
246d 57 11 </P> 
<P><B>Bon Air</B><BR>Orman Sokak 10 Florya, Istanbul<BR> 
Tel: (212) 663 18 29<BR>Fax: (212) 574 01 47</P> 
<P><B>Genel Havacilik</B><BR>Polis Egitim Merkezi Arkasi<BR> 
Ozel Havacilik Hangarlar Bolgesi<BR>Sefakoy, Istanbul<BR> 
Tel: (212) 5412917<BR>Fax: (212) 5412923</P> 
<P><B>Mach Air</B><BR>P9olis Egitim Merkezi Arkasi<BR> 
OzelHavacilik Hangarlar Bolgesi<BR>Sefaoy, Istanbul<BR> 
Tel: (212) 541 14 23 -24<BR>Fax: (212) 541 95 94</P> 
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<P><B>Sancak Air</B><BR>Polis Egitim Merkezi Arkasi<BR> 
Ozel Havacilik Hangarlar Bolgesi<BR>Sefakoy, Istanbul<BR> 
Tel: (212) 541 41 41 <BR>Fax: (212) 541 02 85</P> 
<P><B>TGI Turistik Islet. ve Havacilik</B><BR>Cumhuriyet Cad. 
Hava Palas 155/1 <BR>Elmadag, Istanbul<BR>Tel: (212) 232 52 
OO<BR>Fax: (212) 241 55 52</P> 
<P><B>Top Air</B><BR>Polis Egt. Merkezi Arkasi<BR>Sefakoy, 
Istanbul<BR>Tel: (212) 599 02 27 - 599 07 59<BR>Fax: (212) 599 79 
10 - 598 50 60</P> 
<P><FONT SIZE=" 4 "><B> Ankara</B></FONT></P><P><B> Belko 
Air</B><BR>Mesnevi Sokak 27/A<BR>Asagi Ayranci, Ankara<BR> 
Tel: (312) 440 94 20</P> 
<P> 
<H2> Travel Agencies</H2> 
<H3>Association of Travel Agencies of Turkey (TURSAB)</H3> 
<P>Gazeteciler Sitesi Haberier Sokak 15<BR>Esentepe, Istanbul 
<BR>Tel: (212) 274 13 97 -275 13 61-62<BR>Fax:; (212) 275 00 66 
<BR>Arar Tur Turizm/Istanbul<BR>Tel: (212) 230 10 27 -230 09 
90<BR>Fax: (212) 230 91 71 <BR>Camel Tur/Istanbul<BR>Tel: 
(212) 257 78 28<BR>Fax: (212) 278 31 43 <BR>Duru 
Turizm/Istanbul<BR>Tel: (212) 231 90 08<BR>Fax: (212) 233 03 91 
<BR>Duru Turizm/Ankara<BR>Tel: (312) 440 75 76<BR>Fax: (312) 
440 36 23 <BR>Duru Turizm/Izmir<BR>Tel: (232) 463 29 11 -463 50 
93<BR>Fax: (232) 421 35 66 <BR>Ekin Turizm/Istanbul<BR>Tel: 
(212) 234 43 OO<BR>(5 lines)<BR>Fax: (212) 232 92 60 <BR>Irem 
Tur/Istanbul<BR>Tel: (212) 296 25 03<BR>Fax: (212) 230 30 27 
BR>Irem Tur/Ankara<BR>Tel: (312) 425 28 70-418 69 94<BR>Fax: 
(312) 417 59 23 <BR>Oger Tours/Istanbul<BR>Tel: (242) 247 46 
O<BR>Fax: (242) 248 74 51 <BR>Oger Tours/Izmir<BR>Tel: (232) 
464 07 67<BR>Fax: (232) a464 07 74 <BR>Oger Tours/Antalya<BR> 
Tel: (242) 247 46 60<BR>Fax: (242) 248 74 51 <BR>Oger 
Tours/Istanbul<BR>Tel: (212) 632 02 46<BR>(4 lines)<BR>Fax: 
(212) 632 02 07 <BR>Pacha Tour/Istanbul<BR>Tel: (212) 235 01 
45<BR>(7 lines)<BR>Fax: (212) 235 01 52 <BR>Prog Turizm/ 
Istanbul <BR>Tel: (212) 230 46 73<BR>(3 lines)<BR>Fax: (212) 234 
05 65 <BR>Setur/Istanbul<BR>Tel: (212) 230 03 36<BR>(8lines) 
<BR>Fax: (312) 230 32 19 <BR>Setur/Ankara<BR>Tel: (312) 467 11 
65<BR>Fax: (312) 467 87 75 <BR>Setur/Izmir<BR>Tel: (232) 463 
61 OO<BR>Fax: (232) 422 22 18 <BR>Tantur/Istanbul<BR>Tel: (212) 
272 49 64<BR>Fax: (212) 272 58 02 <BR>Ten Tur/Istanbul<BR>Tel: 
(212) 293 06 50<BR>(6 lines)<BR>Fax: (212) 293 06 57-58 <BR>Tui 
Tourism Travel Agency/Istanbul<BR>Tel: (212) 517 68 31 -518 57 
2<BR>Fax: (212) 518 58 26 <BR>Tura Turizm/Istanbul<BR>Tel: 
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(212) 241 60 82 -<BR>246 53 32<BR>Fax: (212) 233 99 94 <BR> 
Turk Express/Istanbul<BR>Tel: (212) 230 15 15<BR>Fax: (212) 232 
93 73 <BR>Turk Express/Ankara<BR>Tel: (312) 467 73 34-35<BR> 
Fax: (312) 467 29 20 <BR>Vip Turizm/Istanbul<BR>Tel: (212) 241 
65 14<BR>Fax: (212) 230 64 25<H2>0ther Means of Transportation 
in Turkey</H2> 

<UL> 
<LI><A HREF="#Airports "> Airports</ A> 
<Ll><A HREF="#Maritime Lines">Maritime Lines</A> 
<Ll><A HREF="#Sea Buses (Istanbul only)">Sea Buses (Istanbul only)</A> 
<LI><A HREF="#Inner-city Bus Terminals">Inner-city Bus Terminals</A> 
<LI><A HREF="#Car Rental Offices">Car Rental Offices</ A> 
</UL> 

<H3> Airports</H3> 
<P> Istanbul Ataturk International Airport<BR>(212) 663 64 60<BR> 
Ankara Esenboga International Airport<BR>(312) 398 00 OO<BR> 
Izmir Adnan Menderes Airport<BR>(232) 274 24 05</P> 
<P><H3>State Railways</H3><P>Ankara Operator<BR>(312) 309 
05 15<BR>Istanbul Operator (Sirkeci)<BR>(212) 520 65 75<BR> 
Sirkeci Station Information<BR>(212) 527 00 50<BR>Operator 
(Haydarpasa)<BR>(216) 348 80 20<BR>Haydarpasa Station 
Information<BR>(212) 336 04 75<BR>Haydarpasa Reservation<BR> 
(212) 337 87 24-336 44 70<BR>Izmir Operator (Alsancak)<BR> 
(232) 433 58 97 -421 01 14<BR>Operator (Basmane)<BR>(232) 484 
86 38</P> 
<P> 
<H3>Maritime Lines</H3> 
<P>Istanbul City Ferry Lines<BR>(212) 244 42 33<BR>Maritime 
Lines (Information)<BR>(212) 244 02 07<BR>Maritime Lines 
Mngmnt)<BR>(212) 245 53 66<BR>Maritime Lines Reservations 
<BR>(212) 293 74 54 -<BR>249 92 22<BR>Izmir Alsancak 
Mngmnt)<BR>(232) 421 00 94-<BR>4210077 <BR>Available trips 
(in Turkey )<BR> Istanbul-Izmir<BR> Istanbul-Marmara<BR> Istanbul­ 
Black Sea <BR>Available trips (abroad)<BR>Turkey-North Cyprus 
<BR>Turkey-Italy</P> 
<P> 
<H3>Sea Buses (Istanbul)</H3> 
<P>Bakirkoy (212) 560 72 91<BR>Bostanci (216) 362 04 44 (3 Lines) 
<BR>Kabatas (212) 249 15 58<BR>Kadikoy (216) 336 88 19<BR> 
Karakoy (212) 251 61 44<BR>Kartal (212) 306 20 OO<BR>Yenikapi 
(212) 517 71 37<BR>Yaloa (216) 812 04 99</P> 
<P> 
<H3>Inner-city Bus Terminals</H3> 
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<P>Ankara<BR>(312) 310 47 47<BR>Istanbul Esenier<BR>(212) 
658 00 36 (10 lines)<BR>Istanbul Harem<BR>(216) 333 37 63<BR> 
Izmir<BR>(232) 486 22 66</P> 
<P> 
<H3>Major Bus Companies</H3> 
<P>Bostor Turizm<BR>Istanbul (Taksim)<BR>(212) 251 70 OO<BR> 
Ankara (Kizilay)<BR>(312) 425 72 03 <BR>Pamukkale Turizm<BR> 
Ankara (Terminal)<BR>(312) 433 04 70-433 30 07<BR>Istanbul 
(Taksim)<BR>(212) 245 29 46-249 27 91 <BR>Istanbul Kadikoy) 
<BR>(216) 336 54 13<BR>Istanbul (Esenler)<BR>(212) 658 22 22 
(10 lines)<BR>Izmir (Terminal)<BR>(232) 484 08 00 <BR>Ulusoy 
Turizm<BR>Ankara (Sogutozu)<BR>(312) 286 53 30<BR>Ankara 
(Kizilay )<BR>(3 l 2) 419 40 80<BR> Istanbul (Kadikoy )<BR>(216) 
336 93 66 -345 93 04<BR>Istanbul (Merter)<BR>(212) 547 70 22- 
28<BR>Izmir (Efes)<BR>(232) 441 71 50<BR>Izmir (Karsiyaka) 
<BR>(232) 369 19 66 <BR>Varan Turizm<BR>Ankara Kizilay)<BR> 
(312) 417 25 25<BR>Ankara (Sogutozu)<BR>(312) 287 12 11 (2 
lines) <BR>Istanbul (Taksim)<BR>(212) 2517474 (8 lines)<BR> 
Istanbul (Kadikoy)<BR>(216) 337 29 65 -345 40 81<BR>Istanbul 
(Bayrampasa)<BR>(212) 658 02 70<BR>Izmir (Efes)<BR>(232) 489 
19 17 (3 lines)<BR>Izmir (Karsiyaka)<BR>(232) 3816919</P><P> 
<H3>Car Rental Offices</H3><P><B> A VIS</B><BR> Istanbul<BR> 
Kurucesme<BR>Tel: (212) 257 76 70<BR>(10 lines)<BR>Fax: (212) 
257 56 32<BR>Ataturk Airport Domestic Terminal<BR>Tel: (212) 
573 14 52-573 38 70<BR>ATaturk Airport International Terminal 
<BR>Tel: (212) 663 06 46- 47<BR>Beyazit<BR>Tel: (212) 516 61 09 
-lO<BR>Hilton Hotel<BR>Tel: (212) 241 78 96-2412917<BR> 
Kadikoy<BR>Tel: (216) 355 36 65 <BR>Ankara<BR> Kavaklidere 
<BR>Tel: (312) 467 23 13<BR>Fax: (312) 467 57 03<BR>Esenboga 
Airport Domestic Terminal<BR>Tel: (312) 398 03 15-398 00 00 (Ext: 
1570) <BR>Izmir<BR>Adnan Menderes Airport<BR>Tel: (232) 274 
21 74<BR>Fax: (232) 274 21 72<BR>Alsancak<BR>Tel: (232) 441 
44 17 -18<BR>Fax: (232) 4414420<BR>Hilton Hotel<BR>Tel: 
(232) 441 60 16<BR>Karsiyaka<BR>Tel: (232) 381 63 73 
<BR>Antalya<BR>Antalya Airport<BR>Tel: (242) 330 30 73 - 330 
30 08<BR>Downtown Office<BR>Tel: (242) 241 66 930 <BR>242 
56 42<BR>Fax: (242) 241 94 83</P> 
<P><B> Budget</B><BR> Istanbul<BR> Ataturk Airport<BR> Tel: 
(212) 663 08 58<BR>Downtown Office<BR>Tel: (212) 253 92 00 - 
53 96 53<BR>Fax: (212) 256 26 11 <BR>Ankara<BR>Downtown 
Office<BR>Tel: (312) 417 59 52<BR>Fax: (312) 425 96 08<BR> 
Esenboga Airport<BR>Tel: (312) 398 03 72-<BR>398 0 00 (Ext: 
1730) <BR>Izmir<BR>Adnan Menderes Airport<BR>Tel: (232) 251 
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30 86<BR>Downtown Office<BR>Tel: (242) 243 30 06<BR>(3 
lines)<BR>Fax: (242) 242 50 46</P> 
<P><B> Ekin-Hertz</B><BR> Istanbul<BR> Downtown Office<BR> 
Tel: (212) 234 43 OO<BR>(5 lines)<BR>Fax: (212) 232 92 60 <BR> 
Ankara<BR>Esenboga Airport<BR>Tel: (312) 398 05 85 <BR> 
Izmir<BR>Adnan Menderes Airport<BR>Tel: (232) 274 21 93 
<BR>Adana<BR>Airport<BR>Tel: (322) 436 75 68 <BR> Antalya 
<BR>Airport<BR>Tel: (242) 330 30 23 <BR><B>EUROPCAR 
</B><BR>Istanbul<BR>Taksim<BR>Tel: (212) 254 77 99 - 253 58 
73<BR>Fax: (212) 255 59 28<BR>Airport<BR>Tel: (212) 663 07 46 
-47 <BR>Ankara<BR>Downtown Office<BR>Tel: (312) 416 36 
77<BR>Airport<BR>Tel: (312) 398 05 03- 398 00 00 (Ext: 740)<BR> 
Fax: (312) 417 84 45 <BR>lzmir<BR>Downtown Office<BR>Tel: 
(232) 441 51 41-4415521<BR>Fax: (232) 483 00 3l<BR>Airport 
<BR>Tel: (232) 30 74 <BR>Antalya<BR>Downtown Office<BR> 
Tel: (242) 241 88 79<BR>Fax: (31) 248 35 20 

</BODY> 

</HTML> 
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TURK3.HTM 

<HTML> 

<HEAD> 

<META HTTP-EQUIV="Content-Type" CONTENT="text/html; 
charset=windows-1252 "> 
<META NAME="Generator" CONTENT="Microsoft Word 97"> 
<META NAME="AUTHOR" Content="METIN TASKIN"> 
<META NAME="DESCRIPTION" Content="This about 
TURKIYE"> 
<MET A N AME="KEYWORDS" Content="turkiye,hotel,akdeniz 
antalya,izmir, mersin,giresun,ataturk,trabzon, ofo hotel,hilton,prencess, 
kit tur,ormancilar,sheraton"> 

<TITLE> Turkiye</TITLE> 
</HEAD> 

<FRAMESET COLS = "150,644 " > 
<FRAME SRC="fthl3 .htm" NAME="Frame2002514" 
RESIZE> 
<FRAME SRC="fthr3.htm" NAME="Frame2002533" 
RESIZE> 
</FRAMES ET> 
<NO FRAMES> 

<BODY> 
<P> 
</BODY> 

</NO FRAMES> 
</HTML> 

FTHl3.HTM 

<HTML> 
<HEAD> 

<MET A HTTP-EQUIV=" Content-Type" CONTENT="text/html; 
charset=windows-1252 "> 
<META NAME="Generator" CONTENT="Microsoft Word 97"> 
<META NAME=" AUTHOR" Content="METIN T ASKIN"> 
<META NAME="DESCRIPTION" Content="This about 
TURKIYE"> 
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<MET A NAME="KEYWORDS" Content="turkiye,hotel,akdeniz, 
antalya,izmir, mersin,giresun,ataturk, trabzon, ofo hotel,hilton,prencess, 
kit tur,ormancilar,sheraton"> 

<TITLE> Turkiye</TITLE> 
</HEAD> 
</HEAD> 

<BODY BACKGROUND="CDTSBK.jpg" TEXT="#CCOOOO" 
LINK ="#CCOOOO" VLINK ="#660000" ALINK="#CCOOOO"> 
<P ALIGN="CENTER"><IMG SRC="globe7.gif'' WIDTH="88" 
HEIGHT="88" ALIGN="BOTTOM" ALT="dunya" BORDER="O"> 

<CENTER> 
<B><BLINK></B><A HREF="index.htm" target="_top"><FONT 
F ACE="Arial, Helvetica"><B> WELCOME</ A> </B></FONT><B> 
</BLINK></B><A HREF="index.htm" target="_top"><BR></A> 
<B><BLINK></B><A HREF="index.htm" target="_ top"><FONT 
FACE=" Arial, Helvetica"><B> TURKEY</ A></B></FONT><B> 
</BLINK></B><BR> 
<IP> 
<P ALIGN="CENTER"><IMG SRC="Flagtk.gif'' WIDTH="121" 
HEIGHT="71" ALIGN="BOTTOM" BORDER="O"></CENTER> 
<BR> 
<BR> 
<IP> 
<P><IP> 
<P><BR> 
<IP> 
<P ALIGN="CENTER"><A HREF="turk2.htm" target="_top"><IMG 
SRC="docsleft.gif'' WIDTH="30" HEIGHT="30" ALIGN= 
"BOTTOM"BORDER="O"></A><A HREF= "turkO.htm" target= 
"_top"><IMG SRC="docsupar.gif'' WIDTH="30" HEIGHT="30" 
ALIGN="BOTTOM"BORDER="O"></A><A HREF= "tou.htm" 
target="_top"><IMG SRC="docsrigh.gif'' WIDTH="30" HEIGHT= 
"30" ALIGN="BOTTOM" BORDER="O"></A> 
</BODY> 

</HTML> 
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FTHR2.HTM 

<HTML> 
<HEAD> 

<META HTTP-EQUIV="Content-Type" CONTENT="text/html; 
charset=windows-1252 "> 
<META NAME="Generator" CONTENT="Microsoft Word 97"> 
<META NAME="AUTHOR" Content="METIN TASKIN"> 
<META NAME="DESCRIPTION" Content="This about 
TURKIYE"> 
<MET A NAME="KEYWORDS" Content="turkiye,hotel,akdeniz, 
antalya,izmir,mersin,giresun,ataturk,trabzon, ofo hotel,hilton,prencess, 
kit tur,ormancilar,sheraton"> 

<TITLE> Turkiye</TITLE> 
</HEAD> 

<BODY BACKGROUND="CDTSBK.jpg" TEXT="#660099"> 
<P ALIGN="CENTER"><FONT SIZE="4" COLOR="#330066" > 
<B>Common Expressions and helpful phrases in Turkish:</B> 
</FONT></P> 
<P><FONT COLOR="#330066"><B>Pronunciation</B></FONT> 
<IP> 
<P><B>a:</B> <I>a</I>rt <B>e:</B> b<I>ea</I>r <B>u:</B> 
y<I>ou</I> <B>c:</B> <I>ch</I>art <B>s:</B> <I>sh</I>arp 
<B>k:</B> <I>k</I>ick</P> 
<P><B>o: </B><I>ea</I>rly</P> 
<P><FONT COLOR="#330066"><B>Basics</B></FONT></P> 
<P>Hello: Merhaba Goodbye: Allahaismarladik (said by the person 
leaving)// Gule Gule (Said by the person seeing This/her friend off) 
<IP> 
<P>Good morning: Gunaydin Good evening: Iyi Aksamlar Good 
night: Iyi Geceler</P> 
<P>How are you?: Nasilsiniz? I am well: Iyiyim</P> 
<P>Yes: Evet No: Hayir Please: Lutfen Thank You: Tesekkur ederim 
or Mersi</P> 
<P>There is: Var There is not: Yok both expressions used to express 
availability or lack thereof respectively</P> 
<P>I want...: (object)+ istiyorum</P> 
<P><B> Numbers</B></P> 
<PRE WIDTH="132"><B>l</B> Bir <B>ll</B> Onbir 
<B>30</B> Otuz <B>l00,000</B> Yuzbin <B>2</B> 
Iki <B> 12</B> Oniki <B>40</B> Kirk <B> 1 million</B> 
Bir milyon <B> 3</B> Uc <B> 13</B> Onuc <B>50</B> 
Elli <B> 1 billion</B> Bir milyar <B>4</B> Dort 
<B> 14</B> Ondort <B>60</B> Altmis <B>5</B> 
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Bes <B>15</B> Onbes <B>70</B> Yetmis 
<B>6</B> Alti <B> 16</B> Onalti <B>80</B> 
Seksen <B>7</B> Yedi <B>l7</B> Onyedi 
<B>90</B> Doksan <B>8</B> Sekiz <B> 18</B> 
Onsekiz <B> 100</B> Yuz </B> Dokuz <B> 19</B> 
Ondokuz <B>200</B> lkiyuz <B> 1 O</B> <B>On</B> 
<B>20</B> Yirmi <B> 1000</B> Bin </PRE> 
<P><B>Expressions ofTime</B></P> 
<P>When?: Ne zaman? Yesterday: Dun Today: Bugun Tomorrow: 
Yarin</P> 
<P>Moming: Sabah Afternoon: Ogleden sonra Evening: Aksam Night: 
Gece</P> 
<P>One hour: Bir saat What is the time?: Saat kac? At what time? Saat 
kacta?</P> 
<P><B> The Days of the Week</B></P> 
<PRE WIDTH="132"><B>Sunday</B> <B>Monday</B> 
<B> Tuesday</B> <B> Wednesday</B> <B> Thursday</B> 
<B>Friday</B> <B>Saturday</B> Pazar Pazartesi Sali 
Carsamba Persembe Cuma Cumartesi </PRE> 
<P><B> Travel Terms</B></P> 
<P>Airport: Hava alani Port: Liman Town Center: Sehir merkezi</P> 
<P>Where is it?: Nerede? Is it far?: Uzak mi? Be careful!: Dikkatli 
ol!</P> 
<P>Tourism Bureau: Turizm burosu A good hotel: lyi bir otel A 
restaurant: Bir lokanta</P> 
<P> Hospital: Hastahane</P> 
<P><B>Helpful vocabulary// Hotel &amp; Restaurant</B></P> 
<P>A room: Bir oda A room with a view: Manzarali bir oda Bed: 
Yatak</P> 
<P>Restroom: Banyo Two people: lki kisi The bill: Hesap Water: 
Su</P> 
<P>Mineral Water: Maden suyu Milk: Sut Tea: Cay Coffee: 
Kahve</P> 
<P>Sugar: Seker Breakfast: Kahvalti Fruit juice: Meyva suyu</P> 
<P>Wine: Sarap Beer: Bira Ice: Buz Bread: Ekmek</P> 
<P>Rice: Pilav Chicken: Pilic/ Tavuk Fish: Balik Meat: Et</P> 
<P>Mutton: Koyun eti Lamb: Kuzu eti Beef: Sigir eti Veal: Dana 
eti</P> 
<P><B>Shopping</B></P> 
<P>Shopping center: Carsi Grocery store: supermarket Pharmacy: 
eczane</P> 
<P>How much is this?: Bu ne kadar? It is expensive: Bu pahli It is 
cheap: Bu ucuz</P> 



NEAR EAST UNIVERSTY 
COMPUTER lNQ/NEER/NQ 

1988 

<P> I like it: Begendim I don't like it: Begenmedim Bank: Banka</P> 
<P>Cash machine: Banka matik 
</BODY> 

</HTML> 

TOU.HTM 

<HEAD> 

<META HTTP-EQUIV="Content-Type11 CONTENT="text/html; 
charset=windows-1252 "> 
<META NAME="Generator" CONTENT="Microsoft Word 97"> 
<META NAME="AUTHOR11 Content=11METIN TASKIN11> 
<META NAME=11DESCRIPTION11 Content=This about 
TURKIYE"> 
<META NAME=11KEYWORDS II Content=l'turkiye.hotel.akdeniz, 
antalya,izmir,mersin,giresun,ataturk,trabzon, ofo hotel,hilton,prencess, 
kit tur.ormancilar.sheraton''> 

<TITLE> Tourism</TITLE> 
</HEAD> 

<FRAMESET COLS= 11150,644 11 > 
<FRAME SRC="ftll .htm" NAME="Frame7971125" RESIZE> 
<FRAME SRC="ftrl.htm" NAME="Frame7971152" RESIZE> 
</FRAMES ET> 
<NO FRAMES> 

<BODY> 
<P> 
</BODY> 

</NO FRAMES> 
</HTML> 

FTL1.HTM 

<HTML> 
<HEAD> 

<META HTTP-EQUIV=11Content-Type" CONTENT="text/html; 
charset=windows-1252 "> 
<META NAME="Generator11 CONTENT=11Microsoft Word 9711> 
<META NAME=11AUTHOR11 Content=11METIN TASKIN11> 
<META NAME=11DESCRIPTION11 Content=This about 
TURKIYE11> 
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<MET A NAME="KEYWORDS" Content="turkiye,hotel,akdeniz, 
antalya,izmir,mersin,giresun,ataturk,trabzon, ofo hotel,hilton,prencess, 
kit tur,ormancilar,sheraton"> 

<TITLE>Tourism</TITLE> 
</HEAD> 

<BODY BACKGROUND="CDTSBK.jpg" TEXT="#CCOOOO" 
LINK ="#CCOOOO" VLINK ="#660000" ALINK ="#CCOOOO"> 
<P ALIGN="CENTER"><IMG SRC="Flagtk.gif'' WIDTH="121" 
HEIGHT="71" ALIGN="BOTTOM" BORDER="O"><BR> 
<A HREF ="ant.htm" target="_top"><FONT FACE="Arial, 
Helvetica"><B> ANT ALY A </B></FONT></ A></P> 
<P ALIGN="CENTER"><A HREF="izm.htm" target="_top"><FONT 
FACE="Arial, Helvetica"><B>IZMIR</B></FONT></A></P> 
<P ALIGN="CENTER"><A HREF="gir.htm" target="_top"><FONT 
FACE=" Arial, Helvetica"><B>GIRESUN</B></FONT></ A></P> 
<P ALIGN="CENTER"><A HREF="trab.htm" target="_top"><FONT 
FACE=" Arial, Helvetica"><B> TRABZON </B></FONT></ A></P> 
<P ALIGN="CENTER"><A HREF="trab.htm" target="_top"><FONT 
F ACE="Arial, Helvetica"><B><BR> 
<BR> 
<BR> 
<BR> 
<BR> 
<BR> 
</A><A HREF="turk3.htm" target="_top"><IMG SRC="docsleft.gif'' 
WIDTH="30" HEIGHT="30" ALIGN="BOTTOM" BORDER= 
"O"></A><A HREF="turkO.htm" target="_top"><IMG SRC= 
"docsupar.gif'' WIDTH="30" HEIGHT="30" ALIGN="BOTTOM" 
BORDER="O"></A><A HREF="ant.htm" target="_top"><IMG SRC= 
"docsrigh.gif'' WIDTH="30" HEIGHT="30" ALIGN="BOTTOM" 
BORDER="O"></B></FONT></ A> 
</BODY> 

</HTML> 
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FTR1.HTM 

<HTML> 
<HEAD> 

<META HTTP-EQUIV="Content-Type" CONTENT="text/html; 
charset=windows-1252 "> 
<META NAME="Generator" CONTENT="Microsoft Word 97"> 
<META NAME=" AUTHOR" Content="METIN T ASKIN"> 
<META NAME="DESCRIPTION" Content="This about 
TURKIYE"> 
<META NAME="KEYWORDS" Content="turkiye,hotel,akdeniz, 
antalya,izmir,mersin,giresun,ataturk,trabzon, ofo hotel,hilton,prencess, 
kit tur,ormancilar,sheraton"> 

<TITLE> Tourism</TITLE> 
</HEAD> 

<BODY BACKGROUND="CDTSBK.jpg" TEXT="#CCOOOO" 
LINK ="#CCOOOO" VLINK ="#660000" ALINK ="#CCOOOO"> 
<P ALIGN="CENTER"><FONT COLOR="#CCOOOO" FACE="Arial, 
Helvetica"><B>TOURISTIC PLACES ofTURKEY</B></FONT> 
<IP> 
<P ALIGN="CENTER"><IMG SRC="MAP.jpg" WIDTH="405" 
HEIGHT="189" ALIGN="BOTTOM" BORDER="O" USEMAP= 
"#MAP"></P> 
<CENTER> 
<P> 

<TABLE BORDER="l" WIDTH="lOO"> 
<TR> 
<TD><A HREF="izm.htm" target="_top"><IMG SRC="hilton.jpg" WIDTH= 
"125" HEIGHT="125" ALIGN="BOTTOM" BORDER="O"></A></TD> 
<TD> <A HREF="ant.htm" target="_top"><IMG SRC="falez.jpg" WIDTH= 
"125" HEIGHT="125" ALIGN="BOTTOM" BORDER="O"></A></TD> 
</TR> 
<TR> 
<TD><A HREF="gir.htm" target="_top"><IMG SRC="kittur.jpg" WIDTH= 
"125" HEIGHT="125" ALIGN="BOTTOM" BORDER="O"></A></TD> 
<TD><A HREF="trab.htm" target="_top"><IMG SRC="aksular.jpg" 
WIDTH="125" HEIGHT="125" ALIGN="BOTTOM" BORDER="O" > <IA> 
</TD> 
</TR> 
</TABLE> 

<IP> 
</CENTER> 
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<BLOCKQUOTE> 
<BLOCKQUOTE> 
<BLOCKQUOTE> 
<BLOCKQUOTE> 
<BLOCKQUOTE> 
<BLOCKQUOTE> 
<P><A HREF="ant.htrn" target="_top"><FONT F ACE="Arial, 
Helvetica"><B> ANT ALY A </B></FONT></ A></P> 
<P><A HREF="izrn.htrn" target="_top"><FONT FACE="Arial, 
Helvetica"><B> IZMIR </B></FONT></ A></P> 
<P><A HREF="gir.htrn" target="_top"><FONT F ACE="Arial, 
Helvetica"><B>GIRESUN </B></FONT></ A></P> 
<P><A HREF="trab.htrn" target="_ top"><FONT FACE=" Arial, 
Helvetica"><B> TRABZON </B></FONT></ A> 

</BLOCKQUOTE> 
</BLOCKQUOTE> 
</BLOCKQUOTE> 
</BLOCKQUOTE> 
</BLOCKQUOTE> 
</BLOCKQUOTE> 

<P ALIGN="CENTER"><BR> 
<BR> 
<BR> 
<BR> 
<BR> 
<BR> 
<BR> 
<BR> 
<BR> 
<BR> 
<BR> 
<P> 
<MAP Narne="MAP"><AREA Shape="Circle" coords = "259,48,12" 
AHREF="gir.htrn" target="_top"><AREA Shape="Rect" coords = 
"254,52,318,75" HREF="gir.htrn" target="_top"><AREA Shape= 
"Rect" coords = "277,22,337,46" HREF="trab.htrn" target="_top"> 
<AREA Shape="Rect" coords = "98,136,157,163" HREF="ant.htrn" 
target="_top"><AREA Shape="Rect" coords = "28,86,69,104" A 
HREF="izrn.htrn" target="_top"></MAP> 

</BODY> 
</HTML> 
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ANT.HTM 

<HTML> 

<HEAD> 
<META HTTP-EQUIV="Content-Type" CONTENT="text/html; 
charset=windows-1252 "> 
<META NAME="Generator" CONTENT="Microsoft Word 97"> 
<META NAME="AUTHOR" Content="METIN TASKIN"> 
<META NAME="DESCRIPTION" Content="This about 
TURKIYE"> 
<MET A NAME="KEYWORDS" Content="turkiye,hotel,akdeniz, 
antalya,izmir ,mersin,giresun,ataturk, trabzon, ofo hotel,hilton,prencess, 
kit tur,ormancilar,sheraton"> 

<TITLE> Tourism</TITLE> 
</HEAD> 

<FRAMESET COLS= "151,643" > 
<FRAME SRC="ftil l .htm" NAME="Frame 1327217" RESIZE> 
<FRAME SRC="ftirl.htm" NAME="Frame1327227" RESIZE> 
</FRAMES ET> 

<NO FRAMES> 
<BODY> 
<P> 
</BODY> 
</NO FRAMES> 

</HTML> 

FTIL1.HTM 

<HTML> 
<HEAD> 

<META HTTP-EQUIV="Content-Type" CONTENT="text/html; 
charset=windows-1252 "> 
<META NAME="Generator" CONTENT="Microsoft Word 97"> 
<META NAME="AUTHOR" Content="METIN TASKIN"> 
<META NAME="DESCRIPTION" Content="This about 
TURKIYE"> 
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<META NAME="KEYWORDS" Content="turkiye,hotel,akdeniz, 
antalya,izmir,mersin,giresun,ataturk,trabzon, ofo hotel,hilton,prencess, 
kit tur,ormancilar,sheraton"> 

<TITLE> Tourism</TITLE> 
</HEAD> 

<BODY BACKGROUND="CDTSBK.jpg" TEXT="#CCOOOO" 
LINK ="#CCOOOO" VLINK ="#660000" ALINK ="#CCOOOO"> 
<P ALIGN="CENTER"><IMG SRC="Flagtk.gif'' WIDTH="121" 
HEIGHT=''71" ALIGN="BOTTOM" BORDER="O"><BR> 
<FONT FACE="Arial, Helvetica"><B>ANTAL Y A</B></FONT> 
<IP> 
<P ALIGN="CENTER"><A HREF="izm.htm" target="_top"><FONT 
FACE=" Arial, Helvetica"><B> IZMIR </B></FONT></ A><IP> 
<P ALIGN="CENTER"><A HREF="gir.htm" target="_top"><FONT 
FACE=" Arial, Helvetica"><B>GIRESUN</B></FONT></ A></P> 
<P ALIGN="CENTER"><A HREF="trab.htm" target="_top"><FONT 
FACE="Arial, Helvetica"><B>TRABZON</B></FONT></A></P> 
<P ALIGN="CENTER"><A HREF="trab.htm" target="_top"><FONT 
F ACE="Arial, Helvetica"><B><BR> 
<BR> 
<BR> 
<BR> 
<BR> 
<BR> 
</A><A HREF="tou.htm" target="_top"><IMG SRC="docsleft.gif'' 
WIDTH="30" HEIGHT="30" ALIGN="BOTTOM" BORDER="O" > 
</A><A HREF="turkO.htm" target="_top"><IMG SRC="docsupar. 
gif'' WIDTH="30" HEIGHT="30" ALIGN="BOTTOM" BORDER= 
"O"></A><A HREF="izm.htm" target="_top"><IMG SRC="docsrigh. 
gif'' WIDTH="30" HEIGHT="30" ALIGN="BOTTOM" BORDER= 
"O"> </B> </FONT></ A> 
</BODY> 

</HTML> 

FTIR1.HTM 

<HTML> 
<HEAD> 

<META HTTP-EQUIV="Content-Type" CONTENT="text/html; 
charset=windows-1252 "> 
<META NAME="Generator" CONTENT="Microsoft Word 97"> 
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CONCLUSION 

This project that I produced creates a HTLM program and a WEB 
page. I practised all formulas of HTLM. While I was creating this WEB page I 
used two different Browser. These are; WEB page in OFFICE 97 and Visual 
Page Browser. Both of them were very useful. Specialities and usage of 
Browser will be engaged following pages. 

Because of Turkey is Tourist paradise I preferred to engage with 
touristic hotels that they are beneficial for tourism. 

I like to write about my pages briefly: 
First one is Turkey page. Later again a new Turkey page. Meanwhile 

brief and essential assistant information. From this page it is very easy to enter 
to www.turk.org. and www.turk.org./ata5.html pages. And because I wrote 
about hotels province by province first I gave information about provinces. 
After that brief information from that pages and from hotel pages it is possible 
to enter hotels' page. 

What did I use while I was producing HTLM design and Web pages: 
Links that can be found in every Web page, these are Active Links, 

Hyperlink, I preferred to use them. By using Frame I create page. I used tables 
and Background pictures. To colour writings and creating Turkish flag I used 
Animation gif. Also by assistance of Java program via choosing any region of 
map I used link to another page. 
This is not my whole program that now I present you; this is a very small 
sample and my whole program will take place in Internet with its over 150 
pages context. Then h will be possible to see it by June 1998 in Internet. 
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CHAPTER A 

INTERNET 

Historical Background 
The first computer network became operational in the late 1960's, with USA 

taking a lead with the Department of Defence network ARP ANET, which linked 
research computer from the East to the West Coast, with a link to London to allow 
UK researchers to grew rapidly, and was later split up into three interconnected 
networks, with connections to many other network across the world. This vast 
interconnected network is often referred to as the INTERNET . 

. The Internet is a world - wide system that is currently used mainly by academics 
and scientists, but it is rapidly becoming commercialised due to its incredible success. 
In the early 1980's ways to connect ARPANET to other WAN' s (Wide area 
Networks) e.g. in Europe, were developed. An Internet system can therefore be 
viewed as a set of networks interconnected by Gateways. A GATEWAY is a 
computer that has connections to at least two different networks. The purpose of a 
gateway is to translate the methods used to transfer data an one network into the 
methods used by another network so that data can flow smoothly between different 
types of networks. An Internet system is show is below in Figure 1. 

Network 

G 

Network 
Network 

H 

H= Host Computer G= Gateways 
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Fig.1. An Internet System 

From this early work has grown the system known as the Internet which now 
interconnects sites world wide (literally millions of computers interconnected) There 
are about 100 million people currently using the Internet. By the year 2005. "the 
number of computers attached to the Internet will exceed the world's human 
population" (Computer Journal) of course, growth will slow down, but nevertheless 
the growth is an impressive fact. It is radically changing access to information , news 
distribution, collaboration between people in remote places. The growth of the 
Internet has equalled that of a child by almost doubling insize every year. 

The data available to casual users on the Internet has grown as fast as the 
Internet itself and terabytes. Products have been developed to manage the information 
about data and provide a way of finding the document, program or in general the 
bytes that are wanted. 

Early information was shared with email and ftp. Email is moderately easy to 
use. Information can be passed from one person to another, or groups of people could 
form a mailing list. Originally email was just a text message; it didn't have the 
capability to include programs and data files. 
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Technical Definitions: 

The Internet is very difficult to define. Principally because things change on the 
Internet with great rapidity; definitions that are appropriate at one time have little 
meaning later. However, here are some definitions. 

The Internet is: 
=> A World Wide network of networks as Kevin Hughes defined in "A Guide to 

Cyberspace" 
=> A co-operative interconnection as emphasised by VUNETS "Internet Q&A" 
=> A way to communicate and share resources as described in the "What is the 

Internet?" by the Internet Society. 
=> computers connected using the TCP/IP protocol suite, as specified in the NCSA 

Guide to the Internet. 
Therefore, we can define it as a co-operative global network of computer 

networks that communicate and share resources using the TCP/IP protocol. 
In simple terms, it is the means by which computers in one part of the world 

can communicate with other in parts other of the world as easily as with computers in 
the next room. 

The mechanism for doing this is known as the Internet Protocol(IP) and the 
Transmission Control Protocol(TCP). Together these are commonly known as TCP/IP 
connections. The Internet protocol was first developed when the US Government 
wanted to allow researchers to share computing resources by making them available 
across a network. The military establishment were also involved in this process and 
developed the network on the assumption that there would be break ages in the 
network. Thus the protocol does not rely on the existence of any particular computers. 

When two computers communicate using TCP/IP the message is broken into a 
series of small packets which are sent over the network. The Internet Protocol deals 
with sending the individual packets and the Transmission Control Protocol managers 
the process of putting the packets together again at the other end.(Usually a packet is 
512 bytes) 

TCP/IP is a relatively simple networking protocol and was soon made available 
on most computers, allowing different makes of computers to communicate easily. 
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Computers on the Internet are all given a unique Internet Address. This address 
is used to tell the network where to send its individual packets of data. The Internet 
address is normally written as four digits(between O and 255) separated by dots. 

For example: 158.143.103.60 

this, however is not particularly easily to understand and therefore most 
computers provide a human readable name. This name is again made-up of a series of 
parts. 

For example: VAX.RES.AC.UK 

The process of naming computers is organised in a distributed manner, as there 
is no'central organising committee' for the Internet. Reading from right to left, we see 
that the computer is in the UK and, in particular, in the academic community. There is 
a local organiser for the academic community which distributes names for UK 
academic communities. Similarly , in Turkiye 

Various Protocols 

TCP/IP is simply a method for sending packets of data from one computer to 
another. Internet applications are built up by adding extra protocol layers on top of 
these. These are simply rules that describe the kind of messages that can be sent over 
Internet using TCP /IP. 
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CUSEEME 

This is a relatively new protocol that supports on-line video conferencing over 
the Internet. It does this by allowing a computer, if it has the necessary hardware, to 
use a video camera and sends this picture to other computers on that conference. 
Other computers receive this data and display it locally. The limited amount of 
capacity on many parts of the Internet means that often the picture that is received is 
quite Jerky. 

Network News 

Another protocol is the NNTP protocol. This allows you to read news on a 
variety of topics. Essentially, there is a hierarchy of news groups that discuss various 
subjects. For example: talk.rumors focuses on true and false rumours. Individuals 
read this news and can respond by adding their own messages to the group. 
Soc.culture.turkish is a news list where people can discuss things about Turkiye and 
issues related to the Turkish culture. 

Telnet 

One of the original and still mostwidely used protocols is TELNET. This 
essentially allows you to log on to a computer across the Internet. Anything that you 
type in is sent using the TELNET protocol and the response from the remotecomputer 
is sent back. TELNET normally requires that you have an account on the remote 
computer, but it is also used to provide access to library catalogues. 

FTP 

FTP is related to TELNET and allows you to upload and download files from a 
remote computer. FTP is often done anonymously which allows you to download 
files from computers where you don't have an account. FTP is the most widely used 
protocol for downloading files, but is slowly being replaced by more useably front 
ends. 
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Gopher 

One of the fastest and relatively easy to use protocol is Gopher. When you log 
on to a computer using to Gopher protocol it sends you a list of all the information it 
has. This information is normally in the form of individual files or directories. These 
items are displayed on your own computer and you can then choose the one you want. 
If you choose a directory, the system presents you with all the information in that 
directory. 

The beauty of the Gopher protocol is that the files and directories that are listed 
do not have to be on the same computer. You can select a particular item and will be 
automatically a different part of the Internet to obtain sent that information. 

The World Wide Web 

The Gopher protocol is fast and effective and automatically moves you from 
one part of the Internet to another. It is limited, however to the concept of files and 
directories. Whilst this is easily understood by computer specialist, it is not so intivite 
to non-computer specialists. The world wide web protocol overcomes this by 
presenting the information as normal text document. It also possible to include 
graphics within web documents. Within these documents are hot-links to other parts 
of the document or other parts of the Internet. As with Gopher, these jumps are 
handled automatically and invisibly. 

World wide web documents are often viewed using packages like the Microsoft 
Internet Explorer and Netscape Navigator. 

UNIFORM RESOURCE LOCATORS (URLs) 

URL s are designed to help with all these different protocols Essentially, they 
provide a standard format for specifying the Internet Information you want to use. The 
format is normally: 
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Internet Service: II Internet address /Access information. 
For example: 

http:l/www.wired.com/index.html 
http://www.isoctr.org/ 
http:l/www.hurriyet.com.tr 

In this example, http specifies the protocol (hypertext transaction protocol), 
www.wired.com is the name of the computer and index. html is the file to be loaded 
and displayed . 

Searching the Internet 

The Internet is huge and grawing everyday. It also has no central controller so it 
can be very difficult to find information on the net. In order to solve this problem, a 
number of search engines have been developed. Some well-known search engines are: 

1. Altavista (http:l/www.altavista.digital.com) 
2. Yahoo! (http:l/www.yahoo.com) 
3. Lycos (http:l/www.lycos.com) 
4. Webcrawler (http:l/www.webcrawler.com) 
5. lnfoseek (http:l/www.infoseek.com) 
6. Excite (http:l/www.excite.com) 

These normally work by creating a monthly list of everything they know about 
(for example, all the FTP files in all the FTP sites that are known), indexing these lists 
and allowing people to search these indexes. the results are then displayed in the 
appropriate format. 

ARCHIE 

Archie is the search engine for FTP sites. Archie normally only works on the 
basis of file names and related descriptions and so is best used if you know the name 
of the file you are looking for. 
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VERONiCA and JUGHEAD 

These are two search engines for GOPHER sites. They normally index all the 
worlds in the Gopher descriptions and you can perform Logical searches on them,for 
example, all the Gopher elements that contain both information and security. 

CUI and L YCOS 

Indexing world wide web files in much more difficult but these two facilities 
aim to provide results of web files searches. 

www.neu.edu.nc.tr/engf/index.html 

Image File Extensions on the Internet 

.gif 

.Jpg 

Introduction to HTML Language 

A simple Example 

<HTML> 
<HEAD> 
<META HTTP-EQUIV="Content-Type" CONTENT="text/html; charset=iso- 

8859-1 "> 
<META NAME="Author" CONTENT="metin taskm"> 
<META NAME="GENERATOR" CONTENT="Mozilla/4.02 [en] (Win95; I) 

[Netscape]"> 
<TITLE>index</TITLE> 

</HEAD> 
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<BODY> 
<CENTER><FONT COLOR="#330000"><FONT 
SIZE=+ 2></FONT></FONT></CENTER> 
<CENTER><FONT F ACE="Baskerville Win95BT Tur"><FONT 
COLOR="#330000"><FONT SIZE=+2>AMERICAN 
BIRDS</FONT></FONT></FONT></CENTER> 
<CENTER><FONT F ACE="Baskerville Win95BT Tur"><FONT 
COLOR="#330000"><FONT 
SIZE=+ 2></FONT></FONT></FONT></CENTER> 
<CENTER><FONT F ACE="Baskerville Win95BT Tur"><FONT 
COLOR="#000099"><FONT SIZE=+ l>BIRD 
CLASSIFICATION </FONT></FONT></FONT></CENTER> 
<CENTER><FONT F ACE="Baskerville Win95BT Tur"><FONT 
COLOR ="#000000"></FONT></FONT>&nbsp;</CENTER> 

<OL> 
<LI> 
<FONT F ACE="Baskerville 
COLOR="#OOOOOO">HERONS &amp; 
BITTERNS</FONT></FONT></LI> 

Win95BT Tur"><FONT 

<LI> 
<FONT F ACE="Baskerville 
COLOR="#OOOOOO">DUCK, GEESE 
&amp; SW ANS</FONT></FONT></LI> 

Win95BT Tur"><FONT 

<LI> 
<FONT F ACE="Baskerville Win95BT 
COLOR ="#000000"></FONT></FONT></LI> 

Tur"><FONT 

</OL> 
<CENTER><FONT F ACE="Baskerville 
COLOR ="#000099"><FONT 

Win95BT Tur"><FONT 

SIZE=+ 1 ></FONT></FONT></FONT>&nbsp; </CENTER> 
<CENTER><FONT COLOR="#330000"><FONT 
SIZE=+ 2></FONT></FONT>&nbsp;</CENTER> 
</BODY> 
</HTML> 
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What Software to Use For Writing HTML Programs 

1. Nodepad (under Accessories Directory in win95, also available or win3.1) 
2. Write (available or both win95& win 3.1) 
3. World (any version) (available or both win95& win 3.1) 
4. Netscape Communication 
5. Any other text editor. 

File Extension 

All HTML programs should have either. .htm or html extension. We shall later 
in the course that some files use .shtml extension. 

All image files that you use in your programs should either be in GIF format or 
JPG (also written as JPEG) 

TAG REFERENCE 

Document Formatting 

Tag Description 

<html> HTML document indicator 
<head> Document head 
<body> Document body 
<address> Owner/ Contact 
<title> Title 
<! ... > Comment 
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Paragraph Formatting 

Tag Description 

<blockquate> Blockquate 
<p> Paragraph 
<hr> Line break 
<hr> - Horizontal rule 
<pre> Preformatted text 

Character Formatting 

Tag Description 

<em> Emphasised 
<var> Variable 
<cile> Litation 
<i> Italic 
<strong> Strong 
<b> Bold 
<code> Code 
<samp> Sample 
<kbd> Keyboard 
<tt> Teletype 
<key> Keyword 
<dfn> Dfn 
<strike> Strike through 
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List Formattipg 

Tag Description 

<Ii> List item 
<ul> Unnumbered list 
<ol> ordered list 
<menu> Menu list 
<dir> Directory list 
<di> Description list 
<dt> Data term 
<dd> Data deser 

Anchor Formatting 
Tag Attribute Description 

Anchor hyper link 
href Points to destination of link 

<a> name Defines a named anchor so that a 
link can point to a place in a 
document not just to the document 
itself 
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Tag Attribute Descri~tion and Notes 
<img> 

src 
align 

alt 

ismap 

Incorporates images in a document 
The href for the image 
Aligns text, starting at the top, middle, 
or bottom the side of an image 
A name that can be displayed an 
browser that "' don't have image 
capabilities 
Activates the image so that the browser 
returns a set of x,y cordinates at which 
the image was clicked. 
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Table Formatting 

Tag Attribute Descri_etior, and Notes 
<table > I I Defines the table 

border Adds borders to separate rows and 
colums in tables 

<tr> I I Marks the end/start a table row 
Modifies 

<td> I I Encloses a cell of table data 
colspan Modifies the number of columns a cell 

will span 
rowspan I Modifies the number of rows a cell will 

span 
align I Defines the horizontal text alignment 

within a cell 
nowrap I Declares that the cell text cannot be 

broken up to wrap from one line to the 
text 

<th> I I Encloses a cell of table heading 
colspan Modifies the number of columns a cell 

will span 
rowspan I Modifies the number of rows a cell will 

span 
align I Defines the horizontal text alignment 

within a cell 
nowrap I Declares that the cell text cannot be 

broken up to wrap from one line to the 
text 

<caption> I I Creates a title for the table, outside 

GIF - The graphics interchanges format developed in 1987 by people from 
computer serve. This bitmapped format come into being because people wanted to 
exchanged images between different platforms. 

This format is now used on almost every platform that support graphical 
application. GIF format is not only a standart image type for WWW browser, it is 
also the only image type that can be used for inline images on all platforms. The one 
drawback of GIF format is that it is limited to 256 colours. 
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An extended standard called GIF89A was developed to add functionality for 
specific applications. The most no table use of this extended standard in web pages is 
the use of transparent backgrounds. Images can appear to float by making the 
background colour the same as the background of the browser. However browser 
don't always came with the plain grey background, and the user can override the 
choice of background colour as transparent compensates for the users specific 
configuration. 

JPEG - A bitmap format with compression that was designed and named after 
the Joint Photographic Expert Group: JPEG isn't used as often as the other formats 
but it is the basis for the most common moving image format, MPEG. In addition, the 
newest browser on the block, Netscape communicator row offers support for inline 
JPEG images. 

TIFF - The Tagged Image File Format designed by Microsoft and Aldus for 
use with scanners and desktop publishing programs. Most external viewers support 
this format. 

VIDEO STANDARTS 

MPEG - An animated video standard, format based on the JPEG methods. 
Like JPEG, the format received its name from the group that defined the standard 
Motion picture Experts Group. This is the most common movie format for WWW, 
primarily because viewers exist for all platforms. 

AVI - The movie format for Microsoft Windows. Use of this format isn't 
recommended until browsers for other platforms become common. 
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TCP/IP & INTERNET STRUCTURE 

Introduction: 
Data communication between places is the principle of computing. In the early 

days, this was quite hard. In the late 1970 s, networks have been developed and these 
evolved into host networks that were attached to a single packet-switched network. In 
the middle 1980s, various economic and technological factors have energised that 
made it possible to interconnect many physical networks. This new technology is 
called internetworking, and it hides the underlying details of actual networks, in order 
to provide a uniform service across networks. 

The Internet is an example of open systems interconnection(OSI). In on Internet 
structure, several networks are connected together through the use of gateways and 
Internet working protocol(as discussed earlier). The main advantage of an Internet 
structure is that it provides universal interconnection while allowing individual groups 
to use whatever network hardware is best suited to their needs. 

Network 

G-Gateways 

Network 

Network 
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In addition, the term Internet is used when making a generic reference to a 
network built using internetworking technology and the term Internet is used when 
specifically referring to this network. 

The transmission Control Protocol(TCP) 

The transmission Control Protocol, TCP, defines a key service provided by the 
Internet, namely, reliable, stream delivery and it provides a full duplex connection 
between two machines, allowing them to exchange large volume of data efficiently. 

The internet Protocol(IP), defines the IP datagram as the unit of information 
passed across the internet and provides the basis for connectionless, best-effort packet 
delivery stream. 

Message 

Packet Packet 

The TCP is part of the TCP/IP Internet protocol suite, it is an independent, 
general purpose protocol that can be adapted for use with other delivery systems. It is 
possible to use it over a single network like an Ethernet, which is popular Local Area 
Network(LAN ) technology invented at the Xerox corporation Polo Alto Research 
Centre , as well as over a complex Internet, because TCP makes very few assumptions 
about the underlying network. TCP is one of the International Standards 
Organisation(ISO) open system protocols. 

The most important services that TCP provides for its users include: connection 
orientation, sequencing, security against lost connection orientation, sequencing, 
security against loss connection monitoring, multiplexing, flow control, transparent 
data transport and secure connection establishment, release, IP has the ability to: 
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~ transmit messages over an internetwork. 
~ address each partner uniquely 
~ decompose and recombine packets according to the current network 

convertions. 
~ transmit certain information about the packet sequence and security features 

TCP Service Interfaces 
With its host-to-host communication, TCP/IP support the part/socket concept. A 

host, represented by its various application packages, may be viewed as providing a 
set of sockets, into which the desired connections, which are linked to I/0 ports of 
relevant applications by the main of many be plugged. Some sockets and ports are 
reserved for certain standardised application as shown below. 

PROTOCOL DESCRIPTION WELL-KNOWN PORT 
ARP Address Resolution Protocol - 
AUTH Authentication Service 113 
BO OTP Boot Strap Protocol 67,68 
ECHO ECHO Protocol 7 
FTP File Transfer Protocol 20-21 

GRAPHIC Graphics Exchange Protocol - 
MPM Exchange Multimedia Protocol 46 
LDP Load Debugger Protocol - 
LPR line Printer Protocol 514 
NNTP Network News Transfer Protocol 119 
NFS Network File System 2049 
RJE Remote Job Entry - 
RLP Resource Location Protocol 39 
SMTP Simple Mail Transfer Protocol 25 

TELNET Remote Terminal Protocol 23 
TFTP Trivial File transfer Protocol 69 
UDP User Datagram Protocol - 
X X- window System 6000 

STATSRV Sending Gateway Statics 95 
The most important TCP services are: 

OPEN- Open a virtual connection to a partner or wait until the connection is 
opened by an arbitrary or a specific partner. A time-out condition may be given. 

SEND- Deliver a data buffer to TCP for transmission to the other partner. A 
push flag may be used to force the full data transfer, otherwise the nature of the 
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execution is at the discretion of TCP. An URGENT flag may be used for express 
packets which must receive priority handling. 

RECEIVE- Receipt of data from the partner, with entry of size of the 
available buffer. TCP informs the clients process whether the PUSH or URGENT 
flags were set by the partner. 

CLOSE- Release of a virtual connection. 
STATUS- This service is only of a local nature and its fictions depend on the 

form of the current TCP implementation (in other words, which connection-related 
status/statistical data is made available). 

Connection Establishment 

Connection establishment between two TCP partners is based on the so-called 
"three way hardshake " principle. This mechanism reduces the possibility of the 
establishment of false connections. 

The following error situations may arise. 

=> Simultaneous establishment of a connection by each of the two partners 
involved. 

=> Multiple establishment of a connection by the initiator. Because of a time out 
for the first connection-establishment request. 

=> Unwanted establishment of a connection before the previous connection is 
released. 
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Data Transfer 

Once a connection is established between two partners data packets may be 
exchanged. Since these could be lost or rendered worthless as a result of errors or 
overloading of then network, TCP initiates a transmission repeat after the time-out 
condition expires. 

This way lead to duplicated data packets, which TCP detects using a special 
sequence numbering. 

Sequence Numbering 

Each data octet (8 bits=byte) transmitted by TCP is assigned a sequence 
number. This means that, in principle, the receipt of each octet can be confirmed. This 
is implemented in such a way that the confirmation of octet number n implicitly 
confirms the receipt of cell previous octets. Thus, duplicated segments are detected by 
the receiver and do not require special treatment. Sequence numbers run from O to 
232 -1. 

WINDOWS MECHANISM 

While in other protocols, such as HDLC(High Level Data Link Control) or X25 
level 3, the transmission window relates to the number of packets still to be 
transported from the sender to the recipient, because of the sequential numbering of 
octets, TCP uses a different mechanism. Here, a recent tells the sender the sequence 
number of the last octet which it has sufficient buffer space to receive. Unlike the 
above protocols, this provides for very dynamic management of this window. As soon 
as a recipient has a higher load and, thus possibly less buffer space, it can make this 
known to its partner. 
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Transmission Watchdog 

Each data packet transmitted is monitored so that a transmission repeat takes 
place if no acknowledgement is forth coming within a given interval (retransmission 
time). This interval depends heavily on the network type, the dimensioning of the 
network and the wrens network load. To frequent transmission repeats load the 
network unnecessarily too long a waiting period decreases the throughput possibly 
considerably. Thus, for each data packet, TCP continuously determines the time until 
the expiring of the acknowledgement period and thus is able to reset the 
retransmission timer adaptively. 

TCP Internet Protocol(IP) 

The Internet protocol, IP, defines the unreliable, connectionless delivery 
mechanism. IP provides three important definitions. First, the IP as a protocol defines 
the Internet datagram( or IP datagram). Second, IP software performs the routing 
function. Third, IP includes a set of rules that embody the idea of unreliable packet 
delivery. These rules characterise how hosts and gateway(router) should process 
packets how and when error messages should be generated , and the conditions under 
which packets may be discarded. 

A route is the path that network traffic takes from its source to its destination. IP 
datagram contains a source and destination IP, address, fragmentation controls, 
precedence and checksum used to catch transmission error along with data. In a 
TCP/IP datagram Internet each IP datagram, which is basis unit of information passed 
across a TCP/IP Internet, is may include may gateways and many physical network. 
Both hosts and gateways participate in IP routing. When an application program on a 
hosts attempts to communicate, the TCP/IP protocols eventually generate one or more 
IP datagrams. The host must make a routing decision when it chooses where to send 
the datagrams. 
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Datagram Delivery Over A Single Network 

Transmission of an IP datagram between two machines on a single network 
does not involve gateways. The sender encapsulates the datagram in a physical frame, 
binds the destination IP address to a physical hardware address, and Internetwork 
sends the resulting frame directly to the destination. 

Because the Internet addresses of all machines on a single network include a 
common network id, and because extracting that id can be done in a few instructions, 
testing whether a machine can be reached directly is extremely efficient. 

Internet Address 

Universal Identifiers: 

If a communication system allows any host to communicate with any other host, 
it is said to supply universal communication service. To make our communication 
system universal, we need to establish a globally accepted method of identifying 
computers that are attached to it. A name identifies what an object is an address where 
it is, and a route tells us how get there. Ingeneral pronounceable name to identify 
machines are preferred by the people. 

Three Primary Classes of IP Addresses 

For address, the designers of TCP/IP choose a scheme analogous to physical 
network addressing in which a host on the Internet is a assigned an address called an 
IP address. 

The clever part of Internet address is that Integers are carefully chosen to make 
rating efficient. 

An IP address encodes the identification of the network to which a host attaches 
as well as the identification of a unique host on that network. 

Each host on a TCP/IP Internet is assigned a unique 32-bit address that is used 
in all communication with that host. 
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Each address is a pair. One of the pair netid, identifies a network, and the other 
one, hostid, identifies a host on the network. 

Each IP address must have one of the first three forms shown below. 

0123 8 16 24 31 

Class A lo netid I hostid I Class A> 216 
14 

Class B I, 10 netid I hostid I 256<Class B<216 
28 

Cl ass C I 100 neti d I hostid I Class C < 256 

Class D I 1110 Multi Cost Address 

Class E 111110 Reserved For Future usJ 

An IP address can be determined from the three high order bits in a 
given IP address . Class A addresses are used for networks that have more then 
216(i.e.65.336) hosts. Class A bits devote 7 bits to netid and 24 bits to hostid. Class B 
addresses are used for intermediate size networks that have between 2\i.e.256) and 
216 hosts, and allocate 14 bits to the netid an 16 bits to the hostid. Class C networks 
have less then 28 hosts, and allocated 21 bits to the netid and only 8 bits to the hostid. 

The 32 bit Internet number or IP address is commonly represented as for 
numbers joined by period i.e.145.32.217.130 

The fourth part of this address identifies the host machine, the remainder 
identify the sub-network on which the machine resides. Class C network are typically 
LANs. 

Since users do not usually want to have to remember addresses in the form of 
numbers, a name-to- number service is available, called the Domain Name 
Service(DNS). DNS servers exchange information to allow a user to communicate 
with any other machine on the Internet simply by giving its name. One disadvantage 
of this addressing scheme is that if a host moves to another network, its Internet 
address must change. 

Example: Arpanet->- Class C 
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Difference Between Frames & Tables 

Use frames if you want to preserve the same layout an all your options. No need 
to reload the same section every time you choose an option. User can enlarge or 
arrange individual pages(frames)as required. 

Disadvantage of Frames 

Some browser can not view frames and generate an error messages. To cater for 
this when you create frames some HTML editors enable you to prepare text based 
version of pages using frames. 

Still, tables are more popular than frames. With tables you can produce, 
interesting effect and can use them for obtaining a nice layout. If you cheese border 
thickness=O then people cannot easily understand that you are using tables but this 
allows you to obtain nice layouts. 
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USING WORD PAGE 
WORKING WITH ONLINE AND INTERNET DOCUMENTS 

NAVIGATING 
Go to a page, bookmark, footnote, table, comment, graphic, or other location 
1 On the Edit menu, click Go To. 

Show me 

2 In the Go to what box, click the type of item. 
3 To go to a specific item, type the name or number of the item in the Enter 
box, and then click Go To. 

To go to the next or previous item of the same type, leave the Enter box empty, and 
then click Next or Previous. 

Tip For a quick way to go to the next or previous item, click Select Browse Object 
on the vertical scroll bar, and then click the item you want. You can click Next or 
Previous to go to the next or previous item of the same type. 
Navigate by using hyperlinks 
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When a Word publication or Web page contains hyperlinks to other locations% for 
example, to locations in the same file, or to files on the network or the Internet 
% you can move to these locations by clicking the hyperlink display text or image. 
When you point to the display text of a hyperlink, the pointer becomes a hand . 

In a file or Web page that contains hyperlinks, click the display text or image 
of a hyperlink. 

When a hyperlink is followed % that is, when you click the display text and jump to 
another location% the Web toolbar appears. 

Click Back to return to the original location in your Word publication. 
Click Forward to return to the file whose hyperlink you followed. 

Navigate by using the Document Map 

The Document Map is a separate pane that shows an outline of a document's 
headings. You can use the Document Map to quickly navigate around the document 
and keep track of your location in it. For example, click a heading in the Document 
Map to instantly jump to the related part of the document. 
Word automatically displays the Document Map in online layout view, but you can 
display it in any view. 
) 

1 
2 

Click Document Map 
In the Document Map, click the heading you want to go to. 

Word displays the heading at the top of the page. In the Document Map, the heading 
is highlighted to show your location in the document. 
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WORKING WITH DOCUMENTS ON INTRANENTS AND THE INTERNET 

Documents on the Internet 

If you have access to the Internet (for example, if you have a modem and an Internet 
account through an Internet service provider, or if you are in a corporation and have 
access through the network), you can open documents on the World Wide Web or 
anywhere on the Internet from the Open dialog box in your Office programs. You can 
also add FTP sites to the list of available Internet sites. And if your company has an 
intranet, you can open documents there. In addition, if you have the access rights and 
the FTP site supports saving files, you can save documents to the Internet from the 
Save As dialog box in your Office programs. 

Use Microsoft Excel, Word, PowerPoint, and Microsoft Access to browse Office 
documents that contain hyperlinks, whether the document is on your computer, on a 
network drive, or on the Internet. You don't have to be on the Internet to use 
hyperlinks in Office documents. 
The Web toolbar is available in your Office programs to make it easy to browse 
documents that contain hyperlinks. Use the Web toolbar to open a start page or a 
search page in your Web browser. Also from the Web toolbar, add interesting 
documents you find on the Web to the Favourites folder to gain access to them 
quickly. The Web toolbar keeps a list of the last 10 documents you jumped to by 
using either the Web toolbar or a hyperlink so you can easily return to these 
documents again. 

Add an FTP site to the list of Internet sites 

You can add an FTP site to the list of Internet sites to make it easier to open a 
document at an FTP site. To do this procedure, your company must have an intranet, 
or you must have access to the Internet (for example, you may have access by using a 
modem and an Internet account through an Internet service provider, or through the 
network if you are in a corporation). For information about how to set up Internet 
access, see the Microsoft Office 97 Resource Kit. For information about how to 
obtain the Office Resource Kit, click 

1 Click Open . 
2 In the Look in box, click Add/Modify FTP Locations. 
3 In the Name of FTP site box, type the FTP site name; for example, type 
ftp://ftp.microsoft.com/ 
4 If you want to log on to an FTP site that allows anonymous log on, click 
Anonymous. 
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If you want to log on to an FTP site that you have user privileges for, click User, and 
then type your password. 

5 Click Add. 

Remove an FTP site from the list of Internet sites 

1 Click Open . 
2 In the Look in box, click Internet Locations (FTP). 
3 Right-click the FTP site you want to remove, and then click Remove on the 
shortcut menu. 

Change the logon name or password for an FTP site 

You can change the way you log on to an FTP site. To do this procedure, your 
company must have an intranet, or you must have access to the Internet (for 
example, you may have access by using a modem and an Internet account through an 
Internet service provider, or through the network if you are in a corporation). For 
information about how to set up Internet access, see the Microsoft Office 97 Resource 
Kit. For information about how to obtain the Office Resource Kit, click 

1 Click Open . 
2 In the Look in box, click Internet Locations (FTP). 
3 Right-click the FTP site you want to change, and then click Modify on the 

shortcut menu. 
4 Change the options you want. 
Learn about installing and using Web page authoring tools 

Microsoft Word and some other Microsoft Office programs provide Web page 
authoring tools to help you easily create Web pages for intranets and the World 
Wide Web. If you haven't already installed these tools, you can rerun Set-up to install 
them and to install more Help topics about using them. 
When authoring Web pages in Word, you can use many familiars Word features, such 
as spelling and grammar checking, AutoText, and tables. Some features, such as 
graphical bullets and lines, are customised to make Web authoring easier. Features 
that aren't supported by HTML are not available when authoring Web pages. 

To install the Web page authoring features, select the Web Page Authoring (HTML) 
check box in Set-up. For more information about installing components of Office, 
click . 
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Open the Web start page 

When you start a World Wide Web browser, the start page is the first page that 
appears in the browser. You can set this location to any Web site you want or to a 
document on your computer hard disk. You can open the start page from the Web 
toolbar. A start page may contain hyperlinks to other documents on your computer, 
on the network, or on the Web. 
To do this procedure, you must have the Web toolbar displayed. On the View menu, 
point to Toolbars, and then click Web. 

On the Web toolbar, click Start Page 

Change the Web start page 

To do this procedure, the Web toolbar must be visible. On the View menu, point to 
Toolbars, and then click Web. 

1 Open the document you want to use as the start page. 
2 On the Web toolbar, click Go, and then click Set Start Page. 
3 Click Yes. 

Open the Web search page 

A search page provides an organised way to find and go to other Internet sites or to 
documents on an intranet. Many search pages provide the capability to search by 
topic or by keyword. Others simply provide an well-organised list of hyperlinks to 
selected Internet sites or to documents on an intranet. You can open the search page 
from the Web toolbar. 
To do this procedure, you must have the Web toolbar displayed. On the View menu, 
point to Toolbars, and then click Web. 

On the Web toolbar, click Search the Web 

Change the Web search page 

To do this procedure, the Web toolbar must be visible. On the View menu, point to 
Toolbars, and then click Web. 

1 Open the document you want to use as the search page. 
2 On the Web toolbar, click Go, and then click Set Search Page. 
3 Click Yes. 
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Open recently browsed files 

To do this procedure, you must have the Web toolbar displayed. On the View 
menu, point to Toolbars, and then click Web. To open the previous document in the 
history list, click Back on the Web toolbar. 

To open the next document in the history list, click Forward on the Web toolbar. 

Cancel a jump that takes too long 

To do this procedure, you must have the Web toolbar displayed. On the View menu, 
point to Toolbars, and then click Web. 

On the Web toolbar, click Stop Current Jump 

Refresh the display of the current file or Web page 

When you work in a document on the World Wide Web that contains hyperlinks, 
the author may modify the document while you have it open. When you update a 
document, the document is refreshed from the original file that is located on the 
network server, the Internet, or your computer hard disk. 
To do this procedure, you must have the Web toolbar displayed. On the View menu, 
point to Toolbars, and then click Web. 

On the Web toolbar, click Refresh Current Page 

Add the active document to Favourites 

When you open a document on the Internet, World Wide Web, intranet, or even on 
your computer hard disk, add the document to the Favourites folder so you can open it 
again without having to remember the path you typed to get the document the first 
time. 
To do this procedure, you must have the Web toolbar displayed. On the View menu, 
point to Toolbars, and then click Web. 

On the Web toolbar, click Favourites, and then click Add to Favourites. 

Hide all toolbars except the Web toolbar 

To do this procedure, you must have the Web toolbar displayed. On the View menu, 
point to Toolbars, and then click Web. 

On the Web toolbar, click Show Only Web Toolbar 
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Tip To show the toolbars that are hidden, click Show Only Web Toolbar on the 
Web toolbar. 

I can't open a document on the Internet. 

You must have access to the Internet (for example, you may have access by using a 
modem and an Internet account through an Internet service provider, or through the 
network if you are in a corporation) to open files at an FTP site or on the World 
Wide Web. For information about how to set up Internet access, see the Microsoft 
Office 97 Resource Kit. For information about how to obtain the Office Resource Kit, 
click. 

If you have these things, the site may be too busy. Try to open the document 
later. 

The Web Find Fast search page 

Microsoft Office ships with a search page you can use to find files on the intranet. 
The Web Find Fast search page makes it quick and easy to find a file you know exists 
even when you don't know where it's located. The Web Find Fast search page also 
makes it easy to find all of the information available on any subject. You can also 
quickly locate information outside of your workgroup, such as the quarterly report for 
your company, or all files that refer to company policies. 

To obtain the Web Find Fast search page, see your administrator. 

WORKING WITH HYPERLINKS 

Create hyperlinks 

You can enrich Web pages and Word publications that others read online by 
inserting hyperlinks to other items. The hyperlink can jump to a location in the 
current document or Web page, to a different Word document or Web page, or to a 
file that was created in a different program. You can even use hyperlinks to jump to 
multimedia files, such as sounds and videos. 
The destination the hyperlink jumps to can be on your hard disk, on your company's 
intranet, or on the Internet, such as a page on the World Wide Web. For example, 
you can create a hyperlink that jumps from a Word file to a chart in Microsoft Excel 
that provides more detail. A hyperlink is represented by a "hot" image or display 
text% that is often blue and underlined% that the reader clicks to jump to a different 
location. 
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Use the automatic formatting features for Word documents and Web pages when you 
know the addresses to jump to or when you have a document that contains file names 
or addresses that you want to format as hyperlinks. Use Insert Hyperlink to insert a 
hyperlink into Word files and Web pages when you aren't using the automatic 
formatting features or when you want to browse for the destination address. Use a 
drag-and-drop operation in Word files when you want to use the mouse to quickly 
create a hyperlink for text located within another Office file. 

Change the display text or image of a hyperlink 

You can change the display text or image of a hyperlink % the "hot" text or image that 
a user clicks to follow the hyperlink % as you would edit any text or image in your 
document or Web page. To avoid following the hyperlink, or opening the file you're 
inserting the hyperlink to, it's usually best to use the keyboard to select the image or 
text you want to change. 

1 Click outside of the text or image. 
2 Press the arrow keys until your insertion point is located just to the left or the right 
the image or text you want to change. 
3 Hold downs SHIFT and press an arrow key until the text or image is selected. 

Hold down CONTROL+SHIFT to select whole words. 

4 Edit the image or text. 

Remove a hyperlink 

1 Right-click the hyperlink you want to remove, point to Hyperlink on the 
shortcut menu, and then click Edit Hyperlink. 
2 Click Remove Link. 

Tip To remove a hyperlink and the display text or image that represents the hyperlink 
in the document, select the hyperlink, and then press DELETE. 

Change the appearance of all hyperlinks in Word documents 

This procedure doesn't affect hyperlinks on Web pages. For more information about 
changing text colours in Web pages, click . 

1 Open the document that contains the hyperlinks you want to change. 
2 On the Format menu, click Style. 
3 To change the appearance of a hyperlink, click Hyperlink in the Styles box, 
and then click Modify. 
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To change the appearance of a followed hyperlink, click FollowedHyperlink in the 
Styles box, and then click Modify. 

4 Click Format, and then click Font. 
5 Select the options you want. 

Tips 

To use animated text, click the Animation tab in the Font box, and then click 
the option you want in the Animations box. For instance, you could use Las Vegas 
Lights or Sparkle Text to point out the hyperlinks in your document. 

To use the modified Hyperlink or FollowedHyperlink style in new documents 
based on the same template, select the Add to template check box in the Modify 
Style dialog box. Word adds the modified style to the template attached to the active 
document. 

Change the hyperlink destination 

1 Right-click the hyperlink you want to change, point to Hyperlink on the 
shortcut menu, and then click Edit Hyperlink. 
2 Select the options you want. 

Set a hyperlink base for a document 

When you create a hyperlink in a document, you can make the path to the 
destination of the hyperlink a fixed file location (absolute link), which identifies the 
destination by its full address, such as c:\My Documents\Sales.doc, or you can make 
the path a relative link. Use a relative link if you want to move or copy the file that 
contains the hyperlink or the destination file to a new location. To change the path of 
the relative link, set a hyperlink base for the document. 

1 Open the document you want to set a hyperlink base for. 
2 On the File menu, click Properties, and then click the Summary tab. 
3 In the Hyperlink base box, type the path of the relative link you want to use 

for all the hyperlinks you create in this document. 
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CREATING AND WORKING WITH WEB PAGES 

CREATING WEB PAGES 
Create a Web page 

Word offers two easy ways for you to create Web pages. You can start a new page by 
using a wizard or template, or you can convert an existing Word document to HTML, 
the format used for Web pages. When you create a Web page with either of these 
methods, Word customises some toolbars, menu commands, and options to provide 
the Web page authoring features. 

Using the Web page authoring features to create your Web page will usually produce 
the best results. You can use the Web Page Wizard to start with sample content% 
such as a personal home page and registration form % and graphical themes % such as 
festive and community% to help you quickly creates a Web page. If you prefer, you 
can start with a blank Web page. For information about many of the features you can 
use in Web pages, click . 

Use the HTML conversion method when you have existing Word content that you 
want to quickly convert to a Web page. The formatting and features that are supported 
by HTML will be converted. For more information, click 

What do you want to do? 

Create a Web page from a wizard or template 
Save a Word document in HTML format 

Items you can add to Web pages 

You can make Web pages look more interesting by adding bullets and numbering, 
horizontal lines, background colours and textures, tables, pictures, videos, scrolling 
text, and forms. You add most of these items in much the same way as you do in a 
Word document. However, to make Web page authoring easier, Word offers some 
new and some customised commands for this purpose. 
Obtain more Web page graphics and templates from the Microsoft Web site 

Additional bullets, textured backgrounds, horizontal lines, and templates are available 
on the Microsoft Web site. If you have access to the World Wide Web, you can 
obtain these items to use on your Web pages. 
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Tips for creating Web pages 

There are many opinions about the best way to structure and design Web pages. You 
can find many tips, examples, and style guides on the World Wide Web. Here are 
some tips that apply to most Web pages: 

Content should be well organised. Well-structured pages help you deliver 
ideas effectively and help the reader navigate through your site. For more information, 
click . 

Text on Web pages should be easy to read. If you add a background to your 
Web page, it should contrast with the text colour. For more information, click . 

Web pages may not look the same in different Web browsers. It's a good idea 
to plan your Web pages so they are viewable in most browsers. For more information, 
click . 

Large images increase download time, especially for readers who gain access 
to Web pages by modem. Although graphics can make Web pages more interesting, 
you should use graphics strategically. For more information, click . 

Some users tum off the display of images, and some Web browsers don't 
support all video formats. When images and videos contain information that you don't 
want readers to overlook, you can use alternative text for graphics and alternative text 
and images for videos. For more information, click . 

You can use tables as a layout tool. For example, HTML, the format for Web 
pages, doesn't support newspaper columns, but you can create a two-column effect by 
using tables. For more information, click . 

Add a background sound to a Web page 

You can have a background sound play automatically when someone opens your Web 
page. 

1 On the Insert menu, points to Background Sound, and click Properties. 
2 In the Sound box, enter the address, or URL, of the sound file you want, or 
click Browse to locate the file. 
3 In the Loop box, click the number of times you want the sound to repeat. If 
you want it to loop continually while the Web page is open, click Infinite. 
4 To copy the sound to the same folder as your Web page, select the Copy to 
document folder check box. To use a relative path, a path that's relative to your 
current page, select the Use relative path check box. 

For more information about managing files for Web pages, click 

Notes 
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To review the sound while you are authoring the Web page, point to 
Background Sound on the Insert menu, and then click Play. To stop the sound, click 
Stop. 

For others to hear background sounds, they must have a sound system 
installed, and their Web browser must support the sound format of the file you 
inserted. You can insert sound files in WAY, MID, AU, AIF, RMI, SND, and MP2 
(MPEG audio) formats. 

The background sound plays automatically every time your page is opened or 
returned to. For frequently opened pages, such as home pages, this repetition could 
become annoying. You could add the background sound instead to a page that the 
user is likely to jump too less frequently. Or you could insert a hyperlink that the user 
can click to download a sound file. For more information about inserting hyperlinks, 
click . You may want to use caution when selecting Infinite for a looping option, 
because the sound will play continually when the user opens the page. 

Add a horizontal line to a Web page 

Horizontal lines are used often on Web pages to separate logical sections of text. 

1 Click where you want to insert the line. 
2 On the Insert menu, click Horizontal Line. 
3 In the Style box, click the line that you want, or click More to select a 
different line. 

Notes 

A Web browser will draw the first line in the Style box when someone opens 
the page. The other line styles are graphical images. When you save this Web page, 
the line will be saved as an image, such as image.gif, image 1.gif, in the same location 
as the Web page. If you move the Web page % for instance, when publishing the 
page % you should also move the image of the line. For more information, click . 

To quickly insert another line with the same style, click Horizontal Line 

Add a video to a Web page 

You can add an inline video to your Web page, which means the video is downloaded 
when the user opens the page. You can determine whether the video will play when 
the page is opened or when the user points to the video with the mouse. Because not 
all Web browsers support inline video, you may want to provide alternative text and 
images or avoid presenting essential information in videos. 
It's recommended that you save your document before inserting videos. For more 
information about managing files and links, click . 
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1 On the Insert menu, clicks Video. 
2 In the Video box under Source, type the address or URL of the video file you 
want. Or click Browse to search for the file. 
3 In the Alternate image box, type the address or URL of the graphics file that 
you want to designate as a substitute when the user's browser doesn't support videos 
or when the user turns off the display of videos. 
4 In the Alternate text box, type the text that you want to appear in place of the 

video or alternative image when the user's browser doesn't support videos, 
when the server where the video or image is located is temporarily 
unavailable, or when the user turns off the display of images and videos. 

5 In the Start list, click an option to specify how the video will play on a Web 
page. Open causes the video to play when the user downloads the Web page; Mouse­ 
over causes the video to play when the pointer moves over the video; Both causes the 
video to play in both scenarios. 
6 In the Loop box, enter the number of times you want the video to repeat. 
7 If you want to display video controls, such as "Start" and "Stop," while you're 
authoring Web pages, select the Display video controls check box. 

8 To copy the video to the same folder as your Web page, select the Copy to 
document folder check box. To use a relative path, a path that's relative to your 
current page, select the Use relative path check box. 

Notes 

The video will play after you insert it. If you've selected the Mouse-over 
option for video playback, the video will also play in your Web page document when 
your mouse moves over it. 

Video files can be very large and take a long time to download. For tips on 
reducing the size of images, click . 

You can also insert a hyperlink to a video, which means the user can click the 
hyperlink to download the video and play it. For more information about inserting 
hyperlinks, click . 

Add scrolling text to a Web page 

You can enhance your Web page with scrolling text, which is also known as a 
marquee. 

1 On the Insert menu, clicks Scrolling Text. 
2 Type the text that you want to scroll in the Type the scrolling text here box. 
3 Select any other options you want. 
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Notes 

Scrolling text, or the marquee, is supported in all versions of Microsoft 
Internet Explorer except version 1.0. Some other Web browsers don't support 
scrolling text. In those browsers, the text will appear but it won't scroll. 

To delete scrolling text, select the text, and then click Cut on the Edit menu. 
Set the language for a Web page 

When you are authoring a Web page, you can specify the language of the font, or the 
encoding, that a Web browser will use to display the page. For instance, if you want 
the page to appear with Greek characters, set the language to Greek. You can also set 
a default language encoding for new pages that you create. 

1 On the File menu, clicks Properties. 
2 Under HTML encoding, select the items you want. 

To specify the language code that Word will use to display the page if the 
page is not already displayed with the correct language encoding, click the language 
you want in the For displaying this page list. This setting is also used when loading 
subsequent pages, if the language encoding cannot be determined. 

To specify the language code for saving the page, click the language you want 
in the For saving this page list. 

To specify a default encoding for new Web pages that you create, click the 
language you want in the For creating new Web pages (default encoding) list. 

Notes 

To have Word always save your pages using a default language encoding, 
select the Always save Web pages with default encoding check box. This setting 
affects the current page and future pages that you save. This setting is useful if you 
reuse pages from other sources and want to store every page in one encoding. 

Some languages have more than one encoding scheme. To view the available 
encoding, see the lists under HTML encoding. 

Assign a title to a Web page 

The title appears in the title bar of the Web browser, and if someone stores a link to 
your Web page, the title appears in that person's history list and favourites list. 

1 On the File menu, clicks Properties. 
2 In the Title box, type the title you want. 
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Note If you don't specify a title, Word suggests a title based on the first few 
characters that appear on your Web page. 

Insert HTML mark-up 

Word provides features that help you create a Web page without writing HTML 
source. However, you can also insert your own HTML source code onto a page. 

1 Enter the HTML sources that you want. 
2 Select the source. 
3 In the Style box , NORMAL click HTML Mark-up. 

Notes 

You can also enter the HTML source directly when you are viewing the 
source of a Web page. View the source, and then type the HTML codes that you want. 
For more information about viewing the HTML source, click . 

Applying the HTML mark-up style will format text as hidden. If you need to 
view this text and hidden text is not showing, click Show/Hide 

Create a custom HTML template 

You can create a custom template that you base Web pages on. When you create the 
template, start with the Blank Web Page template, and then modify the template as 
you would any Word template. 

1 On the File menu, clicks New. 
2 Double-click Blank Web Page. 
3 Add any boilerplate text or graphics that you want. 
4 On the File menu, click Save As. 
5 In the Save as type box, click Document Template (*.dot). 
6 Word proposes the Templates folder in the Save in box. To save the template 
so that it will appear on a tab other than General, switch to the corresponding 
subfolder within the Templates folder. 

7 In the File name box, type a name for the new template, and then click Save. 

It is recommended that you give the file a .dot extension. 
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CHANGING THE APPEARANCE OF WEB PAGES 

Learn about formatting Web pages 

When creating Web pages in Word, you can use many of the same formatting tools 
you use for Word documents. For instance, you can click Bold to apply bold 
formatting to text, or you can click Heading 1 in the Style box NORMAL to apply 
a heading style. 
The HTML source that Word creates for the Web page doesn't contain formatting, 
but it contains codes that instruct the Web browser to format text. Word takes care of 
the HTML codes behind the scenes, though, so all you need to do is apply the 
formatting you want. 

Paragraphs will automatically contain space before and after them. To create 
paragraphs with no white space between them, press CTRL+ENTER. 
Formatting that isn't supported by HTML or some Web browsers aren't available in 
the Web authoring environment in Word. This includes the Emboss, Shadow, and 
Engrave character formatting effects, line spacing, margins, character spacing, 
kerning, text flow settings, and spacing before and after paragraphs. Tabs are not 
available because they are displayed as spaces by many Web browsers % to shift the 
first line of text to the right, you can use an indent. 

You can apply bold, italic, underline, strikethrough, superscript, and subscript formats 
to selected text. You can change the size of selected text to font sizes supported by 
HTML. You can click Increase Font Size or Decrease Font Size to quickly switch 
to the next available font size. You can also change the type of font, but keep in mind 
that others viewing your Web pages may not have the same fonts on their systems. 
Also, some Web browsers display text in a default font only. 

You can set the colours for text, hyperlinks, and followed hyperlinks for the entire 
page with the Text Colours dialog box (Format menu). You can change the colour 
of selected text % for instance, a word or a sentence % by clicking Font Colour. 
Setting the default text colours for the page doesn't change text whose colour you've 
changed with the Font Colour button. 

You can indent text in .25-inch increments by clicking Increase Indent and Decrease 
Indent , and you can change the alignment of text by clicking Align Left , Centre , 
or Align Right . However, you can't justify text on Web pages. 
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Learn about tables on Web pages 

Working with tables on Web pages is similar to working with tables in Word 
documents. You can use Draw Table to create and modify the structure for your 
table. You can insert a table grid by using Insert Table. There are some differences in 
how borders are applied and cells are formatted. 
Because tables are often used as a behind-the-scenes layout tool on Web pages% for 
instance, to arrange text and graphics % they do not have borders when you insert 
them. You can add borders to tables on Web pages by using the Border command 
(Table menu). Borders that you apply to tables on Web pages have a 3-D appearance 
in Web browsers. 

You can change the background colour, or shading, of tables by using the Table 
Properties command (Table menu); change the background colour of selected cells 
by using the Cell Properties command (Table menu). 
You can change the height of selected rows and the width of selected columns by 
using the Cell Properties command (Table menu). You can change the way that text 
wraps around the table, the distance between the table and surrounding text, and the 
spacing between columns by using the Table Properties command (Table menu). 

Using tables as a layout tool 

You can use tables with or without borders to add graphical effects and manage the 
layout of your Web page. You can organise columns of graphics and text so that they 
will be aligned together in Web browsers. Without tables, it's difficult to keep 
graphics and text aligned in HTML, the format for Web pages. 
You can use the table drawing tool in Word to help arrange text and graphics. If you 
don't want the border to appear on the finished Web page, remove the border. Even if 
the border is removed, gridlines may appear in your Word document to show the 
table boundaries. To control the display of gridlines, click Hide Gridlines or Display 
Gridlines on the Table menu. These will not appear on the finished Web page. 

Most Web browsers now support tables, but some earlier versions do not. If you 
intend for a broad audience to view the content in the table, you may want to also 
structure your information in text-only format and then provide a hyperlink to the 
text-only version. 
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Set text colours on Web pages 

When creating a Web page, you can determine the default colour scheme for text and 
hyperlinks for the Web page. This setting doesn't change the colour of text whose 
colour was set by applying direct font formatting, for example with Font Colour 

1 On the Format menu, clicks Text Colours. 
2 Select the colours you want in the Body text colour, Hyperlink, and 
Followed hyperlink lists. 

Notes 

Colours you set by using the Text Colours command become the default 
colours for all the text, hyperlinks, and followed hyperlinks. You can apply direct 
colour formatting to selected text by clicking Font Colour . 

Those who view your Web page can set their own default colours in their 
Web browsers. To have the colours of text and hyperlinks appear in the browser 
default colours when viewed in a browser, select Auto in each list. 

Working with styles on Web pages 

You can apply built-in styles that correspond to formatting that's supported by HTML 
on Web pages. You apply styles to text on Web pages the same way you apply styles 
to Word documents, but there are some differences in how styles work. 
When you are creating a Web page, Word adds the HTML styles to the Style box 
NORMAL on the Formatting toolbar and to the Styles list in the Style dialog box ( 
Format menu). One character style, HTML Mark-up, should be used for HTML 
source codes that you want to enter manually. 

The HTML-specific styles, such as Address and H2, correspond directly to an HTML 
tag; any modifications you make to these styles will not be retained. If you modify a 
Word built-in style, such as Heading 1, the formatting associated with the style will be 
exported to a corresponding HTML tag, provided the formatting is supported in 
HTML. 
You can define and modify your own styles. When you save the page as HTML, only 
the HTML-supported formatting is converted % any other formatting is lost when you 
view the page in a Web browser. For more information about formatting on Web 
pages, click . 
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Learn about bullets and numbering on Web pages 

You can create bulleted lists when authoring Web pages, similar to the way you create 
bulleted lists when creating Word documents. One main difference is that you can use 
graphical images in addition to bullet symbols. 
Bullet images are available in the Bullets and Numbering dialog box (Format 
menu) when you create Web pages. Text bullets that are supported by HTML, the 
format for Web pages, are also available. In addition to using the graphical bullets in 
the dialog box, you can click More to use other images as bullets. After choosing the 
image you want, click OK to return to the document. 

When you use images as bullets, the images are saved as GIF (.gif) images (unless 
you insert a JPEG [.jpg] image, in which case the JPEG format is retained) in the 
same location as or in a location relative to your Web page. For more information 
about managing files and links, click . 
When you use images as bullets, you can change the image by using the Bullets and 
Numbering command. Before changing a bullet image, however, you must delete the 
existing bullet images. If you inadvertently apply new bullet images without deleting 
the first images, just delete the first bullet images by selecting them and pressing 
DELETE. 

Some settings for bullets and numbering that are supported by HTML aren't available 
when you author Web pages. For instance, it's not possible to change the distance 
between bullets or numbers and text in the Web authoring environment. 
Numbering on Web pages is similar to numbering in Word documents, except that 
automatic outline and heading numbering isn't available in the Web authoring 
environment. By applying different numbering styles and indents, however, you can 
create a list that appears to have multiple levels. For more information, click . 
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WORKING WITH GRAPHICS ON WEB PAGES 

Learn about working with graphics on Web pages 

The first time you save your Web page in HTML format, all graphics are converted 
to GIF or JPEG format, two image types that are supported on the World Wide 
Web. 
You can insert a graphic on a Web page by pointing to Picture on the Insert menu 
and then clicking From File or Clip Art. If the graphic is in JPG format when you 
insert it, Word saves it in JPG format. If the graphic is in any other type of format, 
such as TIF, Word converts it to GIF format. If you have Internet access, you can 
obtain more graphics from the Microsoft Web Art Page. 

When you insert a graphic from a file, Word copies the graphic to the same folder as 
your Web page when you save the Web page, unless you select the Link to file check 
box. If you select the Link to file check box, you can link to a graphic at a fixed 
location, such as another Web server. 
When you insert a graphic on a Web page, it is aligned with the left margin by 
default. You can control the way text flows around the graphic by selecting it and then 
using the commands on the Format menu and the Picture toolbar. To provide 
additional control over the layout of text and graphics, use a table. 

You can use drawing objects% such as Autoshapes, text boxes, and WordArt 
effects% as Microsoft Word Picture objects. Once you close your document, you 
won't be able to update these items again. They will become static GIF images. For 
more information, click . 
The Picture toolbar in Word is customised to provide alignment commands that help 
you arrange your graphics. The customised Picture toolbar commands are compatible 
with HTML, the format for Web pages. When you select a graphic, the Picture 
toolbar appears. To hide the toolbar, right-click the graphic, and then click Hide 
Picture Toolbar on the shortcut menu. 

Align images on Web pages 

When you insert a graphic, such as a picture, on a Web page, by default the graphic is 
aligned with the left margin, and text does not wrap around it. This procedure changes 
the alignment and the way text wraps. 

1 Select the graphic. 
2 On the Format menu, click Picture, and then click the Position tab. 
3 Under Text wrapping, click None, Left, or Right. 
4 Under Distance from text, enter the amount of distance you want between the 
picture and the surrounding text. 

- 44 - 



NEAR EAST llNIVERSTY 
COMPUTER lNQ/NEER/NQ 

1988 

Notes 

To quickly change the way that text wraps, you can also use the buttons on the 
Picture toolbar. 

Left and right alignment isn't available for graphics in table cells. 
Multiple images cannot appear in the same paragraph with the same 

alignment. 

Learn about creating graphics with transparent areas for Web pages 

You can use Microsoft Photo Editor, which comes with Microsoft Office, to create 
GIF (.gif) images with transparent areas for Web pages. When an image contains a 
transparent area, the background colour or texture of the page "shows through" the 
image. 
If Microsoft Photo Editor is not installed on your system, run Set-up again, and select 
Photo Editor in the Office Tools group. For more information about installing 
components of Microsoft Office, click . 

From Word, you can insert a Photo Editor object, and then apply transparency to the 
background colour. On the Insert menu, click Object, and then click the Create New 
tab. Under Object Type, double-click Microsoft Photo Editor 3.0 Photo. Open the 
graphic or photo you want to apply a transparent area to, and then use the Set 
Transparent Colour tool to apply transparency to the image. 
You can also create a graphic with transparent areas in Photo Editor and then insert it 
into Word. For more information about using Photo Editor, search on the keyword 
transparent areas in the Online Help Index in Photo Editor. 

WORKING WITH FORMS ON WEB PAGES 

Create a form for a Web page 

Forms are frequently used on Web pages to collect and provide dynamic data. Some 
examples are forms that provide data from a database on request, registration forms 
for memberships or events, and forms that help users provide feedback about your 
site. 
Word helps you design the form and set the properties for the form elements. Because 
forms require additional support files and, therefore, additional server support, it is 
recommended that you consult your network or Web administrator when planning the 
form. 
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Sample forms, such as feedback and survey forms, are available from the Web Page 
Wizard. You can use the wizard to create a basic form and then modify it to fit your 
needs. Or if the wizard doesn't contain a form that suits your needs, you can create a 
form by inserting the controls you want. 
1 If the Web Page Wizard contains a form you want to use or modify, run the 

wizard, and choose the form you want. 
How? 
If you are creating a form without using the wizard, use the Blank Web Page 
template. 

2 Click where you want to insert additional controls. 
3 On the Insert menu, point to Forms, and then click the form control you want 

to use. 
4 Double-click the control to display properties for the form. 
5 Enter the properties for the form control using either the Alphabetic or 

Categorised tabs. 
6 Repeat steps 2 through 5 until you've added all the form controls you want. 

So that users can submit the form after filling it in, each form should contain a 
Submit or an Image Submit control. 

7 Add or modify any content that you want. 
8 When you are finished inserting form elements, click Exit Design Mode in 

the Control Toolbox. 

VIEWING WEB PAGES AND HTML SOURCE 

View the HTML source of a Web page 

When you save your Web page, Word works behind the scenes to create HTML tags, 
which Web browsers interpret to display your text, graphics, sounds, and videos. For 
example, when you press ENTER to create a new line, Word converts the paragraph 
mark to a <P>, or paragraph tag, in the HTML source. 
It's usually not necessary to view the HTML source as you author Web pages, but you 
can view it if you like. To view the HTML source, you should first save unsaved 
changes to the file. 

1 Click Save. 
2 On the View menu, click HTML Source. 

Note To return to the Web page, click Exit HTML Source 
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Preview a Web page while authoring it 

In order to preview the Web page you're authoring, you must have a Web browser 
installed on your computer. 

Click Web Page Preview 

Note To switch back to Word, click the Word icon in the task bar, or close the 
browser. 

WORKING WITH WEB PAGES AND WEB AUTHORING TOOLS 

Get the latest version of Web authoring tools 

Microsoft will periodically provide updated versions of the Web page authoring tools 
to keep up with changing technology. If you have access to the World Wide Web, 
Word will periodically check to see if a newer version of the Web authoring tools is 
available on the Microsoft Web site. If a newer version is found, a dialog box appears 
to notify you that a newer version is available. You can choose to download and 
install the latest version. You can also use the AutoUpdate command on the Tools 
menu to manually check for the latest version, if you have a dial-up connection to the 
World Wide Web. 

1 Open a Web page document. 
2 On the Tools menu, click AutoUpdate. 
3 If Word prompts you to download the latest version, click Yes. 

Learn about managing files and links on Web pages 

When authoring Web pages, you should manage the related files and plan the links 
and hyperlinks so the images will appear and the links will "work" once the pages are 
placed on the final HTTP server. In many cases, the location where you create your 
Web pages will be different from the location on which they will be published. For 
more information about publishing Web pages, click . 
When all the files % such as bullets, navigational buttons, background textures, and 
Web pages you create hyperlinks to% will be published on the same Web server, you 
should probably use relative links. Using relative links makes it easier to move 
materials to another location. If you move the files or send them to someone, you 
should maintain the same file structure, including subfolders. 
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For example, your Web page, called Pagel.html, includes bullets stored in the Bullets 
folder, so the relative paths for the bullet files are \Bullets\Bulletl.gif and 
\Bullets\Bullet2.gif. If you move Page I .html, you need to create a folder called 
Bullets in your new location where you can move the Bulletl .gif and Bullet2.gif files. 
When you insert items on your Web page% such as pictures, graphical buttons and 
lines, and hyperlinks to other pages % Word prompts you to save your current file. 
Saving is necessary so that Word can properly create links that are relative to your 
current file. 

Hyperlinks to other Web sites, such as a list of your favourite Web sites, should 
typically use a fixed file location that includes the full path, or URL. To indicate an 
absolute, or fixed, location, clear the Use relative path for hyperlink check boxes in 
the Insert Hyperlink dialog box (Insert menu). 
Images, sounds, and videos can't be embedded in Web pages as they can in Word 
documents. These items are stored in separate files. Word will export embedded 
images and OLE objects in Word documents as GIF images when you save your Web 
page. 

When you apply graphical bullets through the Bullets and Numbering command 
(Format menu), insert graphical lines with the Horizontal Line command (Insert 
menu), or add a textured background with the Background command (Format 
menu), Word saves these items as separate files in the same location as your Web 
page. You'll need to move these files along with your Web pages so your links will 
work, which is necessary for your images to appear. For example, bullets are saved as 
Bullet.gif, Bulletl.gif, Bullet2.gif, and so on; lines are saved as Line.gif and so on; 
and textured backgrounds are saved as Image.gif and so on. 
GIF and JPEG formats are common graphical formats used on the Web. When you 
insert an image that is not in either of these formats with the From File subcommand 
(Picture command, Insert menu), and the Link to file check box is cleared, the 
image will be saved in the GIF format. Word saves the images as Image.gif, 
Imagel.gif, and Image2.gif and so on in the same folder as your Word document. If 
you insert JPEG images, the JPEG format and file name extension (.jpg) is retained. 

Learn about charts, equations, and other objects on Web pages 

You can add charts, equations, and other objects to a Web page, although once you 
close the Web page, you can't update the objects as you can OLE objects. The chart, 
equation, or other object becomes a GIF graphic that you can no longer update. 
Insert a chart, equation, or other object by using the Object command on the Insert 
menu. Just keep in mind that you can't make changes to the object once you close the 
document. If you plan to work with a complex equation or chart that you want to 
continue to update, you can instead store it in a Word document and then paste it onto 
your Web page when you're finished working on it. 
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Make your Web page available to other people 

The steps that you take to make your pages available to other people depend on how 
you want to share them. 
To make pages available to other people on your network, save your Web pages and 
related files, such as pictures, to a network location. If your company uses an intranet 
based on Internet protocols, you may need to copy your pages to a Web server. 
Contact your network or Web administrator for more information. 
To make your Web pages available on the World Wide Web, either you need to locate 
an Internet service provider that allocates space for Web pages, or you need to install 
Web server software on your computer. Some factors to consider in setting up your 
computer as a Web server are your computer's speed and availability. If you don't 
want to leave your computer on most or all hours of the day, then you may not want 
to set up your computer as a Web server. 

If you are working with an Internet service provider or a Web administrator, you 
should ask how the Web pages, graphics files, and other files should be structured on 
the server. For instance, find out whether you need to create separate folders for 
bullets and pictures, or whether you need to store all the files in one location. If you 
plan to use forms or image maps, you should ask about any limitations on using these 
items, because they require additional server support. 

Setting up a Web server requires special software. You can use Personal Web Server, 
which is available on the Office 97 ValuPack on CD-ROM, to set up a Web server. 
You can also use Microsoft Internet Information Server to set up an advanced Web 
server. If you have access to the Web, you can learn more about Microsoft Internet 
Information Server. 

The differences between Word and Microsoft FrontPage for Web authoring 

Web page authoring tools are provided with Microsoft Word and with other Microsoft 
Office programs to enable you to easily create various types of Web pages. Another 
Microsoft program, called FrontPage, also helps you create various types of Web 
pages by using an interface that's similar to other Office programs. FrontPage also 
helps you to manage a Web site. 
To create Web pages, you can use the Web page authoring tools in Microsoft Word, 
Microsoft FrontPage, or both. Both programs provide wizards to automate your work, 
and both enable you to view your Web page content % such as bullets and images % 
as you work. There are some purposes, however, for which one program is better 
suited. 
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Use Web page authoring tools in Microsoft Word when: 

You want to use the robust word-processing features in Word, such as 
automatic spelling checking, AutoText, and AutoCorrect. 

Other Web page authors whom you work with frequently use Word. 
You have customised Word features% such as AutoText, custom dictionaries, 

and AutoCorrect entries% that you want to use when creating Web pages. 

Use FrontPage when: 

You want to use WebBot to insert scripts and form elements, such as server 
includes and timestamps. 

You are working with a large team or managing a Web server. 
You need user authentication for Web page authors. 

Note In the Microsoft FrontPage Explorer, you can specify Word as your default 
editor for HTML files. See FrontPage documentation for more information. 

I can't find Web page authoring tools. 

To use the Web authoring features in Word, you must use a Web page template or 
wizard, or convert an existing document to HTML, the format used for Web pages. 
When the Web authoring features are active, you'll notice that the toolbars and menus 
have been customised for working on Web pages. 
The Web templates are on the Web Pages tab in the New dialog box (File menu). To 
convert a document to HTML, click Save as HTML on the File menu. 

If you don't see the Web Pages tab, the Web features may not be installed. You may 
need to run Set-up again and select Web page authoring components. For more 
information, click . 

I can't find Web page files to open them. 

Once you have used the Web page authoring tools, your Web page files% those with 
.html, .html, .asp, or .htx extensions % appear by default in the Open dialog box (File 
menu). Before you use the tools, you can get Web page files to appear in the list by 
clicking All Files in the Files of type box. 
For more troubleshooting information about opening files, click . 
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USING VISUAL PAGE 
USING BASIC FEATURES 

Creating a new Web page 
There are essentially two kinds of Web pages you may create: a Web page with 
frames or a Web page without frames. A Web page with frames can display the 
contents of a different Web page in each of its frames. Like a picture holder that has 
multiple frames for displaying multiple pictures simultaneously, a framed Web page 
can display multiple Web pages simultaneously. A Web page without frames simply 
displays one Web page file. To continue the previous comparison, a Web page 
without frames is like a single picture frame that displays one photograph. 

To create a new Web page: 

1 From the File menu, selects New (or press Control-N). 
A new, untitled Web page opens in Edit mode. 

2 Add graphics, text, plugging, links, and Java applets directly to your new Web 
page. 
3 Save your Web page in a folder dedicated to your collection of Web pages. 

To create a Web page that includes frames: 

1 From the File menu, chooses New Frame Set. 
Visual Page displays a Web page, which is divided into two frames of equal 

size. 
2 You may directly add the text, HTML tags, graphics, and plug-ins to each 
frame, or you may open an existing Web page file in a frame. For more information, 
see Setting the frame source . 
3 Save your Web page in a folder dedicated to your collection of Web pages. 
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Setting the frame source 

A Web page with frames, also known as a frame set, can display multiple Web pages 
by having a different Web page assigned to each frame. You can set a frame to 
display a particular Web page by using the Set Frame Source menu item to assign a 
particular Web page HTML file to the selected frame. 

To set the source file for a frame: 

1 Make sure a frame is selected in an open Web page. 
2 Select Frame > Set Frame Source. 

A standard Open file dialog box displays. 
3 Navigate to and select the HTML files you want the selected frame to display. 
4 Click open. 

A Visual Page Frame Save dialog box displays. 
5 Save the changes to the frame. · 

If you have not given the frame a name, a Save As dialog box displays. 
6 Enter a name for the frame and save it. 

Visual Page displays the Web page in the selected frame. 

Starting from an existing Web page 
The standard Visual Page installation places several professionally designed templates 
in your Visual Page directory. You can use these pre-existing Web pages as the basis 
for your own Web pages. Opening a Visual Page template is the same procedure you 
will use to open a Web page on which you have previously worked. 

To open an existing Web page: 

1 Select Open from the File menu (or press Control-0). 
2 Navigate to the directory where the file you want to work on is located. 
3 Select the file, and click Open. 

The Web page opens in Edit mode. 

Saving a Web page 

When you save a Web page file and name it, make sure that you preserve the HTML 
filename extension. All Web page files must end with a .html or .html filename 
extension. Visual Page's default filename extension is .html. You can change the 
default filename extension in the Preferences dialog box. 
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To save a Web page without frames: 

1 From the File menu, chooses Save or if you want to save a copy of a file with 
a different name, choose Save As. 
2 Navigate to the destination folder for the saved file. 
3 Enter the file name. 

Visual Page includes the default file extension. 
4 Click Save. 

The file is saved to the destination folder. 

Overview of preferences 

Visual Page provides a variety of preferences settings that you can use to customise 
your Web page building environment. If you choose Preferences from the Edit menu 
the Preferences dialog box displays. It includes tabs for: 

1 Setting General Preferences 
2 Setting Output Preferences 
3 Setting Images Preferences 
4 Setting Folder Mappings Preferences 
5 Setting FTP Preferences 
6 Setting Syntax Colour Preferences 

Setting Page Default Preferences 

Use the Page Defaults tab of the Preferences dialog box to set defaults preferences for 
every new page you create with Visual Page. If you want to restore these preferences 
to the default settings, click Use Defaults. If you want to change back to the settings 
that were in place before you opened this dialog box, click Revert. 

To set Page Default preferences: 

1. From the Edit menu, choose Preferences. 
The Preferences dialog box appears. 

2. Click the Page Defaults tab. 
3. Use the dialog box to select the page default preferences you want. 

The preferences are listed below. 
4. When you're finished setting preferences, click OK. 
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* Background sets the default background colour. 
Normal Text sets the default colour for normal text/ 
Normal Links sets the default colour for normal links/ 
Active Links sets the default colour for active links. 
Visited Links sets the default colour for visited links. 
Background Image You can have each new page use a default image as a 
background. 

* 
* 
* 
* 
* 

1 Click the checkbox or click the ellipses. 
The Open dialog box appears. 
Locate the image you want to set as a default background. 
Click Open. 
The selected image appears in the Image Preview window. 
Click OK to make the image the default background image. 

2 
3 

4 

Previewing your work 

To see how your Web page will look in a browser, use the Preview Mode. You'll 
know you're in Preview Mode when the Edit Page toolbar button is active and the 
Preview Page toolbar button is inactive. 

To go to Preview Mode: 

1 From the Edit menu, choose Preview Page. If instead you see Edit Page, you 
are already in Preview Mode. 

2 You can also click the Preview Page tool bar button. 

Printing Web pages 

Using Visual Page, you can print your Web pages as they will appear in a browser. If 
you want to print out the HTML source, make sure that the Source Window is active. 

To print a Web page: 

1 From the File menu, selects Print (or press Control-P). 
2 Select the desired print options. 

Visual Page prints your document. 
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ADDING TEXT 

Adding text 

Adding text to your Visual Page documents is very similar to inserting text using any 
standard word-processing application. The following procedures explain how to insert 
and format text. 

You can insert text by: 

Typing text 
Dragging and dropping text 
Copying and pasting text 
Importing a plain text file 

You can format text by: 

Generating paragraphs and line breaks 
Aligning and indenting paragraphs 
Formatting paragraphs 
Formatting characters 
Creating bulleted lists 
Creating ordered lists 
Creating term and definition lists 

Typing text 

If you have ever used a word processor to create a text document, you probably know 
how to type text into a Web page in the Visual Page environment. Visual Page 
supports all the standard text operations. 

To insert text by typing: 

1 Make sure that you're in Edit mode. 
For information on switching to Edit mode, see Previewing your work. 

2 Within the main Edit window, moves the text cursor to where you want to 
insert text. 

3 Single-click at the insertion point. 
4 Type in your text. 

The text displays on the Web page. 
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Dragging and dropping text 

Visual Page supports drag-and-drop functionality in many ways. It is an extremely 
handy way to move text from one location to another. Visual Page also allows you to 
insert other objects, such as images, from the Windows Explorer into Visual Page. 

To insert text by drag-and-drop: 

1 Make sure that you're in Edit mode. 
For information on switching to Edit mode, see Previewing your work. 

2 Make sure that the files that you want to drag to and from are open. 
3 Select the text you wish to move. 
4 Click on the selection, and, without releasing the mouse button, move the 

selection to the new location. 
5 Release the mouse button. 

The text is now in the new location. 

To insert other objects into Visual Page: 

1 Make sure that you're in Edit mode. 
For information on switching to Edit mode, see Previewing your work. 

2 Locate the object ( e.g. image) you want to insert with the Windows Explorer. 
3 Press and hold the Control key while dragging the object from Explorer into 

Visual Page. 
When you release the mouse and control key, the Save As dialog box appears. 

4 At this point, you can rename the object, or click OK to use the default name. 
The object is added to your page. 

Importing a plain text file 

This feature allows you to instantly fill your Web page with the text from a text file. 

To insert text by importing a plain text file: 

1 Make sure that you're in Edit mode. 
For information on switching to Edit mode, see Previewing your work. 

2 Position the cursor where you want the text to display. 
3 Using the Local Site window, select the plain text file. 

For more information see, Opening a Local Site window. 
4 Drag the plain text file from your Local Site window and drop it on your Web 

page. 
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The contents of the text file displays on your Web page. 

Using the Spelling Checker 

You can check the spelling in your page at any time by clicking the Spelling Checker 
icon. The Spelling Checker checks the spelling in the entire page, but does not check 
spelling of words that you highlight. The functions available are: 

1 Ignore skips the current word and continues spell checking. 
2 Ignore All skips all instances of this word. 
3 Add places the current word into the dictionary. 
4 Change replaces the current word with the word in the Change To window, or 

to the word that is highlighted in the Suggestions window. 
5 Change All replaces all instances of this word with the word in the Change To 

window or to the word that is highlighted in the Suggestions window. 
6 Suggestions automatically provides a list of alternatives to the current word. 
7 Edit Dictionary opens the Personal Dictionary. In the personal dictionary, you 

can add, modify, or delete entries. 
8 Cancel exits the Spelling Checker, but does not cancel any previous spelling 

changes made with the Spelling Checker. 

FORMATING CHARACTERS 

Formatting characters 

You can format individual characters to make words display differently, rather than 
affecting a whole paragraph. You can format individual characters by changing 
character styles or character size. 

To apply a character style: 

1 Select the character: 
2 From the Style menu, choose a style, colour, or size. You can also select a 

style, colour, or size by clicking one of the tool bar buttons. 

Physical character styles include the following standard HTML styles: 

The Bold, Italic, and Fixed Width Font styles can be quickly accessed by these toolbar 
buttons: 

Visual Page also supports these Netscape extensions to standard HTML character 
styles: 
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How these styles will appear depends on each browser's default settings. 

Changing character size 

The size of text in a Web page is relative to the default size setting for each browser. 
This is why the font .sizcs in the Size menu item (on the Style menu) are relative 
numbers 1 through 7, instead of the point sizes you see in a word processor, such as 
12 or 14. 
Visual Page uses the middle font size (number 4) as the "normal" font size. This is the 
browser's default display font. The other numbers signify either a smaller or larger 
font than the browser default, with 1 being the smallest font size and 7 the largest font 
size. 

To change the size of a character: 

1 Click Decrease Font Size or Increase Font Size on the toolbar. You can also 
choose Size from the Style menu, and then choose a number. 

A checkrnark displays next to the selected size. 

Working with fonts 

Visual Page allows you to use the fonts that are installed on your system to enhance 
the look of your Web pages. However, not all fonts are cross-platform compatible, 
and may not display correctly on other platforms. 
You can work with fonts in three ways in Visual Page by: 

Changing fonts 

You can change the font of selected text in your Web page to any other available font. 

To change a font: 

1. Highlight the text in your page that you want to change. 
2. Click on the Font pull-down menu. 

The list of available fonts appears. 
3. Select the new font that you want to apply. 

The font of the highlighted text changes. 
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Creating font groups 

Font groups are groups of fonts that usually have some common characteristic to 
preserve the original design of the Web page. Font groups allow the Web browser to 
substitute fonts from a group of assigned fonts when one or more fonts are not 
available on the client machine. When no font in a group is available on the client 
machine, the Web browser uses default fonts available on the client machine. 

With Visual Page you can create and assign font groups that make your pages look 
their best across different platforms and browsers. 

To create a font group: 

1. From the Font pull-down menu, select Font Groups. 
The Font Groups window opens with the names of default font groups. 

2. Click a blank cell in the Group Name column and enter a name for the new 
font group. 

3. Click the Font Names cell and enter font names separated by a comma. 
4. Click the OK button when you are finished entering font names. 

The font group is added to the Font pull-down menu. 
You can also assign a font group on the fly. 

Assigning font groups 

You can assign font groups in your Web page to allow the Web browser on the client 
machine to substitute fonts when the original font is not available. 

To assign a font group: 

1 Highlight the text to which you want to apply a font group. 
2 From the Font pull-down menu, select a font group. 

The selected font group name appears in the pull-down menu and is applied to the 
highlighted text. 

- 59 - 



NEAR EAST UNIVER9TY 
COMPUTER ENQ/NEER/NQ 

1988 

WORKING WITH PARAGRAPHS 

Generating paragraphs and line breaks 

Paragraphs and line breaks generate different effects in the display of your Web page. 

Use a line break instead of a standard new paragraph if you want to create a space 
between lines without applying the previous paragraph's formatting. You can also use 
multiple line breaks to display multiple lines without text, However, a paragraph 
marker cannot generate multiple empty lines in a Web browser because HTML 
specifications allow only one empty paragraph line. 

To generate a new paragraph: 

1 Place the insertion point where you want the new paragraph to start. 
2 Press the Return key. 

Your cursor goes to a new line and Visual Page generates a paragraph tag in 
the HTML source. 

To create a line break: 

1 Click where you want the new paragraph to start. 
2 Press Shift-Return. 

Visual Page generates a line break (<BR>) tag in the HTML source. 

Aligning and indenting paragraphs 

You can make paragraphs line up against the left margin, the right margin, or the 
centre of the Web page by setting paragraph alignment. You can also format by 
indenting paragraphs. 

To align a paragraph: 

1 Click anywhere within the paragraph. 
2 Click on one of these three alignment tool bar buttons: . The choices are left 

aligned, centre-aligned, and right aligned, respectively. You can also choose, 
from the Format menu, Align Left, Align Right or Align Centre. 
The paragraph aligns according to the alignment option you choose. 
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To indent a paragraph: 

1 Click anywhere within the paragraph. 
2 Click on one of these two indent paragraph tool bar buttons: . The choices are 

Decrease Indent and Increase Indent , respectively. You may also choose 
Format > Increase Indent or Format > Decrease Indent. 
The paragraph indent changes. 

Formatting paragraphs 

Apply paragraph formats to make sections of text display differently, such as 
~eadings, quotes, and mono-spaced (preformatted) text. Visual Page supports these 
paragraph formats: 

Normal 
Headings 
Pre formatted 
Address 

To apply a format to a paragraph: 

1 Click anywhere in a paragraph. 
2 Choose a format from the pop-up menu on the toolbar, or from the Format 
menu. 

Visual Page formats the paragraph accordingly. 

Normal paragraph style 

Normal text is the default style, which is applied when you begin a new paragraph on 
a blank page. (The paragraph you are reading now is formatted with the Normal tag.) 
The text appears flush left in the page window and is displayed in the Visual Page 
default font. 
Use the Normal style for most text in a Web page. 

Heading paragraph style 

Heading tags are used to make headlines or titles distinct from the rest of the text in a 
page. In general, headings are larger than the Normal style, and are in a bold typeface. 
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Heading 1 
Heading 2 
Heading 3 
Heading 4 

Heading 5 

Heading6 

You may also manually specify the font size of a text block instead of using the 
Heading style. 
The heading types supported by Visual Page are: 

Preformatted paragraph style 

uses multiple spaces and tabs, such as the formatting found in code segments. 

Preformatted paragraphs are displayed in moonscape fonts, such as Courier. You can 
see an example of a preformatted paragraph in the following HTML code sample: 

Address paragraph style 

Web page authors typically apply the address style to a paragraph containing a 
signature address. An example of how it is used is shown below: 
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Send comments to the author: 

webmaster@symantec.itools.com 

Choosing to include an address is a matter of style. When you include an address, 
remember to make it an email link. 

CREATING LISTS 

Creating bulleted lists 

Bulleted lists are useful when you want to make some information easy to see. Visual 
Page supports bulleted lists and indented bulleted lists. 

To create a bulleted list: 

1 Select the text you want to change to bulleted list style. 
2 From the Format Paragraph drop-down list on the toolbar, select Bullet List. 

You can also select Format> List> Bullet. 
Visual Page indents the text and places a bullet character to the left of the text 

in the paragraph. 
3 You can apply indentation to the bulleted list by using the Increase Indent 
toolbar button to a bulleted paragraph. 

When you apply added indentation to a bulleted paragraph, the look of the 
bullet changes with the indentation. 

Creating ordered lists 

When you apply any of the ordered list formats to a paragraph, Visual Page indents 
the text and places a number or letter to the left of the paragraph. 

To create an ordered list: 

1 Select the desired text. 
2 Select Format> List and choose the desired type of ordered list. 

To create a numbered list: 

1 Select the desired text. 
2 Click the paragraph tag drop-down list on the toolbar, and select the 
Numbered List tag. 
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Creating term and description lists 

The term and description formats are designed to be used together in lists of 
definitions. The format is similar to what you would find in a Glossary. 
Applying the Term format to a paragraph places the paragraph text flush left at the 
left margin. When you press the return key after applying a Term format to a 
paragraph, Visual Page automatically applies the Description format, then indents the 
text of the paragraph. 

To create a term and description list: 

1 Select the text which you want in the term format. 
2 From the paragraph tag drop-down toolbar button select Term. 

The selected paragraph displays in the Term format. 
3 Select the text, which is to be in the definition format. 
4 From the paragraph tag drop-down toolbar button select Definition. 
5 Repeat steps 1-4 for the remaining terms and definitions. 

USING GRAPHICS AND IMAGE MAPS 

Adding graphics 

You can add graphics to your Web pages by either using drag-and-drop, the Insert 
Image toolbar button, or copy and paste. Graphics must be in BMP, DIB, GIF, or 
JPEG graphic format before you can insert them into a Web page. Visual Page 
automatically converts .bmp and .dib files into interlaced GIF files when you place 
them in your Web page. There is a setting in the Image Preferences for storing the 
new GIF files from these conversions. 
To add a graphic by using drag-and-drop: 

1 Open the Local Site Window, and navigate to the desired graphic's location. 
2 Select desired graphic file, and drag it over to your Web page. 

The image appears full size in your Web page. 

You can also drag and drop graphics from another open Web page, as long as the 
browser supports drag and drop. 
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To add a graphic by using Insert Image: 

1 Place your cursor at the desired location. 
2 Click on the Insert Image button ,or choose Image from the Insert menu. 

A standard Open file dialog box opens. 
3 Navigate to the graphic file you want, and click Open. 

The image displays in your Web page. 

To add a graphic by using copies and paste: 

1 Copy a selected graphic to your clipboard. 
2 Paste it into your Web page. 

The image displays in your Web page. 

Aligning graphics and text 

You can align graphics in a variety of ways. Using graphic alignment settings you can 
also flow text around graphics. You can see a good example of how to format images 
with text in the Visual Page Getting Started tour. 
To align graphics: 

1 Use the Graphic Alignment button on the Visual Page toolbar. You can also 
choose Graphic Alignment from the Settings menu. 

2 Select the graphic alignment you want. 
In general, use the first three options, Top, Bottom, Middle, for small graphics 
that appear in a line of text, like the image in step one. You use the Left and 
Right alignment options when you want to flow a paragraph of text around a 
larger graphic. 

To flow paragraphs of text around graphics: 

1 Select the graphic. 
2 Select Left from either the Graphic Alignment toolbar button, or choose 

Object Alignment from the Format menu. 
3 Insert your cursor to the right of the graphic and enter a paragraph or two of 

text. When the line wraps it returns to the right edge of the graphic, until it 
reaches the bottom of the graphic. 
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Creating transparent graphics 

This feature is useful if your Web page has a coloured background, which is obscured 
in part by an opaque graphic image. In this case, you could use Visual Page to make 
the image transparent so the background colour would show through. Only GIF files 
can be made transparent. 

To make your image transparent: 

Open the graphic file. For more information, see Opening a graphic image file. 
The graphic displays in the Visual Page's graphic editor. 

2 Click the transparency toolbar button on the Image Tools Toolbar. 
3 Click any colour in the image and that colour is rendered transparent. 

When you put the altered graphic in a Web page, you see the Web page's 
background through the image. 

2 To revert a transparent graphic and thus remove the transparent quality, click 
the Remove Transparency toolbar button on the Image Tools Toolbar. 

Setting graphic image properties 

Visual Page supports a range of attributes that are contained within any supported 
graphic. These attributes control the height, width, function, alternate text, and 
spacing around a graphic. 

To set a graphic image's properties: 

1 Make sure that you're in Edit mode. 
For information about how to switch to Edit mode, see Previewing your work. 

2 Select a graphic in a Web page. 
3 From the Edit menu, select Properties, then choose Image Properties. 
4 Use the options in the Image Properties dialog box to set the graphic' s 

attributes. These attributes are described in the table below. 
5 Click OK. Your graphic's settings are adjusted accordingly. 
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Attribute 
Image 
Width 

Height 
Original width 
Original Height 
Horizontal 

Vertical 

Border 

Image 

Has server map 

Submit form button 

Alternative text 

Button name 

Creating image maps 

Description 
The location and filename of the image file. 
The display width of the image, in pixels. Visual Page supports 
image scaling (changing an image's height and width). The 
width and height indicated in the Image Setting dialog box are 
the dimensions of the image as scaled in the HTML file. The 
actual dimensions of the image are indicated in the Original 
Width and Original Height fields, as described below. 
The display height of the image, in pixels. 
The width of the source images, in pixels. 
The height of the source image, in pixels. 
The blank space to the left and right of the image, in pixels. 
The default setting is zero. 
The blank space to the top and bottom of the image, in pixels. 
The default setting is zero. 
The width of the border around an image, in pixels. An image 
border is black and is similar to a frame around a painting. The 
default setting is zero, which indicates no border. 
Select this option if the graphic file functions only as an image. 
This is the default function for graphic files. 
Check this box if the graphic file acts as a server-side image 
map. 
Select this option if the graphic file acts as submit button for a 
form. 
If you type in text here, it displays in a user's browser if the 
image doesn't load properly, or if it can't be displayed by a 
user's browser. Note: The alternative text option is not for 
graphic files that function as a form submit button. 
(For buttons only) The name of the button. This is NOT the 
same as the name of the button's source file. A CGI script uses 
this name as an ID. 

Client-side image maps store the co-ordinates that define the linked areas of an image. 
These image maps are inserted directly into the HTML file. As such, the image map is 
downloaded to and referenced entirely from the user's machine (hence the name 
client-side). Visual Page creates these Image maps for you as you use drawing tools to 
outline and link areas of an image. 
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To create a client-side image map: 

1 Make sure that you're in Edit mode. For information about how to switch to 
Edit mode, see Previewing your work. 

2 Insert a graphic by clicking the Insert Graphics tool bar button. For information 
on inserting graphics, see Adding graphics. 

3 Right-click on the graphic and select Local Map Tools or select View > 
Toolbars > Image Tools from the menus. 

4 The Image Tools toolbar displays. 
5 Create the clickable areas of the image by doing the following: 

Click the rectangle, circle, or polygon Hotspot buttons on the toolbar. 
Click and drag on the graphic file to create a hotspot area. 
To end creating a polygon hotspot, double-click. To end creating a circle or 
rectangle hotspot, release the mouse button. 

6 Create the URL for each of the clickable areas. 

You can do this by either dragging a file or anchor icon from the Local Site window 
onto the selected link area, typing the link address into the Link field at the bottom of 
the main edit window, or right-clicking on the desired link location to open the Link 
To dialog box. You may also double-click on the hotspot to open the Link To dialog 
box. 

To move overlapping hotspots: 

1 Select a hotspot you want to move forwards or backwards. 
2 Click the Front-to-back Order button on the Image Tools toolbar. 
3 Choose Move to Front, Move Forward, Move to Back, or Move Backwards. 

The hotspot will change position. 

To delete hotspot areas: 

Select the hotspot area, and press Delete. 
To save your client-side image map: 
Select File> Save or press Ctrl+ S. 
To make the shapes easier to see, specify the colour of these areas by choosing the 
desired colour from the colour menu button. 
You may also use the Zoom buttons to adjust the graphic to the optimal size for 
outlining links. 
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Setting Images preferences 

Use the Images tab of the Preferences dialog box to set the Visual Page preferences 
described below: If you want to restore these preferences to the default settings, click 
Use Defaults. If you want to change back to the settings that were in place before you 
opened this dialog box, click Revert. 

To set images preferences: 

1 From the Edit menu, chooses Preferences. 
The Preferences dialog box appears. 

2 Click the Images tab. 
3 Use the dialog box to select the Images preference options you want. The 

preferences are listed below. 
4 When you're finished setting preferences, click OK. 

Converted Images Visual Page automatically converts .bmp and .dib files into 
interlaced GIF files. The following options tell Visual Page 
where to place the new GIF files.n Always store the new GIF 
file in same folder as the source documentn Use this image 
folder 

Default Image Map Server Format Visual Page supports server-side image 
maps if you need to use them. The two Server-Side image map 
formats are either CERN or NSCA. 

Setting Image properties 

By using the Image properties dialog box you can: 

1 Resize your image -this is handy if you have an image you want to use more 
than once in your Web site and want to optimize its size for the different 
locations 

2 Adjust the space around an image - this adds a fixed number of pixels of space 
horizontally or vertically around the image. Or, you could opt to create a 
border of space around the whole image. You might want to add space around 
an object when it is embedded in some text or has text flowing around it 

3 Change the function of your image- besides functioning as inert object, images 
can be set to work with an image map, so links can be embedded in the image, 
or as a Submit button which you would provide on a Web page form to 
transmit data in response to a user's click 

3 Alternative text - it's a god idea to provide a short caption which browsers that 
don't display graphics will display instead of the graphic 
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Creating a background 

You can create a coloured or tiled background for your Web page. 
To create a coloured background: 

1 In an open Web page document, click on the Page Properties toolbar button. 
2 Choose a colour from the Background colour well. If you want the 
background set according to each browser's default settings, select Default. 

Using a graphic file to tile your Web page background: 

1 In an open Web page document, click on the Page Properties toolbar button. 
2 Click the Background Image checkbox. 

An Open File dialog box appears. 
3 Navigate to the graphic file you're going to use, then click Open. 

A representation of the tiled graphic appears. 
4 Check the appearance of the tile on your Web page by clicking on the Apply 

button. A graphic may look interesting by itself, but may not be appropriate 
for use as a tiled background. 

To remove a background image: 
Uncheck the Background Image checkbox. 

Adding horizontal lines 

Horizontal lines can be useful layout tools, which can be used to break up a long Web 
page. However, they should be used sparingly or your Web page will appear to be 
choppy. Horizontal lines are easy to add in Visual Page and you may even play with 
their appearance by setting their properties. 

To add a horizontal lines: 

1 Place your cursor where you want the line to be inserted. 
2 Click the Insert Horizontal Line toolbar button. 

To change the properties of a horizontal line: 

1 Select a horizontal line by clicking directly on it.. 
2 Choose Edit > Properties > Line Properties ( or press F 4 ). 

The Line Properties dialog box displays. 
3 Set the shading, size, and alignment using the dialog box. 
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CREATING LINKS AND ANCHORS 

Creating links and anchors 

Hypertext links, also known as links, are one of the most important parts of a Web 
page. Links allow you to connect Web pages together. 

The following topics tell you more about creating and using links in your Web pages: 
Creating links with the Create Link dialog box 
Creating links with the Link Toolbar 
Creating links with the Site Window 
Copying an existing link 
Creating email links 
Creating and linking anchors 
Tes ting links 
Creating image maps . 

Creating links with the Create Link dialog box 

You can create a link to a selected object by using the Create Link dialog box. Using 
this dialog box, you can either enter the URL yourself or browse to locate the file 
you're linking to so Visual Page will generate the URL. 

To create a link with the Create Link dialog box: 

1 Select the object to be linked. 
2 Click the Hyperlink button in the Insert toolbar. The Link dialog box displays. 
3 Determine the file to be linked by either typing in the filename or URL of the 

file, or by clicking Browse and navigating to the file you want. 
Your link is created. 

Creating links with the Link Toolbar 

The Link Toolbar displays at the bottom of the Visual Page window. It consists of a 
label and a text field. 

- 71 - 



NEAR EA91 tlNIYER9TY 
COMPUTER ENQ/NEER/NQ 

1988 

To create a link using the Link Toolbar: 

1 Select the object to be linked. 
2 At the bottom of the Edit window, select the Link to field in the Link toolbar. 

If you do not see the Link to field at the bottom of the Edit window, select 
Toolbars > Link to make the link field display. 

3 Type in the filename or URL in the Link to edit box. 
4 Pressing Return and your link is created. 

Creating links with the Local Site Window 

You can use the Local Site window to drag-and-drop files on selected objects in your 
Web page to create a link. 

To create a link using the Local Site window: 

1 Open a Local Site window for your current project. 
For more information see Opening a Local Site window. 

2 Select the text or graphic image on your Web page that you want to link. 
3 Drag the file or anchor you want to link to from the Local Site window and 

drop it on the selected object. 

Copying an existing link 

If you want multiple links to the same place, such as to a home page, you can create 
the link once and copy and paste the rest of the links. 

To copy an existing link: 

1 Select the link you wish to copy. 
2 From the Edit menu, choose Copy (or press Control-C). 
3 Click where you want the link to be copied to. 
4 From the Edit menu, choose Paste (or press Control-V). 

Creating email links 

When an email link is clicked on, the browser opens up a pre-addressed email 
message window. 
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To create an email link: 

1 Create the link text that will display on a Web page. For example: 
user@company.com 

2 Highlight the link text. 
3 Click on the Link to: field and enter the text in the following format: 

mailto:user@company .com 
4 Replace user with the email address of the person being emailed, and 

company .com with there Internet address. 

Creating and linking anchors 

Anchors are used to mark specific locations within a document. Once an anchor is 
placed in a location, you can create a link to that spot. 

To add an anchor to a Web page: 

1 Click in your Web page where you want to put the anchor. 
2 Select on the Insert Anchor button in the Insert toolbar or select Insert > 

Anchor. 
The Anchor Properties dialog box displays. 

3 Name the anchor, and click OK. 
An anchor icon appears in your text. 

4 Select the object to be linked to the anchor. 
5 Click Create Link button in the Insert toolbar or right Click and select Link to. 

The Link to dialog box appears. 
6 Select the anchor from the drop down list box and click OK. 

The link to the anchor is displayed next to the object. 

Testing links 

You should test your links periodically to make sure they work. It's easy to break links 
when you're constructing Web pages. Since links are really URLs which record the 
location of a file or anchor, you can break a link by inadvertently changing the name 
of a file or of the folders in which the file resides. 
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To test links in your Web pages, use one of the following methods: 

1 In Edit Mode, hold down the Control key while clicking over the link. This 
opens the linked file. 

2 From the Edit menu, choose Preview in Browser. Your Visual Page document 
opens in the Web page browser which resides on your hard disk. You can then 
browse your document as you would any Web page. 

3 From the Edit menu, choose Go To Preview Mode. You can browse and click 
while still within Visual Page. 

USING FRAMES 

Creating frames 

Frames divide the parts of a Web page into two or more independent parts (frames), 
each displaying a separate HTML file. 
To create a Web page that includes frames: 

1 Choose File> New Frame Set or press Ctrl +Shift+ N. 
Visual Page displays a frame file with two frames of equal size. 

2 You may directly add the text, HTML tags, graphics, and plug-ins to each 
frame, or you may open an existing Web page file in a frame. For more 
information, see Setting the frame source. 

3 Save your Web page in a folder dedicated to your collection of Web pages. 
For more information, see Saving a Web page with frames. 

Additional Frame Set functions include: 

Opening a frame in a new window 
Setting a frame's attributes 
Setting the frame target 
Resizing a frame 
Removing a frame 
Splitting frames 
Editing the No Frames settings 

Editing the No Frames setting 

The No Frames window lets you specify what content will display when a user's 
browser doesn't support frames. 
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To use the No Frames window: 

1 Open the main frame file. 
2 Choose Frame > No Frames Page. 

The No Frames page displays. 
3 Enter or edit the content of the page. 
4 Close the No Frames page. 

Opening a frame in a new window 

If you have many Web pages which are accessed through the same Web page with 
frames you may want to navigate your Web site in Preview mode. When you see a 
displayed file that needs editing, opening a frame into a separate window makes it 
easier to edit the Web page. 

To open a frame file in a new window: 

1 Open the main frame file. 
2 Select the frame to be opened in a new window. 
3 Choose Frame> Open in New Window. 
The frame file opens in a new window. 

Removing a frame 

If you add too many frames to your Web page you can use the following procedure to 
remove the selected frame. 

To remove a frame: 

1 Open the main frame file. 
2 Select the frame file to be removed. 
3 Choose Frame > Remove Frame. 

Resizing a frame 

Resizing a frame can be done visually on the Web page by dragging frame borders or 
via the Frame Properties dialog box. 

- 75 - 



NEAR EA91 t/NIVER9TY 
COMPUTER ENQ/NEER/NQ 

1988 

To resize a frame: 

1 Use the resize bar to resize the frame manually. You can also choose Edit> 
Properties > Show Frame Properties, and enter the desired width in the Width 
field. 

Setting the frame source 

A Web page with frames, also known as a frame set, can display multiple Web pages 
by having a different Web page assigned to each frame. You can set a frame to 
display a particular Web page by using the Set Frame Source menu item to assign a 
particular Web page HTML file to the selected frame. 

To set the source file for a frame: 

1 Make sure a frame is selected in an open Web page. 
2 Select Frame > Set Frame Source. 

A standard Open file dialog box displays. 
3 Navigate to and select the HTML files you want the selected frame to display. 
4 Click open. 

A Visual Page Frame Save dialog box displays. 
5 Save the changes to the frame. 

If you have not given the frame a name, a Save As dialog box displays. 
6 Enter a name for the frame and save it. 

Visual Page displays the Web page in the selected frame. 

Saving a Web page with frames 

A frame set, or Web page with frames, has more than one HTML Web page file 
associated with it. The frame set file contains information about the Web page that 
contains the frames. And, each frame displays its own separate HTML file. So, when 
you save a frame set you probably will be prompted to name more than one Web page 
file. Visual Page's default filename extension is .html. You can change the default 
filename extension in the Preferences dialog box. 

To save a Web page frame set: 

1 From the File menu, chooses Save Frame Set. 
Or, if you want to save a copy of a frame set file with a different name, choose 
Save Frame Set As. 

2 In the Save or Save As dialog box, navigate to the destination folder for the 
frame set and select it. 

3 Enter a filename with a .html or .html extension. 
4 Click the Save button. 
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If you made changes to any of the frames in your frame set, the Save Frame or 
Save Frame As dialog box displays. 

5 If asked, enter a name for the frame file, and click Save. 
If you made changes to other frames, another Save Frame or Save Frame As 
dialog box displays. 

6 Enter names and click Save until all the changed frame files are saved. 

Setting a frame's attributes 
<See Also> 

Frames have a set of properties you can set. Most of these can be changed as you 
visually edit the page. The frame properties are described below. 

To edit a frame's properties: 

1 Choose Edit> Properties > Show Frame Properties. 
2 The Frame Properties dialog displays. 
3 Use the options in the Frame Properties dialog box to set the frame's 

attributes. 
These attributes are described in the table below. 

4 Close the Frame Properties dialog. 

Attribute 
Source 
Frame titles 

Frame width 

Frameset height 

Margin width 
Margin height 
Show scrollbar 

Resizable frame 

Definition 
The HTML source file for a frame. 
The frame's name. This is NOT the same as the name of the 
source file. The frameset file (the file that contains the frames 
within a frame set) uses this name as an ID. 
The width of the selected frames, either as a percentage of the 
total frame set, or in pixels. 
The height of the frame set, either as a percentage of the total 
frame set, or in pixels. 
The width of the selected frame's margin, in pixels. 

The height of the selected frame's margin, in pixels. 
The settings for the frames scroll bars. Possible choices are 
Yes, No, and Auto. The default is Auto, which makes the scroll 
bars appear only when the frame extends beyond the length of 
the active window. 
Indicates whether or not the selected frame resizes along with 
the user's browser. The default is checked, which indicates that 
the selected frame will resize 
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Setting Frame properties 

Use the Frame properties to set the properties which pertain to a selected frame of a 
frame set. Use the Frame properties dialog box to check, assign, or change these 
values. 

To set frame properties: 

1 Select the frame whose properties you are setting by clicking once anywhere 
in the frame. 
A heavy black border outlines the frame. 

2 Choose Edit> Properties > Show Frame Properties. 
The Frame Properties dialog box displays. 

3 Set the properties as they are described below. 

The frame property settings: include the following: 

Source Name of the HTML file which you want to display in this 
frame, for instance, HomeTOC.html is an appropriate value. 
Title for the frame, otherwise Visual Page uses the random 
number shown as the default in this field. 
Width of the margin. 
Height of the margin. 
This only applies if there are frames below other frames in the 
frame set. 
Specifies the thickness of the frameset border. Set to O for 
borderless frames. Leave it empty to use the default border 
thickness. 
Defaults to automatically showing scrollbars when they're 
needed. 
Checked by default, if you don't want people to change the size 
of a frame, uncheck it. 

Frame title 

Margin width 
Margin height 
Frameset height 

Frameset Border 

Show scrollbars 

Resizable frame 

Setting the base target for a frame 

Visual Page allows you to select a base target for all the links in a frame. An example 
of using a base target is to direct all the hypertext links in a left-hand frame to appear 
in the neighbouring right-hand frame. 
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To set a base target for the links in a frame: 

1 Open a frame set, and make sure the frames are already named and saved. 
2 Make sure that you're in Edit mode. 

For information about how to switch to Edit mode, see Previewing your work. 
3 Click on the frame you are setting as a base target. 
4 Choose Edit > Properties > Page. 
5 Click the Select Base Target button. The Base Target dialog displays. 
6 Click a frame in the reproduction of your frame set. Set a base target for that 

frame by selecting one of the Base Target options. 
The Base Target options are described below. 

7 Click OK to set the base target for the selected frame. 

Tip: To set the base target for additional frames in your frame set, repeat steps 6 and 
7 for each frame. 

Base Target option 
Default 

New window 
Same frame 

Same window 

Parent window 

Splitting frames 

Description 
Makes the linked file display in the same frame as the current 
frame file. This is the default setting. How the default setting 
performs depends on each browser's configuration. 
Makes the linked file display in a new, untitled window. 
Makes the linked file display in the same frame as the current 
frame file. 
Makes the linked file display in the same window as the current 
frame file. 
Makes the linked file display in the parent window of the 
current frame file. The parent window is the window that was 
active, then a link opened which caused the current frame file 
to display. 

Visual Page lets you add frames by splitting existing frames into two equal parts, 
either horizontally or vertically. 

To split a frame: 

1 Open the main frame file. 
2 Select the frame to be split. 
3 Choose Frame > Split Frame Vertically or Frame > Split Frame Horizontally. 

The frame is split. 
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CREATING TABLES 

Creating tables 

Tables can hold all kinds of Web page elements and are useful in formatting and page 
layout tasks. You can easily create tables in Visual Page. 
To create a table in a Web page: 

1 Place the cursor where you want the table to display. 
2 Click the Insert Table toolbar button on the Insert Toolbar or choose Insert> 

Table > Table. 
The Table Settings dialog box displays. 

3 Set the number of rows and columns for your table. 
4 Click OK. 

The new table displays. 

You can also perform the following tasks: 
Inserting rows 
Inserting columns 
Deleting rows 
Deleting columns 
Changing multiple cells 
Resizing rows, columns and tables 
Spanning rows and columns 
Adding colour to tables 

For information on setting the attributes of a table, see Table settings. 

Inserting rows 

You can have Visual Page insert a new row either before or after the one in which you 
placed the insertion point. 

To insert a row after the current row: 

1 Place the cursor where you want the row to be inserted. 
2 Choose Insert > Table > Row. 

The row is inserted. 

- 80 - 



KEAR EAST UKIVERSTY 
COMPUTER lNQ/NEER/NQ 

1988 

To insert a row before the current row: 

* Choose Insert > Table > Row Before. The row is inserted below the current 
row. 

Inserting columns 

Visual Page allows you to insert a column to the right or left of the column in which 
you placed the insertion point. 

To insert a column to the right of the current column: 

1 Place the cursor where you want the column to be inserted. 
2 Choose Insert> Table> Column. 

The column is inserted. 

To insert a column to the left of the current column: 

* Click Insert > Table > Column Before. A column is inserted to the left of the 
current column. 

Deleting rows 

In Visual Page you can designate a row to be deleted. 

To delete a row or rows: 

1 Select a row or set of rows to be deleted. 
2 Choose Insert> Table> Delete Row 

The row(s) are deleted. 

Deleting columns 

Visual Page allows you to delete multiple columns. 

To delete more than one column: 

1 Select a column or set of columns to be deleted. 
2 Choose Insert> Table > Delete Column 

The column(s) are deleted. 
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Changing multiple cells 

Visual Page allows selection of multiple adjacent cells. Any selected set of cells may 
be formatted by applying the following: 

Paragraph formatting 
Paragraph alignment 
Character formatting 

Resizing rows, columns, and tables 

You can customise tables by changing the size of rows, columns, or the table. 
To resize a row or column: 

1 Place the pointer over the border of the row or column you want to resize. 
The pointer changes to a resizing cursor. 

2 Click on the row or column's border and drag the mouse until the row or 
column is the size you want. 

3 Release the mouse button. 
The row or column displays at the new size. 

To resize a table: 

1 Select the table to be resized. 
2 Click on the resizing handle (a square box) at the bottom right comer of the 

table and drag the mouse until the table is the size you want. 
3 Release the mouse button. 

The table displays at the new size. 

Spanning rows and columns 

Sometimes you want a cell in a table to span across multiple rows or columns. 
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To set a cell to span across multiple rows and/or columns: 

1 Click on the cell that you want to enlarge. 
2 Choose Properties> Table Properties or press F4. 

The Table Properties dialog displays. 
3 Click on the Cells tab. 
4 Enter the number of columns that you want the cell to span in the Span across 

columns field. 
5 Enter the number of rows that you want the cell to span in the Span down rows 

field. 
6 The cell now spans across the specified number of rows and columns. An 

example of a table with a spanned cell is shown below: 

Adding colour to tables 

You can use Visual Page to set the background colour of a cell or an entire table. 

To change a cell's background colour: 

1 Select one or more cells. 
2 Choose Properties> Table Properties or press F4. 

The Table Properties dialog displays. 
3 Click the Cells tab. 
4 Select the colour you want from the Cell background colour palette. 

If you want to create a custom colour, click Custom. 

To change a table's background colour: 

1 Select a table. 
2 Choose Properties> Table Properties or press F4. 

The Table Properties dialog displays. 
3 Click the Table tab. 
4 Select the colour you want from the Background colour palette. 

If you want to create a custom colour, click Custom. 
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Table Settings dialog box 

This dialog box displays when you insert a table. 

Entire table 
number of rows 
number of columns 
space around text 
space between cells 
table width 
table height 
border width 
caption placement 
background colour 
For more information about table properties, see Setting Table properties and Setting 
Cell properties. 
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Harvester of Sorrow 

(Hetfield/Ulrich) 

My Life Suffocates 
Planting Seeds of Hate 
I've Loved, Turned to Hate 
Trapped Far Beyond My Fate 
I Give 
You Take 
This Life That I Forsake 
Been Cheated of My Youth 
You Turned this Lie to Truth 

Anger 
Misery 
You'll Suffer unto Me 

Harvester of Sorrow 
Language of the Mad 
Harvester of Sorrow 

Pure Black Looking Clear 
My Work Is Done Soon Here 
Try Getting Back to Me 
Get Back Which Used to Be 
Drink up 
Shoot in 
Let the Beatings Begin 
Distributor of Pain 
Your Loss Becomes My Gain 

Anger 
Misery 
You'll Suffer unto Me 

Harvester of Sorrow 
Language of the Mad 
Harvester of Sorrow 

All Have Said Their Prayers 
Invade Their Nightmares 
See into My Eyes 
You'll Find Where Murder Lies 
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Harvester of Sorrow 
Language of the Mad 
Harvester of Sorrow 
Language of the Mad 
Harvester of Sorrow 
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UNTIL IT SLEEP 
(Hetfield , Ulrich) 

Where do I take this pain of mine 
I run, but it stays right my side 

So tear me open, pour me out 
There's things inside that scream and shout 
And the pain still hates me 
So hold me, until it sleeps 

Just like the curse, just like the stray 
You feed it once, and now it stays 

So tear me open, but beware 
There's things inside without a care 
And the dirt still stains me 
So wash me, until I'm clean 

*It grips you, so hold me 
It stains you, so hold me 
It hates you, so hold me 
It holds you, so hold me 

Until it sleeps** 

So tell me why you've choosen me 
Don't want your grip, don't want your greed 

I'll tear me open, make you gone 
No more can you hurt anyone 
And the fear still shakes me 
So hold me, until it sleeps 

*--** Repeat 

I don't want it 

So tear me open, but beware 
The things inside without a care 
And the dirt still stains me 
So wash me, 'till I'm clean ... 

I'll tear me open, make you gone 
No longer will you hurt anyone 

Tuesday, June 02, 1998 0:34 PM 
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And the fear still shapes me 
So hold me, until it sleeps ... 

Until it sleeps ... 

!'LinkExchange 

Tuesday, June 02, 1998 0:34 PM 



ACCESS METALLICA - Metallica lyrics for load - Microsoft Internet Explorer Page 1 of 2 

;'Please visit our sponsors. 

I 

r> 

MAMA SAID 
(Hetfield, Ulrich) 

Mama she has taught me well 
Told me when I was young 
Son, your life's an open book 
Don't close it fore it's done 
The brigtest flame burns quickest 
Is what I heard they say 
A son's heart's owned to mother 
But I must find my way 

*Let my heart go 
Let your son grow 
Mama let your heart go 
Or let this heart be still 

Rebel my new last name 
Wild blood in my veins 
Apron strings around my neck 
The mark that still remains 
Left home at an early age 
Of what I heard was wrong 
I never asked forgiveness 
But what I said is done 

* Repeat 

**Never I ask you 
But never I gave 
But you gave me your emptiness 
I now take to my grave 
Never I ask of you 
But never I gave 
But you gave me your emptiness 
I now take to my grave 
So let this heart be still 

Mama now I'm coming home 
I'm not all you wished of me 
But a mother's love for her son 
Unspoken, Help me be 
I took your love for granted 
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And all the things you said to me 
I need your arms to welcome me 
But a cold stone's all I see 

* Repeat 

Let my heart go 
Mama let me heart go 
You never let me heart go 
So let this heart be still 

** Repeat 

'LinkExchange 
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CHAPTER C 

LEARNING JAVASCRIPT 

How to take full advantage of JavaScript by moving 
beyond its built-in commands 

Summary 

The power of any programming language depends on the extent to which you can 
modify it for your own needs. The more you are limited to using just the built-in 
commands and processes, the more you are limited in what you can do with that 
language. And the harder it is to write sophisticated programs. Thankfully, JavaScript 
supports user-defined functions, properties, and methods, and uses a simplified object 
model to create them. (3,400 words) 

JavaScript endorses full extensibility by letting you define your own functions. 
This allows you to create routines you can use over and over again. You save time in 
re-using common "components," and by designing your own functions you can extend 
JavaScript's base language to suit your needs. Think of it as "personalized JavaScript." 

Since JavaScript is based on objects, a JavaScript function can easily be turned 
into an object, and a method for that object. So, not only can you create user-defined 
objects to do your bidding, you can create your own objects that behave in exactly the 
way you want. And you can create methods that act upon those objects. While this 
sounds powerful -- and it is -- the process of creating functions, objects, and methods 
is very easy in JavaScript. 

Introducing functions 
Use the function statement to create your own JavaScript function. The bare-bones 

syntax is: 

function name (params) { 
... function stuff .. 

} 

name is the unique name of the function. All function names in a script 
must be unique. 

params is one or more parameter variables you pass to the function. 
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function stuff is the instructions carried out by the function. You can put 
most anything here. 

Notice the { and } brace characters; these define the function block, and 
are absolutely necessary. The braces tell JavaScript where a function begins 
and ends. The parentheses around the parameters also are required. Include 
the parentheses even if the function doesn't use parameters (and many don't). 

Names for your user-defined functions are up to you, just as long as you 
use only alphanumeric characters (the underscore character _ also is 
permitted). Function names must start with a letter character, but can include 
numbers elsewhere in the name. 

I've stuck with the JavaScript style of function name capitalization -- that is, 
initial lower case, then upper-case characters if the function name is 
composed of composite words. For example, myFuncName, yourFuncName, 
or theirFuncName. Function names are case-sensitive; be sure to use the 
same capitalization when you refer to the function elsewhere in the script. 
JavaScript considers myFunc different from Myfunc. 

To differentiate between functions and variables, I prefer to give my 
variables initial upper case characters, such as MyStuff. This immediately 
differentiates it from a function, which would use a the capitalization myStuff. 
Of course, you are free to adopt any capitalization scheme you Wish. 

Defining and using a function 
The best way to describe the how and why of a function is to show a simple one in 

action. Here's a basic function that displays "Hello, JavaScripters!" and is an obvious 
takeoff on the "Hello World!" example you see for new programming languages. 

function basicFunction () { 
alert ("Hello JavaScripters!"); 

} 

This merely defines the function. JavaScript will do nothing with it unless the 
function is referenced someplace else in the script. You have to call the function in 
order to use it. Calling a user-defined function is the same as calling a built-in 
JavaScript function -- you merely provide the name of the function in your script. 
This serves as the function call. When JavaScript encounters the function call, it 
dashes off to complete whatever instructions are in that function. When the function is 
over, JavaScript returns to the point immediately after the function call, and processes 
the remainder of the script. 

To call the function above, just include the text basicFunction() -- note the empty 
parentheses, as they are required. Here's a working example of the Hello JavaScripters 
program. 
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<HTML> 
<HEAD> 
<TITLE>Basic Function Example<fTITLE> 
<SCRIPT LANGUAGE="JavaScript"> 
function basicFunction () { 

alert ("Hello JavaScripters!"); 
} 
basicFunction(); 
</SCRIPT> 
</HEAD> 
<BODY> 
Page has loaded. 
</BODY> 
</HTML> 
The browser processes the contents of the <SCRIPT> tag as the document loads. 

When it encounters the basicFunction() function call, it pauses momentarily to 
process the function, and an alert box appears. Click OK and the remainder of the 
page finishes loading. 

Calling a function with an event handler 
A common way of calling a function is to include a reference to it in a form button 

or hypertext link. Processing a user-defined function when the user clicks a form 
button is perhaps the easiest of all. You use the onClick event handler to tell 
JavaScript that when the user clicks on the button, the function specified should be 
processed. Here's a revised version of the previous example, showing how 
basicFunction is called when the form button is clicked. 

<HTML> 
<HEAD> 
<TITLE>Basic Function Example<fTITLE> 
<SCRIPT LANGUAGE="JavaScript"> 
function basicFunction () { 

alert ("Hello JavaScripters!"); 
} 
</SCRIPT> 
</HEAD> 
<BODY> 
Click to call function. 
<FORM> 
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<INPUT TYPE="button" VALUE="Click" onClick="basicFunction()"> 
</FORM> 
</BODY> 
</HTML> 

Notice the onClick syntax in the <INPUT> tag. The event you want to process on 
a click is a call to basicFunction. This event is surrounded by double quotes. 

Passing a value to a function 
JavaScript functions support passing values -- or parameters -- to them. These 

values can be used for processing within the function. For instance, rather than having 
the alert box say "Hello JavaScripters!" whenever you call it, you can have it say 
anything you like. The text to display can be passed as a parameter to the function. 

To pass a parameter to a function, provide a variable name as the parameter in the 
function definition. You then use that variable name elsewhere in the function. For 
example: 

function basicExample (Text) { 
alert (Text); 

} 

The variable name is Text, and is defined as the parameter for the function. That 
variable is then used as the text to display in the alert box. When calling the function, 
provide the text you want to show as a parameter of the function call: 

basicExample ("This says anything I want"); 

Passing multiple values to a function 
You can pass multiple parameters to a function. As with built-in JavaScript 

functions and methods, separate the parameters with commas: 

multipleParams ("one", "two"); 

function multipleParams (Param1, Param2) { 

When you define a function with multiple parameters, be sure the parameters are 
listed in the same order in the function call. Otherwise, your JavaScript code may 
apply the parameters to the wrong variables, and your function won't work right. 
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Here's a working example sof a function with multiple parameters. It takes two 
parameters: an input string and a number value. The number value indicates how 
many characters on the left of the string you want to display in the alert box. When 
you run the following script, the alert box displays "This is" -- the first seven 
characters of the input string. 

<HTML> 
<HEAD> 
<TITLE>Global Variable Example<fTITLE> 
<SCRIPT LANGUAGE="JavaScript"> 
lefty ("This is a test", 7); 
function lefty (lnString, Num) { 

var OutString=lnString.substring (lnString, Num); 
alert (OutString); 

} 
</SCRIPT> 
</HEAD> 
<BODY> 
</BODY> 
</HTML> 

Returning a value from a function 
The functions described so far don't return a value; that is, they do whatever magic 

you want them to do, then end. No "output" value is provided by the function. In some 
other languages, such return-less functions are called subroutines. However, in 
JavaScript (like in C and C++), "functions are functions" whether or not they return a 
value. 

It's easy to return a value from a function: use the return statement, along with the 
value you wish to return. This is handy when you want your function to chum through 
some data and return the processed result. Take the "lefty" function from above. 
Instead of displaying the chopped-off string, you can return it to the calling function, 
and use the return value any way you want. 

<HTML> 
<HEAD> 
<TITLE>Global Variable Example<fTITLE> 
<SCRIPT LANGUAGE="JavaScript"> 
var Ret = lefty ("This is a test", 7); 
alert (Ret); 
function lefty (lnString, Num) { 
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var OutString=lnString.substring (lnString, Num); 
return (OutString); 

} 
</SCRIPT> 
</HEAD> 
<BODY> 
</BODY> 
</HTML> 

This script does essentially the same one as the previous example, but 
instead of always displaying the chopped-off text, the function merely returns 
the processed value. The return value is captured in a variable, and you are 
free to use that variable in any way you wish. The above shows the Ret 
variable used with an alert box, but you can use it in other ways, too. For 
example, you can write the contents of the Ret variable using the 
document.write method: 

document.write (Ret); 

Defining local variables within functions 
By default all JavaScript variables are declared global for the document that 

created them. That means when you define a variable in a function, it is also "visible" 
to any other portion of the script on that document. For example, in the following 
global variable test, the variable test is visible to the showVar function, even though 
the variable is defined in the loadVar function. 

<HTML> 
<HEAD> 
<TITLE>Global Variable Example</TITLE> 
<SCRIPT LANGUAGE="JavaScript"> 
function showVar () { 

alert (test) 
} 
function loadVar () { 

test= "6" 
} 
loadVar(); 
</SCRIPT> 
</HEAD> 
<BODY> 
Click to call function. 
<FORM> 
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<INPUT TYPE="button" Value="Click" onClick="showVar()"> 
</FORM> 
</BODY> 
</HTML> 

Global variables aren't always what you want. Instead, you want variables that are 
local to the function. These variables exist only as long as JavaScript is processing the 
function. When it exits the function, the variables are lost. In addition, a local variable 
of a given name is treated as a separate entity from a global variable of the same 
name. In this way, you don't have to worry about reuse of variable names. The local 
variable in the function won't have any effect on the global variable used elsewhere in 
the script. 

To declare a local variable, add the var keyword to the beginning of the variable 
name in the function. This tells JavaScript you want to make the variable local to that 
function. As a test, change the loadVar function above to the following, and re-load 
the script. When you click the button, JavaScript tells you the variable doesn't exist. 
This is because test is only local to the loadVar function, and does not exist outside 
the function. 

function loadVar () { 
var test = "6" 

} 

Calling one function from another function 
Code inside a function behaves just like code anywhere else. This means you can 

call one function from inside another function. This allows you to "nest" functions so 
that you can create separate functions, which each perform a specific task, and then 
run them together as a complete process, one right after the other. For example, here's 
a function that calls three other mythical functions, each one returning a string of text 
that has been altered in some way. 

function run () { 
var Ret = changeText ("Change me"); 
alert (Ret); 
document.write (Ret); 

} 
function changeText (Text) { 

Text= makeBold (Text); 
Text= makeltalics (Text); 
Text= makeBig (Text); 
return (Text); 

} 
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function makeBold (lnString) { 
return (lnString.bold()); 

} 
function makeltalics (lnString) { 

return (lnString.italics()); 
} 
function makeBig (lnString) { 

return (lnString.big()); 
} 

Creating objects with user-defined functions 

JavaScript is based on objects: the window is an object, links are objects, forms 
are objects, even Netscape itself (or other browser) is an object. Using objects can 
help make programming easier and more streamlined. You can extend the use of 
objects in JavaScript by making your own. The process uses functions in a slightly 
modified way. In fact, you'll be surprised how easy it is to make your own JavaScript 
objects. 

Making a new object entails two steps: 
Define the object in a user-defined function. 
Use the new keyword to create (or instantiate) the object with a call to the object 

function. 
Here's an example of the world's simplest user-defined JavaScript object: 
II this part creates a new object 
ret = new makeSimpleObject(); 
II this part defines the object 
function makeSimpleObject() {} 
I've called the new object ret; use any valid variable name for the new object (I 

use lower-case letters for variables that contain objects, so it's easier to tell that the 
variable contains an object). 

You can use the same object function to create any number of new objects. For 
instance, these lines create four new and separate objects: eenie, meenie, minie, and 
moe: 

eenie = new makeSimpleObject(); 
meenie = new makeSimpleObject(); 
minie = new makeSimpleObject(); 
moe = new makeSimpleObject(); 

Actually, there is even a shortcut to the above "world's simplest JavaScript 
object." You don't need to define an object function to make a bare-bones object. 
JavaScript supports a generic Object() object, which you can use to make new objects. 
The following does the same as the above, without an explicit object function: 
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eenie = new Object(); 

Defining new properties to already-made objects 

After an object has been created you can assign a value to it. But instead of just 
assigning a value to the object itself, you should define a new property for the object, 
and assign a value to the property. To create a new property and assign a value to it, 
simply write a variable expression like this: 

myobject.property = value; 
myobject is the name of the user-defined object. 
property is the name of the property you want to create. 
value is the value you want to assign. 
Suppose you create an object called "customer" and you want to define three 

properties to it: name, address, and phone. Here's one way to do it: 

customer= new makeSimpleObject(); 
customer.name= "Fred"; 
customer.address= "123 Main Street"; 
customer.phone= "555-1212"; 
function makeSimpleObject() { 

return (this); 
} 
You can verify that you've indeed created a new object and assigned properties to 

the object my adding an alert method to display one of the properties. For example, 
you could put this after the customer.phone line. When you run the script the alert box 
will say "Fred." 

alert (customer.name); 

Defining properties when you create the object 

Another method of defining properties for objects is to include the property names 
in the object function. You can use this technique to simultaneously create a new 
object and define the property values. All it takes is a few more lines of code in the 
object function. 

customer= new makeCustomer("Fred", "123 Main Street", "555-1212"); 
alert (customer.name); 
function makeCustomer(Name, Address, Phone) { 

this.name= Name; 
this.address= Address; 
this.phone= Phone; 

} 
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Note the series of this statements. Each this statement assigns a property to the 
current object, which is the one being created in the makeCustomer object function. 
Three parameters are passed to the object statement: the customer's name, address, 
and phone number. These parameters are used to define the contents of the three 
properties, which are name, address, and phone. 

JavaScript imposes no limitations on the number of properties you can assign to 
an object. To include as customer object, just do this: 

customer= new makeCustomer("Fred" "123 Main Street" "555-1212")· ' ' ' customer.salutation= "Mr."; 
Note that other objects you create with the makeCustomer object function will 

have just the three base properties, but this object for Fred will have an additional 
property for the salutation. Properties added later do not affect other objects created 
with the same object function. 

Creating user-defined methods 
A user-defined method is yet another way of using functions in JavaScript. 

Methods act upon objects -- either objects built into JavaScript, or objects that you've 
created. A method changes or manipulates an object in some way. For instance, 
suppose you want to insert the various contents of the customer object: name, address, 
and phone number. Write the code to insert the object contents, then stuff the code in 
a function. Call the function, using the customer object as a parameter, like so: 

customer= new makeCustomer("Fred", "123 Main Street", "555-1212"); 
displayCustomer ( customer); 
function displayCustomer (cust_obj) { 

Temp= "Name:"+ cust_obj.name + "<BR>"; 
Temp+= "Address: "+ cust_obj.address + "<BR>"; 
Temp+= "Phone: "+ cust_obj.phone + "<BR>"; 
document.write (Temp+ "<BR>"); 

} 

Here's a fully functioning user-defined property example if you'd like to try this 
out. Load the script; JavaScript will display three lines of customer data. (Reload the 
document if you want to run it again.) 

<HTML> 
<HEAD> 
<TITLE>Object Method Example</TITLE> 
<SCRIPT LANGUAGE="JavaScript"> 
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function run () { 
customer= new makeCustomer("Fred", "123 Main Street", "555-1212"); 
displayCustomer (customer); 
} 
function displayCustomer (cust_obj) { 

Temp= "Name: "+ cust_obj.name + "<BR>"; 
Temp+= "Address: "+ cust_obj.address + "<BR>"; 
Temp+= "Phone:"+ cust_obj.phone + "<BR>"; 
document.write (Temp+ "<P>"); 

} 
function makeCustomer(Name, Address, Phone) { 

this.name= Name; 
this.address= Address; 
this.phone= Phone; 

} 
run() 
</SCRIPT> 
</HEAD> 
<BODY> 
</BODY> 
</HTML> 

The other method is to create a method for the customer object. With this 
approach, you call the method as part of the object. This helps in defining special 
method functions that are designed for -- and only for -- certain kinds of objects. This 
process forms one of the foundations of object-oriented programming, where objects 
contain their own unique methods of operation. Here's the same script as above, 
modified so that the customer object contains the displayCustomer method. 

<HTML> 
<HEAD> 
<TITLE>Object Method Example</TITLE> 
<SCRIPT LANGUAGE="JavaScript"> 
function run () { 

customer= new makeCustomer("Fred", "123 Main Street", "555- 
1212"); 

customer.displayCustomer(); 
} 
function displayCustomer () { 

Temp= "Name: "+this.name+ "<BR>"; 
Temp+= "Address: "+this.address+ "<BR>"; 
Temp+= "Phone: "+this.phone+ "<BR>"; 
document.write (Temp + "<P>"); 

} 
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function makeCustomer(Name, Address, Phone) { 
this.name= Name; 
this.address= Address; 
this.phone= Phone; 
this.displayCustomer = displayCustomer; 

} 

run() 

</SCRIPT> 
</HEAD> 
<BODY> 
</BODY> 
</HTML> 

As you can see, to display the customer data, you call the displayCustomer 
method, like so: 

customer.displayCustomer(); 
Notice a few other changes in this version: 
The call to the displayCustomer function no longer uses a parameter. 
The displayCustomer() function no longer uses a parameter. 
The displayCustomer() function uses the "this" keyword to refers to the current 

object. 
When you write your own methods for objects, you'll follow the pattern used in 

the displayCustomer() function. There's no need to pass parameters to the function 
unless you need to. Refer to properties using the "this" keyword." And, add the name 
of the method function in the function that creates the object -- in this case, it's the 
makeCustomer object function. 

Conclusion 

Much of JavaScript's power comes from user-defined functions -- functions you 
make yourself. With your own functions, you create what is in essence your own 
JavaScript commands. And, you use functions to build JavaScript objects and 
methods. Master functions, and you'll go far in mastering JavaScript. 
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Take Advantage of User-Defined Variables 
JavaScript 
Learn how to master variables, the special information­ 
holding areas that are crucial to a programming language 

Summary 

in 

As with all programming languages, JavaScript relies heavily on user-defined 
variables. But unlike many languages -- including Java -- JavaScript's system of 
variables is simplified, so that even users with minimal programming experience 
can immediately use them. JavaScript doesn't impose strict data formats or types 
for its variables, which can greatly simplify programming. However, just because 
JavaScript's variables are easy to use doesn't mean they lack power. 

These special information-holding areas can store numbers, text strings, 
objects, and other data types. Once stored, this information can be used later in 
your program. With a variable, a person's name could be stored and used at some 
point in the script. 

Variables are temporary holders of information. They can hold: 
• Numeric values ("numbers") -- numbers that can be added together. Example: 

2+ 2 results in 4 
• Character strings -- a collection of text, such as "JavaScript" or "My name is 

Mudd" 
• True/false values -- the Boolean true and false 
• Objects -- JavaScript or user-defined objects (JavaScript variables can hold a 

few other kinds of data, but these are by far the most common types) 
(Note: As with most modem programming languages, JavaScript supports array 

variables in addition to the basic scalar variables used to hold the above data types. 
We'll concentrate on single-value variables for this column and devote a separate 
column to arrays.) 

JavaScript variables "belong" to the script document that created them; the 
variables are lost when the document is unloaded. In addition, the contents of a 
variable are erased when you assign a new value to them. Though a variable created 
in one document script is not usually seen by another document script, JavaScript 
does provide ways to share variables between scripts. You do this by referencing the 
name of the document along with the name of the variable. 

Several JavaScript instructions create and store variables, but the basic way to 
accomplish this manually is with the equals(=) assignment operator. The basic syntax 
1s: 

VariableName = value 
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The first argument is the name of the variable. Variable names can be very long, 
but you are restricted in the characters you may use. For more information on valid 
variable names, see the section on Variable name limits. 

The second argument is the contents of the variable. You can put all sorts of stuff 
into a variable, including a number, a string, a math expression (such as 2+2), and 
various other things that we'll get to in a bit. 

Pascal users may be tempted to construct the variable assignment using :=. Be 
aware that this syntax is not supported in JavaScript. 

Following is a more specific rundown of the four most common contents you can 
place in JavaScript variables, including examples. 

Contents placed in JavaScript variables 
Numbers in variables 

A number is one or more digits stored in the computer in such a way that 
JavaScript can perform math calculations with them. JavaScript supports both integers 
and floating-point values. To place a number in a variable, just provide the variable 
name, the equals sign (the variable assignment operator), and the value you want to 
use. For example, the following is what you do to place the number 10 in a variable 
named MyVar: 

MyVar = 10; 
Strings in variables 

A string is one or more text characters arranged in memory in single file. Strings 
can contain numbers (digits), letters, punctuation, or a combination of these elements. 
Math calculations cannot be performed on strings. Strings are assigned to JavaScript 
variables by being enclosed in a set of single or double quotes: 

"I am a string;' 
or 
'I am a string' 

Note that double or single quotes are acceptable; unlike some languages, such as 
Perl, JavaScript makes no distinction between the two forms of quote marks. This 
working example shows how to place a string into a variable: 

MyVar = "This is JavaScript"; 
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Boolean values in variables 

There are two Boolean values: true and false. Some programming languages don't 
have a separate set of Boolean values, and instead use O for false, and 1 or -1 ( or any 
other non-zero value) for true. JavaScript can use these numbers to represent true and 
false but, in addition, reserves the words "true" and "false" to mean Boolean true and 
false. You can think of the Boolean true and false values as being equivalent to on/off 
or yes/no. To assign a Boolean value to a variable, provide just the word true or false, 
without quotes. Here's an example: 

MyVar = true; 

Objects in variables 
Variables can contain objects, including JavaScript objects. There are basically 

two kinds of object variables: 
• Variables that contain built-in browser-related objects -- window, document, 

navigator, and so on -- actually are references to the original object. They are like 
copies, but the copies change if the original changes. In some cases, making a change 
to the object in the variable affects the original JavaScript object. 

• Variables that contain user-defined objects represent the actual object. Make a 
change to the object in the variable, and you change only that object. 

To assign a JavaScript object to a variable, provide the name of the object, as in: 

MyVar = navigator; 
To assign a new copy of a user-defined object to a variable, use the new 

statement, and provide the name of the object function: 

MyVar = new myObject(); 

SUBHEAD Variable name limits 
When it comes to the names you can give variables, JavaScript offers a great deal 

of latitude. JavaScript variables can be almost unlimited in length, although for 
practical reasons you'll probably keep your variable names under 10 or 15 characters. 
Shorter variable names help JavaScript execute the program faster. Keep the 
following in mind when naming your variables: 

• Variable names should consist of letters only -- without spaces. You can use 
numbers as long as the name doesn't start with a digit. For example, MyVarl is 
acceptable, but lMyVar is not. 
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• Don't use punctuation characters in variable names. Exception: the underscore 
character ( _ ). That is, the variable My_ Var is acceptable, but My*Var is not. 
Variables can begin with the underscore character. 

• Variable names are case-sensitive. The variable MyVar is a distinctly different 
variable from my Var, myvar, and other variations. 

Understanding JavaScript's "loose" variable data types 

Unlike some other programming languages, in JavaScript there is no need to 
explicitly define the type of variable you want to create. This JavaScript behavior is 
called "loose data typing," and it differs from C and Java, both of which use strict data 
typing. 

In JavaScript there is no need to differentiate variable types by appending special 
characters to the end of the variable name, such as My Var$ for a string variable (or, 
for that matter, $MyVar for a scalar variable, a la Perl). JavaScript internally decodes 
the variable type based on its content. 

Using the var statement to assign a variable 

JavaScript supports a var statement that can be used to explicitly define a variable. 
The syntax is merely the statement var, a space, and the same variable assignment 
expression detailed above. For instance: 

var MyVar = "This is a variable"; 
You can also use the var statement with the variable name to declare the variable 

but not define a value for it: 

var MyVar; 

In this case, you've defined MyVar in memory but have yet to assign a value to it. 
This technique is often used when setting up global variables -- variables that can be 
freely shared anywhere in your script. For more information about global variables, 
see the section "Understanding the scope of variables", below. 

String length limitations 
JavaScript imposes a limit of 254 characters for each string variable assignment in 

your program. If you go over the 254-character limit, JavaScript responds with a 
"Unterminated string literal" error message. (Note: This is fundamentally a limit of 
JavaScript in Netscape 2.0x; it's a good idea to observe it since not all users have 
adopted Netscape 3.0.) 
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You can create longer strings by "piecing" them together -- as long as each piece 
is 254 characters or less. After assigning a string to each variable, you combine them 
using the + character. This is called "concatenation." The following example shows 
how concatenation works: 

MyVar = "This is the start " + of how you " + " can build strings"; 

Each individual string segment -- defined by text within the quotes -- can be up to 
254 characters. To make a string longer than 254 characters, merely add more 
segments. Another approach is to build strings using the += assignment operator, like 
this: 

MyVar = "This is the start " 
MyVar += "of how you " 
MyVar + = can build strings " 
You can continue to concatenate strings this way as long as your computer has the 

memory for it. But, while JavaScript can hold strings larger than that possible in many 
other programming languages (like Basie's typical 64K), doing so can severely 
degrade the performance of the system. Obviously, you won't create a lot of huge 
string variables. It's just nice to know that, if needed, a JavaScript variable can 
accommodate so much text. 

Understanding the "scope" of variables 

The "scope of a variable" has nothing to do with optics or mouthwash, but rather 
the extent to which a variable is visible to other parts of a JavaScript program. Unless 
you provide explicit instructions to tell JavaScript otherwise, the scope of its variables 
is managed as follows: 

• Variables defined outside a function are available to any function within the 
script, as long as all the variables are definined in the script of the same HTML 
document. These are referred to as global variables. 

• Variables defined inside a function are also global, assuming the var statement 
is not used when first declaring that variable. That is, MyVar = "hello." 

• Variables defined inside a function with the var statement are "local" to that 
function only. These are referred to as local variables. 

• Global variables remain in memory even after a script has stopped execution. 
The variable remains in memory until the document is unloaded. 

Local variables are treated as if they don't exist outside the function where they 
are defined. That way, you can use the same variable name inside a function, and that 
variable won't interfere with the same-named variable elsewhere in the script. 
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Following is an example that demonstrates this. When you click the button, the 
script displays three alert boxes. The following details what happens when you click 
the button: 

• JavaScript calls firstFunction, which assigns a value of 1 to a local variable 
named My Var. The contents of My Var is displayed. 

• JavaScript calls secondFunction, which assigns a value of 2 to a local variable, 
also called My Var. The contents of My Var are displayed. 

• JavaScript returns to firstFunction, where the contents of My Var are again 
displayed. The result is 1, which is the value of My Var local to firstFunction. 

function firstFunction () { var My Var = 1; alert ("firstFunction: " + My Var); 
secondFunction(); alert ("firstFunction: "+ MyVar); } 

function secondFunction () { var MyVar = 2; alert ("secondFunction: "+ MyVar); 
} 

Referencing variables in other loaded documents 

When using frames, it is often necessary to share variables across documents. One 
or more frames may need a variable contained in another frame. By their nature, 
variables (even global ones) are not visible outside the document that created them. 
So, when you want to reference a variable in another document -- and assuming that 
document is loaded into the browser -:0 you need to explicitly reference that variable 
by adding the window name in front of the variable name. Here is syntax: 

winname.varname 

where w i nname is the name of the document, and v a rname is the name of the 
variable. More about document names in a bit. 

You can assign and reference variables using the following technique. For 
example, this sets the MyVar variable in the mydoc window to 1: 

mydoc.MyVar = 1; 
The code below assigns the value of a local MyVar variable in the mydoc 

window. 

VarlnThisDoc = mydoc.MyVar; 

Where do the names for the windows come from? It all depends on how the 
windows are used. 

To use a variable in the main browser window from a window that you created, 
first provide a "link" to the parent window object, using this method: 

- 102 - 



NEAR EAST UNIVERSTY 
COMPUTER lNCINEER/NQ 

1988 

newwindow = window.open ("","NewWindow"); //repeat this for Mac/X 
Netscape 2.0 

newwindow.creator = self; 
Then, in this new window you can refer to any variable in the main window using 

the syntax: 

creator.MyVar; 

To use a variable in a window you've created, refer to it using the object name 
you've provided when you created the window. For instance, you'd use newwindow 
for a window created with the following: 

newwindow = window.open ("","NewWindow"); 

Now refer to that variable using the syntax: 

newwindow.MyVar; 

To use a variable defined in the frameset -- that is, the document containing tag -­ 
refer to it as parent. Here's an example: 

pa rent. My Var; 

To use a variable in another frame document, refer to it using the frame name 
you've provided in the tag. For instance, you'd use 

parent.frame1 .MyVar; 

for a frame created with the following: 

Understanding when variables are lost 
JavaScript variables don't hang around forever. A variable is lost when one of the 

following happens: 
• The document where the variable was assigned is unloaded (you load another 

document to take its place, for example). 
• You reload the document or frameset. 
• You resize the browser window (this causes the document to be reloaded). 
• You use the document.write method to write to a window or frame where 

the variable was assigned. 
Losing variables when a document is reloaded or resized is one of the most 

aggravating JavaScript behaviors. Each time a document is reloaded or resized you 
effectively start over. The same is true of frames. If the user resizes a frame (by 
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dragging the frame border), it causes the browser to reload the page, and thus loses all 
the previous variable contents. 

Most of the time, however, it won't matter if the page is reloaded or resized, as 
your JavaScript code will behave as if the page was just accessed. But it can be a 
problem if you need to set and keep variables as users work themselves through some 
process you've provided on your page. You will need to consider workarounds if 
losing the variable will corrupt your script. There are several methods to accomplish 
this. 

One method, if your page uses frames, is to include a text-box field in one of the 
frames. You can make that frame invisible by enlarging the others to take up all 
available space, or you can push the text box out of the way and make the frame 
unscrollable and non-resizable. That way the user never sees the text box. You then 
use JavaScript to write a value to the text box. The value remains even if the 
document is reloaded or resized. 

Another method is to use a Netscape cookie, which is a semipermanent data 
storage file provided by Netscape. Cookies allow a safe and secure method to store 
data that you want to use later. With a cookie you can store items for the current 
session of Netscape -- or even between sessions. The current session is sufficient for 
the task of remembering a variable so it will last after a resize or a reload. 

Variable shortcuts, tips, and tricks 
When defining and using variables JavaScript supports a number of useful 

shortcuts. Several of the more useful shortcuts are itemized below. 

Declaring multiple variables at once 

You can declare several variables at the same time, all on one line, using commas 
to separate them. Instead of doing this: 

var MyVar, 
var YourVar; 
var TheirVar; 

you can do this: 

var MyVar, YourVar, TheirVar; 
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Assigning multiple variables at once 

If you want to assign the same value to more than one variable at a time, a 
shortcut method is to use the multiple assignment trick. The following assigns 1 to all 
of the variables. 

var MyVar = YourVar = TheirVar = 1; 

Deleting a variable from memory 

JavaScript normally will delete any variables when the page that created them is 
unloaded. However, you can force "early retirement" of variables with this simple 
technique: 

varname = null; 
This is intended to clear the memory the variable was using, though the variable 

will still exist. You might use this technique, for example, if you've created a large 
variable and now want to clear it from memory to avoid any possible out-of-memory 
problems. 

Converting between number and string variables 
To convert a number to a string, add a set of empty quotes in front of it, like this: 

myVar = ""+= MyVar; 

To convert a string to a number, use the parselnt or parseFloat functions, 
depending on the number type (parselnt is used for integers; parseFloat is used for 
numbers with decimal values): 

MyVar = parselnt(Mylnt); 
or 

MyVar = parseFloat(Mylnt); 
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Conclusion 
JavaScript variables are both easy to use and powerful. As with the entire 

language, JavaScript's variables were designed to be exploited by Web designers of 
all levels, including those with little or no programming experience. This design 
makes JavaScript variables easy to approach but does not undermine their power and 
flexibility. As you work with JavaScript and its variables, keep this power and 
flexibility in mind; you can use it to build JavaScript applications as complex and 
sophisticated as you wish. 
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CHAPTER D 

PROGRAMMING WITH HTML 
INDEX.HTM 

<HTML> 

<HEAD> 
<META HTTP-EQUIV="Content-Type" CONTENT="text/html; 
charset=windows-1252 "> 
<META NAME="Generator" CONTENT="Microsoft Word 97"> 
<META NAME="AUTHOR" Content="METIN TASKIN"> 
<META NAME="DESCRIPTION" Content="This about TURKIYE"> 
<META NAME="KEYWORDS" 
Content="turkiye,hotel,akdeniz,antalya,izmir, 
mersin,giresun,ataturk, trabzon, ofo hotel,hilton,prencess, 
kit tur,ormancilar,sheraton"> 
<TITLE> Turkiye</TITLE> 

</HEAD> 

<FRAMESET COLS= "156,638" > 
<FRAME SRC="finl.htm" NAME="Frame274284" RESIZE> 
<FRAME SRC="finr.htm" NAME="Frame274311" RESIZE> 
</FRAMES ET> 

<NO FRAMES> 
<BODY> 
<P> 
</BODY> 

</NO FRAMES> 

</HTML> 
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FINL.HTM 

<HTML> 
<HEAD> 

<META HTTP-EQUIV="Content-Type" CONTENT="text/html; 
charset=iso-8859-1 "> 
<META NAME="GENERATOR" CONTENT="Mozilla/4.02 [en] 
(Win95; I) [Netscape]"> 
<META NAME="AUTHOR" Content="METIN TASKIN"> 
<META NAME="DESCRIPTION" Content="This about 
TURKIYE"> 
<META NAME="KEYWORDS" Content=" turkiye, hotel, akdeniz, 
antalya, izmir, mersin, giresun, ataturk, trabzon, ofo hotel, hilton, 
prencess, kit tur, ormancilar, sheraton"> 

<TITLE> Turkiye</TITLE> 
</HEAD> 

<BODY TEXT="#CCOOOO" BGCOLOR="#CCOOOO" LINK="#CCOOOO" 
VLINK ="#CCOOOO" ALINK ="#CCOOOO" 
BACKGROUND="CDTSBK.jpg"> 
<CENTER><IMG SRC="globe7.gif'' ALT="dunya" BORDER=O 
HEIGHT=88 WIDTH=88 ALIGN=BOTTOM></CENTER> 
<CENTER><IMG SRC="Flagtk.gif'' ALT="Turk Bayragi" BORDER=O 
HEIGHT=71 WIDTH=121></CENTER> 
<CENTER><B><FONT FACE="Arial, Helvetica"><A HREF="turkO.htm" 
target="_top">WELCOME</A></FONT></B></CENTER> 
<CENTER><B><FONT F ACE="Arial, Helvetica"><A HREF="turkO.htm" 
target="_ top"> TO</ A></FONT></B></CENTER> 
<CENTER><B><FONT F ACE="Arial, Helvetica"><A HREF="turkO.htm" 
target="_ top"> TURKEY</ A></FONT></B></CENTER> 
<CENTER>&nbsp;</CENTER> 
<CENTER>&nbsp;</CENTER> 
<CENTER>&nbsp;</CENTER> 
<CENTER>&nbsp;</CENTER> 
<CENTER>&nbsp;</CENTER> 
<CENTER> 
<H2> 
<A HREF="turkO.htm" target="_top"><IMG SRC="docsrigh.gif'' 
ALT="ileri" BORDER=O HEIGHT=30 WIDTH=30></A></H2></CENTER> 

</BODY> 
</HTML> 
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FINR.HTM 

<HTML> 
<HEAD> 

<META HTTP-EQUIV="Content-Type" CONTENT="text/html; 
charset=windows-1252 "> 
<META NAME="Generator" CONTENT="Microsoft Word 
97"><META NAME="AUTHOR" Content="METIN TASKIN"> 
<META NAME="DESCRIPTION" Content="This about 
TURKIYE"> 
<META NAME="KEYWORDS" Content=" turkiye, hotel, akdeniz, 
antalya, izmir, mersin,giresun,ataturk,trabzon, ofo Hotel, hilton, 
prencess, kit tur, ormancilar, sheraton"> 

<TITLE> Turkiye</TITLE> 
</HEAD> 

<BODY TEXT="#FFOOOO" BGCOLOR="#FFOOOO" 
LINK ="#FFOOOO" VLINK ="#FFOOOO" ALINK ="#FFOOOO" 
BACKGROUND="CDTSBK.jpg"> 
<CENTER><B><FONT FACE=" Arial, Helvetica"><FONT 
SIZE=+4><AHREF="http://www.turkey.org/" 
target="_ top"> TURKEY</ A></FONT></FONT></B></CENTER> 
<CENTER><A HREF="turkO.htm" target="_top"><IMG 
SRC="MAPi.jpg" ALT="turkiye haritasy" BORDER=O HEIGHT=235 
WIDTH=436></ A></CENTER> 
<CENTER><B><BLINK><FONT F ACE="Arial,Helvetica"><FONT 
SIZE=+ 3> WELCOME TO 
TURKEY </FONT></FONT></BLINK></B></CENTER> 

</BODY> 
</HTML> 
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·ruRKO.HTM 

<HTML> 
<HEAD> 

<META HTTP-EQUIV="Content-Type" CONTENT="text/html; 
charset=windows-1252 "> 
<META NAME="Generator" CONTENT="Microsoft Word 97"> 
<MET A NAME=" AUTHOR" Content="METIN T ASKIN"> 
<META NAME="DESCRIPTION" Content="This about 
TURKIYE"> 
<META NAME="KEYWORDS" Content=" turkiye, hotel, akdeniz, 
antalya, izmir, mersin, giresun, ataturk, trabzon, ofo hotel, hilton, 
prencess,kit tur, ormancilar, sheraton"> 

<TITLE> Turkiye</TITLE> 
</HEAD> 

<FRAMESET COLS= "151,643" > 
<FRAME SRC="ftl.htm" NAME="Frame5915145" RESIZE> 
<FRAME SRC="ftr.htm" NAME="Frame5915159" RESIZE> 
</FRAMES ET> 
<NO FRAMES> 

<BODY> 
<P> 
</BODY> 

</NO FRAMES> 

</HTML> 

FTL.HTM 

<HTML> 
<HEAD> 
<META HTTP-EQUIV="Content-Type" CONTENT="text/html; 
charset=windows-1252 "> 
<META NAME="Generator" CONTENT="Microsoft Word 97"> 
<META NAME="AUTHOR" Content="METIN TASKIN"> 
<META NAME="DESCRIPTION" Content="This about TURKIYE"> 
<MET A NAME="KEYWORDS" Content=" turkiye, hotel, akdeniz, antalya, 
izmir, mersin, giresun, ataturk, trabzon, ofo hotel, hilton, prencess, kit tur, 
ormancilar, sheraton"> 
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<TITLE> Turkiye</TITLE> 
</HEAD> 
<BODY BACKGROUND="CDTSBK.jpg" TEXT="#CCOOOO" BGCOLOR= 
"#CCOOOO" LINK ="#CCOOOO" VLINK ="#660000" ALINK ="#CCOOOO"> 
<P ALIGN="CENTER"><IMG SRC="globe7.gif' WIDTH="88" HEIGHT= 
"88" ALIGN="BOTTOM" BORDER="O"> 
<CENTER> 

<IMG SRC="Flagtk.gif' WIDTH="121" HEIGHT="71" 
ALIGN="BOTTOM" BORDER="O"></CENTER> 
<B><BLINK></B><A HREF="index.htm" target="_top"><FONT 
F ACE="Arial, 
Helvetica"><B> WELCOME</ A></B></FONT><B></BLINK></B><A 
HREF="index.htm" target="_top"><BR> 
</ A><B><BLINK></B><A HREF="index.htm" target="_ top"><FONT 
F ACE="Arial, 
Helvetica"><B> TURKEY</ A></B></FONT><B></BLINK></B></P> 
<P ALIGN="CENTER"><BR> 
<BR> 
<BR> 
<BR> 
<BR> 
<BR> 
<A HREF="index.htm" target="_top"><IMG SRC="docsleft.gif' 
WIDTH="30" HEIGHT="30" ALIGN="BOTTOM" BORDER="O"><IMG 
SRC=" docsupar.gif" WIDTH="30" HEIGHT="30" ALIGN="BOTTOM" 
BORDER ="O"></ A><A HREF="turkl .htm" target="_ top"><IMG 
SRC="docsrigh.gif' WIDTH="30" HEIGHT="30" ALIGN="BOTTOM" 
BORDER="O"></A> 

</BODY> 
</HTML> 

FTR.HTM 

<HTML> 
<HEAD> 

<META HTTP-EQUIV="Content-Type" CONTENT="text/html; 
charset=windows-1252 "> 
<META NAME="Generator" CONTENT="Microsoft Word 97"> 
<META NAME="AUTHOR" Content="METIN TASKIN"> 
<META NAME="DESCRIPTION" Content="This about TURKIYE"> 
<META NAME="KEYWORDS" Content=" turkiye, hotel, akdeniz, 
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antalya, izmir, mersin, giresun, ataturk, trabzon, ofo hotel, hilton, prencess, 
kit tur, ormancilar, sheraton"> 
<TITLE> Turkiye</TITLE> 

</HEAD> 
<BODY BACKGROUND="CDTSBK.jpg" TEXT="#CCOOOO" 
BGCOLOR="#CCOOOO" LINK="#CCOOOO" VLINK="#660000" 
ALINK ="#CCOOOO"> 
<P ALIGN="CENTER"><IMG SRC="globe7.gif' WIDTH="88" 
HEIGHT="88" ALIGN="BOTTOM" BORDER="O"> 
<CENTER> 
<IMG SRC="Flagtk.gif' WIDTH="121" HEIGHT="71" 
ALIGN="BOTTOM" BORDER="O"></CENTER> 
<B><BLINK></B><A HREF="index.htm" target="_top"><FONT 
F ACE="Arial, 
Helvetica"><B>WELCOME</A></B></FONT><B></BLINK></B> 
<A HREF="index.htm" target ="_top"><BR> <IA> <B> <BLINK> 
</B> <A HREF="index.htm" target="_top"><FONT F ACE="Arial, 
Helvetica"><B> TURKEY</ A></B></FONT><B></BLINK></B></P 
><P ALIGN="CENTER"><BR> 
<BR> 
<BR> 
<BR> 
<BR> 
<BR> 
<A HREF="index.htm" target="_top"><IMG SRC="docsleft.gif' 
WIDTH="30" HEIGHT="30" ALIGN="BOTTOM" BORDER= "O" > 
<IMG SRC= "docsupar.gif" WIDTH="30" HEIGHT="30" ALIGN= 
"BOTTOM" BORDER="O"></A><A HREF="turkl.htm" target=" 
_top "><IMG SRC= "docsrigh.gif" WIDTH="30" HEIGHT="30" 
ALIGN="BOTTOM" BORDER="O"></A> 
</BODY> 

</HTML> 
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<BODY BACKGROUND="CDTSBK.jpg" TEXT="#CCOOOO" LINK=" #CCOOOO" 
VLINK= "#660000" ALINK="#CCOOOO"> 
<P ALIGN="CENTER"><FONT SIZE="5" COLOR="#CCOOOO" FACE="Arial, 
Helvetica"><B> WELCOME TO TURKEY </B></FONT><FONT 
SIZE=" 5 ">&nbsp;</FONT> 

<CENTER> 
<TABLE BORDER="O" CELLPADDING="O" CELLSPACING="O" 
WIDTH="524" HEIGHT="461 "> 
<TR><TD WIDTH="216" HEIGHT="23" VALIGN= "BOTTOM"> 
&nbsp;</TD> 
<TD WIDTH="153" VALIGN="BOTTOM" ROWSPAN="2"><A HREF= 
"http://www.turkey.org" target="_top"><IMG SRC="Atal.gif'' WIDTH= 
"153" HEIGHT="206" ALIGN="BOTTOM" BORDER="O"></A></TD> 
<TD HEIGHT="23" VALIGN="TOP">&nbsp;</TD> 
</TR> 
<TR> 
<TD WIDTH="216" HEIGHT=" 179" V ALIGN="BOTTOM"><IMG SRC= 
"Flagtk.gif'' WIDTH="216" HEIGHT="l 16" ALIGN="BOTTOM" 
BORDER="O"></TD><TD HEIGHT=" 179" V ALIGN="BOTTOM"> 
<P ALIGN="CENTER"><IMG SRC="globe7.gif'' WIDTH="126" HEIGHT= 
"111" ALIGN="BOTTOM" BORDER="O"> 
</TD> 
</TR> 
<TR> 
<TD HEIGHT="251" V ALIGN="TOP" COLSPAN="3 "> 
<P> <IMG SRC="MAPi.jpg" WIDTH="524" HEIGHT="185" ALIGN= 
"BOTTOM" BORDER= "O"></P> 
<P ALIGN="CENTER"><A HREF="turkl .htm" target="_top"><FONT 
F ACE="Arial, Helvetica"><B> WHEN TO TRAVEL 
TURKEY </B></FONT></ A><IP><P ALI GN="CENTER"><A 
HREF="turk2.htm" target="_top"><FONT F ACE="Arial, 
Helvetica"><B>HOW TO TRAVEL TO TURKEY</B></FONT></A></P> 
<P ALIGN="CENTER"><A HREF="turk3.htm" target="_top"><FONT 
FACE= "Arial, Helvetica"><B>USEFUL PHRASES IN TURKEY </B> 
</FONT></ A><IP> 
<P ALIGN="CENTER"><A HREF="tou.htm" target="_top"><FONT 
FACE= "Arial, Helvetica"><B>TOURISTIC PLACES IN TURKEY </B> 
</FONT></ A> 
</TD> 
</TR> 
</TABLE> 
</CENTER> 
&nbsp; 
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</BODY> 
</HTML> 
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TURK1.HTM 

<HTML> 
<HEAD> 

<MET A HTTP-EQUIV=" Content-Type" CONTENT="text/html; 
charset=windows-1252 "> 
<META NAME="Generator" CONTENT="Microsoft Word 97"> 
<META NAME=" AUTHOR" Content="METIN T ASKIN"> 
<META NAME="DESCRIPTION" Content="This about TURKIYE"> 
<META NAME="KEYWORDS" Content= "turkiye, hotel, akdeniz, 
antalya, izmir, mersin,giresun,ataturk,trabzon, ofo hotel,hilton,prencess, kit 
tur, ormancilar, sheraton"> 

<TITLE> Turkiye</TITLE> 
</HEAD> 

<FRAMESET COLS = "151,643 " > 
<FRAME SRC="fthll .htm" NAME="Frame890491" RESIZE> 
<FRAME SRC="fthrl .htm" NAME="Frame890504" RESIZE> 
</FRAMES ET> 
<NO FRAMES> 

<BODY> 
<P> 

</BODY> 
</NO FRAMES> 

</HTML> 

FTHL1.HTM 

<HTML> 

<HEAD> 
<META HTTP-EQUIV="Content-Type" CONTENT="text/html; 
charset=windows-1252 "> 
<META NAME="Generator" CONTENT="Microsoft Word 97"> 
<META NAME="AUTHOR" Content="METIN TASKIN"> 
<META NAME="DESCRIPTION" Content="This about TURKIYE"> 
<META NAME="KEYWORDS" Content= "turkiye, hotel, akdeniz, antalya, 
izmir, mersin, giresun, ataturk, trabzon, ofo hotel, hilton, prencess, kit tur, 
ormancilar, sheraton"> 

- 115 - 



NEAR EAST UNIVERSTY 
COMPUTER ENC/NEER/NC 

1988 

<TITLE> Turkiye</TITLE> 
</HEAD> 

<BODY BACKGROUND="CDTSBK.jpg" TEXT="#CCOOOO" LINK 
= "#CCOOOO" VLINK="#660000" ALINK="#CCOOOO"> 
<P ALIGN="CENTER"><IMG SRC="globe7.gif'' WIDTH="88" 
HEIGHT ="88" ALIGN="BOTTOM" ALT="dunya" BORDER="O"> 
<CENTER> 
<B><BLINK></B><A HREF= "index.htm" target="_top"><FONT 
FACE= "Arial, Helvetica"><B>WELCOME</A></B></FONT> <B> 
</BLINK></B><A HREF="index.htm" target="_top"><BR> <IA> 
<B><BLINK></B><A HREF="index.htm" target="_top"><FONT 
FACE= "Arial, Helvetica"><B>TURKEY </ A></B></FONT><B> 
</BLINK></B><BR><IMG SRC="Flagtk.gif'' WIDTH= "121" 
HEIGHT= "71" ALIGN="BOTTOM" BORDER="O"></CENTER> 
<BR> 
<BR> 
<BR> 
<BR> 
<BR> 
<BR> 

<P ALIGN="CENTER"><A HREF="turkO.htm" target="_top"><IMG 
SRC="docsleft.gif'' WIDTH="30"HEIGHT="30"ALIGN="BOTTOM" 
BORDER="O"></A><A HREF="index.htm" target="_top"><IMG 
SRC="docsupar.gif''WIDTH="30"HEIGHT="30"ALIGN="BOTTOM 
BORDER="O"></A><A HREF="turk2.htm" target="_top"><IMG 
SRC="docsrigh.gif''WIDTH="30"HEIGHT="30"ALIGN="BOTTOM" 
BORDER="O"></A> 
</BODY> 

</HTML> 

FTHR1.HTM 

<HTML> 
<HEAD> 

<META HTTP-EQUIV="Content-Type" CONTENT="text/html; 
charset=windows-1252 "> 
<META NAME="Generator" CONTENT="Microsoft Word 97"><META 
NAME="AUTHOR" Content="METIN TASKIN"> 
<META NAME="DESCRIPTION" Content="This about TURKIYE"> 
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<MET A NAME="KEYWORDS" Content= 
"turkiye,hotel,akdeniz,antalya, izmir,mersin, giresun,ataturk,trabzon, 
ofo hotel ,hilton, prencess, kit tur,ormancilar,sheraton"> 

<TITLE> Turkiye</TITLE> 
</HEAD> 

<BODY BACKGROUND="CDTSBK.jpg" TEXT="#660099" LINK= 
"#CCOOOO" VLINK="#660000" ALINK="#CCOOOO"><H2 ALIGN= 
"CENTER"><FONT COLOR="#330066">When to Travel to Turkey 
</FONT></H2> 
<P><FONT COLOR="#330066"><B>Marmara, Aegean and 
Mediterranean Coasts:</B></FONT><BR> 

These coasts have a typical Mediterranean climate with hot summers and mild 
winters. The swimming season becomes shorter as one travels north:<BR> 
<STRONG>Marmara and North Aegean:</STRONG> June to September 
<BR> 
<STRONG>South Aegean and Mediterranean: </STRONG>April to October 
<BR> 
<B>Black Sea Coast:</B><BR> 
Temperate climate with warm summers, mild winters and relatively high 
rainfall. </P> 
<P><FONT COLOR="#330066"><B>Central Anatolia:</B></FONT><BR> 
These areas have a steppe climate with hot, dry summers and cold winters. 
<IP> 
<P><FONT CO LOR ="#3 3 0066 "><B> Eastern Anatolia:</B></FONT><BR> 
Long snowy, cold winters with mild summers. <IP> 
<P><FONT COLOR="#330066"><B>Southeast Anatolia:</B></FONT> 
<BR>These areas have a hot summer with mild, rainy winters.</P> 
<P> 
<H3><FONT COLOR="#330066">Average Air temperatures for Major 
Regions</FONT></H3> 
<P>(IN CELSIUS) 

<TABLE BORDER="l"> 
<td> 
<TR> 
<TD>&nbsp;</TD> 
<TD><FONT COLOR="#330066">Jan</FONT></TD> 
<TD><FONT COLOR="#330066">Feb</FONT></TD> 
<TD><FONT COLOR="#330066">Mar</FONT></TD> 
<TD><FONT COLOR="#330066">Apr</FONT></TD> 
<TD><FONT COLOR="#330066">May</FONT></TD> 
<TD><FONT COLOR="#330066"> Jun</FONT></TD> 
<TD><FONT COLOR="#330066">Jul</FONT></TD> 
<TD><FONT COLOR="#330066">Aug</FONT></TD> 
<TD><FONT COLOR="#330066">Sep</FONT></TD> 
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<TD><FONT COLOR="#330066">0ct</FONT></TD> 
<TD><FONT COLOR="#330066">Nov</FONT></TD> 
<TD><FONT COLOR="#330066">Dec</FONT></TD> 
</TR> 
<TR> 
<TD><FONT COLOR="#330066">ANTAL YA</FONT></TD> 
<TD> 1 O</TD> 
<TD> 11 </TD> 
<TD> 13 </TD> 
<TD> 16</TD> 
<TD>20</TD> 
<TD>25</TD> 
<TD>28</TD> 
<TD>28</TD> 
<TD>25</TD> 
<TD>20</TD> 
<TD> 15</TD> 
<TD> 12</TD> 
</TR> 
<TR> 
<TD><FONT COLOR="#330066">IZMIR</FONT></TD> 
<TD>9</TD> 
<TD> 1 O</TD> 
<TD> 11 </TD> 
<TD> 16</TD> 
<TD>20</TD> 
<TD>25</TD> 
<TD>28</TD> 
<TD>27</TD> 
<TD> 23 </TD> 
<TD> 18</TD> 
<TD> 15</TD> 
<TD> 1 O</TD> 
</TR> 
<TR> 
<TD><FONT COLOR="#330066">ISTANBUL</FONT></TD> 
<TD>S</TD> 
<TD>6</TD> 
<TD>7</TD> 
<TD> 12</TD> 
<TD> 16</TD> 
<TD> 21 </TD> 
<TD> 23 </TD> 
<TD> 23 </TD> 
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<TD>20</TD> 
<TD> 16</TD> 
<TD> 12</TD> 
<TD>8</TD> 
</TR> 
<TR> 
<TD><FONT COLOR="#330066">TRABZON</FONT></TD> 
<TD>6</TD> 
<TD>6</TD> 
<TD>7</TD> 
<TD> 11 </TD> 
<TD> 15 </TD> 
<TD>20</TD> 
<TD>22</TD> 
<TD>22</TD> 
<TD> 19</TD> 
<TD> 15</TD> 
<TD> 12</TD> 
<TD>9</TD> 
</TR> 
<TR> 
<TD><FONT COLOR="#330066">ANKARA</FONT></TD> 
<TD>O</TD> 
<TD>l</TD> 
<TD>5</TD> 
<TD> 11 </TD> 
<TD> 16</TD> 
<TD> 20</TD> 
<TD> 23 </TD> 
<TD>23</TD> 
<TD> 18</TD> 
<TD> 13</TD> 
<TD>8</TD> 
<TD>2</TD> 
</TR> 
<TR> 
<TD><FONT COLOR="#330066">ERZURUM</FONT></TD> 
<TD>-9</TD> 
<TD>- 7 </TD> 
<TD>-3</TD> 
<TD>5</TD> 
<TD> 11 </TD> 
<TD> 15</TD> 
<TD> 19</TD> 
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<TD>20</TD> 
<TD> 15</TD> 
<TD>9</TD> 
<TD>2</TD> 
<TD>-5</TD> 
</TR> 
<TR> 
<TD><FONT COLOR="#330066">DIYARBAKIR</FONT></TD> 
<TD>2</TD> 
<TD>2</TD> 
<TD>8</TD> 
<TD> 14</TD> 
<TD> 19</TD> 
<TD> 26</TD> 
<TD> 31 </TD> 
<TD> 31 </TD> 
<TD>25</TD> 
<TD> 17 </TD> 
<TD> 1 O</TD> 
<TD>4</TD> 
</TR> 
<TR> 
<TD></TD> 
<TD></TD> 
<TD></TD> 
<TD></TD> 
<TD></TD> 
<TD></TD> 
<TD></TD> 
<TD></TD> 
<TD></TD> 
<TD></TD> 
<TD></TD> 
<TD></TD> 
<TD></TD> 
</TR> 
</TABLE> 

</BODY> 
</HTML> 
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TURK2.HTM 

<HTML> 
<HEAD> 

<META HTTP-EQUIV="Content-Type" CONTENT="text/html; 
charset=windows-1252 "> 
<META NAME="Generator" CONTENT="Microsoft Word 97"> 
<META NAME="AUTHOR" Content="METIN TASKIN"> 
<META NAME="DESCRIPTION" Content="This about 
TURKIYE"> 
<META NAME="KEYWORDS" Content="turkiye,hotel, akdeniz, 
antalya,izmir,mersin,giresun,ataturk,trabzon, ofo hotel,hilton,prencess, 
kit tur,ormancilar,sheraton"> 

<TITLE> Turkiye</TITLE> 
</HEAD> 

<FRAMESET COLS= "151,643" > 
<FRAME SRC="fthl2.htm" NAME="Frame1677928" RESIZE> 
<FRAME SRC="fthr2.htm" NAME="Frame1677938" RESIZE> 
</FRAMES ET> 
<NO FRAMES> 

<BODY> 
<P> 
</BODY> 

</NO FRAMES> 
</HTML> 

FTHL2.HTM 

<HTML> 
<HEAD> 

<META HTTP-EQUIV="Content-Type" CONTENT="text/html; 
charset=windows-1252 "> 
<META NAME="Generator" CONTENT="Microsoft Word 97"> 
<META NAME="AUTHOR" Content="METIN TASKIN"> 
<META NAME="DESCRIPTION" Content="This about 
TURKIYE"> 
<MET A NAME="KEYWORDS" Content="turkiye,hotel,akdeniz, 
antalya,izmir,mersin,giresun,ataturk,trabzon, ofo hotel, hilton,prencess, 
kit tur,ormancilar,sheraton"> 
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<TITLE> Turkiye</TITLE> 
</HEAD> 

<BODY BACKGROUND="CDTSBK.jpg" TEXT="#CCOOOO" 
LINK ="#CCOOOO" VLINK ="#660000" ALINK ="#CCOOOO"> 
<P ALIGN="CENTER"><IMG SRC="globe7.gif' WIDTH="88" 
HEIGHT="88" ALIGN="BOTTOM" ALT="dunya" BORDER="O"> 
<CENTER> 
<A HREF="index.htm" target="_top"><FONT FACE="Arial, 
Helvetica"><B> WELCOME</B></FONT></ A></CENTER> 
<CENTER> 
<A HREF="index.htm" target="_top"><FONT FACE="Arial, 
Helvetica"><B> TURKEY </B></FONT></ A></CENTER> 
<CENTER> 
<IMG SRC="Flagtk.gif' WIDTH="121" HEIGHT="71" 
ALIGN="BOTTOM" BORDER="O"></CENTER> 
&nbsp; <BR> 
&nbsp; <BR> 
&nbsp; <BR> 
&nbsp; <BR> 
&nbsp; <BR> 
&nbsp; 
<CENTER> 
<A HREF="turkl .htm" target="_top"><IMG SRC="docsleft.gif' 
WIDTH="30" HEIGHT="30" ALIGN="BOTTOM" BORDER= 
"O"><IA><A HREF="turkO.htm" target="_top"> <IMG SRC= 
"docsupar.gif" WIDTH="30" HEIGHT="30" ALIGN="BOTTOM" 
BORDER="O"></A><A HREF="turk3.htm" target= "_top"> <IMG 
SRC="docsrigh.gif' WIDTH="30" HEIGHT="30" ALIGN= 
"BOTTOM" BORDER="O"></A></CENTER> 

</BODY> 
</HTML> 

FTHR2.HTM 

<HTML> 
<HEAD> 

<META HTTP-EQUIV="Content-Type" CONTENT="text/html; 
charset=windows-1252 "> 
<META NAME="Generator" CONTENT="Microsoft Word 97"> 
<META NAME="AUTHOR" Content="METIN TASKIN"> 
<META NAME="DESCRIPTION" Content="This about 
TURKIYE"> 
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<META NAME="KEYWORDS" Content="turkiye,hotel,akdeniz, 
antalya,izmir, mersin,giresun,ataturk,trabzon, ofo hotel,hilton,prencess, 
kit tur,ormancilar,sheraton"> 

<TITLE> Turkiye</TITLE> 
</HEAD> 

<BODY BACKGROUND="CDTSBK.jpg" TEXT="#660099"> 
<P ALIGN="CENTER"><FONT SIZE="5" COLOR= "#330066"> 
<B>How to Travel to Turkey</B></FONT><FONT SIZE="6"><B> 
</B></FONT></P> 

<UL> 
<LI><FONT COLOR="#330066"><B>Airlines</B></FONT><BR> 
Turkish Airlines has regular flights to Ankara, Istanbul, Izmir, Antalya, 
Adana, Trabzon and Dalaman, from the principal capitals and major cities of 
the world. 
<UL> 
<LI> Turkish Airlines 
<LI> International Airlines 
<LI>Charter Airlines 
</UL> 
<P> 
<LI><FONT COLOR="#330066"><B>Travel Agencies</B> </FONT> 
<BR> 
A listing of travel agents in major Turkish cities. 
<P> 
<LI><FONT COLOR="#330066"><B>Other Means of Transportation</B> 
</FONT><BR> A listing of other means of transportation, including state 
railways, maritime lines, sea buses and major city bus companies. 
</UL> 
<H2><FONT COLOR="#330066">Airlines</FONT></H2> 
<UL> 
<LI> Turkish Airlines 
<LI>Other Domestic Airlines 
<LI> International Airlines 
<LI>Charter Aircraft 
</UL> 

<H3>0ffice of Turkish Airlines</H3> 
<P>R: Reservations phone number<BR> 
S: Sales office phone number</P> 
<P><FONT SIZE="4"><B>Istanbul</B></FONT></P> 
<P> Turkish Airlines Head Office<BR> Ataturk Airport Y esilkoy, 
Istanbul<BR> 
Tel: (212) 663 63 OO<BR>Fax: (212) 663 47 44 -63 49 04<BR> 
R: (212) 663 63 63<BR>(25 lines)</P> 
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<P>Cargo Reservation Department<BR> Ataturk Airport Y esilkoy, 
Istanbul<BR>Tel: R: (212) 663 46 OO<BR>(4 lines)<BR>Fax: (212) 
573 35 26 <BR>Istanbul Sales<BR>Cumhuriyet Caddesi 199-201 Kat 
3<BR>Harbiye, Istanbul<BR>Tel: S (212) 248 26 31 -<BR> 
246 40 17 - 247 13 38<BR>R (212) 663 63 63<BR>(25 lines)<BR> 
Fax: (212) 240 29 84 <BR>Sales Offices:<BR>Taksim: (212) 252 11 
06 (6 lines)<BR>Harbiye: (212) 225 05 56<BR>(6 lines)<BR> 
Aksaray: (212) 514 00 22 - 23<BR> 
Sirkeci: (212) 522 88 88 -528 42 61 <IP> 
<P><FONT SIZE=" 4 "><B> Ankara</B></FONT><BR> 
Turkish Airlines<BR>Ataturk Bulvan 25 Bakanliklar, Ankara<BR> 
Tel: S (312) 419 28 25/<BR>418 68 45/ 518 92 60<BR> 
R (312) 418 26 24/<BR>419 28 OO<BR>Fax: (312) 418 94 53</P> 
<P><FONT SIZE=" 4 "><B> Izmir</B></FONT><BR> Turkish 
Airlines <BR>Gaziosmanpasa Bulvan<BR>I/F Buyuk Efes Oteli Alti 
Izmir<BR>Tel: S (232) 484 12 20<BR>(5 lines)<BR>R (232) 425 82 
80<BR>Fax: (232) 483 62 81 </P><P><FONT SIZE="4"><B>Adana 
</B></FONT><BR>Turkish Airlines<BR>Stadyum Caddesi 32 
01120 Adana<BR>Tel: S (322) 453 08 67<BR>R (322) 454 23 
93/<BR>454 35 38/ 453 72 47<BR>Fax: (322) 454 30 88</P> 
<P><FONT SIZE=" 4 "><B> Antalya</B></FONT><BR> Turkish 
Airlines<BR>Ozel Idare Ishani Alti Cumhuriyet Caddesi Antalya 
<BR>Tel: S (242) 243 43 81-82<BR>R (242) 243 43 84<BR> 
(4 linesO<BR>Fax: (242) 248 47 61 </P><P><H3>0ther Domestic 
Airlines</H3><P><B>Green Air</B><BR>Konakli Sokak 1 O<BR> 
Florya, Istanbul<BR>Tel: (212) 663 50 08-09<BR>Fax: (212) 663 56 
90</P> 
<P><B>Istanbul Airlines</B><BR>Cumhuriyet Caddesi 289<BR> 
Harbiye, Istanbul<BR>Tel: (212) 231 75 26<BR>Fax: (212) 246 49 
67</P> 
<P><B>Mas Air (Flights to Bodrum)</B><BR>City Office<BR> 
Cumhurieyet Caddesi<BR>l67 Elmadag, Ist.<BR>Tel: (212) 231 10 
72-73<BR>Fax: (212) 234 43 31 <BR>Airport Office<BR>Ataturk 
Hava Limani Kat 3<BR>Yesilkoy<BR>Istanbul<BR>Tel: (212) 663 
40 94 PBX<BR>Fax: (212) 574 05 53</P> 
<P><H3> International Airlines</H3><P><FONT SIZE=" 4 "><B> 
Istanbul</B></FONT></P><P><B>Adria (Slavonian) Airways</B> 
<BR>Ordu Caddesi 206/1 Lalei<BR>Tel: (212) 512 42 3l<BR>Fax: 
(212) 512 42 34-512 54 36</P> 
<P><B>Aeroflot</B><BR>Mete Caddesi 30 Taksim<BR>Tel: (212) 
243 47 25<BR>Fax: (212) 252 39 98</P> 
<P><B>Air China</B> <BR>Cumhuriyet Caddesi 235/1 
Harbiye<BR>Tel: (212) 232 71 11 <BR>Fax: (212) 232 44 87</P> 
<P><B>Air France</B><BR>Cumhuriyet Caddesi I Taksim<BR> 
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Tel: (212) 256 43 56<BR>Fax: (212) 254 43 34</P><P><B>Alia 
(Jordanian Airlines)</B><BR>Cumhuriyet Caddesi 163 Kat 2 
lmadag<BR>Tel: (212) 230 40 74<BR>Fax: 234 54 10</P><P> 
<B>Alitalia</B><BR>Cumhuriyet Caddesi Seyhan Apt. 12/4<BR> 
Elmadag,<BR>Tel: (212) 231 33 91-92<BR>Fax: (212) 230 63 4</P> 
<P><B> American Airlines</B><BR>Cumhuriyet Caddesi 4 7 /2 
Taksim<BR>Tel: (212) 237 20 03<BR>Fax: (212) 237 20 05</P> 
<P> <B>Austrian Airlines</B><BR>Sheraton Hotel Taksim<BR>Tel: 
(212) 232 22 OO<BR>Fax: (212) 234 37 28</P> 
<P><B>Azerbaijan Airlines</B><BR>Cumhuriyet Caddesi 39/I 
Taksim<BR>Tel: (212) 237 42 01-02<BR>Fax: (212) 237 42 00</P> 
<P><B>Balkan Bulgarian Airlines</B><BR>Cumhuriyet 
Caddesi<BR>Gezi Dukkanlan Taksim<BR>Tel: (212) 245 24 56</P> 
<P><B>British Airways</B><BR>Cumhuriyet Caddesi 10 
lmadag<BR>Tel: (212) 234 13 OO<BR>Fax: (212) 234 13 08</P> 
<P><B>Cathay Pacific Airlines</B><BR>Cumhuriyet Caddesi 309 
Kat I Harbiye<BR>Tel: (212) 241 71 17 - 2416833<BR>Fax: (212) 
234 49 99</P> 
<P><B>Continental Airlines</B><BR>Cumhuriyet Caddesi 163 Kat I 
Elmadag,<BR>Tel: (212) 230 48 32<BR>Fax: (212) 230 83 26</P> 
<P><B>Delta Airlines</B><BR>Istanbul Hilton Girisi Harbiye<BR> 
Tel: (212) 231 23 39<BR>Fax: (212) 2312346</P> 
<P><B>Egypt Air</B><BR>Cumhuriyet Caddesi 337-339 Kat 1 
Harbiye<BR>Tel: (212) 231 11 26<BR>Fax: (212) 234 07 54</P> 
<P><B>El-Al (Israeli Airlines)</B><BR>Rumeli Caddesi Nisantasi Is 
Mrk.<BR>Kat 4 No. 1 Nisantas<BR>Tel: (212) 246 53 03<BR>Fax: 
(212) 230 37 05</P> 
<P><B>Emirates Airlines</B><BR>Halaskargazi Caddesi 69/71 
Harbiye<BR>Tel: (212) 232 32 16<BR>Fax: (212) 240 20 85</P> 
<P><B>Finnair</B><BR>Cumhuriyet Caddesi 26, Elmadag, lst<BR> 
Tel: (1) 234 51 30<BR>Fax: (212) 234 47 44</P> 
<P><B>Georgia Airlines</B><BR> Y olcuzade Iskender Cad. <BR>66- 
68 Kat 2<BR>Sishane<BR>Tel: (212) 253 11 11-253 01 16<BR>Fax: 
(212) 253 21 58</P> 
<P><B>Gulf Air</B><BR>Cumhuriyet Cad. Hilton Oteli Girisi<BR> 
Elmadag<BR>Tel: (212) 231 34 50<BR>Fax: (212) 234 47 44</P> 
<P><B>Iberia</B><BR>Topcu Caddesi Uygun Apt. 2/2 Taksim<BR> 
Tel: (212) 255 19 68<BR>Fax: (212) 250 54 78 -<BR>256 12 13</P> 
<P><B>Iranair</B><BR>Curnhuriyet Caddesi 71 Elmadag<BR>Tel: 
(212) 225 02 55<BR>Fax: (212) 225 22 00</P> 
<P><B>JAL (Japanse Airlines)</B><BR>Cumhuriyet Caddesi 141/6 
K.2 Elmadag,<BR>Tel: (212) 241 73 66<BR>Fax: (212) 234 22 
9</P> 
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<P><B>KLM (Royal Dutch Airlines)</B><BR>Abdi Ipekci Caddesi 
<BR>Unsal Apt 8 Nisantasi<BR>Tel: (212) 230 03 11 <BR>Fax: 
(212) 232 87 49</P> 
<P><B>KTHY (Turkisyh Airlines of Northern Cyprus)</B><BR> 
Buyukdere Cad 56/B Mecidiyekoy<BR>Tel: (212) 272 32 79-<BR> 
267 09 73 (3 lines)<BR>Fax: (212) 274 69 34</P> 
<P><B>Kuwait Airlines</B><BR>Cumhuriyet Caddesi 30<BR> 
Elmadag, Istanbul<BR>Tel: (212) 240 40 81<BR>Fax: (212) 231 45 
37</P> 
<P><B>Lot (Polish Airlines)</B><BR>Cumhuriyet Caddesi 91 Kat 2 
Elmadag,<BR>Tel: (212) 241 57 49<BR>Fax: (212) 246 76 26</P> 
<P><B>Lufthansa</B><BR>Maya Akar Center Buyukdere 
Caddesi<BR>l00-102 Esentepe<BR>Tel: (212) 288 10 50<BR>Fax: 
275 69 61 </P> 
<P><B>Malev (Hungarian Airlines)</B><BR>Cumhuriyet Caddesi 
71 K.2. Elmadag,<BR>Tel: (212) 230 71 30<BR>Fax: (212) 230 20 
34</P> 
<P><B>MAS (Malaysian Airlines)</B><BR>Cumhuriyet Caddesi 71 
K.2 Elmadag,<BR>Tel: (212) 230 71 30<BR>Fax: (212) 230 03 
7</P> 
<P><B>Middle East Airlines (MEA)</B><BR>Cumhuriyet Caddesi 
30 Harbiye<BR>Tel: (212) 248 22 41-42<BR>Fax: (212) 248 37 
3</P> 
<P><B>Olympic Airways</B><BR>Cumhuriyet Caddesi 171/A 
ElmadagTel: (212) 246 50 81<BR>Fax: (212) 232 21 73</P> 
<P><B>Pakistan Airlines (PIA)</B><BR>Cumhuriyet CaddesiTarhan 
203<BR>Elmadag<BR>Tel: (212) 233 05 71 <BR>Fax: (212) 234 10 
60</P> 
<P><B>Royal Air Maroc</B><BR>Valikonagi Caddesi Kose Atp. 
01/4<BR>Nisantasi<BR>Tel: (212) 231 80 21-231 71-21 <BR>Fax: 
(212) 230 65 23</P> 
<P><B>Sabena</B><BR>Topcu Caddesi Uygun Apt. 2/1 
Taksim<BR>Tel: (212) 254 72 54<BR>Fax: (212) 255 13 74</P> 
<P><B>SAS Scandinavian Airlines</B><BR>Cumhuriyet Caddesi 
26/A<BR>Elmadag<BR>Tel: (212) 246 60 75<BR>Fax: 233 88 
03</P> 
<P><B>Saudi Arabian Airlines</B><BR>Cumhuriyet Caddesi Inkilap 
Apt. 33, Elmadag<BR>Tel: (212) 256 48 OO<BR>Fax: (212) 256 46 
47</P> 
<P><B>Singapore Airlines</B><BR>Halaskargazi Caddesi 113 
Harbiye<BR>Tel: (212) 232 37 06<BR>Fax: (212) 248 86 20</P> 
<P><B>Syrian Arab Airlines</B><BR>Istanbul Sheraton Hotel<BR> 
Taksim, Istanbul<BR>Tel: (212) 246 17 81<BR>Fax: (212) 231 21 
80</P> 

- 126 - 



NEAR EAST UN/f/ERSTY 
COMPUTER ENC/NEER/NC 

1988 

<P><B>Swissair</B><BR>Cumhuriyet Caddesi Pak Apt. 6, 
Elmadag<BR>Tel: (212) 2312844<BR>Fax: (212) 240 15 13</P> 
<P><B>Qantas Australian Airlines</B><BR>Cumhuriyet Caddesi 
155/1, Elmadag<BR>Tel: (212) 240 50 32 -<BR>246 34 66<BR> 
Fax: (212) 241 55 52</P> 
<P><B> T AROM Romanian Airlines</B><BR>Cumhuriyet Caddesi 
125 Kat 4, Elmadag<BR>Tel: (212) 230 73 09<BR>Fax: (212) 241 01 
30</P> 
<P><B>Tunisair</B><BR>Valikonagi Caddesi Bizim Apt. 8 
isantasi<BR>Tel: (212) 233 93 06-<BR>248 29 04<BR>Fax: (212) 
246 22 08</P> 
<P><B>TWA</B><BR>Cumhuriyet Caddesi 193, Elmadag,<BR> 
Tel: (212) 234 53 27<BR>Fax: (212) 230 63 44</P> 
<P><B>United Airlines</B><BR>Cumhuriyet Caddesi 209/2, 
Elmadag<BR>Tel: (212) 224 91 80<BR>(6 lines)<BR>Fax: (212) 232 
40 74</P> 
<P><B> Varig (Brazilian Airlines )</B><BR> 19 Mayis Caddesi 
4/505<BR>Nova Baran Carsis Sisli<BR>Tel: (212) 240 45 56<BR> 
Fax: (212) 240 51 06</P> 
<P><FONT SIZE="4"><B>Ankara</B></FONT></P> 
<P><B> Aeroflot</B><BR>Cinnah Caddesi 114/2 Cankaya<BR> Tel: 
(312) 440 98 74-75<BR>Fax: (312) 440 92 20</P> 
<P><B>Air France</B><BR>Ataturk Bulvan, 231/7 
Kavaklidere<BR>Tel: (312) 467 44 OO<BR>Fax: (312) 468 25 95</P> 
<P><B>Alitalia</B><BR>Iran Caddesi 21 Kat 3 No. 369<BR> 
Kavaklidere<BR>Tel: (312) 418 88 13-425 38 13<BR>Fax: (312) 417 
97 96</P> 
<P><B>Austrian Airlines</B><BR>Cinnah Caddesi 43/8 
Cankaya<BR>Tel: (312) 417 56 16-17<BR>Fax: (312) 440 61 08</P> 
<P><B>British Airways</B><BR>Ataturk Bulvan, 237/29 
Kavaklidere<BR>Tel: (312) 467 55 57<BR>Fax: (312) 427 33 13</P> 
<P><B>KTHY (Turkish Airlines of Northern Cyprus)</B><BR> 
Selanik Caddesi 17/1 Kizilay<BR>Tel: (312) 418 04 25<BR>Fax: 
(312) 418 78 17</P> 
<P><B>Delta Airlines</B><BR>Tunus Caddesi 85/8 
Kavaklidere<BR>Tel: (312) 468 28 08<BR>Fax: (312) 467 19 75</P> 
<P><B>KLM Royal Dutch Airlines</B><BR>Cinnah Caddesi 43/8 
Cankaya<BR>Tel: (312) 417 56 16-17<BR>Fax: (312) 440 61 08</P> 
<P><B>Lufthansa</B><BR>Iran Caddesi 2 Kavaklidere<BR>Tel: 
(312) 467 55 lO<BR>Fax: (312) 427 84 71</P> 
<P><B>SAS Scandinavian Airlines</B><BR>Ataturk Bulvan, 127 
Sercan Han Kat 4<BR>Bakanliklar<BR>Tel: (312) 425 51 90-425 76 
13<BR> Fax: (312) 417 24 28</P> 
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<P><B>Sabena</B><BR> Tunali Hilmi Caddesi, 112/1 
Kavaklidere<BR>Tel: (312) 467 25 35-36<BR>Fax: (312) 467 25 
43</P> 
<P><FONT SIZE="4"><B>Izmir</B></FONT></P><P><B>Air 
France</B><BR> 1353. Sokak Taner Ishani 1 <BR>Kat 2 205- 
206<BR>Tel: (232) 425 90 04(3)<BR>Fax: (232) k484 66 31 <IP> 
<P><B>Alitalia</B><BR>Ataturk Caddesi 328/A I.l Kordon<BR> 
Tel: (232) 42 71 97<BR>Fax: (232) 463 31 62</P> 
<P><B> Austrian Airlines</B><BR>Sair Esref Bulvan 5/105<BR> 
1371. Sokak Alkan Han Cankaya<BR>Tel: (232) 425 97 22- 425 80 
20<BR>Fax: (232) 425 03 09</P> 
<P><B> British Airways</B><BR>Sair Esref Bulvan 18<BR> 
Altay Is Mrk. Kat 3 No.1304 Cankaya,<BR>Tel: (232) 441 38 
29<BR>Fax: (232) 441 62 94</P> 
<P><B>Delta Airlines</B><BR>Cumhuriyet Bulvan 143/H 
Alsancak<BR>Tel: (232) 421 42 62-63 <BR>KLM (Royal Dutch 
Airlines)<BR>Adnan Menderes Airport<BR>Tel: (232) 274 20 
82</P> 
<P><B> L ufthansa</B><BR> 13 79 Sokak 23 Alsancak<BR> 
Tel: (232) 422 36 22<BR>Fax: (232) 422 64 12</P> 
<P><B>SAS (Scandinavian Airlines)</B><BR>Cumhuriyet Meydani 
Neyzan Apt. 11/2, Alsancak<BR>Tel: (232) 421 47 57-463 49 
60<BR>Fax: (232) 463 64 58</P> 
<P><B>Swissair</B><BR>Cumhuriyet Meydani Meydan Apt. 11/2, 
Pasaport<BR>Tel: (232) 463 49 60 - 463 49 90<BR>Fax: (232) 463 
64 58</P> 
<P><FONT SIZE="4"><B>Antalya</B></FONT></P> <P><B> 
SunExpress</B><BR>Fener Mahallesi, Sinangoglu Caddesi<BR> 
Oktay Apt. P.O. Bo 28 07100<BR>Tel: (242) 323 40 47-48<BR> 
Fax: (242) 323 40 57</P> 
<P> 
<H3>Charter Aircraft</H3> 
<P><FONT SIZE=" 4 "><B> Istanbul </B></FONT></P> 
<P><B>Birgen Air</B><BR>Cumhuriyet Caddesi 301/9 Harbiye, 
<BR>Istanbul<BR>Tel: (212) 240 11 50-246 17 61 <BR>Fax: (212) 
246d 57 11 </P> 
<P><B>Bon Air</B><BR>Orman Sokak 10 Florya, Istanbul<BR> 
Tel: (212) 663 18 29<BR>Fax: (212) 574 01 47</P> 
<P><B>Genel Havacilik</B><BR>Polis Egitim Merkezi Arkasi<BR> 
Ozel Havacilik Hangarlar Bolgesi<BR>Sefakoy, Istanbul<BR> 
Tel: (212) 5412917<BR>Fax: (212) 5412923</P> 
<P><B>Mach Air</B><BR>P9olis Egitim Merkezi Arkasi<BR> 
OzelHavacilik Hangarlar Bolgesi<BR>Sefaoy, Istanbul<BR> 
Tel: (212) 541 14 23 -24<BR>Fax: (212) 541 95 94</P> 
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<P><B>Sancak Air</B><BR>Polis Egitim Merkezi Arkasi<BR> 
Ozel Havacilik Hangarlar Bolgesi<BR>Sefakoy, Istanbul<BR> 
Tel: (212) 541 41 41 <BR>Fax: (212) 541 02 85</P> 
<P><B>TGI Turistik Islet. ve Havacilik</B><BR>Cumhuriyet Cad. 
Hava Palas 155/1 <BR>Elmadag, Istanbul<BR>Tel: (212) 232 52 
OO<BR>Fax: (212) 241 55 52</P> 
<P><B>Top Air</B><BR>Polis Egt. Merkezi Arkasi<BR>Sefakoy, 
Istanbul<BR>Tel: (212) 599 02 27 - 599 07 59<BR>Fax: (212) 599 79 
10 - 598 50 60</P> 
<P><FONT SIZE=" 4 "><B> Ankara</B></FONT></P><P><B> Belko 
Air</B><BR>Mesnevi Sokak 27/A<BR>Asagi Ayranci, Ankara<BR> 
Tel: (312) 440 94 20</P> 
<P> 
<H2> Travel Agencies</H2> 
<H3>Association of Travel Agencies of Turkey (TURSAB)</H3> 
<P>Gazeteciler Sitesi Haberier Sokak 15<BR>Esentepe, Istanbul 
<BR>Tel: (212) 274 13 97 -275 13 61-62<BR>Fax:; (212) 275 00 66 
<BR>Arar Tur Turizm/Istanbul<BR>Tel: (212) 230 10 27 -230 09 
90<BR>Fax: (212) 230 91 71 <BR>Camel Tur/Istanbul<BR>Tel: 
(212) 257 78 28<BR>Fax: (212) 278 31 43 <BR>Duru 
Turizm/Istanbul<BR>Tel: (212) 231 90 08<BR>Fax: (212) 233 03 91 
<BR>Duru Turizm/Ankara<BR>Tel: (312) 440 75 76<BR>Fax: (312) 
440 36 23 <BR>Duru Turizm/Izmir<BR>Tel: (232) 463 29 11 -463 50 
93<BR>Fax: (232) 421 35 66 <BR>Ekin Turizm/Istanbul<BR>Tel: 
(212) 234 43 OO<BR>(5 lines)<BR>Fax: (212) 232 92 60 <BR>Irem 
Tur/Istanbul<BR>Tel: (212) 296 25 03<BR>Fax: (212) 230 30 27 
BR>Irem Tur/Ankara<BR>Tel: (312) 425 28 70-418 69 94<BR>Fax: 
(312) 417 59 23 <BR>Oger Tours/Istanbul<BR>Tel: (242) 247 46 
O<BR>Fax: (242) 248 74 51 <BR>Oger Tours/Izmir<BR>Tel: (232) 
464 07 67<BR>Fax: (232) a464 07 74 <BR>Oger Tours/Antalya<BR> 
Tel: (242) 247 46 60<BR>Fax: (242) 248 74 51 <BR>Oger 
Tours/Istanbul<BR>Tel: (212) 632 02 46<BR>(4 lines)<BR>Fax: 
(212) 632 02 07 <BR>Pacha Tour/Istanbul<BR>Tel: (212) 235 01 
45<BR>(7 lines)<BR>Fax: (212) 235 01 52 <BR>Prog Turizm/ 
Istanbul <BR>Tel: (212) 230 46 73<BR>(3 lines)<BR>Fax: (212) 234 
05 65 <BR>Setur/Istanbul<BR>Tel: (212) 230 03 36<BR>(8lines) 
<BR>Fax: (312) 230 32 19 <BR>Setur/Ankara<BR>Tel: (312) 467 11 
65<BR>Fax: (312) 467 87 75 <BR>Setur/Izmir<BR>Tel: (232) 463 
61 OO<BR>Fax: (232) 422 22 18 <BR>Tantur/Istanbul<BR>Tel: (212) 
272 49 64<BR>Fax: (212) 272 58 02 <BR>Ten Tur/Istanbul<BR>Tel: 
(212) 293 06 50<BR>(6 lines)<BR>Fax: (212) 293 06 57-58 <BR>Tui 
Tourism Travel Agency/Istanbul<BR>Tel: (212) 517 68 31 -518 57 
2<BR>Fax: (212) 518 58 26 <BR>Tura Turizm/Istanbul<BR>Tel: 
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(212) 241 60 82 -<BR>246 53 32<BR>Fax: (212) 233 99 94 <BR> 
Turk Express/Istanbul<BR>Tel: (212) 230 15 15<BR>Fax: (212) 232 
93 73 <BR>Turk Express/Ankara<BR>Tel: (312) 467 73 34-35<BR> 
Fax: (312) 467 29 20 <BR>Vip Turizm/Istanbul<BR>Tel: (212) 241 
65 14<BR>Fax: (212) 230 64 25<H2>0ther Means of Transportation 
in Turkey</H2> 

<UL> 
<LI><A HREF="#Airports "> Airports</ A> 
<Ll><A HREF="#Maritime Lines">Maritime Lines</A> 
<Ll><A HREF="#Sea Buses (Istanbul only)">Sea Buses (Istanbul only)</A> 
<LI><A HREF="#Inner-city Bus Terminals">Inner-city Bus Terminals</A> 
<LI><A HREF="#Car Rental Offices">Car Rental Offices</ A> 
</UL> 

<H3> Airports</H3> 
<P> Istanbul Ataturk International Airport<BR>(212) 663 64 60<BR> 
Ankara Esenboga International Airport<BR>(312) 398 00 OO<BR> 
Izmir Adnan Menderes Airport<BR>(232) 274 24 05</P> 
<P><H3>State Railways</H3><P>Ankara Operator<BR>(312) 309 
05 15<BR>Istanbul Operator (Sirkeci)<BR>(212) 520 65 75<BR> 
Sirkeci Station Information<BR>(212) 527 00 50<BR>Operator 
(Haydarpasa)<BR>(216) 348 80 20<BR>Haydarpasa Station 
Information<BR>(212) 336 04 75<BR>Haydarpasa Reservation<BR> 
(212) 337 87 24-336 44 70<BR>Izmir Operator (Alsancak)<BR> 
(232) 433 58 97 -421 01 14<BR>Operator (Basmane)<BR>(232) 484 
86 38</P> 
<P> 
<H3>Maritime Lines</H3> 
<P>Istanbul City Ferry Lines<BR>(212) 244 42 33<BR>Maritime 
Lines (Information)<BR>(212) 244 02 07<BR>Maritime Lines 
Mngmnt)<BR>(212) 245 53 66<BR>Maritime Lines Reservations 
<BR>(212) 293 74 54 -<BR>249 92 22<BR>Izmir Alsancak 
Mngmnt)<BR>(232) 421 00 94-<BR>4210077 <BR>Available trips 
(in Turkey )<BR> Istanbul-Izmir<BR> Istanbul-Marmara<BR> Istanbul­ 
Black Sea <BR>Available trips (abroad)<BR>Turkey-North Cyprus 
<BR>Turkey-Italy</P> 
<P> 
<H3>Sea Buses (Istanbul)</H3> 
<P>Bakirkoy (212) 560 72 91<BR>Bostanci (216) 362 04 44 (3 Lines) 
<BR>Kabatas (212) 249 15 58<BR>Kadikoy (216) 336 88 19<BR> 
Karakoy (212) 251 61 44<BR>Kartal (212) 306 20 OO<BR>Yenikapi 
(212) 517 71 37<BR>Yaloa (216) 812 04 99</P> 
<P> 
<H3>Inner-city Bus Terminals</H3> 

- 130 - 



NEAR EAST UNIVER$TY 
COMPUTER ENQ/NEER/NQ 

1988 

<P>Ankara<BR>(312) 310 47 47<BR>Istanbul Esenier<BR>(212) 
658 00 36 (10 lines)<BR>Istanbul Harem<BR>(216) 333 37 63<BR> 
Izmir<BR>(232) 486 22 66</P> 
<P> 
<H3>Major Bus Companies</H3> 
<P>Bostor Turizm<BR>Istanbul (Taksim)<BR>(212) 251 70 OO<BR> 
Ankara (Kizilay)<BR>(312) 425 72 03 <BR>Pamukkale Turizm<BR> 
Ankara (Terminal)<BR>(312) 433 04 70-433 30 07<BR>Istanbul 
(Taksim)<BR>(212) 245 29 46-249 27 91 <BR>Istanbul Kadikoy) 
<BR>(216) 336 54 13<BR>Istanbul (Esenler)<BR>(212) 658 22 22 
(10 lines)<BR>Izmir (Terminal)<BR>(232) 484 08 00 <BR>Ulusoy 
Turizm<BR>Ankara (Sogutozu)<BR>(312) 286 53 30<BR>Ankara 
(Kizilay )<BR>(3 l 2) 419 40 80<BR> Istanbul (Kadikoy )<BR>(216) 
336 93 66 -345 93 04<BR>Istanbul (Merter)<BR>(212) 547 70 22- 
28<BR>Izmir (Efes)<BR>(232) 441 71 50<BR>Izmir (Karsiyaka) 
<BR>(232) 369 19 66 <BR>Varan Turizm<BR>Ankara Kizilay)<BR> 
(312) 417 25 25<BR>Ankara (Sogutozu)<BR>(312) 287 12 11 (2 
lines) <BR>Istanbul (Taksim)<BR>(212) 2517474 (8 lines)<BR> 
Istanbul (Kadikoy)<BR>(216) 337 29 65 -345 40 81<BR>Istanbul 
(Bayrampasa)<BR>(212) 658 02 70<BR>Izmir (Efes)<BR>(232) 489 
19 17 (3 lines)<BR>Izmir (Karsiyaka)<BR>(232) 3816919</P><P> 
<H3>Car Rental Offices</H3><P><B> A VIS</B><BR> Istanbul<BR> 
Kurucesme<BR>Tel: (212) 257 76 70<BR>(10 lines)<BR>Fax: (212) 
257 56 32<BR>Ataturk Airport Domestic Terminal<BR>Tel: (212) 
573 14 52-573 38 70<BR>ATaturk Airport International Terminal 
<BR>Tel: (212) 663 06 46- 47<BR>Beyazit<BR>Tel: (212) 516 61 09 
-lO<BR>Hilton Hotel<BR>Tel: (212) 241 78 96-2412917<BR> 
Kadikoy<BR>Tel: (216) 355 36 65 <BR>Ankara<BR> Kavaklidere 
<BR>Tel: (312) 467 23 13<BR>Fax: (312) 467 57 03<BR>Esenboga 
Airport Domestic Terminal<BR>Tel: (312) 398 03 15-398 00 00 (Ext: 
1570) <BR>Izmir<BR>Adnan Menderes Airport<BR>Tel: (232) 274 
21 74<BR>Fax: (232) 274 21 72<BR>Alsancak<BR>Tel: (232) 441 
44 17 -18<BR>Fax: (232) 4414420<BR>Hilton Hotel<BR>Tel: 
(232) 441 60 16<BR>Karsiyaka<BR>Tel: (232) 381 63 73 
<BR>Antalya<BR>Antalya Airport<BR>Tel: (242) 330 30 73 - 330 
30 08<BR>Downtown Office<BR>Tel: (242) 241 66 930 <BR>242 
56 42<BR>Fax: (242) 241 94 83</P> 
<P><B> Budget</B><BR> Istanbul<BR> Ataturk Airport<BR> Tel: 
(212) 663 08 58<BR>Downtown Office<BR>Tel: (212) 253 92 00 - 
53 96 53<BR>Fax: (212) 256 26 11 <BR>Ankara<BR>Downtown 
Office<BR>Tel: (312) 417 59 52<BR>Fax: (312) 425 96 08<BR> 
Esenboga Airport<BR>Tel: (312) 398 03 72-<BR>398 0 00 (Ext: 
1730) <BR>Izmir<BR>Adnan Menderes Airport<BR>Tel: (232) 251 
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30 86<BR>Downtown Office<BR>Tel: (242) 243 30 06<BR>(3 
lines)<BR>Fax: (242) 242 50 46</P> 
<P><B> Ekin-Hertz</B><BR> Istanbul<BR> Downtown Office<BR> 
Tel: (212) 234 43 OO<BR>(5 lines)<BR>Fax: (212) 232 92 60 <BR> 
Ankara<BR>Esenboga Airport<BR>Tel: (312) 398 05 85 <BR> 
Izmir<BR>Adnan Menderes Airport<BR>Tel: (232) 274 21 93 
<BR>Adana<BR>Airport<BR>Tel: (322) 436 75 68 <BR> Antalya 
<BR>Airport<BR>Tel: (242) 330 30 23 <BR><B>EUROPCAR 
</B><BR>Istanbul<BR>Taksim<BR>Tel: (212) 254 77 99 - 253 58 
73<BR>Fax: (212) 255 59 28<BR>Airport<BR>Tel: (212) 663 07 46 
-47 <BR>Ankara<BR>Downtown Office<BR>Tel: (312) 416 36 
77<BR>Airport<BR>Tel: (312) 398 05 03- 398 00 00 (Ext: 740)<BR> 
Fax: (312) 417 84 45 <BR>lzmir<BR>Downtown Office<BR>Tel: 
(232) 441 51 41-4415521<BR>Fax: (232) 483 00 3l<BR>Airport 
<BR>Tel: (232) 30 74 <BR>Antalya<BR>Downtown Office<BR> 
Tel: (242) 241 88 79<BR>Fax: (31) 248 35 20 

</BODY> 

</HTML> 
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TURK3.HTM 

<HTML> 

<HEAD> 

<META HTTP-EQUIV="Content-Type" CONTENT="text/html; 
charset=windows-1252 "> 
<META NAME="Generator" CONTENT="Microsoft Word 97"> 
<META NAME="AUTHOR" Content="METIN TASKIN"> 
<META NAME="DESCRIPTION" Content="This about 
TURKIYE"> 
<MET A N AME="KEYWORDS" Content="turkiye,hotel,akdeniz 
antalya,izmir, mersin,giresun,ataturk,trabzon, ofo hotel,hilton,prencess, 
kit tur,ormancilar,sheraton"> 

<TITLE> Turkiye</TITLE> 
</HEAD> 

<FRAMESET COLS = "150,644 " > 
<FRAME SRC="fthl3 .htm" NAME="Frame2002514" 
RESIZE> 
<FRAME SRC="fthr3.htm" NAME="Frame2002533" 
RESIZE> 
</FRAMES ET> 
<NO FRAMES> 

<BODY> 
<P> 
</BODY> 

</NO FRAMES> 
</HTML> 

FTHl3.HTM 

<HTML> 
<HEAD> 

<MET A HTTP-EQUIV=" Content-Type" CONTENT="text/html; 
charset=windows-1252 "> 
<META NAME="Generator" CONTENT="Microsoft Word 97"> 
<META NAME=" AUTHOR" Content="METIN T ASKIN"> 
<META NAME="DESCRIPTION" Content="This about 
TURKIYE"> 
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<MET A NAME="KEYWORDS" Content="turkiye,hotel,akdeniz, 
antalya,izmir, mersin,giresun,ataturk, trabzon, ofo hotel,hilton,prencess, 
kit tur,ormancilar,sheraton"> 

<TITLE> Turkiye</TITLE> 
</HEAD> 
</HEAD> 

<BODY BACKGROUND="CDTSBK.jpg" TEXT="#CCOOOO" 
LINK ="#CCOOOO" VLINK ="#660000" ALINK="#CCOOOO"> 
<P ALIGN="CENTER"><IMG SRC="globe7.gif'' WIDTH="88" 
HEIGHT="88" ALIGN="BOTTOM" ALT="dunya" BORDER="O"> 

<CENTER> 
<B><BLINK></B><A HREF="index.htm" target="_top"><FONT 
F ACE="Arial, Helvetica"><B> WELCOME</ A> </B></FONT><B> 
</BLINK></B><A HREF="index.htm" target="_top"><BR></A> 
<B><BLINK></B><A HREF="index.htm" target="_ top"><FONT 
FACE=" Arial, Helvetica"><B> TURKEY</ A></B></FONT><B> 
</BLINK></B><BR> 
<IP> 
<P ALIGN="CENTER"><IMG SRC="Flagtk.gif'' WIDTH="121" 
HEIGHT="71" ALIGN="BOTTOM" BORDER="O"></CENTER> 
<BR> 
<BR> 
<IP> 
<P><IP> 
<P><BR> 
<IP> 
<P ALIGN="CENTER"><A HREF="turk2.htm" target="_top"><IMG 
SRC="docsleft.gif'' WIDTH="30" HEIGHT="30" ALIGN= 
"BOTTOM"BORDER="O"></A><A HREF= "turkO.htm" target= 
"_top"><IMG SRC="docsupar.gif'' WIDTH="30" HEIGHT="30" 
ALIGN="BOTTOM"BORDER="O"></A><A HREF= "tou.htm" 
target="_top"><IMG SRC="docsrigh.gif'' WIDTH="30" HEIGHT= 
"30" ALIGN="BOTTOM" BORDER="O"></A> 
</BODY> 

</HTML> 
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FTHR2.HTM 

<HTML> 
<HEAD> 

<META HTTP-EQUIV="Content-Type" CONTENT="text/html; 
charset=windows-1252 "> 
<META NAME="Generator" CONTENT="Microsoft Word 97"> 
<META NAME="AUTHOR" Content="METIN TASKIN"> 
<META NAME="DESCRIPTION" Content="This about 
TURKIYE"> 
<MET A NAME="KEYWORDS" Content="turkiye,hotel,akdeniz, 
antalya,izmir,mersin,giresun,ataturk,trabzon, ofo hotel,hilton,prencess, 
kit tur,ormancilar,sheraton"> 

<TITLE> Turkiye</TITLE> 
</HEAD> 

<BODY BACKGROUND="CDTSBK.jpg" TEXT="#660099"> 
<P ALIGN="CENTER"><FONT SIZE="4" COLOR="#330066" > 
<B>Common Expressions and helpful phrases in Turkish:</B> 
</FONT></P> 
<P><FONT COLOR="#330066"><B>Pronunciation</B></FONT> 
<IP> 
<P><B>a:</B> <I>a</I>rt <B>e:</B> b<I>ea</I>r <B>u:</B> 
y<I>ou</I> <B>c:</B> <I>ch</I>art <B>s:</B> <I>sh</I>arp 
<B>k:</B> <I>k</I>ick</P> 
<P><B>o: </B><I>ea</I>rly</P> 
<P><FONT COLOR="#330066"><B>Basics</B></FONT></P> 
<P>Hello: Merhaba Goodbye: Allahaismarladik (said by the person 
leaving)// Gule Gule (Said by the person seeing This/her friend off) 
<IP> 
<P>Good morning: Gunaydin Good evening: Iyi Aksamlar Good 
night: Iyi Geceler</P> 
<P>How are you?: Nasilsiniz? I am well: Iyiyim</P> 
<P>Yes: Evet No: Hayir Please: Lutfen Thank You: Tesekkur ederim 
or Mersi</P> 
<P>There is: Var There is not: Yok both expressions used to express 
availability or lack thereof respectively</P> 
<P>I want...: (object)+ istiyorum</P> 
<P><B> Numbers</B></P> 
<PRE WIDTH="132"><B>l</B> Bir <B>ll</B> Onbir 
<B>30</B> Otuz <B>l00,000</B> Yuzbin <B>2</B> 
Iki <B> 12</B> Oniki <B>40</B> Kirk <B> 1 million</B> 
Bir milyon <B> 3</B> Uc <B> 13</B> Onuc <B>50</B> 
Elli <B> 1 billion</B> Bir milyar <B>4</B> Dort 
<B> 14</B> Ondort <B>60</B> Altmis <B>5</B> 
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Bes <B>15</B> Onbes <B>70</B> Yetmis 
<B>6</B> Alti <B> 16</B> Onalti <B>80</B> 
Seksen <B>7</B> Yedi <B>l7</B> Onyedi 
<B>90</B> Doksan <B>8</B> Sekiz <B> 18</B> 
Onsekiz <B> 100</B> Yuz </B> Dokuz <B> 19</B> 
Ondokuz <B>200</B> lkiyuz <B> 1 O</B> <B>On</B> 
<B>20</B> Yirmi <B> 1000</B> Bin </PRE> 
<P><B>Expressions ofTime</B></P> 
<P>When?: Ne zaman? Yesterday: Dun Today: Bugun Tomorrow: 
Yarin</P> 
<P>Moming: Sabah Afternoon: Ogleden sonra Evening: Aksam Night: 
Gece</P> 
<P>One hour: Bir saat What is the time?: Saat kac? At what time? Saat 
kacta?</P> 
<P><B> The Days of the Week</B></P> 
<PRE WIDTH="132"><B>Sunday</B> <B>Monday</B> 
<B> Tuesday</B> <B> Wednesday</B> <B> Thursday</B> 
<B>Friday</B> <B>Saturday</B> Pazar Pazartesi Sali 
Carsamba Persembe Cuma Cumartesi </PRE> 
<P><B> Travel Terms</B></P> 
<P>Airport: Hava alani Port: Liman Town Center: Sehir merkezi</P> 
<P>Where is it?: Nerede? Is it far?: Uzak mi? Be careful!: Dikkatli 
ol!</P> 
<P>Tourism Bureau: Turizm burosu A good hotel: lyi bir otel A 
restaurant: Bir lokanta</P> 
<P> Hospital: Hastahane</P> 
<P><B>Helpful vocabulary// Hotel &amp; Restaurant</B></P> 
<P>A room: Bir oda A room with a view: Manzarali bir oda Bed: 
Yatak</P> 
<P>Restroom: Banyo Two people: lki kisi The bill: Hesap Water: 
Su</P> 
<P>Mineral Water: Maden suyu Milk: Sut Tea: Cay Coffee: 
Kahve</P> 
<P>Sugar: Seker Breakfast: Kahvalti Fruit juice: Meyva suyu</P> 
<P>Wine: Sarap Beer: Bira Ice: Buz Bread: Ekmek</P> 
<P>Rice: Pilav Chicken: Pilic/ Tavuk Fish: Balik Meat: Et</P> 
<P>Mutton: Koyun eti Lamb: Kuzu eti Beef: Sigir eti Veal: Dana 
eti</P> 
<P><B>Shopping</B></P> 
<P>Shopping center: Carsi Grocery store: supermarket Pharmacy: 
eczane</P> 
<P>How much is this?: Bu ne kadar? It is expensive: Bu pahli It is 
cheap: Bu ucuz</P> 
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<P> I like it: Begendim I don't like it: Begenmedim Bank: Banka</P> 
<P>Cash machine: Banka matik 
</BODY> 

</HTML> 

TOU.HTM 

<HEAD> 

<META HTTP-EQUIV="Content-Type11 CONTENT="text/html; 
charset=windows-1252 "> 
<META NAME="Generator" CONTENT="Microsoft Word 97"> 
<META NAME="AUTHOR11 Content=11METIN TASKIN11> 
<META NAME=11DESCRIPTION11 Content=This about 
TURKIYE"> 
<META NAME=11KEYWORDS II Content=l'turkiye.hotel.akdeniz, 
antalya,izmir,mersin,giresun,ataturk,trabzon, ofo hotel,hilton,prencess, 
kit tur.ormancilar.sheraton''> 

<TITLE> Tourism</TITLE> 
</HEAD> 

<FRAMESET COLS= 11150,644 11 > 
<FRAME SRC="ftll .htm" NAME="Frame7971125" RESIZE> 
<FRAME SRC="ftrl.htm" NAME="Frame7971152" RESIZE> 
</FRAMES ET> 
<NO FRAMES> 

<BODY> 
<P> 
</BODY> 

</NO FRAMES> 
</HTML> 

FTL1.HTM 

<HTML> 
<HEAD> 

<META HTTP-EQUIV=11Content-Type" CONTENT="text/html; 
charset=windows-1252 "> 
<META NAME="Generator11 CONTENT=11Microsoft Word 9711> 
<META NAME=11AUTHOR11 Content=11METIN TASKIN11> 
<META NAME=11DESCRIPTION11 Content=This about 
TURKIYE11> 
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<MET A NAME="KEYWORDS" Content="turkiye,hotel,akdeniz, 
antalya,izmir,mersin,giresun,ataturk,trabzon, ofo hotel,hilton,prencess, 
kit tur,ormancilar,sheraton"> 

<TITLE>Tourism</TITLE> 
</HEAD> 

<BODY BACKGROUND="CDTSBK.jpg" TEXT="#CCOOOO" 
LINK ="#CCOOOO" VLINK ="#660000" ALINK ="#CCOOOO"> 
<P ALIGN="CENTER"><IMG SRC="Flagtk.gif'' WIDTH="121" 
HEIGHT="71" ALIGN="BOTTOM" BORDER="O"><BR> 
<A HREF ="ant.htm" target="_top"><FONT FACE="Arial, 
Helvetica"><B> ANT ALY A </B></FONT></ A></P> 
<P ALIGN="CENTER"><A HREF="izm.htm" target="_top"><FONT 
FACE="Arial, Helvetica"><B>IZMIR</B></FONT></A></P> 
<P ALIGN="CENTER"><A HREF="gir.htm" target="_top"><FONT 
FACE=" Arial, Helvetica"><B>GIRESUN</B></FONT></ A></P> 
<P ALIGN="CENTER"><A HREF="trab.htm" target="_top"><FONT 
FACE=" Arial, Helvetica"><B> TRABZON </B></FONT></ A></P> 
<P ALIGN="CENTER"><A HREF="trab.htm" target="_top"><FONT 
F ACE="Arial, Helvetica"><B><BR> 
<BR> 
<BR> 
<BR> 
<BR> 
<BR> 
</A><A HREF="turk3.htm" target="_top"><IMG SRC="docsleft.gif'' 
WIDTH="30" HEIGHT="30" ALIGN="BOTTOM" BORDER= 
"O"></A><A HREF="turkO.htm" target="_top"><IMG SRC= 
"docsupar.gif'' WIDTH="30" HEIGHT="30" ALIGN="BOTTOM" 
BORDER="O"></A><A HREF="ant.htm" target="_top"><IMG SRC= 
"docsrigh.gif'' WIDTH="30" HEIGHT="30" ALIGN="BOTTOM" 
BORDER="O"></B></FONT></ A> 
</BODY> 

</HTML> 
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FTR1.HTM 

<HTML> 
<HEAD> 

<META HTTP-EQUIV="Content-Type" CONTENT="text/html; 
charset=windows-1252 "> 
<META NAME="Generator" CONTENT="Microsoft Word 97"> 
<META NAME=" AUTHOR" Content="METIN T ASKIN"> 
<META NAME="DESCRIPTION" Content="This about 
TURKIYE"> 
<META NAME="KEYWORDS" Content="turkiye,hotel,akdeniz, 
antalya,izmir,mersin,giresun,ataturk,trabzon, ofo hotel,hilton,prencess, 
kit tur,ormancilar,sheraton"> 

<TITLE> Tourism</TITLE> 
</HEAD> 

<BODY BACKGROUND="CDTSBK.jpg" TEXT="#CCOOOO" 
LINK ="#CCOOOO" VLINK ="#660000" ALINK ="#CCOOOO"> 
<P ALIGN="CENTER"><FONT COLOR="#CCOOOO" FACE="Arial, 
Helvetica"><B>TOURISTIC PLACES ofTURKEY</B></FONT> 
<IP> 
<P ALIGN="CENTER"><IMG SRC="MAP.jpg" WIDTH="405" 
HEIGHT="189" ALIGN="BOTTOM" BORDER="O" USEMAP= 
"#MAP"></P> 
<CENTER> 
<P> 

<TABLE BORDER="l" WIDTH="lOO"> 
<TR> 
<TD><A HREF="izm.htm" target="_top"><IMG SRC="hilton.jpg" WIDTH= 
"125" HEIGHT="125" ALIGN="BOTTOM" BORDER="O"></A></TD> 
<TD> <A HREF="ant.htm" target="_top"><IMG SRC="falez.jpg" WIDTH= 
"125" HEIGHT="125" ALIGN="BOTTOM" BORDER="O"></A></TD> 
</TR> 
<TR> 
<TD><A HREF="gir.htm" target="_top"><IMG SRC="kittur.jpg" WIDTH= 
"125" HEIGHT="125" ALIGN="BOTTOM" BORDER="O"></A></TD> 
<TD><A HREF="trab.htm" target="_top"><IMG SRC="aksular.jpg" 
WIDTH="125" HEIGHT="125" ALIGN="BOTTOM" BORDER="O" > <IA> 
</TD> 
</TR> 
</TABLE> 

<IP> 
</CENTER> 
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<BLOCKQUOTE> 
<BLOCKQUOTE> 
<BLOCKQUOTE> 
<BLOCKQUOTE> 
<BLOCKQUOTE> 
<BLOCKQUOTE> 
<P><A HREF="ant.htrn" target="_top"><FONT F ACE="Arial, 
Helvetica"><B> ANT ALY A </B></FONT></ A></P> 
<P><A HREF="izrn.htrn" target="_top"><FONT FACE="Arial, 
Helvetica"><B> IZMIR </B></FONT></ A></P> 
<P><A HREF="gir.htrn" target="_top"><FONT F ACE="Arial, 
Helvetica"><B>GIRESUN </B></FONT></ A></P> 
<P><A HREF="trab.htrn" target="_ top"><FONT FACE=" Arial, 
Helvetica"><B> TRABZON </B></FONT></ A> 

</BLOCKQUOTE> 
</BLOCKQUOTE> 
</BLOCKQUOTE> 
</BLOCKQUOTE> 
</BLOCKQUOTE> 
</BLOCKQUOTE> 

<P ALIGN="CENTER"><BR> 
<BR> 
<BR> 
<BR> 
<BR> 
<BR> 
<BR> 
<BR> 
<BR> 
<BR> 
<BR> 
<P> 
<MAP Narne="MAP"><AREA Shape="Circle" coords = "259,48,12" 
AHREF="gir.htrn" target="_top"><AREA Shape="Rect" coords = 
"254,52,318,75" HREF="gir.htrn" target="_top"><AREA Shape= 
"Rect" coords = "277,22,337,46" HREF="trab.htrn" target="_top"> 
<AREA Shape="Rect" coords = "98,136,157,163" HREF="ant.htrn" 
target="_top"><AREA Shape="Rect" coords = "28,86,69,104" A 
HREF="izrn.htrn" target="_top"></MAP> 

</BODY> 
</HTML> 
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ANT.HTM 

<HTML> 

<HEAD> 
<META HTTP-EQUIV="Content-Type" CONTENT="text/html; 
charset=windows-1252 "> 
<META NAME="Generator" CONTENT="Microsoft Word 97"> 
<META NAME="AUTHOR" Content="METIN TASKIN"> 
<META NAME="DESCRIPTION" Content="This about 
TURKIYE"> 
<MET A NAME="KEYWORDS" Content="turkiye,hotel,akdeniz, 
antalya,izmir ,mersin,giresun,ataturk, trabzon, ofo hotel,hilton,prencess, 
kit tur,ormancilar,sheraton"> 

<TITLE> Tourism</TITLE> 
</HEAD> 

<FRAMESET COLS= "151,643" > 
<FRAME SRC="ftil l .htm" NAME="Frame 1327217" RESIZE> 
<FRAME SRC="ftirl.htm" NAME="Frame1327227" RESIZE> 
</FRAMES ET> 

<NO FRAMES> 
<BODY> 
<P> 
</BODY> 
</NO FRAMES> 

</HTML> 

FTIL1.HTM 

<HTML> 
<HEAD> 

<META HTTP-EQUIV="Content-Type" CONTENT="text/html; 
charset=windows-1252 "> 
<META NAME="Generator" CONTENT="Microsoft Word 97"> 
<META NAME="AUTHOR" Content="METIN TASKIN"> 
<META NAME="DESCRIPTION" Content="This about 
TURKIYE"> 
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<META NAME="KEYWORDS" Content="turkiye,hotel,akdeniz, 
antalya,izmir,mersin,giresun,ataturk,trabzon, ofo hotel,hilton,prencess, 
kit tur,ormancilar,sheraton"> 

<TITLE> Tourism</TITLE> 
</HEAD> 

<BODY BACKGROUND="CDTSBK.jpg" TEXT="#CCOOOO" 
LINK ="#CCOOOO" VLINK ="#660000" ALINK ="#CCOOOO"> 
<P ALIGN="CENTER"><IMG SRC="Flagtk.gif'' WIDTH="121" 
HEIGHT=''71" ALIGN="BOTTOM" BORDER="O"><BR> 
<FONT FACE="Arial, Helvetica"><B>ANTAL Y A</B></FONT> 
<IP> 
<P ALIGN="CENTER"><A HREF="izm.htm" target="_top"><FONT 
FACE=" Arial, Helvetica"><B> IZMIR </B></FONT></ A><IP> 
<P ALIGN="CENTER"><A HREF="gir.htm" target="_top"><FONT 
FACE=" Arial, Helvetica"><B>GIRESUN</B></FONT></ A></P> 
<P ALIGN="CENTER"><A HREF="trab.htm" target="_top"><FONT 
FACE="Arial, Helvetica"><B>TRABZON</B></FONT></A></P> 
<P ALIGN="CENTER"><A HREF="trab.htm" target="_top"><FONT 
F ACE="Arial, Helvetica"><B><BR> 
<BR> 
<BR> 
<BR> 
<BR> 
<BR> 
</A><A HREF="tou.htm" target="_top"><IMG SRC="docsleft.gif'' 
WIDTH="30" HEIGHT="30" ALIGN="BOTTOM" BORDER="O" > 
</A><A HREF="turkO.htm" target="_top"><IMG SRC="docsupar. 
gif'' WIDTH="30" HEIGHT="30" ALIGN="BOTTOM" BORDER= 
"O"></A><A HREF="izm.htm" target="_top"><IMG SRC="docsrigh. 
gif'' WIDTH="30" HEIGHT="30" ALIGN="BOTTOM" BORDER= 
"O"> </B> </FONT></ A> 
</BODY> 

</HTML> 

FTIR1.HTM 

<HTML> 
<HEAD> 

<META HTTP-EQUIV="Content-Type" CONTENT="text/html; 
charset=windows-1252 "> 
<META NAME="Generator" CONTENT="Microsoft Word 97"> 
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<META NAME==="AUTHOR" Content==="METIN TASKIN"> 
<META NAME==="DESCRIPTION" Content==="This about 

TURKIYE"> <META NAME==="KEYWORDS" Content==="turkiye,hotel,akdeniz, 
antalya,izmir,mersin,giresun,ataturk,trabzon, ofo hotel,hilton,prencess, 

kit tur,ormancilar,sheraton"> 
<TITLE> Tourism</TITLE> 

</HEAD> 

<BODY BACKGROUND==="CDTSBK.jpg"> 
<H2 ALIGN==="CENTER"><IMG SRC==="At_map.gif' WIDTH==="480" 
HEIGHT==="l50" ALIGN==="BOTTOM" ALT==="antalya" BORDER==="O" 

></H2> <H2><FONT COLOR==="#330066">Antalya</FONT></H2> 
<P> <FONT COLOR==="#330066"><B>&quot;The Turquoise Riviera 

&quot; </B></FONT></P> <P><FONT COLOR==="#660099">Set amid amazing scenery of sharp 
contrasts, Antalya, Turkey's principal holiday resort,is an attractive city 
with shady palm-lined boulevards and a prize-winning marina. In the 
picturesque old quarter,Kaleici, narrow, winding streets and old 
wooden houses abut the ancient city walls. Since its founding in the 
second century B.C. by Attalos II, a king of Pergamon, Antalya has 
been continuously inhabited. The Romans, Byzantinesand Seljuks 
successively occupied the city before it came under Ottoman rule. 

</FONT></P> <P><FONT COLOR==="#660099">At Antalya, the pine-clad Toros 
Mountains sweep down to the sparkling clear sea forming an irregular 
coastline of rocky headlands and secluded coves. The region, bathed in 
sunshine for 300 days of the year, is a paradise of sunbathing and 
swimming and of sporting activities such as windsurfing, water skiing, 
sailing,rafting, mountain climbing and hunting. If you come toAntalya 
in March and April, you may ski the mountains in the mornings and 
swim in the warm waters of the Mediterranean in the afternoons. 
Important historic sites and beautiful mosques await your discovery 
amid a landscape of pine forests, olive and citrus groves and palm, 
avocado and banana plantations. Perge, 18 km from Antalya along the 
east coast, is an important city of ancient Pamphylian. It was originally 
settled by the Hittites around 1500 B.C. The city features the remains 
of a theater and a handsome city gate.</FONT></P> 
<P><FONT COLOR==="#660099"> Also east of Antal ya, the town of 
Aspendos features the best-preserved theater of antiquity .The 
Aspendos Theater, with seating for 15,000, is still in use today. Nearby 
stand the remains of a basilica, agora and one of the largest aqueducts 

in Anatolia.</FONT></P> 
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<P><FONT COLOR="#660099">The Turquoise Coast is Turkey's 
tourism capital. Its full range of accommodations, sunnyclimate, warm 
hospitality and variety of excursions and activities make it a perfect 
holiday spot and popular venuefor meetings and conferences.</FONT> 
<IP> 

<BLOCKQUOTE> 
<P><A HREF="antalya.htm" target="_top">Hotel</A> 

</BLOCK QUOTE> 
</BODY> 

</HTML> 
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<HTML> 
<HEAD> 

<META HTTP-EQUIV=11Content-Type11 CONTENT=11text/html; 
charset=windows-l ZS?"> 
<META NAME=11Generator11 CONTENT=11Microsoft Word 9711> 
<META NAME=11AUTHOR11 Content=11METIN TASKIN11> 
<META NAME=11DESCRIPTION11 Content=l'This about 
TURKIYE"> 
<META NAME=11KEYWORDS II Content=t'turkiye.hotel.akdeniz, 
Antalya,izmir,mersin,giresun,ataturk,trabzon, ofo hotel,hilton,prencess, 
kit tur.ormancilar.sheraton"> 

<TITLE> Tourism</TITLE> 
</HEAD> 

<FRAMESET COLS = 11151,643 11 > 
<FRAME SRC=''ftil2.htm" NAME="Frame2447083" RESIZE> 
<FRAME SRC=11ftir2.htm11 NAME=11Frame244709311 RESIZE> 
</FRAMES ET> 

<NO FRAMES> 
<BODY> 
<P> 
</BODY> 
</NO FRAMES> 

</HTML> 

FTIL2.HTM 

<HTML> 
<HEAD> 

<META HTTP-EQUIV=11Content-Type11 CONTENT=11text/html; 
charset=windows-l Zc?"> 
<META NAME=11Generator11 CONTENT=11Microsoft Word 9711> 
<META NAME=11AUTHOR11 Content=11METIN TASKIN11> 
<META NAME=11DESCRIPTION11 Content='This about 
TURKIYE11> 
<META NAME=11KEYWORDS" Content=l'turkiye.hotel.akdeniz, 
antalya,izmir ,mersin,giresun,ataturk, trabzon, ofo hotel,hilton,prencess, 
kit tur.ormancilar.sheraton"> 

<TITLE> Tourism</TITLE> 
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</HEAD> 
<BODY BACKGROUND="CDTSBK.jpg" TEXT="#CCOOOO" 
LINK="#CCOOOO" VLINK ="#660000" ALINK ="#CCOOOO"> 
<P ALIGN="CENTER"><IMG SRC="Flagtk.gif' WIDTH="121" 
HEIGHT="71" ALIGN="BOTTOM" BORDER="O"><BR> 
<A HREF="ant.htm" target="_top"><FONT FACE="Arial, 
Helvetica"><B> ANT ALY A </B></FONT></ A><IP> 
<P ALIGN="CENTER"><FONT F ACE="Arial, Helvetica"><B> 
IZMIR </B></FONT></P> 
<P ALIGN="CENTER"><A HREF="gir.htm" target="_top"><FONT 
FACE=" Arial, Helvetica"><B>GIRESUN </B></FONT></ A></P> 
<P ALIGN="CENTER"><A HREF="trab.htm" target="_top"><FONT 
F ACE="Arial, Helvetica"><B> TRABZON </B></FONT></ A><IP> 
<P ALIGN="CENTER"><A HREF="trab.htm" target="_top"><FONT 
F ACE="Arial, Helvetica"><B><BR> 
<BR> 
<BR> 
<BR> 
<BR> 
<BR> 
</A><A HREF="ant.htm" target="_top"><IMG SRC="docsleft.gif' 
WIDTH="30" HEIGHT="30" ALIGN="BOTTOM" 
BORDER="O"></A><A HREF="tou.htm" target="_top"><IMG 
SRC="docsupar.gif' WIDTH="30" HEIGHT="30" ALIGN= 
"BOTTOM" BORDER="O"></A><A HREF="gir.htm"target="_top"> 
<IMG SRC="docsrigh.gif' WIDTH="30" HEIGHT="30" 
ALIGN="BOTTOM" BORDER="O"></B></FONT></A> 
</BODY> 

</HTML> 

FTIR2.HTM 

<HTML> 
<HEAD> 
<MET A HTTP-EQUIV=" Content-Type" CONTENT="text/html; 
charset=windows-1252 "> 
<META NAME="Generator" CONTENT="Microsoft Word 97"> 
<MET A NAME=" AUTHOR" Content="METIN T ASKIN"> 
<META NAME="DESCRIPTION" Content="This about TURKIYE"> 
<META NAME="KEYWORDS" Content="turkiye,hotel,akdeniz, 
antalya,izmir ,mersin,giresun,ataturk, trabzon, ofo hotel,hilton,prencess, 
kit tur,ormancilar,sheraton"> 
<TITLE> Tourism</TITLE> 
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</HEAD> 

<BODY BACKGROUND="CDTSBK.jpg"> 
<H2 ALIGN="CENTER"><IMG SRC="Izmirmap.gif' WIDTH= 
"480" HEIGHT=" 150" ALIGN="BOTTOM" BORDER="O"></H2> 
<H2 ALIGN="CENTER"><FONT COLOR="#330066" FACE= 
"Arial, Helvetica">Izmir and the Agean Sea</FONT></H2> 
<P><FONT COLOR="#660099" FACE="Arial, Helvetica">&quot; 
Beautiful Izmir&quot; -- the &quot;Pearl of the Aegean&quot;-- is 
Turkey's third largest city and second most important port. A city of 
palm-lined promenades, avenues andgreen parks set in sweeping 
curves along a circular bay, Izmir has an exceptionally mild climate 
and many finehotels. The city is a busy commercial and industrial 
center as well as the gateway to the Aegean Region. Turkey's Aegean 
shores are among the loveliest landscapes in the country. The 
Agnificent coastline, lapped by the clearwater of the Aegean Sea, 
abounds in vast and pristine beaches surrounded by olive groves, rocky 
crags and pinewoods. Dotted with idyllic fishing harbors, popular 
holiday villages, and the remains of ancient civilizations,this region 
offers an exceptionally attractive venue for meetings, incentives and 
conferences. </FONT></P> 
<P><FONT COLOR="#660099" FACE="Arial, Helvetica">The 
original city was established in the third millenium B.C.,and at that 
time shared with Troy the most advanced culture in Western Anatolia. 
By 1500 B.C. it had fallen underthe influence of Central Anatolia's 
Hittite Empire. In the first millenium B.C., Izmir, then known as 
Smyrna, rankedas one of the important cities of the Ionian Federation; 
during this period -- one of the city's most brilliant-- it is believed that 
Homer lived here. The Lydian conquest of the city, around 600 B.C., 
brought this periodto an end, and Izmir remained little more than a 
village throughout the Lydian and the subsequent 6th century B.C. 
Persian rule. In the fourth century B.C. a new city was built at the 
instigation of Alexander the Great on theslopes of Mount Pagos 
(Kadifekale). Izmir's Roman period, from the first century B.C., gave 
birth to its secondgreat era. Byzantine rule followed in the fourth 
century and lasted until the Seljuk conquest of the 11th century. 
In 1415, under Sultan Mehmet Celebi, Izmir became part of the 
Ottoman Empire. </FONT></P> 

<BLOCKQUOTE> 
<P><A HREF="izmir.htm" target="_top"><FONT F ACE="Arial, 
Helvetica"> Hotels</FONT></ A> 

</BLOCKQUOTE> 
</BODY> 

</HTML> 
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GIR.HTM 

<HTML> 
<HEAD> 

<META HTTP-EQUIV="Content-Type" CONTENT="text/html; 
charset=windows-1252 "> 
<META NAME="Generator" CONTENT="Microsoft Word 97"> 
<META NAME="AUTHOR" Content="METIN TASKIN"> 
<META NAME="DESCRIPTION" Content="This about 
TURKIYE"> 
<MET A NAME="KEYWORDS" Content="turkiye,hotel,akdeniz, 
antalya,izmir,mersin,giresun,ataturk,trabzon, ofo hotel,hilton,prencess, 
kit tur,ormancilar,sheraton"> 

<TITLE> Tourism</TITLE> 
</HEAD> 

<FRAMESET COLS= "150,643" > 
<FRAME SRC="fti13.htm" NAME="Frame3060292" RESIZE> 
<FRAME SRC="ftir3.htm" NAME="Frame3060305" RESIZE> 
</FRAMES ET> 

<NO FRAMES> 
<BODY> 
<P> 
</BODY> 
</NO FRAMES> 

</HTML> 

FTIL3.HTM 

<HTML> 
<HEAD> 

<META HTTP-EQUIV="Content-Type" CONTENT="text/html; 
charset=windows-1252 "> 
<META NAME="Generator" CONTENT="Microsoft Word 97"> 
<MET A NAME=" AUTHOR" Content="METIN T ASKIN"> 
<META NAME="DESCRIPTION" Content="This about 
TURKIYE"> 
<MET A NAME="KEYWORDS" Content="turkiye,hotel,akdeniz, 
antalya,izmir,mersin,giresun,ataturk,trabzon, ofo hotel,hilton,prencess, 
kit tur,ormancilar,sheraton"> 
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<TITLE> Tourism</TITLE> 
</HEAD> 

<BODY BACKGROUND="CDTSBK.jpg" TEXT="#CCOOOO" 
LINK ="#CCOOOO" VLINK ="#660000" ALINK ="#CCOOOO"> 
<P ALIGN="CENTER"><IMG SRC="Flagtk.gif'' WIDTH="121" 
HEIGHT="71" ALIGN="BOTTOM" BORDER="O"><BR> 
<A HREF="ant.htm" target="_top"><FONT FACE="Arial, 
Helvetica"><B> ANT ALY A </B></FONT></ A><IP> 
<P ALIGN="CENTER"><A HREF="izm.htm" target="_top"><FONT 
F ACE="Arial, Helvetica"><B> IZMIR </B></FONT></ A><IP> 
<P ALIGN="CENTER"><FONT F ACE="Arial, 
Helvetica"><B>GIRESUN</B></FONT></P> 
<P ALIGN="CENTER"><A HREF="trab.htm" target="_top"><FONT 
F ACE="Arial, Helvetica"><B> TRABZON </B></FONT></ A><IP> 
<P ALIGN="CENTER"><A HREF="trab.htm" target="_top"><FONT 
F ACE="Arial, Helvetica"><B><BR> 
<BR> 
<BR> 
<BR> 
<BR> 
<BR> 
<IA><A HREF="izm.htm" target="_top"><IMG SRC="docsleft.gif'' 
WIDTH="30" HEIGHT="30" ALIGN="BOTTOM" BORDER="O"> 
</A><AHREF="tou.htm" target="_top"><IMG SRC="docsupar.gif'' 
WIDTH="30" HEIGHT="30" ALIGN="BOTTOM" BORDER="O" 
><IA><A HREF="trab.htm" target="_top"><IMG SRC="docsrigh.gif'' 
WIDTH="30" HEIGHT="30" ALIGN="BOTTOM" BORDER="O"> 
</B></FONT></ A> 
</BODY> 

</HTML> 

FTIR3.HTM 

<HTML> 
<HEAD> 
<META HTTP-EQUIV="Content-Type" CONTENT="text/html; 
charset=windows-1252 "> 
<META NAME="Generator" CONTENT="Microsoft Word 97"> 
<META NAME="AUTHOR" Content="METIN TASKIN"> 
<META NAME="DESCRIPTION" Content="This about TURKIYE"> 
<META NAME="KEYWORDS" Content="turkiye,hotel,akdeniz, 
antalya,izmir ,mersin,giresun,ataturk, trabzon, ofo hotel,hil ton,prencess, 
kit tur,ormancilar,sheraton"> 
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<TITLE>Tourism</TITLE> 
</HEAD> 

<BODY BACKGROUND="CDTSBK.jpg" TEXT="#CCOOOO" 
LINK ="#000080" VLINK ="#660000" ALINK ="#CCOOOO"> 
<H2 ALIGN="CENTER"><IMG SRC="girrmap.jpg" WIDTH="480" 
HEIGHT="150" ALIGN="BOTTOM" BORDER="O"></H2> 
<H2 ALIGN="CENTER"><FONT COLOR="#330066" 
F ACE="Arial, Helvetica">Black Sea Region</FONT></H2> 
<P><FONT COLOR="#660099" FACE="Arial, Helvetica">Turkey's 
lush, humid and ubiquitously green Black Sea Coast surprisesthose 
who imagine the country to be nothing but barren steppes. From 
Turkey's European border with Bulgaria tothe Georgian border, dense 
pine forests cover the mountain tops; lush vegetation and bountiful 
crops grow in thelower elevations and valleys. Along the coastline, 
mile after mile of beautiful uncrowded beaches offer sun, swimming 
and relaxation. In the springtime, delicate wild-flower blossoms carpet 
especially the rolling meadows in the hillsof the Eastern Black Sea 
Coast. Throughout the region, fishing villages and mountain hamlets 
alike preserve theirindigenous and traditional wooden architectural 
styles. The humid climate and fertile soil encourage the cultivation 
of a variety of produce, including tea, tobacco, corn and hazelnuts. 
</FONT></P> 
<P><FONT COLOR="#660099" FACE="Arial, Helvetica">Once 
called Trapezus, and later Trebizond, the modern town off rabzon is 
the major city of the region. It was founded in the 7th century B.C. by 
Miletian colonists and was thcenter of the ComneneEmpireestablished 
after the fall of Byzantine Istanbul. The exiled Byzantine ruled until 
1461, when the Ottomans conquered the area. The restored 13th 
Century Byzantine church, used for centuries as amosque and now the 
Ayasofya Museum, is the jewel of Trabzon's monuments. Splendid 
frescoes, some of the finestexamples of Byzantine painting, cover 
every surface of the interior church walls. Several other churches were 
convertedto mosques, such as the Faith Mosque and the Y eni Cuma 
Mosque. The Ottoman Gulbahar Mosque, a typical provincial-style 
building, is set in a lovely tea garden. Wooden houses fill the old 
quarter in the ancient fortifications, andit still retains the spirit of a 
medieval town. The house in which Ataturk stayed has been made into 
a museum.</FONT></P> 
<P><FONT COLOR="#660099" FACE="Arial, Helvetica">Boztepe 
Pork on the hills above Trabzon, offers a beautiful viewof the city and 
the coastline. On the western slopes of Boztepe Hill stands the Irene 
Tower, built by Empress Ireneof Trabzon in 1340. Just east of the city, 
the village of Surmene has an impressive 19th century mansion known 
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as the Kastel. Near Trabzon, south of Akcaabat, lovely higland 
meadows - Karadag, Hidirnebi and Erikbeli - areideal hiking and 
picnicking grounds. The road inland from Trabzon winds through 
spectacular mountain landscapebefore reaching the Zigana Tunnel, the 
longest in Turkey. Nearby, Hamsikoy, a charming mountain village, 
has gaineda national reputation for its excellent cuisine and is also 
conveniently near the Zigana Ski Center. Beautifulmeadows and 
highland pastures are ideal sites for outdoor activities and picnics. The 
traditional Kadirga Festivalcelebrates the annual summer migration to 
the high mountain pastures. </FONT></P> 
<P><FONT COLOR="#660099" FACE="Arial, Helvetica">Altindere 
National Park provides a magnificent setting for the 14th century 
Sumela Monastry, perched on a cliff face 270 meters above a deep 
gorge. Surrounded by the ruins ofthe monks' dwellings, the church is 
covered inside and out with brilliant frescoes. Southeast of Trabzon, 
Uzungol,a lovely alpine lake surrounded by mountains and meadows, 
is an excellent camping, trekking and fishing area; itsrestaurants make 
it the best place for eating river-trout.</FONT></P> 
<P><FONT COLOR="#660099" F ACE="Arial, Helvetica"> 
Gumushane, on the ancient trade route between Trabzon and Iran, 
was once of considerable importance. Many elegant buildings from 
that period still remain. Set amid fruit grovesand wild roses, the town 
makes a natural stopping point between Trabzon and rzurum. 
</FONT></P> 
<P><FONT COLOR="#660099" FACE="Arial, Helvetica">Bayburt, 
the newly designated provincial capital, lies on theSilk Road. Marco 
Polo and the inveterate Turkish traveler Evliya Celebi both passed 
through this town. The remainsof a Byzantine castle, important 
mosques, Turkish baths and fascinating carved tomb stones are among 
Bayburt' ssignificant monuments. </FONT></P> 
<P><FONT SIZE="5" COLOR="#330066" FACE="Arial, 
Helvetica"><B>History</B></FONT></P> 
<P><FONT COLOR="#660099" FACE="Arial, Helvetica">Trabzon's 
recorded history begins around 746 BC, when colonistsoriginally from 
Miletus came from Sinop and founded a settlement with its acropolis 
on the Trapeza, or &quot;table&quot;of land above the harbour. 
</FONT></P> 
<P><FONT COLOR="#660099" F ACE="Arial, Helvetica">The 
exiled Byzantine court ruled until 1461 when Ottomans conquered 
the area. The restored 13th century Byzantine church, used for 
centuries as a mosque and now the Ayasofya Museum,is the jewel of 
Trabzon' s monuments. </FONT></P> 

- 151 - 



NEAR EAST UNIVERSTY 
COMPUTER lNQINEER/NQ 

1988 

<P><FONT COLOR="#660099" FACE="Arial, Helvetica">Trabzon 
was under Persian rule until 334 B.C.upon the invasionof Anatolia by 
the Macedonian leader Alexander the Great under the Persian emperor 
Keyhusrev. When Alexander diedin 323B.C. a major part of the Black 
Sea area went under the domain ofEvmenes. In 280 B.C. an 
ndependent stateby the name of Pontus was established.King Farnakes 
was the king of Pontus. As the kingdom developed, Sinop became 
the capital city while Trabzon served as a harbour city supplying the 
Pontus Kingdom with timber and products ofits mines and hipyards. 
</FONT></P> 
<P><FONT COLOR="#660099" FACE="Arial, Helvetica">Upon the 
division of the Roman Empire into two parts, Trabzonwent under the 
domain of Rome with the Eastern Black Sea region. After the second 
half of the 1st century, Trabzongained importance and quickly started 
developing. New commercial opportunities were created in Trabzon 
when roadsconnecting Persia to upper Mesopotamia were built during 
the reign of Emperor Vespasianus. (67-79A.D.) It thenbecame a 
Roman state when Emperor Arianus started to rule. (98-117 A.D.) 
Emperor Hadrianus helped the city and hada harbour built in his name. 
A hippodrome, a theater, an inner fortress and aquaducts were built 
which changedthe appearance of the city. <IFONT><IP> 
<P><FONT COLOR="#660099" F ACE="Arial, Helvetica">This 
lasted until 258 A. D. when Goths invaded and looted thecity during 
the time of Emperor Valerianus. (253-260A.D.) Although the city was 
reconstructed, it never gainedits old beauty. It became an important 
religious center during the expansion of Christianity and as a result, 
manychurches and monasteries were built one after another. The 
attacks of the Muslem Arab armies against the regionfrom 705 A.D. 
onwards affected the city to a great extent. As of 1098, the Christian 
governers of Trabzon triedvery hard to protect their independence 
against Byzantium, but they were not successful. Emperor Justinianus I 
had new fortresses built in order to defend the city and also had water 
brought to the city. Stefanos, the Byzantinehistorian, in his books 
wrote about the constructional works realized during the period of 
Justinianus. In the 11th century Trabzon gained even more importance 
by being a military base. Anatolian Seljuks attacked the cityand it was 
conquered by Sultan Meliksah (1107-1116) but was taken back by 
Governor Theodoros Gabras. When the Latinsinvaded Istanbul Alexius 
Komnenos, the son od Andronikos Komnenos I fled away and came to 
Trabzon. Here he declaredhimself the emperor. Therefore, once again 
the state of Pontus was established in Trabzon. (1204-461) 
<IFONT><IP> 
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<P><FONT COLOR="#660099" FACE="Arial, 
Helvetica">Significant developments were seen while under 
Komnenos's rule.However he lost a great part of his land when he lost 
the battle against David Palaiologos, the Emperor of Iznik.Emperor 
Andronikos I who replaced Komnenos tried hard to regain 
independence from the Seljuks who were ruling thecountry. He sent 
his ships to Sinop for looting purposes and won a sea battle against the 
Seljuks. In return, AlaaddinKeykubad I surrounded the city from both 
the land and the sea, but could not conquer it.</FONT></P> 
<P><FONT COLOR="#660099" FACE="Arial, Helvetica">Trabzon 
was a vital harbour on the Erzurum-Tebriz and Black Sea-Persia 
trading routes in the second half of the 13th century. Mongolians were 
in power in the beginning, however the Turkomanstook power later 
on. </FONT></P> 
<P><FONT COLOR="#660099" F ACE="Arial, Helvetica">The first 
serious Ottoman attempt to conquer Trabzon was duringthe time of 
Emperor Kalo Joannes IV (1447-1458). Sultan Murat II sent his fleet 
but was not able to seize the city. </FONT></P> 
<P><FONT COLOR="#660099" FACE="Arial, Helvetica"> 
Following the conquest of Istanbul, Emperor Kalo Joannes IV paid 
taxes to Fatih Sultan Mehmet and in the meantime incited Pope 
Calixos III and Uzun Hasan against Fatih. He alsopermitted Byzantine 
families who ran away from Istanbul to settle in his country. Fatih 
Sultan ehmet sent HizirBey to Trabzon. Trabzon was faced with the 
unexpected arrival of the Ottoman navy. The emperor yielded by 
proposingto pay tax to the amount of 1000 gold pieces per year. He 
sent his brother, David Komnenos, accompanied by HizirBey, to 
Istanbul to come to an agreement. However, Fatih Sultan Mehmet 
increased the amount to 3000 gold piecesper year. In the meantime the 
Emperor did not give up his assaults. While he was paying taxes, he 
sent messengersto Akkoyunlu Uzun Hasan proposing that he marry his 
daughter Katerina. He also sought a way to make an agreement 
with Karamanoglu Ibrahim Bey. After the death of Emperor Kalo 
Joannes, his brother David Komnenos was crowned.He sent Katherina 
to Uzun Hasan. She changed her name to Despina and played an 
important role in the Akkoyunlupalace. David Komnenos decreased 
the amount of taxes he was paying and also incited the people living on 
the landsbetween Caucasia and Burgond Duchy. The ensuing riots 
resulted in battles, and Fatih Sultan Mehmet conquered Amasra, 
Kastamonu and Sinop and reached Trabzon. Although the emperor was 
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prepared to accept all the conditions set forthby the Ottomans, Trabzon 
was conquered by the Turks on October 26, 1461. Then Trabzon 
became an important centeron the eastern and central Black Sea coastal 
strip. Yavuz Sultan Selim prior to his becoming the sultan, 
administeredthe city as its govemor.</FONT></P> 
<P><FONT COLOR="#660099" FACE="Arial, Helvetica">During 
World War I, Trabzon was invaded by the Russians an April14, 1916, 
but was taken back owing to the Brest-Litovsk agreement signed on 
February 14, 1918. The allied statestried to establish a Pontus-Greek 
state, but their attempts were hindered. Since the War of wazzu 
Independence,there has been peace in Trabzon.</FONT></P> 
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<TITLE>Tourism</TITLE> 
</HEAD> 

<BOD)' BACKGROUND="CDTSBK.jpg" TEXT="#CCOOOO" 
LINK ="#000080" VLINK ="#660000" ALINK ="#CCOOOO"> 
<H2 ALIGN="CENTER"><IMG SRC="trabmap.jpg" WIDTH="480" 
HEIGHT="l50" ALIGN="BOTTOM" BORDER="O"></H2> 
<H2 ALIGN="CENTER"><FONT COLOR="#330066" 
FACE="Arial, Helvetica">Trabzon and the Black Sea Region 
</FONT></H2> 
<P><FONT COLOR="#660099" F ACE="Arial, Helvetica">Turkey's 
lush, humid and ubiquitously green Black Sea Coast surprisesthose 
who imagine the country to be nothing but barren steppes. From 
Turkey's European border with Bulgaria tothe Georgian border, dense 
pine forests cover the mountain tops; lush vegetation and bountiful 
crops grow in thelower elevations and valleys. Along the coastline, 
mile after mile of beautiful uncrowded beaches offer sun, swimming 
and relaxation. In the springtime, delicate wild-flower blossoms carpet 
especially the rolling meadows in the hillsof the Eastern Black Sea 
Coast. Throughout the region, fishing villages and mountain hamlets 
alike preserve theirindigenous and traditional wooden architectural 
styles. The humid climate and fertile soil encourage the cultivation 
of a variety of produce, including tea, tobacco, com and azelnuts. 
</FONT></P> 
<P><FONT COLOR="#660099" F ACE="Arial, Helvetica">Once 
called Trapezus, and later Trebizond, the modem town of 
Trabzon is the major city of the region. It was founded in the 7th 
century B.C. by Miletian colonists and was thecenter of the Comnene 
Empire established after the fall of Byzantine Istanbul. The exiled 
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Byzantine ruled until1461, when the Ottomans conquered the area. The 
restored 13th Century Byzantine church, used for centuries as a 
mosque and now the Ayasofya Museum, is the jewel ofTrabzon's 
monuments. Splendid frescoes, some of the finestexamples of 
Byzantine painting, cover every surface of the interior church walls. 
Several other churches were convertedto mosques, such as the Faith 
Mosque and the Y eni Cuma Mosque. The Ottoman Gulbahar Mosque, 
a typical provincial-stylebuilding, is set in a lovely tea garden. Wooden 
houses fill the old quarter in the ancient fortifications, andit still retains 
the spirit of a medieval town. The house in which Ataturk stayed has 
been made into a museum. </FONT></P> 
<P><FONT COLOR="#660099" FACE="Arial, Helvetica">Boztepe 
Pork on the hills above Trabzon, offers a beautiful viewof the city and 
the coastline. On the western slopes of Boztepe Hill stands the Irene 
Tower, built by Empress Ireneof Trabzon in 1340. Just east of the city, 
the village of Surmene has an impressive 19th century mansion known 
as the Kastel. Near Trabzon, south of Akcaabat, lovely higland 
meadows - Karadag, Hidirnebi and Erikbeli - are ideal hiking and 
picnicking grounds. The road inland from Trabzon winds through 
spectacular mountain landscapebefore reaching the Zigana Tunnel, the 
longest in Turkey. Nearby, Hamsikoy, a charming mountain village, 
has gaineda national reputation for its excellent cuisine and is also 
conveniently near the Zigana Ski Center. Beautifulmeadows and 
highland pastures are ideal sites for outdoor activities and picnics. The 
traditional Kadirga Festivalcelebrates the annual summer migration to 
the high mountain pastures. </FONT></P> 
<P><FONT COLOR="#660099" FACE="Arial, Helvetica">Altindere 
National Park provides a magnificent setting for the 14th century 
Sumela Monastry, perched on a cliff face 270 meters above a deep 
gorge. Surrounded by the ruins ofthe monks' dwellings, the church is 
covered inside and out with brilliant frescoes. Southeast of Trabzon, 
Uzungol,a lovely alpine lake surrounded by mountains and meadows, 
is an excellent camping, trekking and fishing area; itsrestaurants make 
it the best place for eating river-trout.</FONT></P> 
<P><FONT COLOR="#660099" FACE="Arial, Helvetica"> 
Gumushane, on the ancient trade route between Trabzon and Iran, 
was once of considerable importance. Many elegant buildings from 
that period still remain. Set amid fruit groves and wild roses, the town 
makes a natural stopping point between Trabzon and Erzurum. 
</FONT></P> 
<P><FONT COLOR="#660099" F ACE="Arial, Helvetica">Bayburt, 
the newly designated provincial capital, lies on theSilk Road. Marco 
Polo and the inveterate Turkish traveler Evliya Celebi both passed 
through this town. The remainsof a Byzantine castle, important 
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mosques, Turkish baths and fascinating carved tomb stones are among 
Bayburt' s significant monuments. </FONT></P> 
<P><FONT SIZE="5" COLOR="#330066" FACE="Arial, 
Helvetica"><B>History</B></FONT></P> 
<P><FONT COLOR="#660099" FACE="Arial, Helvetica">Trabzon's 
recorded history begins around 746 BC, when colonistsoriginally from 
Miletus came from Sinop and founded a settlement with its acropolis 
on the Trapeza, or &quot;table&quot;of land above the harbour. 
<IFONT><IP> 
<P><FONT COLOR="#660099" F ACE="Arial, Helvetica">The 
exiled Byzantine court ruled until 1461 when Ottomans conquered 
the area. The restored 13th century Byzantine church, used for 
centuries as a mosque and now the Ayasofya Museum, 
is the jewel ofTrabzon's monuments.</FONT></P> 
<P><FONT COLOR="#660099" FACE="Arial, Helvetica">Trabzon 
was under Persian rule until 334 B.C.upon the invasionof Anatolia by 
the Macedonian leader Alexander the Great under the Persian emperor 
Keyhusrev. When Alexander diedin 323B.C. a major part of the Black 
Sea area went under the domain of Evmenes. In 280 B.C. an 
independent stateby the name of Pontus was established.King Famakes 
was the king of Pontus. As the kingdom developed, Sinop became 
the capital city while Trabzon served as a harbour city supplying the 
Pontus Kingdom with timber and products ofits mines and shipyards. 
<IFONT><IP> 
<P><FONT COLOR="#660099" FACE="Arial, Helvetica">Upon the 
division of the Roman Empire into two parts, Trabzon went under the 
domain of Rome with the Eastern Black Sea region. After the second 
half of the 1st century, Trabzon gained importance and quickly started 
developing. New commercial opportunities were created in Trabzon 
when roads connecting Persia to upper Mesopotamia were built during 
the reign of Emperor Vespasianus. (67-79A.D.) It then became a 
Roman state when Emperor Arianus started to rule. (98-117 A.D.) 
Emperor Hadrianus helped the city and had a harbour built in his 
name. A hippodrome, a theater, an inner fortress and aquaducts were 
built which changed the appearance of the city. </FONT></P> 
<P><FONT COLOR ="#660099" FACE=" Arial, Helvetica"> This 
lasted until 258 A. D. when Goths invaded and looted thecity during 
the time of Emperor Valerianus. (253-260A.D.) Although the city was 
reconstructed, it never gainedits old beauty. It became an important 
religious center during the expansion of Christianity and as a result, 
manychurches and monasteries were built one after another. The 
attacks of the Muslem Arab armies against the regionfrom 705 A.D. 
onwards affected the city to a great extent. As of 1098, the Christian 

- 158 - 



KEAR EAST UKIVER9TY 
COMPUTER ENC/NEER/NC 

1988 

governers of Trabzon tried very hard to protect their independence 
against Byzantium, but they were not successful. Emperor Justinianus I 
had new fortresses built in order to defend the city and also had water 
brought to the city. Stefanos, the Byzantinehistorian, in his books 
wrote about the constructional works realized during the period of 
Justinianus. In thel 1th century Trabzon gained even more importance 
by being a military base. Anatolian Seljuks attacked the cityand it was 
conquered by Sultan Meliksah (1107-1116) but was taken back by 
Governor Theodoros Gabras. When the Latinsinvaded Istanbul Alexius 
Komnenos, the son od Andronikos Komnenos I fled away and came to 
Trabzon. Here he declaredhimself the emperor. Therefore, once again 
the state of Pontus was established in Trabzon. (1204-461) 
</FONT></P> 
<P><FONT COLOR="#660099" F ACE="Arial, Helvetica"> 
Significant developments were seen while under Komnenos's rule. 
However he lost a great part of his land when he lost the battle against 
David Palaiologos, the Emperor of Iznik. Emperor Andronikos I who 
replaced Komnenos tried hard to regain independence from the Seljuks 
who were ruling the country. He sent his ships to Sinop for looting 
purposes and won a sea battle against the Seljuks. In return, Alaaddin 
Keykubad I surrounded the city from both the land and the sea, but 
could not conquer it. </FONT></P> 
<P><FONT COLOR="#660099" FACE="Arial, Helvetica">Trabzon 
was a vital harbour on the Erzurum-Tebriz and Black Sea-Persia 
trading routes in the second half of the 13th century. Mongolians were 
in power in the beginning, however the Turkomanstook power later 
on. </FONT></P> 
<P><FONT COLOR="#660099" FACE="Arial, Helvetica">The first 
serious Ottoman attempt to conquer Trabzon was during the time of 
Emperor Kalo Ioannes IV (1447-1458). Sultan Murat II sent his fleet 
but was not able to seize the city. </FONT></P> 
<P><FONT COLOR="#660099" FACE="Arial, Helvetica"> 
Following the conquest of Istanbul, Emperor Kalo Ioannes IV paid 
taxes to Fatih Sultan Mehmet and in the meantime incited Pope 
Calixos III and Uzun Hasan against Fatih. He also permitted Byzantine 
families who ran away from Istanbul to settle in his country. Fatih 
Sultan Mehmet sent HizirBey to Trabzon. Trabzon was faced with the 
unexpected arrival of the Ottoman navy. The emperor yielded by 
proposing to pay tax to the amount of 1000 gold pieces per year. He 
sent his brother, David Komnenos, accompanied by Hizir Bey, to 
Istanbul to come to an agreement. However, Fatih Sultan Mehmet 
increased the amount to 3000 gold pieces per year. In the meantime the 
Emperor did not give up his assaults. While he was paying taxes, he 
sent messengers 
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to Akkoyunlu Uzun Hasan proposing that he marry his daughter 
Katerina. He also sought a way to make an agreementwith 
Karamanoglu Ibrahim Bey. After the death of Emperor Kalo Ioannes, 
his brother David Komnenos was crowned.He sent Katherina to Uzun 
Hasan. She changed her name to Despina and played an important role 
in the Akkoyunlu palace. David Komnenos decreased the amount of 
taxes he was paying and also incited the people living on the lands 
between Caucasia and Burgond Duchy. The ensuing riots resulted in 
battles, and Fatih Sultan Mehmet conquered Amasra, Kastamonu and 
Sinop and reached Trabzon. Although the emperor was prepared to 
accept all the conditions set forth by the Ottomans, Trabzon was 
conquered by the Turks on October 26, 1461. Then Trabzon became an 
important center on the eastern and central Black Sea coastal strip. 
Yavuz Sultan Selim prior to his becoming the sultan, administered 
the city as its governor. </FONT></P> 
<P><FONT COLOR="#660099" FACE="Arial, Helvetica">During 
World War I, Trabzon was invaded by the Russians an April14, 1916, 
but was taken back owing to the Brest-Litovsk agreement signed on 
February 14, 1918. The allied statestried to establish a Pontus-Greek 
state, but their attempts were hindered. Since the War of wazzu 
Independence,there has been peace in Trabzon.</FONT></P> 
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</BODY> 
</NO FRAMES> 

</HTML> 

FOL1.HTM 

<HTML> 
<HEAD> 

<META HTTP-EQUIV="Content-Type" CONTENT="text/html; 
charset=iso-8859-1 "> 
<META NAME="GENERATOR" CONTENT="Mozilla/4.02 [en] 
(Win95; I) [Netscape]"> 
<META NAME="AUTHOR" Content="METIN TASKIN"> 

<META NAME="DESCRIPTION" Content="This about 
TURKIYE"> 
<MET A NAME="KEYWORDS" Content="turkiye,hotel,akdeniz, 
antalya,izmir,mersin,giresun,ataturk,trabzon, ofo hotel,hilton,prencess, 
kit tur,ormancilar ,sheraton"> 

<TITLE> Hotel</TITLE> 
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</HEAD> 
<BODY TEXT="#CCOOOO" LINK="#CCOOOO" VLINK="#660000" 
ALINK ="#CCOOOO" BACKGROUND="CDTSBK.jpg"> 
<CENTER><IMG SRC="Flagtk.gif' AL T="Turk Bayragy" 
BORDER=O HEIGHT=71 WIDTH=121></CENTER> 
<CENTER></CENTER> 
<CENTER><B><FONT FACE="Arial, Helvetica">HOTELS 
</FONT></B></CENTER> 
<CENTER></CENTER> 
<CENTER><B><FONT FACE=" Arial, Helvetica"> ANT ALY A 
</FONT></B></CENTER> 
<CENTER><B><FONT F ACE="Arial, Helvetica"><A HREF= 
"izmir.htm" target="_ top">IZMIR </ A></FONT></B></CENTER> 
<CENTER><B><FONT F ACE="Arial, Helvetica"><A HREF= 
"giresun.htm" target="_top"> GIRESUN</A></FONT> </B> 
</CENTER> 
<CENTER><B><FONT F ACE="Arial, Helvetica"><A HREF= 
"trabzon.htm" target="_top"> TRABZON</ A></FONT></B> 
</CENTER> 
<CENTER>&nbsp;</CENTER> 
<CENTER>&nbsp;</CENTER> 
<CENTER>&nbsp;</CENTER> 
<CENTER>&nbsp;</CENTER> 
<CENTER>&nbsp;</CENTER> 
<CENTER>&nbsp;</CENTER> 
<CENTER></CENTER> 
<CENTER><A HREF="trab.htm" target="_top"><IMG SRC= 
"docsleft.gif" AL T="Bir onceki sayfa" BORDER=O HEIGHT=30 
WIDTH=30></A><A HREF="tou.htm" target="_top"><IMG 
SRC="docsupar.gif' AL T="menuye" BORDER=O HEIGHT=30 
WIDTH=30></A><A HREF="izmir.htm" target="_top"><IMG 
SRC="docsrigh.gif' ALT="ileri" BORDER=O HEIGHT=30 
WIDTH=30></ A></CENTER> 
</BODY> 

</HTML> 
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FOR1.HTM 

<HTML> 
<HEAD> 

<META HTTP-EQUIV="Content-Type" CONTENT="text/html; 
charset=iso-8859-1 "> 
<META NAME="GENERATOR" CONTENT="Mozilla/4.02 [en] 
(Win95; I) [Netscape]"> 
<META NAME="AUTHOR" Content="METIN TASKIN"> 
<META NAME="DESCRIPTION" Content="This about 
TURKIYE"> 
<META NAME="KEYWORDS" Content="turkiye,hotel,akdeniz, 

antalya,izmir,mersin,giresun,ataturk,trabzon, ofo hotel,hilton,prencess, 
kit tur,ormancilar,sheraton"> 

<TITLE> Hotel</TITLE> 
</HEAD> 

<BODY BACKGROUND="CDTSBK.jpg"> 
<CENTER><B><FONT F ACE="Arial, Helvetica"><FONT 
COLOR="#CCOOOO"><FONT SIZE=+4> ANTAL YA </FONT> 
</FONT></FONT></B></CENTER> 
<CENTER></CENTER> 
<CENTER><B><FONT F ACE="Arial, Helvetica"><FONT 
COLOR="#330066"><FONT SIZE=+3>DEDEMAN</FONT> 
</FONT></FONT></B></CENTER> 
<CENTER></CENTER> 
<CENTER><IMG SRC="5yil.jpg" ALT="5 yildiz" BORDER=O 
HEIGHT=39 WIDTH=189></CENTER> 
<CENTER><IMG SRC="dedeman.jpg" AL T="Antalya Dedeman" 
BORDER=O HEIGHT=280 WIDTH=270></CENTER> 
<P><FONT F ACE="Arial, Helvetica"><FONT 
COLOR ="#660099"><8> Address:</B> 
Lara Yolu 07100 Antalya </FONT></FONT> 
<BR><FONT FACE="Arial, Helvetica"><FONT COLOR= 
"#660099"><B>Tel:</B> (242)3217910 - 15 Lines, 3213930 - 15 
Lines</FONT></FONT> 
<BR><FONT F ACE="Arial, Helvetica"><FONT COLOR= 
"#660099"><B>Fax:</B> 321 38 73</FONT></FONT> 
<BR><FONT F ACE="Arial, Helvetica"><FONT COLOR= 
"#660099"><B>Beds:</B> 1020Total Rooms: 482 
</FONT></FONT> 
<BR><FONT F ACE="Arial, Helvetica"><FONT COLOR= 
"#660099"><B>Rooms with:</B>Phone, WC, AirCondition, Bath, 
TV, Balcony, hair Dryer, Sea view, usic,Minibar.</FONT></FONT> 
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<BR><FONT F ACE="Arial, Helvetica"><FONT COLOR="#660099" 
><B>Hotel Facilities:</B>Snack Bar, Shopping Center,</FONT> 
</FONT> 
<BR><FONT F ACE="Arial, Helvetica"><FONT 
COLOR="#660099">Game Hall, Casino, 
Central Heating, Gymnasium Hall, Dry</FONT></FONT> 
<BR><FONT F ACE="Arial, Helvetica"><FONT 
COLOR="#660099">Cleaning, Air Condition,Safety Box, Cafeteria, 
Market, </FONT></FONT> 
<BR><FONT F ACE="Arial, Helvetica"><FONT COLOR= 
"#660099">Children's Room,Night Club, Lift, Healty Center, Turkish 
Bath, </FONT></FONT> 
<BR><FONT F ACE="Arial, Helvetica"><FONT COLOR= 
"#660099">TV Room, Patisserie,Coiffeur, Garden, Disco, 
Generator, </FONT></FONT> 
<BR><FONT F ACE="Arial, Helvetica"><FONT COLOR= 
"#660099"> J akuzzi, Sauna,Laundry. </FONT></FONT> 
<BR><FONT F ACE="Arial, Helvetica"><FONT 
CO LOR ="#660099"><B> Restaurant:</B> 
Bogazici, <B>Indoor</B>; Kumkapi, Outdoor; 
Akdeniz, </FONT></FONT> 
<BR><FONT F ACE="Arial, Helvetica"><FONT 
COLOR="#660099"> Indoor;Turkuaz, 
Indoor; Istanbul,Outdoor</FONT></FONT> 
<BR><FONT F ACE="Arial, Helvetica"><FONT 
COLOR="#660099">Bar: Neyzen; Turkuaz; 
Garden, Outdoor; Beach, Outdoor;</FONT></FONT> 
<BR><FONT F ACE="Arial, Helvetica"><FONT 
CO LOR ="#660099"> Patara, Outdoor. </FONT></FONT> 
<BR><FONT F ACE="Arial, Helvetica"><FONT 
COLOR ="#660099"><B> Meeting Room:</B> 
Balo salonu, Cap:600; 1,Cap:30; 1,Cap: 150</FONT></FONT> 
<BR><FONT F ACE="Arial, Helvetica"><FONT 
COLOR ="#660099"><B>Conference Hall :</B> 
1, Cap:600, Simultaneous, Translation System</FONT></FONT> 
<BR><FONT F ACE="Arial, Helvetica"><FONT 
COLOR ="#660099"><B> Banquet Facilities 
Capacity:</B> 1200</FONT></FONT> 
<BR><FONT F ACE="Arial, Helvetica"><FONT 
COLOR="#660099"><B>Breakfast Hall 
Capacity: </B>300 - 1000</FONT></FONT> 
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<BR><FONT F ACE="Arial, Helvetica"><FONT 
COLOR="#660099">Indoor SwimmingPool, Outdoor Swimming 
Pool, Children's Pool, Parking, Garage, Beach. </FONT></FONT> 
<BR><FONT F ACE="Arial, Helvetica"><FONT COLOR= 
"#660099"><B>Sports: </B> Table 
Tennis, Basketball, Billards. </FONT></FONT> 
<BR><FONT F ACE="Arial, Helvetica"><FONT COLOR= 
"#660099"><B>Water Sports:</B>WindSurf, Diving, Banana, Canoe, 
Salling, Jetski, Parasailling, Waterski .. </FONT></FONT> 
<BR><FONT FACE="Arial, Helvetica"><FONT COLOR= 
"#660099"><B>City Center</B>: 3 km, Airport: 15km, 
Beach:O</FONT></FONT> 
<CENTER></CENTER> 
<CENTER><B><FONT F ACE="Arial, Helvetica"><FONT 
COLOR="#330066"><FONT SIZE=+3>FALEZ 
HOTEL</FONT></FONT></FONT></B></CENTER> 
<CENTER></CENTER> 
<CENTER><IMG SRC="5yil.jpg" ALT="5 yildiz" BORDER=O 
HEIGHT=39 WIDTH=189></CENTER> 
<CENTER><IMG SRC="falez.jpg" AL T="Antalya Falez" 
BORDER=O HEIGHT=280 WIDTH=270></CENTER> 
<P><FONT F ACE="Arial, Helvetica"><FONT 
COLOR="#660099"><B>Address:</B>Konyaalti Falez Mevkii 
PK.808 07050 Antalya</FONT></FONT> 
<BR><FONT F ACE="Arial, Helvetica"><FONT 
COLOR="#660099"><B>Tel:</B> (242) 
248 50 00 - 24 Lines</FONT></FONT> 
<BR><FONT FACE="Arial, Helvetica"><FONT COLOR= 
"#660099"><B>Fax:</B> 24850 25</FONT></FONT> 
<BR><FONT F ACE="Arial, Helvetica"><FONT 
COLOR="#660099"><B>Beds:</B> 684</FONT></FONT> 
<BR><FONT FACE=" Arial, Helvetica"><FONT 
COLOR ="#660099"><8> Total Rooms</B>: 
342, Suits: 20</FONT></FONT> 
<BR><FONT F ACE="Arial, Helvetica"><FONT COLOR= 
"#660099"><B>Rooms With:</B>Phone, WC, AirCondition, TV, 
Balcony, Sea View, Hair Dryer, Music, Bath,Minibar, Safety 
Box. </FONT></FONT> 
<BR><FONT F ACE="Arial, Helvetica"><FONT 
COLOR="#660099"><B>Hotel Facilities:</B>Casino, Gymnasium 
Hall, Night Club, Healty Center, Turkish Bath, Coiffeur, 
Garden, disco, Jakuzzi, Sauna.</FONT></FONT> 
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<BR><FONT FACE="Arial, Helvetica"><FONT COLOR= 
"#660099"><8> Restaurant:</B> 
5.</FONT></FONT> 
<BR><FONT F ACE="Arial, Helvetica"><FONT 
COLOR="#660099"><B>Bar: </8>6.</FONT></FONT> 
<BR><FONT F ACE="Arial, Helvetica"><FONT 
COLOR="#660099"><B>Meeting Room:</B> 
2</FONT></FONT> 
<BR><FONT F ACE="Arial, Helvetica"><FONT 
CO LOR ="#660099"><B>Confemce Hall :</B> 
7</FONT></FONT> 
<BR><FONT F ACE="Arial, Helvetica"><FONT 
COLOR="#660099">0utdoor SwimmingPool, Children's 
Pool</FONT></FONT> 
<BR><FONT F ACE="Arial, Helvetica"><FONT 
COLOR="#660099"><B>Sports: </B>Tennis,Table Tennis, Billards, 
Mini Golf, Volleyball. </FONT></FONT> 
<BR><FONT F ACE="Arial, Helvetica"><FONT COLOR= 
"#660099"><B>Water Sports:</B>WindSurf, Waterski, Banana, 
Canoe. </FONT></FONT> 
<BR><FONT F ACE="Arial, Helvetica"><FONT COLOR= 
"#660099"><B>City Center:</B> 
1km, Airport: 1 lkm</FONT></FONT> 
<CENTER></CENTER> 
<CENTER><B><FONT F ACE="Arial, Helvetica"><FONT 
COLOR="#330066"><FONT SIZE=+3>0FO 
HOTEL</FONT></FONT></FONT></B></CENTER> 
<CENTER></CENTER> 
<CENTER><IMG SRC="5yil.jpg" ALT="5 yildiz" BORDER=O 
HEIGHT=39 WIDTH=189></CENTER> 
<CENTER><IMG SRC="ofo.jpg" ALT="OFO Hotel" BORDER=O 
HEIGHT=280 WIDTH=270></CENTER> 
<P><FONT F ACE="Arial, Helvetica"><FONT 
CO LOR ="#660099"><8> Address:</B> Lara 
Antalya</FONT></FONT> 
<BR><FONT F ACE="Arial, Helvetica"><FONT COLOR= 
"#660099"><B>Tel: </8>(242)349 40 00 PBX</FONT></FONT> 
<BR><FONT FACE="Arial, Helvetica"><FONT COLOR= 
"#660099"><B>Fax:</B> 34940 16</FONT></FONT> 
<BR><FONT F ACE="Arial, Helvetica"><FONT COLOR= 
"#660099"><B>Beds: </8>302</FONT></FONT> 
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<BR><FONT F ACE="Arial, Helvetica"><FONT COLOR= 
"#660099"><B> Total Rooms: 
</B> 151, King Suits: 2</FONT></FONT> 
<BR><FONT F ACE="Arial, Helvetica"><FONT COLOR= 
"#660099"><B>Rooms With:</B>Phone, WC, AirCondition, TV, 
Balcony, Hair Dryer, Music, Bath, Minibar, Safety 
Box. </FONT></FONT> 
<BR><FONT F ACE="Arial, Helvetica"><FONT COLOR= 
"#660099"><B>Hotel Facilities:</B>Snack Bar, Shopping Center, 
Casino, Gymnasium Hall, Cafeteria, Market,Night Club, Healty 
Center, Turkish Bath, TV Room, Patisserie, Coiffeur,Garden, Disco, 
Jakuzzi, Sauna, Laundry.</FONT></FONT> 
<BR><FONT F ACE="Arial, Helvetica"><FONT COLOR= 
"#660099 "><B> Restaurant: </B>4, Indoor, 
Cap: 1250.</FONT></FONT> 
<BR><FONT F ACE="Arial, Helvetica"><FONT COLOR= 
"#660099"><B>Bar:</B> 7</FONT></FONT> 
<BR><FONT F ACE="Arial, Helvetica"><FONT COLOR= 
"#660099"><B>Meeting Room:</B>5, Cap: 2300</FONT></FONT> 
<BR><FONT F ACE="Arial, Helvetica"><FONT COLOR= 
"#660099"><B>Banquet FacilitiesCapacity:</B> 2000</FONT> 
</FONT> 
<BR><FONT F ACE="Arial, Helvetica"><FONT COLOR= 
"#660099">1ndoor SwimmingPool, Outdoor Swimming Pool, 
Children's Pool. </FONT></FONT> 
<BR><FONT F ACE="Arial, Helvetica"><FONT COLOR= 
"#660099">Beach</FONT></FONT> 
<BR><FONT FACE="Arial, Helvetica"><FONT COLOR= 
"#660099"><B>Sports:</B>Tennis, Table Tennis, 
Volley ball. </FONT></FONT> 
<BR><FONT F ACE="Arial, Helvetica"><FONT COLOR= 
"#660099"><B>City Center:</B>9km, Airport: 6km,</FONT> 
</FONT> 
<CENTER></CENTER> 
<CENTER><B><FONT F ACE="Arial, Helvetica"><FONT COLOR= 
"#330066"><FONT SIZE=+2>SERACLUB HOTEL</FONT> 
</FONT></FONT></B></CENTER> 
<CENTER></CENTER> 
<CENTER><IMG SRC="5yil.jpg" AL T="5 yildiz" BORDER=O 
HEIGHT=39 WIDTH=189></CENTER> 
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<CENTER><IMG SRC="seraclub.jpg" AL T="Sera Club Hotel" 
BORDER=O HEIGHT=280 WIDTH=270></CENTER> 
<P><FONT F ACE="Arial, Helvetica"><FONT 
CO LOR ="#660099"><B> Address :</B> Lara Antalya</FONT>< 
</FONT> 
<BR><FONT F ACE="Arial, Helvetica"><FONT COLOR= 
"#660099"><B>Tel:</B> (242)349 34 34 PBX Fax: 349 34 
54</FONT></FONT> 
<BR><FONT FACE="Arial, Helvetica"><FONT COLOR= 
"#660099''><B>e-mail:</B>hotelsera.a.turk.net</FONT></FONT> 
<BR><FONT F ACE="Arial, Helvetica"><FONT COLOR= 
"#660099 "><B> Internet Address: </B> http :www. cl ubsera. com 
</FONT></FONT> 
<BR><FONT F ACE="Arial, Helvetica"><FONT COLOR= 
"#660099"><B>Beds: </B>518Total Rooms: 244, Suits: 
1 O</FONT></FONT> 
<BR><FONT FACE="Arial, Helvetica"><FONT COLOR= 
"#660099"><B>Rooms With:</B>Phone, WC, AirCondition, TV, 
Balcony, Sea View, Hair Dryer, Music,Bath, Mini bar, TV Satellite 
System, Safety Box.</FONT></FONT> 
<BR><FONT F ACE="Arial, Helvetica"><FONT 
COLOR="#660099"> <B> Hotel Facilities:</B>Snack Bar, Shopping 
Center, Game Hall,Casino, Central Heating, GymnasiumHall, Dry 
Cleaning, Air condition, Safety Box, Cafeteria, Night Club, Lift, 
Turkish Bath, TV Room, Patisserie, Coiffeur, Garden, Disco, 
Generator,Sauna, Laundry. </FONT></FONT> 
<BR><FONT F ACE="Arial, Helvetica"><FONT COLOR= 
"#660099"><B>Restaurant:</B>Four Seasons, Indoor; Olympos, 
Outdoor; Garden, Outdoor; Beach, Outdoor. </FONT></FONT> 
<BR><FONT F ACE="Arial, Helvetica"><FONT COLOR= 
"#660099"><B>Bar:</B> Lobby,Indoor; Garden, Outdoor; Beach, 
Outdoor; Casino, Indoor; Sauna, Indoor.</FONT></FONT> 
<BR><FONT F ACE="Arial, Helvetica"><FONT COLOR= 
"#660099"><B>Meeting Room:</B>Club Room, Cap: 
40</FONT></FONT> 
<BR><FONT F ACE="Arial, Helvetica"><FONT 
COLOR ="#660099"><B>Conference Hall :</B> Balo Salonu, 
Cap:200. </FONT></FONT> 
<BR><FONT F ACE="Arial, Helvetica"><FONT COLOR= 
"#660099"><B>Banquet FacilitiesCapacity: </B> 1000, Breakfast Hall 
Capacity : 500</FONT></FONT> 
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<BR><FONT F ACE="Arial, Helvetica"><FONT COLOR= 
"#660099">0utdoor SwimmingPool, Children's Pool, Parking. Private 
Beach 1 O</FONT></FONT> 
<BR><FONT F ACE="Arial, Helvetica"><FONT COLOR= 
"#660099"><B>Sports:</B>Tennis,Table Tennis, Billards, Voleyball, 
Jogging, Basketball, Dart, Football.</FONT></FONT> 
<BR><FONT F ACE="Arial, Helvetica"><FONT COLOR= 
"#660099"><B>Water Sports:</B>Banana, Jetski, WinsSurf, Pedalo, 
Catamaran, Canoe, Sailing, Parasailing,Waterski.</FONT></FONT> 
<BR><FONT F ACE="Arial, Helvetica"><FONT COLOR= 
"#660099"><B>City Center:</B> 12km, Airport: 9km.</FONT> 
</FONT> 
<CENTER></CENTER> 
<CENTER><B><FONT F ACE="Arial, Helvetica"><FONT COLOR= 
"#330066"><FONT SIZE=+ 2>SHERA TONVOY AGER 
HOTEL</FONT></FONT></FONT></B></CENTER> 
<CENTER></CENTER> 
<CENTER><IMG SRC="5yil.jpg" AL T="5 yildiz" BORDER=O 
HEIGHT=39 WIDTH=189></CENTER> 
<CENTER><IMG SRC="sheraton.jpg" ALT="Sheraton Voyager 
Hotel" BORDER=O HEIGHT=280 WIDTH=270></CENTER> 
<P><FONT FACE="Arial, Helvetica"><FONT COLOR= 
"#660099"><B> Address:</B> 100 Yil Bul. 07050 Antalya</FONT> 
</FONT> 
<BR><FONT F ACE="Arial, Helvetica"><FONT COLOR= 
"#660099"><B>Tel:</B>(242)243 24 42 Fax: 243 24 62</FONT> 
</FONT> 
<BR><FONT F ACE="Arial, Helvetica"><FONT COLOR= 
"#660099"><B>Beds:</B> 800</FONT></FONT> 
<BR><FONT F ACE="Arial, Helvetica"><FONT COLOR= 
"#660099"><B>Total Rooms:</B>409, Suits: 10</FONT></FONT> 
<BR><FONT F ACE="Arial, Helvetica"><FONT COLOR= 
"#660099"><B>Rooms With:</B>Phone, WC, AirCondition, TV, 
Balcony, Hair Dryer, Music, Bath, Minibar,TV Satellite System. 
</FONT> </FONT> 
<BR><FONT F ACE="Arial, Helvetica"><FONT COLOR= 
"#660099"><B>Hotel Facilities:</B>Snack bar, Casino, Central 
Heating, Gymnasium Hall, Safety Box, HealtyCenter, Turkish Bath, 
Patisserie, Coiffeur, Garden, Sauna</FONT></FONT> 
<BR><FONT F ACE="Arial, Helvetica"><FONT COLOR= 
"#660099"><B>Restaurant:</B>4, Cap: 295. </FONT></FONT> 

- 169 - 



NEAR EAST UNIVERSTY 
COMPUTER ENQINEER/NQ 

1988 

<BR><FONT F ACE="Arial, Helvetica"><FONT COLOR= 
"#660099"><B>Bar: l</B>obby;Terrace; Pool.</FONT></FONT> 
<BR><FONT F ACE="Arial, Helvetica"><FONT COLOR= 
"#660099"><B>Meeting Room:</B>6, Cap: 1000</FONT></FONT> 
<BR><FONT F ACE="Arial, Helvetica"><FONT COLOR= 
"#660099"><B>Conference Hall:</B> 1,Cap:600</FONT></FONT> 
<BR><FONT F ACE="Arial, Helvetica"><FONT COLOR= 
"#660099"><B>Banquet FacilitiesCapacity: </B> 1000</FONT> 
</FONT> 
<BR><FONT F ACE="Arial, Helvetica"><FONT COLOR= 
"#660099">Indoor SwimmingPool, Outdoor Swimming Pool, 
Children's Pool. </FONT></FONT> 
<BR><FONT F ACE="Arial, Helvetica"><FONT COLOR= 
"#660099">Beach 400</FONT></FONT> 
<BR><FONT FACE="Arial, Helvetica"><FONT COLOR= 
"#660099"><B>Sports:</B>Tennis, Table Tennis.</FONT></FONT> 
<BR><FONT FACE="Arial, Helvetica"><FONT COLOR= 
"#660099"><B>City Center:</B> lkm,Airport: 11km, Beach: 
400m</FONT></FONT> 
</BODY> 

</HTML> 
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IZMIR.HTM 
<HTML> 

<HEAD> 
<META HTTP-EQUIV="Content-Type" CONTENT="text/htrnl; 
charset=windows-1252 "> 
<META NAME="Generator" CONTENT="Microsoft Word 97"> 
<MET A NAME=" AUTHOR" Content="METIN T ASKIN"> 
<META NAME="DESCRIPTION" Content="This about 
TURKIYE"> 
<MET A NAME="KEYWORDS" Content="turkiye,hotel,akdeniz, 
antal ya,izrnir ,rnersin,giresun,ataturk, trabzon, ofo hotel,hilton,prencess, 
kit tur,orrnancilar,sheraton"> 

<TITLE> Hotel</TITLE> 
</HEAD> 

<FRAMESET COLS = "152,642 " > 
<FRAME SRC="fol2.htrn" NAME="Frarne6912523" RESIZE> 
<FRAME SRC="for2.htrn" NAME="Frarne6912537" RESIZE> 
</FRAMES ET> 

<NO FRAMES> 
<BODY> 
<P> 
</BODY> 
</NO FRAMES> 

</HTML> 

FOL2.HTM 

<HTML> 
<HEAD> 

<META HTTP-EQUIV="Content-Type" CONTENT="text/htrnl; 
charset=windows-1252 "> 
<META NAME="Generator" CONTENT="Microsoft Word 97"> 
<META NAME="AUTHOR" Content="METIN TASKIN"> 

<META NAME="DESCRIPTION" Content="This about 
TURKIYE"> 
<MET A NAME="KEYWORDS" Content="turkiye,hotel,akdeniz, 
antalya,izrnir ,rnersin,giresun,ataturk, trabzon, ofo hotel,hil ton,prencess, 
kit tur,orrnancilar,sheraton"> 

<TITLE> Hotel</TITLE> 
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</HEAD> 
<BODY BACKGROUND="CDTSBK.jpg" TEXT="#CCOOOO" 
LINK= "#CCOOOO" VLINK ="#660000" ALINK ="#CCOOOO"> 
<P ALIGN="CENTER"><IMG SRC="Flagtk.gif'' WIDTH=" 121" 
HEIGHT="71" ALIGN="BOTTOM" ALT="Turk Bayragy" 
BORDER="O"> 
<CENTER> 
<FONT FACE="Arial, Helvetica"><B>HOTELS</B></FONT> 
</CENTER> 
<CENTER> 
<A HREF="antalya.htm" target="_top"><FONT FACE="Arial, 
Helvetica"><B> ANT ALY A </B></FONT></ A></CENTER> 
<CENTER> 
<FONT FACE=" Arial, Helvetica"><B> IZMIR </B></FONT> 
</CENTER> 
<CENTER> 
<A HREF="giresun.htm" target="_top"><FONT FACE="Arial, 
Helvetica"><B>GIRESUN</B></FONT></A></CENTER> 
<CENTER> 
<A HREF="trabzon.htm" target="_top"><FONT F ACE="Arial, 
Helvetica"><B> TRABZON </B></FONT></ A></CENTER> 
<CENTER> 
&nbsp;</P> 
<P ALIGN="CENTER"><BR> 
<BR> 
<BR> 
</CENTER> 
<CENTER> 
&nbsp;<BR> 
<A HREF="antalya.htm" target="_top"><IMG SRC="docsleft.gif'' 
WIDTH="30" HEIGHT="30" ALIGN="BOTTOM" AL T="Bir onceki 
sayfa"BORDER ="O"></ A><A HREF="tou.htm" target="_ top"><IMG 
SRC="docsupar.gif'' WIDTH="30" HEIGHT="30" 
ALIGN="BOTTOM" AL T="menu"BORDER="O"></ A><A 
HREF="giresun.htm" target="_top"><IMG SRC="docsrigh.gif'' 
WIDTH="30" HEIGHT="30" ALIGN="BOTTOM"ALT="Bir sonraki 
sayfa" BORDER ="O"></ A></CENTER> 
</BODY> 

</HTML> 
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FOR2.HTM 

<HTML> 
<HEAD> 

<META HTTP-EQUIV="Content-Type" CONTENT="text/html; 
charset=iso-8859-1 "> 
<META NAME="GENERATOR" CONTENT="Mozilla/4.02 [en] 

(Win95; I) [Netscape]"> 
<META NAME="AUTHOR" Content="METIN TASKIN"> 
<META NAME="DESCRIPTION" Content="This about 
TURKIYE"> 
<MET A NAME="KEYWORDS" Content="turkiye,hotel,akdeniz, 

antal ya,izmir ,mersin,giresun,ataturk, trabzon, ofo hotel,hil ton,prencess, 
kit tur,ormancilar,sheraton"> 

<TITLE> Hotel </TITLE> 
</HEAD> 

<BODY BACKGROUND="CDTSBK.jpg"> 
<CENTER><B><FONT F ACE="Arial, Helvetica"><FONT 
COLOR ="#CCOOOO"><FONT 
SIZE=+4> IZMIR </FONT></FONT></FONT></B></CENTER> 
<CENTER></CENTER> 
<CENTER><B><FONT F ACE="Arial, Helvetica"><FONT 
COLOR="#330066"><FONT SIZE=+2>GRAND 
HOTEL MERCURE</FONT></FONT></FONT></B></CENTER> 
<CENTER></CENTER> 
<CENTER><IMG SRC="Syil.jpg" ALT="5 yildiz" BORDER=O 
HEIGHT=39 WIDTH=189></CENTER> 
<CENTER></CENTER> 
<CENTER><IMG SRC="mercure.jpg" AL T="Hotel Mercure" 
BORDER =O HEI GHT=280 WIDTH=270></CENTER> 
<P><FONT F ACE="Arial, Helvetica"><FONT 
CO LOR ="#660099"><B> Address:</B>Curnhuriyet 
Bul. No:138 35210 Alsancak IZMIR</FONT></FONT> 
<BR><FONT F ACE="Arial, Helvetica"><FONT 
COLOR="#660099"><B>Tel:</B> (232)489 
40 90</FONT></FONT> 
<BR><FONT F ACE="Arial, Helvetica"><FONT COLOR= 
"#660099"><B>Fax:</B> 48940 89</FONT></FONT> 
<BR><FONT FACE="Arial, Helvetica"><FONT COLOR= 
"#660099"><B>Telex:</B> 52233ETIZ TR</FONT></FONT> 
<BR><FONT FACE="Arial, Helvetica"><FONT COLOR= 
"#660099"><B>Beds:</B> 370</FONT></FONT> 
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<BR><FONT F ACE="Arial, Helvetica"><FONT COLOR= 
"#660099"><B>Total Rooms:</B>185, Suits: 16, King 
Suits: 1 </FONT></FONT> 
<BR><FONT F ACE="Arial, Helvetica"><FONT COLOR= 
"#660099"><B>Rooms With:</B>Phone, WC, AirCondition, TV, 
Balcony, Hair Dryer, Music, Bath, Minibar.</FONT></FONT> 
<BR><FONT F ACE="Arial, Helvetica"><FONT COLOR= 
"#660099"><B>Hotel Facilities:</B>Safety Box, Healty Center, 
Patisserie, Coiffeur, Sauna.</FONT></FONT> 
<BR><FONT F ACE="Arial, Helvetica"><FONT COLOR= 
"#660099"><B>Restaurant:</B> 1, Indoor. </FONT></FONT> 
<BR><FONT FACE="Arial, Helvetica"><FONT COLOR= 
"#660099"><B> Bar: </B> Bekri;Lo bby. </FONT></FONT> 
<BR><FONT F ACE="Arial, Helvetica"><FONT COLOR= 
"#660099">0utdoor SwimmingPool. </FONT></FONT> 
<BR><FONT F ACE="Arial, Helvetica"><FONT COLOR= 
"#660099"><B> Airport:</B> 25km. </FONT></FONT> 
<CENTER>&nbsp;</CENTER> 
<CENTER></CENTER> 
<CENTER><B><FONT F ACE="Arial, Helvetica"><FONT COLOR= 
"#330066"><FONT SIZE=+2>BUYUKEFES 
OTEL</FONT></FONT> </FONT></B></CENTER> 
<CENTER></CENTER> 
<CENTER><IMG SRC="5yil.jpg" ALT="5 yildiz" BORDER=O 
HEIGHT=39 WIDTH=l 89></CENTER> 
<CENTER></CENTER> 
<CENTER><IMG SRC="efes.jpg" AL T="Buyuk Efes Otel" 
BORDER=O HEIGHT=280 WIDTH=270></CENTER> 
<P><FONT F ACE="Arial, Helvetica"><FONT 
COLOR="#660099"><B>Address:</B>Gaziosmanpasa Bul. No:1 
35210 IZMIR</FONT></FONT> 
<BR><FONT F ACE="Arial, Helvetica"><FONT COLOR= 
"#660099"><B>Tel: </B>(232)484 43 00 - Lines</FONT></FONT> 
<BR><FONT F ACE="Arial, Helvetica"><FONT COLOR= 
"#660099"><B>Fax:</B> 44156 95 Telex: 52341 Efes tr - 53416 Befs 
tr</FONT></FONT> 
<BR><FONT FACE="Arial, Helvetica"><FONT COLOR= 
"#660099"><B>Beds:</B> 885</FONT></FONT> 
<BR><FONT F ACE="Arial, Helvetica"><FONT COLOR= 
"#660099"><B>Total Rooms:</B>446, Suits: 50 Rooms with: Phone, 
WC, AirCondition, TV, Balcony, Hair Dryer,Music, Bath, Minibar, 
TV Sateillite System.</FONT></FONT> 
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<BR><FONT F ACE="Arial, Helvetica"><FONT COLOR= 
"#660099"><B>Hotel Facilities:</B>Casino, Market, Turkish Bath, 
Healty Center,Garden, Coiffeur, Sauna, Jakuzi.</FONT></FONT> 
<BR><FONT FACE="Arial, Helvetica"><FONT COLOR= 
"#660099"><B>Restaurant:</B>5, Indoor, Cap: 2500. Bar: 5. Meeting 
Room: 7, Cap: 310. Conference Hall:5, Cap: 3000. Banquet Facilities 
Capacity: 1500 Indoor Swimming Pool, OutdoorSwimming Pool, 
Childeren's Pool, Garage. Sports: Tennis, Table Tennis,Jogging. 
</FONT></FONT> 
<BR><FONT F ACE="Arial, Helvetica"><FONT COLOR= 
"#660099"><B> Airport:</B> 18km. </FONT></FONT> 
<CENTER>&nbsp;</CENTER> 
<CENTER></CENTER> 
<CENTER><B><FONT F ACE="Arial, Helvetica"><FONT COLOR= 
"#660099"><FONT 
SIZE=+ 3>HIL TONHOTEL</FONT></FONT></FONT></B> 
</CENTER> 
<CENTER></CENTER> 
<CENTER><IMG SRC="5yil.jpg" ALT="5 yildiz" BORDER=O 
HEIGHT=39 WIDTH=189></CENTER> 
<CENTER><IMG SRC="hilton.jpg" AL T="Izmir Hilton" 
BORDER=O HEIGHT=280 WIDTH=270></CENTER> 
<P><FONT FACE="Arial, Helvetica"><FONT COLOR= 
"#660099"><B>Address:</B> Gaziosmanpasa Bul. No: 7 35210 
Izmir</FONT></FONT><BR><FONT F ACE="Arial, Helvetica"> 
<FONT COLOR="#660099"><B>Tel:</B> (232)441 16 60 Fax: 441 
22 77</FONT></FONT><BR><FONT F ACE="Arial, Helvetica" 
><FONT COLOR="#660099"><B>Telex: </B>51167hizm 
tr</FONT></FONT> 
<BR><FONT F ACE="Arial, Helvetica"><FONT COLOR= 
"#660099"><B>Beds:</B> 542Total Rooms: 381, Suits: 20+2P 
</FONT></FONT> 
<BR><FONT F ACE="Arial, Helvetica"><FONT COLOR= 
"#660099"><B>Rooms With:</B>Phone, WC, AirCondition, TV, 
Hair Dryer, Music, Bath, Mini bar, TV SatelliteSystem. </FONT> 
</FONT> 
<BR><FONT FACE="Arial, Helvetica"><FONT COLOR= 
"#660099"><B>Hotel Facilities:</B>Shopping Center, Casino, 
Cafeteria, Healty Center, Generator, Sauna.Restaurant: 3, Indoor, Cap: 
318. Bar: 3.</FONT></FONT> 
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<BR><FONT FACE="Arial, Helvetica"><FONT COLOR= 
"#660099">Meeting Room. 11,Cap: 900.</FONT></FONT> 
<BR><FONT F ACE="Arial, Helvetica"><FONT COLOR= 
"#660099"><B>Banquet FacilitiesCapacity:</B> 900, Breakfast Hall 
Capacity: 152</FONT></FONT> 
<BR><FONT F ACE="Arial, Helvetica"><FONT COLOR= 
"#660099">Indoor SwimmingPool, Garage.</FONT></FONT> 
<BR><FONT F ACE="Arial, Helvetica"><FONT COLOR= 
"#660099"><B>Sports:</B>Tennis, Table Tennis.</FONT></FONT> 
<BR><FONT F ACE="Arial, Helvetica"><FONT COLOR= 
"#660099"><B>City Center:</B>85km Cesme, Airport: 18km, Beach: 
30km</FONT></FONT> 
<CENTER></CENTER> 
<CENTER><B><FONT F ACE="Arial, Helvetica"><FONT COLOR= 
"#660099"><FONT SIZE=+2>THERMALPRINCESS HOTEL 
</FONT> </FONT></FONT></B></CENTER> 
<CENTER></CENTER> 
<CENTER><IMG SRC="5yil.jpg" ALT="5 yildiz" BORDER=O 
HEIGHT=39 WIDTH=189></CENTER> 
<CENTER><IMG SRC="princess.jpg" AL T="Thermal Princess 
Hotel" BORDER=O HEIGHT=280 WIDTH=270></CENTER> 
<P><FONT FACE="Arial, Helvetica"><FONT COLOR= 
"#660099"><B> Adresses: </B> 3 5 3 3 OBalcova Izmir</FONT> 
</FONT> 
<BR><FONT F ACE="Arial, Helvetica"><FONT COLOR= 
"#660099"><B>Tel:</B> (232)238 51 51 PBX Fax: 239 09 
3 9</FONT></FONT> 
<BR><FONT F ACE="Arial, Helvetica"><FONT COLOR= 
"#660099"><B> Beds : </B>600</FONT></FONT><BR><FONT 
FACE="Arial, Helvetica"><FONT COLOR="#660099"><B>Total 
Rooms:</B>300,</FONT></FONT><BR><FONT FACE= "Arial, 
Helvetica"><FONT COLOR="#660099"><B>Suits :</B> 10, King 
Suits: 2</FONT></FONT> 
<BR><FONT F ACE="Arial, Helvetica"><FONT COLOR= 
"#660099"><B>Rooms With:</B>Phone, WC, AirCondition, TV, 
Balcony, Hair Dryer, Music, Bath, Minibar,TV Satellite System. 
</FONT> </FONT> 
<BR><FONT F ACE="Arial, Helvetica"><FONT COLOR= 
"#660099"><B>Hotel Facilities:</B>Snack Bar, Casino, Gymnasium 
Hall, Cafeteria, Market, Night Club, TurkishBath, TV Room, atisserie, 
Coiffeur, Garden, Disco, Jakuzzi, sauna.</FONT></FONT> 
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<BR><FONT F ACE="Arial, Helvetica"><FONT COLOR= 
"#660099"><B>Restaurant:</B> 1, Indoor, Cap: 2000; 1, Outdoor,Cap: 
2000</FONT></FONT> 
<BR><FONT F ACE="Arial, Helvetica"><FONT 
COLOR="#660099"><B>Bar:</B> Smyrna; Lobby; 
Roof. </FONT></FONT> 
<BR><FONT F ACE="Arial, Helvetica"><FONT COLOR= 
"#660099"><B>Meeting Room:</B>5, Cap: 2000. Corference Hall: 2, 
Cap: 480.</FONT></FONT> 
<BR><FONT F ACE="Arial, Helvetica"><FONT COLOR= 
"#660099"><B>Banquet FacilitiesCapacity:</B> 1200 Indoor 
Swimming Pool, Outdoor Swimming Pool, Childeren'sPool, 
Garage. </FONT></FONT> 
<BR><FONT FACE="Arial, Helvetica"><FONT COLOR= 
"#660099"><B>Sports:</B>Tennis, Table Tennis, Football, 
Volleyball, Basketball, Jogging. </FONT></FONT> 
<BR><FONT FACE=" Arial, Helvetica"><FONT 
COLOR="#660099"><B>City Center:</B>20km Cesmealti, Airport: 
24km, Beach: 750m</FONT></FONT> 

</BODY> 
</HTML> 
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GIRESUN.HTM 

<HTML> 
<HEAD> 

<META HTTP-EQUIV="Content-Type" CONTENT="text/html; 
charset=windows-1252 "> 
<META NAME="Generator" CONTENT="Microsoft Word 97"> 
<META NAME="AUTHOR" Content="METIN TASKIN"> 
<META NAME="DESCRIPTION" Content="This about 
TURKIYE"> 
<META NAME="KEYWORDS" Content="turkiye,hotel,akdeniz, 
antalya,izmir,mersin,giresun,ataturk,trabzon, ofo hotel,hilton,prencess, 
kit tur,ormancilar,sheraton"> 

<TITLE> Hotel</TITLE> 
</HEAD> 

<FRAMESET COLS= "151,643" > 
<FRAME SRC="fol3.htm" NAME="Frame7693942" RESIZE> 
<FRAME SRC="for3.htm" NAME="Frame7693957" RESIZE> 
</FRAMES ET> 

<NO FRAMES> 
<BODY> 
<P> 
</BODY> 
</NO FRAMES> 

</HTML> 

FOL3.HTM 

<HTML> 
<HEAD> 

<META HTTP-EQUIV="Content-Type" CONTENT="text/html; 
charset=windows-1252 "> 
<META NAME="Generator" CONTENT="Microsoft Word 97"> 
<META NAME="AUTHOR" Content="METIN TASKIN"> 
<META NAME="DESCRIPTION" Content="This about 
TURKIYE"> 
<META NAME="KEYWORDS" Content="turkiye,hotel,akdeniz, 
antal ya,izmir ,mersin,giresun,ataturk, trabzon, ofo hotel,hilton,prencess, 
kit tur,ormancilar,sheraton"> 
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<TITLE> Hotel </TITLE> 
</HEAD> 

<BODY BACKGROUND="CDTSBK.jpg" TEXT="#CCOOOO" 
LINK ="#CCOOOO" VLINK ="#660000" ALINK ="#CCOOOO"> 
<P ALIGN="CENTER"><IMG SRC="Flagtk.gif' WIDTH="121" 
HEIGHT="71" ALIGN="BOTTOM" ALT="Turk Bayragi" BORDER 
="O"> 

<CENTER> 
<FONT F ACE="Arial, Helvetica"><B>HOTELS</B> </FONT> 

</CENTER> 
<CENTER> 

<A HREF="antalya.htm" target="_top"><FONT FACE="Arial, 
Helvetica"><B> ANT ALY A </B></FONT></ A></CENTER> 

<CENTER> 
<A HREF="izmir.htm" target="_top"><FONT FACE="Arial, 
Helvetica"><B>IZMIR </B></FONT></ A></CENTER> 

<CENTER> 
<FONT FACE=" Arial, Helvetica"><B>GIRESUN </B></FONT> 

</CENTER> 
<CENTER> 

<A HREF="trabzon.htm" target="_top"><FONT FACE="Arial, 
Helvetica"><B> TRABZON </B></FONT></ A></CENTER> 

<CENTER> 
&nbsp;</CENTER> 
<CENTER> 
&nbsp;</CENTER> 
<CENTER> 
&nbsp;</P> 

<P ALIGN="CENTER">&nbsp;<BR> 
&nbsp;</CENTER> 
<CENTER> 
&nbsp;<BR> 
<A HREF="izmir.htm" target="_top"><IMG SRC="docsleft.gif' 
WIDTH="30" HEIGHT="30" ALIGN="BOTTOM" AL T="Bir onceki 
sayfa"BORDER ="O"></ A><A HREF="tou.htm" target="_ top"><IMG 
SRC="docsupar.gif' WIDTH="30" HEIGHT="30" 
ALIGN="BOTTOM" AL T="menu"BORDER="O"></ A><A 
HREF="trabzon.htm" target="_top"><IMG SRC="docsrigh.gif' 
WIDTH="30" HEIGHT="30" ALIGN="BOTTOM"AL T="Bir sonraki 
sayfa" BORDER ="O"></ A></CENTER> 
</BODY> 

</HTML> 
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FOR3.HTM 

<HTML> 
<HEAD> 

<META HTTP-EQUIV="Content-Type" CONTENT="text/html; 
charset=windows-1252"> 
<META NAME="Generator" CONTENT="Microsoft Word 97"> 
<META NAME="AUTHOR" Content="METIN TASKIN"> 
<META NAME="DESCRIPTION" Content="This about 
TURKIYE"> 
<MET A NAME="KEYWORDS" Content="turkiye,hotel,akdeniz, 
antalya,izmir,mersin,giresun,ataturk,trabzon, ofo hotel,hilton,prencess, 
kit tur,ormancilar,sheraton"> 

<TITLE> Hotel </TITLE> 
</HEAD> 
</HEAD> 

<BODY BACKGROUND="CDTSBK.jpg" TEXT="#660099" 
LINK ="#CCOOOO" VLINK ="#660000" ALINK ="#CCOOOO"> 
<P ALIGN="CENTER"><FONT SIZE=''7'' COLOR="#CCOOOO" 
F ACE="Arial, Helvetica"><B>GIRESUN</B></FONT></P> 
<P ALIGN="CENTER"><FONT SIZE="5" COLOR="#330066" 
FACE="Arial, Helvetica"><B>KIT-TUR HOTEL</B></FONT></P> 
<P ALIGN="CENTER"><IMG SRC="3yil.jpg" WIDTH="l 13" 
HEIGHT="39" ALIGN="BOTTOM" BORDER="O"></P> 
<P ALIGN="CENTER"><IMG SRC="kittur.jpg" WIDTH="270" 
HEIGHT="280" ALIGN="BOTTOM" BORDER="O"></P> 
<P><BR> 
<B>Address:</B> Arifbey Cad. No:27 28100 Giresin<BR> 
<B>Tel:</B> (454) 212 20 45,212 02 55<BR><B>Fax: </B>212 30 
34<BR><B>Beds:</B> lOO<BR><B>Total Rooms:</B> 50<BR> 
<B>Rooms With:</B> Phone,WC, TV, Music, Bath, TV Stallitite 
System.<BR><B>Hotel Facilities:</B> Snack Bar, Gymnasium Hall, 
TV Room, Sauna, Laundry.<BR><B>Restaurant:</B> 1,Cap:100. 
<BR><B>Meeting Room:</B> 1,Cap: 100.<BR><B>Breakfast Hall 
Capacity: </B> 1 OO<BR>Parking.<BR><B>Airport: </B> 130km 
Trabzon. <IP> 
<P ALIGN="CENTER"><FONT SIZE="5" COLOR="#330066" 
F ACE="Arial, Helvetica"><B>ORMANCILAR 
HOTEL</B></FONT></P><P ALIGN="CENTER"> <IMG 
SRC="lyil.jpg" WIDTH="40" HEIGHT="39" ALIGN="BOTTOM" 
BORDER ="O"></P> 
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<P ALIGN="CENTER"><IMG SRC="orman.gif'' WIDTH="270" 
HEIGHT="280" ALIGN="BOTTOM" BORDER="O"></P> 
<P><B>Address:</B> Gazi Cd. No:37 28100 Giresun<BR> 
<B>Tel:</B> (454) 216 67 95,212 43 9l<BR><B>Fax:</B> 212 71 
05 46<BR><B>Total Rooms:</B> 23, King Suits: 1.<BR><B>Rooms 
With: </B>Phone, WC, TV, Bath, TV satellite System.<BR><B>Hotel 
Facilities: </B>Central Heating, Safety Box, TV Room,Generator. 
<BR> 
<B>Restaurant:</B> 1.<BR><B>Breakfast Hall Capacity: </B> 40 
<BR><B>Airport: </B>130km Trabzon, Beach: 250m 
</BODY> 

</HTML> 
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TRABZON.HTM 

<HTML> 
<HEAD> 

<META HTTP-EQUIV="Content-Type" CONTENT="text/html; 
charset=windows-1252 "> 
<META NAME="Generator" CONTENT="Microsoft Word 97"> 
<MET A NAME=" AUTHOR" Content="METIN T ASKIN"> 
<META NAME="DESCRIPTION" Content="This about 
TURKIYE"> 
<MET A NAME="KEYWORDS" Content="turkiye,hotel,akdeniz, 
antalya,izmir,mersin,giresun,ataturk,trabzon, ofo hotel,hilton,prencess, 
kit tur,ormancilar,sheraton"> 

<TITLE> Hotel </TITLE> 
</HEAD> 

<FRAMESET COLS= "153,641" > 
<FRAME SRC="fol4.htm" NAME="Frame9437861" RESIZE> 
<FRAME SRC="for4.htm" NAME="Frame9437870" RESIZE> 
</FRAMES ET> 

<NO FRAMES> 
<BODY> 
<P> 
</BODY> 
</NO FRAMES> 

</HTML> 

FOL4.HTM 

<HTML> 
<HEAD> 

<META HTTP-EQUIV="Content-Type" CONTENT="text/html; 
charset=iso-8859-1 "> 
<META NAME="GENERATOR" CONTENT="Mozilla/4.02 [en] 
(Win95; I) [Netscape]"> 
<META NAME="AUTHOR" Content="METIN TASKIN"> 
<META NAME="DESCRIPTION" Content="This 

aboutTURKIYE"> 
<MET A NAME="KEYWORDS" Content="turkiye,hotel,akdeniz, 
antalya,izmir,mersin,giresun,ataturk,trabzon, ofo hotel,hilton,prencess, 
kit tur,ormancilar,sheraton"> 

<TITLE>Hotel</TITLE> 
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</HEAD> 
<BODY TEXT="#CCOOOO" LINK="#CCOOOO" VLINK="#660000" 
ALINK ="#CCOOOO" BACKGROUND="CDTSBK.jpg"> 
<CENTER><IMG SRC="Flagtk.gif' ALT="Turk Bayragi" 
BORDER=O HEIGHT=71 WIDTH=121></CENTER> 
<CENTER></CENTER> 
<CENTER><B><FONT F ACE="Arial, Helvetica">HOTELS 
</FONT> </B></CENTER> 
<CENTER></CENTER> 
<CENTER><B><FONT F ACE="Arial, Helvetica"><A HREF= 
"antalya.htm" target="_top">ANTAL YA</A></FONT> 
</B></CENTER> 
<CENTER><B><FONT F ACE="Arial, Helvetica"><A HREF= 
"izmir.htm" target="_top">IZMIR</A></FONT></B></CENTER> 
<CENTER><B><FONT F ACE="Arial, Helvetica"><A HREF= 
"giresun.htm" target="_top">GIRESUN</A></FONT> 
</B></CENTER> 
<CENTER><B><FONT F ACE="Arial, Helvetica"> TRABZON 
</FONT></B></CENTER> 
<CENTER>&nbsp;</CENTER> 
<CENTER>&nbsp;</CENTER> 
<CENTER>&nbsp;</CENTER> 
<CENTER>&nbsp;</CENTER> 
<CENTER>&nbsp;</CENTER> 
<CENTER>&nbsp;</CENTER> 
<CENTER></CENTER> 
<CENTER><A HREF="giresun.htm" target="_top"><IMG SRC= 
"docsleft.gif" AL T="Bir onceki sayfa" BORDER=O HEIGHT=30 
WIDTH=30></A><A HREF="tou.htm" target="_top"><IMG 
SRC="docsupar.gif' ALT="menu" BORDER=O HEIGHT=30 
WIDTH=30></A><A HREF="index.htm" target="_top"><IMG 
SRC="docsrigh.gif' ALT="Bir sonraki sayfa" BORDER=O 
HEIGHT=30 WIDTH=30></ A></CENTER> 
</BODY> 

</HTML> 
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FOR4.HTM 

<HTML> 
<HEAD> 

<META HTTP-EQUIV="Content-Type" CONTENT="text/html; 
charset=windows-1252 "> 
<META NAME="Generator" CONTENT="Microsoft Word 97"> 
<META NAME="AUTHOR" Content="METIN TASKIN"> 
<MET A NAME="DESCRIPTION" Content="This about 
TURKIYE"> 
<META NAME="KEYWORDS" Content="turkiye,hotel,akdeniz, 
antalya,izmir,mersin,giresun,ataturk,trabzon, ofo hotel,hilton,prencess, 
kit tur,ormancilar,sheraton"> 

<TITLE>Hotel</TITLE> 
</HEAD> 

<BODY BACKGROUND="CDTSBK.jpg" TEXT="#660099"> 
<P ALIGN="CENTER"><FONT SIZE="5" COLOR="#330066" 
F ACE="Arial, Helvetica"><B>AKSULAR OTEL</B></FONT></P> 
<P ALIGN="CENTER"><IMG SRC="2yil.jpg" WIDTH="76" 
HEIGHT="39" ALIGN="BOTTOM" BORDER="O"></P> 
<P ALIGN="CENTER"><IMG SRC="aksular.jpg" WIDTH="270" 
HEIGHT="280" ALIGN="BOTTOM" BORDER="O"></P> 
<P><B>Address: </B>Uzunkum Mevkii No:33 Trabzon<BR> 
<B>Tel: </B>(462) 230 11 30 - 8 Lines<BR><B>Fax:</B> 229 -t7 59 
<BR><B>Beds:</B> 150<BR><B>Total Rooms: </B>70, Suits: 7 
<BR><B>Rooms With: </B>Phone, WC, TV, Hair Dryer, Music 
Bath, Minibar, TV Satellite System, Safety Box.<BR><B>Hotel 
Facilities: </B>Central Heating, AirCondition, TV Room, Garden, 
Generator.<BR><B>Restaurant:</B> 1, Indoor, Cap:480; lOutdoor, 
Cap: 80.<BR><B>Bar: </B>Roof.<BR><B>Breakfast Hall Capacity: 
</B> 80<BR>Parking.<BR><B>City Center: </B>O, Airport: 7km, 
Beach: 50m</P><P ALIGN="CENTER"><FONT SIZE="S" 
COLOR= "#330066" FACE="Arial, Helvetica"><B>HORON 
HOTEL</B></FONT></P> 
<P ALIGN="CENTER"><IMG SRC="horon.jpg" WIDTH="270" 
HEIGHT="280" ALIGN="BOTTOM" BORDER="O"></P> 
<P><B>Address: </B>Siramagazalar Cd. No:125 61100 Trabzon 
<BR><B>Tel: </B>(462) 326 64 55 - 6 Lines<BR><B>Fax: </B>321 
66 28<BR><B>Beds:</B> 107<BR><B>Total Rooms: </B>44, Suits: 
5<BR><B>Rooms With: </B>Phone, WC, AirCondition, TV, Balcony 
, Refrigerator, Bath, TV Stailite System.<BR><B>Hotel acilities:</B> 
Snack Bar, Central Heating, TV Room, Generator.<BR> 
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<B>Restaurant: </B> 1, Indoor,Cap: 120.<BR><B>Bar: </B>2.<BR> 
<B>Meeting Room: </B>4, Cap: 80.<BR>Parking.<BR><B>City 
Center: </B>O, Airport: 3km, Beach: 400m</P> 
<P ALIGN="CENTER"><FONT SIZE="5" COLOR="#330066" 
F ACE="Arial, Helvetica"><B>USTA HOTEL</B></FONT></P> 
<P ALIGN="CENTER"><IMG SRC="usta.jpg" WIDTH="270" 
HEIGHT="280" ALIGN="BOTTOM" BORDER="O"></P> 
<P><B>Address: </B>Telgrafhane Sk. No: 3 61100 Trabzon<BR> 
<B>Tel:</B> (462) 326 57 00 PBX<BR><B>Fax: </B>322 37 93 
<BR><B>Telex:</B> 83214 Atmetr<BR><B>Beds:</B> 166<BR> 
<B>Total Rooms:</B> 87, Suits: 6, King Suits: 6<BR><B>Rooms 

With:</B> Phone, WC, AirCondition, TV, Hair Dryer, Bath, Minibar, TV 
Satellite System.<BR><B>Hotel Facilities:</B> Snack Bar, Central Heating, 
Air Condition, Patisserie, Coiffeur, Sauna.<BR><B>Restaurant: </B>2, Cap: 
280.<BR><B>Meeting Room:</B> 1, Cap: 150.<BR><B>Banquet Facilities 
Capacity:</B> 250, Breakfast Hall<BR><B>Capacity: </B>lOO<BR> 
Parking, Garage.<BR><B>City Center:</B> 0, 
</BODY> 

</HTML> 

- 185 - 


	Page 1
	Titles
	NEAREAST UNIVERSITY 
	METiN TA~KIN 
	MISS. BESiME ERiN 

	Images
	Image 1
	Image 2
	Image 3


	Page 2
	Titles
	NEAR EAST UNIVER9TY 
	CONTENTS 
	CHAPTER A 

	Images
	Image 1


	Page 3
	Titles
	NEAR EAST UNIVERSTY 
	CONTENTS 

	Images
	Image 1


	Page 4
	Titles
	NEAR EAST tlNIVERSTY 
	CONTENTS 
	CHAPTER B 

	Images
	Image 1


	Page 5
	Titles
	NEAR EAST llNIVERSTY 
	CONTENTS 
	CHAPTER C 

	Images
	Image 1


	Page 6
	Images
	Image 1


	Page 7
	Titles
	NEAR EAST UNIVERSTY 
	CONCLUSION 

	Images
	Image 1


	Page 8
	Titles
	NEAR EAST UNIVERSTY 
	CHAPTER A 
	INTERNET 
	Historical Background 

	Images
	Image 1
	Image 2
	Image 3
	Image 4
	Image 5
	Image 6


	Page 9
	Titles
	NEAR EAST UNIVERSTY 
	Fig.1. An Internet System 

	Images
	Image 1


	Page 10
	Titles
	NEAR EA$1 tlNIVER9TY 
	Technical Definitions: 

	Images
	Image 1


	Page 11
	Titles
	NEAR EAST UNIVERSTY 
	For example: 158.143.103.60 
	For example: VAX.RES.AC.UK 
	Various Protocols 

	Images
	Image 1


	Page 12
	Titles
	NEAR EAST UNIVER9TY 
	CUSEEME 
	Network News 
	Telnet 
	FTP 

	Images
	Image 1


	Page 13
	Titles
	NEAR EAST UNIVERSTY 
	Gopher 
	The World Wide Web 
	UNIFORM RESOURCE LOCATORS (URLs) 

	Images
	Image 1


	Page 14
	Titles
	NEAR EAST UNIYER9TY 
	Searching the Internet 
	ARCHIE 

	Images
	Image 1


	Page 15
	Titles
	NEAR EAST tlNIVERSTY 

	Images
	Image 1


	Page 16
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 17
	Titles
	NEAR EAST UNIVERSTY 
	What Software to Use For Writing HTML Programs 
	File Extension 
	TAG REFERENCE 
	Document Formatting 
	Tag Description 

	Images
	Image 1
	Image 2

	Tables
	Table 1


	Page 18
	Titles
	Paragraph Formatting 
	NEAR EAST tlNIVERSTY 
	Tag 
	Description 
	Character Formatting 
	Tag Description 

	Images
	Image 1

	Tables
	Table 1
	Table 2


	Page 19
	Titles
	NEAR EA91 tlNIVER9TY 
	List Formattipg 
	Tag 
	Description 
	Anchor Formatting 
	Tag Attribute Description 

	Images
	Image 1
	Image 2

	Tables
	Table 1
	Table 2


	Page 20
	Titles
	Image Formatting 
	NEAR EAST UNIYERSTY 
	Tag 
	Attribute 
	Descri~tion and Notes 

	Images
	Image 1


	Page 21
	Titles
	NEAR EAST UNIVERSTY 
	Table Formatting 
	Tag Attribute Descri_etior, and Notes 

	Images
	Image 1


	Page 22
	Titles
	NEAR EAST UNIVERSTY 
	VIDEO STANDARTS 

	Images
	Image 1


	Page 23
	Titles
	NEAR EAST UN/f/ERSTY 
	TCP/IP & INTERNET STRUCTURE 
	Introduction: 
	Network 
	G-Gateways 
	Network 
	Network 

	Images
	Image 1
	Image 2
	Image 3


	Page 24
	Titles
	NEAR EAST UNIVERSTY 
	The transmission Control Protocol(TCP) 
	Message 
	Packet 
	Packet 

	Images
	Image 1
	Image 2
	Image 3
	Image 4


	Page 25
	Titles
	NEAR EAST UNIVERSTY 
	TCP Service Interfaces 
	The most important TCP services are: 

	Images
	Image 1

	Tables
	Table 1


	Page 26
	Titles
	NEAR EAST UNIVERSTY 
	Connection Establishment 

	Images
	Image 1


	Page 27
	Titles
	NEAR EAST UNIVERSTY 
	Data Transfer 
	Sequence Numbering 
	WINDOWS MECHANISM 

	Images
	Image 1


	Page 28
	Titles
	NEAR EAST UNIVERSTY 
	Transmission Watchdog 
	TCP Internet Protocol(IP) 

	Images
	Image 1
	Image 2
	Image 3


	Page 29
	Titles
	NEAR EAST UNIVERSTY 
	Datagram Delivery Over A Single Network 
	Internet Address 
	Universal Identifiers: 
	Three Primary Classes of IP Addresses 

	Images
	Image 1
	Image 2


	Page 30
	Titles
	NEAR EAST tlNIVERSTY 

	Images
	Image 1
	Image 2

	Tables
	Table 1


	Page 31
	Titles
	NEAR EAST UNIVERSTY 
	Difference Between Frames & Tables 
	Disadvantage of Frames 

	Images
	Image 1
	Image 2


	Page 32
	Titles
	NEAR EAST IINIVERSTY 
	CHAPTER B 
	USING WORD PAGE 
	WORKING WITH ONLINE AND INTERNET DOCUMENTS 

	Images
	Image 1
	Image 2
	Image 3


	Page 33
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 34
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 35
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 36
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 37
	Titles
	NEAR EA91 UNIYER9TY 

	Images
	Image 1
	Image 2


	Page 38
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 39
	Titles
	NEAR EA9T tlNIVER9TY 

	Images
	Image 1
	Image 2


	Page 40
	Titles
	NEAR EAST l/NIVERSTY 

	Images
	Image 1
	Image 2


	Page 41
	Titles
	NEAR EAST UNIVERSTY 
	CREATING AND WORKING WITH WEB PAGES 

	Images
	Image 1
	Image 2


	Page 42
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 43
	Titles
	NEAR EAST UNIVER9TY 

	Images
	Image 1
	Image 2


	Page 44
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 45
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 46
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 47
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 1
	Titles
	NEAREAST UNIVERSITY 
	METiN TA~KIN 
	MISS. BESiME ERiN 

	Images
	Image 1
	Image 2
	Image 3


	Page 2
	Titles
	NEAR EAST UNIVER9TY 
	CONTENTS 
	CHAPTER A 

	Images
	Image 1


	Page 3
	Titles
	NEAR EAST UNIVERSTY 
	CONTENTS 

	Images
	Image 1


	Page 4
	Titles
	NEAR EAST tlNIVERSTY 
	CONTENTS 
	CHAPTER B 

	Images
	Image 1


	Page 5
	Titles
	NEAR EAST llNIVERSTY 
	CONTENTS 
	CHAPTER C 

	Images
	Image 1


	Page 6
	Images
	Image 1


	Page 7
	Titles
	NEAR EAST UNIVERSTY 
	CONCLUSION 

	Images
	Image 1


	Page 8
	Titles
	NEAR EAST UNIVERSTY 
	CHAPTER A 
	INTERNET 
	Historical Background 

	Images
	Image 1
	Image 2
	Image 3
	Image 4
	Image 5
	Image 6


	Page 9
	Titles
	NEAR EAST UNIVERSTY 
	Fig.1. An Internet System 

	Images
	Image 1


	Page 10
	Titles
	NEAR EA$1 tlNIVER9TY 
	Technical Definitions: 

	Images
	Image 1


	Page 11
	Titles
	NEAR EAST UNIVERSTY 
	For example: 158.143.103.60 
	For example: VAX.RES.AC.UK 
	Various Protocols 

	Images
	Image 1


	Page 12
	Titles
	NEAR EAST UNIVER9TY 
	CUSEEME 
	Network News 
	Telnet 
	FTP 

	Images
	Image 1


	Page 13
	Titles
	NEAR EAST UNIVERSTY 
	Gopher 
	The World Wide Web 
	UNIFORM RESOURCE LOCATORS (URLs) 

	Images
	Image 1


	Page 14
	Titles
	NEAR EAST UNIYER9TY 
	Searching the Internet 
	ARCHIE 

	Images
	Image 1


	Page 15
	Titles
	NEAR EAST tlNIVERSTY 

	Images
	Image 1


	Page 16
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 17
	Titles
	NEAR EAST UNIVERSTY 
	What Software to Use For Writing HTML Programs 
	File Extension 
	TAG REFERENCE 
	Document Formatting 
	Tag Description 

	Images
	Image 1
	Image 2

	Tables
	Table 1


	Page 18
	Titles
	Paragraph Formatting 
	NEAR EAST tlNIVERSTY 
	Tag 
	Description 
	Character Formatting 
	Tag Description 

	Images
	Image 1

	Tables
	Table 1
	Table 2


	Page 19
	Titles
	NEAR EA91 tlNIVER9TY 
	List Formattipg 
	Tag 
	Description 
	Anchor Formatting 
	Tag Attribute Description 

	Images
	Image 1
	Image 2

	Tables
	Table 1
	Table 2


	Page 20
	Titles
	Image Formatting 
	NEAR EAST UNIYERSTY 
	Tag 
	Attribute 
	Descri~tion and Notes 

	Images
	Image 1


	Page 21
	Titles
	NEAR EAST UNIVERSTY 
	Table Formatting 
	Tag Attribute Descri_etior, and Notes 

	Images
	Image 1


	Page 22
	Titles
	NEAR EAST UNIVERSTY 
	VIDEO STANDARTS 

	Images
	Image 1


	Page 23
	Titles
	NEAR EAST UN/f/ERSTY 
	TCP/IP & INTERNET STRUCTURE 
	Introduction: 
	Network 
	G-Gateways 
	Network 
	Network 

	Images
	Image 1
	Image 2
	Image 3


	Page 24
	Titles
	NEAR EAST UNIVERSTY 
	The transmission Control Protocol(TCP) 
	Message 
	Packet 
	Packet 

	Images
	Image 1
	Image 2
	Image 3
	Image 4


	Page 25
	Titles
	NEAR EAST UNIVERSTY 
	TCP Service Interfaces 
	The most important TCP services are: 

	Images
	Image 1

	Tables
	Table 1


	Page 26
	Titles
	NEAR EAST UNIVERSTY 
	Connection Establishment 

	Images
	Image 1


	Page 27
	Titles
	NEAR EAST UNIVERSTY 
	Data Transfer 
	Sequence Numbering 
	WINDOWS MECHANISM 

	Images
	Image 1


	Page 28
	Titles
	NEAR EAST UNIVERSTY 
	Transmission Watchdog 
	TCP Internet Protocol(IP) 

	Images
	Image 1
	Image 2
	Image 3


	Page 29
	Titles
	NEAR EAST UNIVERSTY 
	Datagram Delivery Over A Single Network 
	Internet Address 
	Universal Identifiers: 
	Three Primary Classes of IP Addresses 

	Images
	Image 1
	Image 2


	Page 30
	Titles
	NEAR EAST tlNIVERSTY 

	Images
	Image 1
	Image 2

	Tables
	Table 1


	Page 31
	Titles
	NEAR EAST UNIVERSTY 
	Difference Between Frames & Tables 
	Disadvantage of Frames 

	Images
	Image 1
	Image 2


	Page 32
	Titles
	NEAR EAST IINIVERSTY 
	CHAPTER B 
	USING WORD PAGE 
	WORKING WITH ONLINE AND INTERNET DOCUMENTS 

	Images
	Image 1
	Image 2
	Image 3


	Page 33
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 34
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 35
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 36
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 37
	Titles
	NEAR EA91 UNIYER9TY 

	Images
	Image 1
	Image 2


	Page 38
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 39
	Titles
	NEAR EA9T tlNIVER9TY 

	Images
	Image 1
	Image 2


	Page 40
	Titles
	NEAR EAST l/NIVERSTY 

	Images
	Image 1
	Image 2


	Page 41
	Titles
	NEAR EAST UNIVERSTY 
	CREATING AND WORKING WITH WEB PAGES 

	Images
	Image 1
	Image 2


	Page 42
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 43
	Titles
	NEAR EAST UNIVER9TY 

	Images
	Image 1
	Image 2


	Page 44
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 45
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 46
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 47
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 48
	Titles
	NEAR EAST tlNIVERSTY 

	Images
	Image 1
	Image 2


	Page 49
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 50
	Titles
	NEAR EA$1 UNIVER9TY 

	Images
	Image 1
	Image 2


	Page 51
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 52
	Titles
	NEAR EAST llNIVERSTY 

	Images
	Image 1
	Image 2


	Page 53
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 54
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 55
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 56
	Titles
	NEAR EAST UNIVER9TY 

	Images
	Image 1
	Image 2


	Page 57
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 58
	Titles
	NEAR EAST UNIVERSTY 
	USING VISUAL PAGE 
	USING BASIC FEATURES 

	Images
	Image 1
	Image 2


	Page 59
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 60
	Titles
	NEAR EAST UNIYERSTY 

	Images
	Image 1
	Image 2
	Image 3


	Page 61
	Titles
	NEAR EAST llNIVER9TY 
	* 
	* 

	Images
	Image 1
	Image 2


	Page 62
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 63
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 64
	Titles
	NEAR EAST UNIYERSTY 

	Images
	Image 1
	Image 2


	Page 65
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 66
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 67
	Titles
	NEAR EAST UNIVER9TY 

	Images
	Image 1
	Image 2


	Page 68
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 69
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2
	Image 3


	Page 70
	Titles
	NEAR EAST UNIVERSTY 
	webmaster@symantec.itools.com 

	Images
	Image 1
	Image 2


	Page 71
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 72
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 73
	Titles
	NEAR EAST UN/f/ERSTY 

	Images
	Image 1
	Image 2


	Page 74
	Titles
	NEAR EAST UNIVER9TY 

	Images
	Image 1
	Image 2


	Page 75
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 76
	Titles
	NEAR EAST UN/f/ER9TY 

	Images
	Image 1
	Image 2


	Page 77
	Titles
	KEAR EAST UKIVERSTY 

	Images
	Image 1
	Image 2


	Page 78
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 79
	Titles
	NEAR EA91 tlNIYER9TY 

	Images
	Image 1
	Image 2


	Page 80
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 81
	Titles
	KEAR EAST UKIVERSTY 

	Images
	Image 1
	Image 2


	Page 82
	Titles
	NEAR EAST UNIVER9TY 

	Images
	Image 1
	Image 2


	Page 83
	Titles
	NEAR EA91 t/NIVER9TY 

	Images
	Image 1
	Image 2


	Page 84
	Titles
	NEAR EAST tlNIVERSTY 

	Images
	Image 1
	Image 2


	Page 85
	Titles
	NEAR EAST tlNIVERSTY 

	Images
	Image 1
	Image 2


	Page 86
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1


	Page 87
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 88
	Titles
	KEAR EAST UKIVERSTY 

	Images
	Image 1
	Image 2


	Page 89
	Titles
	NEAR EAST t/NIVERSTY 

	Images
	Image 1
	Image 2


	Page 90
	Titles
	NEAR EAST llNIVERSTY 

	Images
	Image 1
	Image 2


	Page 91
	Titles
	KEAR EAST UKIVERSTY 

	Images
	Image 1
	Image 2


	Page 92
	Titles
	Harvester of Sorrow 

	Images
	Image 1


	Page 93
	Images
	Image 1
	Image 2
	Image 3


	Page 94
	Titles
	UNTIL IT SLEEP 

	Images
	Image 1
	Image 2


	Page 95
	Images
	Image 1
	Image 2


	Page 96
	Titles
	MAMA SAID 

	Images
	Image 1
	Image 2


	Page 97
	Images
	Image 1
	Image 2


	Page 98
	Titles
	NEAR EAST UNIVERSTY 
	CHAPTER C 
	LEARNING JAVASCRIPT 
	How to take full advantage of JavaScript by moving 
	Summary 
	Introducing functions 
	function name (params) { 
	} 
	name is the unique name of the function. All function names in a script 
	params is one or more parameter variables you pass to the function. 

	Images
	Image 1
	Image 2


	Page 99
	Titles
	NEAR EAST UNIVERSTY 
	Defining and using a function 

	Images
	Image 1
	Image 2


	Page 100
	Titles
	NEAR EAST t/NIVERSTY 
	Calling a function with an event handler 

	Images
	Image 1
	Image 2


	Page 101
	Titles
	NEAR EAST UNIVERSTY 
	<INPUT TYPE="button" VALUE="Click" onClick="basicFunction()"> 
	</BODY> 
	</HTML> 
	Passing a value to a function 
	function basicExample (Text) { 
	Passing multiple values to a function 
	multipleParams ("one", "two"); 
	function multipleParams (Param1, Param2) { 

	Images
	Image 1
	Image 2


	Page 102
	Titles
	NEAR EAST UNIVERSTY 
	Returning a value from a function 

	Images
	Image 1
	Image 2


	Page 103
	Titles
	NEAR EAST tlNIVERSTY 
	Defining local variables within functions 

	Images
	Image 1
	Image 2


	Page 104
	Titles
	NEAR EA91 UNIVER9TY 
	Calling one function from another function 
	} 

	Images
	Image 1
	Image 2


	Page 105
	Titles
	NEAR EAST UNIVERSTY 
	Creating objects with user-defined functions 

	Images
	Image 1
	Image 2


	Page 106
	Titles
	NEAR EAST UNIVERSTY 
	Defining new properties to already-made objects 
	Defining properties when you create the object 
	} 

	Images
	Image 1
	Image 2
	Image 3


	Page 107
	Titles
	NEAR EAST UN/f/ERSTY 
	' ' ' 
	Creating user-defined methods 
	} 

	Images
	Image 1
	Image 2


	Page 108
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 109
	Titles
	NEAR EAST UNIVER9TY 
	function makeCustomer(Name, Address, Phone) { 
	this.address= Address; 
	this.phone= Phone; 
	this.displayCustomer = displayCustomer; 
	run() 
	Conclusion 

	Images
	Image 1
	Image 2


	Page 110
	Titles
	in 
	NEAR EAST UNIVER9TY 
	Take Advantage of User-Defined Variables 
	Learn how to master variables, the special information� 
	Summary 

	Images
	Image 1
	Image 2


	Page 111
	Titles
	NEAR EAST UNIVER9TY 
	Contents placed in JavaScript variables 
	Numbers in variables 
	MyVar = 10; 
	Strings in variables 
	"I am a string;' 
	'I am a string' 
	MyVar = "This is JavaScript"; 

	Images
	Image 1
	Image 2


	Page 112
	Titles
	NEAR EAST UNIVERSTY 
	Boolean values in variables 
	MyVar = true; 
	Objects in variables 
	MyVar = navigator; 
	MyVar = new myObject(); 

	Images
	Image 1
	Image 2


	Page 113
	Titles
	NEAR EAST UNIVER9TY 
	Understanding JavaScript's "loose" variable data types 
	Using the var statement to assign a variable 
	var MyVar = "This is a variable"; 
	var MyVar; 
	String length limitations 

	Images
	Image 1
	Image 2


	Page 114
	Titles
	NEAR EA91 llNIVER9TY 
	Understanding the "scope" of variables 

	Images
	Image 1
	Image 2


	Page 1
	Titles
	NEAREAST UNIVERSITY 
	METiN TA~KIN 
	MISS. BESiME ERiN 

	Images
	Image 1
	Image 2
	Image 3


	Page 2
	Titles
	NEAR EAST UNIVER9TY 
	CONTENTS 
	CHAPTER A 

	Images
	Image 1


	Page 3
	Titles
	NEAR EAST UNIVERSTY 
	CONTENTS 

	Images
	Image 1


	Page 4
	Titles
	NEAR EAST tlNIVERSTY 
	CONTENTS 
	CHAPTER B 

	Images
	Image 1


	Page 5
	Titles
	NEAR EAST llNIVERSTY 
	CONTENTS 
	CHAPTER C 

	Images
	Image 1


	Page 6
	Images
	Image 1


	Page 7
	Titles
	NEAR EAST UNIVERSTY 
	CONCLUSION 

	Images
	Image 1


	Page 8
	Titles
	NEAR EAST UNIVERSTY 
	CHAPTER A 
	INTERNET 
	Historical Background 

	Images
	Image 1
	Image 2
	Image 3
	Image 4
	Image 5
	Image 6


	Page 9
	Titles
	NEAR EAST UNIVERSTY 
	Fig.1. An Internet System 

	Images
	Image 1


	Page 10
	Titles
	NEAR EA$1 tlNIVER9TY 
	Technical Definitions: 

	Images
	Image 1


	Page 11
	Titles
	NEAR EAST UNIVERSTY 
	For example: 158.143.103.60 
	For example: VAX.RES.AC.UK 
	Various Protocols 

	Images
	Image 1


	Page 12
	Titles
	NEAR EAST UNIVER9TY 
	CUSEEME 
	Network News 
	Telnet 
	FTP 

	Images
	Image 1


	Page 13
	Titles
	NEAR EAST UNIVERSTY 
	Gopher 
	The World Wide Web 
	UNIFORM RESOURCE LOCATORS (URLs) 

	Images
	Image 1


	Page 14
	Titles
	NEAR EAST UNIYER9TY 
	Searching the Internet 
	ARCHIE 

	Images
	Image 1


	Page 15
	Titles
	NEAR EAST tlNIVERSTY 

	Images
	Image 1


	Page 16
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 17
	Titles
	NEAR EAST UNIVERSTY 
	What Software to Use For Writing HTML Programs 
	File Extension 
	TAG REFERENCE 
	Document Formatting 
	Tag Description 

	Images
	Image 1
	Image 2

	Tables
	Table 1


	Page 18
	Titles
	Paragraph Formatting 
	NEAR EAST tlNIVERSTY 
	Tag 
	Description 
	Character Formatting 
	Tag Description 

	Images
	Image 1

	Tables
	Table 1
	Table 2


	Page 19
	Titles
	NEAR EA91 tlNIVER9TY 
	List Formattipg 
	Tag 
	Description 
	Anchor Formatting 
	Tag Attribute Description 

	Images
	Image 1
	Image 2

	Tables
	Table 1
	Table 2


	Page 20
	Titles
	Image Formatting 
	NEAR EAST UNIYERSTY 
	Tag 
	Attribute 
	Descri~tion and Notes 

	Images
	Image 1


	Page 21
	Titles
	NEAR EAST UNIVERSTY 
	Table Formatting 
	Tag Attribute Descri_etior, and Notes 

	Images
	Image 1


	Page 22
	Titles
	NEAR EAST UNIVERSTY 
	VIDEO STANDARTS 

	Images
	Image 1


	Page 23
	Titles
	NEAR EAST UN/f/ERSTY 
	TCP/IP & INTERNET STRUCTURE 
	Introduction: 
	Network 
	G-Gateways 
	Network 
	Network 

	Images
	Image 1
	Image 2
	Image 3


	Page 24
	Titles
	NEAR EAST UNIVERSTY 
	The transmission Control Protocol(TCP) 
	Message 
	Packet 
	Packet 

	Images
	Image 1
	Image 2
	Image 3
	Image 4


	Page 25
	Titles
	NEAR EAST UNIVERSTY 
	TCP Service Interfaces 
	The most important TCP services are: 

	Images
	Image 1

	Tables
	Table 1


	Page 26
	Titles
	NEAR EAST UNIVERSTY 
	Connection Establishment 

	Images
	Image 1


	Page 27
	Titles
	NEAR EAST UNIVERSTY 
	Data Transfer 
	Sequence Numbering 
	WINDOWS MECHANISM 

	Images
	Image 1


	Page 28
	Titles
	NEAR EAST UNIVERSTY 
	Transmission Watchdog 
	TCP Internet Protocol(IP) 

	Images
	Image 1
	Image 2
	Image 3


	Page 29
	Titles
	NEAR EAST UNIVERSTY 
	Datagram Delivery Over A Single Network 
	Internet Address 
	Universal Identifiers: 
	Three Primary Classes of IP Addresses 

	Images
	Image 1
	Image 2


	Page 30
	Titles
	NEAR EAST tlNIVERSTY 

	Images
	Image 1
	Image 2

	Tables
	Table 1


	Page 31
	Titles
	NEAR EAST UNIVERSTY 
	Difference Between Frames & Tables 
	Disadvantage of Frames 

	Images
	Image 1
	Image 2


	Page 32
	Titles
	NEAR EAST IINIVERSTY 
	CHAPTER B 
	USING WORD PAGE 
	WORKING WITH ONLINE AND INTERNET DOCUMENTS 

	Images
	Image 1
	Image 2
	Image 3


	Page 33
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 34
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 35
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 36
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 37
	Titles
	NEAR EA91 UNIYER9TY 

	Images
	Image 1
	Image 2


	Page 38
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 39
	Titles
	NEAR EA9T tlNIVER9TY 

	Images
	Image 1
	Image 2


	Page 40
	Titles
	NEAR EAST l/NIVERSTY 

	Images
	Image 1
	Image 2


	Page 41
	Titles
	NEAR EAST UNIVERSTY 
	CREATING AND WORKING WITH WEB PAGES 

	Images
	Image 1
	Image 2


	Page 42
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 43
	Titles
	NEAR EAST UNIVER9TY 

	Images
	Image 1
	Image 2


	Page 44
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 45
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 46
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 47
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 48
	Titles
	NEAR EAST tlNIVERSTY 

	Images
	Image 1
	Image 2


	Page 49
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 50
	Titles
	NEAR EA$1 UNIVER9TY 

	Images
	Image 1
	Image 2


	Page 51
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 52
	Titles
	NEAR EAST llNIVERSTY 

	Images
	Image 1
	Image 2


	Page 53
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 54
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 55
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 56
	Titles
	NEAR EAST UNIVER9TY 

	Images
	Image 1
	Image 2


	Page 57
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 58
	Titles
	NEAR EAST UNIVERSTY 
	USING VISUAL PAGE 
	USING BASIC FEATURES 

	Images
	Image 1
	Image 2


	Page 59
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 60
	Titles
	NEAR EAST UNIYERSTY 

	Images
	Image 1
	Image 2
	Image 3


	Page 61
	Titles
	NEAR EAST llNIVER9TY 
	* 
	* 

	Images
	Image 1
	Image 2


	Page 62
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 63
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 64
	Titles
	NEAR EAST UNIYERSTY 

	Images
	Image 1
	Image 2


	Page 65
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 66
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 67
	Titles
	NEAR EAST UNIVER9TY 

	Images
	Image 1
	Image 2


	Page 68
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 69
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2
	Image 3


	Page 70
	Titles
	NEAR EAST UNIVERSTY 
	webmaster@symantec.itools.com 

	Images
	Image 1
	Image 2


	Page 71
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 72
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 73
	Titles
	NEAR EAST UN/f/ERSTY 

	Images
	Image 1
	Image 2


	Page 74
	Titles
	NEAR EAST UNIVER9TY 

	Images
	Image 1
	Image 2


	Page 75
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 76
	Titles
	NEAR EAST UN/f/ER9TY 

	Images
	Image 1
	Image 2


	Page 77
	Titles
	KEAR EAST UKIVERSTY 

	Images
	Image 1
	Image 2


	Page 78
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 79
	Titles
	NEAR EA91 tlNIYER9TY 

	Images
	Image 1
	Image 2


	Page 80
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 81
	Titles
	KEAR EAST UKIVERSTY 

	Images
	Image 1
	Image 2


	Page 82
	Titles
	NEAR EAST UNIVER9TY 

	Images
	Image 1
	Image 2


	Page 83
	Titles
	NEAR EA91 t/NIVER9TY 

	Images
	Image 1
	Image 2


	Page 84
	Titles
	NEAR EAST tlNIVERSTY 

	Images
	Image 1
	Image 2


	Page 85
	Titles
	NEAR EAST tlNIVERSTY 

	Images
	Image 1
	Image 2


	Page 86
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1


	Page 87
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 88
	Titles
	KEAR EAST UKIVERSTY 

	Images
	Image 1
	Image 2


	Page 89
	Titles
	NEAR EAST t/NIVERSTY 

	Images
	Image 1
	Image 2


	Page 90
	Titles
	NEAR EAST llNIVERSTY 

	Images
	Image 1
	Image 2


	Page 91
	Titles
	KEAR EAST UKIVERSTY 

	Images
	Image 1
	Image 2


	Page 92
	Titles
	Harvester of Sorrow 

	Images
	Image 1


	Page 93
	Images
	Image 1
	Image 2
	Image 3


	Page 94
	Titles
	UNTIL IT SLEEP 

	Images
	Image 1
	Image 2


	Page 95
	Images
	Image 1
	Image 2


	Page 96
	Titles
	MAMA SAID 

	Images
	Image 1
	Image 2


	Page 97
	Images
	Image 1
	Image 2


	Page 98
	Titles
	NEAR EAST UNIVERSTY 
	CHAPTER C 
	LEARNING JAVASCRIPT 
	How to take full advantage of JavaScript by moving 
	Summary 
	Introducing functions 
	function name (params) { 
	} 
	name is the unique name of the function. All function names in a script 
	params is one or more parameter variables you pass to the function. 

	Images
	Image 1
	Image 2


	Page 99
	Titles
	NEAR EAST UNIVERSTY 
	Defining and using a function 

	Images
	Image 1
	Image 2


	Page 100
	Titles
	NEAR EAST t/NIVERSTY 
	Calling a function with an event handler 

	Images
	Image 1
	Image 2


	Page 101
	Titles
	NEAR EAST UNIVERSTY 
	<INPUT TYPE="button" VALUE="Click" onClick="basicFunction()"> 
	</BODY> 
	</HTML> 
	Passing a value to a function 
	function basicExample (Text) { 
	Passing multiple values to a function 
	multipleParams ("one", "two"); 
	function multipleParams (Param1, Param2) { 

	Images
	Image 1
	Image 2


	Page 102
	Titles
	NEAR EAST UNIVERSTY 
	Returning a value from a function 

	Images
	Image 1
	Image 2


	Page 103
	Titles
	NEAR EAST tlNIVERSTY 
	Defining local variables within functions 

	Images
	Image 1
	Image 2


	Page 104
	Titles
	NEAR EA91 UNIVER9TY 
	Calling one function from another function 
	} 

	Images
	Image 1
	Image 2


	Page 105
	Titles
	NEAR EAST UNIVERSTY 
	Creating objects with user-defined functions 

	Images
	Image 1
	Image 2


	Page 106
	Titles
	NEAR EAST UNIVERSTY 
	Defining new properties to already-made objects 
	Defining properties when you create the object 
	} 

	Images
	Image 1
	Image 2
	Image 3


	Page 107
	Titles
	NEAR EAST UN/f/ERSTY 
	' ' ' 
	Creating user-defined methods 
	} 

	Images
	Image 1
	Image 2


	Page 108
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 109
	Titles
	NEAR EAST UNIVER9TY 
	function makeCustomer(Name, Address, Phone) { 
	this.address= Address; 
	this.phone= Phone; 
	this.displayCustomer = displayCustomer; 
	run() 
	Conclusion 

	Images
	Image 1
	Image 2


	Page 110
	Titles
	in 
	NEAR EAST UNIVER9TY 
	Take Advantage of User-Defined Variables 
	Learn how to master variables, the special information� 
	Summary 

	Images
	Image 1
	Image 2


	Page 111
	Titles
	NEAR EAST UNIVER9TY 
	Contents placed in JavaScript variables 
	Numbers in variables 
	MyVar = 10; 
	Strings in variables 
	"I am a string;' 
	'I am a string' 
	MyVar = "This is JavaScript"; 

	Images
	Image 1
	Image 2


	Page 112
	Titles
	NEAR EAST UNIVERSTY 
	Boolean values in variables 
	MyVar = true; 
	Objects in variables 
	MyVar = navigator; 
	MyVar = new myObject(); 

	Images
	Image 1
	Image 2


	Page 113
	Titles
	NEAR EAST UNIVER9TY 
	Understanding JavaScript's "loose" variable data types 
	Using the var statement to assign a variable 
	var MyVar = "This is a variable"; 
	var MyVar; 
	String length limitations 

	Images
	Image 1
	Image 2


	Page 114
	Titles
	NEAR EA91 llNIVER9TY 
	Understanding the "scope" of variables 

	Images
	Image 1
	Image 2


	Page 115
	Titles
	NEAR EAST llNIVERSTY 
	Referencing variables in other loaded documents 
	winname.varname 
	mydoc.MyVar = 1; 
	VarlnThisDoc = mydoc.MyVar; 

	Images
	Image 1
	Image 2


	Page 116
	Titles
	NEAR EAST UNIVERSTY 
	newwindow = window.open ("","NewWindow"); //repeat this for Mac/X 
	newwindow.creator = self; 
	creator.MyVar; 
	newwindow = window.open ("","NewWindow"); 
	newwindow.MyVar; 
	pa rent. My Var; 
	parent.frame1 .MyVar; 
	Understanding when variables are lost 

	Images
	Image 1
	Image 2


	Page 117
	Titles
	NEAR EAST t/NIVERSTY 
	Variable shortcuts, tips, and tricks 
	Declaring multiple variables at once 

	Images
	Image 1
	Image 2


	Page 118
	Titles
	NEAR EAST tlNIVERSTY 
	Assigning multiple variables at once 
	var MyVar = YourVar = TheirVar = 1; 
	Deleting a variable from memory 
	varname = null; 
	Converting between number and string variables 
	myVar = ""+= MyVar; 
	MyVar = parselnt(Mylnt); 
	MyVar = parseFloat(Mylnt); 

	Images
	Image 1
	Image 2


	Page 119
	Titles
	NEAR EAST tlNIVERSTY 
	Conclusion 

	Images
	Image 1
	Image 2


	Page 120
	Titles
	NEAR EA91 UNIVER9TY 
	CHAPTER D 
	PROGRAMMING WITH HTML 
	INDEX.HTM 

	Images
	Image 1
	Image 2


	Page 121
	Titles
	NEAR EAST UN/f/ERSTY 
	FINL.HTM 

	Images
	Image 1
	Image 2


	Page 122
	Titles
	NEAR EAST l/NIVERSTY 
	FINR.HTM 

	Images
	Image 1
	Image 2


	Page 123
	Titles
	KEAR EAST UKIVERSTY 
	·ruRKO.HTM 
	FTL.HTM 

	Images
	Image 1
	Image 2


	Page 124
	Titles
	NEAR EA$1 UNIVER9TY 
	FTR.HTM 

	Images
	Image 1
	Image 2


	Page 125
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 126
	Titles
	NEAR EA$1 UNIYER9TY 

	Images
	Image 1
	Image 2


	Page 127
	Images
	Image 1
	Image 2


	Page 128
	Titles
	NEAR EA9T UNIVER9TY 
	TURK1.HTM 
	FTHL1.HTM 

	Images
	Image 1
	Image 2


	Page 129
	Titles
	NEAR EAST UNIVERSTY 
	FTHR1.HTM 

	Images
	Image 1
	Image 2


	Page 130
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 131
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 132
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 133
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 134
	Titles
	NEAR EAST UNIVERSTY 
	TURK2.HTM 
	FTHL2.HTM 

	Images
	Image 1
	Image 2


	Page 135
	Titles
	NEAR EAST UNIVERSTY 
	FTHR2.HTM 

	Images
	Image 1
	Image 2


	Page 136
	Titles
	NEAR EA91 UNIVER9TY 

	Images
	Image 1
	Image 2


	Page 137
	Titles
	NEAR EA91 UNIVER9TY 

	Images
	Image 1
	Image 2


	Page 138
	Titles
	NEAR EA9T UNIVER9TY 

	Images
	Image 1
	Image 2


	Page 139
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 140
	Titles
	NEAR EAST UN/f/ERSTY 

	Images
	Image 1
	Image 2


	Page 141
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 142
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 143
	Titles
	NEAR EA$1 UNIVER9TY 

	Images
	Image 1
	Image 2


	Page 144
	Titles
	NEAR EAST UNIVER$TY 

	Images
	Image 1
	Image 2


	Page 145
	Titles
	NEAR EA91 UNIVER9TY 

	Images
	Image 1
	Image 2


	Page 146
	Titles
	NEAR EAST UNIVERSTY 
	TURK3.HTM 
	FTHl3.HTM 

	Images
	Image 1
	Image 2


	Page 147
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 148
	Titles
	NEAR EAST UNIVERSTY 
	FTHR2.HTM 

	Images
	Image 1
	Image 2


	Page 149
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2
	Image 3


	Page 150
	Titles
	NEAR EAST UNIVERSTY 
	TOU.HTM 
	FTL1.HTM 

	Images
	Image 1
	Image 2


	Page 151
	Titles
	NEAR EA$1 tlNIVER9TY 

	Images
	Image 1
	Image 2
	Image 3


	Page 152
	Titles
	NEAR EAST t/NIVERSTY 
	FTR1.HTM 

	Images
	Image 1
	Image 2


	Page 153
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 154
	Titles
	NEAR EAST UNIVER9TY 
	ANT.HTM 
	FTIL1.HTM 

	Images
	Image 1
	Image 2


	Page 155
	Titles
	NEAR EAST tlNIVER9TY 
	FTIR1.HTM 

	Images
	Image 1
	Image 2


	Page 1
	Titles
	NEAREAST UNIVERSITY 
	METiN TA~KIN 
	MISS. BESiME ERiN 

	Images
	Image 1
	Image 2
	Image 3


	Page 2
	Titles
	NEAR EAST UNIVER9TY 
	CONTENTS 
	CHAPTER A 

	Images
	Image 1


	Page 3
	Titles
	NEAR EAST UNIVERSTY 
	CONTENTS 

	Images
	Image 1


	Page 4
	Titles
	NEAR EAST tlNIVERSTY 
	CONTENTS 
	CHAPTER B 

	Images
	Image 1


	Page 5
	Titles
	NEAR EAST llNIVERSTY 
	CONTENTS 
	CHAPTER C 

	Images
	Image 1


	Page 6
	Images
	Image 1


	Page 7
	Titles
	NEAR EAST UNIVERSTY 
	CONCLUSION 

	Images
	Image 1


	Page 8
	Titles
	NEAR EAST UNIVERSTY 
	CHAPTER A 
	INTERNET 
	Historical Background 

	Images
	Image 1
	Image 2
	Image 3
	Image 4
	Image 5
	Image 6


	Page 9
	Titles
	NEAR EAST UNIVERSTY 
	Fig.1. An Internet System 

	Images
	Image 1


	Page 10
	Titles
	NEAR EA$1 tlNIVER9TY 
	Technical Definitions: 

	Images
	Image 1


	Page 11
	Titles
	NEAR EAST UNIVERSTY 
	For example: 158.143.103.60 
	For example: VAX.RES.AC.UK 
	Various Protocols 

	Images
	Image 1


	Page 12
	Titles
	NEAR EAST UNIVER9TY 
	CUSEEME 
	Network News 
	Telnet 
	FTP 

	Images
	Image 1


	Page 13
	Titles
	NEAR EAST UNIVERSTY 
	Gopher 
	The World Wide Web 
	UNIFORM RESOURCE LOCATORS (URLs) 

	Images
	Image 1


	Page 14
	Titles
	NEAR EAST UNIYER9TY 
	Searching the Internet 
	ARCHIE 

	Images
	Image 1


	Page 15
	Titles
	NEAR EAST tlNIVERSTY 

	Images
	Image 1


	Page 16
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 17
	Titles
	NEAR EAST UNIVERSTY 
	What Software to Use For Writing HTML Programs 
	File Extension 
	TAG REFERENCE 
	Document Formatting 
	Tag Description 

	Images
	Image 1
	Image 2

	Tables
	Table 1


	Page 18
	Titles
	Paragraph Formatting 
	NEAR EAST tlNIVERSTY 
	Tag 
	Description 
	Character Formatting 
	Tag Description 

	Images
	Image 1

	Tables
	Table 1
	Table 2


	Page 19
	Titles
	NEAR EA91 tlNIVER9TY 
	List Formattipg 
	Tag 
	Description 
	Anchor Formatting 
	Tag Attribute Description 

	Images
	Image 1
	Image 2

	Tables
	Table 1
	Table 2


	Page 20
	Titles
	Image Formatting 
	NEAR EAST UNIYERSTY 
	Tag 
	Attribute 
	Descri~tion and Notes 

	Images
	Image 1


	Page 21
	Titles
	NEAR EAST UNIVERSTY 
	Table Formatting 
	Tag Attribute Descri_etior, and Notes 

	Images
	Image 1


	Page 22
	Titles
	NEAR EAST UNIVERSTY 
	VIDEO STANDARTS 

	Images
	Image 1


	Page 23
	Titles
	NEAR EAST UN/f/ERSTY 
	TCP/IP & INTERNET STRUCTURE 
	Introduction: 
	Network 
	G-Gateways 
	Network 
	Network 

	Images
	Image 1
	Image 2
	Image 3


	Page 24
	Titles
	NEAR EAST UNIVERSTY 
	The transmission Control Protocol(TCP) 
	Message 
	Packet 
	Packet 

	Images
	Image 1
	Image 2
	Image 3
	Image 4


	Page 25
	Titles
	NEAR EAST UNIVERSTY 
	TCP Service Interfaces 
	The most important TCP services are: 

	Images
	Image 1

	Tables
	Table 1


	Page 26
	Titles
	NEAR EAST UNIVERSTY 
	Connection Establishment 

	Images
	Image 1


	Page 27
	Titles
	NEAR EAST UNIVERSTY 
	Data Transfer 
	Sequence Numbering 
	WINDOWS MECHANISM 

	Images
	Image 1


	Page 28
	Titles
	NEAR EAST UNIVERSTY 
	Transmission Watchdog 
	TCP Internet Protocol(IP) 

	Images
	Image 1
	Image 2
	Image 3


	Page 29
	Titles
	NEAR EAST UNIVERSTY 
	Datagram Delivery Over A Single Network 
	Internet Address 
	Universal Identifiers: 
	Three Primary Classes of IP Addresses 

	Images
	Image 1
	Image 2


	Page 30
	Titles
	NEAR EAST tlNIVERSTY 

	Images
	Image 1
	Image 2

	Tables
	Table 1


	Page 31
	Titles
	NEAR EAST UNIVERSTY 
	Difference Between Frames & Tables 
	Disadvantage of Frames 

	Images
	Image 1
	Image 2


	Page 32
	Titles
	NEAR EAST IINIVERSTY 
	CHAPTER B 
	USING WORD PAGE 
	WORKING WITH ONLINE AND INTERNET DOCUMENTS 

	Images
	Image 1
	Image 2
	Image 3


	Page 33
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 34
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 35
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 36
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 37
	Titles
	NEAR EA91 UNIYER9TY 

	Images
	Image 1
	Image 2


	Page 38
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 39
	Titles
	NEAR EA9T tlNIVER9TY 

	Images
	Image 1
	Image 2


	Page 40
	Titles
	NEAR EAST l/NIVERSTY 

	Images
	Image 1
	Image 2


	Page 41
	Titles
	NEAR EAST UNIVERSTY 
	CREATING AND WORKING WITH WEB PAGES 

	Images
	Image 1
	Image 2


	Page 42
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 43
	Titles
	NEAR EAST UNIVER9TY 

	Images
	Image 1
	Image 2


	Page 44
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 45
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 46
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 47
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 48
	Titles
	NEAR EAST tlNIVERSTY 

	Images
	Image 1
	Image 2


	Page 49
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 50
	Titles
	NEAR EA$1 UNIVER9TY 

	Images
	Image 1
	Image 2


	Page 51
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 52
	Titles
	NEAR EAST llNIVERSTY 

	Images
	Image 1
	Image 2


	Page 53
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 54
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 55
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 56
	Titles
	NEAR EAST UNIVER9TY 

	Images
	Image 1
	Image 2


	Page 57
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 58
	Titles
	NEAR EAST UNIVERSTY 
	USING VISUAL PAGE 
	USING BASIC FEATURES 

	Images
	Image 1
	Image 2


	Page 59
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 60
	Titles
	NEAR EAST UNIYERSTY 

	Images
	Image 1
	Image 2
	Image 3


	Page 61
	Titles
	NEAR EAST llNIVER9TY 
	* 
	* 

	Images
	Image 1
	Image 2


	Page 62
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 63
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 64
	Titles
	NEAR EAST UNIYERSTY 

	Images
	Image 1
	Image 2


	Page 65
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 66
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 67
	Titles
	NEAR EAST UNIVER9TY 

	Images
	Image 1
	Image 2


	Page 68
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 69
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2
	Image 3


	Page 70
	Titles
	NEAR EAST UNIVERSTY 
	webmaster@symantec.itools.com 

	Images
	Image 1
	Image 2


	Page 71
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 72
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 73
	Titles
	NEAR EAST UN/f/ERSTY 

	Images
	Image 1
	Image 2


	Page 74
	Titles
	NEAR EAST UNIVER9TY 

	Images
	Image 1
	Image 2


	Page 75
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 76
	Titles
	NEAR EAST UN/f/ER9TY 

	Images
	Image 1
	Image 2


	Page 77
	Titles
	KEAR EAST UKIVERSTY 

	Images
	Image 1
	Image 2


	Page 78
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 79
	Titles
	NEAR EA91 tlNIYER9TY 

	Images
	Image 1
	Image 2


	Page 80
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 81
	Titles
	KEAR EAST UKIVERSTY 

	Images
	Image 1
	Image 2


	Page 82
	Titles
	NEAR EAST UNIVER9TY 

	Images
	Image 1
	Image 2


	Page 83
	Titles
	NEAR EA91 t/NIVER9TY 

	Images
	Image 1
	Image 2


	Page 84
	Titles
	NEAR EAST tlNIVERSTY 

	Images
	Image 1
	Image 2


	Page 85
	Titles
	NEAR EAST tlNIVERSTY 

	Images
	Image 1
	Image 2


	Page 86
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1


	Page 87
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 88
	Titles
	KEAR EAST UKIVERSTY 

	Images
	Image 1
	Image 2


	Page 89
	Titles
	NEAR EAST t/NIVERSTY 

	Images
	Image 1
	Image 2


	Page 90
	Titles
	NEAR EAST llNIVERSTY 

	Images
	Image 1
	Image 2


	Page 91
	Titles
	KEAR EAST UKIVERSTY 

	Images
	Image 1
	Image 2


	Page 92
	Titles
	Harvester of Sorrow 

	Images
	Image 1


	Page 93
	Images
	Image 1
	Image 2
	Image 3


	Page 94
	Titles
	UNTIL IT SLEEP 

	Images
	Image 1
	Image 2


	Page 95
	Images
	Image 1
	Image 2


	Page 96
	Titles
	MAMA SAID 

	Images
	Image 1
	Image 2


	Page 97
	Images
	Image 1
	Image 2


	Page 98
	Titles
	NEAR EAST UNIVERSTY 
	CHAPTER C 
	LEARNING JAVASCRIPT 
	How to take full advantage of JavaScript by moving 
	Summary 
	Introducing functions 
	function name (params) { 
	} 
	name is the unique name of the function. All function names in a script 
	params is one or more parameter variables you pass to the function. 

	Images
	Image 1
	Image 2


	Page 99
	Titles
	NEAR EAST UNIVERSTY 
	Defining and using a function 

	Images
	Image 1
	Image 2


	Page 100
	Titles
	NEAR EAST t/NIVERSTY 
	Calling a function with an event handler 

	Images
	Image 1
	Image 2


	Page 101
	Titles
	NEAR EAST UNIVERSTY 
	<INPUT TYPE="button" VALUE="Click" onClick="basicFunction()"> 
	</BODY> 
	</HTML> 
	Passing a value to a function 
	function basicExample (Text) { 
	Passing multiple values to a function 
	multipleParams ("one", "two"); 
	function multipleParams (Param1, Param2) { 

	Images
	Image 1
	Image 2


	Page 102
	Titles
	NEAR EAST UNIVERSTY 
	Returning a value from a function 

	Images
	Image 1
	Image 2


	Page 103
	Titles
	NEAR EAST tlNIVERSTY 
	Defining local variables within functions 

	Images
	Image 1
	Image 2


	Page 104
	Titles
	NEAR EA91 UNIVER9TY 
	Calling one function from another function 
	} 

	Images
	Image 1
	Image 2


	Page 105
	Titles
	NEAR EAST UNIVERSTY 
	Creating objects with user-defined functions 

	Images
	Image 1
	Image 2


	Page 106
	Titles
	NEAR EAST UNIVERSTY 
	Defining new properties to already-made objects 
	Defining properties when you create the object 
	} 

	Images
	Image 1
	Image 2
	Image 3


	Page 107
	Titles
	NEAR EAST UN/f/ERSTY 
	' ' ' 
	Creating user-defined methods 
	} 

	Images
	Image 1
	Image 2


	Page 108
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 109
	Titles
	NEAR EAST UNIVER9TY 
	function makeCustomer(Name, Address, Phone) { 
	this.address= Address; 
	this.phone= Phone; 
	this.displayCustomer = displayCustomer; 
	run() 
	Conclusion 

	Images
	Image 1
	Image 2


	Page 110
	Titles
	in 
	NEAR EAST UNIVER9TY 
	Take Advantage of User-Defined Variables 
	Learn how to master variables, the special information� 
	Summary 

	Images
	Image 1
	Image 2


	Page 111
	Titles
	NEAR EAST UNIVER9TY 
	Contents placed in JavaScript variables 
	Numbers in variables 
	MyVar = 10; 
	Strings in variables 
	"I am a string;' 
	'I am a string' 
	MyVar = "This is JavaScript"; 

	Images
	Image 1
	Image 2


	Page 112
	Titles
	NEAR EAST UNIVERSTY 
	Boolean values in variables 
	MyVar = true; 
	Objects in variables 
	MyVar = navigator; 
	MyVar = new myObject(); 

	Images
	Image 1
	Image 2


	Page 113
	Titles
	NEAR EAST UNIVER9TY 
	Understanding JavaScript's "loose" variable data types 
	Using the var statement to assign a variable 
	var MyVar = "This is a variable"; 
	var MyVar; 
	String length limitations 

	Images
	Image 1
	Image 2


	Page 114
	Titles
	NEAR EA91 llNIVER9TY 
	Understanding the "scope" of variables 

	Images
	Image 1
	Image 2


	Page 115
	Titles
	NEAR EAST llNIVERSTY 
	Referencing variables in other loaded documents 
	winname.varname 
	mydoc.MyVar = 1; 
	VarlnThisDoc = mydoc.MyVar; 

	Images
	Image 1
	Image 2


	Page 116
	Titles
	NEAR EAST UNIVERSTY 
	newwindow = window.open ("","NewWindow"); //repeat this for Mac/X 
	newwindow.creator = self; 
	creator.MyVar; 
	newwindow = window.open ("","NewWindow"); 
	newwindow.MyVar; 
	pa rent. My Var; 
	parent.frame1 .MyVar; 
	Understanding when variables are lost 

	Images
	Image 1
	Image 2


	Page 117
	Titles
	NEAR EAST t/NIVERSTY 
	Variable shortcuts, tips, and tricks 
	Declaring multiple variables at once 

	Images
	Image 1
	Image 2


	Page 118
	Titles
	NEAR EAST tlNIVERSTY 
	Assigning multiple variables at once 
	var MyVar = YourVar = TheirVar = 1; 
	Deleting a variable from memory 
	varname = null; 
	Converting between number and string variables 
	myVar = ""+= MyVar; 
	MyVar = parselnt(Mylnt); 
	MyVar = parseFloat(Mylnt); 

	Images
	Image 1
	Image 2


	Page 119
	Titles
	NEAR EAST tlNIVERSTY 
	Conclusion 

	Images
	Image 1
	Image 2


	Page 120
	Titles
	NEAR EA91 UNIVER9TY 
	CHAPTER D 
	PROGRAMMING WITH HTML 
	INDEX.HTM 

	Images
	Image 1
	Image 2


	Page 121
	Titles
	NEAR EAST UN/f/ERSTY 
	FINL.HTM 

	Images
	Image 1
	Image 2


	Page 122
	Titles
	NEAR EAST l/NIVERSTY 
	FINR.HTM 

	Images
	Image 1
	Image 2


	Page 123
	Titles
	KEAR EAST UKIVERSTY 
	·ruRKO.HTM 
	FTL.HTM 

	Images
	Image 1
	Image 2


	Page 124
	Titles
	NEAR EA$1 UNIVER9TY 
	FTR.HTM 

	Images
	Image 1
	Image 2


	Page 125
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 126
	Titles
	NEAR EA$1 UNIYER9TY 

	Images
	Image 1
	Image 2


	Page 127
	Images
	Image 1
	Image 2


	Page 128
	Titles
	NEAR EA9T UNIVER9TY 
	TURK1.HTM 
	FTHL1.HTM 

	Images
	Image 1
	Image 2


	Page 129
	Titles
	NEAR EAST UNIVERSTY 
	FTHR1.HTM 

	Images
	Image 1
	Image 2


	Page 130
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 131
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 132
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 133
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 134
	Titles
	NEAR EAST UNIVERSTY 
	TURK2.HTM 
	FTHL2.HTM 

	Images
	Image 1
	Image 2


	Page 135
	Titles
	NEAR EAST UNIVERSTY 
	FTHR2.HTM 

	Images
	Image 1
	Image 2


	Page 136
	Titles
	NEAR EA91 UNIVER9TY 

	Images
	Image 1
	Image 2


	Page 137
	Titles
	NEAR EA91 UNIVER9TY 

	Images
	Image 1
	Image 2


	Page 138
	Titles
	NEAR EA9T UNIVER9TY 

	Images
	Image 1
	Image 2


	Page 139
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 140
	Titles
	NEAR EAST UN/f/ERSTY 

	Images
	Image 1
	Image 2


	Page 141
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 142
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 143
	Titles
	NEAR EA$1 UNIVER9TY 

	Images
	Image 1
	Image 2


	Page 144
	Titles
	NEAR EAST UNIVER$TY 

	Images
	Image 1
	Image 2


	Page 145
	Titles
	NEAR EA91 UNIVER9TY 

	Images
	Image 1
	Image 2


	Page 146
	Titles
	NEAR EAST UNIVERSTY 
	TURK3.HTM 
	FTHl3.HTM 

	Images
	Image 1
	Image 2


	Page 147
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 148
	Titles
	NEAR EAST UNIVERSTY 
	FTHR2.HTM 

	Images
	Image 1
	Image 2


	Page 149
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2
	Image 3


	Page 150
	Titles
	NEAR EAST UNIVERSTY 
	TOU.HTM 
	FTL1.HTM 

	Images
	Image 1
	Image 2


	Page 151
	Titles
	NEAR EA$1 tlNIVER9TY 

	Images
	Image 1
	Image 2
	Image 3


	Page 152
	Titles
	NEAR EAST t/NIVERSTY 
	FTR1.HTM 

	Images
	Image 1
	Image 2


	Page 153
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 154
	Titles
	NEAR EAST UNIVER9TY 
	ANT.HTM 
	FTIL1.HTM 

	Images
	Image 1
	Image 2


	Page 155
	Titles
	NEAR EAST tlNIVER9TY 
	FTIR1.HTM 

	Images
	Image 1
	Image 2


	Page 156
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2
	Image 3


	Page 157
	Titles
	NEAR EAST UNIYERSTY 

	Images
	Image 1
	Image 2


	Page 158
	Titles
	NEAR EAST UNIVERSTY 
	1988 
	FTIL2.HTM 
	- 145 - 

	Images
	Image 1
	Image 2
	Image 3


	Page 159
	Titles
	KEAR EAST UKIVERSTY 
	FTIR2.HTM 

	Images
	Image 1
	Image 2


	Page 160
	Titles
	NEAR EA91 UNIVER9TY 

	Images
	Image 1
	Image 2


	Page 161
	Titles
	NEAR EAST tlNIVERSTY 
	GIR.HTM 
	FTIL3.HTM 

	Images
	Image 1
	Image 2


	Page 162
	Titles
	KEAR EAST UKIVERSTY 
	FTIR3.HTM 

	Images
	Image 1
	Image 2


	Page 163
	Titles
	NEAR EA91 tlNIVER9TY 

	Images
	Image 1
	Image 2


	Page 164
	Titles
	NEAR EAST UN/f/ERSTY 

	Images
	Image 1
	Image 2


	Page 165
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 166
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 167
	Titles
	NEAR EAST UNIVERSTY 
	TRAB.HTM 

	Images
	Image 1
	Image 2


	Page 168
	Titles
	NEAR EAST UNIVER9TY 
	FTIL4.HTM 

	Images
	Image 1
	Image 2


	Page 169
	Titles
	NEAR EAST UNIYERSTY 
	FTIR4.HTM 

	Images
	Image 1
	Image 2


	Page 170
	Titles
	NEAR EA91 UNIVER9TY 

	Images
	Image 1
	Image 2


	Page 171
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 172
	Titles
	KEAR EAST UKIVER9TY 

	Images
	Image 1
	Image 2


	Page 173
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 174
	Titles
	NEAR EAST UN/f/ERSTY 
	ANTALYA.HTM 
	FOL1.HTM 

	Images
	Image 1
	Image 2


	Page 175
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 176
	Titles
	NEAR EAST UNIVERSTY 
	FOR1.HTM 

	Images
	Image 1
	Image 2


	Page 177
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 178
	Titles
	NEAR EA91 UNIVER9TY 

	Images
	Image 1
	Image 2


	Page 179
	Titles
	NEAR EA$1 UNIVER$TY 

	Images
	Image 1
	Image 2


	Page 180
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 181
	Titles
	NEAR EAST UN/f/ERSTY 

	Images
	Image 1
	Image 2
	Image 3


	Page 182
	Titles
	NEAR EA91 UNIVER9TY 

	Images
	Image 1
	Image 2


	Page 183
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 184
	Titles
	NEAR EAST UNIVERSTY 
	IZMIR.HTM 
	FOL2.HTM 

	Images
	Image 1
	Image 2


	Page 185
	Titles
	NEAR EAST UNIYERSTY 

	Images
	Image 1
	Image 2
	Image 3


	Page 186
	Titles
	NEAR EAST UNIVERSTY 
	FOR2.HTM 

	Images
	Image 1
	Image 2


	Page 187
	Titles
	KEAR EAST flKIVERSTY 

	Images
	Image 1
	Image 2


	Page 188
	Titles
	NEAR EA91 tlNIVER9TY 

	Images
	Image 1
	Image 2


	Page 189
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1
	Image 2


	Page 190
	Titles
	KEAR EAST UKIVER9TY 

	Images
	Image 1
	Image 2


	Page 191
	Titles
	NEAR EAST UNIVERSTY 
	GIRESUN.HTM 
	FOL3.HTM 

	Images
	Image 1
	Image 2
	Image 3


	Page 192
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1


	Page 193
	Titles
	NEAR EAST UNIVERSTY 
	FOR3.HTM 

	Images
	Image 1


	Page 194
	Titles
	KEAR EAST llKIVERSTY 

	Images
	Image 1


	Page 195
	Titles
	NEAR EAST UNIVERSTY 
	TRABZON.HTM 
	FOL4.HTM 

	Images
	Image 1
	Image 2
	Image 3


	Page 196
	Titles
	NEAR EAST llNIVERSTY 

	Images
	Image 1
	Image 2
	Image 3


	Page 197
	Titles
	NEAR EAST UNIVERSTY 
	FOR4.HTM 

	Images
	Image 1
	Image 2


	Page 198
	Titles
	NEAR EAST UNIVERSTY 

	Images
	Image 1



